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Preface
The Java Desktop System Release 3 User Guide provides information for the following
releases:
■

Sun™ Java™ Desktop System Release 3 for the Solaris™ 10 Operating System on
SPARC® platforms.

■

Java Desktop System Release 3 for the Solaris 10 Operating System on x86
platforms.

Most of the information in the manual is generic to all releases of the Java Desktop
System. Where the information is not generic, the platform is indicated.

Who Should Use This Book
This book is for users who plan to use the Java Desktop System as the default desktop
environment. Use this book if you need to do the following:
■
■
■

Work with applications in the desktop.
Customize the look and feel of your personal desktop.
Find out more about specific functionality.

How This Book Is Organized
This book is organized as follows:
■

Chapter 1
This chapter provides information about how to start, manage, and end Java
Desktop System sessions.
11

■

Chapter 2
Panels are a key component of the Java Desktop System. This chapter tells you
how to use the different parts of your panels, and how to invoke the available
functions of the Java Desktop System using panels.

■

Chapter 3
This chapter provides information about how to use and customize the menus in
the Java Desktop System.

■

Chapter 4
This chapter describes basic windows functions such as moving and resizing. This
chapter also describes the controls that you use with windows.

■

Chapter 5
This chapter describes how to use the file manager to work with your file system.

■

Chapter 6
This chapter describes how to use the desktop background to start applications, and
open your files and folders. The chapter also describes how to use Trash from the
desktop background, how to use the desktop background menu, and how to
customize the desktop background.

■

Chapter 7
This chapter describes how to use the preference tools to customize the Java
Desktop System.

■

Appendix A
This appendix provides information about mouse usage, shortcut keys, basic
window skills, and basic dialog skills.

■

Glossary
The glossary contains a list of terms used in this guide, and definitions of the
terms.

Before You Read This Book
Before you read this book, click on the Learn About The Java™ Desktop System icon
on the desktop background. This launches a help browser from where you can access
overview information about the Java Desktop System.
You should also ensure that you have some familiarity with the following topics:
■
■
■

Three-button mouse devices
Graphical user interfaces
Command line interfaces

See Appendix A for information about mouse usage, shortcut keys, basic window
skills, and basic dialog skills.
12

Java Desktop System Release 3 User Guide • January, 2005

Related Documentation
The following manuals are related to this guide:
■
■
■
■
■

Java Desktop System Release 3 Accessibility Guide
Java Desktop System Release 3 Administration Guide
Java Desktop System Release 3 Installation Guide
Java Desktop System Release 3 Release Notes
Java Desktop System Release 3 Troubleshooting Guide

You can access these manuals on the accompanying software media, and at
http://docs.sun.com.

Associated Documentation
The following manuals are associated with this guide:
■
■
■
■
■
■

Java Desktop System Email and Calendar User Guide
StarOffice 7 Office Suite Administration Guide
StarOffice 7 Office Suite Basic Guide
StarOffice 7 Office Suite Setup Guide
StarOffice 7 Office Suite User’s Guide
System Configuration Manager, Release 1

You can access these manuals on the accompanying software media, or at
http://docs.sun.com.

Accessing Sun Documentation Online
The docs.sun.comSM Web site enables you to access Sun technical documentation
online. You can browse the docs.sun.com archive or search for a specific book title or
subject. The URL is http://docs.sun.com.

13

Ordering Sun Documentation
Sun Microsystems offers select product documentation in print. For a list of
documents and how to order them, see “Buy printed documentation” at
http://docs.sun.com.

Typographic Conventions
The following table describes the typographic changes used in this book.
TABLE P–1 Typographic Conventions
Typeface or Symbol

Meaning

Example

AaBbCc123

The names of commands, files, and
directories; on-screen computer output

Edit your .login file.
Use ls -a to list all files.
machine_name% you have
mail.

What you type, contrasted with
on-screen computer output

machine_name% su

AaBbCc123

Command-line placeholder: replace with
a real name or value

To delete a file, type rm
filename.

AaBbCc123

Book titles, new words, or terms, or
words to be emphasized.

Read Chapter 6 in User’s Guide.

AaBbCc123

Password:

These are called class options.
You must be root to do this.

Shell Prompts in Command Examples
The following table shows the default system prompt and superuser prompt for the C
shell, Bourne shell, and Korn shell.

14
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TABLE P–2 Shell Prompts
Shell

Prompt

C shell prompt

machine_name%

C shell superuser prompt

machine_name#

Bourne shell and Korn shell prompt

$

Bourne shell and Korn shell superuser prompt #

Mouse Usage Conventions
The following table lists the conventions for mouse usage in documentation for the
Java Desktop System.

Action

Definition

Click

Press and release the left mouse button, without moving
the mouse.

Click-and-hold

Press and do not release the left mouse button.

Left-click

Same as click. Left-click clarifies the action when there
might be confusion with right-click.

Middle-click

Press and release the middle mouse button, without
moving the mouse.

Right-click

Press and release the right mouse button, without moving
the mouse.

Double-click

Press and release the left mouse button twice in rapid
succession without moving the mouse.

Drag

Click-and-hold a mouse button, then move an object. For
example, you can drag a window or an icon. The left and
middle mouse buttons can perform drag actions.

Drag-and-drop

Click-and-hold a mouse button, then move an object. For
example, you can drag-and-drop a window or an icon.
Release the mouse button to place the object in a new
location.

Grab

Point to an item that you can move, and click-and-hold on
the mouse button. For example, you can grab the titlebar of
a window, then drag the window to a new location.

15
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CHAPTER

1

Getting Started
This chapter provides the information you need to start, manage, and end a Java
Desktop System session.

Logging In to Your Desktop
A session occurs between the time that you log in to the Java Desktop System and the
time that you log out. The login screen is your gateway to the Java Desktop System.
The login screen provides fields for you to enter your username and password. The
login screen enables you to select login options, for example you can select the
language of your session.
You start a session when you log in. The session manager starts after your username
and password are authenticated. The session manager enables you to manage the
session. For example, you can save the state of your most recent session and return to
that session the next time that you log in. The session manager saves and restores the
following:
■

The appearance and behavior settings, for example fonts, colors, and mouse
settings.

■

The applications that you were running, for example file manager and text editor
windows. You cannot save and restore applications that the session manager does
not manage. For example, if you start the vi editor from the command line in a
terminal window, session manager cannot restore your editing session.

To Log In to the Desktop on Linux
To log in to the desktop, perform the following steps:
17

1. On the login screen, click on the Session icon. Choose the Java Desktop System
from the list of available desktop environments.
2. Enter your username in the Username field on the login screen, then press Return.
3. Enter your password in the Password field on the login screen, then press Return.
When you log in successfully, the session manager starts a session. If this is the first
time you log in, then the session manager starts a new session. If you have logged in
before, then the session manager restores your previous session, if you saved the
settings for the previous session when you logged out.
If you want to shut down or restart the system before you log in, click on the Actions
icon on the login screen. A dialog is displayed. Select the option that you require, then
click OK.

To Log In to a Different Language on Linux
To log in to the desktop in a different language, perform the following actions:
1. On the login screen, click on the Language icon. Choose the language you require
from the list of available languages.
2. Enter your username in the Username field on the login screen, then press Return.
3. Enter your password in the Password field on the login screen, then press Return.
Note – When you log in to a session in a different language, you choose the language
for the user interface. You do not specify a keyboard layout for the session. To specify
a keyboard layout, use the Keyboard Layout Switcher panel application.

Panel applications are small, interactive applications that reside within a panel, for
example CD Player. Each panel application has a simple user interface that you can
operate with the mouse or keyboard.

To Log In to the Desktop on the Solaris Operating
System
To log in to the desktop, perform the following steps:
1. Choose Options → Session. Choose the Java Desktop System from the list of
available desktop environments.
2. Enter your login name in the field on the Login Manager dialog, then click OK.
3. Enter your password in the field on the Login Manager dialog, then click OK.
18
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When you log in successfully, the session manager starts a session. If this is the first
time you log in, then the session manager starts a new session. If you have logged in
before, then the session manager restores your previous session.

To Log In to a Different Language on the Solaris
Operating System
To log in to the desktop in a different language, perform the following actions:
1. On the login dialog, choose Options → Session. Choose the Java Desktop System
from the list of available desktop environments.
2. On the login dialog, choose Options → Language.
3. Choose the language group that includes the language that you want.
4. Choose a language.
5. Log in.
Your system administrator sets the default language for your system. The Options
menu on the Login Manager dialog enables you to access other languages. When you
choose a language in the Options menu, your system sets the LANG variable for your
session. The system restores the default language at the end of the session.

When You Log In for the First Time
When you start a session for the first time, you should see a startup screen, with a
panel at the bottom of the screen and various icons on the desktop background.

Initial Desktop Configuration
This section describes what you see when you start a session for the first time. Your
system administrator might have set your default bottom edge panel according to
your local requirements, so you might see a slightly different bottom edge panel.

Chapter 1 • Getting Started
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The Java Desktop System startup screen typically consists of the following:
■

This Computer
Enables you to access media and configuration details about your system.

■

Documents
Enables direct access to files stored in your default directory.

■

Network Places
Provides access to networked computers from a single directory.

■

Trash
Provides a temporary holding area for files, folders or desktop objects that you can
later retrieve or permanently delete.

■

StarOffice 7
Launches the StarOffice application.

■

Learn About The Java™ Desktop System
Launches a help browser from where you can access overview information about
the Java Desktop System.

■

20

Bottom edge panel
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The following panel objects appear in your bottom edge panel by default:

■

■

Launch button: Provides menus for applications and configuration tools on the
Java Desktop System.

■

Clock: Displays the time and date in a panel.

■

Show Desktop: Displays a button that you can click to minimize all open
windows.

■

Window List: Displays a button for each window that is open. You can click on
a window list button to minimize and restore windows.

■

Notification Area: Displays icons from various applications to indicate activity
in the application. For example, when you use the CD Player application to
play a CD, a CD icon is displayed in the Notification Area.

■

Workspace Switcher: Displays a visual representation of your workspaces. You
can use Workspace Switcher to switch between workspaces.

■

Volume Control: Displays a button that enables you to control and set the
sound level for your system.

■

Network Monitor: Displays a dialog that enables you to monitor the activities of
your network.

Desktop Background
The desktop background lies behind all of the other components on the Java
Desktop System. The desktop background is an active component of the user
interface. You can place objects on the desktop background to quickly access your
files and directories, or to start applications that you use often. You can also
right-click on the desktop background to open a menu.

To Lock Your Screen
To lock the screen, perform one of the following actions:
■

Click Launch, then choose Lock Screen.

■

If the Lock button is present on a panel, click on the Lock button.
To add the Lock button to a panel, right-click on the panel. Choose Add to Panel →
Actions → Lock.

When you lock your screen, the screensaver starts. To unlock the screen, move your
mouse to display the locked screen dialog. Enter your username and password in the
locked screen dialog, then press Return.
Note – To lock your screen correctly, you must have a screensaver enabled.

Chapter 1 • Getting Started
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Managing Your Desktop Session
To configure your desktop session, use the Sessions preference tool. The Sessions
preference tool recognizes the following types of application:
■

Applications that are session-managed. When you save the settings for your
session, the session manager saves all of the session-managed applications. If you
log out, then log in again, the session manager automatically starts the
session-managed applications.

■

Applications that are not session-managed. When you save the settings for your
session, the session manager does not save any applications that are not
session-managed. If you log out, then log in again, the session manager does not
start non-session-managed applications. You must start the application manually.
Alternatively, you can use the Sessions preference tool to specify
non-session-managed applications that you want to automatically start.

To Define Log In and Log Out Behavior
To set how a session behaves when you log in and log out, use Sessions preference
tool. Make the changes you require in the Session Options tabbed section. For
example, you can select to display a splash screen when you log in.

To Use Startup Applications
You can configure your sessions to start with applications that are not
session-managed. To configure non-session-managed startup applications, use the
Sessions preference tool. Use the Startup Programs tabbed section to add, edit, and
delete applications. If you save your settings and log out, the next time that you log in,
the startup applications start automatically.

To Browse Applications
To browse the applications in the current session, use the Sessions preference tool. The
Current Session tabbed section lists the following:

22

■

All Java Desktop System applications that are currently running, that can connect
to the session manager, and that can save the state of the application.

■

All preference tools that can connect to the session manager, and that can save the
state of the tool.
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You can use the Current Session tabbed section to perform a limited number of
actions on the session properties of an application or preference tool. For example, you
can edit the startup order, and restart style of any Java Desktop System application or
preference tool that is in the list.

To Save Your Settings
To save your session settings, perform the following steps:
1. Configure your session to automatically save settings when you end the session. To
configure your session, use the Sessions preference tool. The Sessions preference
tool starts. Select the Automatically save changes to session option on the Session
Options tabbed section.
2. End your session.
If you do not select the Automatically save changes to session option, when you log
out, a dialog asks if you want to save your current settings. To save your settings,
select the option, then continue to log out.

Logging Out
To end your session, close all your currently active processes, then perform one of the
following actions:
■

Click Launch, then choose Log Out name.

■

If the Log Out button is present on a panel, click on the Log Out button.
To add the Log Out button to a panel, right-click on the panel. Choose Add to
Panel → Actions → Log Out.

Before you end a session, you might want to save your current settings so that you can
restore the session later. During the logout process, a dialog asks if you want to save
your current settings. In the Sessions preference tool, you can select an option to
automatically save your current settings.

Chapter 1 • Getting Started
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CHAPTER

2

Working With Panels
The information in this chapter describes how to use panels. A panel is an area in the
Java Desktop System from which you can run applications and perform other tasks.

Introducing Panels
When you start a session for the first time, the Java Desktop System contains at least
one panel. Your system administrator might have set your default panels according to
your local requirements, so you might see slightly different default panels.
You can change the behavior and appearance of your panels to suit your requirements.
You can also add or remove objects from your panels. You can create multiple panels,
and choose different properties, objects, and backgrounds for each panel. You can also
hide panels.
Typically, the Java Desktop System contains a preconfigured panel displayed at the
bottom edge of the screen.

Bottom Edge Panel
The bottom edge panel contains the following items:

Object

Description

Launch

The Launch button contains menus and menu items for
applications and configuration tools on the Java Desktop System.

25

Object

Description

Clock

Displays the time and date in a panel.

Show Desktop

Displays a button that you can click to minimize all open
windows.

Window List

Displays a button for each window that is open. You can click on
a window list button to minimize and restore windows.

Notification Area

Displays icons from various applications to indicate activity in
the application.

Workspace Switcher

Displays a visual representation of your workspaces. You can use
Workspace Switcher to switch between workspaces.

Volume Control

Displays a button that enables you to control and set the sound
level for your system.

Network Monitor

Displays the status of a network device.

Managing Your Panels
The following sections describe how to manage your panels.

To Add a New Panel
To add a panel, right-click on a vacant space on any panel, then choose New Panel.
The new panel is added to the Java Desktop System. The new panel contains no
objects. You can customize the new panel to suit your preferences.

To Interact With a Panel
To interact with a panel, you must left-click, middle-click, or right-click on a vacant
space on the panel. You can also middle-click or right-click on one of the hide buttons
to select the panel, if the panel has no vacant space. If the hide buttons are not visible
on a panel, modify the properties of the panel so that the hide buttons are visible.
You use the mouse buttons to interact with a panel in the following ways:

26

Middle-click

Enables you to grab a panel, then drag the panel to a new location.

Right-click

Opens the panel popup menu.
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To Move a Panel
You can move panels to different locations. To move a panel, middle-click and hold on
any vacant space on the panel, then drag the panel to the new location.

To Hide a Panel
You can hide or show panels. To hide a panel, use a hide button. If the hide buttons
are not visible on a panel, modify the panel properties so that the hide buttons are
visible.
Hide buttons are at either end of a panel. The hide buttons contain an optional arrow
icon. The following illustration shows hide buttons.

To hide a panel, click on one of the hide buttons. The panel reduces in the direction of
the arrow on the hide button. The hide button at the other end of the panel remains
visible.
To show a hidden panel again, click on the visible hide button. The panel expands in
the direction of the arrow on the hide button. Both hide buttons are now visible.
You can set a panel to autohide. When you set autohide, the panel hides automatically
when the mouse is not pointing to the panel. The panel reappears when you point to
the part of the screen where the panel resides. To set your panel to autohide, modify
the properties of the panel.

To Modify Panel Properties
To modify preferences for all panels, use the Panel preference tool to make the
changes that you require. For example, you can modify animation preferences for
panels.
You can also modify properties for each individual panel. You can change the features
for each panel, such as the position of the panel, the hide behavior, and the visual
appearance.
To modify the properties of a panel perform the following steps:
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1. Right-click on a vacant space on the panel, then choose Properties to display the
Panel Properties dialog. The Panel Properties dialog contains the following tabbed
sections:
■
■

General
Background

2. To modify panel size, position, and hiding properties, click on the General tab. The
following table describes the dialog elements on the General tabbed section:

Dialog Element

Description

Name

Type a name for the panel. When you use shortcut keys to
switch between your panels and the desktop, this panel name is
displayed.

Orientation

Select the position of the panel on your screen. Click on the
required position for the panel.

Size

Use the spin box to specify the size of the panel.

Expand

Select this option if you want the panel to expand to the full
length of the edge of the screen where the panel is located.

Autohide

Select this option to enable autohide.

Show hide buttons

Select this option to display hide buttons on your panel.

Arrows on hide button

Select this option to display arrows on the hide buttons, if the
hide button is enabled.

3. To modify the panel background, click on the Background tab. Choose the type of
background for the panel. The choices are as follows:

Dialog Element

Description

None (use system theme)

Select this option to use the default panel background. The
default panel background depends on the settings in the
Theme preference tool.

Solid color

Select this option to specify a single color for the panel
background. Click on the Color button to display the color
selector dialog. Choose the color that you require from the
color selector dialog.
Use the Style slider to specify the degree of transparency or
opaqueness for the color. For example, to make the panel
transparent, move the slider towards the Transparent end.
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Dialog Element

Description

Background image

Select this option to specify an image for the panel
background. Enter the filename of the image to use in the
drop-down combination box. Alternatively, to browse for the
file, click on the Browse button. When you have selected the
file, click OK.

You can also drag a color or image on to a panel to set the color or image as the
background of the panel. For more information, see “To Drag a Color or Image to
the Background of a Panel” on page 29.
4. Click Close to close the Panel Properties dialog.

To Drag a Color or Image to the Background of a Panel
You can drag a color or image on to a panel to set the color or image as the
background of the panel. You can drag a color or image from many applications. For
example, you can drag a color from the file manager to a panel to set the color as the
background of the panel. You can also drag a color from any color selector dialog.
You can drag an image to a panel to set the image as the background of the panel. You
can also drag pattern images from the file manager to set the background of the panel.

To Delete a Panel
To delete a panel from the Java Desktop System, right-click on the panel that you want
to delete, then choose Delete This Panel.
Note – You must always have at least one panel in the Java Desktop System. If you
have only one panel in the Java Desktop System, you cannot delete that panel.

Panel Objects
This section describes the objects that you can add to your panels, and use from your
panels.

Interacting With Panel Objects
You use the mouse buttons to interact with a panel object in the following ways:
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Left-click

Launches the panel object.

Middle-click

Enables you to grab an object, then drag the object to a new location.

Right-click

Opens the panel object popup menu.

You interact with panel objects in a different way. For more information, see “To Select
a Panel Application” on page 33.

To Add an Object to a Panel
You can add an object to a panel in several ways, as follows:
■

From the panel popup menu
Right-click on a vacant space on a panel to open the panel popup menu. The panel
popup menu contains an Add to Panel submenu. The Add to Panel submenu
enables you to add the following objects to your panels:

■

■

Panel applications in the following categories: Accessories, Amusements,
Internet, Multimedia, Utility.

■

Buttons for quick access to common actions: Find Files button, Force Quit
button, Lock Screen button, Log Out button, Run Applications button,
Screenshot button, Show Desktop button.

■

Launchers

■

Launchers from menus

■

Main Menu

■

Menu Bar

■

Drawers

From any menu
When you right-click on a launcher in any menu, a popup menu for the launcher
opens. You can use this popup menu to add the launcher to a panel.
You can also drag menus, launchers, and panel applications from menus to panels.

■

From the file manager
Each launcher corresponds to a .desktop file. You can drag the .desktop file on
to your panels to add the launcher to the panel.

To Modify the Properties of an Object
Some panel objects, such as launchers and drawers, have a set of associated properties.
The properties are different for each type of object. The properties specify details such
as the following:
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■
■
■

The command that starts an application.
The location of the source files for a menu.
The icon that represents the object.

To modify the properties of an object perform the following steps:
1. Right-click on the object to open the panel object popup menu, as shown in Figure
2–1.

FIGURE 2–1

Panel Object Popup Menu

2. Choose Properties. Use the Properties dialog to modify the properties as required.
The properties in the Properties dialog depend on which object you select in step 1.
3. Click OK to apply the changes, then close the Properties dialog.

To Move a Panel Object
You can move panel objects within a panel, and from one panel to another panel. You
can also move objects between panels and drawers.
To move a panel object, middle-click and hold on the object and drag the object to a
new location. When you release the middle mouse button, the object anchors at the
new location.
Alternatively, you can use the panel object popup menu to move an object, as follows:
1. Right-click on the object, then choose Move.
2. Point to the new location for the object, then click any mouse button to anchor the
object to the new location. This location can be on any panel that is currently in the
Java Desktop System.
Movement of a panel object affects the position of other objects on the panel. To
control how objects move on a panel, you can specify a movement mode. To specify
the movement mode, press one of the following keys as you move the panel object:

Key

Movement Mode

Description

No key

Switched movement

The object swaps places with other panel objects.
Switched movement is the default movement
mode.
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Key

Movement Mode

Description

Alt key

Free movement

The object jumps over other panel objects into the
next vacant space on the panel.

Shift key

Push movement

The object pushes other panel objects further
along the panel.

To Lock a Panel Object
You can lock panel objects so that the objects stay in the same position on the panel.
This feature is useful if you do not want some panel objects to change position when
you move other panel objects.
To lock an object to the current location of the object in the panel, right-click on the
object to open the panel object popup menu, then choose Lock. To unlock the object,
right-click on the object, then choose Unlock.

To Remove a Panel Object
To remove an object from a panel right-click on the object to open the panel object
popup menu, then choose Remove From Panel.

Panel Applications
A panel application is a small application whose user interface resides within a panel.
For example, the following figure shows the following panel applications, from left to
right:

32

■

Window List: Displays the windows currently open on your system.

■

CD Player: Enables you to control the compact disc player on your system.

■

Volume Control: Enables you to control the volume of the speaker on your system.
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To Add an Application to a Panel
You can add an application to a panel from the panel popup menu. Right-click on any
vacant space on the panel to open the panel popup menu. Choose Add to Panel, then
choose the panel application that you want to add from one of the following
submenus:
■
■
■
■
■

Accessories
Amusements
Internet
Multimedia
Utility

Alternatively, drag the panel application from the submenu on to the panel.

To Select a Panel Application
To modify the properties of a panel application, you must first right-click on the panel
application to display the panel object popup menu. To move a panel application, you
must middle-click on the panel application.
Some restrictions apply on where you can click on a panel application in order to
display the panel object popup menu, or to move the panel application, as follows:
■

Some panel applications have popup menus of panel application-specific
commands that open when you right-click on particular parts of the panel
application. For example, the Window List panel application has a vertical handle
on the left side, and buttons that represent your windows on the right side. To
open the panel object popup menu for the Window List panel application, you
must right-click on the handle. If you right-click on a button on the right side, a
popup menu for the button opens.

■

Some panel applications have areas that you cannot use to select the panel
application. For example, the Command Line application has a field in which you
enter commands. You cannot middle-click or right-click on this field to select the
panel application. Instead, middle-click or right-click on another part of the panel
application.

To Modify Preferences for a Panel Application
To modify the preferences for a panel application perform the following steps:
1. Right-click on the panel application, then choose Preferences. Use the Preferences
dialog to modify the preferences as required. The preferences for panel applications
vary depending on the panel application.
2. Click Close to close the Preferences dialog.
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Launchers
When you click on a launcher, you initiate one of the following actions:
■

Start a particular application.

■

Execute a command.

■

Open a folder in a file manager window.

■

Open a browser at a particular Uniform Resource Locator (URL). A URL is the
address of a particular location on the Web.

■

Open special Uniform Resource Identifiers (URIs). The Java Desktop System contains
special URIs that enable you to access particular functions from the file manager.

You can find launchers in the following places in the Java Desktop System:
■

Panels: On panels, launchers are represented by icons.

■

Menus: On menus, launchers are represented by menu items. The menu items
usually have an icon beside the menu item.

■

Desktop: On the desktop, launchers are represented by icons.

You can modify the properties of a launcher. For example, the properties of a launcher
include the name of the launcher, the icon that represents the launcher, and how the
launcher runs.

To Add a Launcher to a Panel
You can add a launcher to a panel in one of the following ways:
■

From the panel popup menu
To create a new launcher, right-click on any vacant space on the panel, then choose
Add to Panel → Launcher. A Create Launcher dialog is displayed. For more
information on how to complete this dialog, see “To Create a Launcher With the
Create Launcher Dialog” on page 35.
Alternatively, to add an existing launcher to the panel, choose Add to Panel →
Launcher from menu from the panel popup menu. Choose the launcher that you
want to add from the menu.

■

From any menu
To add a launcher to a panel from any menu, perform one of the following steps:
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■

Open a menu that contains the launcher. Drag the launcher on to the panel.

■

Open the menu that contains the launcher from the panel where you want the
launcher to reside. Right-click on the title of the launcher. Choose Add this
launcher to panel.
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■

From the file manager
To add a launcher to a panel from the file manager, find the .desktop file for the
launcher in your file system. To add the launcher, drag the .desktop file to the
panel.

To Create a Launcher With the Create Launcher Dialog
To create a launcher with the Create Launcher dialog perform the following steps:
1. Right-click on any part of a panel to open the panel popup menu. Choose Add to
Panel → Launcher to display the Create Launcher dialog.
2. Enter the properties of the launcher in the Basic tabbed section. The following table
describes the dialog elements on the Basic tabbed section:

Dialog Element

Description

Name

Use this text box to specify the name of the launcher. You can use
the Advanced tab to add translations of the name. This name is
the name that appears when you add the launcher to a menu or to
the desktop.

Generic name

Use this text box to specify the class of application to which the
launcher belongs. For example, you might type Text Editor in
this text box for a gedit launcher. You can use the Advanced tab to
add translations of the generic name.

Comment

Use this text box to specify a short description of the launcher.
The comment is displayed as a tooltip when you point to the
launcher icon on the panel. You can use the Advanced tabbed
section to add translations of the comment.

Command

Use this field to specify a command to execute when you click on
the launcher. For sample commands, see the next section.

Type

Use this drop-down combination box to specify the type of
launcher. Select from the following:
■
Application: Select this option to create a launcher that starts
an application.
■
Link: Select this option to create a launcher that links to a URI.

Icon

Choose an icon to represent the launcher. To choose an icon, click
on the No Icon button. An icon selector dialog is displayed.
Choose an icon from the dialog. Alternatively, to choose an icon
from another directory, click Browse. When you choose an icon,
click OK.

Run in Terminal

Select this option to run the application or command in a terminal
window. Choose this option for an application or command that
does not create a window in which to run.
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3. To set advanced properties for the launcher, click on the Advanced tab.
4. Enter the advanced properties of the launcher in the Advanced tabbed section. The
following table describes the dialog elements on the top part of the Advanced
tabbed section:

Dialog Element

Description

Try this before using

Enter a command here to check before starting the launcher.
If the command is executable and is in your path, the
launcher appears on the panel.

Documentation

Enter the path to the help file for the launcher. If you enter a
path in this field, a Help on launcher-name Application menu
item is displayed on the popup menu for the launcher.

5. You can also add a translation of the Name, Generic name, and Comment fields
from the Basic tabbed section. To add a translation, enter the details of the
translation in the Name/Comment translations table as follows:

Field

Description

First field

Enter the two-letter code for the language for which you want to add a
translation.

Second field

Enter the translation of the Name of the launcher.

Third field

Enter the translation of the Generic name of the launcher.

Fourth field

Enter the translation for the Comment for the launcher.

Then click on the Add/Set button.
To edit a translation, select the translation. The translated text appears in the lower
part of this dialog. Edit the fields as required, then click on the Add/Set button.
To remove a translation, select the translation, then click on the Remove button.
6. To create the launcher and close the Launcher Properties dialog, click OK.

Launcher Commands
The type of commands that you can enter in the Command field depend on the option
that you choose from the Type drop-down combination box. If you choose
Application from the Type drop-down combination box, you can enter a normal
command. The following table shows some sample commands and the actions that the
commands perform:
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Sample Application Command

Action

gedit

Starts the gedit text editor application.

gedit /user123/loremipsum.txt

Opens the file /user123/loremipsum.txt in
the gedit text editor application.

nautilus /user123/Projects

Opens the folder /user123/Projects in a file
manager window.

If you choose Link from the Type drop-down combination box, you can enter a link
command. The following table shows some sample link commands and the actions
that the commands perform:

Sample Link Command

Action

http://www.sun.com

Opens the Sun Microsystems website in your
default browser.

ftp://ftp.gnome.org

Opens the GNOME FTP site in your default
browser.

applications:///

Opens the Applications location in a file
manager window. Double-click on an
application to start the application.

preferences:///

Opens the Preferences location in a file manager
window. Double-click on a preference tool to
start the preference tool.

To Modify the Properties of a Launcher
To modify the properties of a launcher perform the following steps:
1. Right-click on the launcher to open the panel object popup menu.
2. Choose Properties. Use the Launcher Properties dialog to modify the properties as
required. For more information on the Launcher Properties dialog, see “To Create
a Launcher With the Create Launcher Dialog” on page 35.
3. Click Close to close the Launcher Properties dialog.
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Buttons
You can add buttons to your panels to provide quick access to common actions and
functions.

Find Files Button
You can use the Find Files button to open the Search for Files dialog.
To add a Find Files button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Actions → Find Files. To open the Search for Files dialog, click
on the Find Files button.

Force Quit Button
The Force Quit button enables you to select a window to terminate an application.
This button is useful if you want to terminate an application that does not respond to
your commands.
To terminate an application, click on the Force Quit button, then click on a window
from the application that you want to terminate. If you do not want to terminate an
application after you click on the Force Quit button, press Esc.

Lock Screen Button
The Lock Screen button locks your screen and activates your screensaver. To access
your session again, you must enter your password. To lock your screen correctly, you
must have a screensaver enabled.
To add a Lock Screen button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Actions → Lock Screen.
Right-click on the Lock Screen button to open a menu of screensaver-related
commands. Table 2–1 describes the commands that are available from the menu.
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TABLE 2–1

Lock Screen Menu Items

Menu Item

Function

Activate Screensaver

Activates the screensaver immediately, but does not
lock the screen.

Lock Screen

Locks the screen immediately. This command
performs the same function as when you click on the
Lock button.

Kill Screensaver Daemon

Terminates the screensaver process. After you
terminate the screensaver process, you cannot lock
your screen.

Restart Screensaver Daemon

Terminates and restarts the screensaver process. Use
this command after you change your password.
When you restart the screensaver process, use your
new password with the screensaver.

Properties

Displays the XScreenSaver preference tool.

Log Out Button
The Log Out button begins the process to log out of a Java Desktop System session.
To add a Log Out button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Actions → Log Out. To log out of your session or shut down
your system, click on the Log Out button.

Run Applications Button
You can use the Run Applications button to open the Run Application dialog.
To add a Run Applications button to a panel, right-click on any vacant space on the
panel. Choose Add to Panel → Actions → Run Applications. To open the Run
Application dialog, click on the Run Applications button.

Screenshot Button
You can use the Screenshot button to take a screenshot of your screen.
To add a Screenshot button to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Actions → Screenshot. To take a screenshot of your screen,
click on the Screenshot button.
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Show Desktop Button
You can use the Show Desktop button to minimize all open windows and show the
desktop.
To add a Show Desktop button to a panel, right-click on any vacant space on the
panel. Choose Add to Panel → Actions → Show Desktop. To minimize all windows
and show the desktop, click on the Show Desktop button.

Notification Area
The Notification Area displays icons from various applications to indicate activity in
the application. For example, when you use the CD Player application to play a CD, a
CD icon is displayed in the Notification Area. The graphic above illustrates the CD
icon in the Notification Area.
To add a Notification Area to a panel, right-click on any vacant space on the panel.
Choose Add to Panel → Utility → Notification Area.

Menus
You can add the following types of menu to your panels:
■

Launch: You can access almost all of the standard applications, commands, and
configuration options from the Launch button. To add a Launch button to a panel,
right-click on any vacant space on the panel, then choose Add to Panel → Main
Menu. You can add as many Launch buttons to your panels as you want.

■

Menu Bar: You can access almost all of the standard applications, commands, and
configuration options from the menus in the Menu Bar. The Menu Bar contains the
Applications menu and the Actions menu. To add a Menu Bar to a panel,
right-click on any vacant space on the panel, then choose Add to Panel → Menu
Bar. You can add as many Menu Bar objects to your panels as you want.

■

System menus: System menus contain the standard applications and tools that you
can use in the Java Desktop System. The Applications menu and Actions menu are
system menus. To add a system menu to a panel, right-click on a launcher in the
menu, then choose Entire menu → Add this as menu to panel.

Menus that you add to your panels are represented by an icon with an arrow. The
arrow indicates that the icon represents a menu or drawer. Figure 2–2 shows how
menus typically appear on panels.
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FIGURE 2–2

Typical Menu Objects on a Panel

Drawers
A drawer is an extension of a panel. You can open and close a drawer in the same way
that you can show and hide a panel. A drawer can contain all panel objects, including
launchers, menus, other panel objects, and other drawers. When you open a drawer,
you can use the objects in the same way that you use objects on a panel.
The following figure shows an open drawer that contains two panel objects.

The arrow on the drawer icon indicates that the icon represents a drawer or menu.
You can add, move, and remove objects from drawers in the same way that you add,
move, and remove objects from panels.

To Open and Close a Drawer
To open a drawer, click on the drawer object in a panel. You can close a drawer in the
following ways:
■

Click on the drawer.
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■

Click on the drawer hide button.

To Add a Drawer to a Panel
You can add a drawer to a panel in the following ways:
■

From the panel popup menu
Right-click on any vacant space on the panel, then choose Add to Panel → Drawer.

■

From any menu
You can add a menu as a drawer object to a panel.
To add a menu as a drawer to a panel, open the menu from the panel. Right-click
on any launcher in the menu, then choose Entire menu → Add this as drawer to
panel.

To Add an Object to a Drawer
You add an object to a drawer in the same way that you add objects to panels. For
more information, see “To Add an Object to a Panel” on page 30.

To Modify Drawer Properties
To modify preferences for all panels and drawers, use the Panel preference tool. For
example, you can select various options related to the appearance and behavior of
objects on panels and drawers. You can also select options that relate to drawers only.
For example, you can select an option to close your drawers when you click on a
launcher in the drawer.
You can also modify other properties for each individual drawer. You can change
features for each drawer, such as the visual appearance of the drawer and whether the
drawer has hide buttons.
To modify properties for a drawer perform the following steps:
1. Right-click on the drawer, then choose Properties to display the Panel Properties
dialog. The dialog displays the General tabbed section.
2. Select the properties for the drawer in the dialog. The following table describes the
elements on the General tabbed section:
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Dialog Element

Description

Name

Type a name for the panel. When you use shortcut keys to
switch between your panels and the desktop, this panel name is
displayed.

Size

Select the size of the panel.

Icon

Choose an icon to represent the drawer. Click on the Icon button
to display an icon selector dialog. Choose an icon from the
dialog. Alternatively, click Browse to choose an icon from
another directory. When you choose an icon, click OK.

Show hide buttons

Select this option to display hide buttons on your panel.

Arrows on hide button

Select this option to display arrows on the hide buttons, if the
hide button is enabled.

3. You can use the Background tabbed section to set the background for the drawer.
For information on how to complete the Background tabbed section, see the step
on this topic in “To Modify Panel Properties” on page 27. You can also drag a color
or image on to a drawer to set the color or image as the background of the drawer.
For more information, see “To Drag a Color or Image to the Background of a
Panel” on page 29.
4. Click Close to close the Panel Properties dialog.
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CHAPTER

3

Working With Menus
This chapter describes how to use menus in the Java Desktop System.

Introduction to Menus
You can access all Java Desktop System functions through menus. You can add menus
to panels and you can use a combination of menus and panels to perform your tasks.
You can perform various actions on your menus, such as copy menu items to panels.
You can access the following menus in the Java Desktop System:
■

Launch button: You can access the items in the Applications menu from the Launch
button. You can have many Launch buttons in your panels.

■

Menu Bar: You can access the items in the Applications and Actions menus from
Menu Bar. You can have many Menu Bar panel applications in your panels.

■

Applications menu: You can access many of your applications, commands, and
configuration options from the Applications menu.

■

Actions menu: You can access commands that enable you to perform various tasks
from the Actions menu. For example, you can start the Search Tool application, or
log out of the Java Desktop System.

You can also right-click on the desktop to open the Desktop menu. The Desktop menu
enables you to perform desktop-related tasks.
All of these menus provide you with multiple ways to perform your tasks, and enable
you to work in the way that you prefer.
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Menu Features
Menus can contain the following items:
■
■

Submenus
Launchers or menu items

An arrow to the right of an item in a menu indicates that the item is a submenu. When
you point to the submenu, the submenu opens. You can choose items from the
submenu.
When you choose a launcher, the launcher starts an application or runs a command.
You can also right-click on a launcher to open a popup menu. The popup menu
enables you to add the item to a panel, and perform other tasks. For more information
on the popup menu, see the next section.
You can change the theme for your session to change how all your menus look. To
change the theme, use the Theme preference tool.

Menu Item Popup Menu
Items in menus have an associated popup menu that enables you to perform tasks
related to the item. When you right-click on an item in a menu, the popup menu for
the item opens. The popup menu also contains a submenu that enables you to perform
menu-related tasks.
You can use the menu item popup menu to perform the following tasks:
■

Add menu items as launchers to panels.

■

Remove items from menus.

■

Open the Run Application dialog with the menu item command in the dialog.

■

Add menus to panels. You can add a menu as a menu object or as a drawer object.

■

Add new items to menus.

■

Change the properties of submenus and menu items.

Figure 3–1 shows the popup menu.
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FIGURE 3–1

Menu Item Popup Menu

Table 3–1 describes menu item popup menus.
TABLE 3–1

Menu Item Popup Menus

Item

Description

Add this launcher to panel

Adds the launcher to the panel from which you open
the menu.

Remove this item

Removes the launcher from the menu.

Put into run dialog

Displays the Run Application dialog with the
command from the Command field of the launcher in
the command field on the Run Application dialog.

Help on application-name

Opens the online help for the application.

Properties

Displays a dialog that enables you to edit the
properties of the launcher.

Entire menu → Add this as drawer to
panel

Adds the submenu as a drawer to the panel from
which you open the menu.

Entire menu → Add this as menu to
panel

Adds the submenu as a menu object to the panel
from which you open the menu.

Entire menu → Add new item to this
menu

Enables you to add an item to the submenu.

Entire menu → Properties

Displays a dialog that enables you to edit the
properties of the submenu.

Applications Menu
The Applications menu contains a hierarchy of submenus, from which you can start
the standard Java Desktop System applications and preference tools.
You can access the Applications menu from the following places:
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■
■

Launch button
Menu Bar

Actions Menu
The Actions menu contains commands that enable you to perform various tasks in the
Java Desktop System. Table 3–2 describes the commands in the Actions menu.
TABLE 3–2

Actions Menu Commands

Menu Item

Function

Run Application

Opens the Run Application dialog. Use the Run
Application dialog to run commands. For more
information, see “Using the Run Application Dialog”
on page 48.

Open Recent

Displays a submenu of the last ten files which you saved.

Take Screenshot

Takes a screenshot of the screen, and opens the Save
Screenshot dialog. Use the Save Screenshot dialog to
save the screenshot.

Find Files

Starts the Search Tool application.

Lock Screen

Locks your screen.

Log Out

Logs you out of the current session.

You can access the Actions menu items from the following places:
■
■

Launch button
Menu Bar

Using the Run Application Dialog
The Run Application dialog gives you access to the command line. When you run a
command in the Run Application dialog, you cannot receive output from the
command.
To run a command from the command line, perform the following steps:
1. Display the Run Application dialog. You can display the Run Application dialog
in any of the following ways:
■
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From any panel
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Add the Run button to a panel. Right-click on the panel, then choose Add to
Panel → Actions → Run. Click on the Run button.
■

From the Launch button
Click Launch, then choose Run Application.

■

From the Menu Bar
Choose Actions → Run Application.

■

Use shortcut keys
The default shortcut keys to display the Run Application dialog are Super + R.
You can change the shortcut keys that display the Run Application dialog in
the Keyboard Shortcuts preference tool.

■

From a menu item popup menu
Right-click on an item in a menu, then choose Put into run dialog from the
popup menu. The Run Application dialog opens with the command from the
menu in the command field.

2. Enter the command that you want to run in the blank field. Alternatively, to choose
a command that you ran previously, click the down arrow button beside the
command field, then choose the command to run.
Alternatively, select the Show list of known applications option to display a list of
available applications.
You can also use the Run with file button to choose a file to append to the
command line. For example, you can enter emacs as the command, then choose a
file to edit.
Select the Run in terminal option to run the application or command in a terminal
window. Choose this option for an application or command that does not create a
window in which to run.
3. Click on the Run button on the Run Application dialog.

To Take a Screenshot
You can take a screenshot in any of the following ways:
■

From any panel
1. Add the Screenshot button to a panel.
2. Right-click on the panel, then choose Add to Panel → Actions → Screenshot.
3. Click on the Screenshot button to take a screenshot of the entire screen.
4. Use the Save Screenshot dialog to save the screenshot.

■

Use shortcut keys
To take a screenshot, use the following shortcut keys:
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Default Shortcut Keys

Function

Print Screen

Takes a screenshot of the entire screen, and displays the
Save Screenshot dialog. Use the Save Screenshot dialog
to save the screenshot.

Alt + Print Screen

Takes a screenshot of the window to which the mouse
points, and displays the Save Screenshot dialog. Use the
Save Screenshot dialog to save the screenshot.

You can use the Keyboard Shortcuts preference tool to modify the default shortcut
keys.
■

From Menu Bar
To take a screenshot of the entire screen, choose Actions → Take Screenshot. A Save
Screenshot dialog is displayed. To save the screenshot, select the Save screenshot
to file option. Enter the path and filename for the screenshot in the drop-down
combination box. Alternatively, to save the screenshot to another directory, click
Browse. When you select a directory, click OK.
You can also save the screenshot to the desktop. To save the screenshot to the
desktop, select the Save screenshot to desktop option.

■

Use a command
You can use the gnome-panel-screenshot command to take a screenshot. The
gnome-panel-screenshot command takes a screenshot of the entire screen, and
displays the Save Screenshot dialog. Use the Save Screenshot dialog to save the
screenshot.
You can also use options on the gnome-panel-screenshot command as
follows:
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Option

Function

--window

Takes a screenshot of the window that has focus, and
displays the Save Screenshot dialog. Use the Save
Screenshot dialog to save the screenshot.

--delay=seconds

Takes a screenshot after the specified number of seconds,
and displays the Save Screenshot dialog. Use the Save
Screenshot dialog to save the screenshot.

--help

Displays the options for the command.

Java Desktop System Release 3 User Guide • January, 2005

Launch Button

The Launch button provides access to the Applications menu and many of the items in
the Actions menu. You can access almost all of the standard applications, commands,
and configuration options from the Launch button.
You can add Launch buttons to your panels.

To Access the Launch Button
You can access the Launch button in the following ways:
■

From a panel with a Launch button.
Click Launch.

■

Use shortcut keys.
You can use shortcut keys to open Launch.
The default shortcut keys to open Launch are Ctrl + Esc. To change the shortcut
keys that open Launch, use the Keyboard Shortcuts preference tool.

To Add a Launch Button to a Panel
You can add as many Launch buttons as you want to your panels. To add a Launch
button to a panel, right-click on any vacant space on the panel. Choose Add to Panel
→ Main Menu.

Menu Bar
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The Menu Bar provides access to the Applications and Actions menus. You can access
almost all of the standard applications, commands, and configuration options from the
Menu Bar.

To Add a Menu Bar to a Panel
You can add as many Menu Bar panel applications as you want to your panels. To add
a Menu Bar to a panel, right-click on any vacant space on the panel. Choose Add to
Panel → Menu Bar.

Customizing Your Menus
You can modify the contents of the following menus:
■
■

Applications menu
Preferences menu

You use the following Java Desktop System components to customize menus:
■
■

Menus on panels
File manager

When you use panels to customize your menus, you use the menu item popup menu.
For more information, see “Menu Item Popup Menu” on page 46.
When you use the file manager to customize your menus, you must access the
Applications menu or the Preferences menu from within the file manager. To access
the Applications menu or the Preferences menu, open a file manager window.
To access menus in the file manager, enter one of the following URIs in the field on the
location bar:
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Menu

Enter this URI

Applications menu

applications:///

Preferences menu

preferences:///
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To Add a Menu
To add a menu, perform the following steps:
1. In a file manager window, access the location where you want to add the menu.
For example, if you want to add a menu to the Applications menu, enter
applications:/// in the field on the location bar.
2. Choose File → Create Folder. An untitled folder is added to the view pane. The
name of the folder is selected.
3. Type a name for the folder, then press Return.
The next time that you log out then log in again, the menu is in the assigned location.

To Add a Launcher to a Menu
To add a launcher to a menu, perform the following steps:
1.
2.
3.
4.

Right-click on any item in the menu to which you want to add the launcher.
Choose Entire menu → Add new item to this menu.
Enter the properties of the launcher in the Create Launcher dialog.
Click OK.

To Add a Launcher to an Empty Menu
To add a launcher to an empty menu, perform the following steps:
1.
2.
3.
4.

In a file manager window, access the menu where you want to add the launcher.
Choose File → Create Launcher.
Enter the properties of the launcher in the Create Launcher dialog.
Click OK.

To Copy a Launcher to a Menu
To copy an existing launcher to a menu, perform the following steps:
1. In a file manager window, access the location from which you want to copy the
launcher. For example, if you want to copy a launcher from the Applications menu,
enter applications:/// in the field on the location bar.
2. Select the launcher that you want to copy, then choose Edit → Copy File.
3. In a file manager window, access the location to which you want to copy the
launcher.
4. Choose Edit → Paste Files. The launcher is added to the new location.
Alternatively, you can drag the launcher from one location to another.
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The next time that you log out then log in again, the launcher is in the new menu
location.

To Edit the Properties of a Menu
To edit the properties of a menu, perform the following steps:
1.
2.
3.
4.

Right-click on any item in the menu that you want to edit.
Choose Entire menu → Properties.
Modify the properties of the menu in the Launcher Properties dialog.
Click OK.

To Edit a Menu Item
To edit a menu item, perform the following steps:
1.
2.
3.
4.

Right-click on the item that you want to edit.
Choose Properties.
Modify the properties of the launcher in the Launcher Properties dialog.
Click OK.

To Delete an Item from a Menu
To delete an item from a menu, use the menu item popup menu. To delete an item
from a menu, perform the following steps:
1. Right-click on the item that you want to delete.
2. Choose Remove this item.
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CHAPTER

4

Working With Windows
The information in this chapter describes how to use windows in the Java Desktop
System. You can use Metacity window manager with the Java Desktop System.This
chapter describes the functions that are associated with the Metacity window
manager.

Windows and Workspaces
Windows are displayed in subdivisions of the Java Desktop System that are called
workspaces. Every workspace contains the same desktop, the same panels, and the
same menus. However, you can run different applications, and open different
windows in each workspace. You can display only one workspace at a time, but you
can have windows open in other workspaces.
The Workspace Switcher panel application displays a visual representation of your
windows and workspaces, as shown in Figure 4–1.

FIGURE 4–1

Workspace Switcher Panel Application

You can add workspaces at any time. To add workspaces to the Java Desktop System,
right-click on the Workspace Switcher panel application, then choose Preferences. The
Workspace Switcher Preferences dialog is displayed. Use the Number of workspaces
spin box to specify the number of workspaces you require.
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Window Manager Behavior
A window manager controls how windows appear and behave. The window manager
manages where your windows are located, and which window has focus. The window
frame contains buttons that enable you to perform standard actions such as moving,
closing, and resizing windows.
You can set some window manager preferences in the Window Behavior preference
tool. This manual describes the functions that are associated with the default
configuration of the Metacity window manager. The default configuration is specified
in the Window Behavior preference tool.

Types of Window
The Java Desktop System features the following types of windows:
■

Application windows
When you start an application, an application window opens. The window
manager applies a frame to the application window. By default, the top edge of the
application window contains a titlebar. The titlebar contains buttons that you can
use to work with the window. The buttons in an application window frame enable
you to perform actions such as open the Window Menu, or close the window. The
Window Menu provides a number of actions that you can perform on the window.
The following figure shows a typical application window.

■
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Dialog windows

Java Desktop System Release 3 User Guide • January, 2005

A dialog window is a popup window in which you enter information or
commands. The dialog appears within a window frame.
You can use the top edge of the frame to work with the window. For example, you
can use the titlebar to move the dialog. The frame also contains buttons that enable
you to do the following:
■
■

Open the Window Menu
Close the dialog window

Typically, you open a dialog window from an application window. When you open
a dialog window, the window is usually raised and has focus. Some dialog
windows do not allow you to use the application until you close the dialog.
The following figure shows a typical dialog window.

Window Frames
A window frame is a border around a window. The window frame contains a titlebar.
The titlebar contains buttons that you can use to work with the window.

Themes
You can apply several themes to your window frames. The theme determines how the
frame looks. To choose a theme for all your window frames, use the Theme preference
tool.

Control Elements
You can use the window frame to perform various actions with the window. In
particular, the titlebar contains various buttons. The following figure shows the
titlebar of an application window:
Chapter 4 • Working With Windows

57

Dialog windows also contain some of the window frame control elements. Table 4–1
describes the active control elements on window frames, from left to right.
TABLE 4–1
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Window Frame Control Elements

Control Element

Description

Window Menu button

Click on the button to open the Window Menu.

Titlebar

You can use the titlebar to perform the following
actions:
■
To give focus to the window click on the titlebar.
■
To move the window grab the titlebar and drag the
window to the new location.
■
To shade the window, double-click on the titlebar.
To unshade the window, double-click on the
titlebar again.

Minimize button

Click on the Minimize button to minimize the
window.

Maximize button

Click on the Maximize button to maximize the
window.

Close Window button

Click on the Close Window button to close the
window.

Border

The border around the window. Use the border to
perform the following actions:
■
To resize the window grab the border and drag the
border to the new size.
■
To open the Window Menu, right-click on the
border.
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TABLE 4–1

Window Frame Control Elements

(Continued)

Control Element

Description

Window contents

The area inside the window frame. Use the window
contents to perform the following actions:
■
To move a window, press-and-hold Alt, click in the
window contents, then drag the window to the
new location.
■
To resize a window, press-and-hold Alt, then
middle-click near the corner you want to resize. To
resize the window, drag from the corner on which
you middle-clicked.
■
To open the Window Menu, press-and-hold Alt,
then right-click in the window contents.

Using Menus and Panel Applications
With Windows and Workspaces
This section describes the menus and panel applications that you can use to work with
windows and workspaces.

Window Menu
The Window Menu is a menu of commands that you can use to perform actions on
your windows. To open the Window Menu perform one of the following actions:
■

Click on the Window Menu button on the window that you want to work with.

■

Press Alt + spacebar.

■

Press-and-hold Alt, then right-click on any part of the window that you want to
work with.

Table 4–2 describes the commands and submenus in the Window Menu.
TABLE 4–2

Window Menu Commands and Submenus

Menu Item

Function

Minimize

Minimizes the window.

Maximize or Unmaximize

Maximizes the window. If the window is already maximized,
choose Unmaximize to restore the window to its previous size.
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TABLE 4–2

Window Menu Commands and Submenus

(Continued)

Menu Item

Function

On Top

Places the window above any other open windows on the
desktop background.

Move

Enables you to use the arrow keys to move the window.

Resize

Enables you to use the arrow keys to resize the window.

Close

Closes the window.

Put on All Workspaces or
Only on This Workspace

Puts the window on all of your workspaces. If the window is
already on all of your workspaces, choose Only on This
Workspace to put the window on the current workspace only.

Move to Workspace Right or
Move to Workspace Left

Move the window to the workspace to the right of the current
workspace. If the window is already in the last workspace at
the right of the Workspace Switcher, choose Move to
Workspace Left to move the window to the workspace to the
left of the current workspace.

Move to Another Workspace

Moves the window to another workspace. Select the
workspace to which you want to move the window from the
submenu.

Window List
The Window List displays a button for each application window that is open. You can
use the Window List to perform the following tasks:
■

To minimize a window
Click on the button that represents the window.

■

To restore a minimized window
Click on the button that represents the window.

■

To give focus to a window
Click on the button that represents the window.

When you open an application window, Window List displays a button that
represents the window. The window list buttons show which application windows are
open. You can view which windows are open even if some windows are minimized,
or other windows overlap a window. Window List can display buttons for the
windows in your current workspace, or in all workspaces. To select this option, you
must change the preferences of Window List.
You can also right-click on a window list button to open the Window Menu for the
window that the button represents. When you open the Window Menu from Window
List, the Window Menu does not contain the workspace commands. For more
information on the Window Menu commands, see “Window Menu” on page 59.
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Figure 4–2 shows Window List when the following windows are open:
■
■
■
■

gedit
Dictionary
GHex
GNOME Terminal

FIGURE 4–2

Window List Panel Application

The buttons in the panel application show the status of your windows. Table 4–3
explains the information that the window list buttons provide about the window. The
examples in Table 4–3 refer to Figure 4–2.
TABLE 4–3

Window Status Information on Window List Buttons

State

Indicates

Example

Button is pressed in.

The window has focus.

gedit

Square brackets around
window title.

The window is minimized.

[Dictionary]

Button is not pressed in, no
square brackets around title.

The window is displayed, and ghex
is not minimized.

Numeral on button, in
parentheses.

The button represents a group Gnome-terminal (3)
of buttons.

Grouping Buttons
Window List can group the buttons that represent windows in the same class under
one window list button. The Gnome-terminal button in Figure 4–2 is an example of a
button that represents a group of buttons. The following figure shows an example of
Window List with a button group open:

To open a list of the windows in a group, click on the window list button that
represents the group. You can click on the items in the list to give focus to windows,
minimize windows, and restore windows.
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To open the Window Menu for a window in a button group, right-click on the window
list button that represents the group. A list of the windows in the group is displayed.
To open the Window Menu for a window in the group, click on the item in the list.
When you open the Window Menu from the Window List, the Window Menu does
not contain the workspace commands. For more information on the Window Menu
commands, see “Window Menu” on page 59.

Workspace Switcher
Workspace Switcher displays a visual representation of your workspaces, as shown in
Figure 4–3. Figure 4–3 shows the Workspace Switcher when the Java Desktop System
session contains four workspaces. Your workspaces appear as buttons on the panel
application. The background of the button in the Workspace Switcher that represents
the current workspace is highlighted. The current workspace in Figure 4–3 is the
workspace at the left of the panel application. To switch to another workspace, click on
the workspace in the panel application.

FIGURE 4–3

Workspace Switcher Panel Application

Workspace Switcher also displays the application windows and dialogs that are open
in your workspaces.
The panel application displays the workspaces in order from left to right across the
rows of the panel application. In Figure 4–3, the panel application is set up to display
the workspaces in one row. You can specify the number of rows in which your
workspaces are displayed in Workspace Switcher. You can also change the default
behavior of the Workspace Switcher to display the names of your workspaces in the
panel application.

Window Selector
You can view a list of all windows that are currently open. You can also choose a
window to give focus to. To view the window list, click on the Window Selector panel
application. The following figure shows an example of the Window Selector panel
application:
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To give focus to a window, select the window from the Window Selector panel
application.
The Window Selector lists the windows in all workspaces. The windows in all
workspaces other than the current workspace, are listed under a separator line.

Manipulating Windows
This section describes how to manipulate windows.

To Give Focus to a Window
A window that has focus can receive input from the mouse and the keyboard. Only
one window can have focus at a time. The window that has focus has a different
appearance than other windows.
You can use the following elements to give focus to a window:

Element

Action

Mouse

Click on the window, if the window is visible.

Shortcut keys

Use shortcut keys to switch between the windows that are
open. To give focus to a window, release the keys. The default
shortcut keys to switch between windows are Alt + Tab.

Window List

Click on the button that represents the window in Window
List.
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Element

Action

Workspace Switcher

Click on the window that you want to give focus to in the
Workspace Switcher display. If you click on a window in
another workspace, Workspace Switcher switches to the new
workspace, and gives focus to the window.

To Minimize a Window
To minimize a window perform one of the following actions:
■

Click on the Minimize button on the window frame.

■

Open the Window Menu, then choose Minimize.

■

If the window has focus, click on the button that represents the window in
Window List. If the window does not have focus, click twice on the button that
represents the window.

■

Right-click on the button that represents the window in Window List, then choose
Minimize from the popup menu.

To Maximize a Window
When you maximize a window, the window expands as much as possible. To
maximize a window perform one of the following actions:
■

Click on the Maximize button on the window frame. Alternatively, open the
Window Menu, then choose Maximize.

■

Right-click on the button that represents the window in Window List, then choose
Maximize from the Window Menu.

To Restore a Window
To restore a maximized window perform one of the following actions:
■

Click on the Maximize button on the window frame.

■

Open the Window Menu. Choose Unmaximize.

■

Right-click on the button that represents the window in Window List to open the
Window Menu. Choose Unmaximize.

To restore a minimized window, click on the button that represents the window in
Window List.

To Place a Window on Top of Other Windows
To place a window on top of other windows, open the Window Menu, then choose On
Top.
64

Java Desktop System Release 3 User Guide • January, 2005

To Close a Window
To close a window perform one of the following actions:
■

Click on the Close Window button on the window frame.

■

Open the Window Menu. Choose Close.

■

Right-click on the button that represents the window in Window List, then choose
Close from the Window Menu.

If you have unsaved data in the window, you are prompted to save your data.

To Resize a Window
To resize a window perform one of the following actions:
■

Point to a corner of the window. The mouse pointer changes to indicate that you
can resize the window. Grab the corner and drag the window to the new size.

■

Right-click on the button that represents the window in Window List. Choose
Resize from the Window Menu. Use the arrow keys to resize the window.

■

Press-and-hold Alt, then middle-click near the corner that you want to resize. The
mouse pointer changes to indicate that you can resize from the corner. To resize the
window, drag from the corner on which you middle-clicked.

■

To resize a window horizontally point to one of the vertical edges of the window.
The mouse pointer changes to indicate that you can resize the window. Grab the
edge and drag the window to the new size.

■

To resize a window vertically point to the bottom edge of the window. The mouse
pointer changes to indicate that you can resize the window. Grab the edge and
drag the window to the new size.

Note – You cannot resize some dialog windows. Also, some application windows have
a minimum size below which you cannot reduce the window.

To Move a Window
To move a window perform one of the following actions:
■

Grab the titlebar of the window and drag the window to the new location.

■

Press-and-hold Alt, then drag the window to the new location.

■

Open the Window Menu, then choose Move. Use the arrow keys to move the
window to the new location.

■

Right-click on the button that represents the window in Window List, then choose
Move from the Window Menu. Use the arrow keys to move the window to the new
location.
Chapter 4 • Working With Windows

65

To Roll Up a Window
You can roll up and roll down windows, as follows:
Roll up

Reduce the window so that only the titlebar is visible.

Roll down

Switch a window from a rolled-up state so that the full window is
displayed.

To roll up a window perform one of the following actions:
■

Double-click on the titlebar of the window. To roll down the window, double-click
on the titlebar again.

■

Right-click on the button that represents the window in Window List, then choose
Roll Up from the Window Menu. To roll down the window, choose Unroll.

To Put a Window on All Workspaces
To put a window in all workspaces, open the Window Menu. Choose Put on All
Workspaces. To set the window to appear only in the current workspace, choose Only
on This Workspace.

To Move a Window to Another Workspace
You can move a window to another workspace in either of the following ways:
■

Use Workspace Switcher
In the Workspace Switcher display, drag the window to the workspace you require.

■

Use the Window Menu
Open the Window Menu. To move the window to the next workspace choose
Move to workspace-name.

To Resize Panes
Some windows contain more than one pane. A pane is a subdivision of a window. For
example, the file manager window contains a side pane and a view pane. A window
that contains panes has a resize handle on the edge between the panes. To resize the
pane, grab the resize handle, then drag the edge to the size you require.
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Using Tables
Some windows contain information that is organized in a table. This section describes
how to work with tables in windows.
To change the width of a column, drag one of the vertical edges of the column.
In some tables, you can sort the information by a particular column. To sort
information in a table, click on the heading on top of the column by which you want
to sort the information. An up arrow is displayed in the column heading by which the
table is sorted. The following figure shows the up arrow.

To reverse the sort order, click on the column heading again. The up arrow changes to
a down arrow. The down arrow indicates that the information in the column is sorted
in reverse order.
In some tables, you can select multiple items. The following table describes how to
select items in tables.

Task

Action

Select an item

Click on the item.

Select a group of contiguous
items

Press-and-hold Shift. Click on the first item in the group,
then click on the last item in the group.

Select multiple items

Press-and-hold Ctrl. Click on the items that you want to
select.

Manipulating Workspaces
This section describes how to manipulate workspaces.

To Switch Between Workspaces
You can switch between workspaces in any of the following ways:
■

Use Workspace Switcher
Click on the workspace that you want to switch to in Workspace Switcher.
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■

Use shortcut keys
The default shortcut keys to switch between the workspaces are as follows:

Default Shortcut Keys

Function

Ctrl + Alt + right arrow

Selects the workspace to the right.

Ctrl + Alt + left arrow

Selects the workspace to the left.

To Add Workspaces
To add workspaces to the Java Desktop System, right-click on Workspace Switcher,
then choose Preferences. The Workspace Switcher Preferences dialog is displayed.
Use the Number of workspaces spin box to specify the number of workspaces you
require. Workspace Switcher adds new workspaces at the end of the workspace list.

To Name Workspaces
The default names of your workspaces are Workspace 1, Workspace 2, Workspace
3, and so on. To assign names to your workspaces, right-click on Workspace Switcher,
then choose Preferences. The Workspace Switcher Preferences dialog is displayed.
Use the Workspaces names list box to specify the names of your workspaces. Select a
workspace, then type the new name for the workspace.

To Delete Workspaces
When you delete a workspace the windows in the workspace are moved to another
workspace, and the empty workspace is deleted.
To delete workspaces from the Java Desktop System, right-click on Workspace
Switcher, then choose Preferences. The Workspace Switcher Preferences dialog is
displayed. Use the Number of workspaces spin box to specify the number of
workspaces you require. Workspace Switcher deletes workspaces from the end of the
workspace list.
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CHAPTER

5

Using Your File Manager
Nautilus is the name of the Java Desktop System file manager that provides an
integrated access point to your files and applications.
This chapter describes how to use the file manager.

Introduction to File Manager
The file manager provides an integrated access point to your files and applications.
The file manager enables you to do the following:
■
■
■
■
■
■
■

Create folders and documents.
Display your files and folders.
Manage your files and folders.
Customize your files and folders.
Open special URI locations.
Write data to a CD.
Use removable media.

The file manager also manages the desktop background. The desktop background lies
behind all of the other components on your visible desktop. The desktop background
is an active component of the user interface.
To open a file manager window, double-click on the Documents object on the desktop
background. The file manager window displays the contents of your default
documents location in the view pane.
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File Manager Windows
File manager windows enable you to display and manage your files and folders.
Figure 5–1 shows a file manager window that displays the contents of a folder.

FIGURE 5–1

Contents of a Folder in a File Manager Window

Table 5–1 describes the components of file manager windows.
TABLE 5–1
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File Manager Window Components

Component

Description

Menubar

Contains menus that you use to perform tasks in the file manager.

Toolbar

Contains buttons that you use to perform tasks in the file
manager.
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TABLE 5–1

File Manager Window Components

(Continued)

Component

Description

Location bar

Contains the following elements:
■
Location field or Go To field: Enables you to specify a file,
folder, or URI that you want to view.
■
Zoom buttons: Enable you to change the size of items in the
view pane.
■
View as drop-down list: Enables you to choose how to show
items in your view pane.

Side pane

Performs the following functions:
■
Shows information about the current file or folder.
■
Enables you to navigate through your files.
The side pane contains a drop-down list that enables you to
choose what to show in the side pane. You can choose from the
following options:
■
Information
■
Emblems
■
History
■
Notes
■
Tree
To display the side pane, choose View → Side Pane.

View pane

Shows the contents of the following:
Particular types of files
■
Folders
■
FTP sites
■
Locations that correspond to special URIs
■

Statusbar

Displays status information.

You can also open a popup menu from file manager windows. To open this popup
menu right-click in a file manager window. The items in this menu depend on where
you right-click. For example, when you right-click on a file or folder, you can choose
items related to the file or folder. When you right-click on the background of a view
pane, you can choose items related to the display of items in the view pane.

View Pane
The view pane can display the contents of the following:
■
■
■
■

Particular types of files
Folders
FTP sites
Locations that correspond to special URIs
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The file manager contains viewer components that enable you to display particular types
of file in the view pane. For example, you can use a text viewer to display text files in
the view pane.
Displaying a file in the view pane provides the following benefits:
■
■

Uses less system resources than when you launch an application.
Takes less time than when you launch an application.

However, you cannot edit a file in the view pane.
The file manager also includes views that enable you to display the contents of your
folders in different ways. For example, you can display the contents of a folder in the
following types of view:
■
■
■

Icon view: Shows the items in the folder as icons.
List view: Shows the items in the folder as a list.
Audio view: Shows only the audio items in the folder.

Use the View menu to choose how to display a folder. For more information on views,
see “Using Views to Display Your Files and Folders” on page 94.

Side Pane
To display the side pane, choose View → Side Pane. You can choose what information
you want to view in the side pane. You can choose to display one of the following:
■

Information
Displays an icon that represents the current file or current folder. Also displays
information about the current file or current folder. If a file is displayed in the view
pane, buttons appear in the side pane. The buttons enable you to perform actions
on a file, other than the default action.

■

Emblems
Contains emblems that you can add to a file or folder.

■

History
Contains a history list of files, folders, FTP sites, and URIs that you have recently
visited.

■

Notes
Enables you to add notes to your files and folders.

■

Tree
Displays a hierarchical representation of your file system. You can use the Tree to
navigate through your files.

To close the side pane, click on the X button at the top right of the side pane.
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Icons and Emblems
In icon view, the file manager displays your files and folders as icons. You can add
emblems to your file icons and folder icons. An emblem is a small icon that you can
add to an item to visually mark the item. For example, to mark a file as important, you
can add an Important emblem to the file icon to create the following visual effect:

For more information on how to add an emblem to an icon, see “To Add an Emblem
to a File or Folder” on page 92.
The following table describes the structure of the file icon:

Component

Description

Emblem. This emblem is the Important emblem.

Icon that represents the file. This icon might contain a
preview of the contents of the file.

Icon caption. You can modify what items of information are
displayed in the icon caption.

The file manager includes default emblems for the following types of item:
■

Symbolic links

■

Items for which you have the following permissions:
■
■

Read permission only
No read permission and no write permission
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The following table shows the default emblems:

Default Emblem

Description

Symbolic link

Read permission only

No read permission and no write permission

Navigating Your Computer
The file manager provides an integrated access point to your files, applications, FTP
sites, and URIs.
This section describes the following:
■
■
■
■
■
■
■

How to display items in file manager windows.
How to open files from file manager windows.
How to navigate the files and folders in your file system.
How to open locations on your file system.
How to connect to a server.
How to navigate to FTP sites.
How to access special URI locations.

To Display a Folder
You can display the contents of a folder in any of the following ways:
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■

Double-click on the folder in the view pane.

■

In the Location field, type the path of the folder that you want to display, then
press Return. The Location field includes an autocomplete feature. As you type a
path, the file manager reads your file system. When you type enough characters to
uniquely identify a directory, the file manager completes the name of the directory
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in the Location field.
■

Use the Tree in the side pane. For more information, see “Using the Tree From the
Side Pane” on page 75.

■

Use the Back toolbar button and the Forward toolbar button to browse through
your navigation history.

To change to the folder that is one level above the current folder, choose Go → Up.
Alternatively, click on the Up toolbar button.
To reload the display, click on the Reload button.
If you cannot find the folder that you want to display, you can use Search Tool. To start
the Search Tool, click Launch, then choose Find Files.

Using the Tree From the Side Pane
The Tree displays a hierarchical representation of your file system. The Tree provides a
convenient way to navigate your file system. To display the Tree in the side pane,
choose Tree from the drop-down list at the top of the side pane.
In the Tree, folders are represented as follows:

Folder State

Graphic Representation

Closed folder

Right arrow

Open folder

Down arrow

Table 5–2 describes the tasks that you can perform with the Tree, and how to perform
the tasks.
TABLE 5–2 Tree Tasks
Task

Action

Open the Tree.

Choose Tree from the drop-down list at the
top of the side pane.

Close the Tree.

Choose another item from the drop-down list
at the top of the side pane.

Open a folder in the Tree.

Click on the arrow next to the folder in the
Tree.

Close a folder in the Tree.

Click on the arrow next to the folder in the
Tree.
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TABLE 5–2 Tree Tasks

(Continued)

Task

Action

Display the contents of a folder in the view
pane.

Select the folder in the Tree.

Display the contents of a file in the view pane.

Select the file in the Tree.

You can set your preferences so that the Tree does not display files.

Opening Files
When you open a file, the file manager performs the default action for that file type.
The default action can be one of the following:
■
■

Use a viewer component to display the file in the view pane.
Launch an application that opens the file.

The file manager checks the contents of a file to determine the type of a file. If the first
lines do not determine the type of the file, then the file manager checks the file
extension.
If you cannot find the file that you want to open, you can use Search Tool. To start the
Search Tool, click Launch, then choose Find Files.

Viewing Files in the View Pane
The file manager contains viewer components that enable you to display particular
types of file in the view pane. For example, you can display the following types of files
in the view pane:
■
■
■

Plain text files
PNG files
Joint Photographic Experts Group (JPEG) files

To reload the contents of the view pane, choose View → Reload. To stop loading an
item in the view pane, choose View → Stop.
When you display a file in the view pane, the viewer component might add menu
items to the file manager menus. The menu items relate to the file type that is
displayed. For example, when you display a PNG file, the Edit menu contains flip and
rotate menu items.
Also, when you display some types of file in the view pane, you can use the file
manager zoom buttons to change the size of the item.
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To Execute the Default Action
To execute the default action for a file, double-click on the file. For example, if the
default action for plain text documents is to display the file in a text viewer. In this
case, you can double-click on the file to display the file in a text viewer.
You can set your file manager preferences so that you click once on a file to execute the
default action.

To Execute Non-Default Actions Using the Open With
Submenu
To execute actions other than the default action for a file, perform the following steps:
1. In the view pane, select the file that you want to perform an action on. Choose File
→ Open With. The Open With submenu opens. The items in this submenu
correspond to the contents of the following parts of the File Associations preference
tool:
■
■

Default action drop-down list in the Edit file type dialog
Viewer component drop-down list in the Edit file type dialog

2. Choose an action from the Open With submenu.

To Execute Other Actions When Displaying a File
When you display a file in the view pane, the side pane might contain buttons.
The buttons represent any actions that are defined in the File Associations preference
tool. The actions are defined in the Default action drop-down list in the Edit file type
dialog in the File Associations preference tool. Click on a button to execute an action.
For example, if an action defined for plain text documents is to open the file in the
gedit text editor. If this action is defined, an Open with gedit button is displayed in the
side pane. To open the file in the gedit application, click on the Open with gedit
button.
Note – A button that represents the action does not appear in the side pane if the
actions are excluded in either of the following dialogs:
■
■

Open with Other Application
Open with Other Viewer

To Open Locations
The file manager provides an integrated access point to your files, applications, FTP
sites, and URIs.
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You can use the file manager to quickly access different locations on your file system.
To open a location, perform the following steps:
1. Choose Go → Location.
2. In the Location field, type the path of the folder that you want to display
3. Press Return.
The Location field includes an autocomplete feature. As you type a path, the file
manager reads your file system. When you type enough characters to uniquely
identify a directory, the file manager autocompletes the name of the directory in the
Location field.

To Connect to a Server
If your Java Desktop System environment is configured to access servers on a
network, you can use the Connect to Server menu to connect to servers.
To connect to a server, perform the following steps:
1. Choose File → Connect to Server.
2. Enter the name of a server in the Link name field of the Connect to Server dialog.
3. Enter the URL location, for example ftp:///ftp.gnome.org in the Location
(URL) field.
4. Click on the Connect button.

Using the This Computer Location

The This Computer location enables you to access the following functions:
■

Applications
Double-click Applications to access your key Java Desktop Systems applications.
You can also access the Applications menu through the Launch menu and the
Menu Bar.

■

Preferences
Double-click on Preferences to customize the Java Desktop System. You can also
access the preference tools through the Launch menu

■
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Double-click on File System to access the top level folder of the Java Desktop
System.
You can access the This Computer location in the following ways:
■

From the desktop background
Double-click on the This Computer object on the desktop background. The
contents of the This Computer location are displayed in a file browser window.

■

From a file browser window, access the computer:/// URI.

To Access FTP Sites
You can use the file manager to access FTP sites. To access an FTP site, enter the URL
for the site in the field on the location bar, then press Return. The contents of the site
are displayed in the view pane. To copy a file from the FTP site, drag the file to the
new location.
To access an FTP site that requires a username and password, you can enter the URL
in the following form:
ftp://username:password@hostname.domain
To reload the FTP site in the view pane, choose View → Reload. To stop loading the
FTP site, choose View → Stop.

To Access Network Places
If your system is configured to access places on a network, you can use the file
manager to access the network places.
To access network places, open the file manager and choose Go → Network Places.
Alternatively, double-click on the Network Places object on the desktop background.
Double-click on the Network object. A file manager window is displayed. The
window displays the network places that you can access. Double-click on the network
that you want to access.
To access UNIX shares, double-click on the Unix Network (NFS) object. A list of the
UNIX shares available to you is displayed in the file manager window.
To access Windows shares, double-click on the Windows Network (SMB) object. A list
of the Windows shares available to you is displayed in the file manager window.

To Add a Network Place
To add a network place, perform the following steps:
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1. Open the file manager and choose Go → Network Places. Alternatively,
double-click on the Network Places object on the desktop background.
2. Double-click on the Add Network Place object. The Add Network Place dialog is
displayed. Enter the details of the server in the dialog, as follows:

Dialog Element

Description

Location

Use this text box to specify the location that you want to add.
Alternatively, select one of the following locations from the
drop-down list:
■
FTP Server
■
Web Folder
■
Windows Network (SMB)
■
Unix Network (NFS)

Shortcut name

Use this text box to specify a shortcut name for the network
place.

Anonymous login

FTP Server option only. Select this option to log in to the FTP
server as an anonymous user.

No login required

Web Folder, Windows Network (SMB), and Unix Network (NFS)
options only. Select this option if you do not need to log in to the
web folder, Windows share, or UNIX share.

Username

Use this text box to specify a username when you connect to the
specified network place.
When you connect to the network place, you must enter your
password.

Go there now

Select this option if you want to access the network place
immediately.

3. Click OK to add your network place.

To Access Network Servers
If your GNOME desktop environment is configured to access servers on a network,
you can use the Applications menu to access the network servers.
To access network servers, choose Applications → Network Servers. A file object
window is displayed. The window displays the network servers that you can access.
Double-click on the network server that you want to access.
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To Add a Network Server
To add a network server, choose Applications → Network Servers. A file object
window is displayed. Double-click on the New Server object. A New Server dialog is
displayed. Enter the name of the server in the dialog, then click OK.

Accessing Special URI Locations
The Java Desktop System contains special URI locations that enable you to access
particular functions from the file manager. For example, to access the preference tools,
you can access the preferences:/// URI in a file manager window. Table 5–3 lists
the special URI locations that you can use with the file manager.
TABLE 5–3

Special URI Locations

URI Location

Description

applications:///

Displays a list of the applications in the Java Desktop System.
The applications are the same as the applications in the
Applications menu. To open an application, double-click on
the application.

computer:///

Displays a list of applications and preference tools in the Java
Desktop System. Also displays icons to access your file
system, CD-ROM, and floppy drives.

network:///

Displays network locations to which you can connect, if your
system is configured to access locations on a network. To
access a network location, double-click on the network
location. You can also use this URI to add network locations to
your system.

preferences:///

Displays a list of the preference tools in the Java Desktop
System. The preference tools are the same as the preference
tools in the Preferences menu. To open a preference tool,
double-click on the preference tool.

server-settings:///

Displays a list of applications that you can use to configure
your system as a server.

system-settings:///

Displays a list of applications that you can use to modify your
system settings.

Using Your Navigation History
The file manager maintains a history list of files, folders, FTP sites, and URI locations.
You can use the history list to navigate to files, folders, FTP sites, and URI locations
that you have recently visited. Your history list contains the last ten items that you
viewed. The following sections describe how to navigate your history list.
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To clear your history list choose Go → Clear History.

To Navigate Your History List Using the Go Menu
To display a list of previously-viewed items, choose the Go menu. Your history list is
displayed in the lower part of the Go menu. To open an item in your history list,
choose the item from the Go menu.

To Navigate Your History List Using the Toolbar
To use the toolbar to navigate your history list, perform one of the following actions:
■

To open the previous file, folder, or URI in your history list, click on the Back
toolbar button.

■

To open the next file, folder, or URI in your history list, click on the Forward
toolbar button.

■

To display a list of previously-viewed items, click on the down arrow to the right
of the Back toolbar button. To open an item from this list, click on the item.

■

To display a list of items that you viewed after you viewed the current item, click
on the down arrow to the right of the Forward toolbar button. To open an item
from this list, click on the item.

To Navigate Your History List Using History in the Side
Pane
To display the History list in the side pane, choose History from the drop-down list at
the top of the side pane. The History list in the side pane displays a list of your
previously-viewed items.
To display an item from your history list in the view pane, click on the item in the
History list.

To Bookmark Your Favorite Locations
To access an item in your bookmarks, choose the item from the Bookmarks menu. You
can add your favorite locations to your Bookmarks menu. You can add bookmarks to
files and folders in your file system, to FTP sites, or to URI locations.

To Add a Bookmark
To add a bookmark, display the item that you want to bookmark in the view pane.
Choose Bookmarks → Add Bookmark.
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To Edit a Bookmark
To edit your bookmarks perform the following steps:
1. Choose Bookmarks → Edit Bookmarks.
2. To edit a bookmark, select the bookmark on the left side of the Edit Bookmarks
dialog. Edit the details for the bookmark on the right side of the Edit Bookmarks
dialog, as follows:

Dialog Element

Description

Name

Use this text box to specify the name that identifies the bookmark
in the Bookmarks menu.

Location

Use this field to specify the location of the bookmark.

3. To delete a bookmark, select the bookmark on the left side of the dialog. Click
Delete.

Managing Your Files and Folders
This section describes how to work with your files and folders.

Drag-and-Drop in the File Manager
You can use drag-and-drop to perform several tasks in the file manager. When you
drag-and-drop, the mouse pointer provides feedback about the task that you perform.
Table 5–4 describes the tasks that you can perform with drag-and-drop. The table also
shows the mouse pointers that appear when you drag-and-drop.
TABLE 5–4

Drag-and-Drop in the File Manager

Task

Action

Move an item

Drag the item to the new location.

Mouse Pointer
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TABLE 5–4

Drag-and-Drop in the File Manager

(Continued)

Task

Action

Mouse Pointer

Copy an item

Grab the item, then press-and-hold Ctrl. Drag the item
to the new location.

Create a symbolic
link to an item

Grab the item, then press-and-hold Ctrl + Shift. Drag
the item to the location where you want the symbolic
link to reside.

Ask what to do
with the item you
drag

Grab the item, then press-and-hold Alt. Drag the item
to the location where you want the item to reside.
Release the mouse button. A popup menu appears.
Choose one of the following items from the popup
menu:
■
Move here
Moves the item to the location.
■
Copy here
Copies the item to the location.
■
Link here
Creates a symbolic link to the item at the location.
■
Set as Background
If the item is an image, sets the image to be the
desktop background. You can use this command to
set the desktop background and the view pane
background.
■
Cancel
Cancels the drag-and-drop operation.

To Select Files and Folders
You can select files and folders in several ways in the file manager. Table 5–5 describes
how to select items in file manager windows and from the desktop background.
TABLE 5–5
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Selecting Items in the File Manager

Task

Action

Select an item

Click on the item.

Select a group of contiguous
items

In icon view, drag around the files that you want to select.
In list view, click on the first item in the group.
Press-and-hold Shift, then click on the last item in the
group.
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TABLE 5–5

Selecting Items in the File Manager

(Continued)

Task

Action

Select multiple items

Press-and-hold Ctrl. Click on the items that you want to
select.
Alternatively, press-and-hold Ctrl, then drag around the
files that you want to select.

Select all items in a folder

Choose Edit → Select All Files.

To perform the default action on an item, double-click on the item. You can set your
file manager preferences so that you click once on a file to execute the default action.

To Move a File or Folder
The following sections describe the ways that you can move a file or folder.

Drag to the New Location in a View Pane
To drag a file or folder to a new location in a view pane, perform the following steps:
1. Open a file manager window. Choose File → New Window to open a second file
manager window.
2. In one window, select the folder from which you want to move the file or folder. In
the other window, select the folder to which you want to move the file or folder.
3. Drag the file or folder that you want to move to the new location in the other
window.
To move the file or folder to a folder that is one level below the current location, do
not open a new window. Instead, drag the file or folder to the new location in the
same window.

Cut and Paste to the New Location
You can cut a file or folder and paste the file or folder into another folder, as follows:
1. Select the file or folder that you want to move, then choose Edit → Cut File.
2. Open the folder to which you want to move the file or folder, then choose Edit →
Paste Files.

To Copy a File or Folder
The following sections describe the ways you can copy a file or folder.
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Drag to the New Location in a View Pane
To copy a file or folder perform the following steps:
1. Open a file manager window. Choose File → New Window to open a second file
manager window.
2. In one window, select the folder from which you want to copy the file or folder. In
the other window, select the folder to which you want to copy the file or folder.
3. Grab the file or folder, then press-and-hold Ctrl. Drag the file or folder to the new
location in the other window.
To copy the file or folder to a folder that is one level below the current location, do not
open a new window. Instead, grab the file or folder, then press-and-hold Ctrl. Drag the
file or folder to the new location in the same window.

Copy and Paste to the New Location
You can copy a file or folder and paste the file or folder into another folder, as follows:
1. Select the file or folder that you want to copy, then choose Edit → Copy File.
2. Open the folder to which you want to copy the file or folder, then choose Edit →
Paste Files.

To Duplicate a File or Folder
To create a copy of a file or folder in the current folder perform the following steps:
1. Select the file or folder that you want to duplicate in the view pane.
2. Choose Edit → Duplicate. Alternatively, right-click on the file or folder in the view
pane, then choose Duplicate.
A copy of the file or folder appears in the current folder.

To Create a Folder
To create a folder perform the following steps:
1. Select the folder where you want to create the new folder.
2. Choose File → Create Folder. Alternatively, right-click on the background of the
view pane, then choose Create Folder.
An untitled folder is added to the view pane. The name of the folder is selected.
3. Type a name for the folder, then press Return.
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To Rename a File or Folder
To rename a file or folder perform the following steps:
1. Select the file or folder that you want to rename in the view pane.
2. Choose Edit → Rename. Alternatively, right-click on the file or folder in the view
pane, then choose Rename.
The name of the file or folder is selected.
3. Type a new name for the file or folder, then press Return.

Templates and Documents
You can create templates from documents that you frequently create. For example, if
you often create invoices, you can create an empty invoice document and save the
document as invoice.doc in the $HOME/Templates folder.
You can also access the templates folder from a file browser window. Choose Go →
Templates.
The template name is displayed as a submenu item in the Create Document menu.
You can also create subfolders in the template folder. Subfolders display as submenus
in the menu.
You can also share templates. Create a symbolic link from the template folder to the
folder that contains the shared templates.

To Create a Document
If you have document templates, you can choose to create a document from one of the
installed templates.
To create a document perform the following steps:
1. Select the folder where you want to create the new document.
2. Choose File → Create Document. Alternatively, right-click on the background of
the view pane, then choose Create Document.
The names of any available templates are displayed as submenu items from the
Create Document menu.
3. Double-click on the template name for the document that you want to create.
4. Rename the document and save to the appropriate folder.
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To Move a File or Folder to Trash
To move a file or folder to Trash perform the following steps:
1. Select the file or folder that you want to move to Trash in the view pane.
2. Choose Edit → Move to Trash. Alternatively, right-click on the file or folder in the
view pane, then choose Move to Trash.
Alternatively, you can drag the file or folder from the view pane to the Trash object on
the desktop background.
Note – When you move a file or folder from a removable media to Trash, the file or
folder is stored in a Trash location on the removable media. To remove the file or
folder permanently from the removable media, you must empty Trash.

To Delete a File or Folder
When you delete a file or folder, the file or folder is not moved to Trash, but is deleted
from your file system immediately. The Delete menu item is only available if you
select the Include a Delete command that bypasses Trash option in the Folders
Preferences dialog.
To delete a file or folder perform the following steps:
1. Select the file or folder that you want to delete in the view pane.
2. Choose Edit → Delete. Alternatively, right-click on the file or folder in the view
pane, then choose Delete.

To Create a Symbolic Link to a File or Folder
A symbolic link is a special type of file that points to another file or folder. When you
perform an action on a symbolic link, the action is performed on the file or folder to
which the symbolic link points. However, when you delete a symbolic link, you delete
the link file, not the file to which the symbolic link points.
To create a symbolic link to a file or folder, select the file or folder to which you want
to create a link. Choose Edit → Make Link. A link to the file or folder is added to the
current folder.
Alternatively, grab the item to which you want to create a link, then press-and-hold
Ctrl + Shift. Drag the item to the location where you want to place the link.
By default, the file manager adds an emblem to symbolic links.
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Note – The permissions of a symbolic link are determined by the file or folder to which
a symbolic link points.

To View the Properties of a File or Folder
To view the properties of a file or folder, perform the following steps:
1.
2.
3.
4.

Select the file or folder whose properties you want to view.
Choose File → Properties.
Use the properties dialog to view the properties of the file or folder.
Click Close to close the properties dialog.

To Change Permissions
Permissions are settings assigned to each file and folder that determine what type of
access users can have to the file or folder. The following table lists the permissions that
you can set for files and folders, and the effect of the permission on files and folders:

Permission

File

Folder

Read

Permission to read the file.

Permission to list the contents of the
folder.

Write

Permission to make changes to the
file.

Permission to create and delete files in
the folder.

Execute

Permission to run the file as a
program. This is only relevant if the
file is a program or script.

Permission to access files in the
directory.

You can set permissions for different types of user. The following table lists the types
of user that you can set for which you can set permissions:

User Category

Description

Owner

The user that created the file or folder.

Group

The group to which the owner belongs.

Others

All other users who are not in the group to which the owner
belongs.

To change the permissions on a file or folder perform the following steps:
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1. Select the file or folder that you want to change.
2. Choose File → Properties.
3. Click on the Permissions tab. In the Permissions tabbed section, use the
drop-down lists and check boxes to change the permissions for the file or folder.
The following table describes the dialog elements on the Permissions tabbed
section:

Element

Description

File owner

To change the owner of the file or folder, select the
owner from the drop-down list.

File group

To change the group to which a file or folder belongs,
select the group from the drop-down list.

Owner

Select the permissions that you want to apply to the
owner of the file or folder.

Group

Select the permissions that you want to apply to the
group to which the owner of the file or folder belongs.

Others

Select the permissions that you want to apply to all
other users who are not in the group to which the
owner belongs.

Text view

Displays the permissions that you select from the Read,
Write, and Execute options, in text format.

Number view

Displays the permissions that you select from the Read,
Write, and Execute options, in text format.

Last changed

Displays the date and time that the file or folder was
last modified.

4. Click Close to close the properties dialog.

Adding Notes to Files and Folders
You can add notes to files or folders. You can add notes to files or folders in the
following ways:
■
■

From the Properties dialog
From Notes in the side pane

To Add a Note Using the Properties Dialog
To add a note to a file or folder, perform the following steps:
1. Select the file or folder to which you want to add a note.
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2. Choose File → Properties.
3. Click on the Notes tab in the properties dialog. In the Notes tabbed section, type
the note.
4. Click Close to close the properties dialog. A note emblem is added to the file or
folder.
To delete a note, delete the note text from the Notes tabbed section.

To Add a Note Using Notes in the Side Pane
To add a note to a file or folder, perform the following steps:
1. Open the file or folder to which you want to add a note in the view pane.
2. Choose Notes from the drop-down list at the top of the side pane. To display the
side pane, choose View → Side Pane.
3. Type the note in the side pane. A note emblem is added to the file or folder in the
view pane, and a note icon is added to the side pane. You can click on this icon to
display the note.
To delete a note, delete the note text from Notes in the side pane.

Using Trash
You can move the following items to Trash:
■
■
■

Files
Folders
Desktop background objects

If you need to retrieve a file from Trash, you can display Trash and move the file out
of Trash. When you empty Trash, you delete the contents of Trash permanently.

To Display Trash
You can display the contents of Trash in the following ways:
■

From a file manager window
Choose Go → Trash. The contents of Trash are displayed in the window.

■

From the desktop background
Double-click on the Trash object on the desktop background.

To Empty Trash
You can empty the contents of Trash in the following ways:
■

From a file manager window
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Choose File → Empty Trash.
■

From the desktop background
Right-click on the Trash object, then choose Empty Trash.

Modifying the Appearance of Files and
Folders
The file manager enables you to modify the appearance of your files and folders in
several ways, as described in the following sections.

To Add an Emblem to a File or Folder
To add an emblem to an item perform the following steps:
1. Select the item to which you want to add an emblem.
2. Right-click on the item, then choose Properties.
3. Click on the Emblems tab in the properties dialog to display the Emblems tabbed
section.
4. Select the emblem to add to the item.
5. Click Close to close the properties dialog.

To Add a New Emblem
To add a new emblem, perform the following steps:
1. Choose Edit → Backgrounds and Emblems.
2. Click on the Emblem button, then click on the Add a New Emblem button in the
Backgrounds and Emblems dialog.
3. Type a name for the emblem in the Keyword text box of the Create a New Emblem
dialog.
4. Click on the Image button.
5. Click Browse in the Select an image file for the new emblem dialog. When you
choose an emblem, click OK.
6. Click OK in the Create a New Emblem dialog.
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To Change the Icon for a File or Folder
To change the icon that represents an individual file or folder, perform the following
steps:
1. Select a file or folder.
2. Choose File → Properties.
3. On the Basic tabbed section in the properties dialog, click on the Select Custom
Icon button.
4. Use the Select an icon dialog to choose the icon to represent the file or folder. Click
Ok.
5. Click Close to close the properties dialog.
To restore an icon from a custom icon to the default icon specified in the File
Associations preference tool, right-click on the icon then choose Remove Custom Icon.
Alternatively, click on the Remove Custom Icon button on the properties dialog.
To change the icon that represents a file type, use the File Associations preference tool.

To Change the Size of Items in a View
You can change the size of items in a view. You can change the size if the view
displays a file or a folder. You can change the size of items in a view in the following
ways:
■
■
■

To enlarge the size of items in a view, choose View → Zoom In.
To reduce the size of items in a view, choose View → Zoom Out.
To return items in a view to the normal size, choose View → Normal Size.

You can also use the zoom buttons on the location bar to change the size of items in a
view. Table 5–6 describes how to use the zoom buttons.
TABLE 5–6 Zoom Buttons
Button

Button Name

Description

Zoom Out button

Click on this button to reduce the size of
items in a view.

Normal Size button

Click on this button to return items in a
view to normal size.
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TABLE 5–6 Zoom Buttons
Button

(Continued)

Button Name

Description

Zoom In button

Click on this button to enlarge the size of
items in a view.

The file manager remembers the size of items in a particular folder. The next time that
you display the folder, the items are displayed in the size that you selected. In other
words, when you change the size of items in a folder, you customize the folder to
display the items at that size. To return the size of the items to the default size
specified in your preferences, choose View → Reset View to Defaults.

Using Views to Display Your Files and Folders
The file manager provides several ways to display the contents of your files. The file
manager includes viewer components that enable you to display particular types of
file in the view pane. For example, you can use a web page viewer to display HTML
files in the view pane. You can use a text viewer to view plain text files in the view
pane.
You can also use the file manager to open a file in an appropriate application. For
more information, see “Opening Files” on page 76.
The file manager includes views that enable you to show the contents of your folders
in different ways. For example, you can show the contents of a folder in the following
types of view:
■

Icon view
Shows the items in the folder as icons.

■

List view
Shows the items in the folder as a list.

Use the View menu to choose how to display a file or folder. You can also use the
View as drop-down list to choose how to display a file or folder. When you display a
folder, you can specify how you want to arrange or sort items in the folder. You can
modify the size of the items in the view pane. The following sections describe how to
work with icon view, list view, and views of files.

To Choose a View in Which to Display a File or Folder
Choose the type of view in which to display the contents of a file or folder from the
View menu.
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Alternatively, to choose a view, choose View → View as. Select the view that you want
to use from the Open with Other Viewer dialog, then click on the Choose button.
You can also choose the type of view from the View as drop-down list. The View as
drop-down list is located at the right side of the location bar.
You can display different folders in different views. The file manager remembers the
view that you choose for a particular folder. The next time that you display the folder,
the file manager displays the folder in that view. To return the view for the folder to
the default view specified in your preferences, choose View → Reset View to Defaults.

To Arrange Your Files in Icon View
When you display the contents of a folder in icon view, you can specify how to
arrange the items in the folder. To specify how to arrange items in icon view, choose
View → Arrange Items. The Arrange Items submenu contains the following sections:
■

The top section contains an option that enables you to arrange your files manually.

■

The middle section contains options that enable you to sort your files
automatically.

■

The bottom section contains options that enable you to modify how your files are
arranged.

Choose the appropriate options from the submenu, as described in the following table:

Option

Description

Manually

Select this option to arrange the items manually. To arrange the
items manually, drag the items to the location you require within
the view pane.

By Name

Select this option to sort the items alphabetically by name. The
order of the items is not case sensitive. If the file manager is set to
display hidden files, the hidden files are shown last.

By Size

Select this option to sort the items by size, with the largest item
first. When you sort items by size, the folders are sorted by the
number of items in the folder. The folders are not sorted by the
total size of the items in the folder.

By Type

Select this option to sort the items alphabetically by object type.
The items are sorted alphabetically by the description of their
MIME type in the File Associations preference tool. The MIME type
identifies the format of a file, and enables applications to read the
file. For example, an email application can use the image/png
MIME type to detect that a PNG file is attached to an email.
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Option

Description

By Modification Date

Select this option to sort the items by the date the items were last
modified. The most recently modified item is first.

By Emblems

Select this option to sort the items by any emblems that are added
to the items. The items are sorted alphabetically by emblem name.
Items that do not have emblems are sorted after items with
emblems.

Compact Layout

Select this option to arrange the items so that the items are closer
to each other.

Reversed Order

Select this option to reverse the order of the option by which you
sort the items. For example, if you sort the items by name, select
the Reversed Order option to sort the items in reverse alphabetical
order.

The file manager remembers how you arrange the items in a particular folder. The
next time that you display the folder, the items are arranged in the way that you
selected. In other words, when you specify how to arrange the items in a folder, you
customize the folder to display the items in that way. To return the arrangement
settings of the folder to the default arrangement settings specified in your preferences,
choose View → Reset View to Defaults.

To Resize an Icon in Icon View
In icon view, you can change the size of the icon that represents an item that is
displayed. To change the size of an item in icon view, perform the following steps:
1. Right-click on the item that you want to resize, then choose Stretch Icon. A
rectangle appears around the item, with a handle at each corner.
2. Grab one of the handles, then drag the icon to the size that you want.
To return the icon to the original size, right-click on the icon, then choose Restore
Icon’s Original Size.
You can also resize objects on the desktop background.

To Modify the Behavior of a View
You can modify the behavior of a view in the following ways:
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■

Specify that the view is the default view for a particular file or folder.

■

Specify that the view is the default view for a file type or all folders.

■

Specify that the view is an item in the View as submenu for a particular file or
folder.

■

Specify that the view is an item in the View as submenu for all of a particular file
type or for all folders.
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■

Specify that the view is not an item in the View as submenu for a particular file or
folder.

To modify the behavior of a view perform the following steps:
1. Choose View → View as.
2. Select the view that you want to modify from the table in the Open with Other
Viewer dialog.
3. Click on the Modify button. The following table describes the options on the
Modify dialog:

Option

Description

Include in the menu for
item-name items

Select this option to include the view in the View as
submenu for this type of item.

Use as default for item-name
items

Select this option to use the view as the default for this
type of item.

Include in the menu for
item-name only

Select this option to include the view in the View as
submenu for this item only.

Use as default for item-name
only

Select this option to use the view as the default for this
item only.

Don’t include in the menu for
item-name items

Select this option to exclude the view from the View as
submenu for this type of item.

4. Click OK, then click Cancel to close the Open with Other Viewer dialog.
Note – You can also modify the actions that are associated with a file type in the Edit
file type dialog in the File Associations preference tool. To open the Edit file type
dialog, click on the Go There button.

Assigning Actions to Files
When you open a file, the file manager performs the default action for that file type.
The File Associations preference tool contains a table of file types, their associated file
extensions, and their default actions. This table specifies what happens when you
double-click on a file in the file manager.
You can also use the file manager to modify the actions that are associated with a
particular file or file type.
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You can use the File Associations preference tool to perform the following tasks:
■

Specify the default action for a file type. You can also change the default action for
a file type in the file manager.

■

Associate a file type with one or more applications. The default action might
specify to open the file in an application that is associated with the file type.

■

Associate a file type with one or more viewers. The default action might specify to
open the file in a viewer that is associated with the file type.

■

Associate a file extension with a MIME type. The MIME type specifies the format
of the file so that Internet browsers and email applications can read the file.

To Modify Actions
You can modify the actions associated with a file or file type. You can do the following:
■

Specify that the action is the default action for a particular file.

■

Specify that the action is the default action for a particular file type.

■

Specify that the action is an item in the Open With submenu for a particular file.

■

Specify that the action is an item in the Open With submenu for a particular file
type.

■

Specify that the action is not an item in the Open With submenu for a particular file
type.

To modify the actions associated with a file or file type, perform the following steps:
1. In the view pane, select the file for which you want to modify an action. If you
want to modify an action associated with a file type, select a file of that type.
2. Choose File → Open With.
3. Choose Other Application. An Open with Other Application dialog is displayed.
4. From the table in the dialog, select the application or viewer for which you want to
modify the behavior.
5. Click on the Modify button. The following table describes the options on the
Modify dialog:

Option

Description

Include in the menu for filetype Select this option to include the application or viewer in
items
the Open With submenu for this file type.
Use as default for filetype items Select this option to use the application or viewer as the
default action for this file type.
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Option

Description

Include in the menu for
filename only

Select this option to include the application or viewer in
the Open With submenu for this file, and not for other
files of this type.

Use as default for filename only Select this option to use the application or viewer as the
default action for this file, and not for other files of this
type.
Don’t include in the menu for
filetype items

Select this option to exclude the application or viewer
from the Open With submenu for this file type.

6. Click OK, then click Cancel to close the dialog.
Note – You can also modify the actions that are associated with a file type in the Edit
file type dialog in the File Associations preference tool. To open the Edit file type
dialog, click on the Go There button.

Writing CDs
The file manager provides a special location where you can copy files and folders that
you want to write to a CD. You can write the contents of the location to a CD easily.
To write a CD, perform the following steps:
1. From a file browser window, choose Go → CD Creator. The file manager opens a
special location, burn:///, from which you can write CDs.
2. From a file browser window, copy the files and folders that you want to write to
CD into the burn:/// location.
3. Insert a writable CD into the CD writer device on your system.
4. Choose File → Write to CD. Alternatively, click on the Write to CD button on the
toolbar.
5. Use the Write files to a CD recorder dialog to specify how you want to write the
CD, as follows:
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Dialog Element

Description

Target to write to

Select the device to which you want to write
the CD from the drop-down list. To create an
CD image file for the files and folders, select
the File image option.

Write speed

Select the speed at which you want to write
the CD from the drop-down list.

CD name

Type a name for the CD in the text box.

Erase CD

Select this option to erase the current
contents of the CD.

Eject CD when done

Select this option to eject the CD from the
drive when the CD is written.

Reuse these files for another CD

Select this option if you want to write the
files and folders to another CD. If you select
this option, the files and folders are not
removed from the burn:/// location after the
CD is written.

6. Click on the Write files to CD button.
If you selected the File image option from the Target to write to drop-down list, a
Choose a filename for the cdrom image dialog is displayed. Use the dialog to
specify the location where you want to save the CD image file. By default, CD
image files have a .iso file extension.
A Writing CD dialog is displayed. When the CD is written or when the CD image
file is created, a message to indicate that the process is complete is displayed in the
dialog.
If you created a CD image file, you can write this file to a CD. To write a CD image
file to CD, right-click on the CD image file, then choose Write to CD from the
popup menu.
If you did not select the Reuse these files for another CD option, the files and
folders are removed from the burn:/// location.

Using Removable Media on the Solaris
Operating System
The file manager supports the following removable media:
■
■
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Floppy diskette
CD-ROM
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■

Digital Video Disc (DVD)

When the file manager detects a new media, an object for the media is added to the
desktop. You can display the contents of the media in a file manager window. You can
drag-and-drop files and folders between removable media. You cannot format media
that is read-only, such as CD-ROM.
Note – Removable media works on Solaris 9 and Solaris 10 only.

To Display Media Contents on the Solaris
Operating System
You can display media contents in any of the following ways:
■

Double-click on the object that represents the media on the desktop.

■

Right-click on the object that represents the media on the desktop, then choose
Open.

A file manager window displays the contents of the media. To reload the display, click
on the Reload button.

To Display Media Properties on the Solaris
Operating System
To display the properties of removable media, right-click on the object that represents
the media on the desktop, then choose Properties. A Media Properties dialog is
displayed.
To view basic information on the media, select the Basic tab. The following table
describes the Basic elements on the Media Properties dialog:

Dialog Element

Description

Name

Displays the name assigned to the media.

Location

Displays the file path assigned to the media.

Volume

Displays the name of the volume assigned to the media.

Free Space

Displays the free space available on the media.

Modified

Displays the date that the media was last modified.

Select the Emblems tab to assign an emblem to the media icon.
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To view permissions information on the media, select the Permissions tab. The
following table describes the Permissions elements on the Media Properties dialog:

Dialog Element

Description

File Owner

Displays the name of the user that owns the file.

File Group

Displays the name of the group that owns the file.

Read/Write/Execute
checkboxes

Displays the read/write/execute permissions for
Owner/Group/Others.

Special Flags

Displays the Set user ID, Set group ID, and Sticky
checkboxes set for the media.

Text view

Displays the drwxrwxrwx string that corresponds to the
Read/Write/Execute checkboxes.

Number view

Displays the octal string that corresponds to the
Read/Write/Execute checkboxes.

Notes

Displays a note that you previously assigned to the media
using the File Manager. The note is not visible to other users.

Click Close to close the Media Properties dialog.

To Format Media on the Solaris Operating System
To format media is to prepare the media for use with a particular file system.
When you format media, you overwrite any existing information on the media. To
format media, perform the following steps:
1. Right-click on the object that represents the media on the desktop, then choose
Format. A Media Format dialog is displayed.
2. Select your format options in the Media Format dialog. The following table
describes the elements on the dialog:
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Dialog Element

Description

Quick Format

Select this option to format without certification, or with
limited certification of certain tracks on the media.

Long Format

Select this option to perform a complete format. For some
devices this might include certification of whole media by
the drive.
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Dialog Element

Description

File System Type

Select the type of file system in which you want to format
the media. Select from the following options:
■
PCFS (DOS): Select this option if you want to use the
media on an MS-DOS operating system.
■
UFS (UNIX): Select this option if you want to use the
media on a UNIX operating system.
■
UDFS (UNIX): Select this option if you want to format
the media in Universal Disk File System (UDFS).
■
NEC (DOS): Select this option if you want to format
the media in the NEC file system.

Volume Label

Type a name for the media in the text box.

3. Click Apply to format the media.

To Eject Media on the Solaris Operating System
To eject a floppy, right-click on the floppy object on the desktop, then choose Unmount
Volume. If the drive for the media is a motorized drive, the media is ejected from the
drive. If the drive for the media is not a motorized drive, a message is displayed when
you can manually eject the media.
To eject a CD-ROM, right-click on the CD-ROM object on the desktop, then choose
Eject. When you use the Eject command to eject media, the media is automatically
unmounted.
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CHAPTER

6

Using Your Desktop Background
This chapter describes how to use the desktop background to start applications, and
open your files and folders. The chapter also describes how to use the Desktop
Background menu, and how to customize the desktop background.

Introduction to the Desktop Background
The desktop background lies behind all of the other components on your visible
desktop. The desktop background is an active component of the user interface. You
can perform the following tasks from your desktop background:
■

Start your applications, and open your files and folders.
You can add desktop objects for convenient access to files, folders, and applications
that you use frequently. For example, you can add an application launcher to the
desktop background. You can create a symbolic link to a file that you use often,
then add this link to your desktop background. You can also store files and folders
on the desktop background.

■

Open the Desktop Background menu.
Right-click on the desktop background to open the Desktop menu. You can use the
Desktop menu to perform actions on the desktop background.

■

Work with Trash.
You can move objects to Trash and empty your Trash.

■

Customize your desktop background.
You can customize the pattern or color of the desktop background.

By default, your desktop background contains five objects. Table 6–1 describes the
functions of the default objects on the desktop:
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TABLE 6–1

Functions of Default Desktop Background Objects

Object

Function

This Computer

Provides an access point to some of the key features of the
Java Desktop System. You can access your applications and
configuration tools from the This Computer location. You
can also access programs that enable you to configure your
system as a server, and to modify other system
configuration details.

Documents

Enables direct access to files stored in your default directory.

Trash

Provides a temporary holding area for files, folders or
desktop objects that you can later retrieve or permanently
delete.

Learn About The Java Desktop
System

Launches a help browser from where you can access Help
about the Java Desktop System.

Star Office 7

Launches the StarOffice application.

Desktop Background Objects
A desktop background object is an icon on your desktop background that you can use
to open your files, folders, and applications. You can also add objects to your desktop
background to provide convenient access to files, folders, applications, and URIs that
you use frequently. For example, you can add a launcher to your desktop background
to enable you to open a particular application that you use often.
Table 6–2 describes the types of object that you can add to your desktop background.
TABLE 6–2

Types of Desktop Background Objects

Object Type

Description

Symbolic link

A symbolic link is an object that points to another file or folder.
When you choose a symbolic link from the desktop background,
the file or folder that the symbolic link points to is opened. You
can move or copy a symbolic link to the desktop background.
You can identify symbolic links by the default arrow emblem
that appears on all symbolic links.

Launcher
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You can add the following types of launcher to the desktop
background:
■
Application: Starts a particular application.
■
Link: Links to a particular file, folder, or URI.
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TABLE 6–2

Types of Desktop Background Objects

(Continued)

Object Type

Description

File

You can add files to your desktop background. Files on your
desktop background reside in your Desktop directory.

Folder

You can move folders to your desktop background, and you can
create folders on your desktop background. Folders on your
desktop background reside in your Desktop directory.

The following sections describe how to work with objects on the desktop background.

To Select Objects on the Desktop Background
To select an object on the desktop background, click on the object. To select multiple
objects, press-and-hold Ctrl, then click on the objects that you want to select.
You can also select an area on the desktop background to select all objects within that
area. Click-and-hold on the desktop background, then drag over the area that contains
the objects that you want to select. When you click-and-hold then drag, a rectangle
appears to mark the area that you select.
To select multiple areas, press-and-hold Ctrl, then drag over the areas that you want to
select.

To Open an Object from the Desktop Background
To open an object from the desktop background, double-click on the object.
Alternatively, right-click on the object, then choose Open. When you open an object,
the default action for the object executes. For example, if the object is a text file, the
text file opens in a file manager window. The default actions for file types are specified
in the File Associations preference tool.
To execute an action other than the default action for an object, right-click on the
object, then choose Open With. Choose an action from the Open With submenu.
The items in the Open With submenu correspond to the contents of the following parts
of the File Associations preference tool:
■
■

Default action drop-down list in the Edit file type dialog
Viewer Component drop-down list in the Edit file type dialog

You can set your preferences in a file manager window so that you click once on a file
to execute the default action.
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To Add a Launcher to the Desktop Background
A desktop background launcher can start an application or link to a particular file,
folder, FTP site, or URI location.
To add a launcher to your desktop background, perform the following steps:
1. Right-click on the desktop background, then choose Create Launcher.
2. Type the required information in the Create Launcher dialog. The command that
you enter for the launcher is the command that is executed when you use the
desktop background object.

To Add a Symbolic Link to the Desktop
Background
You can create symbolic links on your desktop background to perform the following
actions:
■
■
■

Open a particular file in a particular application.
Open a particular folder in a file manager window.
Run a binary file or a script.

To create a symbolic link on the desktop background, perform the following steps:
1. Display the file or folder for which you want to create a symbolic link in a file
manager window.
2. Create a symbolic link to the file or folder. To create a symbolic link to a file or
folder, select the file or folder to which you want to create a link. Choose Edit →
Make Link. A link to the file or folder is added to the current folder. You can
identify symbolic links by the default arrow emblem that appears on all symbolic
links. The following figure shows a symbolic link to a file:

3. Drag the symbolic link to the desktop background. The icon for the object is moved
to the desktop background.

Adding a File or Folder to the Desktop Background
The following sections describe how you can add file objects and folder objects to the
desktop background.
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To Move a File or Folder to the Desktop Background
You can move a file or folder from the file manager to the desktop background. To
move a file or folder to the desktop background, perform the following steps:
1. Open a file manager window.
2. Display the file or folder that you want to move.
3. Drag the file or folder to the desktop background. The icon for the file or folder is
moved to the desktop background. The file or folder is moved to your Desktop
directory.
Alternatively, select the file or folder, then choose Edit → Cut Files. Right-click on
any desktop background object, then choose Paste Files.

To Copy a File or Folder to the Desktop Background
You can copy a file or folder from the file manager to the desktop background. To copy
a file or folder to the desktop background, perform the following steps:
1. Open a file manager window.
2. Display the file or folder that you want to move.
3. Press-and-hold Ctrl, then drag the file or folder to the desktop background. An
icon for the file or folder is added to the desktop background. The file or folder is
copied to your Desktop directory.
Alternatively, select the file or folder, then choose Edit → Copy Files. Right-click on
any desktop background object, then choose Paste Files.

To Create a Folder Object on the Desktop Background
To create a folder object, right-click on the desktop background to open the Desktop
menu. Choose Create Folder. An untitled folder is added to the desktop background.
Type the name of the new folder, then press Return. The folder is displayed with the
new name. The new folder resides in your Desktop directory.

To Rename a Desktop Background Object
To rename a desktop background object, right-click on the object, then choose Rename.
The name of the desktop background object is highlighted. Type the new name for the
object, then press Return.

To Remove an Object from the Desktop
Background
To remove an object from the desktop background, right-click on the object, then
choose Move to Trash. Alternatively, drag the object to Trash.
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Note – When you move a file or folder from a removable media to Trash, the file or
folder is stored in a Trash location on the removable media. To remove the file or
folder permanently from the removable media, you must empty Trash.

To Delete an Object from the Desktop Background
When you delete an object from the desktop background, the object is not moved to
Trash, but is immediately deleted from the desktop background. The Delete menu
item is only available if you select the Include a Delete command that bypasses Trash
option in the file manager File Management Preferences dialog.
To delete an object from the desktop background, right-click on the object, then choose
Delete.
Note – You cannot delete the This Computer or Trash desktop background objects.

To View the Properties of a Desktop Background
Object
To view the properties of a desktop background object, perform the following steps:
1. Right-click on the object whose properties you want to view, then choose
Properties.
2. Use the properties dialog to view the properties of the desktop background object.
3. Click Close to close the properties dialog.

To Change the Permissions of a Desktop
Background Object
To change the permissions of a desktop background object, perform the following
steps:
1. Right-click on the object whose permissions you want to change, then choose
Properties.
2. Click on the Permissions tab in the properties dialog.
3. In the Permissions tabbed section, use the drop-down lists and check boxes to
change the permissions for the file or folder. For more information on the dialog
elements in the Permissions tabbed section, see Using Your File Manager.
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4. Click Close to close the properties dialog.

To Add an Emblem to a Desktop Background
Object
To add an emblem to a desktop background object, perform the following steps:
1. Right-click on the object to which you want to add an emblem, then choose
Properties.
2. Click on the Emblems tab in the Emblems tabbed section.
3. Select the emblem to add to the item.
4. Click Close to close the properties dialog.

To Add a Note to a Desktop Background Object
To add a note to a desktop background object, perform the following steps:
1. Select the object to which you want to add a note.
2. Choose File → Properties.
3. Click on the Notes tab in Notes tabbed section. Type the note.
4. Click Close to close the properties dialog. A note emblem is added to the desktop
background object.
To delete a note, delete the note text from the Notes tabbed section.

To Change the Icon for a Desktop Background
Object
To change the icon for desktop background object, perform the following steps:
1. Right-click on the object whose permissions you want to change, then choose
Properties.
2. On the Basic tabbed section, click on the Select Custom Icon button.
3. Use the Select an icon dialog to choose the icon to represent the file or folder.
4. Click Close to close the properties dialog.
To restore an icon from a custom icon to the default icon, click on the Remove Custom
Icon button on the Properties dialog.
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To Resize a Desktop Background Object Icon
You can change the size of the icon that represents a desktop background object. To
change the size of an icon on the desktop background, perform the following steps:
1. Right-click on the desktop background object whose icon you want to resize, then
choose Stretch Icon. A rectangle appears around the icon, with a handle at each
corner.
2. Grab one of the handles, then drag the icon to the size that you want.
To return the icon to the original size, right-click on the icon, then choose Restore
Icon’s Original Size.

Using Trash on the Desktop Background
You can move the following items to Trash:
■
■
■

Files
Folders
Desktop background objects

If you need to retrieve a file from Trash, you can view Trash and move the file out of
Trash. When you empty Trash, you delete the items in Trash permanently.

To Display Trash
You can display the contents of Trash in the following ways:
■

From the desktop background
Double-click on the Trash object on the desktop background. The contents of Trash
are displayed in a file manager window.

■

From a file browser window
Choose Go → Trash. The contents of Trash are displayed in the file browser
window.

To Empty Trash
You can empty the contents of Trash in the following ways:
■

From the desktop background
Right-click on the Trash object, then choose Empty Trash.
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■

From a file manager window
Choose File → Empty Trash.

Using the Desktop Background Menu
To open the Desktop Background menu, right-click on a vacant space on the desktop
background. You can use the Desktop menu to perform actions on the desktop
background.
Table 6–3 describes the items in the Desktop Background menu.
TABLE 6–3

Items on the Desktop Background Menu

Menu Item

Function

Open Terminal

Starts a Terminal application.

Create Folder

Creates a new folder object.

Create Launcher

Creates a launcher on your desktop background. For more
information, see “To Add a Launcher to the Desktop
Background” on page 108.

Create Document

Creates a document. You can create templates from
documents that you frequently create. For example, if you
often create invoices, you can create an empty invoice
document and save the document as invoice.doc in the
$HOME/Templates folder.

Clean Up By Name

Arranges the objects on the desktop background
alphabetically by name.

Keep Aligned

Ensures that the left edges of the objects on the desktop
background are aligned with one another.

Paste Files

Puts file or files into a selected folder or the desktop
background.

Use Default Background

Resets the desktop background to the last pattern that you
chose from the Backgrounds and Emblems dialog. You can
access the Backgrounds and Emblems dialog from Nautilus
windows.

Change Desktop Background

Starts the Desktop Background preference tool.

Change Desktop Resolution

Starts the Screen Resolution preference tool.
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Changing the Pattern or Color of the
Desktop Background
You can change the pattern or color of the desktop background to suit your
preferences. The file manager includes background patterns and colors that you can
use to change the look-and-feel of the desktop background.
You can change the pattern or color of the desktop background in any of the following
ways:
■

Drag a pattern or color from another window or dialog to the desktop background.
If your desktop background is a color, you can create a gradient effect from a color
into the desktop background color. A gradient effect is a visual effect where one
color blends gradually into another color. To create a gradient effect on your
desktop background, drag a color to one of the edges of the screen. The color
blends from the edge to which you drag the color, to the opposite edge of the
screen.
Before you drag a color to a screen edge, check if there is an edge panel on the
screen edge. If there is an edge panel on the screen edge, you must hide the panel
before you drag the color.

■

Use the Desktop Background preference tool.

■

Choose a pattern or color for the background from the Backgrounds and Emblems
dialog. To change the pattern or color of the desktop background, perform the
following steps:
1. Open a file manager window.
2. Choose Edit → Backgrounds and Emblems.
3. To display a list of patterns that you can use, click on the Patterns button in the
Backgrounds and Emblems dialog. To display a list of the colors that you can
use, click on the Colors button.
4. To change the desktop background to a pattern, drag the pattern to the desktop
background. To change the desktop background to a color, drag the color to the
desktop background.
5. Click Close.
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CHAPTER

7

Using Your Preference Tools
This chapter describes how to start and use the preference tools to customize the Java
Desktop System.

Starting a Preference Tool
You can start the preference tools in the following ways:
■

Click Launch, then choose Preferences. Choose the tool that you require from the
submenus.

■

Double-click on the This Computer object on the desktop background. A file
browser window opens at the This Computer location. Double-click on the
Preferences object in the browser window to display your preference tools.
Double-click on the tool that you require.

Setting Assistive Technology Preferences
To access the Assistive Technology Support preference tool, click Launch, then choose
Preferences → Assessibility →Assistive Technology Support.
Use the Assistive Technology preference tool to enable assistive technologies in the
Java Desktop System. You can also use the Assistive Technology preference tool to
specify assistive technology applications to start automatically when you log in.
Table 7–1 lists the assistive technology preferences that you can modify.
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TABLE 7–1

Assistive Technology Preferences

Dialog Element

Description

Enable assistive technologies

Select this option to enable assistive
technologies in the Java Desktop System.

Screenreader

Select this option to start the Screenreader
application automatically when you log in.

Magnifier

Select this option to start the Magnifier
application automatically when you log in.

On-screen keyboard

Select this option to start the On-screen
keyboard application automatically when you
log in.

Customizing the Desktop Background
To access the Desktop Background preference tool, click Launch, then choose
Preferences → Desktop Preferences → Display → Desktop Background.
You can customize the desktop background in the following ways:
■

Select an image for the desktop background. The image is superimposed on the
desktop background color. The desktop background color is visible if you select a
transparent image, or if the image does not cover the entire desktop background.

■

Select a color for the desktop background. You can select a solid color, or create a
gradient effect with two colors. A gradient effect is a visual effect where one color
blends gradually into another color.

You can also change the appearance of your desktop background from within the file
manager.
Table 7–2 lists the background preferences that you can modify.
TABLE 7–2
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Desktop Background Preferences

Dialog Element

Description

Desktop Wallpaper

Choose an image to display on the desktop background. To choose
an image, click on the Select picture button. An image selector
dialog is displayed. Use the dialog to choose an image. When you
choose an image, click OK.
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TABLE 7–2

Desktop Background Preferences

(Continued)

Dialog Element

Description

Style

To specify how to display the image, select one of the following
options from the Style drop-down list:
■
Centered: Displays the image in the middle of the desktop
background.
■
Fill Screen: Enlarges the image to cover the desktop
background and maintains the relative dimensions of the image.
■
Scaled: Enlarges the image until the image meets the screen
edges, and maintains the relative dimensions of the image.
■
Tiled: Enlarges the image until the image meets the screen
edges, and maintains the relative dimensions of the image.

Add Wallpaper

Click on Add Wallpaper to display the Add Wallpapers dialog.
Choose the wallpaper that you want to appear as the background,
then click OK.

Remove

Choose the Desktop Wallpaper that you want to remove, then click
Remove.

Desktop Colors

To specify a color scheme, use the options in the Background Style
drop-down list, and the color selector buttons.
You can specify a color scheme in one of the following ways:
Choose Solid color from the Background Style drop-down list
to specify a single color for the desktop background.
To choose the color that you require, click on the Color button.
The Pick a Color dialog is displayed. Choose a color, then click
OK.
■
Choose Horizontal gradient from the Background Style
drop-down list. This option creates a gradient effect from the
left screen edge to the right screen edge.
Click on the Left Color button to display the Pick a Color
dialog. Choose the color that you want to appear at the left
edge.
Click on the Right Color button. Choose the color that you want
to appear at the right edge.
■
Choose Vertical gradient from the Background Style
drop-down list. This creates a gradient effect from the top screen
edge to the bottom screen edge.
Click on the Top Color button to display the Pick a Color
dialog. Choose the color that you want to appear at the top
edge.
Click on the Bottom Color button. Choose the color that you
want to appear at the bottom edge.
■
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Configuring a CD Database Server
To access the CD Database Server preference tool, click Launch, then choose
Preferences → Desktop Preferences → CD Database Server.
The CD Database Server preference tool enables you to configure a CD database
server that your system can query. A CD database server contains information about
CDs, such as the name of the artist, the title, and the track list. When an application
plays a CD, the application can query the CD database server about the CD, then
display the information.
Table 7–3 describes the preferences in the CD Database Server preference tool.
TABLE 7–3
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CD Database Server Preferences

Dialog Element

Description

Send no information

Select this option if you do not want to send any information to the
CD database server.

Send real information

Select this option to send your name and hostname information to
the CD database server.

Send other information

Select this option to send another name and hostname to the CD
database server. Enter the name in the Name field. Enter the
hostname in the Hostname field.

FreeDB round robin
server

FreeDB is a CD database. The FreeDB round robin server is a
load-sharing configuration of FreeDB servers. Select this option to
access the FreeDB CD database from this server.

Other FreeDB server

Select this option to access the FreeDB CD database from another
server. Select the server that you require from the server table.

Update Server List

Click on this button to update the list of available FreeDB servers in
the server table.

Other server

Select this option to use another CD database server. Enter the
name of the server on which the database resides in the Hostname
field. Enter the port number on which you can access the database
in the Port field.
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Configuring File Associations
To access the File Associations preference tool, click Launch, then choose Preferences
→ Desktop Preferences → File Associations.
Use the File Associations preference tool to configure the following:
File types

You can specify how files of various types are displayed and edited. For
example, you can specify an icon to represent a particular type of file.
For another example, you can specify that if a file is a plain text file, the
file is launched in a text editor.
The file manager and other desktop applications check the contents of a
file to determine the type of a file. If the first lines do not determine the
type of the file, then the application checks the filename.

Services

A Uniform Resource Identifier (URI) is a string that identifies a particular
location in a file system or on the Web. For example, the web address of
a web page is a URI. A service is a protocol or task that a URI requests.
For example, the http://www.gnome.org URI requests the http
service.
You can associate an application with a service, so that the application
performs the task required by the service. For example, you can
associate your preferred web browser with the http service.

Table 7–4 describes the elements on the File Associations preference tool.
TABLE 7–4

Elements on File Associations Preference Tool

Element

Description

Table

To view the contents of a category of file types, click on the right
arrow next to the category name. The category expands, and
displays a description of each file type, and the file extension that is
associated with the file type.
To select a file type that you want to work with, click on the file
type.

Add File Type

Click on this button to add a file type. For more information, see
“To Add a File Type” on page 120.

Add Service

Click on this button to add a service. For more information, see “To
Add a Service” on page 121.

Edit

To edit a file type, a service, or a file type category, select the item
that you want to edit, then click Edit.
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TABLE 7–4

Elements on File Associations Preference Tool

(Continued)

Element

Description

Remove

To delete a file type or a service, select the item that you want to
delete, then click Remove.

To Add a File Type
To add a file type, perform the following steps:
1. Start the File Associations preference tool.
2. Click on the Add File Type button.
3. Enter the properties of the file type in the Add File Type dialog. The following
table describes the dialog elements of the Add File Type dialog:
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Dialog Element

Description

No Icon

Choose an icon to represent the file type. To choose an
icon, click on the No Icon button. An icon selector
dialog is displayed. Choose an icon from the dialog.
Alternatively, to choose an icon from another directory,
click Browse. When you choose an icon, click OK.

Description

Type a description of the file type.

MIME type

Enter the MIME type for this type of file.

Category

Enter the category to which you want the file type to
belong in this preference tool. Click on the Choose to
choose a category from the Choose a file category
dialog.

Filename extensions

Enter the file extensions to associate with the file type.
Enter a file extension in the field on the left side, then
press Return. To delete a file extension, select the file
extension in the field on the right side, then click on the
Remove button.

Viewer component

Select the viewer component to use to display files of
this type in the file manager.

Default action

Select the default application to use to open files of this
type.
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Dialog Element

Description

Program to run

Specify a program to associate with the file type. Enter
the command to start the program in this field.
Alternatively, to choose a command that you entered
previously, click the down arrow button, then choose
the command to run.
You can also use the Browse button to choose a
command to run.

Run in Terminal

Select this option to run the program in a terminal
window. Choose this option for a program that does not
create a window in which to run.

4. Click OK.

To Add a Service
To add a service, perform the following steps:
1. Start the File Associations preference tool.
2. Click on the Add Service button.
3. Enter the properties of the service in the Add Service dialog. The following table
describes the dialog elements on the Add Service dialog:

Dialog Element

Description

Description

Type a description of the service.

Protocol

Enter the protocol for the service.

Program to Run

Information to be supplied in a future release.

Program

Specify the program to associate with the service.
Enter the command to start the program in this
field. Alternatively, to choose a command that you
entered previously, click the down arrow button,
then choose the command to run.
You can also use the Browse button to choose a
command to run.

Run in Terminal

Select this option to run the program in a terminal
window. Choose this option for a program that does
not create a window in which to run.

4. Click OK.
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Setting Folder Preferences
You can customize your folders to suit your requirements and preferences. This
section describes how to customize your folder preferences.

Setting Your Preferences
To access the Folders preference tool, click Launch, then choose Preferences →
Desktop Preferences → Folders.
Alternatively, you can use the Folders Preferences dialog to set preferences for the file
manager. To display the Folder Preferences dialog, choose Edit → Preferences from
any file browser window.
You can set preferences in the following categories:
■
■
■
■

The default settings for views.
The behavior of files and folders, executable text files, and Trash.
The information that is displayed in icon captions.
Preview options to improve the performance of the file manager.

To Set Views Preferences
You can specify a default view, and select sort options and display options. You can
also specify default settings for icon views and list views. To specify your default view
settings, choose Edit → Preferences. Click on the Views tab to display the Views
tabbed section.
Table 7–5 lists the views preferences that you can modify.
TABLE 7–5 Views Preferences
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Dialog Element

Description

View new folders using

Select the default view for folders. When you open a folder,
the folder is displayed in the view that you select.

Arrange items

Select the characteristic by which you want to sort the items
in folders that are displayed in this view.

Sort folders before files

Select this option to list folders before files when you sort a
folder.
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TABLE 7–5 Views Preferences

(Continued)

Dialog Element

Description

Show hidden and backup files

Select this option to display hidden files and backup files in
the view pane. The first character in a hidden filename is a
period (.). The last character in a backup filename is a tilde
(~).
You can hide files from the view pane by adding .hidden
extension to the filename.

Default zoom level

Icon view and list view. Select the default zoom level for
folders that are displayed in this view. The zoom level
specifies the size of items in a view.

Use compact layout

Select this option to arrange the items in icon view so that
the items in the folder are closer to each other.

Text beside icons

Select this option to place the icon captions for items beside
the icon rather than under the icon.

Show only folders

Select this option to display only folders in the Tree in the
side pane.

To Set Behavior Preferences
To set your preferences for files and folders, choose Edit → Preferences. Click on the
Behavior tab to display the Behavior tabbed section.
Table 7–6 lists the preferences that you can modify for files and folders.
TABLE 7–6

File and Folder Behavior Preferences

Option

Description

Single click to activate items

Select this option to perform the default action for an item
when you click on the item. When this option is selected,
and you point to an item, the title of the item is underlined.

Double click to activate items

Select this option to perform the default action for an item
when you double-click on the item.

Run executable files when they
are clicked

Select this option to run an executable file when you choose
the executable file. An executable file is a text file that can
execute, that is, a shell script.

View executable files when
they are clicked

Select this option to display the contents of an executable
file when you choose the executable file.

Ask each time

Select this option to display a dialog when you choose an
executable file. The dialog asks whether you want to execute
the file or display the file.
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TABLE 7–6

File and Folder Behavior Preferences

(Continued)

Option

Description

Ask before emptying the Trash
or deleting files

Select this option to display a confirmation message before
Trash is emptied, or files are deleted.

Include a Delete command that
bypasses Trash

Select this option to add a Delete menu item to the
following menus:
■
The Edit menu.
■
The popup menu that is displayed when you right-click
on a file, folder, or desktop background object.
When you select an item then choose the Delete menu item,
the item is deleted from your file system immediately.

To Set Icon Captions Preferences
An icon caption displays the name of a file or folder in an icon view. The icon caption
also includes three additional items of information on the file or folder. The additional
information is displayed after the file name. Normally only one item of information is
visible, but when you zoom in on an icon, more of the information is displayed. You
can modify what additional information is displayed in icon captions.
To set your preferences for icon captions, choose Edit → Preferences. Click on the Icon
Caption tab to display the Icon Caption tabbed section.
Select the items of information that you want to display in the icon caption from the
three drop-down lists. Select the first item from the first drop-down list, select the
second item from the second drop-down list, and so on. The following table describes
the items of information that you can select:
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Information

Description

Size

Choose this option to display the size of the item.

Type

Choose this option to display the description of the MIME
type of the item from the File Types and Programs
preference tool.

Date modified

Choose this option to display the last modification date of
the item.

Date accessed

Choose this option to display the date that the item was last
accessed.

Owner

Choose this option to display the owner of the item.

Group

Choose this option to display the group to which the item
belongs.
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Information

Description

Permissions

Choose this option to display the permissions of the item as
three sets of three characters, for example -rwxrw-r--.

Octal permissions

Choose this option to display the permissions of the item in
octal notation, for example 764.

MIME type

Choose this option to display the MIME type of the item.

None

Choose this option to display no information for the item.

To Set List Columns Preferences
You can specify what information is displayed in list view in file manager windows.
You can specify which columns are displayed in list view, and the order in which the
columns are displayed.
To set your preferences for list columns, choose Edit → Preferences. Click on the List
Columns tab to display the List Columns tabbed section.
To specify a column to display in list view, select the option that corresponds to the
column, then click on the Show button. To remove a column from the list view, select
the option that corresponds to the column, then click on the Hide button.
Use the Move Up and Move Down buttons to specify the position of columns in list
view.
To use the default columns and column positions, click on the Use Default button.
The following table describes the columns that you can display:

Information

Description

Name

Select this option to display the name of the item.

Size

Select this option to display the size of the item.

Type

Select this option to display the description of the MIME
type of the item from the File Types and Programs
preference tool.

Date Modified

Select this option to display the last modification date of the
item.

Date Accessed

Select this option to display the date that the item was last
accessed.

Group

Select this option to display the group to which the item
belongs.
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Information

Description

MIME type

Select this option to display the MIME type of the item.

Octal Permissions

Select this option to display the permissions of the item in
octal notation, for example 764.

Owner

Select this option to display the owner of the item.

Permissions

Select this option to display the permissions of the item as
three sets of three characters, for example -rwxrw-r--.

To Set Preview Preferences
The file manager include some file preview features. The preview features can affect
the speed with which the file manager responds to your requests. You can modify the
behavior of some of these features to improve the speed of the file manager. For each
preview preference, you can select one of the options described in the following table:

Option

Description

Always

Performs the action for both local files, and files on other file
systems.

Local Files Only

Performs the action for local files only.

Never

Never performs the action.

To set your preview preferences, choose Edit → Preferences. Click on the Preview tab
dialog to display the Preview tabbed section.
Table 7–7 lists the preview preferences that you can modify.
TABLE 7–7 Preview Preferences
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Dialog Element

Description

Show text in icons

Select an option to specify when to preview the content of
text files in the icon that represents the file.

Show thumbnails

Select an option to specify when to show thumbnails of
image files. The file manager stores the thumbnail files for
each folder in a .thumbnails directory that is one level
below the folder.

Only for files smaller than

Specify the maximum file size for files for which the file
manager creates a thumbnail.

Preview sound files

Select an option to specify when to preview sound files.
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TABLE 7–7 Preview Preferences

(Continued)

Dialog Element

Description

Count number of items

Select an option to specify when to show the number of
items in folders. If you have set your view to icon view, you
might need to increase your default zoom level in the Views
tabbed section to see the number of items in each folder.

Changing Backgrounds
The file manager includes backgrounds that you can use to change the look-and-feel of
the following screen components:
■
■
■

Desktop
Side pane and view pane of file browser windows
Panels

To change the background of a screen component perform the following steps:
1. Choose Edit → Backgrounds and Emblems.
2. To display a list of patterns that you can use on the background, click on the
Patterns button in the Backgrounds and Emblems dialog. To display a list of the
colors that you can use on the background, click on the Colors button.
3. To change the background to a pattern, drag the pattern to the screen component.
To change the background to a color, drag the color to the screen component.
4. Click Close.
To reset the background of the view pane or side pane to the default background,
right-click on the background of the pane, then choose Use Default Background.
When you change the background of the side pane or the view pane of a particular
folder, the file manager remembers the background that you chose. The next time that
you display the folder, the background that you selected is displayed. In other words,
when you change the background of a folder, you customize the folder to display the
background.

To Add a Pattern
To add a pattern to the patterns that you can use on your screen components, choose
Edit → Backgrounds and Emblems. Click on the Patterns button, then click on the Add
a New Pattern button. A dialog is displayed. Use the dialog to find the new pattern.
Click OK to add the new pattern to the Backgrounds and Emblems dialog.
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To Add a Color
To add a color to the colors that you can use on your screen components, choose Edit
→ Backgrounds and Emblems. Click on the Colors button, then click on the Add a
New Color button. A color selector dialog is displayed. Use the color wheel or the
sliders to choose the color. Click OK to add the new color to the Backgrounds and
Emblems dialog.

Choosing Default Fonts
To access the Fonts preference tool, click Launch, then choose Preferences → Desktop
Preferences → Display → Fonts.
Use the Fonts preference tool to select the fonts to use in your applications, windows,
terminals, and desktop background.
Table 7–8 lists the font preferences that you can modify.
TABLE 7–8 Font Preferences
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Dialog Element

Description

Application font

Click on the font selector button to select a font to use in your
applications.

Desktop font

Click on the font selector button to select a font to use on your
desktop background only.

Window title font

Click on the font selector button to select a font to use in the
titlebars of your windows.

Terminal font

Click on the font selector button to select a font to use in the
Terminal application
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TABLE 7–8 Font Preferences

(Continued)

Dialog Element

Description

Font Rendering

To specify how to render fonts on your screen, select one of the
following options:
■
Monochrome: Renders fonts in black and white only. The
edges of characters might appear jagged in some cases
because the characters are not antialiased. Antialiasing is an
effect that is applied to the edges of characters to make the
characters look smoother.
■
Best shapes: Antialiases fonts where possible. Use this option
for standard Cathode Ray Tube (CRT) monitors.
■
Best contrast: Adjusts fonts to give the sharpest possible
contrast, and also antialiases fonts, so that characters have
smooth edges. This option might enhance the accessibility of
the Java Desktop System to users with visual impairments.
■
Subpixel smoothing (LCDs): Uses techniques that exploit the
shape of individual Liquid Crystal Display (LCD) pixels to
render fonts smoothly. Use this option for LCD or flat-screen
displays.

Details

Click on this button to specify further details of how to render
fonts on your screen.
■
Resolution (dots per inch): Use the spin box to specify the
resolution to use when your screen renders fonts.
■
Smoothing: Select one of the options to specify how to
antialias fonts.
■
Hinting: Hinting is a font-rendering technique that improves
the quality of fonts at small sizes and an at low screen
resolutions. Select one of the options to specify how to apply
hinting to your fonts.
■
Subpixel order: Select one of the options to specify the
subpixel color order for your fonts. Use this option for LCD or
flat-screen displays.

Configuring Your Proxy Connection
To access the Proxy Configuration preference tool, click Launch, then choose
Preferences → Desktop Preferences → Proxy Configuration.
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The Proxy Configuration preference tool enables you to configure how your system
connects to the Internet. You can configure the Java Desktop System to connect to a
proxy server, and specify the details of the proxy server. A proxy server is a server that
intercepts requests to another server, and fulfills the request itself, if it can. You can
enter the Domain Name Service (DNS) name or the Internet Protocol (IP) address of
the proxy server. A DNS name is a unique alphabetic identifier for a computer on a
network. An IP address is a unique numeric identifier for a computer on a network.
Table 7–9 lists the proxy configuration preferences that you can modify.
TABLE 7–9 Internet Preferences
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Dialog Element

Description

Direct internet connection

Select this option if you want to connect directly to the
Internet, without a proxy server.

Manual proxy configuration

Select this option if you want to connect to the Internet
through a proxy server, and you want to configure the
proxy server manually.

HTTP proxy

Enter the DNS name, or the IP address of the proxy server
to use when you request a HTTP service. Enter the port
number of the HTTP service on the proxy server in the Port
spin box.

Secure HTTP proxy

Enter the DNS name, or the IP address of the proxy server
to use when you request a Secure HTTP service. Enter the
port number of the Secure HTTP service on the proxy server
in the Port spin box.

FTP proxy

Enter the DNS name, or the IP address of the proxy server
to use when you request a FTP service. Enter the port
number of the FTP service on the proxy server in the Port
spin box.

Socks host

Enter the DNS name, or the IP address of the Socks host to
use. Enter the port number for the Socks protocol on the
proxy server in the Port spin box.

Automatic proxy configuration

Select this option if you want to connect to the Internet
through a proxy server, and you want to configure the
proxy server automatically.

Autoconfiguration URL

Enter the URL that contains the information required to
configure the proxy server automatically.
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Configuring Keyboard Accessibility
Options
To access the Keyboard accessibility preference tool, click Launch, then choose
Preferences → Accessibility → Keyboard.
Use the Keyboard accessibility preference tool to set the keyboard accessibility
preferences. The Keyboard accessibility preference tool is also known as AccessX.
You can customize the preferences for the keyboard accessibility in the following
functional areas:
■
■
■

Basic
Filters
Mouse

Basic Preferences
Table 7–10 lists the basic keyboard accessibility preferences that you can modify.
TABLE 7–10

Keyboard Accessibility Preferences

Dialog Element

Description

Enable keyboard
accessibility features

Select this option to enable keyboard accessibility features. When you
select this option, the other options in the preference tool become
available.

Disable if unused for

Select this option to deactivate keyboard accessibility preferences if
the keyboard is not used for a specified period of time. Use the slider
to specify the number of seconds of keyboard idle time required
before the system disables the keyboard accessibility preferences.
When the specified number of seconds elapses, the following
keyboard accessibility preferences are disabled:
■
Bounce keys
■
Mouse keys
■
Slow keys
■
Sticky keys
■
Toggle keys

Beep when features
turned on or off from
keyboard

Select this option for an audible indication when a feature such as
sticky keys or slow keys is activated, or deactivated.

Import Feature Settings Click on this button to import an AccessX configuration file.
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TABLE 7–10

Keyboard Accessibility Preferences

(Continued)

Dialog Element

Description

Enable Sticky Keys

Select this option to perform multiple simultaneous keypress
operations by pressing the keys in sequence. Alternatively, to enable
the sticky keys feature, press Shift five times.
You can set the following sticky keys preferences:
Beep when modifier is pressed: Select this option for an audible
indication when you press a modifier key.
■
Disable if two keys pressed together: Select this option to specify
that when you press two keys simultaneously, you can no longer
press keys in sequence to perform multiple simultaneous
keypresses.
■

Repeat Keys

Select this option to enable the autorepeat settings for your keyboard.
You can set the following autorepeat preferences:
■
Delay: Use the slider or the spin box to specify the interval to wait
after the first keypress before the automatic repeat of a pressed
key.
■
Speed: Use the slider or the spin box to specify the number of
characters per second to enter.

Type to test settings

The test area is an interactive interface so you can see how the
keyboard settings affect the display as you type. Type text in the test
area to test the effect of your settings.

For more information on configuring basic keyboard accessibility preferences, see the
Java Desktop System Release 3 Accessibility Guide.

Filter Preferences
Table 7–11 lists the filter preferences that you can modify.
TABLE 7–11 Filter Preferences
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Dialog Element

Description

Enable keyboard
accessibility features

Select this option to enable keyboard accessibility features. When you
select this option, the other options in the preference tool become
available.
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TABLE 7–11 Filter Preferences

(Continued)

Dialog Element

Description

Enable Slow Keys

Select this option to control the period of time that you must
press-and-hold a key before acceptance. Alternatively, to enable the
slow keys feature, press-and-hold Shift for eight seconds.
You can set the following slow keys preferences:
Only accept keys held for: Use the slider or the spin box to
specify the period of time that you must press-and-hold a key
before acceptance.
■
Beep when key is: Select the appropriate option or options for an
audible indication when a key is pressed, accepted, or rejected.
■

Enable Bounce Keys

Select this option to accept a key input and to control the key repeat
characteristics of the keyboard. You can set the following bounce keys
preferences:
■
Ignore duplicate keypresses within: Use the slider or the spin
box to specify the interval to wait after the first keypress before
the automatic repeat of a pressed key.
■
Beep if key is rejected: Select this option for an audible indication
of key rejection.

Enable Toggle Keys

Select this option for an audible indication of a toggle keypress. You
hear one beep when a toggle key is turned on. You hear two beeps
when a toggle key is turned off.

Type to test settings

The test area is an interactive interface so you can see how the
keyboard settings affect the display as you type. Type text in the test
area to test the effect of your settings.

For more information on configuring filter accessibility preferences, see the Java
Desktop System Release 3 Accessibility Guide.

Mouse Preferences
Table 7–12 lists the mouse preferences that you can modify.
TABLE 7–12 Mouse Preferences
Dialog Element

Description

Enable keyboard
accessibility features

Select this option to enable keyboard accessibility features. When you
select this option, the other options in the preference tool become
available.
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TABLE 7–12 Mouse Preferences

(Continued)

Dialog Element

Description

Enable Mouse Keys

Select this option to make the numeric keypad emulate mouse
actions. You can set the following mouse key preferences:
■
Maximum pointer speed: Use the slider or the spin box to specify
the maximum speed that the pointer moves across the screen.
■
Time to accelerate to maximum speed: Use the slider or the spin
box to specify the duration of the acceleration time of the pointer.
■
Delay between keypress and pointer movement: Use the slider
or the spin box to specify the period of time that must pass after a
keypress before the pointer moves.

Mouse Preferences

Click on this button to open the Mouse preference tool.

For more information on configuring the mouse accessibility preferences, see the Java
Desktop System Release 3 Accessibility Guide.

Configuring Keyboard Behavior
Preferences
To access the Keyboard preference tool, click Launch, then choose Preferences →
Desktop Preferences → Keyboard → Behavior.
Use the Keyboard Behavior preference tool to modify the autorepeat preferences for
your keyboard, and to configure typing break settings.
You can set the preferences for the Keyboard Behavior preference tool in the following
functional areas:
■
■
■
■

Keyboard
Typing Break
Layouts
Layout Options

Keyboard Preferences
Use the Keyboard tabbed section to set general keyboard preferences. To start the
Keyboard accessibility preference tool, that is, AccessX, click on the Accessibility
button.
Table 7–13 lists the keyboard preferences that you can modify.
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TABLE 7–13 Keyboard Preferences
Dialog Element

Description

Key presses repeat when
key is held down

Select this option to enable keyboard repeat. If keyboard repeat is
enabled, when you press-and-hold a key, the action associated
with the key is performed repeatedly. For example, if you
press-and-hold a character key, the character is typed repeatedly.

Delay

Select the delay from the time you press a key to the time that the
action repeats.

Speed

Select the speed at which the action is repeated.

Cursor blinks in text
boxes and fields

Select this option to enable the cursor to blink in fields and text
boxes.

Speed

Use the slider to specify the speed at which the cursor blinks in
fields and text boxes.

Type to test settings

The test area is an interactive interface so you can see how the
keyboard settings affect the display as you type. Type text in the
test area to test the effect of your settings.

Typing Break Preferences
Use the Typing Break tabbed section to set typing break preferences. To start the
Keyboard accessibility preference tool, that is, AccessX, click on the Accessibility
button.
Table 7–14 lists the typing break preferences that you can modify.
TABLE 7–14

Typing Break Preferences

Dialog Element

Description

Lock screen to enforce typing break

Select this option to lock the screen when you
are due a typing break.

Work interval lasts

Use the spin box to specify how long you can
work before a typing break occurs.

Break interval lasts

Use the spin box to specify the length of your
typing breaks.

Allow postponing of breaks

Select this option if you want to be able to
postpone typing breaks.
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Keyboard Layout
Use the Layouts tabbed section to set your keyboard layout. Select your keyboard
model from the drop-down list. Use the navigational buttons to add or remove a
selected layout from the list of available layouts.
You can choose different layouts to suit different locales.
To start the Keyboard accessibility preference tool, that is, AccessX, click on the
Accessibility button.

Keyboard Layout Options
Use the Layout Options tabbed section to set your keyboard layout options. Select an
option from the list of available layout options and click Add to select an option. Use
Remove to remove a selected option.
To start the Keyboard accessibility preference tool, that is, AccessX, click on the
Accessibility button.

Customizing Menus and Toolbars in
Applications
To access the Menus & Toolbars preference tool, click Launch, then choose
Preferences → Desktop Preferences → Display → Menus & Toolbars.
You can use the Menus & Toolbars preference tool to customize the appearance of
menus, menubars, and toolbars for GNOME-compliant applications.
Table 7–15 lists the menu and toolbar preferences that you can modify for
GNOME-compliant applications.
TABLE 7–15
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Menu and Toolbar Preferences

Dialog Element

Description

Show icons in menus

Select this option to display an icon beside each item in a menu.
Some menu items do not have an icon.
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TABLE 7–15

Menu and Toolbar Preferences

(Continued)

Dialog Element

Description

Detachable toolbars

Select this option if you want to move toolbars from application
windows to any location on the screen. If you select this option,
handles are displayed on the left side of the toolbars in your
applications. To move a toolbar, click-and-hold on the handle, then
drag the toolbar to the new location.

Toolbar button labels

Choose one of the following options to specify what to display on
the toolbars in your GNOME-compliant applications:
■
Text below icons: Select this option to display toolbars with text
as well as an icon on each button.
■
Text beside icons: Select this option to display toolbars with an
icon only on each button, and with text on the most important
buttons.
■
Icons only: Select this option to display toolbars with an icon
only on each button.
■
Text only: Select this option to display toolbars with text only
on each button.

Setting Mouse Preferences
To access the Mouse preference tool, click Launch, then choose Preferences → Desktop
Preferences → Mouse.
Use the Mouse preference tool to configure your mouse for right-hand use or for
left-hand use. You can also specify the speed and sensitivity of mouse movement.
You can customize the settings for the Mouse preference tool in the following
functional areas:
■
■
■

Buttons
Cursors
Motion

Buttons Preferences
Use the Buttons tabbed section to specify whether the mouse buttons are configured
for left-hand use. You can also specify the delay between clicks for a double-click.
Table 7–16 lists the mouse button preferences that you can modify.
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TABLE 7–16

Mouse Button Preferences

Dialog Element

Description

Left-handed mouse

Select this option to configure your mouse for left-hand use.
When you configure your mouse for left-hand use, the functions
of the left mouse button and the right mouse button are swapped.

Timeout

Use the slider to specify the amount of time that can pass between
clicks when you double-click. If the interval between the first and
second clicks exceeds the time that is specified here, the action is
not interpreted as a double-click.

Pointer Preferences
Use the Cursors tabbed section to set your mouse pointer preferences.
Table 7–17 lists the mouse pointer preferences that you can modify:
TABLE 7–17

Mouse Pointer Preferences

Dialog Element

Description

Small

Select this option to display a small mouse
pointer.

Medium

Select this option to display a medium mouse
pointer.

Large

Select this option to display a large mouse
pointer.

Highlight the pointer when you press Ctrl

Select this option to enable a mouse pointer
animation when you press and release Ctrl.
This feature can assist you to locate the mouse
pointer.

Motion Preferences
Use the Motion tabbed section to set your preferences for mouse movement.
Table 7–18 lists the mouse motion preferences that you can modify:
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TABLE 7–18

Mouse Motion Preferences

Dialog Element

Description

Acceleration

Use the slider to specify the speed at which your mouse pointer
moves on your screen when you move your mouse.

Sensitivity

Use the slider to specify how sensitive your mouse pointer is to
movements of your mouse.

Threshold

Use the slider to specify the distance that you must move an item
before the move action is interpreted as a drag-and-drop action.

Customizing Your Panels
To access the Panel preference tool, click Launch, then choose Preferences → Desktop
Preferences → Panel.
The Panel preference tool enables you to configure the behavior of panels. Any
changes that you make with the Panel preference tool affect all of your panels.
Table 7–19 lists the panel preferences that you can modify:
TABLE 7–19 Panel Preferences
Dialog Element

Description

Close drawer when launcher is clicked

Select this option if you want a drawer on a
panel to close when you choose a launcher in
the drawer.

Drawer and panel animation

Select this option if you want your panels and
drawers to show and to hide in an animated
style.

Animation speed

Select the speed of the panel animation from
the drop-down list.

Choosing Your Preferred Applications
To access the Preferred Applications preference tool, click Launch, then choose
Preferences → Desktop Preferences → Preferred Applications.
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Use the Preferred Applications preference tool to specify the applications that you
want the Java Desktop System to use when the preferred application starts. For
example, you can specify Xterm as your preferred terminal application. When you
click Launch, then choose Applications → Utilities → Terminal, Xterm starts.
You can customize the preferences for the Preferred Applications preference tool in the
following functional areas.
■
■
■
■

Web Browser
Mail Reader
Text Editor
Terminal

Web Browser Preferences
Use the Web Browser tabbed section to configure your preferred web browser. The
preferred web browser opens when you click on a URL. For example, the preferred
web browser opens when you select a URL in an application, or when you select a
URL launcher on the desktop background.
Table 7–20 lists the preferred web browser preferences that you can modify.
TABLE 7–20

Preferred Web Browser Preferences

Dialog Element

Description

Select a Web Browser

Select this option if you want to use a standard web browser. Use
the drop-down combination box to select your preferred web
browser.

Custom Web Browser

Select this option if you want to use a custom web browser.

Command

Enter the command to execute to start the custom web browser. To
enable the browser to display a URL that you click on, include
“%s” after the command.

Start in Terminal

Select this option to run the command in a terminal window. Select
this option for a browser that does not create a window in which to
run.

Email Client Preferences
Use the Mail Reader tabbed section to configure your preferred email client.
Table 7–21 lists the preferred email client preferences that you can modify.
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TABLE 7–21

Preferred Email Client Preferences

Dialog Element

Description

Select a Mail Reader

Select this option if you want to use a standard email client. Use the
drop-down combination box to select your preferred email client.

Custom Mail Reader

Select this option if you want to use a custom email client.

Command

Enter the command to execute to start the custom email client.

Start in Terminal

Select this option to run the command in a terminal window. Select
this option for an email client that does not create a window in
which to run.

Text Editor Preferences
Use the Text Editor tabbed section to configure your preferred text editor.
Table 7–22 lists the preferred text editor preferences that you can modify.
TABLE 7–22

Preferred Text Editor Preferences

Dialog Element

Description

Select an Editor

Select this option if you want to use a standard text editor. Use the
drop-down combination box to specify your preferred text editor.

Custom Editor

Select this option if you want to use a custom text editor. A Custom
Editor Properties dialog is displayed.
■
Name: Type the name of the custom text editor.
■
Command: Enter the command to start the custom text editor.
■
This application can open multiple files: Select this option if
the default text editor can open multiple files.
■
This application needs to be run in a shell: Select this option to
run the command in a terminal window. Select this option for
an editor that does not create a window in which to run.
After you specify a custom text editor, you can click on the
Properties button to display the Custom Editor Properties dialog.
You can use the dialog to modify the properties of the custom text
editor.

Use this editor to open
text files in the file
manager

Select this option if you want the file manager to start the custom
text editor to display text files.
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Terminal Preferences
Use the Terminal tabbed section to configure your preferred terminal.
Table 7–23 lists the preferred terminal preferences that you can modify.
TABLE 7–23

Preferred Terminal Preferences

Dialog Element

Description

Select a Terminal

Select this option if you want to use a standard terminal. Use the
drop-down combination box to specify your preferred terminal.

Custom Terminal

Select this option if you want to use a custom terminal.

Command

Enter the command to execute to start the custom terminal.

Exec Flag

Enter the exec option to use with the command.

Setting Screen Resolution Preferences
To access the Screen Resolution preference tool, click Launch, then choose Preferences
→ Desktop Preferences → Display → Screen Resolution.
Use the Screen Resolution preference tool to specify the resolution settings for your
screen. Table 7–24 lists the screen resolution preferences that you can modify.
TABLE 7–24
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Screen Resolution Preferences

Dialog Element

Description

Resolution

Select the resolution to use for the screen from
the drop-down list.

Refresh rate

Select the screen refresh rate to use for the
screen from the drop-down list.

Make default for this computer only

Select this option to make the screen
resolution settings the default settings for the
system that you are logged in to only.
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Setting Screensaver Preferences
To access the Screensaver preference tool, click Launch, then choose Preferences →
Desktop Preferences → Display → Screensaver.
A screensaver is an application that you can use to replace the image on your screen
when the screen is not in use. You can use screensavers in the following ways:
■
■
■

Activate after a specified period of idle time.
Activate when you lock your screen.
Manage power used by your monitor when your system is idle.

You can customize the settings for the Screensaver preference tool in the following
functional areas:
■
■

Display Modes
Advanced

Display Modes Preferences
Use the Display Modes tabbed section to set display mode preferences.
Table 7–25 lists the display mode preferences that you can modify.
TABLE 7–25

Screensaver Display Mode Preferences

Dialog Element

Description

Mode

Use the drop-down list to specify the behavior of the
screensaver application. Select from the following options:
■
Disable Screen Saver: Select this option if you do not
want to use the screensaver application.
■
Blank Screen Only: Select this option if you want your
screen to become blank when your screen locks.
■
Only One Screen Saver: Select this option if you want
to display a single screensaver display from the display
list when your screen locks.
■
Random Screen Saver: Select this option if you want to
display a random selection of screensaver displays from
the screensaver display list when your screen locks.

Display list

Select the screensaver display that you require from the list.

Blank After

Specify how long to wait after the last use of the mouse or
keyboard, to activate the screensaver.
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TABLE 7–25

Screensaver Display Mode Preferences

(Continued)

Dialog Element

Description

Cycle After

Specify how long to show a particular screensaver display
before the next display.

Lock Screen After

Select this option if you want the screen to lock after the
screensaver is activated. Use the spin box to specify the
delay between the activation of the screensaver and when
the screen locks.

Preview

Click on this button to preview the screensaver display that
is selected in the screensaver display list. To stop the
preview, press any key or click a mouse button.

Settings

Click on this button to display the options for the
screensaver display that is selected in the screensaver
display list.

Advanced Preferences
Use the Advanced tabbed section to set advanced screensaver preferences.
Table 7–26 lists the advanced screensaver preferences that you can modify.
TABLE 7–26
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Advanced Screensaver Preferences

Dialog Element

Description

Grab Desktop Images

Some screensavers can take a screenshot of your screen,
then manipulate the screenshot to create your
screensaver display. Select this option to enable
screensavers to take a screenshot of your screen.

Grab Video Frames

Some screensavers can capture a frame of video, then
manipulate the captured image to create your
screensaver display. If your system has a video capture
card, select this option to enable screensavers to capture
a frame of video.

Choose Random Image

Select this option to enable screensavers to use images
from a directory that you select. Type the path for the
directory in the field. Alternatively, click Browse to
display a dialog from which you can select a directory.

Verbose Diagnostics

Select this option if you want to display screensaver
diagnostic information.

Display Subprocess Errors

Select this option if you want to display errors related
to screensaver subprocesses on screen.
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TABLE 7–26

Advanced Screensaver Preferences

(Continued)

Dialog Element

Description

Display Splash Screen at Startup

Select this option if you want Xscreensaver to display a
splash dialog when Xscreensaver starts.

Power Management Enabled

Select this option to enable power management of your
monitor. Power management can reduce energy
consumption by your monitor when you are not using
the monitor.

Standby After

Specify how long to wait to put the monitor in standby
mode. When the monitor is in standby mode, the
screen is black.

Suspend After

Specify how long to wait to put the monitor in
power-saving mode.

Off After

Specify how long to wait to switch off monitor.

Install Colormap

Select this option to install a private colormap when the
screensaver is active. Use of a private colormap might
improve the quality of the color in particular
screensaver displays.

Fade to Black When Blanking

Select this option if you want your display to fade to
black when the screensaver activates.

Fade from Black When Unblanking

Select this option if you want your display to fade from
black to the screen contents when the screensaver stops.

Fade Duration

Specify how long to take to fade to black when the
screensaver activates.

Configuring Sessions
To access the Sessions preference tool, click Launch, then choose Preferences →
Desktop Preferences → Sessions.
The Sessions preference tool enables you to manage your sessions. You can set session
preferences, and specify which applications to start when you start a session. You can
configure sessions to save the state of applications in the Java Desktop System, and to
restore the state when you start another session. You can also use this preference tool
to manage multiple Java Desktop System sessions.
You can customize the settings for sessions and startup applications in the following
functional areas:
■

Session Options
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■
■

Current Session
Startup Programs

Setting Session Preferences
Use the Session Options tabbed section to manage multiple sessions, and to set
preferences for the current session.
Table 7–27 lists the session options that you can modify.
TABLE 7–27 Session Options
Dialog Element

Description

Show splash screen on
login

Select this option to display a splash screen when you start a
session.

Prompt on logout

Select this option to display a confirmation dialog when you end a
session.

Automatically save
changes to session

Select this option if you want the session manager to save the
current state of your session. The session manager saves the
session-managed applications that are open, and the settings
associated with the session-managed applications. The next time
that you start a session, the applications start automatically, with
the saved settings.
If you do not select this option, when you end you session the
Logout Confirmation dialog displays a Save current setup option.

Sessions

Use this area of the dialog to manage multiple sessions in the Java
Desktop System, as follows:
■
To create a new session, click on the Add button. Use the Add a
new session dialog to specify a name for your session.
■
To change the name of a session, select the session in the
Choose Current Session table. Click on the Edit button. The
Edit session name dialog is displayed. Type a new name for
your session.
■
To delete a session, select the session in the Choose Current
Session table. Click on the Delete button.

Setting Session Properties
Use the Current Session tabbed section to specify startup order values, and to choose
restart styles for the session-managed applications in your current session.
Table 7–28 lists the session properties that you can configure.
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TABLE 7–28 Session Properties
Dialog Element

Description

Order

The Order property specifies the order in which the session
manager starts session-managed startup applications. The session
manager starts applications with lower order values first. The
default value is 50.
To specify the startup order of an application, select the application
in the table. Use the Order spin box to specify the startup order
value.

Style

The Style property determines the restart style of an application. To
select a restart style for an application, select the application in the
table, then choose one of the following styles:
■
Normal
Starts automatically when you start a Java Desktop System
session. Use the kill command to terminate applications with
this restart style during a session.
■
Restart
Restarts automatically whenever you close or terminate the
application. Choose this style for an application if the
application must run continuously during your session. To
terminate an application with this restart style, select the
application in the table, then click on the Remove button.
■
Trash
Does not start when you start a Java Desktop System session.
■
Settings
Starts automatically when you start a session. Applications with
this style usually have a low startup order, and store your
configuration settings for the Java Desktop System and
session-managed applications.

Remove

Click on the Remove button to delete the selected application from
the list. The application is removed from the session manager, and
closed. Applications that you delete are not started the next time
that you start a session.

Apply

Click on the Apply button to apply changes to the startup order and
the restart style.

Configuring Startup Applications
Use the Startup Programs tabbed section of the Sessions preference tool to specify
non-session-managed startup applications. Startup applications are applications that
start automatically when you start a session. You specify the commands that run the
non-session-managed applications in the Startup Programs tabbed section. The
commands execute automatically when you log in.
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You can also start session-managed applications automatically. For more information,
see “Setting Session Preferences” on page 146.
Table 7–29 lists the startup applications preferences that you can modify.
TABLE 7–29

Startup Programs Preferences

Dialog Element

Description

Additional startup
programs

Use this table to manage non-session-managed startup applications
as follows:
■
To add a startup application, click on the Add button. The Add
Startup Program dialog is displayed. Enter the command to
start the application in the Startup Command field.
If you specify more than one startup application, use the Order
spin box to specify the startup order of the each application. The
startup order is the order in which you want the startup
applications to start.
■
To edit a startup application, select the startup application, then
click on the Edit button. The Edit Startup Program dialog is
displayed. Use the dialog to modify the command and the
startup order for the startup application.
■
To delete a startup application, select the startup application,
then click on the Delete button.

Customizing Keyboard Shortcuts
To access the Shortcuts preference tool, click Launch, then choose Preferences →
Desktop Preferences → Keyboard → Shortcuts.
A keyboard shortcut is a key or combination of keys that provides an alternative to
standard ways of performing an action.
Use the Shortcuts preference tool to display the default keyboard shortcuts. You can
customize the default keyboard shortcuts to your requirements. In addition, you can
also set shortcut key preferences for multimedia functions.
You can also create hot keys on Solaris systems. Hot keys are keyboard shortcuts that
start applications.
Table 7–30 lists the keyboard shortcut settings that you can customize on Linux.
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TABLE 7–30

Keyboard Shortcuts Preferences on Linux

Dialog Element

Text editing shortcuts

Description

Select one of the following settings:
Default: Use this setting for standard shortcut keys.
■
Emacs: Use this setting for Emacs shortcut keys.
■

Desktop shortcuts

This table lists actions and the shortcut keys that are
associated with each action.
To change the shortcut keys for an action, click on the
action to select the action, then click on the shortcut for the
action. Press the keys that you want to associate with the
action.
To disable the shortcut keys for an action, click on the
action to select the action, then click on the shortcut for the
action. Press Back Space.

Table 7–31 lists the keyboard shortcut settings that you can customize on Solaris.
TABLE 7–31

Keyboard Shortcuts Preferences on Solaris

Dialog Element

Text editing shortcuts

Description

Select one of the following settings:
Default: Use this setting for standard shortcut keys.
■
Emacs: Use this setting for Emacs shortcut keys.
■

Desktop shortcuts

This table lists actions and the shortcut keys that are
associated with each action.
To change the shortcut keys for an action, click on the
action to select the action, then click on the shortcut for the
action. Press the keys that you want to associate with the
action.
To disable the shortcut keys for an action, click on the
action to select the action, then click on the shortcut for the
action. Press Back Space.
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TABLE 7–31

Keyboard Shortcuts Preferences on Solaris

(Continued)

Dialog Element

Description

Custom Shortcuts

To add a hot key, perform the following steps:
1. Click New. A Custom Binding dialog is displayed.
Enter the command to associate with the hot key in the
New Command field. Alternatively, to browse for the
command, click on the Browse button. When you have
selected the command, click OK. The command is
added to the Custom Shortcuts section of the Desktop
shortcuts table.
2. Click in the Shortcut column of the command in the
Custom bindings section of the Desktop shortcuts
table. Press the key or key combination that you want
to associate with the command.
To edit a hot key, select the hot key in the Custom
Shortcuts section of the Desktop shortcuts table, then click
Edit. Edit the command in the Custom Binding dialog.
To remove a hot key, select the hot key in the Custom
Shortcuts section of the Desktop shortcuts table, then click
Delete.

Use the Multimedia Keys preference tool to assign shortcut keys to an action.
Table 7–32 lists the shortcut key preferences that you can set for multimedia functions.
TABLE 7–32

Multimedia Keys Preferences

Dialog Element

Description

Multimedia keys table

To add the shortcut keys for an action, click on
the action to select the action, then press the
keys that you want to associate with the
action.
To disable the shortcut keys for an action, click
on the action to select the action, then press
Back Space.

Use PCM volume instead of Master volume
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Select this option if you want to use Pulse
Code Modulation (PCM) volume instead of
Master volume.

Setting Sound Preferences
To access the Sound preference tool, click Launch, then choose Preferences → Desktop
Preferences → Sound.
The Sound preference tool enables you to control when the Java Desktop System
sound server starts. You can also specify which sounds to play when particular events
occur.
You can customize the settings for the Sound preference tool in the following
functional areas:
■
■
■

General
Sound Events
System Bell

General Sound Preferences
Use the General tabbed section of the Sound preference tool to specify when to launch
the Java Desktop System sound server. You can also enable sound event functions.
Table 7–33 lists the general sound preferences that you can modify.
TABLE 7–33

General Sound Preferences

Dialog Element

Description

Enable sound server
startup

Select this option to start the sound server when you start a
session. When the sound server is active, the Java Desktop System
can play sounds.

Sounds for events

Select this option to play sounds when particular events occur in
the Java Desktop System. You can select this option only if the
Enable sound server startup option is selected.

Sound Event Preferences
Use the Sound Events tabbed section of the Sound preference tool to associate
particular sounds with particular events.
Note – You must select the Enable sound server startup option, and the Sounds for
events option before you can access the Sound Events tabbed section.
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Table 7–34 lists the sound events preferences that you can modify.
TABLE 7–34

Sound Event Preferences

Dialog Element

Description

Sounds table

Use the Sounds table to associate particular sounds with
particular events.
The Event column displays a hierarchical list of events that can
occur. To expand a category of events, click on the right arrow
beside a category of events.
The Sound File column lists the sound file that plays when the
event occurs.

Play

Click on this button to play the sound file that is associated with
the selected event.

Sound file drop-down
combination box, Browse

To associate a sound with an event, select the event in the Sounds
table. Enter the name of the sound file that you want to associate
with the selected event in the drop-down combination box.
Alternatively, click Browse to display a Select Sound File dialog.
Use the dialog to specify the sound file that you want to associate
with the selected event.
Note – You can only associate sound files in .wav format with

events.

System Bell Settings
Use the System Bell tabbed section to set your preferences for the system bell.
Some applications play a bell sound to indicate a keyboard input error. Use the
preferences in the System Bell tabbed section to configure the bell sound. Table 7–35
lists the system bell preferences that you can modify.
TABLE 7–35
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System Bell Preferences

Dialog Element

Description

Sound an audible bell

Select this option to enable the system bell.

Visual feedback

Select this option to enable visual feedback to indicate input
errors.

Flash window titlebar

Select this option if you want window titlebars to flash to indicate
an input error.

Flash entire screen

Select this option if you want the entire screen to flash to indicate
an input error.
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Customizing Themes
To access the Theme preference tool, click Launch, then choose Preferences → Desktop
Preferences → Display → Theme.
A theme is a group of coordinated settings that specifies the visual appearance of a
part of the Java Desktop System. You can choose themes to change the appearance of
the Java Desktop System. Use the Theme preference tool to select a theme. You can
choose from a list of available themes. The list of available themes includes several
themes for users with accessibility requirements.
A theme contains settings that affect different parts of the Java Desktop System, as
follows:
Controls

The controls setting for a theme determines the visual appearance
of windows, panels, and panel applications. The controls setting
also determines the visual appearance of the GNOME-compliant
interface items that appear on windows, panels, and panel
applications, such as menus, icons, and buttons. Some of the
controls setting options that are available are designed for special
accessibility needs. You can choose an option for the controls
setting from the Controls tabbed section in the Theme preference
tool.

Window frame

The window frame setting for a theme determines the appearance
of the frames around windows only. You can choose an option for
the window frame setting from the Window Border tabbed section
in the Theme preference tool.

Icon

The icon setting for a theme determines the appearance of the icons
on panels and the desktop background. You can choose an option
for the icon setting from the Icons tabbed section in the Theme
preference tool.

To Create a Custom Theme
The themes that are listed in the Theme preferences tool are different combinations of
controls options, window frame options, and icon options. You can create a custom
theme that uses different combinations of controls options, window frame options,
and icon options.
To create a custom theme, perform the following steps:
1. Start the Theme preference tool.
2. Select a theme in the list of themes.
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3. Click on the Theme Details button. A Theme Details dialog is displayed.
4. Select the controls option that you want to use in the custom theme from the list in
the Controls tabbed section. The list of available controls options includes several
options for users with accessibility requirements.
5. Click on the Window Border tab to display the Window Border tabbed section.
Select the window frame option that you want to use in the custom theme from the
list of available options. The list of available window frame options includes
several options for users with accessibility requirements.
6. Click on the Icons tab to display the Icons tabbed section. Select the icons option
that you want to use in the custom theme from the list of available options. The list
of available icons options includes several options for users with accessibility
requirements.
7. Click Close to close the Theme Details dialog.
8. On the Theme preferences tool, click on the Save Theme button.
9. Type a name and a short description for the custom theme in the Save Theme to
Disk dialog, then click Save. The custom theme now appears in your list of
available themes.

To Install a New Theme
You can add a theme to the list of available themes. The new theme must be an archive
file that is tarred and zipped. That is, the new theme must be a .tar.gz file.
To install a new theme, perform the following steps:
1. Start the Theme preference tool.
2. Click on the Install Theme button.
3. Enter the location of the theme archive file in the drop-down combination box of
the Install a Theme dialog. Alternatively, to browse for the file, click on the Browse
button. When you have selected the file, click OK.
4. Click on the Install button to install the new theme.

To Install a New Theme Option
You can install new controls options, window frame options, or icons options. You can
find many controls options on the Internet.
To install a new controls option, window frame option, or icons option, perform the
following steps:
1. Start the Theme preference tool.
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2. Click on the Theme Details button.
3. Click on a tab in the Theme Details dialog for the type of theme that you want to
install. For example, to install an icons option, click on the Icons tab.
4. Click on the Install Theme button.
5. Enter the location of the option archive file in the drop-down combination box of
the Install a Theme dialog. Alternatively, to browse for the file, click on the Browse
button. When you have selected the file, click OK.
6. Click on the Install button to install the new option.

To Delete a Theme Option
You can delete controls options, window frame options, or icons options.
To delete a controls option, window frame option, or icons option, perform the
following steps:
1. Start the Theme preference tool.
2. Click on the Theme Details button.
3. Click on a tab in the Theme Details dialog for the type of option that you want to
delete.
4. Click on the Go to Theme Folder button. A file manager window opens on the
default option folder.
5. Use the file manager window to delete the option.

Customizing Windows
To access the Window Behavior preference tool, click Launch, then choose Preferences
→ Desktop Preferences → Display →Window Behavior.
Use the Window Behavior preference tool to customize window behavior for the Java
Desktop System.
Table 7–36 lists the windows preferences that you can modify.
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TABLE 7–36 Windows Preferences
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Dialog Element

Description

Select windows when
the mouse moves over
them

Select this option to give focus to a window when you point to the
window. The window retains focus until you point to another
window.

Raise selected windows
after an interval

Select this option to raise windows a short time after the window
receives focus.

Interval before raising

Specify the interval to wait before raising a window that has
received focus.

Double-click titlebar to
perform this action

Select the behavior that you want to occur when you double-click
on a window titlebar. Select one of the following options:
■
Roll up: Shades the window.
■
Maximize: Maximizes the window.

To move a window,
press-and-hold this key
then grab the window

Select the key to press-and-hold when you drag a window to move
the window.
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APPENDIX

A

Mouse and Keyboard Functionality
This appendix discusses some of the basic skills that you need to work with the Java
Desktop System.

Mouse Functionality
This section describes the button conventions and action terminology used in this
manual. This section also describes the mouse pointers.

Mouse Button Conventions
All the instructions in this manual are for the following types of mouse devices:
■

Devices that are configured for right-hand users.

■

Three button devices. If you have a two-button mouse device, then you press the
two buttons simultaneously to simulate the effect of a middle mouse button.

The mouse button conventions used in this manual are as follows:

Mouse Button

Definition

Left mouse button

The button on the left side of a mouse device configured
for normal right-hand use.

Middle mouse button

The middle button of a mouse device configured for
normal right-hand use.
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Mouse Button

Definition

Right mouse button

The button on the right side of a mouse device configured
for normal right-hand use.

To reverse the handedness of your mouse device, start the Mouse preference tool, then
select the options that you require. If you do reverse the handedness of your mouse
device, then you must reverse the mouse button conventions used in this manual.

Mouse Actions
The following table describes the actions that you can perform with the mouse:

Mouse Button

Usage

Left mouse button

Use to perform the following actions:
■
Select text.
■
Choose items.
■
Drag items.

Middle mouse button

Use to perform the following actions:
■
Paste text.
■
Move items.

Right mouse button

Opens a menu for the selected object, if a menu applies.

For example, if you want to copy text then perform the following steps:
1. Select the text with the left mouse button.
2. Move the mouse pointer to the location where you want to copy the text.
3. Click on the middle mouse button.
You can also right-click on the desktop background to open the Desktop background
menu.

Mouse Pointers
As you use the mouse, the appearance of the mouse pointer can change. The
appearance of the pointer can provide feedback about a particular operation, location,
or state. The following table lists and describes some of the mouse pointers.
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Pointer

Associated Action

Description

Point to an item, choose a menu
item

Normal pointer. The pointer that
appears during normal use of the
mouse.

Drag-and-drop

Move pointer. Indicates that when
you drop the object, the object is
moved from the old location to the
new location.

Drag-and-drop

Copy pointer. Indicates that when
you drop the object, a copy of the
object is created where you drop
the object.

Drag-and-drop

Symbolic link pointer. Indicates
that when you drop the object, a
symbolic link to the object is created
where you drop the object. A
symbolic link is a special type of
file that points to another file or
folder.

Drag-and-drop

Ask pointer. Indicates that when
you drop the object, a menu opens.
You can choose to move or copy
the object, or to create a symbolic
link to the object.

Drag-and-drop

Not available pointer. Indicates that
you cannot drop the object at the
current location.

Move panel object

Move panel object pointer.
Indicates that you have selected a
panel object to move.

Resize window horizontally

Horizontal resize pointer. Indicates
that you have selected a vertical
window border to resize the
window horizontally.

Resize window vertically

Vertical resize pointer. Indicates
that you have selected a horizontal
window border to resize the
window vertically.
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Pointer

Associated Action

Description

Resize window horizontally and
vertically

Corner resize pointer. Indicates that
you have selected a corner of a
window border to resize the
window horizontally and vertically.

Resize window pane or resize table Window pane or table column
column
resize pointer. Indicates that you
have selected a column in a table to
resize.

Keyboard Functionality
For almost every task that you can perform with the mouse, you can use the keyboard
to perform the same task. Shortcut keys are keys that provide you with a quick way to
perform a task.
You can use shortcut keys to perform general Java Desktop System tasks and to work
with interface items such as panels and windows. You can also use shortcut keys in
applications. To customize your shortcut keys, use the Shortcuts preference tool.
You can also modify the desktop preferences to use keyboard accessibility features.
The following sections describe the shortcut keys that you can use.

General Shortcut Keys
General shortcut keys enable you to use the keyboard to perform general Java Desktop
System tasks. The following table lists some general shortcut keys:
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Default Shortcut Keys

Function

Ctrl + Esc

Opens the Main Menu.

Super + R

Displays the Run Application dialog.

Print Screen

Takes a screenshot.

Alt + Print Screen

Takes a screenshot of the window that has focus.

Ctrl + Alt + right arrow

Switches to the workspace to the right of the current
workspace.
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Default Shortcut Keys

Function

Ctrl + Alt + left arrow

Switches to the workspace to the left of the current
workspace.

Ctrl + Alt + up arrow

Switches to the workspace above the current workspace.

Ctrl + Alt + down arrow

Switches to the workspace below the current workspace.

Ctrl + Alt + d

Minimizes all windows, and gives focus to the desktop
background.

F1

Starts the online help browser, and displays appropriate
online Help.

Window Shortcut Keys
Window shortcut keys enable you to use the keyboard to perform window tasks. The
following table lists some window shortcut keys:

Default Shortcut Keys

Function

Alt + Tab

Switches between windows. When you use these shortcut
keys, a list of windows that you can select is displayed.
Release the keys to select a window.

Alt + Esc

Switches between windows in reverse order. Release the
keys to select a window.

F10

Opens the first menu on the left side of the menubar.

Alt + spacebar

Opens the Window Menu.

Arrow keys

Moves the focus between items in a menu.

Return

Chooses a menu item.

Esc

Closes an open menu.

Ctrl + Alt + right arrow

Switches to the workspace to the right of the current
workspace.

Ctrl + Alt + left arrow

Switches to the workspace to the left of the current
workspace.

Ctrl + Alt + up arrow

Switches to the workspace above the current workspace.

Ctrl + Alt + down arrow

Switches to the workspace below the current workspace.

Ctrl + Alt + d

Minimizes all windows, and gives focus to the desktop
background.
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Panel Shortcut Keys
Panel shortcut keys enable you to use the keyboard to perform panel tasks. The
following table lists panel shortcut keys:

Default Shortcut Keys

Function

Ctrl + Alt + Tab

Switches the focus between the panels and the desktop
background. When you use these shortcut keys, a list of items
that you can select is displayed. Release the keys to select an
item.

Ctrl + Alt + Esc

Switches the focus between the panels and the desktop
background. Release the keys to select an item.

Ctrl + F10

Opens the popup menu for the selected panel.

Tab

Switches the focus between objects on a panel.

Return

Chooses the selected panel object or menu item.

Shift + F10

Opens the popup menu for the selected panel object.

Arrow keys

Moves the focus between items in a menu. Moves the focus
between interface items in an applet also.

Esc

Closes an open menu.

F10

Opens the Applications menu from the Menu Bar, if the Menu
Bar is in a panel.

Application Shortcut Keys
Application shortcut keys enable you to perform application tasks. You can use
shortcut keys to perform application tasks more quickly than if you use a mouse. The
following table lists some application shortcut keys:
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Shortcut Keys

Command

Ctrl + N

New

Ctrl + X

Cut

Ctrl + C

Copy

Ctrl + V

Paste

Ctrl + Z

Undo

Ctrl + S

Save
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Shortcut Keys

Command

Ctrl + Q

Quit

Access Keys
A menubar is a bar at the top of a window that contains the menus for the application.
An access key is an underlined letter in a menubar, menu, or dialog that you can use to
perform an action. On a menubar, the access key for each menu is underlined.
To open a menu, press Alt, then press the access key. In the menu, the access key for
each menu item is underlined. To choose a menu item, press the access key for the
menu item. The following table shows example access keys from the Text Editor
application:

Access Keys

Function

Alt + F

Opens the File menu.

N

Chooses the New item on the File menu.

You can also use access keys to access elements in a dialog. In a dialog, one letter in
most dialog elements is underlined. To access a particular dialog element, press Alt,
then press the access key. The following table shows an example access key from the
Preferences dialog in the Text Editor application:

Access Key

Function

Alt + U

Gives focus to the Use default theme font check box.

You can use also other keys to navigate within a window or dialog.

Key

Function

Tab

Moves the focus from element to element in a window or
dialog.
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Key

Arrow keys

Function

Use the arrow keys to perform the following actions:
In a menubar, move the focus from one menu to the
next menu. In an open menu, move the focus from one
menu item to the next menu item.
■
Move the focus from one option to the next option to
make your selection, for example, within a group of
radio buttons in a dialog.
■
Change the value that a spin box displays.
■
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Glossary
desktop

Your visible Java Desktop System, including all panels, icons,
applications, and the desktop background.

desktop background

The desktop background lies behind all of the other components on
the Java Desktop System.

desktop background
object

An icon on your desktop background that you can use to open your
files, folders, and applications.

DNS name

A unique alphabetic identifier for a computer on a network.

drawer

A drawer is a sliding extension to a panel that you can open or close
from a drawer icon.

format

To prepare storage media for use with a particular file system. When
you format media, you overwrite any existing information on the
media.

GNOME-compliant
application

An application that uses the standard GNOME programming libraries.
For example, gedit text editor is a GNOME-compliant application.

hot key

Hot keys are keyboard shortcuts that start applications.

IP address

A unique numeric identifier for a computer on a network.

keyboard shortcut

A keyboard shortcut is a key or combination of keys that provides an
alternative to standard ways of performing an action.

launcher

A launcher starts a particular application, executes a command, or
opens a file. A launcher can reside on a panel or in a menu.

menubar

A menubar is a bar at the top of an application window that contains
the menus for the application.
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MIME type

A Multipurpose Internet Mail Extension (MIME) type identifies the
format of a file. The MIME type enables applications to read the file.
For example, an email application can use the image/png MIME type
to detect that a Portable Networks Graphic (PNG) file is attached to an
email.

mount

To make a file system available for access. When you mount a file
system, the file system is attached as a subdirectory to your file
system.

pane

A pane is a subdivision of a window. For example, the file browser
window contains a side pane and a view pane.

panel application

A panel application is a small, interactive application that resides
within a panel, for example the CD Player.

PDA

Personal Digital Assistant. A hand-held computer that you can use as a
personal organizer.

PDA daemon

A background application which waits for a PDA to attempt to
synchronize with your computer. When a PDA attempts to
synchronize with the computer, the PDA daemon synchronizes the
data on the PDA with data on the computer.

preference tool

A dedicated software tool that controls a particular part of the
behavior of the Java Desktop System.

shortcut keys

Shortcut keys are keystrokes that provide a quick way to perform an
action.

slice

A partition of a disk. You can create slices on your Zip and Jaz media.
An object for each slice appears on the desktop.

stacking order

The stacking order is the order in which windows are stacked on top
of each other on your screen.

statusbar

A statusbar is a bar at the bottom of a window that provides
information about the current state of what you are viewing in the
window.

symbolic link

A special type of file that points to another file or folder. When you
perform an action on a symbolic link, the action is performed on the
file or folder to which the symbolic link points.

toolbar

A toolbar is a bar that contains buttons for the most commonly-used
commands in an application. Typically, a toolbar appears under a
menubar.

Uniform Resource
Identifier

A Uniform Resource Identifier (URI) is a string that identifies a
particular location in a file system or on the Web. For example, the
address of a web page is a URI.

Uniform Resource
Locator

A Uniform Resource Locator (URL) is the address of a particular
location on the Web.
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view

A file manager component that enables you to display a folder in a
particular way. For example, the file manager contains an icon view
which enables you to display the contents of a folder as icons. The file
manager also contains a list view which enables you to display the
contents of a folder as a list.

viewer component

A file browser window component that enables you to display a
particular type of file in the view pane. A viewer component might
add menu items that are relevant to the file type to the file manager
menus. A viewer component might also enable you to use the file
browser window zoom buttons to change the size of the item in the
view pane.

workspace

A workspace is a discrete area in the desktop in which you can work.
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Index
A
access keys, 163-164
accessibility
bounce keys, 133
configuring keyboard, 131-134
mouse keys, 134
repeat keys, 132
setting assistive technology
preferences, 115-116
slow keys, 133
sticky keys, 132
toggle keys, 133
AccessX, See preference tools, Keyboard
Accessibility
action buttons, See buttons
applications, terminating, 38

buttons
adding to panel, 38-40
Force Quit, 38
Lock, 38-39
Log Out, 39
Run, 39
Screenshot, 39
Search, 38
Show Desktop, 40

C
CDs, writing, 99-100
closing windows, 65

D
B
backgrounds
adding colors, 128
adding patterns, 127
changing desktop background, 114
changing screen component, 127-128
customizing desktop background, 116-117
basic skills
keyboard skills, 160-164
mouse skills, 157-160
bottom edge panel
default contents, 25-26
introduction, 25-26
burning CDs, See writing CDs

default applications, See preferred applications
desktop, desktop objects, 106-112
desktop background
adding a file or folder to, 108-109
adding emblems to objects, 111
adding launchers, 108
adding notes to objects, 111
adding symbolic links, 108
background, changing pattern or color, 114
changing icon of a desktop object, 111
changing permissions of object, 110-111
copying a file or folder to, 109
creating a folder on, 109
customizing background, 116-117
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desktop background (Continued)
deleting an object from, 110
introduction, 105-106
moving a file or folder to, 109
opening objects, 107
removing an object from, 109-110
renaming object, 109
resizing icons, 112
selecting objects, 107
using Desktop menu, 113-114
using Trash, 112-113
viewing properties of object, 110
Desktop menu
description, 113-114
illustration, 113
desktop objects
adding emblems, 111
adding notes to, 111
changing icons, 111
changing permissions, 110-111
deleting, 110
files and folders, 108-109
launchers, 108
opening, 107
removing, 109-110
renaming, 109
resizing icons, 112
selecting, 107
symbolic links, 108
viewing properties, 110
drawers
adding objects to, 42
adding to panel, 42
closing, 41-42
modifying properties, 42-43
opening, 41-42

E
email client, preferred application, 140-141
emblems
adding new, 92
adding to desktop objects, 111
adding to file, 92
adding to folder, 92
introduction, 73-74
events, associating sounds with, 151-153
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F
file manager
assigning actions to files, 97-99
bookmarks, 82-83
changing backgrounds, 127-128
changing permissions, 89
copying files and folders, 85-86
creating documents, 87
creating folders, 86
creating symbolic link, 88-89
customizing, 122-128
deleting files or folders, 88
displaying folders, 74-75
drag-and-drop, 83-84
duplicating files and folders, 86
emblems
See emblems
executing default actions for files, 77
executing non-default actions for files, 77
executing other actions for files, 77
FTP sites
See FTP sites
History, 82
icon view
arranging files in, 95-96
illustration, 70
icons
caption preferences, 124-125
changing, 93
introduction, 73-74
resizing, 96
introduction, 69
managing files and folders, 83-92
modifying actions, 98-99
modifying appearance of files and
folders, 92-97
moving files and folders, 85
navigating, 74-83
navigating history list, 81-82
network places
See network places
notes
adding, 90-91
deleting, 91
opening files, 76-77
preferences
behavior, 123-124
icon captions, 124-125
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file manager, preferences (Continued)
introduction, 122-127
preview, 126-127
views, 122-123
renaming folders, 87
selecting files and folders, 84-85
side pane
introduction, 72
special URI locations, 81
This Computer location
See This Computer location
Trash
See Trash
Tree, using, 75-76
view pane
See view pane
viewing files in view pane, 76
viewing properties, 89
views
choosing, 94-95
introduction, 94-97
modifying behavior, 96-97
windows, 70-74
writing CDs, 99-100
zooming in and out, 93-94
file types
adding, 120-121
configuring, 119-121
editing, 119
focus, giving to a window, 63-64
fonts
applications, 128-129
desktop background, 128-129
rendering, 128-129
terminal, 128-129
window title, 128-129
Force Quit button, 38
FTP sites, accessing, 79

I
icon themes, See themes, icons options
internet
configuring connection, 129-130
setting preferences, 129-130

J
Java Desktop System preference tools, See
preference tools

K
keyboard
basic skills, 160-164
configuring accessibility options, 131-134
configuring general preferences, 134-136
configuring sound preferences, 152-153
keyboard shortcuts, configuring, 148-150

L
language, logging in different, 18, 19
Launch, opening, 51
Launch menu, adding to panel, 51
launchers
adding to panel, 34-37, 47
modifying properties, 37
Lock button, 21-22, 38-39
locking panel objects, 32
locking screen, 21-22, 38-39
Log Out button, 39
logging in, 18-19
to session, 17-18
to session in different language, 18, 19
logging out, 23

G
GTK+ themes, See themes, controls options

H
hot keys, configuring, 148-150

M
maximizing windows, 64
Menu Bar
adding to panel, 52
introduction, 51-52
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menu item popup menu
description, 46-47
illustration, 47
menus
Actions menu, 48-50
adding, 53
adding launchers to, 53
adding to panel, 40-41, 47
Applications menu, 47-48
copying launchers to, 53-54
customizing, 52-54
deleting menu items, 54
Desktop menu, 113-114
editing menu items, 54
editing properties, 54
features, 46-47
in applications, customizing
appearance, 136-137
introduction, 45
Launch
See Launch Menu
Menu Bar
See Menu Bar
menu item popup menu, 46-47
Window Menu, 59-60
Metacity themes, See themes, window frame
options
minimizing, windows, 64
mouse
actions, 158
basic skills, 157-160
button conventions, 157-158
configuring, 137-139
pointers, 158-160
moving windows, 65

N
network places, accessing, 79-80
NFS servers, See Unix network
notes
adding to desktop objects, 111
adding to files and folders, 90-91
deleting, 91
Notification Area, 40
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P
panel application, adding to panel, 33
panel applications
introduction, 32-33
modifying preferences, 33
Notification Area, 40
selecting, 33
Window List, 60-62
Workspace Switcher, 62
panel object popup menu, illustration, 31
panel objects
adding, 30
drawers
See drawers
Force Quit button, 38
interacting with, 29-30
launchers
See launchers
Lock button, 38-39
locking, 32
Log Out button, 39
menus, 40-41
modifying properties, 30-31
moving, 31-32
Notification Area, 40
panel applications
See panel applications
removing, 32
Run button, 39
Screenshot button, 39
Search button, 38
Show Desktop button, 40
panels
adding new, 26
bottom edge panel
See bottom edge panel
changing background, 29
customizing behavior and appearance, 139
deleting, 29
hiding, 27
interacting with, 26
introduction, 25-26
managing, 26-29
modifying properties, 27-29
moving, 27
panel objects
See panel objects
panes, resizing, 66
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permissions
and emblems, 73
changing file and folder, 89
displaying as characters, 125, 126
displaying in octal notation, 125, 126
introduction, 89-90
pointers, See mouse pointers
preference tools
Assistive Technology, 115-116
Background, 116-117
CD Database Server, 118
File Associations, 119-121
Font, 128-129
internet configuration, 129-130
Keyboard, 134-136
Keyboard Accessibility, 131-134
Keyboard Layout, 136
Keyboard Layout Options, 136
Menus & Toolbars, 136-137
Mouse, 137-139
Multimedia Keys, 150
Panel Preferences, 139
Preferred Applications, 139-142
Screen Resolution, 142
Screensaver, 143-145
Sessions, 22-23, 145-148
Shortcuts, 148-150
Sound, 151-153
Theme, 153-155
Windows Behavior, 155-156
preferences, file manager, See folder preferences
preferred applications
email client, 140-141
terminal, 142
text editor, 141-142
web browser, 140
proxy configuration, setting
preferences, 129-130

R
removable media
displaying contents, 101
displaying properties, 101-102
ejecting, 103
formatting, 102-103
introduction, 100-103

resizing windows, 65
restoring, windows, 64
rolling up windows, 66
Run Application dialog, using, 48-49
Run button, 39

S
Samba servers, See Windows network
screensaver, setting preferences, 143-145
Screenshot button, 39
screenshots, taking, 49-50
Search button, 38
services
adding, 121
configuring, 119-121
editing, 119
sessions
browsing applications, 22-23
configuring screensaver, 143-145
different language, logging in, 18, 19
ending, 23
locking screen, 21-22
logging in, 17-18, 18-19
logging out, 23
login behavior, 22
logout behavior, 22
managing, 22-23
preferences, 145-148
saving settings, 23
setting options, 146
setting properties, 146-147
starting, 17-19
using startup applications, 22
shading windows, See rolling up windows
shortcut keys
application, 162-163
configuring, 148-150
general, 160-161
panel, 162
window, 161-162
Show Desktop button, 40
side pane, See file manager
sound
associating events with sounds, 151-153
configuring system bell preferences, 152-153
setting preferences, 151-153
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sound server, 151-153
special URI locations
accessing, 81
and launchers, 34
special URIs, launchers, 37
startup applications
customizing, 145-148
non-session-managed, 22, 147-148
session-managed, 22-23, 146
startup programs, See startup applications
symbolic link
to desktop object, creating, 108
to file or folder, creating, 88-89
symbolic links, and emblems, 74
system bell, configuring preferences, 152-153

T
tables, using, 67
terminal, preferred application, 142
terminating applications, 38
text editor, preferred application, 141-142
themes
controls options
introduction, 153
icons options
introduction, 153
setting controls options, 153-155
setting icons options, 153-155
setting window frame options, 153-155
window frame options
introduction, 153
This Computer location, using, 78-79
toolbars, customizing appearance, 136-137
top edge panel, window selector icon, 62-63
Trash
displaying, 91, 112
emptying, 91-92, 112-113
introduction, 91-92
moving files or folders to, 88
using on desktop, 112-113
Tree, using, 75-76

U
URI, special, See special URI locations
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V
view pane
introduction, 71-72
viewing files in, 76
viewer components, 72, 76, 94-97

W
web browser, preferred application, 140
Window List panel application
grouping buttons, 61-62
introduction, 60-62
window status information, 61
window lists, Window List panel
application, 60-62
window manager, customizing, 155-156
window selector, top edge panel, 62-63
windows
closing, 65
frame control elements, 57-59
frames, 57-59
giving focus to, 63-64
introduction, 55-56
manipulating, 63-67
maximizing, 64
minimizing, 64
moving, 65
moving to another workspace, 66
panel applications and menus for working
with, 59-63
putting on all workspaces, 66
resizing, 65
resizing panes, 66
restoring, 64
rolling up, 66
setting frame theme options, 153-155
themes, 57
types of, 56-59
using tables, 67
Window List panel application
See Window List panel application
window managers, 56
Window Menu, 59-60
Workspace Switcher panel application, 62
workspaces
adding, 68
deleting, 68
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workspaces (Continued)
introduction, 55-56
manipulating, 67-68
moving windows to, 66
naming, 68
switching between, 67-68
Workspace Switcher panel application, 62
writing CDs, 99-100

X
XScreenSaver, See screensaver
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