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Preface
These release notes provide release information about the Sun Java™ Desktop System
Release 3 for the Solaris™ 10 Operating System.

Supported Systems
This release of the Java Desktop System supports the following systems:
■
■

Systems running the Solaris 10 Operating System on SPARC® platforms.
Systems running the Solaris 10 Operating System on x86 platforms.

Table P–1 describes where you can find information about systems that are supported
by the Solaris Operating System, relevant to this product release. In the Java Desktop
System documentation, the term x86 refers to the processor families shown in Table
P–1.
TABLE P–1

Supported Solaris Systems

Architecture

Processor Families

Solaris Systems

SPARC

■

See the Solaris 10 Hardware Compatibility
List at the following location:

■

SPARC64
UltraSPARC

http://www.sun.com/bigadmin/hcl
x86

■
■
■

AMD64
Pentium
EMT64

See the Solaris 10 Hardware Compatibility
List at the following location:
http://www.sun.com/bigadmin/hcl

5

Who Should Read These Release Notes
These release notes are for users who perform the following tasks with the Java
Desktop System Release 3 on Solaris Operating Systems:
■
■
■

Install the Java Desktop System.
Administer the Java Desktop System.
Set up the Java Desktop System in various locales.

Related Documentation
The following manuals are related to these release notes:
■
■
■
■

Java Desktop System Release 3 Accessibility Guide
Java Desktop System Release 3 Administration Guide
Java Desktop System Release 3 Troubleshooting Guide
Java Desktop System Release 3 User Guide

Associated Documentation
The following documents are associated with these release notes:
■
■
■
■
■

Java Desktop System Email and Calendar User Guide
StarOffice 7 Office Suite Administration Guide
StarOffice 7 Office Suite Basic Guide
StarOffice 7 Office Suite Setup Guide
StarOffice 7 Office Suite User’s Guide

Accessing Sun Documentation Online
The docs.sun.comSM Web site enables you to access Sun technical documentation
online. You can browse the docs.sun.com archive or search for a specific book title or
subject. The URL is http://docs.sun.com.
6
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Ordering Sun Documentation
Sun Microsystems offers select product documentation in print. For a list of
documents and how to order them, see “Buy printed documentation” at
http://docs.sun.com.

Typographic Conventions
The following table describes the typographic changes that are used in this book.
TABLE P–2 Typographic Conventions
Typeface or Symbol

Meaning

Example

AaBbCc123

The names of commands, files, and
directories, and onscreen computer
output

Edit your .login file.
Use ls-a to list all files.
machine_name% you have
mail.

What you type, contrasted with onscreen
computer output

machine_name% su

AaBbCc123

Command-line placeholder: replace with
a real name or value

The command to remove a file
is rm filename.

AaBbCc123

Book titles, new terms, and terms to be
emphasized

Read Chapter 6 in the User’s
Guide.

AaBbCc123

Password:

These are called class options.
Do not save the file.
(Emphasis sometimes appears
in bold online.)

Shell Prompts in Command Examples
The following table shows the default system prompt and superuser prompt for the
C shell, Bourne shell, and Korn shell.
7

TABLE P–3 Shell Prompts
Shell

Prompt

C shell prompt

machine_name%

C shell superuser prompt

machine_name#

Bourne shell and Korn shell prompt

$

Bourne shell and Korn shell superuser prompt #

Mouse Usage Conventions
The following table lists the conventions for mouse usage in documentation for the
Java Desktop System.
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Action

Definition

Click

Press and release the left mouse button, without moving the
mouse.

Click-and-hold

Press and do not release the left mouse button.

Left-click

Same as click. Left-click clarifies the action when there might be
confusion with right-click.

Middle-click

Press and release the middle mouse button, without moving the
mouse.

Right-click

Press and release the right mouse button, without moving the
mouse.

Double-click

Press and release the left mouse button twice in rapid succession
without moving the mouse.

Drag

Click-and-hold a mouse button, then move an object. For
example, you can drag a window or an icon. The left and middle
mouse buttons can perform drag actions.

Drag-and-drop

Click-and-hold a mouse button, then move an object. For
example, you can drag-and-drop a window or an icon. Release
the mouse button to place the object in a new location.

Grab

Point to an item that you can move, and click-and-hold on the
mouse button. For example, you can grab the titlebar of a
window, then drag the window to a new location.
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CHAPTER

1

Java Desktop System Release 3 Release
Notes
These release notes provide information for the following releases:
■

Java Desktop System Release 3 for the Solaris 10 Operating System (OS) on SPARC
platforms.

■

Java Desktop System Release 3 for the Solaris 10 OS on x86 platforms.

1.1 Product Features
The Java Desktop System includes the following features:
Open source standards

Components include the GNOME desktop
environment, StarOffice productivity suite, Mozilla
browser, Evolution mail and calendar client, and
the Java 2 Platform Standard Edition.

Enhanced system management

Server-side administration tools enable centralized
configuration, deployment, and administration of
the user desktop environment.

Developer features

Advanced developer tools assist developers in
creating Java-technology based applications for the
desktop.

Applications features

New applications features since the previous
release of the Java Desktop System are as follows:
■

■

Connector for Microsoft Exchange Server
V2.0.1.
Sun Java Calendar Preview.
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1.2 What’s New in This Release
This release of the Java Desktop System on the Solaris 10 OS combines innovations
from the open source software community and from Sun Microsystems to create a
comprehensive, integrated, and interoperable desktop environment. The following
table describes improvements and enhancements in this release of the Java Desktop
System.

Function

Description

Mobility

■

Improved profile management for roaming web browser
profiles.

Interoperability

■

An Exchange connector allows the Email and Calendar
application to interoperate with a Microsoft Exchange
network.
New Sun Java Calendar Preview, a Java calendar and
address book client with support for connectivity to
Microsoft Exchange servers and to Sun Java System
Messaging Server.
Improved browser compatibility with Internet Explorer.
Samba 3.0 provides better interoperability with Windows
file shares.

■

■
■

New Accessibility Applications

■
■

Screen reader and screen magnifier
On-Screen Keyboard

See the Java Desktop System Release 3 Accessibility Guide and the
Java Desktop System Release 3 Accessibility Release Notes for more
details.
Internationalization

■
■

General Improvements

■

■
■
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New simplified Chinese SunPinYin input method.
New File System Examiner to help users migrate from
legacy environments to UTF–8 character encoding.
All of the major components of the Java Desktop System,
GNOME 2.0x, Email and Calendar Application, Mozilla
and Gaim have been updated.
StarOffice 7 includes Product Patch 4.
The framework for Smartcard integration via industry
standard PC/SC API is included.
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1.3 Known Issues
The following table describes known issues in this release of the Java Desktop System
for which there are no workarounds at the time of product release.

Topic

Known Issue

Applications

■

■

■

■

■

Localization

■

Change Request Number: 6200999
Mozilla: You can specify that User Preferences should be transferred to
and from the Roaming Access server. Choose Edit → Preferences →
Roaming User → Item Selection then choose User Preferences. However
this selection does not take effect.
Change Request Number: 6204976
Email and Calendar: The Evolution application cannot save attachments
with localized content.
Change Request Number: 5082008
Archive Manager: You cannot use Archive Manager to create the following
types of archives:
■
.arj
■
.lha
■
.bzip
■
.lzop
■
.zoo
Volume Control
The option in the Volume Control panel application that enables you to
start the Volume Control desktop applications does not work.
Sound Recorder
The slide bar and the side counter do not working when recording a
new.wav file.
You cannot print out documents from Mozilla containing non-BMP
Unicode characters.

1.4 Differences From the Previous
Release
This release of the Java Desktop System on the Solaris 10 OS is based on the GNOME
2.6 Desktop. The following components are no longer included in this release of the
Java Desktop System:
■

/usr/bin/galf
Chapter 1 • Java Desktop System Release 3 Release Notes

11

■
■
■
■
■
■
■
■
■
■
■
■
■
■
■
■
■
■
■
■

/usr/bin/galf-server
/usr/bin/gnome-settings-daemon
/usr/bin/gnome-theme-properties
/usr/bin/gnometris
/usr/bin/intltool-unicodify
/usr/bin/jmplay.bin
/usr/bin/libgnomeprint-2.0-font-install
/usr/bin/linc-config
/usr/bin/metacity-properties
/usr/bin/mk-star-menuentries
/usr/bin/nautilus-gtkhtml-view
/usr/bin/play
/usr/bin/rec
/usr/bin/sfconvert
/usr/bin/sfinfo
/usr/bin/soxmix
/usr/bin/yelp-pregenerate
/usr/lib/libgen_util_applet-2.so
/usr/lib/liblinc.so
/usr/lib/libzvt-2.0.s

If you need any of these components, contact the GNOME community. See
http://gnome.org

1.5 Where To Find Documentation
You can view PDF and HTML versions of the documentation for the Java Desktop
System in the following locations:
■
■

On the accompanying Documentation CD.
On http://docs.sun.com.

1.5.1 Accessing Localized Versions of User
Documentation
Some localized versions of the Java Desktop System user documentation do not
display in the Help browser.
Perform the following steps to view the localized versions of the user documentation
on http://docs.sun.com:
1. Open the following page:
12
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http://docs.sun.com
2. Select the language that you require from the language selection buttons.
The language selection buttons are located next to the Search/browse within area
of the page.
3. Enter the name of the manual that you want in the Search field.
4. Choose the manual that you want from the list displayed.

1.5.2 Documentation for Sample Applications
This release of the Java Desktop System includes sample applications that have Help
manuals provided by the GNOME free software community. Sun Microsystems does
not take any responsibility for the completeness or accuracy of Help manuals
provided by the free software community.
Sun provides approximately 130 man pages related to applications and functionality. If
Sun Microsystems, or an agent of Sun Microsystems, is not specifically credited as the
author of a man page, Sun Microsystems takes no responsibility for the content or
accuracy of the document.
Sun Microsystems does not provide localized versions of documentation for sample
applications.

1.5.3 Information About Removable Media
For information about removable media, refer to the Java Desktop System Release 3 User
Guide on http://docs.sun.com.

1.6 Sample Applications for Evaluation
Sun Microsystems provides a variety of sample applications with the Java Desktop
System for you to review and evaluate. The sample applications are from the GNOME
free software community or from third-party suppliers. Sun Microsystems does not
provide any of the following with sample applications:
■
■
■
■
■

Accessibility features
Bug fixes
Documentation or Help
Localization
Technical support
Chapter 1 • Java Desktop System Release 3 Release Notes
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1.6.1 Sample Applications
The following table lists the applications from the GNOME free software community
that Sun Microsystems provides as sample applications.

Application

Description

Calendar Client
Preview

Calendar application.

Diagram Editor

Diagram editor that enables you to create flow charts, maps, UML
diagrams, and many other diagrams.

Dictionary

Online dictionary that enables you to look up definitions and correct
spellings of words.

Digital Camera
Browser

Digital camera browser that enables you to manage images.

Disk Analyzer

Disk analyzer that enables you to visualize your disk.

Image Editor

GNU Image Manipulation Program that enables you to edit images.

Image Organizer

Image viewer and browser that displays thumbnails of images on your
desktop.

Interface Editor

Programming application that enables you to create user interfaces for
GNOME applications.

Movie Player

Multimedia player that enables you to play motion pictures.

On-screen
Keyboard

Provides an on-screen keyboard that you can use as an input device for
the Java Desktop System.

Project Manager

Project management and scheduling tool.

Screen Magnifier

Provides screen magnification and several other accessibility features.

Source Editor

General purpose extensible editor for programmers.

Weather Report

Displays current weather conditions for different regions.

1.6.2 Third-Party Applications
The following table describes third-party products in this release of the Java Desktop
System. Sun Microsystems does not take any responsibility for the functionality,
features, or any other form of support for these applications.

14
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Third Party
Products

Adobe
Acrobat
Reader

Description

Platform

Enables you to view PDF documents on the Java
Desktop System. You can find information about this
application at the following location:
http://www.adobe.com.

SPARC

The GNOME PDF Document Viewer is available on the x86 platform to view PDF
documents. To start PDF Document Viewer, click Launch, then choose Applications →
Graphics → PDF Document Viewer.

1.6.3 Sample Games
Sun Microsystems provides the following sample games for evaluation only:
■
■
■
■
■
■
■
■
■
■
■
■
■
■

Ataxx
Four-in-a-row
Iagno
Klotski
Lines
Mahjongg
Mines
Nibbles
Robots
Same GNOME
Spider
Stones
Tali
Tetravex

1.7 Plugins for Mozilla 1.7
This section contains information about plugins for Mozilla 1.7.

1.7.1 Java Plugin
Java Plugin is enabled in Mozilla 1.7 by default. If Java Plugin does not work, then
create a symbolic link in the /usr/sfw/lib/mozilla/plugins directory, pointing
to the appropriate file shown in the following table:
Chapter 1 • Java Desktop System Release 3 Release Notes
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Platform

Path

SPARC

$JAVA_PATH/plugin/sparc/ns7/libjavaplugin_oji.so

x86

$JAVA_PATH/plugin/i386/ns7/libjavaplugin_oji.so

In the Java Desktop System Release 3, $JAVA_PATH is /usr/java/jre.
Note – Do not copy the libjavaplugin_oji.so file instead of creating a symbolic

link. A copy of the file causes Java to crash.

Install all Java plugins in the /usr/sfw/lib/mozilla/plugins directory.

1.7.2 Other Plugins
The Adobe Acrobat Reader third-party plugin is also available for Mozilla 1.7:
For more installation information about Mozilla plugins, see the following location:
http://plugindoc.mozdev.org/solaris.html

1.8 Localization Support
The supported languages for this release of the Java Desktop System are as follows:
■
■
■
■
■
■
■
■
■
■
■

16

English
French
German
Italian
Japanese
Korean
Spanish
Swedish
Simplified Chinese
Traditional Chinese
Brazilian Portuguese — User interface support only
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Note – This release of the Java Desktop System includes some localizations that are
taken from the GNOME community. Sun Microsystems does not take any
responsibility for the completeness or accuracy of these localizations.

1.9 Recommended Locales
Sun Microsystems recommends that you use the UTF-8 and the zh_CN.GB18030
locales even though other legacy locales are listed in the login screen. When you
manually switch from the default login screen to the GNOME 2.x Display Manager,
only the UTF-8 and zh_CN.GB18030 locales are available. If you want to add the
legacy locales on your GNOME 2.x Display Manager login screen, remove the
comment tags surrounding the entries for the locales in
/etc/X11/gdm/locale.alias file and then reboot your system.

1.10 Migration To Unicode Multilingual
Computing
The Java Desktop System is a fully Unicode-enabled, multilingual system that
supports languages with Unicode UTF-8 encoding. The Java Desktop System also
provides codeset conversion to support legacy (non-UTF-8) encodings. This section
describes issues you might encounter when you migrate to Unicode multilingual
computing.

1.10.1 Importing And Exporting Data
There are a number of methods of importing and exporting data that are affected by
the migration to Unicode multilingual computing.

1.10.1.1 Microsoft Office Files
Microsoft Office files are encoded in Unicode. StarOffice applications can read and
write the Unicode encoded files.
Chapter 1 • Java Desktop System Release 3 Release Notes
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1.10.1.2 HTML Files
HTML files authored using HTML editors such as Mozilla Composer , or HTML files
saved by a web browser, usually contain a charset encoding tag. After exporting or
importing, you can browse such HTML files with the Mozilla Navigator web browser,
or edit the files with Mozilla Composer, according to the encoding tag in the HTML
file.

1.10.1.3 Fixing Broken HTML Files
Some HTML files might be displayed in garbage characters. This problem is typically
due to the following reasons:
■
■

The charset encoding tag is incorrect.
The charset encoding tag is missing.

To find the charset encoding tag in the HTML file, perform the following actions:
1. Open the file with Mozilla.
2. Press Ctrl+i, or click View to open the View menu.
3. Click on Page Info.
The charset information is in the bottom of the General tab, for example:
Content-Type text/html; charset=us-ascii
If the string charset=us-ascii does not match with the actual encoding of the file,
the file might appear as broken. To edit the encodings of the HTML file, perform the
following actions:
1. Open the file with Mozilla Composer.
2. Open the File menu.
3. Select Save As Charset.
4. Choose the correct encoding. Mozilla Compose automatically converts the
encoding and the charset tag as appropriate.

1.10.1.4 Emails Saved As Portable Format
Modern emails are tagged with the MIME charset tag. The Email and Calendar
application accepts MIME charset tags. You do not need to perform any encoding
conversion.

1.10.1.5 Plain Text Files
Plain text files do not have a charset tag. If the files are not in UTF-8 encoding,
encoding conversion is needed. For example, to convert a plain text file encoded in
Traditional Chinese big5 to UTF-8, execute the following command:
18
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iconv -f big5 -t UTF-8 inputfilename > outputfilename
You can also use File System Examiner for the encoding conversion.
You can use Text Editor to read and write character encoding text automatically or by
specifying an encoding explicitly when opening or saving a file.
To start Text Editor, click Launch, then choose Applications → Accessories → Text
Editor.

1.10.1.6 File Names and Directory Names
If file names and directory names using multibyte characters are not in UTF-8
encoding, encoding conversion is needed. You can use File System Examiner to
convert file and directory names and the contents of plain text files from legacy
character encodings to UTF-8 encoding. Refer to the online Help for File System
Examiner for more information.
To start File System Examiner, click Launch, then choose Applications → Utilities →
File System Examiner.
When you access non-UTF-8 file or directory names on Microsoft Windows via SMB
using File Manager, you can access the non-UTF-8 file or directory names without
encoding conversion.

1.10.1.7 Launching Legacy Locale Applications
For applications that are not ready to migrate to Unicode UTF-8, you can create a
launcher on a front panel to start the application in legacy locales. You can also launch
the applications directly from the command line. Perform the following steps to create
a launcher for an application:
1. Right-click on the panel where you want to place the launcher.
2. Choose Add to Panel -> Launcher.
3. Use the following format to type the entry in the Command field in the Create
Launcher dialog:
env LANG=locale LC_ALL=locale application name
For example, if you want to launch an application called motif-app from
/usr/dt/bin in the Chinese Big5 locale, enter the following text in the Command
field of the Create Launcher:
env LANG=zh_TW.BIG5 LC_ALL=zh_TW.BIG5 /usr/dt/bin/motif-app
You may also need to specify appropriate LD_LIBRARY_PATH for the application
4. Click OK to create the launcher on the panel.

Chapter 1 • Java Desktop System Release 3 Release Notes

19

When you need to run CLI (command line interface) applications which are specific to
a legacy locale, open a Terminal window in the legacy locale first and then run the CLI
applications in the same Terminal terminal window. To open a Terminal window in a
legacy locale, enter the following command:
env LANG=locale LC_ALL=locale gnome-terminal --disable-factory.
Instead of opening a new Terminal window in a legacy locale, you can switch the
locale setting from UTF-8 to a legacy locale in the current Terminal window by
changing the encoding the Set Character Encoding menu in the Terminal window.
Then you must also set the LANG and LANG environment variables to the current shell.
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