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Preface

Solaris Common Desktop Environment: User’s Guide describes the basic features of the
Common Desktop Environment (CDE). It describes how to use the desktop and
desktop applications.

Note – In this document the term “IA” refers to the Intel 32–bit processor architecture,
which includes the Pentium, Pentium Pro, Pentium II, Pentium II Xeon, Celeron,
Pentium III, and Pentium III Xeon processors and compatible microprocessor chips
made by AMD and Cyrix.

Who Should Use This Book
This book is intended for users who have Solaris Common Desktop Environment
installed on their workstation and who plan to use it as their default desktop. To use
this book, you should also be familiar with a three-button mouse, graphical user
interfaces, and typing commands at a command-line prompt.

Before You Read This Book
You should first read the following book:

� Solaris Common Desktop Environment: User’s Transition Guide
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How This Book Is Organized
This book contains the following chapters:

� Chapter 1 describes the basic skills you need to work with the Common Desktop
Environment, keyboard navigation, and some common interface aspects of the
desktop.

� Chapter 2 describes how to log in to and out of the desktop, and how to set the
session that will appear at login.

� Chapter 3 explains how to get help about an application and how to navigate
within the help viewer.

� Chapter 4 describes the Front Panel, a special desktop window that contains a set
of controls for doing common tasks. It explains the Front Panel controls and how to
customize the Front Panel.

� Chapter 5 explains how to work with files and folders in the graphical user
interface File Manager. It describes basic skills, navigation, manipulating and
finding files and folders, and the Trash Can.

� Chapter 8 explains how to run applications using Application Manager, the main
repository for applications in CDE.

� Chapter 9 explains how to use Style Manager to customize the look and behavior
of your desktop. It also describes how to set personal environment variables.

� Chapter 10 describes how to send and receive electronic mail messages through
Mailer, and how to add and retrieve attachments.

� Chapter 11 explains how to print through the desktop, and how to change the
default printer.

� Chapter 12 describes the desktop Text Editor, which you can use to create and edit
short documents such as memos, mail messages, or resource files.

� Chapter 13 explains how to use Calendar to set appointments for yourself or a
group, and how to create To Do lists.

� Chapter 14 explains how to display and customize terminal emulator windows on
the desktop.

� Chapter 15 explains how to create files for use as desktop icons or backdrops.

� Chapter 16 describes how to capture snapshots and to view, edit, print, and
translate the file formats of monochrome and color images and multiple page
documents such as PostScript files.

� Chapter 17 describes how to use Audio to record or play audio files.

� Chapter 18 describes how to find cards containing information about users, hosts,
and systems, and how to perform related actions.
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� Chapter 19 describes how to display the process running on your workstation, and
how to investigate and kill these processes.

� Chapter 20 describes how to monitor activity levels on your system, and how to
identify errant behavior.

� Chapter 21 describes how to use the Hotkey Editor to create, modify, or delete CDE
hotkeys.

� Chapter 22 describes how to synchronize your PDA with your desktop
information.

� Appendix A describes desktop keyboard navigation

� Appendix B describes how to change the language for your desktop session, and
how to change fonts for different languages.

� Appendix C lists the keyboard commands needed to compose special characters
(for the ISO Latin-1 code set only).

� Appendix D describes the display, manipulation, and printing of text using CDE
and the Thai and Hebrew locales.

� Glossary is a list of words and phrases found in this book and their definitions.

Related Books
Once you’ve read this book, you may want to read more detailed information on the
desktop in Solaris Common Desktop Environment: Advanced User’s and System
Administrator’s Guide.

Ordering Sun Documents
Fatbrain.com, an Internet professional bookstore, stocks select product documentation
from Sun Microsystems, Inc.

For a list of documents and how to order them, visit the Sun Documentation Center on
Fatbrain.com at http://www1.fatbrain.com/documentation/sun.
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Accessing Sun Documentation Online
The docs.sun.comSM Web site enables you to access Sun technical documentation
online. You can browse the docs.sun.com archive or search for a specific book title or
subject. The URL is http://docs.sun.com.

Typographic Conventions
The following table describes the typographic changes used in this book.

TABLE P–1 Typographic Conventions

Typeface or Symbol Meaning Example

AaBbCc123 The names of commands, files, and
directories; on-screen computer output

Edit your .login file.

Use ls -a to list all files.

machine_name% you have
mail.

AaBbCc123 What you type, contrasted with
on-screen computer output

machine_name% su

Password:

AaBbCc123 Command-line placeholder: replace with
a real name or value

To delete a file, type rm
filename.

AaBbCc123 Book titles, new words, or terms, or
words to be emphasized.

Read Chapter 6 in User’s Guide.

These are called class options.

You must be root to do this.

Shell Prompts in Command Examples
The following table shows the default system prompt and superuser prompt for the C
shell, Bourne shell, and Korn shell.
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TABLE P–2 Shell Prompts

Shell Prompt

C shell prompt machine_name%

C shell superuser prompt machine_name#

Bourne shell and Korn shell prompt $

Bourne shell and Korn shell superuser prompt #
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CHAPTER 1

Basic Skills

This chapter introduces you to the windows and controls in CDE, and shows you how
to perform tasks you will use everyday, for example, dragging an object using a
mouse, re sizing a window, and the like.

For information about logging in to the desktop, refer to Chapter 2.

� “Mouse Skills” on page 39
� “Desktop” on page 42
� “Running Applications” on page 45
� “Working with Windows” on page 48
� “Using Workspaces” on page 54
� “Using Controls in Application Windows” on page 57
� “Using Menus” on page 62
� “Basic Keyboard Skills” on page 68
� “Leaving the Desktop” on page 69
� “Getting Help” on page 72

Mouse Skills

� To Click
� Press and release mouse button 1 without moving the mouse.

By default, mouse button 1 is the left button.
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Tasks that you perform by clicking include:

� Selecting a window or icon, making it active or selected
� Choosing a button in a dialog box or a control in the Front Panel
� Choosing a hyperlink within a help window or mail message

� To Double-Click
� Press and release mouse button 1 twice in rapid succession, without moving the

mouse.

Here are some tasks you perform by double-clicking:

� Starting the default action for a File Manager or workspace icon

� Restoring a window icon (displaying the whole window again)

� Closing a window to remove it from the workspace—double-click the Window
menu button in the upper left corner of the window frame

� To Drag
To move a window or drop an icon, use the press-drag-release motion.
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� Point to the window’s title bar or anywhere on the icon, press and hold mouse
button 1, drag the mouse, then release the button.

Tasks you perform by dragging and dropping include:

� Moving windows and icons on your screen

� Moving or copying files and folders within File Manager

� Dragging a slider within a scroll bar to scroll the contents of a window

� Printing a file by dropping its icon on the Printer control in the Front Panel

� To Duplicate
1. Select the required text by holding down mouse button 1 and dragging the cursor

over it.

2. Release mouse button 1.

3. Point the mouse at the location to which you wish to duplicate the text, and click
mouse button 2.

By default, mouse button 2 is the middle mouse button. The text is copied to the new
location without removing it from its original location.

4. (Optional) Repeat step 3 and duplicate the text in other locations.
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Desktop
CDE uses windows and other objects to represent applications, files, and services
available to the user. When you log into CDE, the CDE desktop is displayed.

Workspace One 

Front Panel

Application icons 
(minimized application windows)

Applications submenu 
on the Workspace menu

FIGURE 1–1 CDE Desktop

CDE Desktop
The CDE desktop comprises a Front Panel sitting over a selected workspace, or screen
background. The Front Panel displays information about your workstation, and
enables you to run applications, to log out, and to switch between workspaces.
Applications that are running are represented by windows and icons on the
workspace. You can also run commands from a Workspace menu, which is displayed
when you click mouse button 3 on an unused part of the workspace backdrop.
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Front Panel
The Front Panel (see Chapter 4) is a collection of frequently used controls and desktop
services available in every workspace.

Workspaces
Workspaces are like separate screens or desktops. You can only display one workspace
at a time, but applications in all workspaces can run simultaneously.

By default, four workspaces named One through Four are available. To display
another workspace, you click its button in the workspace switch in the center of the
Front Panel.

Tip – You can specify whether an application is displayed on one or all workspaces by
clicking mouse button 3 on its window frame and selecting an item from the pop-up
menu.

Workspace Menu
When you click mouse button 3 on an unused area of a workspace, the Workspace
menu (see Figure 1–1) is displayed. It includes items on the Front Panel and
Application Manager. Most applications are on the Applications menu.

Working With Files
The Files subpanel gives you access to file-related devices and applications.
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FIGURE 1–2 Location of Files Subpanel

CDE provides full-functioned File Manager and File Finder applications. In File
Manager and File Finder, files and folders are represented by icons that indicate their
types.

44 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



Clicking on mouse button 3 displays options for the selected object, and
double-clicking an object invokes the default action for that object. For example,
double-clicking a compressed file expands it, and double-clicking an audio file plays
it.

Task or Feature Methods

To find a file Select Find File on the Files subpanel

To carry out an action on a file Click mouse button 3 on the file and choose
the action from the pop-up menu

Drag and drop the file on an appropriate drop
zone

Click a control on the Files subpanel

To print a file Drop a file on the printer control on the Front
Panel

To access a floppy diskette or CD-ROM Select Open Floppy or Open CD-ROM on the
Files subpanel

Deleting Files
CDE provides a trash can or wastebasket facility. The Trash Can is a temporary store
for objects (files and folders) to be deleted. You can move selected objects to the Trash
Can using drag and drop, by mapping certain menu items, or by pressing the Delete
key. Once in the Trash Can, the objects no longer appear in their original folder.

To permanently remove the deleted files in CDE, you use the Empty Trash Can control
on the Trash subpanel.

Running Applications
CDE provides the following methods of running applications:

� The Front Panel and the Workspace menu provide access to collections of
commonly used applications.

� Where an application is not available from the Front Panel or the Workspace menu,
you will probably find it in Application Manager.

� You can run certain applications by dropping files or data on their drop zones in
the Front Panel.
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� Terminal emulator windows and the File Manager application also enable you to
run applications, but this requires a little more understanding of commands, files,
and folders.

Note – You can also add applications to the Front Panel, Worskpace menu, and
Application Manager.

Running Applications from the Front Panel
The Front Panel contains a number of controls, or program icons. Some are on the
main panel, which is displayed by default, and others are on subpanels, which can be
displayed by clicking a tab marked by a triangle.

You run an application by clicking mouse button 1 on its control.

For instructions on running applications from the Front Panel or for adding and
manipulating controls on the Front Panel, see “Front Panel Applications” on page 132
and “Customizing the Front Panel” on page 138.

Running Applications from the Workspace Menu
The Workspace menu is displayed when you press mouse button 3 on any unused
part of the workspace backdrop. You can run an application by dragging to its menu
item and releasing the mouse button.

Running Applications from Application Manager
You can open Application Manager by clicking its control on the Applications
subpanel on the Front Panel. Application Manager contains several application
groups, such as desktop tools, and OpenWindows applications. These groups can be
opened by clicking their icons in the Application Manager main window.

46 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



Controls

Application
Manager

Subpanel

Main Panel

FIGURE 1–3 Front Panel and Application Manager

To run an application in an Application Manager window, you double-click its
program icon.

Running Applications from Drop Zones on the
Front Panel
Certain controls on the Front Panel—such as the Printer, Mailer and Web Browser
controls—act as drop zones (see “Front Panel Drop Zones” on page 112) that activate
the relevant application when you drag and drop appropriate text or files on them. For
example, if you drop a file on the Mailer control, Mailer displays a New Message
window with the file attached to the new message.

For instructions on drop zones, see “Front Panel Drop Zones” on page 112 and “Tour
of the Front Panel” on page 114.

Running Applications from File Manager
You can run an application by clicking its application icon in a File Manager window.
For example, you can run Image Viewer by clicking the file SDTimage in the folder
/var/dt/appconfig/appmanager/user-hostname-0/Desktop_Apps/ where
user-hostname-0 is a folder specific to your user ID.

If an application uses data files, it may be configured so that the application can be
started from File Manager by clicking one of its data files. For example,
double-clicking a bitmap file (a file whose name ends with .bm) runs Icon Editor.
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For instructions on running applications from File Manager see “Executing an Action
for a File or Folder” on page 160.

Running Applications from a Terminal Emulator
Window
A terminal emulator is an application whose window provides a command-line
interface to your system—for example, operating system commands, script names, or
commands that run applications.

All applications have a command that you can type to start them. The application’s
documentation usually describes how to use the command.

The desktop provides a terminal emulator called dtterm. Your system may include
other terminal emulators. To open a terminal emulator window, click the This Host
control in the Hosts subpanel.

For more information on using dtterm, see Chapter 14.

Working with Windows
This section describes how to open, close, and manipulate windows in a workspace.

Window Frame Controls
A window’s frame provides controls with which you can:

� Focus attention on a window, making it active (indicated by its frame changing
color) for input from your mouse or keyboard

� Move a window

� Minimize a window into an icon

� Size a window

� Close a window, removing it from the desktop

� Display a window in other workspaces
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Refer to Chapter 9 for information about settings that make windows active.

           
Maximize button

Resize border

Resize corner

Minimize buttonTitle barWindow menu
button

FIGURE 1–4 Window Frame Controls

Click the Window menu button to display the Window menu.

To close a window and remove it from the desktop, double-click the Window menu
button or display the Window menu and choose Close.

Click the minimize button to turn the window into a window icon. To restore a
window from its icon, double-click the icon.

Click the maximize button to display the window in its largest allowable size. Return
the window to its former size by clicking the maximize button again.

The title bar shows the name of the application that owns the window. Select a
window by clicking its title bar. You can move a window by dragging its title bar.

Drag a window’s resize corner or border to resize the window.

For information on keyboard navigation and windows, see “Opening and Closing
Windows” on page 581 in Appendix A.

� To Open an Application Window (Mouse)
� Click the application’s control in the Front Panel.

� Or, from within Application Manager, double-click the application’s icon.
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� Or, from within Application Manager, double-click the application’s icon.

� Or, from the Workspace Programs submenu, choose the item with the application
name.

You can also select an icon in a File Manager or Application Manager window by
clicking it and then choose an action for the selected icon from the Selected menu.

� To Open an Application Window (Keyboard)
From the Front Panel:

1. Press Alt+Tab to move the keyboard focus to the Front Panel.

2. Press the arrow keys to move the highlight within the Front Panel and select a
control.

3. Press Spacebar or Return to choose the control and open the application’s window.

� To Close an Application Window
Closing an application window removes it from all workspaces. Closing an
application is the same as quitting an application on other systems.

Caution – Before closing an application window, save your work. In most applications
you can do this by choosing Save from the File menu.

� Choose Close from the application’s File menu.

� Or, double-click the Window menu button (in the upper left corner of the
application’s window).

� Press Alt+Tab to move the highlight to the window you want to close and press
Alt+F4.

� To Turn a Window into an Icon (Mouse)
To save screen space, you can minimize windows into window icons. This keeps the
windows easily available and programs running in them continue to run.

� Click the window’s minimize button.
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� To Turn a Window into an Icon (Keyboard)
1. Press Alt+Spacebar to display the Window menu.

2. Choose Minimize:

� Press Down Arrow until you select Minimize, then press Return.
� Or, press N, the menu’s mnemonic for Minimize.

� To Restore a Window from an Icon (Mouse)
� Double-click the icon.

� To Restore a Window from an Icon (Keyboard)
1. With keyboard focus on the icon, press Alt+Spacebar to display the Window menu.

2. Press Down Arrow to select Restore, then press Return.

� To Move a Window or Window Icon (Mouse)
1. Point to the window’s title bar or icon.

2. Drag the window or icon to its new location.

� To Move a Window or Window Icon (Keyboard)
1. Press Alt+Spacebar to display the Window menu.

2. Press M, the menu’s mnemonic for Move.
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3. Press the arrow keys to relocate the window or icon.

Hold down Control while you press an arrow key to speed up the movement of the
window or icon.

4. When you’ve moved the window or icon to where you want it, press Return.

To cancel the move operation, press Esc.

� To Resize a Window (Mouse)
1. Place the pointer on a window’s border or corner.

The pointer changes to a resize arrow.

2. Drag the border or corner. An outline appears to show you the window’s new size.

3. Release the mouse button when the outline shows the window’s desired size.

Stretch or shrink
a window by
dragging its
border or corner

� To Resize a Window (Keyboard)
1. Press Alt+Spacebar to display the Window menu.

2. Press S, the menu’s mnemonic for Size.

3. Press the arrow keys to stretch or shrink the window.

Hold down Control while you press an arrow key to size the window faster.

4. When the outline shows the size you want, press Return.

To cancel the resize operation, press Esc.
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� To Move a Window or Icon to the Foreground or
Background (Mouse)

1. Click a visible part of the window’s frame or anywhere on the icon.

2. Choose Shuffle Up or Shuffle Down from the Workspace menu.

� To Move a Window or Icon to the Foreground or
Background (Keyboard)
� To bring the bottom window or icon in a workspace forward, press Alt+Up Arrow.

� To place the top window in the background, press Alt+Down Arrow.

� To cycle through and select the windows and icons in a workspace, press Alt+Tab
or Alt+Esc.

� To cycle through and select the windows and icons in reverse order, press
Shift+Alt+Tab or Shift+Alt+Esc.

Copying and Pasting Text into Windows
Copying and pasting eliminates the need to retype text.

You can copy from and paste text into:

� Text fields
� Terminal emulator windows
� Text Editor windows
� Mailer Compose windows

You can also copy text from a Mailer message view and a Help Viewer window and
paste it into Text Editor, terminal emulator, and Mailer Compose windows.

� To Select the Text To Be Copied
1. Move the pointer to the start of the text to be pasted.

2. Drag to the end of the text to be pasted, then release the mouse button, leaving the
text highlighted.
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� To Paste Text
1. Place the text insertion cursor in the target location.

2. Click mouse button 2 to paste the text.

Note – To deselect text, click in an empty area of the window that has the text selected,
or press Esc.

For related information, refer to:

� Chapter 3
� Chapter 12
� Chapter 14

Using Workspaces
Workspaces are like separate screens or windows. To help organize your desktop, you
can have separate workspaces for different groups of related tasks. For example, a
workspace you’ve named Reports could contain the tools you use to prepare reports,
such as a spreadsheet, desktop publisher, and graphics applications. You might set up
other workspaces according to your projects.

This section describes how to display workspaces, place windows in specific
workspaces, and rename workspaces.

For information about using your keyboard for desktop navigation, refer to
Appendix A.
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� To Display Another Workspace (Mouse)
� Click the workspace’s button in the workspace switch of the Front Panel.

� To Display Another Workspace (Keyboard)
1. Press Alt+Tab until the keyboard focus, as shown by the highlight, is on the Front

Panel.

2. Press the arrow keys to move the highlight to the button for the

workspace you want to display.

3. Press Return.

� To Place a Window in Other Workspaces (Mouse)
1. Click the Window menu button.

The Window menu appears.

2. Choose Occupy Workspace from the Window menu.

3. In the Workspaces list of the Occupy Workspace dialog box, select the workspaces
in which you want the window to appear.

� To select more than one contiguous workspace name in the list, hold down Shift
while you click.

� To select discontiguous workspace names in the list, hold down Control while you
click.

� Click a selected workspace to deselect it.

� To place the window in every workspace, click the All Workspaces button.

4. Click OK.
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� To Place a Window in Other Workspaces
(Keyboard)

1. To display the Window menu, press Alt+Spacebar.

2. Press the Down Arrow key to select Occupy Workspace, then press Return.

The Occupy Workspace dialog box appears.

3. Press Tab until the keyboard focus, as shown by the highlight, is in the Workspaces
list.

4. Select the workspaces in which you want the window to appear:

� Press Down Arrow or Up Arrow to move through the list.

� To select more than one workspace, press Shift+Down Arrow or Shift+Up Arrow.

5. Press Return.

� To Rename a Workspace (Mouse)
1. Click the Front Panel button for the workspace whose name you want to change.

That workspace is displayed.

2. Click the workspace’s Front Panel button again.

The button becomes a text field.

3. Edit the workspace’s name in the text field.

4. Once you’ve renamed the workspace, press Return.

� To Rename a Workspace (Keyboard)
1. Press Alt+Tab until the keyboard focus, as shown by the highlight, is on the Front

Panel.

2. Press the arrow keys to move the highlight to the button for the workspace you
want to rename.

3. Press Shift+F10 to display the workspace button’s pop-up menu.

4. Press the Down Arrow key to select the Rename item, then press Return.

The button becomes a text field.

5. Edit the workspace’s name in the text field.
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6. Once you’ve renamed the workspace, press Return.

Using Controls in Application Windows
Windows and dialog boxes contain controls that help you work with applications. You
use controls to manipulate objects, select choices, or type information.

This section describes various types of controls you’ll come across while using the
desktop. Here’s a list of the most common controls:

� Buttons initiate commands, start actions, or specify options and settings. Types of
buttons include push buttons and radio buttons.

� Check boxes specify options and settings.

� Text fields provide areas where you can type information.

� Lists display a scrollable list of choices from which you can select.

� Sliders provide incremental selection from a range of values.

� Scroll bars enable you to scroll through a window’s contents.

Push Buttons
Choosing a push button immediately performs the associated command or action. For
example, choosing an OK button applies any changes made to a dialog box then closes
it.

As a shortcut, many dialog boxes automatically give focus to the OK button so that
you can quickly specify settings and then press Return to choose OK.

OK, Cancel, and Help
are examples of push
buttons

� To Choose a Push Button (Mouse)
� Click the button.
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� To Choose a Push Button (Keyboard)
1. Press Tab and the arrow keys until the button has the keyboard focus, as shown by

the highlight.

2. Press Return.

Check Boxes and Radio Buttons
You select a check box to specify an option or setting. You can select more than one
check box in a group.

You also use a radio button (sometimes referred to as a choice button) to specify an
option or setting, but only one radio button in a group can be selected at a time.

� To Select a Check Box or Radio Button (Mouse)
� Click the check box or radio button you want to select.

� To Select a Check Box or Radio Button (Keyboard)
1. Press Tab and the arrow keys until the check box or radio button has the keyboard

focus, as shown by the highlight.

2. Press the Spacebar.
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To Scroll the Contents of a Window
Windows often contain more information than you can see at one time. Use a
window’s scroll bar to bring the window’s contents into view.

Click to move down one line

Click to move down one screen

Drag the slider to move to a region of the
window

Click to move up one screen

Click to move up one line

� To Scroll (Keyboard)
1. Press Tab to move to the window area you want to scroll.

2. Press the arrow keys, or Prev and Next, or Page Up and Page Down.

Hold down Control while you press an arrow key to scroll faster.

� To Use a Slider (Keyboard)
1. Press Tab or an arrow key to move the highlight to the slider.

2. Press Up Arrow or Down Arrow to move the slider.

Hold down Control while you press an arrow key to move the slider faster.

Selecting List Items
A selected list item becomes highlighted. The highlighted item is acted upon when
you click a button, such as OK.
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� To Select a List Item (Mouse)
1. Click the list item.

In a multiple-selection list, hold down Shift while you click the items.

To deselect an item, click it again.

2. Click a button, such as OK.

In some lists, double-clicking an item selects the item and chooses the default
command.

Single-selection list

Multiple-selection list

� To Select a List Item (Keyboard)
1. Press Tab to move to the list.

2. Select the list item:

� In a single-selection list, use the arrow keys to reach your choice.

� In a multiple-selection list, use the arrow keys to reach your first selection, then
press Shift+Up Arrow or Shift+Down Arrow.

To deselect an item, press the Spacebar.

3. Press Tab to move to a button, such as OK or Apply, then press Return.

Text Fields
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Text
insertion
cursor

A text field accepts information you type.

� To Enter Text in a Field (Mouse)
1. Click the field to display the text insertion cursor.

2. Type the text.

In many dialog boxes, pressing Return completes the text entry and activates the
default button, such as OK or Apply.

� To Enter Text in a Field (Keyboard)
1. Press Tab, Shift+Tab, or the arrow keys until you reach the text fie

ld.

A blinking cursor indicates that the text field has the keyboard focus.

2. Type the text, then press Control+Tab to move keyboard focus out of the text field.

� To Edit Text in a Field (Mouse)
1. Select the text in the field to edit:

Characters - Drag from the first character to the last character

Word - Double-click the word

Line - Triple-click the line

Multiline - Quadruple-click the field

To deselect text, click an empty area in the window.

2. Type the replacement text.
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To Edit Text in a Field (Keyboard)
1. Press Tab, Shift+Tab, or the arrow keys until you reach the field.

2. Use the editing keys to edit the field’s contents, then type the replacement text.

Arrow key - Move the text insertion cursor

Backspace - Delete the character to the left of the cursor

Delete or Delete char - Delete the character to the right of the cursor

Control+Delete or Control+Delete char - Delete from the cursor to the end of the line

3. Press Control+Tab to move keyboard focus out of the text field.

Using Menus
Menus provide access to commands you use to manage windows and operate
software applications.

Choosing a menu item performs an associated action on the currently selected object.
For example, when you select a window and choose Minimize from its Window
menu, the window becomes an icon.

Menu items that appear dimmed are available only under certain conditions. For
example, the Window menu’s Restore item is available only when the window is an
icon.

Menus you’ll use on the desktop include:

� Menus that you “pull down” from an application’s menu bar by clicking the
menu’s name or typing Alt and its mnemonic. A mnemonic is an underlined
character in a menu or item name.
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Mnemonic for the
File menu is Alt-F

Shortcut key
for Print

An application’s File menu is shown here.

The sequence of keys listed to the right of some items is called a shortcut key.
Typing mnemonics and shortcut keys gives you quick keyboard access to menu
items.

� Menus that “pop up” when you click mouse button 3 (or press Shift+F10) in an
application window or on a workspace object.

Window Menu
Use Window menu items to control windows and window icons.

This menu is displayed when you:

� Click the Window menu button in the upper left corner of a window

� Click a window icon
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� Press Alt+Spacebar with the keyboard focus on a window or window icon

Window
menu
button

Restore - Turns an icon back into a window

Move - Changes the window’s location

Size - Changes the size of the window (inactive for icons)

Minimize - Turns the window into an icon

Maximize - Enlarges the window to its greatest allowable size

Lower - Moves the window to the background

Occupy Workspace - Use to select the workspaces in which you want the window
to appear

Occupy All Workspaces - Displays the window in all workspaces

Close - Closes the window, removing it from the workspace

Workspace Menu
The Workspace menu is a pop-up menu that contains items for managing the
workspace.

To display the Workspace menu, click mouse button 3 on the workspace backdrop.
You cannot access this menu through your keyboard.
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FIGURE 1–5 Workspace Menu with Applications Submenu Displayed

Note – You can start many of the applications listed in the Applications submenu by
clicking their Front Panel controls or Application Manager icons. Selected
OpenWindows desktop applications are available on this menu; others are available
from within the OpenWindows application group in Application Manager.

� To Choose a Workspace Menu Item
1. Move the pointer over the workspace backdrop.

2. Press mouse button 3, drag to the item, then release the mouse button.

To close the menu without choosing an item, move the pointer away from the menu
and click.
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Note – You cannot choose a Workspace menu item using your keyboard.

� To Choose a Window Menu Item (Mouse)
1. Click the Window menu button to display the menu.

If the window is an icon, click the icon.

2. Click a menu item.

To close the menu without choosing an item, click anywhere other than the menu.

Tip – For faster access, you can press mouse button 1 over the Window menu button
or icon, drag to the item, then release the mouse button.

� To Choose a Window Menu Item (Keyboard)
1. Press Alt+Tab until you’ve placed the keyboard focus, as shown by the highlight,

on the window or window icon.

2. Press Alt+Spacebar to display the Window menu.

3. Press the key for the item’s mnemonic, the underlined character in the item name.

To close the menu without choosing an item, press Esc.

� To Choose a Menu Item with the Mouse
1. Display the menu:

� Pull-down (menu bar) menu: Using mouse button 1, click the menu name.

� Pop-up menu: Click mouse button 3 inside the application.

� Object’s pop-up menu: Click the object with mouse button 3.

2. Click the item.

You can also choose a menu item by pressing the mouse button, dragging to the item,
then releasing the mouse button.

To close a menu without choosing an item, move the pointer away from the menu and
click.
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� To Choose a Pull-Down Menu Item With the
Keyboard

1. Press Alt+Tab until you’ve placed the keyboard focus, as shown by the highlight,
on the application window.

2. Display the menu by holding down Alt and then pressing the key for the menu’s
mnemonic (the underlined character in the menu’s name as shown in the menu
bar).

3. Press the key for the item’s mnemonic.

Or, press an arrow key to move to the item, then press Return.

� To Choose a Pop-up Menu Item With the Keyboard
1. Press Alt+Tab until the keyboard focus is on the application window or workspace

object.

2. Press Shift+F10 to display the pop-up menu.

3. Press the key for the item’s mnemonic.

Or, press Down Arrow to move to the item, then press Return.

To close a menu without choosing an item, press Esc.

For more information about using your keyboard for desktop navigation, refer to
Appendix A.

Using Tear-Off Menus
In some applications such as Mailer and Calendar, you can “tear off” a menu, which
keeps it open on your desktop for repeated use. You can recognize the availability of a
tear-off menu by the appearance of a dotted line at the top of the menu.

� To Keep a Tear-Off Menu on the Desktop
1. Display the menu by clicking its name in the menu bar.

2. Click the dotted line above the first menu item.

The tear-off menu stays on your desktop until you dismiss it by either pressing Alt+F4
or double-clicking the Window menu button (in the upper left corner of the
application’s window).
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Basic Keyboard Skills
You can perform desktop tasks using your keyboard instead of your mouse. When
you use your keyboard for desktop navigation, note the following:

� The Alt key is the same as the Extend char key on some keyboards

� Return is the same as Enter on some keyboards

� Pressing Esc halts most interactive operations

� In Style Manager, the Window Behavior setting must be Click In Window To Make
Active (this is the default value)

For more information on the Window Behavior setting, refer to Chapter 9.

Keyboard focus uses the highlight to show you which element of a window, menu, or
control will respond to your input. To activate a selected menu item or control (such as
a button), press the Spacebar.

Here’s a summary of several common keyboard operations:

� To move the highlight to the next window: Press Alt+Tab.

� To move the keyboard highlight within a window: Press Tab and the arrow keys
(up, down, left, and right).

� To close a window and remove it from the workspace: Press Alt+F4.

� To minimize a window (turn it into an icon): Press Alt+Spacebar, then N to choose
Minimize from the Window menu.

� To move a window: Press Alt+Spacebar, then M to choose Move from the Window
menu. Press the arrow keys to move the window up, down, left, or right, then
press Return.

Hold down Control while you press an arrow key to move the window faster.

For more information about using your keyboard for desktop navigation, refer to
Appendix A. For information on currency symbols and characters from other
languages, see “Composing Special Characters” on page 70. For information on
displaying, manipulating and printing characters from the Thai and Hebrew Locales,
see Appendix D.
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Leaving the Desktop
This section describes how to log out of and exit the desktop, and how to lock your
display to prevent unauthorized use of your system when you are away from it and
have not logged out.

� To Log Out

Caution – Before logging out of the desktop, save your work in all open application
windows. Remember to check each workspace.

� Click the Exit control in the Front Panel.

� Or, choose Log out from the Workspace menu.

Note – You cannot display the Workspace menu using your keyboard.

As you log out of the desktop, your current session is saved. When you log back in,
the desktop will appear as it did before you logged out.

Applications that do not get saved as part of the current session include:

� Applications that you run in terminal emulator windows

� Non-desktop applications that do not preserve their state during logout

You’ll need to restart these applications when you log in. For more information, see
Chapter 2.
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� To Lock Your Display
To prevent unauthorized use of your system when you are away from it and have not
logged out:

� Click the Lock control in the Front Panel.

To unlock your display, type your password.

For information about screen lock options, refer to Chapter 9.

Composing Special Characters

Note – This section applies to users of English language locales only.

Characters such as £ and ¢ are not displayed on all types of keyboard. However, if you
are using a code set that supports the character you require, you can use special key
compose sequences to insert the required character in a document. For example, to
compose the e acute symbol (é), you press the Compose key, followed by the e key,
followed by the ’ (apostrophe) key.

The commonly used ISO 8859-1, or “ISO Latin-1” code set provides most of the
commonly used characters for Western European languages. For a table containing the
Compose Key Sequences for ISO 8859-1 see Appendix C.
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Note – For information on displaying, manipulating and printing text from CTL
(Complex Text Layout) locales such as Thai and Hebrew, see Appendix D.

Euro Currency Symbol
Established code sets such as ISO Latin-1 do not support the Euro symbol: They will
not enable you to create the symbol in a document; they will not display the symbol.

To create or display the Euro symbol, you need to be running one of the following:

� an ISO 8859–15 based code set such as en_US.8859–15 or en_UK.8859–15 (shipped
with Solaris 7 Operating Environment and compatible versions)

� A UTF-8 code set (commonly used by multilingual users) such as en_US.UTF-8 or
en_GB.UTF-8.

FIGURE 1–6 Euro Currency Symbol

Keyboard Placement
Table 1–1 shows the placement of the Euro on Sun Type 6 keyboards:

TABLE 1–1 Placement of Euro on Sun Type 6 Keyboards

Type 6 Keyboards Euro Placement

US AltGraph+4

UNIX AltGraph-E

UNIX/Logoless AltGraph-E

French AltGraph-E

Danish AltGraph-E

Italian AltGraph-E

Netherlands/Dutch AltGraph-E

Norwegian AltGraph-E

Portuguese AltGraph+E
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TABLE 1–1 Placement of Euro on Sun Type 6 Keyboards (Continued)
Type 6 Keyboards Euro Placement

Spanish AltGraph-E

Swedish AltGraph-E

Finnish AltGraph-E

Swiss/French AltGraph-E

Swiss/German AltGraph-E

UK (Ireland) AltGraph-E

Keyboard Input in UTF-8 Locales
Two additional methods exist for typing the Euro in UTF-8 locales.

� Unicode Hexadecimal code input method

To generate the Euro, type the Unicode value for this symbol: U+20AC

� Table Lookup Method

Activate this method by pressing Compose, followed by Ctrl+I. Select Latin from
the list of possible scripts, and choose the Euro from the table of characters.

Getting Help
You can request help by:

� Pressing F1 or the Help key

� Choosing an item from an application’s Help menu

� Clicking the Help button in a dialog box

� Opening the Help Manager to browse all the available help

For more information on using help, refer to Chapter 3.

The quickest and easiest way to get help is to press the F1 key. When you press F1,
the application you are using displays the help topic most closely related to your
current activity.

Some keyboards have a dedicated Help key that may take the place of the F1 key.
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Help Menu
Most applications have a Help menu for requesting specific kinds of help.

Overview - Displays introductory information about the application

Tasks - Displays instructions for using the application

Table of Contents - Displays a standard Table of Contents for the help volume

Reference - Displays summary information about application components

On Item - Changes the pointer to a question mark—click the question mark pointer on
an item to display its description

Using Help - Displays information about using Help

About - Displays version and copyright information about the application (in this
case, Text Editor)

To learn more about using help windows, choose Using Help from an application’s
Help menu. Or, you can press F1 while using a Help window.

� To Display the Help Manager
The Help Manager lists all the online help volumes installed on your system.

1. Click the Help Manager control in the Front Panel.

The Help Viewer opens, displaying the Help Manager.

2. Choose the Common Desktop Environment topic to display the list of help volumes
for the desktop.
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3. Browse the list of titles. To open a volume, click its title.
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CHAPTER 2

Starting a Desktop Session

A desktop session occurs between the time you log in and the time you log out.

The login screen, displayed by the Login Manager, is your gateway to the desktop. It
provides a place for you to type your login name and password. The Options menu on
the login screen lists your login options. In addition to running a desktop session, you
can run a failsafe session. You can also select the language for your session.

� “Starting and Ending a Desktop Session” on page 75
� “To Use a Session in a Different Language” on page 76
� “Starting a Failsafe Session” on page 77
� “Starting a Command-Line Session” on page 77
� “Using a Home Session” on page 78

Starting and Ending a Desktop Session
A desktop session starts when you log in. Session Manager is started after Login
Manager authenticates your login and password.

Session Manager provides the ability to manage sessions—to remember the state of
your most recent session and return you there the next time you log in.

Session Manager saves and restores:

� The appearance and behavior settings – for example, fonts, colors, and mouse
settings.

� The window applications that were running – for example, your File Manager and
Text Editor windows. Certain types of applications can’t be saved and restored by
Session Manager. For example, if you start the vi editor from a command line in a
Terminal window, Session Manager cannot restore your editing session.
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� To Log In to a Desktop Session
1. Type your login name and press Return or click OK.

2. Type your password and press Return or click OK.

If Login Manager does not recognize your name or password, click Start Over and
start the log in process over again.

Once you’ve logged in, Session Manager starts a session:

� If this is the first time you’ve logged in, you’ll get a new session.
� If you’ve logged in before, your previous session will be restored.

� To Log Out
� Click the Exit control in the Front Panel.

� Or, choose Log out from the Workspace menu.

When you log out of a regular desktop session, Session Manager saves information
about your current session so that it can be restored the next time you log in.
Information about non-desktop applications may not be saved.

� To Use a Session in a Different Language
1. Choose Language from the Options menu on the login screen.

2. Choose the language group that includes the language you need.

3. Select a language.

4. Log in.

The default language for your system is set by your system administrator. The Options
menu enables you to access other languages. Choosing a language in the Options
menu sets the LANG environment variable for your session. The default language is
restored at the end of the session.
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Starting a Failsafe Session
A failsafe session is a session that starts a single Terminal window (and optionally
Workspace Manager). It is useful when you need access to a single Terminal window
to execute several commands before logging in to a desktop session.

� To Log In to a Failsafe Session
1. Choose Session from the Options menu.

2. Choose Failsafe Session from the Session submenu.

3. Log in.

� To Log Out of a Failsafe Session
� Type the exit command in a Terminal window.

Starting a Command-Line Session
Command Line Login mode enables you to temporarily leave the desktop to work in
your operating system environment. Command Line Login mode is not a desktop
session. When your system is in Command Line Login mode, the desktop is
suspended. You log in using your operating system mechanism rather than Login
Manager. There are no windows because the X server is not running.

� To Log In to and Out of a Command-Line Session

Note – Certain types of configurations (for example, X terminals) do not provide a
Command Line Login mode option.

To enter Command Line Login mode:
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1. Choose Command Line Login from the Options menu.

The login screen disappears and is replaced by a console prompt.

2. Supply your login and password as prompted.

To leave Command Line Login mode:

� Type exit at a command-line prompt.

Using a Home Session
Ordinarily, the desktop saves session information when you log out and uses that
information to start your next session. If you start or stop applications during your
session, or use Style Manager to change the appearance and behavior of your system,
changes you make are reflected in your next session. This type of session is called a
current session.

The desktop also provides a home session. A home session is a session that you
explicitly save. It’s like taking a snapshot of your current session at some point in time.
Once you’ve saved a home session, you can specify that logging in always restores
that session instead of the current session.

� To Save a Home Session
1. Click the Style Manager control in the Front Panel.

2. Click the Startup control in Style Manager.

The Startup dialog box is displayed.

3. Click Set Home Session in the Startup dialog box.

4. Click OK in the confirmation dialog box that appears.

This saves the current state of your session.

� To Automatically Start the Home Session at Login
1. Click the Style Manager control in the Front Panel.
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2. Click the Startup control in Style Manager.

The Startup dialog box is displayed.

3. Select Return to Home session.

4. Click OK.

When you choose Return to Home session, Session Manager will not save your
session at logout.

� To Choose between the Current and Home Session
for Each Session

1. Click the Style Manager control in the Front Panel.

2. Click the Startup control in Style Manager.

The Startup dialog box is displayed.

3. Select Ask Me at Logout.

4. Click OK.

You decide what will be your next session—current or home—at logout time. If you
choose to return to the home session, the current session information is not saved.
(You cannot change your mind the next time you log in.)
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CHAPTER 3

Getting Help

Online help is available for each of the standard applications in the Common Desktop
Environment (CDE). Whether you are using File Manager, Calendar, or Mailer for
example, you request and display help topics in the same way. You can also browse
help information on your system using the desktop Help Manager.

Other applications installed on your desktop may take advantage of using the
desktop’s Help System or provide help in other ways.

� “Requesting Help” on page 81
� “Using Help Windows” on page 85
� “Selecting Help Topics” on page 87
� “Moving between Help Topics” on page 89
� “Searching for Specific Information” on page 92
� “Browsing Help on Your System” on page 95
� “Printing Help Topics” on page 101

Requesting Help
Here are the ways you can request Help:

� Press F1—also known as the “help key”—to get context-sensitive help

� Choose a command from an application’s Help menu

� Open Help Manager from the Front Panel to browse help on your system

� Open the Help subpanel to choose help about the desktop or to choose On Item
Help
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Press F1 — The Help Key
When you have a question, the quickest and easiest way to get help is to press F1.
When you press F1, the application you are using displays a help topic most closely
related to the component—a window or button for example—that is highlighted.
Because the application determines which help topic is most appropriate, this type of
help is called context-sensitive.

The F1 key is a quick way to get help on an application menu or dialog box. For
example, to request help about the File Manager File menu, display the File menu and
press F1. File Manager displays a description of each item in the menu. Or, if a dialog
box is open, pressing F1 will display an explanation of the dialog box. The F1 key is a
shortcut for clicking the dialog box’s Help button.

Note – Some computers have a dedicated “Help” key on the keyboard. If yours does,
it may take the place of the F1 key.

Using an Application’s Help Menu
Most applications have a Help menu that contains commands for requesting different
types of help such as an introduction, application tasks, or reference information.

FIGURE 3–1 CDE application Help menu

A typical CDE Help menu includes these commands:
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Overview—displays the home topic for the application. The home topic is the first topic
of the application’s help topic hierarchy.

Tasks—displays task instructions for most operations performed with the application.

Reference—displays reference summaries for various components, such as windows
and dialog boxes, menus, and application resources.

On Item—enables you to click an item in any window of an application and view a
description of the item.

Using Help—provides help on using the help windows.

About Application—displays the version and copyright information for the
application.

Applications can include additional choices. Also, non-CDE applications may have
different commands in their Help menus.

On Item Application Help
On Item help is interactive. It enables you to move the pointer to a specific item (such
as a menu, button or dialog box) and click the item to display its corresponding help.

� To Select On Item Help
1. Choose On Item from the Help menu.

The pointer changes to a ? (question mark).

2. Move the pointer to an item in the application and click mouse button 1.

A description of the item is displayed.

Using Help Manager
Help Manager is a special help volume that lists all the online help registered on your
system. Clicking the Help Manager control in the Front Panel opens the Help Manager
help volume.
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FIGURE 3–2 Help Manager control

Click any of the underlined titles to view the corresponding help information. For
additional instructions about using Help Manager see “Browsing Help on Your
System” on page 95.
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For convenience, the Help subpanel on the Front Panel provides help on CDE and the
Front Panel (see “Help Subpanel” on page 128).

FIGURE 3–3 Help Subpanel

Using Help Windows
The Help System is built into each of the CDE applications (and possibly other
applications installed on your system). When you ask for help while using an
application, the application displays a help window.

Applications can use two types of help windows to display help topics: a general help
window and a quick help window, shown in Figure 3–4.
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FIGURE 3–4 Types of help windows

FIGURE 3–4 Types of help windows

General help windows have a topic tree and a topic display area. The topic tree is a list
of help topics that you can browse to find help on a subject. When you choose a topic,
it is displayed in the lower portion of the help window called the topic display area.

Quick help windows are streamlined help windows. A quick help window has just a
topic display area and one or more buttons.
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Selecting Help Topics
There are two ways to select a help topic. You can choose a topic from the topic tree.
Or, within a help topic, you can select a hyperlink. A hyperlink is an active word or
phrase that “jumps” to another related help topic. Any underlined text in a help
window is a hyperlink.

Graphic images can also be used as hyperlinks. For more information about
hyperlinks, see “Using Hyperlinks” on page 88.

Using the Topic Tree
The topic tree is an outline of a help volume’s major topics. Subtopics are indented
under main topics. The current topic, whose contents are displayed in the topic
display area, is marked with an (arrow). You can scroll the topic display area to see all
your choices or resize the entire help window.
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You can also change the size of the topic pane. To do so, drag the sash control shown
in Figure 3–5. Then release the mouse button to set the new size.

FIGURE 3–5 Resizing the topic tree

� To Select a Topic
1. Move the pointer into the topic tree.

2. Click mouse button 1 on the topic you want to display.

Using Hyperlinks
Any underlined text in a help window is a hyperlink. It is easy to “jump” to related
help topics using hyperlinks—just click the underlined text.

What Hyperlinks Look Like
A solid underline identifies a standard hyperlink that displays the new topic in the
current help window. For example, the last paragraph in Figure 3–5 shows a hyperlink
of this type.
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A dashed underline indicates a definition link, which displays a quick help window.

A graphic—an icon, for example—can also be a hyperlink. A grey open-cornered
border identifies a graphic hyperlink. Figure 3–6 shows the different hyperlink formats
that can be used in help topics.

FIGURE 3–6 Hyperlink formats

Links That Display a New Window
Most hyperlinks display the related topic in the same window. However, if you choose
a hyperlink that jumps to a help topic for another application, a new window is
displayed. Links that jump from one application’s online help into another’s are called
cross-volume or cross-application hyperlinks.

� To Select a Hyperlink
1. Move the pointer to the underlined text or graphic image.

2. Click mouse button 1.

Moving between Help Topics
To move between help topics, use these commands on the Navigate menu:

Backtrack—returns to the previous topic. Backtrack enables you to return to each topic
you have visited.

History—displays a History dialog box that lists help volumes and topics you have
visited. Select a help topic to re-display it.

Home Topic—returns to the home topic, or beginning of the help volume.
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For convenience, Backtrack and History are also provided as push buttons.

Help Pop-up Menu
In a general help window, you can also use the Help pop-up menu as a shortcut. The
pop-up menu includes both Backtrack and Home Topic, which are frequently used
commands.

Quick help windows do not have a pop-up menu.

� To Display the Help Pop-up Menu
1. Point to the topic display area and press mouse button 3.

2. Choose Backtrack or Home Topic.

FIGURE 3–7 Help pop-up menu

Location Indicators
Because hyperlinks can quickly take you from one piece of information to another, you
may need to know where you are. A quick look at your help window can give you the
information you need.

� The line located below the menu bar reports the name of the volume you are
viewing. This is helpful when you have explored several help volumes using Help
Manager, the help index, or cross-volume links.
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� Within the topic tree, the first item is the home topic, or the beginning of the help
volume. After exploring topics, you can easily return to the home topic by scrolling
to the top of the topic tree. Or, you can choose Home Topic from the Navigate
menu or pop-up menu.

� An (arrow) points to the title of the current topic. As you choose topics, the arrow
moves to identify your selection. Scrolling the topic tree shows you where you are
located relative to other topics.

Knowing Where You’ve Been
A general help window keeps track of the topics that you have visited. The History
command opens a dialog box that lists the help volumes and help topics you have
visited.
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FIGURE 3–8 History dialog box

� To Use History to Return to a Topic
1. Click the History button.

2. Choose the title of the help volume or topic that you want to display.

3. When you’re done, click Close.

Searching for Specific Information
Like a book, a help volume has an index of important words and phrases that you can
use to find help topics on a subject. You can browse or search the index of the current
volume, selected volumes, or all help volumes available on your system.
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FIGURE 3–9 Index Search dialog box

Because the help index can be quite large even for a single volume, index entries can
be expanded or contracted. A + (plus) sign indicates that the index entry relates to
more than one help topic. The number shows the count of help topics. You can click
the index item to list the topics.

For instance, the result of an index search for the word “display” is shown in Figure
3–9. The -36 prefix tells you that there are 36 index entries that contain the keyword
“display.” Clicking any title marked by a + (plus) expands the list and the + (plus)
changes to a - (minus) sign. The last index entry shown in the figure has been
expanded in this way.
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� To Search for Topics Using the Help Index

Note – The help index is available only in a general help window.

1. To open the index, click the Index button.

The index lists all of the entries for the current help volume. You can choose All
Volumes to view an index for all available help volumes or choose Selected if you
want to select only certain volumes.

2. Select the Entries with field, type the word or phrase you are looking for, and press
Return.

Index searches are not case sensitive. Wildcards such as * (asterisk) and ? (question
mark) can be used (see “Pattern Searches” on page 94 below).

3. Select the index entry you want to view.

If the entry has a + (plus sign) prefix, the list will expand to show additional choices.
Then select a help topic to view.

You may view as many topics as you want.

4. Click Close when you are done.

Pattern Searches
In a pattern search certain characters (known as “wildcards”) have special meaning.
You can combine these characters in a variety of ways.

Two frequently used wildcards are asterisk (*) and question mark (?). The * matches
any string of characters (including no characters), and ? matches any single character.
Other wildcards include:

. (period)—matches any character

| (vertical bar)—specifies two search patterns and matches either pattern (logical OR)

( ) (parentheses)—encloses a pattern expression

To search for a character that has special meaning in a regular expression, precede the
character with a \ (backslash).

Examples

mouse.*clicking—matches entries that contain the word “mouse” followed by any
number of characters followed by “clicking”
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mouse | click—matches entries that contain the word “mouse” or “click”

(session | style)*manager—matches entries that contain “Session Manager” or “Style
Manager”

Browsing Help on Your System
You can browse all application help volumes registered on your system without
having to start each individual application—just start Help Manager from the Front
Panel.

At the top level, Help Manager groups help volumes into help families. For example,
the help family Common Desktop Environment lists help volumes for the standard
desktop applications. You can browse and display any of the volumes listed.

� To Open Help Manager
1. Click the Help Manager control in the Front Panel (see Figure 3–2).

A help window displays a list of help families with online help. This is the top level of
Help Manager.
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FIGURE 3–10 Top-level view in Help Manager

2. Scroll the window to find the product group you are interested in and click its title
(underlined).

This lists the help volumes available for that product.

3. To open a particular help volume, click its title (underlined text).

4. To return to the top level of Help Manager, click the Top Level button.

For example, to browse File Manager’s online help:

1. Click the Help Manager control.

2. Choose Common Desktop Environment.

3. Scroll the list of help volumes until you see File Manager Help.
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4. Click File Manager Help.

File Manager’s help is displayed. This is the same help information you would see if
you opened File Manager and chose Overview from the Help menu.

FIGURE 3–11 File Manager help viewed in Help Manager

� To Duplicate a Help Window
1. Choose New Window from the Help Manager File menu.

The current help window is duplicated. You can size the new window and select
topics independently of the original window.
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2. To remove the window, choose Close from the File menu.

Note – The New Window command is only available in the Help Manager help
window (see “Browsing Help on Your System” on page 95).

Displaying Documentation Online
Online manuals can be displayed by choosing AnswerBook2 from the Help subpanel.
The current versions of CDE manuals are normally available on the Internet at the
URL http://docs.sun.com.
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Displaying a Man Page
Manual reference pages, traditionally known as “man pages,” can be displayed using
the Man Page Viewer action. The action icon is located in the Desktop_Apps folder in
Application Manager.

FIGURE 3–12 Man Page action icon

� To Display a Man Page
1. Click the Application Manager control in the Applications subpanel of the Front

Panel.
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Application Manager opens.

2. Double-click the Desktop_Apps icon.

3. Double-click the Man Page Viewer icon.

A dialog box is displayed, prompting you to enter a man page name.

4. Type the name of the man page you want to see and optional command line
options, and press Return.

The man page is displayed in a quick help window.

5. Click Close to dismiss the man page.
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Note – For a list of command line options available with the man command, display
the man(1) man page.

Printing Help Topics
Sometimes you may want to have a printed version of a help topic for a particular
application. You can print an individual help topic, a table of contents and index, or
the entire help volume. Printing options, such as paper size, number of copies, and
destination printer, can also be set in the Print dialog box.

Printed help topics are directed to your default printer unless you provide a different
printer name in the dialog box. Printed output is text only.

� To Print a Help Topic
1. Choose Print from the File menu. (In a quick help window, click the Print button.)

You can use the default values in the Print dialog box and skip to step 5 or enter new
values for your print job.
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2. Optional. Type the name of the printer that you want to use.

3. Optional. Type the number of copies to print.

4. Optional. Click the paper size button to choose a paper size.

5. Select the topic or topics you want to print.

Current Topic (the default)—prints only the current topic

Current and Subtopics—prints the current topic and its subtopics

Table of Contents and Index—prints the help volume table of contents and index

Entire Volume—prints the contents of the help volume including the table of contents
and index

6. Click Print.

Printing Configuration
The Print dialog box displays the name of your default printer. You can change the
default printer name by modifying the LPDEST environment variable. You can also
change the printer for a specific application by modifying the application’s application
defaults file.
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� To Set the Printer Resource for an Application
� Edit your HomeDirectory/.Xdefaults file by adding this resource:

application_name*printer printer.name

If you do not have an .Xdefaults file, create the file in your home directory.

Example

You want to direct all printed help topics of an application named ImageScan to a
printer named laser2 rather than to your default printer.

Add this resource to your .Xdefaults file:

ImageScan*printer: laser2

Modifying Help Window Colors
You can change the colors of the topic tree or topic display area of a help window by
setting application resources. Choosing contrasting colors is important. This ensures
that text (foreground color) will be visible against the background color.

� To Change Help Window Colors for an Application
1. Edit your HomeDirectory/.Xdefaults file by adding these resources:

application_name*DtHelpDialog*DisplayArea.foreground: color
application_name*DtHelpDialog*DisplayArea.background: color
application_name*DtHelpDialog*TocArea.foreground: color
application_name*DtHelpDialog*TocArea.background: color
application_name*DtHelpQuickDialog*DisplayArea.foreground: color
application_name*DtHelpQuickDialog*DisplayArea.background: color

Substitute the name of the application whose help windows you want to change for
application_name.

You can ask your system administrator for a list of colors that you can use or refer to
your system documentation.

2. Save and close the file.

When you restart your application, it will use the new color values for the topic tree
and topic display area in its help windows.
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For example, these resource entries change the foreground and background colors of
the topic tree (TocArea) and topic display area (DisplayArea) for an application named
DtCardCatalog.

DtCardCatalog*DtHelpDialog*TocArea.foreground: yellow
DtCardCatalog*DtHelpDialog*TocArea.background: blue
DtCardCatalog*DtHelpDialog*DisplayArea.foreground: yellow
DtCardCatalog*DtHelpDialog*DisplayArea.background: blue
DtCardCatalog*DtHelpQuickDialog*DisplayArea.foreground: yellow

DtCardCatalog*DtHelpQuickDialog*DisplayArea.background: blue

Quick help windows do not have a topic tree, so the TocArea resource is omitted.
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CHAPTER 4

Using the Front Panel

The Front Panel is your “dashboard” or control area for the CDE desktop. It gives you
point-and-click and drag-and-drop access to the majority of applications on your
system; it allows you to switch workspaces; and it displays information such as time
and date, printer status, and so on. You can customize your Front Panel to include
your favorite applications, and you can move or minimize the Front Panel.

Before using the Front Panel, you should be aware of the following features:

� Using the Front Panel is faster than using Application Manager: it enables you to
run the common actions on the Main Panel with one click of the mouse, and you
can activate the thirty or so other controls on the subpanels with two clicks of the
mouse.

� Controls are grouped logically into subpanels, making them easier to find.

� Many controls on the Front Panel act as drop zones that carry out actions on files
and text dropped on them, often interpreting the required action by looking at the
file contents. For example, if you drop a mail message on the activity drop zone
(spinning globe) it opens the message in Mailer, but if you drop text file on the
same drop zone, it opens the file in Text Editor. Front Panel is also fully web-aware,
running the web browser when you drop bookmark files, URL text, or HTML files
on appropriate drop zones.

� Many controls on the Main Panel also act as indicators, displaying time and date,
print and mail status, workstation performance, and so on.

� “Front Panel Elements” on page 106
� “Basic Front Panel Skills” on page 107
� “Tour of the Front Panel” on page 114
� “Front Panel Applications” on page 132
� “Customizing the Front Panel” on page 138
� “Customizing Workspaces” on page 141
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Front Panel Elements
The Front Panel comprises the Main Panel (displayed by default) and several
subpanels that roll-up when you click their tab on the main panel.

Hosts subpanel

Tab for Hosts subpanel

FIGURE 4–1 Main Panel and an Open Subpanel

Main Panel
The central area of the Main Panel, called the workspace switch, enables you to display
other workspaces, run actions, lock the display and log out.

Subpanels
Above each control on the main panel is a tab marked with a triangle. Clicking this tab
displays the subpanel, whose name is indicated on its title bar.

Subpanels contain:

� A labelled copy of the control in the Main Panel.

� Other controls for running applications. (You can promote these to the Main Panel.)

� An Install Icon control, which acts as a drop zone for adding a control to the
subpanel.
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The Workspace Switch
The workspace switch contains the buttons you use to change from one workspace to
another, and other controls. You can rename a workspace by clicking its button and
editing the name text.

Workspace Switch

Editing a button

Each workspace occupies the entire display, as though your display has several layers.
Workspaces effectively expand the amount of display area available on your desktop.

Basic Front Panel Skills
This section covers basic skills for using Front Panel controls and subpanels.

� To Activate a Front Panel Control
� Click or double-click the control.

� To Open a Subpanel
Controls that have subpanels have an arrow button on top of the control.

� Click the tab above the control.
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Tabs

� To Close a Subpanel
The subpanel closes automatically when you choose a control unless you have moved
the subpanel from its original location.

� Click the tab for the open subpanel.

� Or, choose Close from the subpanel’s window menu (upper left corner)
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Window 
menu
button

Tab

Front Panel Pop-Up Menus
Each control in the Front Panel has a pop-up menu. The menu is different for each
control.

� To Display a Front Panel Pop-Up Menu
� Press mouse button 3 over the control.

The control’s pop-up menu is displayed.
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Contents of the Pop-Up Menus
The contents of the pop-up menu depend on the behavior of the control and its
location.

Main Panel Controls

If the control starts an application, the first entry in the menu is a command that starts
the application. Choosing the menu item has the same effect as clicking the control.

In addition, the pop-up menu may contain the following items:

� Delete Subpanel - Removes the subpanel and its contents

� Move Left - Interchanges the selected icon (and its subpanel) with the icon and
subpanel immediately to its left

� Move Right - Interchanges the selected icon (and its subpanel) with the icon and
subpanel immediately to its right

� Add Icon - Adds a blank icon immediately to the right of the selected control

� Delete Icon - Removes the selected icon and its subpanel

� Help - Displays On Item help for the control

Switch Area

The switch area is the portion of the workspace switch not occupied by other controls
or workspace buttons.
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The switch area pop-up menu contains the following items:

� Add Workspace - Adds a workspace and creates a workspace button in the
workspace switch

� Help - Displays help for the workspace switch

Workspace Buttons

Use the workspace buttons to change workspaces. Each button has its own menu.

The workspace button pop-up menu includes the following items:

� Add Workspace - Adds a workspace to your list of workspaces
� Delete - Deletes the workspace
� Rename - Changes the button into a text field for editing the name
� Help - Displays help for the workspace switch

Subpanel Controls

The pop-up menus for subpanels include a command for making the control the
current Main Panel control.
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The pop-up menu for subpanel controls includes the following items:

� Promote to Front Panel - Duplicates the control in the Main Panel, replacing the
current Main Panel control

� Rename - Renames the control on the subpanel

� Move Up - Interchanges the selected icon with the icon immediately above it

� Move Down - Interchanges the selected icon with the icon immediately below it

� Delete - Deletes the control from the subpanel

� Help - Displays On Item help for the control

Front Panel Drop Zones
The Front Panel contains the following controls that act as drop zones:

� Some controls act as drop zones as specified for the applications that they run. For
example, the File Manager control will display folder paths dropped on it, the Text
Editor control will open files dropped on it, and the Web Browser control will open
URLs dropped on it.
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� The Add Icon control on each subpanel acts as a drop zone (as explained in “To
Add an Application or Other Icon to a Subpanel” on page 139).

� The Activity indicator (globe) control on the main panel is a drop zone for all
registered data types, invoking the default actions for each object dropped on it.
For example, dropping a URL displays the URL in a browser, and dropping a
folder displays the folder contents in File Manager.

Front Panel Help
You can get help on:

� Individual controls
� Using and configuring the Front Panel

� To Get On Item Help on a Front Panel Control
� Choose Help from the control’s pop-up menu.

Or:

1. Display the Help subpanel.

2. Click the On Item Help control.

The pointer changes shape.

3. Click the control on which you want help.

� To Get Help on Using and Configuring the Front Panel
1. Display the Help subpanel.

2. Click the Front Panel Help control.

This displays the Help Viewer and Front Panel help volume.

� To Move the Front Panel or a Subpanel
Subpanels are moved like other windows—by dragging the title bar.

The Main Panel is moved using its move handles.
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Move handles

� To Minimize the Front Panel
Minimizing the Front Panel turns it into an icon.

� Click the Front Panel’s minimize button.

Minimize button

The Front Panel window icon is labeled with the workspace name.

Tour of the Front Panel
This section introduces the contents of the Main Panel and the subpanels. Your Front
Panel may be customized with different or additional controls.
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Main Panel
The following table describes the controls on the Main Panel.

TABLE 4–1 Main Panel Controls

Icon

Control

(Subpanel) Click Behavior Drop Behavior Indicator Behavior

Clock (Links) Opens the default
browser

None Current time

Calendar
(Cards)

Starts the
Calendar
application

Dropping an
appointment file
adds the
appointment to
the calendar

Current date

File Manager
(Files)

Opens a File
Manager view of
your home folder

Dropping a
folder opens a
File Manager
view of that
folder

None

Text Note
(Applications)

Starts the desktop
Text Editor
application

Puts the dropped
file or text on the
workspace

None
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TABLE 4–1 Main Panel Controls (Continued)

Icon

Control

(Subpanel) Click Behavior Drop Behavior Indicator Behavior

Mailer (Mail) Starts the desktop
Mailer
application

Attaches dropped
item to a New
Message window

Changes
appearance when
you have new
mail

Lock Locks the display
and keyboard.
You must type
your password to
unlock the
system.

None None

Workspace
switch

Changes
workspaces

None Indicates current
workspace

Activity
Indicator

Displays a Go
action dialog box

Runs action (for
example, a
browser)
registered for
data type
dropped

Spins when the
system is running
an action
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TABLE 4–1 Main Panel Controls (Continued)

Icon

Control

(Subpanel) Click Behavior Drop Behavior Indicator Behavior

Exit Begins logout
from the current
session

None None

Default

(Personal
Printers)

Displays the
status of the
default printer

Prints the file on
the printer

None

Style Manager
(Tools)

Opens the
desktop Style
Manager
application

None None

Performance
Meter (Hosts

Opens
Performance
Meter

Opens
Performance
Meter for the
hostname
dropped

Once activated,
indicates CPU
and disk activity
for future
sessions

Help Manager
(Help)

Opens a Help
Viewer window
displaying the
top level of help
information

Dropping a
master volume
file (*.sdl)
opens a Help
Viewer window
with that help
volume

None
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TABLE 4–1 Main Panel Controls (Continued)

Icon

Control

(Subpanel) Click Behavior Drop Behavior Indicator Behavior

Trash (Trash) Opens the Trash
Can window

None Different
appearance when
not empty

Links Subpanel
Use the Links subpanel to open a web browser, display the Sun Microsystems web
search site (http://search.Sun.com), and manage your personal bookmarks.

TABLE 4–2 Links Subpanel Controls

Icon Name Click Behavior Drop Behavior

Clock Opens default browser Opens default browser
for URL
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TABLE 4–2 Links Subpanel Controls (Continued)
Icon Name Click Behavior Drop Behavior

Web Browser Opens default browser Opens default browser
for URL

Personal Bookmarks Opens File Manager view
of personal bookmarks

Opens default browser
for URL

Find Web Page Opens default browser
for the Sun Microsystems
search site

None

Cards Subpanel
Use the Cards subpanel to open Calendar and search for address cards, host cards,
and mail alias cards.

TABLE 4–3 Controls on the Cards Subpanel

Icon Name Click Behavior Drop Behavior

Calendar Opens Calendar for the
current date and user

Sets up the dropped
appointment
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TABLE 4–3 Controls on the Cards Subpanel (Continued)
Icon Name Click Behavior Drop Behavior

Find Card Opens Address Manager
with default search
options

Opens a dropped card, or
opens Address Manager
with default options and
searches for dropped text

Files Subpanel
Use the Files subpanel to:

� Open File Manager
� Access removable media such as CD-ROMs and diskettes
� Examine file properties
� Run encryption, compression, and archiving commands
� Find files and folders
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TABLE 4–4 Controls on the Files Subpanel

Icon Name Click Behavior Drop Behavior

Home Folder Opens File Manager view
of $HOME

Opens File Manager view
of dropped folder

Open Floppy Loads a diskette in drive
and displays File
Manager view of it.

None

Open CD-ROM Loads a CD-ROM
volume in drive and
displays a File Manager
view of it

None
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TABLE 4–4 Controls on the Files Subpanel (Continued)
Icon Name Click Behavior Drop Behavior

Properties Opens Properties dialog
box with no file selected

Opens Properties dialog
box for file or folder
dropped

Encryption Prompts for the file to be
encrypted and the
encryption key

Encrypts and replaces an
unencrypted file;
decrypts and replaces an
encrypted file

Compress File Prompts for file to be
compressed

Compresses and replaces
an uncompressed file;
decompresses and
replaces a compressed
file

Archive Prompts for file or folder
to be archived

Archives and replaces
dropped file or folder

Find File Opens File Finder in
default mode

Searches for dropped text
as file or folder name
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Applications Subpanel
Use the Applications subpanel to post text and voice notes on the workspace, to run
Text Editor, and to open Application Manager.

TABLE 4–5 Controls on the Applications Subpanel

Icon Name Click Behavior Drop Behavior

Text Note Opens Text Editor in note
mode

Puts the dropped file on
the workspace

Text Editor Opens Text Editor Opens the dropped file in
Text Editor

Voice Note Opens Audio in note
mode

None

Applications Opens Application
Manager

None
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Mail Subpanel
Use the Mail subpanel for to access Mailer or to connect to the Solaris suggestion box
mail alias.

TABLE 4–6 Controls on the Mail Subpanel

Icon Name Click Behavior Drop Behavior

Mail Opens Mailer Displays New Message
dialog box and attaches
dropped file

Suggestion Box Opens New Message
dialog box to sent to the
default suggestion box
mail alias for Solaris at
Sun Microsystems

Displays New Message
dialog box for suggestion
box mail alias and
appends dropped file

Personal Printers Subpanel
Use the Personal Printers subpanel to view print jobs on your printer or to work with
all the printers on your system.
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TABLE 4–7 Controls on the Personal Printers Subpanel

Icon Name Click Behavior Drop Behavior

Printer Jobs Opens Printer Jobs for your
default printer

Prints the dropped file
on the default printer

Print Manager Opens Print Manager for all
printers available on your
network

Prints the dropped file
on the selected printer.
This is a useful method
of printing to a printer
other than your default
printer.

Tools Subpanel
Use the Tools subpanel to setup your preferences for the desktop and workspace, to
run Process Manager, and to view errors in CDE.
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TABLE 4–8 Controls on the Tools Subpanel

Icon Name Click Behavior Drop Behavior

Desktop Style Opens Style Manager None

CDE Error Log Displays the file
$HOME/.dt/errolog
which contains CDE
errors after xsession
startup

None

Customize Workspace
Menu

Warns you to update the
workspace and opens a
File Manager view of the
Workspace menu

None
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TABLE 4–8 Controls on the Tools Subpanel (Continued)
Icon Name Click Behavior Drop Behavior

Add Item To Menu Opens the Add Item to
Workspace Menu dialog
box

None

Find Process Opens Process Manager
for your workstation

Opens Process Manager
in default mode

Hosts Subpanel
Use the Hosts subpanel to view system information, to monitor host performance, to
open terminal and console sessions on hosts, and to find hosts.

TABLE 4–9 Controls on the Hosts Subpanel

Icon Name Click Behavior Drop Behavior

Performance Opens Performance
Meter for your
workstation

Opens Performance
Meter in default mode
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TABLE 4–9 Controls on the Hosts Subpanel (Continued)
Icon Name Click Behavior Drop Behavior

This Host Opens Terminal window
for your workstation

None

System Info Opens Workstation
Information for your
workstation

Displays Workstation
Information for dropped
host name

Console Opens Console for your
workstation

None

Find Host Opens Address Manager
to search for host cards

Searches for dropped
host name

Help Subpanel
The Help subpanel enables you to access AnswerBook2™ documentation, the master
help volume (Help Manager), and other online help volumes such as Front Panel
Help.
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First-time CDE Users
If you are upgrading from a previous version of CDE and want to read about the
current features of the CDE desktop, see:

� Desktop Introduction
� Front Panel Help

If you are transitioning from OpenWindows, see:

� Desktop Introduction

� Front Panel Help

� Solaris Common Desktop Environment: User’s Transition Guide which can be accessed
via the AnswerBook2 viewer.

If you are transitioning from another windowing system such as Microsoft Windows,
see:

� Desktop Introduction

� Front Panel Help

� Solaris Common Desktop Environment: User’s Guide which can be accessed via the
AnswerBook2 viewer

Using the Front Panel 129



Help with Procedures
If you need to know how to carry out a procedure or task in CDE, see:

� Help Manager and search the help volumes for the required procedure or keyword

� The procedures in Solaris Common Desktop Environment: User’s Guide which can be
accessed via the AnswerBook2 viewer

Technical Issues and Support
System administrators will find Solaris Common Desktop Environment: Advanced User’s
and System Administrator’s Guide (available via the AnswerBook2 viewer) useful for
resolving configuration and administration issues.

System administrators investigating possible bugs should register with SunSolve™,
the Sun Microsystems online information, FAQ, and patch service; click SunSolve
Online for more details. For help with specific problems that may require interaction
with technical support, click on Solaris Support.

The following table describes the Help subpanel controls.

TABLE 4–10 Help Subpanel Controls

Icon Name Click Behavior Drop Behavior

Help Manager
(duplicate of Main
Panel control)

Opens a Help Viewer
window displaying the
top level of help
information

Dropping a master
volume file (*.sdl)
opens that help volume

SunSolve Online Opens a browser for the
Sun Microsystems
documentation and FAQ
web site

None

Solaris Support Opens a browser for the
Sun Microsystems
download site for
patches, and technical
support

None
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TABLE 4–10 Help Subpanel Controls (Continued)
Icon Name Click Behavior Drop Behavior

Information Opens the Information
folder in Application
Manager

None

Desktop Introduction Displays the Introducing
the Desktop help volume

None

Front Panel Help Displays the Front Panel
help volume

None

On Item Help Provides on-item help for
the Front Panel. Click this
control, then click the
control on which you
want help.

None

AnswerBook2 Displays the
AnswerBook2 viewer if
you have AnswerBook2
installed.

None
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Trash Subpanel
Use the Trash subpanel to trash and recover files, and to remove (shred) files from the
system.

TABLE 4–11 Controls on the Trash Subpanel

Icon Name Click Behavior Drop Behavior

Trash Opens Trash Can
window

Moves dropped files to
the Trash Can window

Empty Trash Can Shreds (removes)
contents of Trash Can
window

Moves dropped files to
Trash Can window

Front Panel Applications
This section describes selected applications available on the default Front Panel. Other
applications are described in their respective chapters, or in their online help or man
pages.

Changing the Default Web Browser
The Links subpanel of the Front Panel contains a Web Browser control. When you
click the control, the default browser is launched.
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Your PATH environment is searched for the netscape command (for the Netscape
browser) or hotjava command (for the HotJava™ browser).

If the netscape command is found first, the Netscape browser is launched. If the
hotjava command is found first, the HotJava browser is launched. If neither is
found, an error dialog box appears reporting the failure to find a browser.

The SdtWebClient action is used to launch your system’s default web browser. If
you want to ensure that the default is always Netscape, change the MAP_ACTION
setting in your user-prefs.dt file to

MAP_ACTION SDtNetscape

If you want to ensure that the default is always the HotJava browser, change the
MAP_ACTION setting in your user-prefs.dt file to

MAP_ACTION SDtHotJava

The user-prefs.dt file belongs in your $HOME/.dt/types directory. To create a
user-prefs.dt file, copy the /usr/dt/appconfig/types/C/user-prefs.dt
file and save it in your $HOME/.dt/types directory as user-prefs.dt.

� To Display a Different Clock
The Links subpanel of the Front Panel contains a Clock control. When you click the
control, the default browser is launched. You can remove this control and display a
digital clock on the desktop as follows:

1. Open the Links Subpanel.

2. Click mouse button 3 on the Web Browser control.

A pop-up menu is displayed.

3. Choose Promote to Front Panel.

The Web Browser control is displayed on the Main Panel and the Clock control is
displayed on the subpanel.

4. Click mouse button 3 on the Clock control.

A pop-up menu is displayed.

5. Choose Delete.

The Clock control is removed from the subpanel.

6. Open the Desktop Tools folder in Application Manager.

7. Double-click Digital Clock.

The Digital Clock application displays the time and date. This application can be left
on your Workspace permanently. Ensure that it is saved with your session defaults
using Style Manager.
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Working With Bookmarks
A bookmark is a file containing a web URL, or a folder or attachment containing
bookmarks. Clicking on a bookmark’s icon displays the web page in your default
browser.

CDE uses a file extension of .url to identify bookmarks. Double click the
index.html icon in the Sample Bookmarks folder to read more about bookmarks in
CDE.

Personal Bookmarks
The Folders subpanel of the Front Panel contains a Personal Bookmarks control. When
you click the control, a File Manager view appears on the desktop. It is initially empty.
You can create bookmarks to put in this folder. These URLs are then easily accessible
through the Front Panel.

Creating Bookmarks
You can create bookmarks in any of the following ways:

� Drag URL text onto the Personal Bookmarks window. This creates a new file. The
new file name is Untitled.url unless there is another file in your Personal
Bookmarks folder with that name. In that case, a dialog box appears telling you to
rename the new file.

� Drag URL text onto the Personal Bookmarks control on the Front Panel. This
creates a new file with a .url extension.

� Copy an existing bookmark: Use the File Manager Selected menu to copy an
existing bookmark into your Personal Bookmarks folder, or hold down the Control
key and drag the icon onto the opened Personal Bookmarks File Manager window
or the Personal Bookmarks control on the Front Panel.

You can create a bookmark using any URL that is normally available, such as URLs
with http addresses.

Sharing Bookmarks
If you drop URL text or a bookmark file or folder onto the Front Panel mail icon, a
Mailer Compose window appears with the corresponding bookmark as an
attachment.
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Using Find Web Page
The Find Web Page control on the Links subpanel enables you to display a Sun
Microsystems search site, http://search.sun.com/. This site enables you to search
selected sites at Sun Microsystems or to search the Internet.

You may find this search site more useful than standard commercial sites when you
are searching for information relating to Sun Microsystems and its products.

Using Encryption
The Encryption control on the Files subpanel enables you to encrypt and decrypt files
using the default encryption application. The encryption application shipped with
Solaris is crypt, as described in the crypt man page.

� To Encrypt a File
You can encrypt a file by doing one of the following:

1. Click Encrypt in the Desktop_Tools folder of Application Manager, and specify the
file and encryption key in the dialog box displayed.

2. Or, click the Encryption icon on the Files subpanel, and specify the file and
encryption key in the dialog box displayed.

3. Or, drop the file on the Encryption icon on the Files subpanel and specify the
encryption key in the dialog box displayed.

The file is encrypted, encoded, and replaced in its original location.

� To Decrypt a File
You can decrypt a file by doing one of the following:

1. Click Decrypt in the Desktop_Tools folder of Application Manager, and specify the
file and encryption key in the dialog box displayed.

2. Or, drop the file on the Encryption icon on the Files subpanel and specify the
encryption key in the dialog box displayed.

The file is decoded, decrypted, and replaced in its original location.

Using the Front Panel 135



Tip – You can decrypt a file by double-clicking on it in a File Manager window.

Using Compression
The Compression control on the Files subpanel enables you to compress (or zip) and
decompress (or unzip) files using the default compression application. Compression
and Decompression is also available via the Compress File and Uncompress File icons
in Application Manager.

The encryption application shipped with the Solaris software is compress which, as
described in the crypt man page, uses adaptive Lempel-Ziv coding. Compressed files
are given the extension .z.

� To Compress a File
1. Click Compress File in the Desktop_Tools folder of Application Manager and

specify the file in the dialog box displayed.

2. Or, click the Compression icon on the Files subpanel and specify the file in the
dialog box displayed.

3. Or, drop the file on the Compression icon on the Files subpanel.

The file is compressed, given a .z extension, and replaced in its original location.

� To Decompress or Restore a File
1. Click Uncompress File in the Desktop_Tools folder of Application Manager, and

specify the file in the dialog box displayed.

2. Or, drop the file on the Compression icon on the Files subpanel.

The file is decompressed, has its .z extension removed, and is replaced in its original
location.
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Tip – You can decompress a file by double-clicking on it in a File Manager window.

Using Archiving
The Archive control on the Files subpanel enables you to archive (tar) and unpack
files. tar commands are also available via the Archive, Archive Unpack, and Archive
List Contents icons in Application Manager.

The archiving application shipped with Solaris is tar which is described in the tar
man page. By default, archived files are given the extension .tar.

� To Archive a File
1. Click Archive in the Desktop_Tools folder of Application Manager and specify the

relevant file and folder names in the dialog box displayed.

2. Or, click the Archive icon on the Files subpanel and specify the relevant file and
folder names in the dialog box displayed.

3. Or, drop the file on the Archive icon on the Files subpanel.

The file is compressed, given a .tar extension, and replaced in its original location.

� To Unpack an Archived File
1. Click Archive Unpack in the Desktop_Tools folder of Application Manager, and

specify the file in the dialog box displayed.

2. Drop the file on the Archive icon on the Files subpanel.

The file is decompressed, has its .tar extension removed, and is replaced in its
original location.

Tip – You can unpack a file by double-clicking on it in a File Manager window.

Using Suggestion Box
The Suggestion Box control on the Mail subpanel enables you to send an email to a
product improvement proposals mailbox at Sun Microsystems.

Your suggestions should do one of the following:
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� Propose the addition of applications, utilities and services to Solaris

� Propose enhancements to existing services and applications

� Report functionality and nomenclature you find difficult to understand, learn, or
use

Caution – The suggestion box facility does not provide any guaranteed level of
service to you. For issues or bugs that you need to be resolved, use the normal bug
reporting process, which is conducted through the distributor network.

Using Workstation Information
When you click System Info on the Hosts subpanel, the Workstation Information
dialog box is displayed. The information in this dialog box is typically of interest to
system administrators and technical support agents. It includes:

� User identification
� System identification
� Memory usage and allocation
� Version identification for operating environment and CDE
� Current session information

Tip – You cannot change the amount of physical memory allocated using Workstation
Information. For information on setting the swap space, see the swap(1M) man page.

Customizing the Front Panel
You can change the layout and contents of the subpanels and change the contents of
the main panel by:

� Adding controls to subpanels
� Interchanging Main Panel and subpanel controls
� Adding subpanels
� Adding and deleting workspaces
� Renaming workspaces

Other customization options require that you create or edit a Front Panel configuration
file. These are explained in Solaris Common Desktop Environment: Advanced User’s and
System Administrator’s Guide.
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� To Put a Subpanel Control in the Main Panel
1. Click mouse button 3 on the subpanel control you want to put in the Main Panel.

2. Choose Promote to Main Panel from the control’s pop-up menu.

� To Add an Application or Other Icon to a Subpanel
You can add any type of File Manager or Application Manager icon to the Front Panel.
However, the most convenient use for this feature is adding application icons.

1. Display the object’s icon in File Manager or Application Manager.

2. Display the subpanel to which the object is to be added.

3. Drag the object to the Install Icon control and drop it on the control.

How Installed Icons Work
The behavior of controls added to the Front Panel using the Install Icon control
depend on the type of icon that was dropped.

� File - The same behavior as the file’s icon in File Manager
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� Folder - Opens a File Manager view of the folder

� Application group - Opens an Application Manager view of the application group

� Application icon - The same behavior as the application’s icon in File Manager or
Application Manager

Adding and Removing Subpanels
Any control in the Main Panel can have a subpanel.

� To Add a Subpanel
1. Click mouse button 3 on a control in the Main Panel that does not have a subpanel.

2. Choose Add Subpanel from the control’s pop-up menu.

� To Remove a Subpanel
1. Click mouse button 3 on the control whose subpanel you want to remove.

2. Choose Delete Subpanel from the control’s pop-up menu.

� To Replace a Control in the Main Panel
The easiest way to replace a control in the Main Panel is to exchange it with a
subpanel control. If the control does not have a subpanel, you can create one
temporarily or permanently.

1. If the control you want to replace does not have a subpanel, create one by choosing
Add Subpanel from the control’s pop-up menu.

2. Display the new subpanel.

3. If the control you want to put in the Main Panel is not already in the subpanel, add
it to the subpanel.

See “To Add an Application or Other Icon to a Subpanel” on page 139.

4. Choose Copy to Main Panel from the subpanel control’s pop-up menu.
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� To Remove All User Customizations

Note – This procedure does not affect advanced customizations made by manually
editing Front Panel configuration files.

1. Open Application Manager and double-click the Desktop_Controls application
group icon.

2. Double-click Restore Front Panel.

The screen will go blank for several seconds while the Workspace Manager is
restarted.

The Restore Front Panel action removes all customization made using:

� The Install Icon control
� The Front Panel’s pop-up menus

Customizing Workspaces
You can use the Front Panel workspace switch to rename workspaces and change the
number of workspaces.

� To Rename a Workspace
1. Point to the workspace button of the workspace you want to rename.

2. Choose Rename from the button’s pop-up menu (displayed by pressing Shift+F10
or mouse button 3).

The workspace button turns into a text field.

3. Edit the text field.

4. Press Return.

� To Add Workspaces
1. Point to any area in the workspace switch and press mouse button 3 to display the

pop-up menu.
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2. Choose Add Workspace from the pop-up menu.

The new workspace, named New, is placed at the end of the set of workspaces.

3. Rename the workspace (see “To Rename a Workspace” on page 141).

� To Remove Workspaces
If you remove a workspace that contains windows, those windows are moved to the
next workspace.

1. Point to the workspace button of the workspace you want to remove.

2. Choose Delete from the button’s pop-up menu (displayed by pressing Shift+F10 or
mouse button 3).

� To Customize the Controls in the Workspace
Switch
This is an advanced task that requires you to create a Front Panel configuration file.
Advanced customization is covered in Solaris Common Desktop Environment: Advanced
User’s and System Administrator’s Guide.

Initially, the workspace switch has the four positions shown below.

Position 1
Lock

Position 2
Activity Indicator

Position 3
Blank

Position 4
Exit/Logout

Use this procedure to replace one of these controls. (Blank is also a control.)
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1. Install the application you want placed in the switch into the Applications
subpanel.

For example, if you want to add a Display System Load control to the switch, drag it
from the Desktop_Tools application group to the Applications subpanel.

2. Locate the Front Panel configuration file created automatically when you installed
the control in the Applications subpanel. The definition is located in the directory
$HOME/.dt/types/fp_dynamic.

For example, when Display System Load is added to the Applications subpanel, it
creates the file Xload1.fp.

3. Move the file from the $HOME/.dt/types/fp_dynamic directory to the
$HOME/.dt/types directory.

4. Open the file in the $HOME/.dt/types directory for editing.

Edit the lines that define the CONTAINER_TYPE and CONTAINER_NAME to the
following:

CONTAINER_TYPE SWITCH
CONTAINER_NAME Switch

5. Edit the line that defines the position (POSITION_HINTS). For example, to put the
control in the Blank location, set:

POSITION_HINTS 3

6. Save the configuration file.

7. Create another file in the $HOME/.dt/types directory.

The file name must end with .fp. For example. you might create a new file
$HOME/.dt/types/DeleteBlank.fp.

8. Open the file for editing.

9. Open the file /usr/dt/appconfig/types/language/dtwm.fp in another editor
window.

This file is read-only. You will not have to write to it.

10. In /usr/dt/appconfig/types/language/dtwm.fp, find the definition for the
switch control you are replacing.

For example, this is the definition for the Blank control:

CONTROL Blank
{

TYPE blank
CONTAINER_NAME Switch
CONTAINER_TYPE SWITCH
POSITION_HINTS 3
ICON FpblnkS
HELP_TOPIC FPOnItemSwitch
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HELP_VOLUME FPanel
}

11. Copy the definition for the control you are replacing from
/usr/dt/appconfig/types/language/dtwm.fp to the new configuration file.

For example, you would copy the definition for the Blank control to the new file
$HOME/.dt/types/DeleteBlank.fp.

12. Add the line DELETE True to the end of the definition, within the curly braces:

CONTROL Blank
{

... HELP_VOLUME FPanel
DELETE True

}

13. Save the file.

14. Choose Restart Workspace Manager from the Workspace menu.

Front Panels and Multiple Screens
CDE for Solaris supports multi-headed systems, or multiple screens on the same
workstation. This effectively adds space to your CDE desktop. By default, each screen
on your system has its own Front Panel.

Each Front Panel is handled separately by CDE, so changes made to one Front Panel
will not affect others. See “Miscellaneous Configurations” and ”Advanced Front Panel
Configuration“ in Solaris Common Desktop Environment: Advanced User’s and System
Administrator’s Guide.
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CHAPTER 5

Managing Files with File Manager

Use File Manager to create, find, and use desktop objects: files, folders, and
applications. Each object is represented by an icon in File Manager.

� “Introducing the File Manager Window and Desktop” on page 146
� “Manipulating Files and Folders” on page 156
� “Navigating to Folders and Subfolders” on page 159
� “File and Folder Ownership and Security” on page 163
� “Deleting Objects to the Trash Can” on page 162
� “Using File Manager Objects on the Desktop” on page 176
� “Using File Finder” on page 178
� “Customizing File Manager Views” on page 184
� “Using Removable Media with File Manager” on page 192

To open File Manager:
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� Click the File Manager control in the Front Panel.

Introducing the File Manager Window
and Desktop
The File Manager main window is a view of a folder on your system. The folder you
are currently viewing is called the current folder.

Menu bar and
menus

Object iconsObject viewing
area

Current folder
path

� Current folder path - Displays iconic view of the current folder’s path (double-click
to change path)

� Menu bar and menus - Contains the commands available in File Manager
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� Object viewing area - Shows the objects (files and folders) in the current working
folder

� Object icons - Uses icons to represent the files and folders in the current folder

Basic File System Concepts
This section describes basic file system concepts.

Files
A file is a container that holds information. Most of the files you use contain
information (data) in some particular format—a document, a spreadsheet, a chart. The
format is the particular way the data is arranged inside the file. The format of a file is
known as its data type.

When File Manager is in one of its icon-view modes, you can identify the data type of
a file by the icon used to represent the file. Each data type has a different icon.

Most application programs understand a limited number of data types. For example, a
document editor probably cannot read a spreadsheet file. The desktop helps you
recognize different types of files using a data-type database. In most cases, when you
double-click a file, the desktop will automatically launch the application that
understands that file’s data type.

The maximum allowable length of a file name varies from system to system. Some
operating systems do not allow file names longer than 14 characters. If necessary,
consult with your system administrator.

Folders
A folder is a container for files, similar to a folder in a file cabinet. In fact, File Manager
uses a folder icon to represent a folder. A folder can contain other folders—sometimes
called subfolders. With folders and subfolders, you can create multiple layers of
organization that form a hierarchy. In other contexts, folders are often referred to as
directories.

Within any single folder, each file name must be unique. However, files in different
folders may have the same name.
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As you navigate from folder to folder, your current location is referred to as the current
folder.

Objects
Since files and folders are both represented in File Manager as icons, the term object is
used to describe them both. Objects are discrete things on the desktop that you can
create and manipulate.

On the desktop, applications can also be represented as objects. For example,
Application Manager contains objects representing the applications available on your
system.

Paths
The location of a file is often specified by listing the folders and subfolders that lead to
the file—this list is called a path. A file’s path is visible in two places in File Manager.
First it is shown in the iconic path as a string of folders. Second, it is shown in a text
form in the text path line above the view area. These two areas can be turned off. (See
“To Configure the Headers” on page 184 for more information.)

Paths and Path Names
The path to an object is a way to specify where the object is located in the file system.
There are two ways to specify the path: absolute path and relative path.

Absolute Paths
A path is an absolute path if it begins at the root folder. The root folder is the single
common folder on your system where the hierarchy begins. If a path begins with a
slash (/), it is an absolute path specified from the root folder. For example, the
following is an absolute path to the file letter:

/usr/dt/config/letter

Relative Paths
A path is relative if it describes the location of a file or folder as it relates to the current
folder. If you are in a folder and you want to move down the folder tree, you don’t
need to type the absolute path name. You can just type the path starting with the name
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of the next folder in the path. If a path does not begin with a slash, it is a relative path.
For example, if the current folder is /usr/dt and you want to move to the folder
/usr/dt/config/letters, you would use the following relative path:

config/letters

Two special folder names are useful when specifying relative paths. The “.” folder
(sometimes called “dot”) represents the current folder. The “..” folder (sometimes
called “dot-dot”) represents the parent folder—the folder one level up in the folder
hierarchy. For example, if your current folder is /usr/dt/config, then the relative
path to the Dtwm file becomes:

../app-defaults/language/Dtwm

because the file is in the /usr/dt/app-defaults/language folder, one level above
the current folder and in the app-defaults/language subfolder.

See Also
� “To Change to Another Folder” on page 159
� “To Find a File or Folder by Name” on page 179
� “To Find a File by Contents” on page 182

If you still want to learn more about your computer’s file system, refer to the online
help or documentation for your operating system. There are also many commercial
books available that cover the basics of file systems and file management.

Basic File Management Skills
To get started using File Manager, you need to learn a few basic skills. Each icon in
File Manager represents an object that you can manipulate in a variety of ways,
including:

� Object selection
� Dragging and dropping
� Using pop-up menus
� Renaming objects
� Getting online help on objects
� Opening objects
� Viewing information about an object
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Object Selection
When you select the icon of a file or folder, its name is highlighted. Many choices in
File Manager’s menus apply to the currently selected file or folder. The Selected menu
contains choices that affect only the currently selected objects. The contents of this
menu will change as you select different kinds of objects in the view area.

Selecting multiple files is useful if you want to delete several files at once, or move a
group of files to a new folder. Note that when you select more than one object, the
Actions portion of the Selected menu will be empty.

When multiple icons are selected, dragging any one of the selected icons drags the
whole group. The Selected menu and various menu commands that apply only to a
single object are inactive.

Tip – To deselect icons, hold the Control key down and highlight those icons again;
this causes them to become unselected from the group.

� To Select a Single File or Folder (Mouse)
� Click once on the icon.

� To Select a Single File or Folder (Keyboard)
1. Use the Tab and arrow keys to move the highlight to the icon you want to select.

2. Press the Spacebar.

To deselect a file or folder, select another icon or click an empty area within the File
Manager window.

� To Select Multiple Files and Folders (Mouse)
� Drag the mouse from a blank area to draw a box around the icons you want to

select, and then release the mouse button.

You can then hold down the Control key and drag around additional icons.

If you have selected icons in File Manager, clicking or dragging anywhere in the File
Manager scrolling pane will deselect those icons. However, if you hold down the
Control button before clicking or dragging in the scrolling pane, your existing
selections are retained. This method is useful for making multiple selections.

150 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



Tip – When the icons you want to select are not located next to each other, click mouse
button 1 to select the first icon, then hold down the Control key and click mouse
button 1 to select each additional icon.

� To Select Multiple Files and Folders (Keyboard)
1. Select the first file or folder icon by pressing the Spacebar.

2. For each additional icon you want to select, move the highlight to it, then press
Control+Spacebar.

� To Drag and Drop a File or Folder
1. Put the mouse pointer over the file or folder.

2. Press and hold mouse button 1.

3. Drag the icon to where you want to drop it.

4. Release the mouse button.

So, the motion for dropping an object is press…drag…release.

To cancel a drag in progress, press Esc before releasing the mouse button.

FIGURE 5–1 Drag icon showing the object being dragged

If more than one icon is selected, you drag the entire group by dragging any of the
selected icons.
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Note – You cannot drag and drop an object without a mouse or other pointing device.

Basic Drag-and-Drop Tasks
� To move a file to another folder, drop the icon on the destination folder’s icon. Or,

if both the source and destination folders are open, drag the icon from the source
folder’s view window and drop it onto the background of the folder’s view
window.

� To place an icon for a file or folder on the backdrop of your current workspace,
drop the file or folder icon outside of any window. A desktop object is really just a
reference to the real object, which remains in the File Manager view, unchanged.

� To print a file, drop the file icon onto the Printer control in the Front Panel (or one
of the printers in the Personal Printers subpanel).

� To delete a file or folder, drop the file or folder icon onto the Trash Can control in
the Front Panel.

If you try to drop an icon in a location that does not support dropped objects, the icon
snaps back to its original location in File Manager or on the desktop.

� To Display a Pop-up Menu (Mouse)
Each object in File Manager has a pop-up menu. The File Manager window itself has a
pop-up menu viewable when the pointer is placed in a location in the view window
outside the boundaries of the individual file or folder objects.
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1. Point to the icon whose pop-up menu you want to display and press mouse button
3.

FIGURE 5–2 Sample Pop-up Menu

2. To choose a command from the menu, drag to the command, then release. Or, click
the command.

� To Display a Pop-up Menu (Keyboard)
1. Using the Tab and direction keys, move the highlight to the icon whose menu you

want to display.

2. Press Shift+F10.

3. To choose a command from the menu, use the direction keys to highlight the
command, then press Return.

4. To cancel the menu without choosing a command, press Esc.

� To Rename a File or Folder (Mouse)
1. Select the file or folder name by clicking the name beneath its icon.

2. Type the new name.

3. Press Return. If you click outside the name without first pressing Return, your
changes will be lost.

To cancel a rename operation, press Esc.
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Note – You can’t rename actions.

� To Rename a File or Folder (Keyboard)
1. Use the Tab and arrow keys to move to the icon for the file or folder you want to

rename.

2. Press the Spacebar to highlight (select) the icon name.

3. Choose Rename from the Selected menu.

4. Type the new name.

5. Press Return.

To cancel a rename operation, press Esc.

� Getting Help on a File or Folder
The description displayed when you ask for help on an icon describes the data type
associated with the file or folder. The description is specified in the data-type
definition.

To get help using the mouse:

� Select the file or folder, then press F1.

� Or, put the mouse pointer on the object and select help from the object’s pop-up
menu (displayed by pressing mouse button 3).

� Or, choose On Item from the Help menu, then click the file or folder’s icon.

To get help using the keyboard:

� Use the Tab and arrow keys to move to the icon, then press F1.

To find out more about how to use Help, see Chapter 3.

� To View a File or Folder’s Information
Use the Information dialog box to view information about a file or folder.
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1. In File Manager, select the icon of the file or folder whose information you want to
view.

2. Choose Properties from the File Manager Selected menu, or from the icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

The Properties dialog box appears.

3. Click the Information radio button.

4. Examine the information about the file or folder:

� Owner Name – The name of the file or folder’s owner

� Group Name – The name of the group to which the file or folder belongs

� Size – The size of the file or folder

� Last Accessed – The date on which the file or folder was last accessed

� Last Modified – The date on which the file or folder was last modified

Note – If you want to view the information for another file or folder, select the object,
choose Properties from the Selected menu, and click the Information radio button. If
you bring up the Properties dialog box by typing sdtfprop& on the command line,
you can click Browse in the dialog box and select the file or folder name to view
properties.

Opening a File or Folder
The most basic action you can perform on an object is to open it. “Open” is a very
general term, and the action taken depends on the type of object you are opening. For
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example, opening a folder changes the File Manager view to show the contents of that
folder. Opening a data file usually starts the application that created the file and loads
the data file.

� To Open a File or Folder
� Double-click the icon.

Double-clicking an icon executes the object’s default action, which is always the first
action in the Actions portion of the Selected menu. For most data files, the default
action opens the file by starting the appropriate application and loading the file.

� Or, select the icon, then go to the menu bar and choose Open (or Open In Place or
Open New View) from the Selected menu.

� Or, choose an Open item from the icon’s pop-up menu (displayed by pressing
Shift+F10 or mouse button 3).

Manipulating Files and Folders
The major identifying features of a file or folder are:

� Its name and location in the folder hierarchy.

� Its owner permissions (properties).

For more information on permissions and how to set them, see “File and Folder
Ownership and Security” on page 163.

� Whether it is linked to another file. A linked file is a representation of another file.
Linked files provide a way for you to have one file that appears to exist in two or
more folders.

Note – The following procedures assume that you have permission to write to the files
or directories. See “Basic Permissions” on page 163.

� To Create a New File or Folder
1. Choose New File or New Folder from the File menu.

2. Type the name into the New File or New Folder field.
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3. Click OK or press Return.

To close the New File or New Folder dialog box without creating a new file or folder,
click Cancel or press Esc.

There are two other ways to create objects:

� Copy an existing object, then rename the copy (see “To Copy a File or Folder
(Mouse)” on page 157).

� Create a new file within an application. For example, Text Editor creates a new file
when you save a new document.

� To Move a File or Folder (Mouse)
1. Make the source and destination folders visible: by opening a File Manager view of

the contents of the destination folder or the icon of the closed destination folder.

2. Select the file or folder to be moved and drag it to the destination folder.

If you move a folder, the entire folder and its contents are moved.

� To Move a File or Folder (Keyboard)
1. Use the Tab and direction keys to move the highlight to the file or folder to be

moved.

2. Press the Spacebar to select the object.

3. Choose Move to from the Selected menu.

4. Type a name into the Destination Folder text field.

For example, if you want to move the file report into the folder /u/john, you would
type /u/john.

5. Click OK or press Return.

If you move a folder, the entire folder and its contents are moved.

� To Copy a File or Folder (Mouse)
1. Make the source and destination folders visible:

Open a File Manager view of the contents of the destination folder or the icon of the
closed destination folder.

2. Select the file or folder to be copied.
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3. Press and hold the Control key.

4. Drag the file or folder and drop it onto the destination folder.

Make sure that you release the mouse button before you release the Control key.
Otherwise, you will move instead of copy the file or folder.

� To Copy a File or Folder (Keyboard)
1. Select the icon.

2. Choose Copy to from the Selected menu.

3. Type a name into the Destination Folder text field.

Note that this must be the new full path name for the file. For example, if you want to
copy the file report into the folder /u/john, you would type /u/john.

4. Click OK or press Return.

To close the Copy File dialog box without copying a file, click Cancel or press Esc.

Symbolic Links
A link icon is a copy of an icon that points to the same file or folder as the original
icon. Any changes you make after opening the link icon will also appear when you
access the file or folder using the original icon.

� To Create a Symbolic Link (Mouse)
1. Make the source and destination folders visible:

� Open a File Manager view of the contents of the destination folder.

� Or, open a File Manager view that shows the icon of the closed destination folder.

2. Select the file or folder to be copied.

3. Press and hold the Shift key and the Control key while dragging and dropping the
icon of a file or folder onto the icon of a new folder.

When you drop the icon, File Manager creates symbolic link in the new folder that
points to the original file or folder. Make sure that you release the mouse button before
you release the Shift key and the Control key. Otherwise, you will move instead of link
the file or folder.
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� To Create a Symbolic Link (Keyboard)
1. Use the Tab and arrow keys to move the highlight to the icon of the file or folder to

which you want to link.

2. Press the Spacebar to select the icon.

3. Choose Copy as Link from the Selected menu.

4. Type a name into the Destination Folder text field including the path for the name
of the folder where you want this link icon to appear.

5. (Optional) If you want this link icon to have a different name that the original icon,
type a new name in the Name for copy text field.

6. Click OK or press Return.

Navigating to Folders and Subfolders
Each File Manager window (also called a view) shows the contents of a single folder.

If you are not familiar with hierarchical file systems, see “Basic File System Concepts”
on page 147.

� To Change to Another Folder
You can change to another folder in any of the following ways:

� Double-click a folder icon.

� Select a folder icon and choose Open In Place from the Selected menu to open the
folder in the current window, or Open New View from the Selected menu to open
it in a new window.

� Choose the Open In Place or Open New View command from the folder’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

� Double-click a folder in the iconic path to change the view to that folder.

� Select (click) the current folder line to change it into a text field. Type the name of
the path you want and then press Return.

� In the current folder line, double-click a segment of the current path. For example,
if the current folder is /users/fredj/.dt/types, you can change to the
/users/fredj folder by double-clicking the word fredj.
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� Choose Go To from the File menu. Enter the folder’s full path name in the
Destination Folder text field of the Go To window.

� To Go to Your Home Folder
� Choose Go Home from the File menu.

� To Change to the Parent Folder
� Choose Go Up from the File menu

� Or, double-click the .. (go up) icon.

� To Open a Terminal Window in the Current Folder
This procedure opens a terminal emulator window with the same current folder as the
File Manager window. This is a quick way to type a command to affect the contents of
the folder you are currently viewing.

� Choose Open Terminal from the File menu.

Note – You must have execute permission for a folder before you can open a Terminal
window from it.

To find out how to use terminal emulators, see Chapter 14.

Executing an Action for a File or Folder
Actions act on objects, and are a basic part of working with them. For example,
printing the contents of an object uses the Print action. Starting an application for a
data file object uses an Open action, or some other application action.
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The Selected menu contains a list of commands followed by a list of actions you can
use with the selected icon. The contents of the actions portion of the Selected menu
change depending on the type of icon that is currently selected.

Actions

The action listed at the top of the action portion of the menu (the default action) is the
action that will be taken when you double-click a file or folder. In the menu shown in
the figure, the default action is Open In Place.

� To Execute the Default Action
The default action is the first action listed in the actions portion of the Selected menu.

� Double-click the object’s icon.

� To Execute Other Actions
1. Select the object’s icon.

2. Choose the action you want to execute from the Selected menu or from the object’s
pop-up menu.
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Deleting Objects to the Trash Can
The Trash Can collects the files and folders that you delete. They are not actually
removed from the file system until the trash is “emptied.” You can only change your
mind and restore a file you’ve put in the Trash Can if the Trash Can hasn’t been
emptied.

� To Open the Trash Can Window
� Click the Trash Can control in the Front Panel.

� To Put an Object in the Trash Can
� Choose Put in Trash from the object’s pop-up menu (displayed by pressing

Shift+F10 or mouse button 3).

� Or, select the object’s icon, then choose Put in Trash from the Selected menu.

� Or, drag the object’s icon and drop it onto the Trash Can control in the Front Panel.

� Or, drag an object’s icon to the open Trash Can window.

� To Put Back a File or Folder from the Trash Can
� Drag the object from the Trash Can window to File Manager.

� Or, in the Trash Can window, select the object you want to restore and choose Put
back from the File menu.

� Or, choose Put back from the object’s pop-up menu (displayed by pressing
Shift+F10 or mouse button 3).
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� To Delete a File or Folder Permanently
When you delete a file permanently, it cannot be recovered (unless you have a backup
mechanism.)

1. Open the Trash Can.

2. Select the objects you want to empty from the Trash Can.

Select individual objects, or choose Select All from the File menu.

3. Choose Shred from the File menu or from the object’s pop-up menu (displayed by
pressing Shift+F10 or mouse button 3).

4. Click OK in the confirmation dialog box.

File and Folder Ownership and Security
The traditional UNIX file and folder protection scheme provides read, write, and execute
permissions for three user types: owner, group, and other. These are called basic
permissions.

Access Control Lists (ACLs) provide greater control over file and folder permissions
than do basic permissions. ACLs enable you to define file or folder permissions for the
owner, owner’s group, others, and specific users and groups, and default permissions
for each of these categories.

Basic Permissions
The permissions on a file or folder specify how it can be accessed. These permissions
apply to the basic user types as well as to the ACL default types described in “Setting
Default Permissions Through an Access Control List” on page 172.

� Read Permission – Allows access to retrieve, copy, or view the contents of the object.

� Write Permission – For a file, allows access to change the contents of the file. For a
folder, allows access to create or delete objects from the folder.

� Execute Permission – For a file, allows access to run the file (for executable files,
scripts, and actions). For a folder, allows access to search and list the folder’s
contents.
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If you do not have permission to write inside a folder, the folder will look like this:

If you do not have read or execute permission for a folder, the folder will look like
this:

Basic User Types
For a file or folder, the three basic types of users are:

� Owner – The user who owns the file or folder. Only a system administrator (root
user) can change the owner of a file or folder.

� Group – Users who have been grouped together by the system administrator. For
example, the members of a department might belong to the same group. This
group is the owning group and usually includes the file or folder’s owner.

� Other – All other users on the system besides the owner and owning group.

Examples
To make a folder private:

� Change the folder’s properties, giving yourself (the owner) read, write, and execute
permission, but giving no permissions for group and other. This means that only
you and the root user can view the contents of the folder.

To make an object that you’ve created available for everyone to use but protect it so it
isn’t inadvertently overwritten:

� Change the file’s properties, giving read and execute permission to owner, group,
and other. Don’t give anyone write permission.

164 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



� To View a File or Folder’s Permissions
1. In File Manager, select the icon of the file or folder whose permissions you want to

view.

2. Choose Properties from the File Manager Selected menu, or from the icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box is the default view.

3. Examine the file or folder’s Basic Permissions in the Effective column (“r” stands for
Read permission, “w” stands for Write permission, and “x” stands for Execute
permission).

� Owner – The permissions granted to the file or folder’s owner

� Group – The permissions granted to the file or folder’s group

� Other – The permissions granted to everyone besides the owner and group

Note – The Read, Write, and Execute columns in the dialog box represent requested
permissions, and may be different than the permissions that are actually in effect
(which are shown in the Effective column). The requested permissions may not be in
effect because of the mask (see “Permissions Mask” on page 175).

If you want to look at the permissions for another file or folder, select the object and
choose Properties from the Selected menu. If you display the Properties dialog box by
typing sdtfprop& on the command line, you can click Browse in the dialog box and
select the file or folder name to view properties.

� To Modify Basic Permissions
1. In File Manager, select the icon of the file or folder whose permissions you want to

modify.

2. Choose Properties from the File Manager Selected menu or from the icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.

3. Click the check boxes to set the Owner, Group, and Other permissions.

The mask restricts the Group permissions, but does not affect Owner or Other
permissions. The actual read, write, and execute permissions that Owner, Group, and
Other receive appear in the Effective column.
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4. Use the Apply Changes To option button to choose the scope of the changes.

For files, the options are This File Only (default), All Files in Parent Folder, and All
Files in Parent Folder and its Subfolders. For folders, the options are This folder only
(default) and This folder and its Subfolders.

5. Click OK on the Permissions dialog box to apply the current settings and dismiss
the dialog box. Click Apply to apply the settings without dismissing the
Permissions dialog box.

If you want to modify the permissions for another file or folder, select the object and
choose Properties from the Selected menu. If you display the Properties dialog box by
typing sdtfprop& on the command line, you can click Browse in the dialog box and
select the file or folder name to modify properties.

See “Permissions Mask” on page 175 for a discussion of the mask.

� To Change File or Folder Ownership

Note – If you do not have permission to change the properties, some of the controls in
the Permissions dialog box are unavailable.

1. In File Manager, select the icon of the file or folder whose ownership you want to
modify.

2. Choose Properties from the File Manager Selected menu or from the icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.

3. To change the owner, type the new owner name into the Owner text field. To change
the owning group, type the new group name into the Group text field.

You can specify a different owning group only if you are also a member of another
group, even if you are not the file or folder owner.

4. Click OK to apply the current settings and dismiss the dialog box. Click Apply to
apply the settings without dismissing the Permissions dialog box.

� To Browse and Edit Properties of Multiple Files
and Folders

1. Open the Properties dialog box by typing sdtfprop& at the command line.

You can edit the File Name text field and click Browse to open the File Selection dialog
box only if you open the Properties dialog box from the command line.
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2. Click Browse or type the name of a file or folder in the File Name field.

3. Browse or edit the file or folder properties.

4. Click OK to apply the current settings and dismiss the dialog box. Click Apply to
apply the settings and continue the browsing and editing process.

Access Control Lists
ACLs enable you to define file or folder permissions for the owner, owner’s group,
others, and specific users and groups, and default permissions for each of these
categories. You can set up only one ACL per file or folder. An ACL consists of ACL
entries. Each entry has a user type associated with it, much as basic permissions have
Owner, Group, or Other associated with them.

If you want to grant file or folder access to a particular user or group, use the User or
Group type ACL entry, respectively. You must specify the name of the user or group
when you create the ACL entry. For example, you can use an ACL to grant a friend
read permission on your resume, while protecting it from being read by the rest of the
world (besides yourself).

To create, modify, or view ACLs on a file or folder, it must reside on a server or system
running Solaris 2.5 Operating Environment or compatible versions, and you must be
running Solaris 2.5 Operating Environment or compatible versions. Such files and
folders are called ACL-enabled. To set, modify, and view basic permissions and ACLs
using the Properties Graphical User Interface (GUI), you must be running CDE 1.1 or
later.
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You must be the owner of the file or folder to create or modify basic permissions or
ACLs for that file or folder. If you are not the owner, all fields in the Properties dialog
box are displayed as read-only.

Note – ACL terminology in this section refers to terminology used in the Properties
GUI. Command-line terminology may be slightly different.

� To View an Access Control List
1. In File Manager, select the icon of the file or folder whose Access Control List (ACL)

you want to view.

2. Choose Properties from the File Manager Selected menu or from the icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

The Properties dialog box appears.

If the file or folder has an ACL, it appears in the scrolling list labeled Access Control
List Permissions. If the file or folder has no ACL, the scrolling list is hidden.

The Requested column shows the permissions that the owner requests for each ACL
entry. These permissions are restricted by the mask, and the actual ACL entry
permissions appear in the Effective column. See “Permissions Mask” on page 175 for a
discussion of the mask.
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Note – To create, modify, or view ACLs on a file or folder, it must reside on a server or
system running Solaris 2.5 Operating Environment or compatible systems, and you
must be running Solaris 2.5 Operating Environment or compatible systems.

� To Add an Access Control List Entry

Note – Adding the first Access Control List entry creates the Access Control List.

1. In File Manager, select the icon of the file or folder whose ACL you want to modify.

2. Choose Properties from the File Manager Selected menu or from the icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.

3. Click Show Access Control List if the ACL portion of the Permissions dialog box is
not visible.

4. Click the Add button.

The Add Access List Entry dialog box appears.

5. Select an option from the Type option button.

6. Enter the name associated with the chosen Type, if it has one in the Name field.

Managing Files with File Manager 169



7. Click the Permission check boxes to reflect the values you want for the new ACL
entry.

The status line at the bottom of the dialog box informs you if the permissions you
request are restricted by the mask.

8. Click Add in the Add Access List Entry dialog box.

9. Use the Apply Changes To option button to choose the scope of the change.

For files, the options are This File Only (default), All Files in Parent Folder, and All
Files in Parent Folder and its Subfolders. For folders, the options are This folder only
(default) and This folder and its Subfolders.

10. Click OK to apply the current settings and dismiss the dialog box. Click Apply to
apply the settings without dismissing the dialog box.

� To Change an Access Control List Entry
1. In File Manager, select the icon of the file or folder for which you want to change an

ACL entry.

2. Choose Properties from the File Manager Selected menu or from the icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.

3. Select the entry in the Access Control List Permissions scrolling list that you want
to change.

4. Click Change.

The Change Access List Entry dialog box appears.

5. Click the Permission check boxes to reflect the values you want for the ACL entry.

The status line at the bottom of the dialog box informs you if the permissions you
request are restricted by the mask.
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6. Click the Change button in the Change Access List Entry dialog box.

7. Use the Apply Changes To option button to choose the scope of the change.

For files, the options are This File Only (default), All Files in Parent Folder, and All
Files in Parent Folder and its Subfolders. For folders, the options are This folder only
(default) and This folder and its Subfolders.

8. Click OK to apply the current settings and dismiss the dialog box. Click Apply to
apply the settings without dismissing the dialog box.

� To Delete an Access Control List Entry
1. In File Manager, select the icon of the file or folder for which you want to delete an

ACL entry.

2. Choose Properties from the File Manager Selected menu or from the icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.

3. Select the entry in the Access Control List Permissions scrolling list that you want
to delete.

4. Click the Delete button.

A dialog box appears asking you to confirm this deletion. If you delete any of the four
required ACL default entries, all ACL default entries will be deleted. See “Setting
Default Permissions Through an Access Control List” on page 172 for a description of
required and optional default ACL entries.

Note – Removing all entries (except Mask) removes the entire Access Control List.

5. Use the Apply Changes To option button to choose the scope of the change.

For files, the options are This File Only (default), All Files in Parent Folder, and All
Files in Parent Folder and its Subfolders. For folders, the options are This folder only
(default) and This folder and its Subfolders.

6. Click OK to apply the current settings and dismiss the dialog box. Click Apply to
apply the settings without dismissing the dialog box.
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Setting Default Permissions Through an Access Control
List
When you create a file or folder within a folder, it inherits the basic permissions set by
the system administrator. (To determine the current defaults, create a new file or folder
and then choose Properties from the Selected menu to view the permissions.)

You can use an Access Control List to set default basic permissions yourself for any file
or folder that is created within a folder. The ACL for that folder must contain entries
for all four of the following required Default entry types: Default Owning User, Default
Owning Group, Default Other, and Default Mask. An ACL can contain only one entry
of each required type.

The file or folder inherits the values for Owner, Group, and Other from the person
who creates it and inherits the basic permissions from the required ACL Default entry
types on the containing folder. ACL entries of these types do not have names
associated with them.

You can also set optional Default entry types—Default User and Default Group— for
any file or folder that is created within a folder. You can create as many Default User
or Default Group ACL entries as you want. You must specify the name of the user or
group when you create the ACL entry.

Any ACL in which you want to put a Default User or Default Group entry must also
contain one of each required entry type.

Example

Suppose that the values for Owner and Group for a user named Carla are otto and
otto_staff, respectively. The value for Other (call it otto_other) is everyone at
Carla’s company except for Carla and the members of otto_staff. Carla creates
these required Default ACLs on her folder named Project1:

� Default Owning User with permissions rwx (read, write, execute)
� Default Owning Group with permissions rx (read, execute)
� Default Other with permissions no-read, no-write, no-execute
� Default Mask with permissions rw (read, write)

Any file or folder subsequently placed in the Project1 folder inherits these basic
permissions from Project1:

� The file or folder Owner value is otto and otto has read, write, and execute
permission on that file or folder

� The file or folder Group value is otto_staff and otto_staff has read and
execute permission on that file or folder

� The file or folder Other value is otto_other and otto_other has no-read,
no-write, and no-execute permission on that file or folder
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Also, the file or folder has a Mask entry in the Access Control List Permissions
scrolling list with the value rw (read, write).

If Carla also adds an optional ACL of type Default User (Default Group) for the
Project1 folder, then any file or folder subsequently placed in Project1 will inherit
an ACL of type User (Group).

� To Set Required Default Entry Types
1. In File Manager, select the icon of the folder for which you want to set the required

ACL Default entry types.

2. Choose Properties from the File Manager Selected menu or from the icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.

3. Click the Show Access Control List button if the folder has no ACL defined.

If the folder has an ACL defined, it will be visible when you open the Permissions
dialog box.

4. Click Add and select an ACL entry of type Default Owning User, Default Owning
Group, Default Other, or Default Mask.

A message appears reminding you that the other required ACL Default entries will
also be added.

5. Click the Permission check boxes to set the permissions for the Default entry.

6. Click Add in the Add Access List Entry dialog box.

The other three required ACL Default entries are automatically created for you, with
permissions set to no-read, no-write, no-execute.

7. (Optional) Change the permissions for the required ACL Default entries that were
automatically created in step 6 above.

8. Use the Apply Changes To option button to choose the scope of the changes.

The options are This folder only (default) and This folder and its Subfolders.

9. Click OK to apply the current settings and dismiss the dialog box. Click Apply to
apply the settings without dismissing the dialog box.

� To Delete Required ACL Default Entry Types
1. In File Manager, select the icon of the folder for which you want to delete an ACL

Default entry.
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2. Choose Properties from the File Manager Selected menu or from the icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.

3. Select required ACL Default entry and click Delete.

A message appears to remind you that once you delete one of the required default
ACL entries, the other three are automatically deleted for you.

4. Click Delete in the confirmation dialog box.

5. Use the Apply Changes To option button to choose the scope of the change.

The options are This folder only (default) and This folder and its Subfolders.

6. Click OK to apply the current settings and dismiss the dialog box. Click Apply to
apply the settings without dismissing the dialog box.

� To Set Optional ACL Default Entry Types
1. In File Manager, select the icon of the folder for which you want to set an optional

ACL Default entry type.

2. Choose Properties from the File Manager Selected menu or from the icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.

3. Click the Show Access Control List button if the folder has no ACL defined.

If the folder has an ACL defined, it will be visible when you open the Permissions
dialog box.

4. Click Add and select an ACL entry of type Default User or Default Owning Group.

If the ACL does not contain the required default entries, they will also be created, with
permissions set to no-read, no-write, no-execute.

5. Click the Permission check boxes to set the permissions for the Default entry.

6. Click Add in the Add Access List Entry dialog box.

7. Continue to add as many ACL entries of type Default User or Default Owning
Group as you want.

8. Use the Apply Changes To option button to choose the scope of the changes.

The options are This folder only (default) and This folder and its Subfolders.

9. Click OK to apply the current settings and dismiss the dialog box. Click Apply to
apply the settings without dismissing the dialog box.
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Permissions Mask
ACL-enabled files and folders have a mask defined whose default permissions are the
group permissions for the file or folder. The mask is the maximum allowable
permissions granted to any user on all ACL entries and for Group basic permissions. It
does not restrict Owner or Other basic permissions. For example, if a file’s mask is
read-only, then you cannot create an ACL with write or execute permission for a user
without changing the mask value.

Use the mask as a quick way to limit permissions for users and groups.

� To Modify the Mask
1. In File Manager, select the icon of the file or folder whose mask you want to modify.

2. Choose Properties from the File Manager Selected menu or from the icon’s pop-up
menu (displayed by pressing Shift+F10 or mouse button 3).

The Permissions dialog box appears.

3. Click the Show Access Control List button if the folder has no ACL defined.

If the folder has an ACL defined, it will be visible when you open the Permissions
dialog box.

4. Select the Mask entry in the Access Control List Permissions scrolling list.

The current mask permissions appear in the Effective column.

5. Click the Change button.

6. Click the Permission check boxes to reflect the values you want for the mask.

7. Click the Change button in the Change Access List Entry dialog box.

8. Use the Apply Changes To option button to choose the scope of the permissions
changes.

For files, the options are This File Only (default), All Files in Parent Folder, and All
Files in Parent Folder and its Subfolders. For folders, the options are This folder only
(default) and This folder and its Subfolders.

9. Click OK to apply the current settings and dismiss the dialog box. Click Apply to
apply the settings without dismissing the dialog box.
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Using File Manager Objects on the
Desktop
The desktop lets you put any file or folder icon directly on the backdrop of the current
workspace for quick access. Any icon you drop on the desktop stays where you put it.

File Manager provides a way to view all the objects in your file system. However, the
object is only visible when you are viewing the folder it is in.

To make an object more accessible, you can put it directly on the workspace backdrop.
The desktop is that area or surface on which windows appear to lie. When an object is
placed there, it is called a workspace object. There is a separate desktop for each
workspace.

Placing an object on the workspace does not alter the original file or folder. In fact, the
icon that appears on the workspace is really just a shortcut for accessing the real file or
folder. Any operation you perform on the workspace object is actually performed on
the file or folder it represents.

Workspaces in the Desktop
You can have several workspaces on your desktop, so you can set up your working
environment by putting the files and folders in the workspaces where you use them
most, or in more than one workspace if needed.

Pop-up Menus
Each workspace object has its own pop-up menu, displayed with mouse button 3 or
by pressing Shift+F10 when the icon is selected. This menu contains commands for
manipulating the object, including all the actions that appear in the File Manager’s
Selected menu when the object is selected. The Workspace pop-up menu is similar to
the pop-up menu available within File Manager windows, but contains a few different
commands.
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� To Put a File or Folder on the Workspace Backdrop
This procedure creates a copy of the icon on the workspace backdrop. Any changes
you make to the copy on your workspace backdrop will also be made to the original
that is still in File Manager.

1. Switch to the workspace where you want to display the object.

2. Then:

� Drag and drop the object’s icon onto the workspace.

� Or, select the icon, then choose the Put in Workspace command from the Selected
menu or from the icon’s pop-up menu (displayed by pressing Shift+F10 or mouse
button 3).

You can repeat these steps to put an icon on the desktop in as many workspaces as
you want.

� To Display the Pop-up Menu for a Workspace
Object (Mouse)

1. Point to the object’s icon.

2. Press mouse button 3.

3. Choose a command from the menu by dragging to the command then releasing the
mouse button.

� To Display the Pop-up Menu for a Workspace
Object (Keyboard)

1. Move the highlight to the object’s icon using Alt+Tab.

2. Press Shift+F10.

3. Choose a command from the menu by using the direction keys to highlight the
command, then press Return.

To cancel the menu without choosing a command, press Esc.
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� To Remove an Object from the Workspace
1. Switch to the workspace where the object resides.

2. Locate the object’s icon on the desktop.

3. Choose Remove From Workspace from the object’s pop-up menu.

Removing an object from the workspace does not alter the original object; that is, the
object still exists in File Manager.

Using File Finder
File Finder is an application that searches a folder and its subfolders and returns a list
of files or folders that match your search criteria. Files and folders are sometimes
generally called objects.

When specifying search criteria, you typically supply a file or folder name, or some
text that you expect to find in the required file. You can also specify the size, owner,
date modified, type, and permissions.

� To Open File Finder
You can open File Finder from the Front Panel or from inside File Manager.

� Click the Find File control on the Files subpanel of the Front Panel.

The Find File application opens with the default search path set to your home folder.

� Or, choose Find on the File menu of the File Manager application.

The Find File application opens with the default search path set to the folder that was
displayed in File Manager.
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� To Find a File or Folder by Name
1. Open File Finder.

File Finder displays the Find dialog box.

2. Select the folder under which you expect to find the required files or folders using
the following table as a guide to the menu items in the Find dialog.
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Paths you used
previously and were
automatically saved

Menu Item Where File Finder Searches

My Home Directory Your home directory (referred to as $HOME in this chapter),
for example, /home/fredj

Floppy Contents of the diskette drive

CD-ROM Contents of the CD-ROM drive

Local Storage All folders on this workstation

$PATH All folders on the workstation’s default path

Other Host Specify the hostname of a different workstation

Other Folder Specify another folder on this workstation

Folders are arranged in a hierarchical structure (“Basic File System Concepts”
on page 147) By default, the Find operation will search the folder you specify and all
its subfolders.

180 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



3. If you want to search across symbolic links that originate on your search path, select
the Follow Links check box.

Tip – If the actual location of a linked folder is at the top level of a large number of
folders, the search might take a long time. Be aware of the locations to which folders
are linked before starting search operations.

4. Select whether you will be searching for a file name containing, equalling, or not
containing your search text by selecting the appropriate option in the Whose Name
selector.

5. Type a full or partial name of the file or folder you want to find into text box on the
same line as the Whose Name selector.

Note – The following applies when you select “is equal to” from the and Name
selector:

When you specify a file or folder name, you can include wildcard characters such as
asterisk (*) and question mark (?). The * matches any string of characters (including
no characters), and ? matches any single character. For example:

ba*-matches all names that begin with the string ba

ba?-matches all three-character names that begin with the string ba

*.dt-matches all names that end with the .dt suffix

*.???-matches all names that have a three-character suffix

The file name and contents can be specified using the same regular expression syntax
allowed by the find command. (Refer to the find man page and grep man page for
more information.)

6. Click Find.

File Manager begins searching the specified folder and its subfolders for files that
match the specified search criteria. Matches that are found are listed in the Items
Found list. You can stop the search at any time by clicking the Stop button.

Tip – If too many objects are returned, you can specify more restrictive criteria and try
again.

7. (Optional) If you want to go to an object in the list, select it and click Go To open
File Manager displaying its folder, or click Put on Workspace to display an icon for
it on the workspace.
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� To Find a File by Contents
1. Open File Finder.

2. Click More Criteria to display the More Criteria dialog box.

3. Select the Content checkbox and click OK.

The And Content line is added to the Find dialog.

4. Specify the search folder and any name constraints for the search on the Find Items
In line and on the Whose Name line.

5. If you leave the File or Folder Name field empty, File Manager searches every file
within the search folder.

Names can be specified using the same regular expression syntax allowed by the grep
command. (Refer to the grep man page for more information.)

6. In the File Contents field, type the text string you want to find.

If you select “and content contains (any case), then case is ignored for this string
(upper- and lowercase letters are equivalent). You do not have to use complete words.
For example, if you type fi it will find both fish and File.

7. Click Find to commence the search.

File Manager begins searching the search folder and its subfolders for any file
containing the search string. Matches that are found are listed in the Files Found list.
Once you have found a file, you can select it in the list and then click Go To to open
File Manager for its folder. You can stop the search at any time by clicking Stop.

Tip – If too many files are returned, specify more restrictive criteria.

Finding a File by File Properties
The previous procedures explained how to search for a file or folder by specifying a
name, and how to search for a file by specifying some of its contents. You can also
specify the following object properties as search criteria:

� Size - Specify a file size in characters. Append the character “c” to the size you
specify to return a file size in characters (as displayed in File Manager). If this line
is displayed and left blank, qualifying objects of all sizes will be returned.

� Owner - Specify an exact UNIX user name for the object’s owner. If this line is
displayed and left blank, qualifying objects belonging to all users will be returned.

� Date modified - Specify a date using the date specification format
[[CC]YY]MMDD[hhmm][.SS]. Entries enclosed by square brackets are optional. If
this line is displayed and left blank or left with the above prompt string, qualifying
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objects of all modification dates will be returned.

� Type - Choose whether to return files or folders. If this line is displayed, qualifying
objects of only the type selected will be returned. Otherwise, qualifying objects of
both types will be returned.

� Permissions - Select one of the options which relate to the ACL (Access Control
List) If this line is displayed, qualifying objects of only the type selected will be
returned. Otherwise, qualifying objects of all types will be returned (subject to
other constraints).

By default, File Finder displays only the line for specifying name criteria. By clicking
More Criteria, you can display lines for other criteria.

FIGURE 5–3 File Finder With All Search Criteria Displayed

� To Find a File by File Properties
1. Open File Finder.

File Finder opens with the default display and settings.

2. Click More Criteria to display the More Criteria dialog box.
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3. Select the check boxes for the criteria that you intend specifying in your search.

File Finder updates the Find dialog box to contain a line for specifying each of the
selected criteria.

4. (Optional) Specify the folder to be searched, the name of the file or folder, and the
contents of the required file using the instructions in “To Find a File or Folder by
Name” on page 179 and “To Find a File by Contents” on page 182.

5. Specify criteria relating to the properties of the file or folder on the lines provided.

Each line of constraints will be evaluated as described above. If you use more than one
set of criteria, File Finder will return only objects that satisfy all of the search criteria.

6. When you are satisfied with the criteria you have entered, click Find.

File Finder searches the specified folders and subfolders, and returns a list of the files
and folders that match all of the specified search criteria. You can stop the search at
any time by clicking Stop.

Tip – If too many files are returned, you can specify more restrictive criteria and try
again.

Customizing File Manager Views
File Manager provides several ways to see the contents of folders. You can:

� Change the basic viewing structure from one folder at a time to seeing a tree view
see “To Display the Tree View” on page 187).

� Determine the sort order of objects (see “To Change the Order in Which Icons Are
Sorted” on page 188).

� Hide (filter) certain objects (see “To Show or Hide Files and Folders” on page 189).

� Change the style used for objects – names and small or large icons, names alone, or
a long list of names plus properties.

� To Configure the Headers
1. Choose Set View Options from the View menu.
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2. Determine which headers to display:

� Select Iconic Path to show current folder path as a string of folder icons at the top
of the window.

� Select Text Path to show the current folder’s full path name in a text field above the
view pane.

� Select Message Line to show a count of the number of files in the folder. The line
will appear at the bottom of the window.

3. To implement the chosen option and close the Set View Options dialog box, click
OK.

To implement the chosen option and leave the Set View Options dialog box open, click
Apply.

� To Configure How Icons are Placed
1. Choose Set View Options from the View menu.

2. Determine how you want to have the icons placed:

� Select As Placed to leave icons where they are dropped.

� Select Rows and Columns to automatically align the icons you drop into a grid.

3. To implement the chosen option and close the Set View Options dialog box, click
OK. To implement the chosen option and leave the Set View Options dialog box
open, click Apply.

Using the Tree View
The tree view resembles an outline. Files and folders contained in a folder are listed
beneath that folder in an indented list
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FIGURE 5–4 File Manager Tree View

In the tree view, a folder can have three states. The states are shown and changed
using the buttons to the left of the folder. You can also open and close the tree
branches by selecting a folder and then pressing the + and - keys on your keyboard
(these are the keys in the center, not the numeric keypad):

+()- The folder is in its closed state. None of the folder’s contents are shown. Clicking
the button expands the folder partially or fully, depending on the tree view option
currently in effect.

-()- The folder is in its fully expanded state. All objects in the folder are shown.
Clicking the button fully closes the folder.

+/-()- The folder is in its partially expanded state. The only contents shown are the
folders it contains. (This view is possible only when viewing “Folders, then Files”.)
Clicking the button expands the folder to show the file names.

You can alter the appearance of files and folders in the tree view by changing the
settings in the Show box in the Set View Options dialog box. Changes to the
preferences are only for the current session. To make them permanent, see “To Save
the Current Preferences as Your Default” on page 189.

If you double-click a folder in tree view, a new view of that folder opens that is not in
tree view mode.
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� To Display the Tree View
The tree view shows a folder and the files and folders beneath it.

1. Change to the folder where you want the tree view to start.

2. Choose Set View Options from the View menu.

3. Select By Tree in the Show box.

4. Select one of the tree view options:

� Folders only - The tree shows folders only. To view files, double-click a folder
name. This is the default view.

� Folders, then Files - Folders only appear at first. Click the [+] button next to each
folder to view its contents. The first click shows subfolders. A second click shows
files that are inside. When you click the button a third time, the folder contracts
again.

� Folders and Files - The tree shows both folders and files automatically.

5. To implement the chosen options and close the Set View Options dialog box, click
OK. To implement the chosen options and leave the Set View Options dialog box
open, click Apply.

� To Display the Folder View
The folder view will show a folder and all the files and folders in that folder.

1. Change to the folder that you want to view.

2. Choose Set View Options from the View menu.

3. Select By Single Folder in the Show box.

4. To implement the chosen options and close the Set View Options dialog box, click
OK. To implement the chosen options and leave the Set View Options dialog box
open, click Apply.

You can alter the appearance of files and folders in the folder view by changing the
settings in the Show box in the Set View Options dialog box. Changes to the
preferences are only for the current session. To make them permanent, see “To Save
the Current Preferences as Your Default” on page 189.

� To Change How Objects Are Represented
1. Choose Set View Options from the View menu.
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2. Select the representation you prefer from the Representation box.

� By Name Only - Icons will not be displayed in File Manager. File Manager
indicates objects that are folders by adding a slash (/) after their names. Executable
programs have an asterisk (*) after their name.

� By Large Icons - This is the default. The objects in File Manager will appear with
their names and large icons.

� By Small Icons - The objects in File Manager will appear with their names and
small icons.

� By Name, date, size, ... - The objects in File Manager will appear with date, size,
and so on in addition to the file names and icons.

3. Click OK or Apply.

� To Change the Order in Which Icons Are Sorted
1. Choose Set View Options from the View menu.

2. Select the sort order you prefer from the Order box, and the direction from the
Direction box.

� Alphabetically - A to Z (Ascending) or Z to A (Descending). Icons with names that
start with capital letters appear first. Icons with names that start with lowercase
letters are at the bottom.

� By File Type - By object type. For example, files, folders and actions are different
types of objects. Within each group of the same type, the icons are sorted
alphabetically (based on the order the data types are read into the database).

� By Date - By date the files were last modified, oldest to newest (Ascending) or
newest to oldest (Descending).

� By Size - By file size, smallest to largest (Ascending) or largest to smallest
(Descending).

3. Click OK or Apply.

If you have Placement set to As Placed, icons are sorted only when you choose Clean
Up from the View menu or when you click Apply in the Set View Options dialog box.
If Placement is set to Rows and Columns, the icons are sorted each time there’s a
change to the folder’s contents, or when you choose Update from the View menu.
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� To Re-Sort (Clean Up) Objects
The Clean Up command sorts the objects in the current view (according to the settings
in the Set View Options dialog box) and lines them up in a grid pattern. The settings
in other File Manager windows are not affected.

� Choose Clean Up from the View menu.

The Clean Up command is unavailable if you have the Placement preference set to
Rows and Columns.

� To Save the Current Preferences as Your Default
When you apply changes using the Set View Options and Set Filter Options dialog
boxes, the changes only apply to the current session. If you want to save the
preferences so they will be used the next time you open File Manager:

1. Set the preferences that you want and apply them (using Set View Options and Set
Filter Options in the View menu).

2. Choose Save As Default Options from the View menu.

3. Click OK.

These changes to the default view will not take effect until the next time you click the
File Manager control in the Front Panel.

After saving the current preferences, all new File Manager views you open use the
new preferences and filter list.

Hiding Files and Folders
Hidden files and folders are those whose file types are selected in the filter list.

The criterion for hiding or showing a file or folder is based on its data type. Use the
Set Filter Options command to change which data types are shown and hidden. (See
“To Specify Which Data Types Are Hidden” on page 190 below.) The default hidden
data types are DOT_FILE, DOT_FOLDER, and CURRENT_FOLDER.

� To Show or Hide Files and Folders
� Choose Show Hidden Objects from the View menu.
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Choosing the command a second time again reverses the toggle (from shown to
hidden and back again).

The criterion for hiding or showing a file or folder is based on its data type. Use the
Set Filter Options command to change which data types are shown and hidden. (See
“To Specify Which Data Types Are Hidden” on page 190 below.) The default hidden
data types are DOT_FILE, DOT_FOLDER, and CURRENT_FOLDER.

� To Specify Which Data Types Are Hidden
1. Choose Set Filter Options from the View menu.

Data types that have already been chosen to be hidden are highlighted.

2. In the Select File Types to be Hidden box, select the data types you want to be
hidden. File types that are already being hidden are highlighted.

Or, to reset the default filter list (DOT_FILE, DOT_FOLDER, and
CURRENT_FOLDER), click Defaults.

3. (Optional) Type a name pattern into the Also Hide (Optional) field specifying
additional file and folder names to be hidden.

The filter list specifies which files are not to be displayed. If you select all object types
or type * into the Filter String field, then no files are displayed. If you type *.txt,
then any file whose name ends in .txt will be added to the filter list and not
displayed.

Advanced users: The Filter String may be any regular expression. Refer to the
regexp(5) man page for more information.

4. Click OK, or, if you want to view the results before closing the dialog box, click
Apply.

To reset to the default filter list, choose Defaults. This resets the default values but
does not apply them until you click Apply or OK.

Icon Browsing
Files with names that end in .pm or .bm contain icons. These are the files that File
Manager uses to build icons. By default, you must open these files to see the icons
they contain. If you enable icon browsing, File Manager displays the contents of .pm
or .bm files so you don’t have to open them to see what they look like.
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FIGURE 5–5 Icon with Icon Browsing Enabled (Left) and Disabled (Right)

� To Enable Icon Browsing
1. Copy the file /usr/dt/examples/types/language/IconBrowse.dt into your

/$HOME/.dt/types folder.

2. Open Application Manager and double-click Reload Actions in the
Desktop_Controls application group.

3. Restart File Manager.

Note – The maximum default display area for icons is 38x38 pixels. So, if a picture file
is larger than 38x38, the picture will be clipped and only the top left 38x38 pixels will
be shown. You can increase the size of the display area for icons if you want larger
images to be fully visible (see “To Change the Icon Display Area Size” on page 191).
However, a larger display size area will slow down the opening of folders, and icons
will be spread further apart in folder views.

� To Disable Icon Browsing
1. Remove your personal copy of the IconBrowse.dt file.

2. Open Application Manager and double-click Reload Actions in the
Desktop_Controls application group.

� To Change the Icon Display Area Size
1. Open a Terminal window and type dtpad ~/.Xdefaults.

2. When the file is displayed, it may be empty or there may be text already in the file.
In either case, add the following four lines of text to the file:

Dtfile*smallIconWidth:24

Dtfile*smallIconHeight:24

Dtfile*largeIconWidth:38

Dtfile*largeIconHeight:38
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When you type in these lines, replace the default numbers at the end of each line with
the new display area size you want.

3. Choose Save from the File menu.

4. Choose Close from the File menu.

Note – The change will not take effect until you exit the desktop and log back in. If
you should want to return to the default display area size, type the default sizes back
in or just remove the four lines you added, and then exit and restart the desktop.

Using Removable Media with File
Manager
File Manager enables you to use removable media, such as diskettes and CD-ROMs, on
the workspace. You can view the contents of your diskettes or CD-ROMs if you have a
system with at least one diskette drive or one CD-ROM drive and you are running
Solaris CDE 1.1 or later.

Removable media are mounted on your file system in removable media folders. File
Manager enables you to view the contents of the removable media without having to
know the location of these folders.

File Manager restricts the view of a diskette or CD-ROM window to the removable
media folder and its subfolders. You cannot navigate out of the folder
/floppy/diskette_name when you view the diskette labeled /diskette_name or navigate
out of the folder /cdrom/cdrom_name when you view the CD-ROM labeled
/cdrom_name.

Note – The File Selection dialog box enables you to perform certain tasks, such as
Open or Save As, on the files in file systems for all mounted CD-ROMs and diskettes,
as well as for your home folder. You can choose your home folder or mounted
CD-ROMs and diskettes through the menu button at the end of the Enter Path or
Folder name text field.

Dragging and Dropping Files and Folders
When you drag a file or folder icon from a regular folder window, the default
drag-and-drop behavior is:
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� A copy operation when you drop the icon onto a diskette window.

� A move operation when you drop the icon onto a folder window.

� A move operation when you drop the icon onto the Trash Can or to the Trash
window.

When you drag a file or folder icon from a diskette window, the default drag-and-drop
behavior is:

� A copy operation when you drop the icon onto another diskette window.

� A copy operation when you drop the icon onto a folder window.

� A move operation when you drop the icon onto the Trash Can or to the Trash Can
window.

When you drag a file or folder icon from a CD-ROM window, the default
drag-and-drop behavior is:

� A copy operation when you drop the icon onto a diskette window.

� A copy operation when you drop the icon onto a folder window.

Note – You cannot drag and drop files or folders onto a CD-ROM.

Supported Formats
CDE reads and writes the following file-system formats:

� DOS High Density (commonly used by PCs running Windows or DOS)

� NEC-DOS Medium Density (sometimes used by older PCs)

� UNIX (Solaris version, as written by CDE running on a SPARC-based workstation)

� UNIX (IA version, as written by CDE running on an IA–based workstation)

CDE supports DOS High Density and NEC-DOS Medium Density formats whether
running on SPARC or IA, but the following restrictions apply to the UNIX format:

� A SPARC-based workstation cannot read or write diskettes formatted as "UNIX" on
an IA system

� An IA– based workstation cannot read or write diskettes formatted as "UNIX" on
an SPARC system
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Tip – If you need to use the same diskettes on SPARC-based and IA–based systems,
use the DOS High Density format.

Removable Media Manipulation Skills
This section describes tasks that you can perform using diskettes and CD-ROMs with
File Manager.

� To View Files and Folders on a Diskette
1. Insert the diskette into a disk drive.

2. Select Open Floppy from the Files subpanel on the Front Panel, or from the File
Manager File menu.

If the diskette is formatted and readable by the system (see “Supported Formats”
on page 193), File Manager displays a view of the diskette’s contents. If the diskette is
unformatted or is unreadable by the system, File Manager displays the Format Floppy
dialog box.

Note – If your system has more than one disk drive, File Manager opens one window
for each readable diskette you insert when you choose Open Floppy from the File
menu.

� To View Files and Folders on a CD-ROM
� Insert the CD-ROM into a CD-ROM drive.

File Manager displays a window containing a view of the CD-ROM contents.

If you close the CD-ROM’s File Manager window, you can reopen it by selecting Open
CD-ROM from either the File Manager File menu or from the Folders Subpanel on the
Front Panel.

� To Format a Diskette
1. Choose Format Floppy from the diskette’s File Manager window File menu.

The Format Floppy dialog box appears.

2. Select one of the formatting options (see “Supported Formats” on page 193).
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3. Click Format or press Return.

4. (Optional) To rename the diskette, type the new name in the Floppy Name text field
and press Return.

� To Rename a Diskette
1. Choose Rename Floppy from the diskette’s File Manager window File menu.

The Rename Floppy dialog box appears.

2. Type the new name in the Floppy Name text field.

3. Click Rename or press Return.

� To Eject a Diskette or CD-ROM
1. Choose Eject from the File Manager window File menu.

2. Remove the diskette or CD-ROM from the disk drive.

� To Copy Files or Folders to a Diskette
1. Select the icon for the file or folder you want to copy.

2. Choose Copy to from the Selected menu.

The Copy Object dialog box appears.

3. Type a full path name in the Destination Folder text field.

Use /floppy as the directory name. For example, if you want to copy the file report
onto a diskette named john, you would type /floppy/john.

4. Type the file or folder name in the Name for copy text field.

In the above example, you would type report.

5. Click OK or press Return.

Note – You cannot copy files or folders to a CD-ROM.

� To Move Files or Folders to a Diskette
1. Select the icon for the file or folder you want to move.
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2. Choose Move to from the Selected menu.

The Move Object dialog box appears.

3. Type a full path name in the Destination Folder text field.

Use /floppy as the directory name. For example, if you want to move the file
report onto a diskette named john, you would type /floppy/john.

4. Click OK or press Return.

Note – You cannot move files or folders to a CD-ROM.

� To Delete Files or Folders From a Diskette
� Choose the Put in Trash command from the file or folder icon’s pop-up menu

(displayed by pressing Shift+F10 or mouse button 3).

� Or, select the file or folder’s icon, then choose Put in Trash from the Selected menu.

� Or, drag the file or folder’s icon and drop it onto the Trash Can control in the Front
Panel.

� Or, drag the file or folder’s icon to an open Trash Can window.

� To Create Files and Folders on a Diskette
1. Choose New File or New Folder from the File menu.

2. Type a name in the New File Name field of the New File dialog box or New Folder
Name field of the New Folder dialog box.

3. Click OK or press Return.

To close the New File or New Folder dialog box without creating a new file or folder,
click Cancel or press Escape.

Note – You cannot create files or folders on a CD-ROM.
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CHAPTER 6

Using Removable Media Manager

Use Removable Media Manager to format, protect, and view data on removable media
devices such as diskettes, CD-ROM, DVD-ROM, Iomega Zip drives, and Iomega Jaz
drives.

� “Starting Removable Media Manager” on page 197
� “Supported Media Classes” on page 198
� “Viewing Additional Information About a Device” on page 198
� “Properties” on page 199
� “Formatting and Slicing Devices” on page 200
� “To Protect a Device” on page 202

Starting Removable Media Manager
To open the Removable Media Manager:

� In File Manager, choose Removable Media Manager from the File menu.

� From the Front Panel, click the Removable Media Manager icon in the Files
subpanel.

� From the Workspace menu, choose Removable Media Manager in the Folders
menu.

When Removable Media Manager starts, it displays all media currently loaded into
the drives. The different forms of devices are represented by icons and are unlimited.
For example, if a machine has three drives loaded with diskettes, three diskette icons
are displayed. The icon view updates each time a device is inserted or ejected. Each
class of media is represented by a different icon.
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You can select one or more devices and perform operations on them. A device is
displayed with a nickname (cdrom0), an optional volume name
(ssa_2_1_sparc), and an optional partition or slice number (s1).

Note – In order to have the Removable Media Manager recognize a diskette, you must
choose Open Floppy from one of the following:

� File subpanel of the Front Panel
� File menu of the File Manager
� Folders menu of the Workspace Menu

Supported Media Classes
Removable Media Manager supports the following devices:

� Diskette
� CD-ROM
� DVD-ROM
� Zip
� Jaz
� Rmdisk (generic call includes Sysquest devices)

Viewing Additional Information About a
Device
To display additional information about a device, you must change the viewing
option. To do this:

� To Change the Viewing Option
1. In the Removable Media Manager window, click on a device.

2. From the View menu, select Set View Options.

3. Under the Representation section, select the By Name, date, size... button.
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4. Click OK.

Note – If the device has no name, it is shown as ..unnamed.

In verbose mode, Removable media manager shows the following for each media
object:

� Volume name
� Media nickname or alias
� Media partition or slice number
� Total storage capacity
� Mount point UNIX permissions
� Mount point owner name
� Mount point group name
� Mount point path
� Mount point date

Properties
The Properties dialog box displays the properties and capacity capabilities of a device.
Two property categories can be displayed using the properties dialog box:

� Information—shows the alias, product id, write protect and password protection
status. Also displayed are the file system, mount point and total capacity.

� Floating Capacities—shows the used and available capacities for a device.

� To View the Properties of a Device
The properties of a device are available using two different methods. Properties can be
accessed from the Removable Media Manager menu and from the Command Line.

1. Viewing properties from the Removable Media Window

a. From the Removable Media Manager window, click on a device to select it.

b. From the Selected menu, select Properties.

2. To view properties using the command line option, type:

sdtmedia_prop -u k /vol/dev/rdsk/...

where —u is b, k, m, or g.
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This action shows capacities in units of bytes, kilobytes, megabytes, or gigabytes.

Formatting and Slicing Devices
You can format, name, and create file systems in a single operation on all types of
removable devices by the format option in the Removable Media Manager window.

Two separate actions are launched. The first is a low level format of the device, which
utilizes a status bar to update you on the percentage completed. When the format is
complete, the second action is launched which applies the file system and optional
name and slices to the device.

� To Format a Device
Formatting is done on all re-writable devices, including diskettes, Jaz, and Zip devices.
Formatting can be initiated in one of two ways.

1. To format from the Removable Media Manager window:

a. Click on a device icon.

b. From the Removable Media Manager window, choose the Selected menu.

c. Choose Format.

The Media Format window will appear with further selections relative to the
device you have selected.

d. Select either Quick Format or Long Format.

e. Select a type from the File System pull-down menu.

f. (Optional) Under Volume Name type a name for the formatted device.

If no name is specified, the device will not be named. If the device has already been
formatted and has a volume name, the volume name will not be shown.

If UFS was selected as the file system the Solaris Slice Editor button will appear in
the dialog box.
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g. Click Format.

Note – ‘Long Format’ ignores password protection on the device. If the media is
read-write protected you will be prompted for the password. ’Long Format’ is the
default value for previously sliced media, write protected media or write protected
with password media.

2. To format using the command line option:

To format, name, and create file systems on all types of removable media devices from
the command line type:

sdtmedia_format -d volume_device_name

� Creating Solaris Slices
The Media Slice Editor is used to create Solaris slices on a device. You can only create
slices in an UFS file system. If you select a PCFS or UDFS file system, you will not
have the option of creating Solaris slices.

Once slices are created, the Media Slice Editor can be used to write UFS or UDFS file
systems onto the slices. Where possible the Media Slice Editor will check the slice
values supplied by the user and the overall integrity of the slice information. For
example, it will report errors for overlapping slices.

There are two methods of creating slices. The first is to use the AutoSlice option.

1. Using AutoSlice.

a. Select the AutoSlice button.

b. Type the number of slices to be created.

c. Click OK.

2. Or you may enter the number and size of the slices into the Slice Editor dialog box.
The Slice Editor will create slices on cylinder boundaries.
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To Protect a Device
Device protection enables you to view the software protection for a selected device
and to either write protect, read-write protect or disable protection. The device
protection options are:

� Disable Protection
� Write Protect Without Password
� Write Protect With Password
� Read-Write Protect with Password

� To View a Device’s Protection
1. In the Removable Media Manager window, click on a device.

2. From the Selected menu, choose Properties.

� To Disable Protection
This option allows the user to disable software protections if the medium has been
previously write or read-write protected.

1. If the media has been write protected without a password:

a. In the Removable Media Manager window, select the device.

b. From the Selected menu, select Disable Protection.

2. If the media has been write or read-write protected with a password:

a. In the Removable Media Manager window, select the device.

b. From the Selected Menu, choose Disable Protection.

c. Type the password into the Password dialog.

� To Enable Protection
This option allows the user to enable software protection.
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1. To write protect without a password:

a. In the Removable Media Manager window, select the device.

b. From the Selected Menu, choose Write Protect.

c. In the Protect dialog, click Write Protect Without Password.

d. Click OK.

2. To write protect with a password:

a. In the Removable Media Manager window, select the device.

b. From the Selected menu, choose Write Protect.

c. In the Protect dialog, click Write Protect With Password.

d. In the Enter Password area, type the password.

e. Tab to the Verify Password area and type the password again.

f. Click Apply.

3. To read-write protect with a password:

a. In the Removable Media Manager window, select the device.

b. From the Selected Menu, choose Read-Write Protect.

c. In the Protect dialog, click Read-Write Protect With Password.

d. In the Enter Password area, type the password.

e. Tab to the Verify Password area and type the password again.

f. Click Apply.

4. Command Line Option

To start the Password dialog box from the command line, type:

sdtmedia_prot [-w|-d] /vol/dev/rdsk/...

Use the command line options in the following table to specify the degree of
protection for the device.

TABLE 6–1 Command Line Option sdtmedia_prot

—w
If the device is not protected, write protects the device without a
password and does not display any dialogs. If the device is already
protected, displays an error dialog.
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TABLE 6–1 Command Line Option sdtmedia_prot (Continued)

—d
Disable device protection. If the device is password protected, the user is
prompted for the password.

Use the command line options in the following to specify the degree of protection for a
device.

� To Change Your Password
To change your password, you must first disable the existing password protection and
then apply the new password protection to the device. After entering your new
password you will have to enable password protection.

1. Disable your password protection.

2. Type a new password in the field.

3. Re-enter the same password.

4. Click Apply to enable password protection or Cancel to abort the operation.
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CHAPTER 7

Using Window Manager
Enhancements

Window Manager Enhancements consist of three separate applications. They are:

� “Graphical Workspace Manager” on page 205
� “Window List ” on page 212
� “Workspace Manager” on page 218

These three applications provide the ability to manipulate workspaces and windows
from the different applications depending on the tasks you want to perform. Graphical
Workspace Manager allows for changes in workspaces and windows. The Window
List concentrates on the manipulation of windows. Finally, the Workspace Manager
controls the number of workspaces, whether or not the Workspace Switch Area
appears on the Front Panel, and the ability to restore the default values.

Graphical Workspace Manager
Graphical Workspace Manager enables you to operate a workspace "control panel".
This panel displays a window containing a miniaturized picture of each workspace on
the desktop. Workspaces may be created, deleted, renamed, tiled, or cascaded.
Application windows may be moved (within or between workspaces), terminated,
minimized, or maximized.
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FIGURE 7–1 Graphical Workspace Manager Main Screen

Starting the Graphical Workspace Manager
The Graphical Workspace Manager can be started either from the Desktop or from the
command line.

� To Start the Graphical Workspace Manager from the
Desktop

1. Right-click on the Desktop to open the Workspace menu.

2. Choose Applications.

3. Choose Application Manager.

4. Double-click Desktop_Apps.

5. Double-click GWM.

� To Start the Graphical Workspace Manager from the
Command Line

� Type sdtgwm at the command line.
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Graphical Workspace Manager Tasks
There are a number of tasks that you can perform using Graphical Workspace
Manager:

FIGURE 7–2 Graphical Workspace Manager – Workspace Menu

� “To Add a Workspace” on page 207
� “To Delete a Workspace” on page 208
� “To Rename a Workspace” on page 208
� “To Switch to a Different Workspace” on page 208
� “To Cascade All Windows in a Workspace” on page 208
� “To Tile All Windows in a Workspace” on page 208
� “To Minimize a Window” on page 209
� “To Close a Window” on page 209
� “To Terminate an Application” on page 210
� “To Move a Window to a Different Workspace” on page 210
� “To Occupy Workspace(s)” on page 210
� “To Unoccupy Workspace” on page 210

� To Add a Workspace
1. Choose Add Workspace from the Workspace menu.

2. Enter a name in the Add Workspace dialog box.
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3. Click OK.

� To Delete a Workspace
1. Choose Delete Workspace from the Workspace menu.

2. Choose the workspace to be deleted from the submenu.

� To Rename a Workspace
1. Choose Rename from the Workspace menu.

2. From the submenu, select the workspace to be renamed.

3. Enter the new name in the Rename Workspace dialog box.

4. Click OK.

� To Switch to a Different Workspace
1. Choose Switch to Workspace from the Workspace menu.

2. From the submenu, select the workspace to which you want to switch.

� To Cascade All Windows in a Workspace
This task executes in the current workspace.

� Choose Cascade All Windows from the Workspace menu.

� To Tile All Windows in a Workspace
This task executes in the current workspace.

1. Choose Tile All Windows from the Workspace menu.

2. From the submenu, choose Horizontal or Vertical.
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� To Open the Options Dialog
� Choose Options from the Workspace menu.

For further information on the Options Dialog, see “Graphical Workspace Manager
Options Dialog” on page 210.

FIGURE 7–3 Graphical Workspace Manager — Window Menu

� To Minimize a Window
1. Select a window in Graphical Workspace Manager.

2. Choose Minimize from the Window menu.

� To Close a Window
1. Select a window in Graphical Workspace Manager.

2. Choose Close Window from the Window menu.

3. (Optional) If the window you are closing is the only window that contains the
application, a confirmation dialog will appear. Click OK, if you want to continue
with closing the window.
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� To Terminate an Application
1. Select an application window in Graphical Workspace Manager.

2. Choose Terminate Application from the Window menu.

3. In the confirmation dialog box, click OK.

� To Move a Window to a Different Workspace
1. Select a window in the Graphical Workspace Manager.

2. Choose Move to Workspace from the Window menu.

3. From the submenu, choose the workspace to which you want the window to move.
You may also choose All Workspaces.

� To Occupy Workspace(s)
1. Select a window in the Graphical Workspace Manager.

2. Choose Occupy Workspace from the Window menu.

3. Choose the workspace(s) from the submenu.

Multiple workspaces can be selected by pressing the Control key and selecting the
additional workspaces.

4. Click OK.

� To Unoccupy Workspace
1. Select a window in the Graphical Workspace Manager.

2. Choose Unoccupy Workspace from the Window menu.

Graphical Workspace Manager Options Dialog
The Graphical Workspace Manager Options dialog box contains a number of options
that can be set. They are:
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FIGURE 7–4 Graphical Workspace Manager Options Dialog Box

� Show Workspace Thumbnails On Front Panel – Determines if the Graphical
Workspace Manager workspace images will appear on the Front Panel.

� Show Workspace Backdrops – Determines if the actual workspace backdrops will
be shown in the Graphical Workspace Manager.

� Show Workspace Names – Displays the workspace names in the thumbnailed
workspaces of the Graphical Workspace Manager.

� Number of Visible Rows – Enables the setting of the number of rows used to
display the open workspaces of the Graphical Workspace Manager.

� Desired Thumbnail Width (Pixels) – Sets the width, in pixels, of the workspace
display in the Graphical Workspace Manager.

� Changes Thumbnail Size – Specifies that a resize of the Graphical Workspace
Manager will actually increase/decrease the size of the Graphical Workspace
Manager main window, thus changing the size of the workspace thumbnails.

� Changes Layout – Specifies that a resize of the Graphical Workspace Manager will
only change the layout of the workspace thumbnails within the Graphical
Workspace Manager.

� Show Window Contents – Causes window images to be grabbed and displayed.
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� Show Window Frames – Window images will not be grabbed. Blank boxes will be
displayed.

� Highlight Windows In Current Workspace – The windows in the current
workspace will be displayed in the desktop highlight color. This option is only
available if Show Window Frames is selected.

� Show Window Names – The command name of the window will appear in the
window. This option is only available if Show Window Frames is selected.

Window List
The Window List displays information about all windows across the CDE workspaces.
Once launched, the window list will be updated in a dynamic fashion.

FIGURE 7–5 Window List Main Screen

The windows can be sorted in one of the following orders:

� Workspace Name
� Window State
� Application Name
� Window Title

Starting the Window List
The Window List can be started either from the Desktop or from the command line.
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� To Start the Window List from the Desktop
1. Right-click on the Desktop to open the Workspace Menu.

2. Select Applications.

3. Select Application Manager from the Applications submenu.

4. Double-click Desktop_Apps.

5. Double-click Window List.

� To Start the Window List From the Command Line
� Type sdtwinlst at the command line.

Performing Window List Tasks From the Window
Menu
There are a number of tasks that you can perform using the Window List. They are:

� “To Go To a Window” on page 214 – Goes to the selected window and gives it
focus. If it is in another workspace, you are moved to that workspace.

� “To Get a Window” on page 214 – Moves the selected window from whatever
workspace it is in to the one you are currently in and gives it focus.

� “To Lower a Window in the Stack” on page 215 – Lowers the selected window to
the bottom of the window stack.

� “To Minimize the Selected Window(s)” on page 215 – Minimizes the selected
window(s).

� “To Close a Window” on page 215 – Closes the selected window(s). If the window
to be closed is the only window associated with an application, a confirmation
dialog box appears.

� “To Terminate an Application” on page 215 – A confirmation dialog box appears
and all windows associated with that application are closed.

� “To Move the Selected Window(s) Into Another Workspace” on page 215 – Moves
the selected window(s) to the specified workspace.

� “To Occupy the Selected Workspace” on page 216 – Opens the Workspace Chooser
dialog box and places the selected window in the workspace chosen from the list.

� “To Unoccupy the Selected Workspace” on page 216 – Removes the selected
window from the current workspace. If this is the only workspace the selected
window resides in, this option is greyed out.
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� “To Cascade all Non-minimized Windows in a Workspace” on page 216 – Cascades
all windows in the current workspace.

� “To Tile all Non-minimized Windows in a Workspace” on page 216 – Tiles all
windows in the current workspace. Tiling can be horizontal or vertical.

FIGURE 7–6 Window List Window Menu

� To Go To a Window
1. Select a window from the Window List.

2. Choose Go To Window from the Window menu.

Note – Depending on the setting of the Window List Options, you may be able to
double-click on the Window List entry and move to the workspace that contains the
selected window or have the window move to the current workspace. Refer to “To Set
the Action of a Double-click on a Window Entry” on page 218.

� To Get a Window
1. Select a window from the Window List.

2. Choose Get Window from the Window menu.

Window appears in the current workspace.
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� To Lower a Window in the Stack
1. Select a window from the Window List.

2. Choose Lower from the Window menu.

� To Minimize the Selected Window(s)
1. Select a window(s) from the Window list.

2. Choose Minimize from the Window menu.

� To Close a Window
1. Select a window(s) from the Window List.

2. Choose Close Window from the Window menu.

3. (Optional) If the window being closed is the only window that contains a given
application, a confirmation dialog box will appear. Click OK, if you want to close
the window and terminate the application.

� To Terminate an Application
1. Select a window from the Window List.

2. Choose Terminate Application from the Window menu.

3. (Optional) If the window being closed is the only window that contains a given
application, a confirmation dialog box will appear. Click OK, if you want to close
the window and terminate the application.

� To Move the Selected Window(s) Into Another Workspace
1. Select a window(s) from the Window List.

2. Choose Move to Workspace from the Window menu.

3. Choose a workspace or All Workspaces.
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� To Occupy the Selected Workspace
1. Select a window(s) from the Window List.

2. Choose Occupy a Workspace from the Window menu.

3. Choose the workspace you want the window to occupy from the Occupy Workspace
dialog box.

� To Unoccupy the Selected Workspace
1. Select a window(s) from the Window List.

2. Choose Unoccupy a Workspace from the Window menu.

� To Cascade all Non-minimized Windows in a Workspace
This occurs only in the current workspace.

� Choose Cascade All in Workspace from the Window menu.

� To Tile all Non-minimized Windows in a Workspace
This occurs only in the current workspace.

1. Choose Tile All in Workspace from the Window menu.

2. Click Horizontal or Vertical from the submenu.

Performing Window List Tasks from the Option
Menu
There are two tasks that can be performed from the Option Menu. They are:

� “Sorting Options” on page 217
� “Opening the Options Dialog” on page 217
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FIGURE 7–7 Window List Option Menu

� Sorting Options
1. Select Sort By from the Option menu.

2. Choose one of the four sort options.

� Opening the Options Dialog
� Select Options from the Option menu.

Window List Options
There are two options that you can change using the Window List – Options dialog
box:

� Show Column
� Double–clicking on a window in the list

These two options allow the setting of which columns will appear in the Window List
and what action will be taken when you double-click on a window item in the
Window List.
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FIGURE 7–8 Window List – Options Dialog

� To Show Columns
� Click the State, Application, or Workspace check boxes for that column to be

displayed.

The lack of a checkmark means the column will not be displayed.

Note – The Window Title column will always be visible.

� To Set the Action of a Double-click on a Window Entry
Window List provides the ability to select the effect of double-clicking a window entry
in the Window List.

1. Click the Switches to the workspace where the window resides check box.

This has the effect of switching to the workspace that contains the selected window.

2. Click the Moves the window to the current workspace check box.

This has the effect of moving the selected window to the current workspace.

Workspace Manager
The Workspace Manager provides a Graphical User Interface (GUI) for controlling
behavior and the number of workspaces. You will be able to add and delete
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workspaces using the slide bar. Workspace Manager enables you to show the
Workspace Switch Area on the Front Panel instead of the workspace buttons. You will
also be able to return to the default settings.

FIGURE 7–9 Workspace Manager Main Screen

Starting Workspace Manager
You can start the Workspace Manager either from the Workspace Menu or at the
command line.

� To Start the Workspace Manager From the Desktop
1. Right-click on the Desktop to open the Workspace Menu.

2. Choose Applications.

3. Choose Application Manager from the submenu.

4. Double-click Desktop_Apps.

5. Double-click Workspace Manager Controls.

� To Start the Workspace Manager From the Command Line
� Type sdtwsm at the command line.
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Using Workspace Manager Controls
There are a number of functions that can be performed using the Workspace Manager:

� “To Display the Workspace Switch Area on the Front Panel” on page 220
� “To Synchronize Workspaces Across Screens” on page 220
� “To Set the Number of Workspaces” on page 220
� “To Restore the Default Settings” on page 220

� To Display the Workspace Switch Area on the Front
Panel

1. Select the Show Workspace Switch Area On Front Panel check box.

2. Click OK.

� To Synchronize Workspaces Across Screens
1. Select the Synchronize Workspaces Across Screens check box.

2. Click OK.

� To Set the Number of Workspaces
1. Move the Number of Workspaces slide bar until the desired number of workspaces

appears.

2. If the resulting number of workspaces is an addition, the new workspace icons will
appear on the Front Panel.

3. (Optional) If the resulting number of workspaces is a reduction, the Workspace
Manager Delete Workspace dialog box will appear. Click OK, if you want to delete
the workspace(s).

� To Restore the Default Settings
� Click the Default button in the Workspace Manager Controls window.
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CHAPTER 8

Using Application Manager

Application Manager is a container for the applications and other tools available on
your system. (The relationship between Application Manager and the Front Panel and
Workspace menu is explained in “Running Applications” on page 45.)

This chapter explains how to use and make personal customizations to Application
Manager. Customizations are typically carried out by the system administrator.

� To Open Application Manager
� Application Manager Windows
� To Run an Application
� Setting Up Applications

To Open Application Manager
1. Open the Application subpanel by clicking the tab above the Text Note control on

the Front Panel.
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FIGURE 8–1 Application Manager control

2. Click Applications.

The main Application Manager window is displayed

FIGURE 8–2 Personal Applications Group in Applications Manager

Application Manager Windows
The Application Manager window is a special File Manager view of the Application
Manager in your file system. It looks and behaves somewhat like a File Manager
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window, but it is populated each time you log in, and you cannot copy new
applications and files directly into it.

The main window contains a set of application groups, or folders containing icons that
you use to start applications; some application groups contain other useful application
files such as sample data files, templates, and ‘‘read me’’ files. The application groups
may be located on your system or on other systems throughout the network. An icon
that starts an application is called an action icon or application icon.

FIGURE 8–3 Action (Application) Icons in the Desktop_Apps Application Group

The application groups in your Application Manager are either built in or registered
by your system administrator. CDE provides the built-in application groups listed in
the following table.

TABLE 8–1 Application Groups in Application Manager

Application Group Description

Desktop_Apps Applications and accessories typically found in a desktop
environment, (for example: Calculator, File Manager and Text
Editor).

Desktop_Controls Applications typically used for setup and customization of
the desktop (for example, Customize Workspace Manager
and Restore Front Panel).

Desktop_Tools File manipulation tools that are typically used by people who
understand actions and file types

Information Online documentation and release notes.
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TABLE 8–1 Application Groups in Application Manager (Continued)
Application Group Description

OpenWindows Standard applications from the OpenWindows desktop
environment for users transitioning from it

System_Admin Tools for use by the system administrator and for people
working with hardware devices such as CD-ROM drives and
disks.

Menus and Commands
Since Application Manager is closely related to the File Manager window, it uses most
of the same menus, commands, and other features.

For more information about using the File Manager menus and dialog boxes, see
Chapter 5.

To Run an Application
1. Open Application Manager.

2. Double-click the application group’s icon to display its contents.

3. Double-click the application’s action icon.
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FIGURE 8–4 Opening an Application Window from Application Manager

Setting up Applications
You can put an application on the Front Panel or on your desktop. You can also create
your own application group in Application Manager.

� To Put an Application Icon in the Front Panel
1. Display the application’s icon in Application Manager.

2. Display the subpanel to which you want to add the application.
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3. Drag the action icon from Application Manager to the Install Icon control in the
subpanel.

FIGURE 8–5 Installing an Application (Action Icon) in the Front Panel

� To Put an Application Icon on the Workspace
Backdrop
This procedure copies an application icon from Application Manager to the workspace
(backdrop). This makes the icon available when you don’t have an Application
Manager window open

1. Open the application group containing the application you want to add.

2. Drag the application from Application Manager to the workspace backdrop.
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� To Create a Personal Application Group
A personal application group is an application group that you can alter, since you
have write permission to it.

1. From your home folder, change to the .dt/appmanager subfolder.

2. Create a new folder and name it.

The folder name will become the name of the new application group.

3. Double-click Reload Applications in the Desktop_Controls application group.

Your new application group will become registered at the top level of Application
Manager.

� To Add Applications to a Personal Application
Group
� Copy icons from other application groups to the personal application group.

For example, you can copy (by dragging) the Calculator icon from the
Desktop_Tools application group to your new personal application group.

� Create an action for an application and then place an application (action) icon in
the personal application group.

� To Update Application Manager
The contents of your Application Manager are built each time you log in. Each time it
is built, it searches certain system and network locations for applications.

If your system administrator adds an application to your system or to an application
server while you are in a session, you must update your Application Manager if you
want the new application to be registered immediately.

There are two ways to update Application Manager:

� Open the Desktop_Controls application group and double-click Reload
Applications.

� Or, log out and log back in.
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Advanced Application Manager
Concepts
This section describes several advanced Application Manager concepts:

� The relationship between file names and icon labels

� The folder location of Application Manager

� Creating personal actions and data types

� Where to obtain additional information about customizing Application Manager

File Names in Application Manager
Unlike regular files displayed in File Manager, the name displayed below an
application icon in Application Manager is the action icon’s label, not the action file
name. Normally, you do not need to know the action file name.

However, there are situations where you may see the file name, for example, if you
use the Copy File dialog box to copy the icon. In such cases, select the file and choose
Copy To from the Selected menu, and the Copy To dialog box will display the file
name.

Folder Location of Application Manager
Application Manager behaves much like File Manager. This is because Application
Manager is a File Manager view of a special folder on your system used to gather
registered applications. Ordinarily, you do not need to know the location of this
special folder. However, its location may be useful to you if you are trying to
troubleshoot problems.

Login Manager creates the Application Manager folder each time you log in. Its
location is:

/var/dt/appconfig/appmanager/special_folder_name

where special_folder_name is a name assigned by the system that is unique for your
system and login name.
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Caution – You should never attempt to directly modify the special_folder_name folder
from a command line.

Creating Personal Actions and Data Types
The desktop provides a tool that helps you create icons for running scripts,
applications, and other commands. You may want to use this tool if you have a
personal application your system administrator has not configured for you.

For example, suppose you have your own favorite spreadsheet application that you
usually start by typing a command into a terminal emulator window:

FavoriteSpreadSheet -file data_file

You can create an icon that runs this command so that you won’t have to continue
manually typing it. To do this, you must create a special desktop ‘‘macro’’ called an
action. You can also create a data type for each data_file.

The desktop includes a tool called Create Action that makes it easy to create actions
and data types. To open the Create Action window, double-click the Create Action icon
in the Desktop_Apps application group.
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FIGURE 8–6 Create Action Window

� To Get Help on the Create Action Window
1. Choose Tasks from the Create Action window’s Help menu.

2. Click the hyperlink ‘‘To Create an Action With Create Action.’’

Create Action:

� Creates an action for your application
� Places an action icon in your home folder.
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You can move or copy that icon to other locations—for example, to a personal
application group that you’ve created.

Registering Applications
When an application is registered in Application Manager, it has its own application
group. This application group is available to all users on the system.

Registering applications is an advanced task, since it requires you to be the root user.
For instructions, see the Advanced User’s and System Administrator’s Guide.
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CHAPTER 9

Customizing the Desktop Environment

Style Manager can be used to customize the appearance of the desktop.

� “Customizing Screen Appearance” on page 235
� “Customizing System Behavior” on page 244
� “Customizing Startup and Logout” on page 250
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Note – By default, your customizations will affect only the current session unless you
save them as the home session, as explained in “To Set a Home Session” on page 251.

Introducing Style Manager
To start Style Manager:

� Click the Style Manager control in the Front Panel.

FIGURE 9–1 Style Manager Front Panel control

The Style Manager controls and the items that they control are:

Color - Workspace colors and palettes

Font - Application font sizes and font groups

Backdrop - Workspace backdrop patterns

Keyboard - Key click volume and character repeat capability

Mouse - Mouse button click settings, double-click speed, pointer acceleration, and
pointer movement threshold

Beep - Beeper volume, tone, and duration

Screen - Number of minutes before your screen blanks and whether your screen is
covered and locked at that time

Window - How a window acquires focus, if the window raises when it receives focus,
and where window icons are placed

Startup - How your session begins and ends
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FIGURE 9–2 Style Manager controls

Customizing Screen Appearance
You can change the following aspects of your screen appearance:

� Color Palettes
� Workspace backdrops
� Font sizes and font groups

Color Palettes and Color Flashing
You set your workspace colors through a color palette. The number of colors in the
palette is determined by your display type and the Number of Colors selection.

FIGURE 9–3 Number of Colors Dialog Box

Running certain applications may result in a phenomenon know as color flashing or
colormap flashing, where the application appears with incorrect colors while the rest of
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the desktop appears normal, and when given the focus it displays with correct colors
but the rest of the desktop does not. Color flashing is typically found in either of the
following circumstances.

� Your workstation does not use a 24 bit graphics card

� You are running applications that are designed to use their own colormaps (thus
placing a burden on the frame buffer)

This is due to fundamental limitations in XWindows when dealing with applications
that do not use the default colormap. While you can’t use more colors than your
display allows, you can reduce the number of colors used by the desktop by choosing
a lower-valued color usage in the Number of Colors to Use dialog box, or by exiting
other graphics-intensive applications.

For example, if you have a high-color display and have selected More Colors for
Desktop but you want to run a color-rich application such as a computer-aided design
(CAD) program, you should choose More Colors for Applications or Most Colors for
Applications to decrease the number of colors that the desktop uses. The remaining
colors are available for the CAD program.

� To Overcome Color Flashing
If you have closed all other graphics-intensive applications and your application is
still experiencing color flashing, the following procedure may help eliminate the
problem.

1. Open Style Manager.

2. Click Color.

The Color dialog box is displayed.

3. Click Number of Colors.

The Number of Colors To Use dialog box (see Figure 9–3) is displayed.

4. Select Most Colors For Applications and click OK.

5. Click Desktop background and choose a simple workspace background such as
Gray Lt.

6. Make this session your home session by following the procedure in“To Set a Home
Session” on page 251.

7. Exit Style Manager and logout of CDE.
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8. Login to CDE and re-open the application that previously experienced color
flashing.

If the application no longer experiences color flashing, make a note of the current Style
Manager settings; if it is still experiencing color flashing, the application has probably
specified a list of colormaps to be installed, CDE is only installing the first colormap in
this list, so you will need to cycle through the colormaps as explained in the following
steps.

9. Use the following special keyboard keys to cycle through the colormaps.

Control-L2 (or Control-Again) Steps forward through the colormaps

Control-L4 (or Control-Undo) Steps backward through the colormaps

Cycling through the colormaps may end up installing the correct colormap, and will
not affect the other windows on the desktop in any way. If you continue to experience
colormap flashing, have your system administrator seek further information on
SunSolveSM.

Running OpenWindows Applications

During startup, dtsession will set *foreground, *background and other
OpenWindows global color resources so that OpenWindows applications will be in the
same color scheme as CDE applications. You can still control the appearance of their
applications by setting application-specific resources; alternatively, change the palette
in Style Manager and restart the OpenWindows application.

Color Buttons
Your display type and the Number of Colors selection determine the number of color
buttons that make up a palette. You will have two, four, or eight color buttons in the
Color dialog box. The different color buttons in the palette control the colors used for
different areas of the screen.

If you have eight color buttons, they will be used as follows (buttons numbered from
left to right, top to bottom):

1. Active window borders

2. Inactive window borders

3. Switch for workspace 1 and every fourth additional workspace (workspace 5, 9, ...)

4. Text and list areas

5. Main window background and switch for workspace 2 and every fourth additional
workspace (workspace 8, 12, ...)

Customizing the Desktop Environment 237



6. Dialog box background and menu bar and switch for workspace 3 and every
fourth additional workspace (workspace 7, 11, ...)

7. Switch for workspace 4 and every fourth additional workspace (workspace 6, 10,
...)

8. Front Panel background

If you have four color buttons, they will be used as follows (buttons numbered from
left to right):

1. Active window borders
2. Window bodies:

a. Inactive window borders
b. Main window and dialog box backgrounds and menu bar
c. Front Panel background

3. Workspace switches and backgrounds
4. Text and list areas

If you have two color buttons, they will be used as follows (buttons numbered from
left to right):

1. Active window borders
2. Everything else

� To Select a Palette
1. Click the Style Manager Color control.

2. Select a palette from the Palettes list.
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3. Click OK.

Workspace colors come from predefined color palettes. The Color dialog box lists the
palettes that came with your system plus any palettes you have added.

� To Modify an Existing Palette
1. Click the Style Manager Color control.

2. Select a palette in the Color dialog box.

3. Double-click a color button to open the Modify Color dialog box, or click a color
button and then click Modify.

4. Adjust the settings for the level of red, green, blue, brightness, or hue by adjusting
the corresponding slider.

The old and new color samples will be displayed in the upper left corner of the
Modify Color dialog box.
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5. Click OK in the Modify Color dialog box.

6. Repeat steps 2-4 to modify another color button.

7. Click OK in the Color dialog box.

� To Grab a Color from the Workspace
1. Click the Style Manager Color control.

2. Select a palette in the Color dialog box.

3. Double-click a color button to open the Modify Color dialog box, or click a color
button and then click Modify.

4. Click Grab Color to display the grab pointer.

5. Move the pointer to an area of color on the screen that you want to grab.

6. Click to make that color the new color.

Note – This causes the desktop to use one more color so applications have one fewer
color available to them.

� To Create a Custom Palette
You can create your own palette by copying and modifying an existing palette.

1. Click the Style Manager Color control.

2. Choose Add in the Color dialog box.

3. Type the new palette name and click OK in the Add Palette dialog box.

4. Modify the palette.

5. Click OK in the Color dialog box.

Adding a palette makes a copy of the currently selected palette with a unique name.
You then create your custom palette by modifying the copy and the original palette is
not changed.
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� To Delete a Palette
1. Click the Style Manager Color control.

2. Select the palette from the Palettes list.

3. Click Delete.

4. Click OK in the Delete Palette dialog box.

When you delete a palette, Style Manager prefixes the name of the palette with a ~
and stores a copy in the HomeDirectory/.dt/palettes directory.

� To Restore a Deleted Palette
1. Open a File Manager view showing HomeDirectory/.dt/palettes.

2. For system-supplied palettes, delete the file ~palette_name.dp.

For user-added palettes, rename the deleted palette from ~palette_name.dp to
palette_name.dp.

3. Restart Style Manager (close, then reopen).

� To Change the Number of Colors Used by the Desktop
1. Click the Style Manager Color control.

2. Click Number of Colors in the Color dialog box.

3. Select an option to set the number of colors used by the desktop.

See “Color Palettes and Color Flashing” on page 235.

4. Click OK.

You must log out and back in for the change to take effect.

Fonts
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The font size and font group you select in Style Manager is used on titles, menu
bars, window labels and text. The new font size and font group is used as
applications are started. Existing windows will not reflect the change.

� To Select a Font Size
1. Click the Style Manager Font control.

2. Select a font size under Size.

3. Click OK to enable newly started applications to use the selected typeface, or click
Cancel to cancel the operation.

� To Select a Font Group
1. Click the Style Manager Font control.

2. Select a font group under Font Group.

3. Look at the Preview window labels and text, which show the new font typeface.

4. Click OK to enable newly started applications to use the selected typeface, or click
Cancel to cancel the operation.

� To Add a Font Group
1. Click the Style Manager Font control.

2. Choose Add in the Font dialog box.

3. Choose a font group from the System scrolling list and a font group from the User
scrolling list.

4. Click OK to open the Font Group Name dialog box.
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5. Enter a name in the New Font Group Name field of the Font Group Name dialog
box for the new font group.

You can enter any non-blank name that you want.

6. Click OK to add a font group to the Font dialog box scrolling list.

� To Delete a Font Group
1. Click the Style Manager Font control.

2. Select a font group from the Font Group scrolling list on the Font dialog box.

3. Click the Delete button.

The Delete Font Group dialog box appears.

4. Click OK to delete the font group from the Font Group scrolling list.

� To View Font Attributes
1. Click the Style Manager Font control.

2. Click the Attributes button.

The Font Attribute dialog box appears. It provides name and location information on
the font size and font group you selected. This information varies according to the
alias family (system, user, user bold) and character set you choose from the combo
boxes at the top of the dialog box.

3. Click Close to dismiss the Font Attribute dialog box.

Backdrops

You can select a backdrop pattern to cover each of your workspaces (the screen area
underneath your windows). A unique backdrop for each workspace adds variety
and helps you to quickly identify the workspace you are in.
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� To Select a Backdrop
1. Switch to the workspace where you want the backdrop.

2. Click the Style Manager Backdrop control.

3. Select a backdrop.

4. Click Apply.

Customizing System Behavior
You can adjust the following settings for system devices:

� Keyboard click volume and character repeat

� Mouse button click settings, double-click speed, pointer acceleration, and pointer
movement threshold

� Beeper volume, tone, and duration

� Screen blanking when not in use

� Window focus, movement, and icon behavior

� To Change Keyboard Behavior

1. Click the Style Manager Keyboard control.

2. Select the settings you want:

� Auto Repeat: Sets characters to repeat when you hold down their keys
� Click Volume: Determines the volume of key clicks (turned off at 0%)

3. To save the changes, click OK. To return to the default settings, click Default.
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� To Change Mouse Behavior

1. Click the Style Manager Mouse control.

2. Select the settings you want:

� Handedness: Reverses mouse buttons 1 and 3.

� Button 2: Determines whether the middle mouse button is used to extend
selections (Adjust) or drag-and-drop objects (Transfer). If Adjust is selected,
transfer actions (drag) will require the use of mouse button 1.

� Double-Click: Determines the maximum time between clicks of a double-click.
(Test the speed by double-clicking in the mouse picture provided.) A new
double-click speed does not take effect until the next time you log in.

� Acceleration: Sets how fast the mouse pointer moves across the display.

� Threshold: The distance in pixels the pointer moves at a slow speed before moving
at the accelerated rate.

3. To save the changes, click OK. To return to the default settings, click Default.
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Note – You can also set the edge Move Threshold (the minimum proximity of the
mouse pointer to an object without the object becoming selectable) for the mouse. See
the dtwm man page.

� To Change Beep Settings

1. Click the Style Manager Beep control.

2. Select the settings you want:

� Volume: Determines the volume of the beep (turned off at 0%)
� Tone: Determines the pitch of the beep from 82 to 9000 Hertz
� Duration: Determines the length of the beep

3. To save the changes, click OK. To return to the default settings, click Default.

Screen without Lock Extensions

You can customize the screen blanker or Front Panel lock, or return the settings to
the default. If your system supports lock on timeout, see “Screen with Lock
Extensions” on page 248.

If you have a color display, bright colors on the screen can burn into the picture tube.
Setting the screen to go blank or be covered prevents this from happening.
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Power Management
If you select a blank background screen, and your hardware is capable of turning the
power off, it does so to save energy.

To disable power management when using Solaris CDE, change the Style Manager’s
screen saver default blank screen to a screen pattern. It can also be disabled by
running the following command in a terminal emulator window:

% xset s noblank

� To Change Screen Blanker Settings
1. Click the Style Manager Screen control.

2. Select the settings you want:

� Screen Blanker: Enables (On) or disables (Off) the screen blanker immediately, even
before you click OK. When Screen Blanker is On the Start Blanker slider is active.

� Start Blanker: Specifies the number of minutes from the last pointer movement or
keystroke before the screen is blanked. When this value is changed, the new value
goes into effect immediately, even before you click OK.

3. To save the changes, click OK. To return to the default settings, click Default.

� To Change Front Panel Lock Settings
1. Click the Style Manager Screen control.

2. Select the settings you want:

� Use Backgrounds For Lock: Enables the lock backgrounds.

� Transparent Lock: Backgrounds are not used when the screen is locked.

� Backgrounds List: Displays the available backgrounds in a multiple-select list.
Select or deselect a background by clicking on the list item. The last background
selected will be displayed to the right of the list.

� Time Per Background: Specifies the number of minutes each selected background
runs before the next one starts when the screen is being saved. The backgrounds
are cycled through in the same sequence as they appear in the list. A setting of 0
(zero) results in only the last background (the one currently in the preview area)
being used.

3. To save the changes, click OK. To return to the default settings, click Default.
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Screen with Lock Extensions
You can customize the screen saver or screen lock, or return the settings to the default.
If your system does not support lock on timeout, see “Screen without Lock
Extensions” on page 246.

If you have a color display, bright colors on the screen can burn into the picture tube.
Setting the screen to go blank or be covered prevents this from happening.

Power Management
If you select a blank background screen, and your hardware is capable of turning the
power off, it does so to save energy.

To disable power management when using Solaris CDE, change the Style Manager’s
screen saver default blank screen to a screen pattern. It can also be disabled by
running the following command in a terminal emulator window:

% xset s noblank

� To Change Screen Saver Settings
1. Click the Style Manager Screen control.

2. Select the settings you want:

� Screen Saver: Enables (On) or disables (Off) the screen saver immediately, even
before you click OK. When Screen Saver is On the Start Saver slider is active.

� Screen Saver List: Displays the available screen savers in a multiple-select list.
Select or deselect a screen saver by clicking on the list item. The last screen saver
selected will be displayed to the right of the list.

� Start Saver: Sets the number of minutes from the last pointer movement or
keystroke before the screen saver starts. When this value is changed, the new value
goes into effect immediately, even before you click OK.

� Time per Saver: Specifies the number of minutes each selected screen saver runs
before the next one starts.

3. To save the changes, click OK. To return to the default settings, click Default.

� To Change Screen Lock Settings
If the screen saver and screen lock are both enabled (On) and the Start Lock value is
smaller than the Start Saver value, when the screen lock times-out it replaces the
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contents of the screen with the currently selected screen savers. If Start Lock is greater
than Start Screen, then the automatic screen lock simply continues the current screen
saver.

If the screen saver is disabled (Off) and automatic screen lock is enabled (On), when
the screen lock times-out the contents of the screen are not covered with a screen saver.

1. Click the Style Manager Screen control.

2. Select the settings you want:

� Screen Lock: Enables (On) or disables (Off) Screen Lock on a timeout. When this
setting is changed, the new setting goes into effect immediately, even before the
dialog box is closed.

� Start Lock: Specifies the number of minutes from the last pointer move or
keystroke before the screen lock starts. When this value is changed, the new value
goes into effect immediately, even before you click OK.

3. To save the changes, click OK. To return to the default settings, click Default.

Windows

You can change the window focus policy, how active windows are displayed, and
where window icons are displayed.

� To Change Window Behavior
1. Click the Style Manager Window control.

2. Select the settings you want:

� Point In Window To Make Active: Makes a window active when the mouse pointer
enters it

� Click In Window To Make Active: Makes a window active when the mouse pointer
enters it and you click mouse button 1
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3. To save your changes, click OK.

4. Click OK when asked to Restart the Workspace Manager.

� To Change How Active Windows Are Displayed
1. Click the Style Manager Window control.

2. Select the settings you want:

� Raise Window When Made Active: Select this if you want a partially concealed
window to be brought to the top when it becomes active

� Allow Primary Windows On Top: Select this if you want the main window to be
displayed on top of secondary windows when you click the primary window

� Show Contents During Move: Select this if you want to move the whole window
during a window move instead of just moving the outline at first

3. To save your changes, click OK.

4. Click OK when asked to Restart the Workspace Manager.

� To Change Where Window Icons Are Displayed
1. Click the Style Manager Window control.

2. Select the settings you want:

� Use Icon Box: Displays your window icons in an icon box

� Place On Workspace: Displays your window icons on the workspace backdrop

3. To save your changes, click OK.

4. Click OK when asked to Restart the Workspace Manager.

Customizing Startup and Logout
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You can change the following options for startup and logout:

� Session started when you log in
� Session to be your home session
� Logout confirmation preference

Whenever you are logged into the desktop, you are working in a current session. By
default, when you log out, the desktop saves your current session and restores it the
next time you log in.

You can also save a home session, a session you want to be able to return to regardless
of what you do during the current session.

� To Change How Your Next Session Starts
1. Click the Style Manager Startup control.

2. Select the settings you want:

� Resume current session: Starts your next session the way you left your last one
including any setting, client, or resource modifications

� Return to Home session: Starts the session you set as your home session

� Ask me at Logout: Select this if you want to be asked at logout whether to restart
the current session or restore the home session

To define a new home session based on your current session, select Set Home Session.

3. To save your changes, click OK.

� To Set a Home Session
When setting a home session, be sure to first select and save your desired startup
settings.

1. Click the Style Manager Startup control.
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2. Click Set Home Session.

3. Click OK in the confirmation dialog box that appears.

4. Click OK in the Startup dialog box.

If you have never set a home session, the system default session is used when you
select Return to Home session.

� To Set Your Logout Confirmation Preference
1. Click the Style Manager Startup control.

2. Select On or Off for Logout Confirmation.

If you set Logout Confirmation to On, whenever you log out you will be asked for
confirmation that you want to log out.

3. Click OK.
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CHAPTER 10

Using Mailer

Mailer is an application for sending, receiving, and managing your electronic mail
(email) messages. It is fully integrated into the desktop, allowing you to drag and drop
messages and files between Mailer and other applications.

� “Starting Mailer” on page 253
� “Logging In to Your IMAP Inbox” on page 255
� “Using the Mailer Main Window” on page 255
� “Viewing Your Mail Messages” on page 256
� “Acting on Your Mail Messages” on page 258
� “Sending Mail Messages” on page 268
� “Editing and Formatting Outgoing Messages” on page 278
� “Creating and Using Mailboxes” on page 281
� “Printing Mail Messages” on page 285
� “Working with Attachments” on page 286
� “Customizing Mailer” on page 289
� “Using the File Selection Dialog Box” on page 292

The instructions in this chapter assume you are familiar with basic desktop skills and
keyboard navigation.

For more information, see Chapter 1 and Appendix A. Many of the tasks you do in
Mailer can be done using drag and drop.

Starting Mailer
� Click the Mailer control in the Front Panel.
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FIGURE 10–1 Mailer icon showing new mail

FIGURE 10–2 Mailer icon showing read mail

FIGURE 10–3 Mailer icon showing no mail

When you start Mailer for the first time on your system, it looks for a local or remote
Internet Messaging Access Protocol (IMAP) mailbox in your email setup.

� If the setup does not indicate the type of mailbox you have, Mailer prompts you to
specify the mailbox type.

� If the setup indicates that your mailbox is local, Mailer opens your Inbox (which
usually resides in the directory /var/mail/username).

� If the setup indicates that your mailbox is remote, Mailer opens the Mailer Login
dialog box so you can log in to the IMAP server.

After Mailer starts, the mailbox is displayed, along with message headers and a view
of the selected message.
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Logging In to Your IMAP Inbox
With the Login dialog box displayed, do the following:

1. Type the server name in the IMAP Server field.

The name that you type in this field becomes the default. Next time you log in, Mailer
displays it in the IMAP Server field.

To change this default, see “To Change the Default Mailbox Directory” on page 284.

2. Type your login name in the Login field.

3. Type your password in the Password field.

4. Determine when you want Mailer to load attachment contents when it loads
messages.

To have Mailer load both the message text and attachment contents when it retrieves a
message, select Always under Retrieve attachments.

To have Mailer load the message text but not the attachment contents when it retrieves
a message, select When Open under Retrieve attachments. Mailer will retrieve the
contents of the attachment when you double-click the attachment icon.

5. Click Login.

Your IMAP Inbox opens.

Using the Mailer Main Window
The Mailer main window is shown in Figure 10–4.
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FIGURE 10–4 Mailer main window

The main window contains the following areas:

Message Header List Displays information about mail messages

Toolbar Contains buttons for tasks that you perform frequently

Sash Resizes the Message Header List and message view area

Message view area Contains header fields and message text

Attachment list Displays icons of mail message attachments, if any

Viewing Your Mail Messages
Once you’ve started Mailer and begun to collect email messages, you’ll want to read
and perhaps sort them.
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� To Read a Mail Message
1. Choose Check for New Mail from the Mailbox menu to retrieve any new messages

that have been delivered to your mailbox.

2. Click to select the message to be viewed from the Message Header List.

The text of the message is displayed in the message view area.

Use the Next and Previous buttons on the Toolbar or options on the View menu to
continue to select and read messages in the message view area.

To open a message into a separate window for reading:

� Select the message and choose Open from the Message menu. From this window,
the Edit and Attachments menus become available.

The message remains in the separate window even when you select another message
in your Message Header List. You can then view two messages at the same time.

� To Change the Character Set of an Incoming
Message
On occasion, you may receive an email message from a machine that uses an encoding
that is different from the default encoding for your machine. To be able to read the
message, change the character set for your machine to one that matches the message’s
encoding (for example, US-ASCII).

1. Select the message in the Message Header List.

2. Choose Change Char Set from the View menu or press Control+Y, the keyboard
accelerator.

Mailer displays the name of a character set (for example, US-ASCII) in the footer
immediately below the Toolbar icons.

3. Choose the Change Char Set menu item or press Control+Y again to cycle through
the choices until the correct one is displayed.

Selecting Default Char Set displays your message in the default encoding for your
machine.

Mailer converts the text of the message to the character set that you selected, not its
header or attachments.
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Sorting Mail Messages
You can use the options on the View menu to order your messages.

By Date/Time Sorts messages with the most recent at the bottom

By Sender Sorts messages alphabetically by sender name

By Subject Sorts messages alphabetically by subject

By Size Sorts messages from the smallest to the largest

By Status Sorts messages together by read and new (useful if you read your mail
in non-sequential order)

The message headers are rearranged and redisplayed in the mailbox in the new order.

Acting on Your Mail Messages
After reading your email, you may want to reply to, search for, delete, and (possibly)
undelete some messages.

� To Reply to a Message
1. Select the message to which you want to reply.

2. Decide on the type of reply:

� To reply to the sender, choose Reply from the Compose menu.

A Compose window is displayed with the email address of the recipient and the
message subject filled in.

� To reply to the sender and all recipients, choose Reply to All from the Compose
menu.

A Compose window is displayed with the email addresses of the recipients and the
subject of the message filled in.

� To reply to the sender or all recipients and include a copy of the message, choose
Reply, Include Message or Reply to All, Include Message from the Compose menu.

A Compose window is displayed that includes the text of the message with the
email addresses of the recipients and the subject filled in. Attachments are not
included in the reply.
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3. Type your reply and click Send.

For more information, see “To Address, Compose, and Send a Mail Message”
on page 269.

� To Forward a Message
1. Select the message you want to forward.

2. Choose Forward from the Compose menu, or click the Forward button on the
Toolbar.

The text of the message to be forwarded is displayed within a new message, as well as
its attachments, if any.

If you do not want to forward the attachments, choose Forward, no Attachments.

3. Type the addresses of the message recipients in the To or Cc fields, or use the To or
Cc button menus to access any aliases that you have set up.

4. Add any additional text and click Send.

See “To Address, Compose, and Send a Mail Message” on page 269for more
information.

� To Edit an Incoming Message
1. Select the message you want to change.

2. Choose Forward from the Compose menu.

3. Address the message to yourself.

4. Edit the message in the Compose window and send it.

Note – You may want to create a separate mailbox for these edited messages as they
can add to the size of your Inbox.

� To Save an Incoming or an Outgoing Message as
Text

1. Select a received message, then choose Save As Text from the Message menu or, for
an outgoing message in a Compose window, choose Text from the Save As submenu
of the File menu.
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2. Type a file name and location in the File Selection dialog box that appears, then
click Save.

If a file of the name specified already exists, you are asked whether you want to
overwrite the file or cancel the operation.

� To Append a Message to A Text File
1. Select a received message, then choose Save As Text from the Message menu or, for

an outgoing message in a Compose window, choose Text from the Save As submenu
of the File menu.

Mailer displays a file selection dialog box.

2. Type the file name and location of an existing file, and click Append.

Mailer appends the text of the mail message to the file.

� To Delete a Mail Message
To remove a message from the Message Header List:

1. Select the message for deletion.

You can drag to select multiple messages. Shift+Click selects several messages in a row
by moving the highlight up or down the Message Header List. Control+Click selects
discontiguous messages from the list, one at a time.

2. Choose Delete from the Message menu, or click the Delete button in the Toolbar.

The messages are deleted from the list.

Note – Even if a message has been deleted, you can get it back unless you made your
deletions permanent by choosing Destroy Deleted Messages from the Mailbox menu.
See the following section.

� To Undelete a Mail Message
Do one of the following to undelete a mail message:

� To restore a message you just deleted, choose Undelete Last from the Message
menu.

� To restore an earlier message, choose Undelete from List from the Message menu,
then select one or more messages from the list of deleted messages, and click the
Undelete button.
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Note – To make the deletions in the list permanent, choose Destroy Deleted Messages
from the Mailbox menu.

� To Destroy Deleted Messages When Closing the
Mailbox
You can set your options so that when you close your mailbox, the messages you
deleted will be permanently destroyed. Doing so means that once you close your
mailbox, you cannot restore the messages that you deleted.

1. Choose Basic from the Options menu.

The Basic Options dialog box is displayed.

2. Select “When I close the mailbox” under Destroy Deleted Messages.

To remove the confirmation notice that appears each time you close the mailbox and
asks if you want to destroy deleted messages, deselect “Show confirmation notice.”

3. Click OK or Apply to make your changes take effect.

Searching for Mail Messages Within a Mailbox
You can search for mail messages within a mailbox according to the search criteria that
you define. Basic search criteria fields in the Basic window of the Search dialog box
include: the addressees (To), the sender (From), the subject (Subject), the carbon copy
recipients (Cc), and the message text, including the headers (Entire Message).

By creating a search script in the Advanced window of the Search dialog box with
keywords and arguments, you can define more sophisticated search criteria for finding
messages.

The tables that follow show the keywords you can use in search scripts, grouped
under the following categories:

� Headers – Keywords that denote the headers or the text part of the messages (Table
10–1)

� Dates – Keywords that indicate when the messages were sent (Table 10–2)

� States – Keywords that describe the status of the messages (Table 10–3)

� Operators – Keywords that join together other keywords to form a search criterion
(Table 10–4)
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Note – Those keywords you can type manually but are not available through the
menus in the Advanced window of the Search dialog box are marked with an asterisk
(*).

TABLE 10–1 Headers Search Keywords

Keyword Explanation

TO

FROM

SUBJECT

Cc

TEXT A keyword that pertains to the entire message, including headers and
attachments

BCC

HEADER* A keyword to use according to the syntax: header HeaderName
HeaderValue, such as header x-sun-charset us-ascii

BODY* A keyword that applies to the message text and the text attachments, but
not the headers

Table 10–2 lists and describes the Dates keywords.

Note – The date format is dd-mmm-yyyy (for example, 02-Apr-1996).

TABLE 10–2 Dates Search Keywords

Keyword Explanation

BEFORE

SINCE

ON

DURING

SENTSINCE*

SENTBEFORE*

SENTON*
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TABLE 10–2 Dates Search Keywords (Continued)
Keyword Explanation

TODAY An argument for the keywords that are associated with dates,
such as before

YESTERDAY Same as above

LASTWEEK Same as above

THISMONTH Same as above

LASTMONTH Same as above

JANUARY..DECEMBER

SUNDAY..SATURDAY

Table 10–3 lists and describes the States keywords.

TABLE 10–3 States Search Keywords

Keyword Explanation

READ

UNREAD

NEW*

OLD*

DELETED* A keyword for messages that you have deleted, but not permanently

UNDELETED*

RECENT*

FLAGGED*

ANSWERED*

UNANSWERED*

KEYWORD*

UNKEYWORD*

DRAFT*

UNDRAFT*

ALL* A keyword that denotes all the messages in the mailbox

LARGER/
SMALLER*

A keyword that requires two arguments, such as smaller 300, the
numeric denoting bytes
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Table 10–4 lists and describes the search operators.

TABLE 10–4 Search Operators

Operator Explanation

AND

OR

~ (not) A symbol that represents the logical not operator. Place it in front of the
search keyword, for example: ~ text "good morning"

( A symbol that denotes the beginning of an expression

) A symbol that denotes the end of an expression

Search scripts are not case sensitive.

Here are some examples:

To search for messages that were sent from john in April with either “urgent” or
“important” in the subject line:

from john and (subject urgent or subject important) and during april

To search for messages that were sent from bill with no carbon copy to tigerteam
and not yet read:

from bill and ~(cc tigerteam) and unread

To search for messages that were addressed to bill or sent with a carbon copy to
bill, with “monthly report” in the message, including the headers and attachments:

(to bill or cc bill) and text “monthly report”

� To Find a Mail Message Within a Mailbox
1. Choose Search from the Message menu.

The Search dialog box is displayed.
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FIGURE 10–5 Mailer Search dialog box

2. Type the text you want to search for in the appropriate field.

You can search for a match on one or more of the To, From, Subject, or Cc fields. If you
type the criteria in multiple fields, Mailer searches for messages that match all of the
criteria.

Within each field, Mailer considers the input as one criterion even if there are multiple
strings separated by spaces or commas. For example, if you type wood smith in the
To field, Mailer looks for a message that is addressed to wood smith, not wood or
smith.

The fields are not case-sensitive.

3. Click Search Down or Search Up to find the next or previous matching message in
your mailbox. To find all the matches, click Select All.

Note – To remove all the text in the fields in the Search dialog box, click Clear.

� To Create Advanced Search Scripts
1. Choose Advanced from the Search Type menu.

The Advanced Search dialog box is displayed.
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2. Type your script in the text area.

Choose keywords from the menus to help you create the script.

The keywords are not case sensitive.

Using Views
Occasionally, you may want to display only the messages in your mailbox that match
one or more search criteria, such as messages to or from a certain individual. You can
do so by defining the criteria and saving them as a view.

� To Create a View
1. Choose Search from the Message menu.

The Mailer Search dialog box is displayed.

2. Specify your search criteria.

3. Click Save As View.

The Mailer Save As View dialog box is displayed.

4. Type a name in the Enter View Name field.

You cannot use All or New as a view name; they are listed under Default Views. You
may want to use a name that reflects the search criteria.

5. Click OK.

Mailer creates a new view and places it in the Custom Views list in the Views dialog
box. To see the list, click Show Views in the Search dialog box or choose Show Views
from the Mailbox menu.
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� To Display, Delete, or Update Views
1. Choose Show Views from the Mailbox menu.

If the Search dialog box is open, you can also click Show Views in that dialog box.

The Views dialog box is displayed.

Listed are:

� Default Views: Message statistics for the entire mailbox (All) and messages that
you have not yet read (New)

� Custom Views: Message statistics for the views that you have created. Mailer
displays the name of the view being loaded in the title bar of the main window.

2. To display a view, double-click the view in the list, or select it and click Load.

The messages that match the search criteria for that view are displayed in the mailbox.

3. (Optional) To update views, click Update.

Mailer revises the message statistics for all of the views for the mailbox.

4. (Optional) To delete a view, select it and click Delete.

5. Click Close to close the dialog box.

� To Edit a View
1. Select a view in the Custom Views list.
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2. Click Edit.

The Search dialog box is displayed with the fields filled in with the search criteria for
that view.

3. Edit the fields.

If Mailer cannot display the search criteria in the Basic window, then it loads the
search script in a text area in the Advanced window for you to edit.

4. Click Save as View.

Mailer displays the view name in the Enter View Name field.

5. Click OK to save the view with the same name.

Alternately, type a new name for the view and click OK to save it.

� To Rearrange the Order of the List Under Custom Views
� Select a view under Custom Views. Click the up or down arrow button to move the

view up or down the list.

Sending Mail Messages
An email address is like your personal address for receiving electronic mail messages.
This is also the way you send messages to other email users. The format used for
email addresses is username@hostname. Your system administrator uses this format to
set up email addresses.

This section gives you most of the information you need to address, compose, and
send a message to another user.

Using Aliases
An alias is a private name for one or more user names (or user addresses). By creating
a distribution list of user addresses to which you frequently send mail and giving the
list a name, you can select the alias in the To or Cc fields instead of typing each
address every time you send a message (see Figure 18–1).

The name you give to your alias can be descriptive of a group of users, or just a name
you will remember. These aliases are also displayed as Personal Alias cards in Address
Manager (see “Alias Cards” on page 482).
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� To Create, Modify, or Delete an Alias
1. Choose Aliases from the Options menu in the main window, from the Format menu

in a Compose window, or from the To or Cc button menu in the Compose window.

The Aliases Options dialog box is displayed.

2. Type the name for your alias in the Alias field.

3. Type the user addresses that will make up the alias in the Addresses field.

Each of these addresses should be in the form username@hostname and be separated by
a comma, a space, or both.

4. Click Add to add the information in the Alias and Addresses fields to the scrolling
list.

5. (Optional) To change an alias, select it and edit the Alias or Addresses field, as
appropriate, then click Change.

6. (Optional) To remove an alias, select it and click Delete.

7. Click OK or Apply to make the settings take effect.

Note – You can also work with aliases using Address Manager (see “To Create a
Personal Alias Card” on page 492).

� To Address, Compose, and Send a Mail Message
Once you have the receiving party’s email address, you can send a message.

Note – If this is the first time you are using email and if you know your own email
address, you can use these procedures to send a test message to yourself.

1. If Mailer is not already started, click the Mailer control in the Front Panel.

The Inbox is displayed.

2. Choose New Message from the Compose menu.

The (New Message) Compose window is displayed.
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Header fields

Text area

FIGURE 10–6 Mailer Compose window

3. Type the email address of the recipient in the To field and press Return.

You can address a message to one or more people, or to an alias.

If one or more of the email addresses contains a space, then separate the email
addresses with commas; otherwise, separate them with commas or spaces.

Alternatively, if you have created aliases, use the To button menu to access them.

For information on aliases, see “Using Aliases” on page 268.

4. (Optional) Type the topic or title of the message in the Subject field and press
Return.

5. (Optional) Type the email addresses of users you want to be carbon copy recipients
of this message in the Cc field, or, if you have created aliases, use the Cc button
menu to access any aliases that you have set up.

6. Once your message is addressed, press Return to go to the text area and compose
the message.

To insert a text file, see “To Include a Text File in a Mail Message” on page 275. Also
see “Using a Template to Compose a Mail Message” on page 272and “Using a Draft to
Compose a Mail Message” on page 273.

To find out about editing text in your message, see “Editing Text” on page 278or
“Formatting Text” on page 279.
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You can save the message you are composing at any time by choosing Text from the
Save As submenu of the File menu or from the Save As button menu at the bottom of
a Compose window.

7. (Optional) Choose Include Signature from the Compose Format menu to place your
signature in the text area if you have deselected “Include signature in every
message” in the Signature Options dialog box.

See “Using a Signature” on page 275for details.

8. (Optional) To format the text to the width of your Compose window, select the text
and choose Word Wrap from the Compose Format menu.

9. (Optional) Add files to the message as attachments, if necessary.

To find out how to do so, see “To Add an Attachment” on page 287.

10. (Optional) Choose Save Outgoing Mail from the Compose File menu to save a copy
of the message to the file that stores your outgoing messages
(HomeDirectory/Mail/sent.mail by default).

To change the default file name, choose Basic from the Options menu and edit the
“Save a copy of outgoing mail in” field.

11. Click the Send button, choose Send from the Compose File menu, or press F3.

The Compose window closes, and the message is sent.

Note – Clicking Close removes the Compose window and discards your message. Be
sure to save any text you might want later before closing a Compose window.

To Change the Character Set of an Outgoing
Message
If you need to send an email message to a machine that uses a different encoding from
the one for your machine, you can convert its text to your recipient’s encoding.

1. After typing your message in the Compose window, choose Change Char Set from
the Format menu or press Control+Y, the keyboard accelerator.

Mailer displays the name of a character set (for example, ISO-2022-JP) in the footer of
the Compose window.

2. Choose the Change Char Set menu item or press Control+Y again to cycle through
the choices until the correct one is displayed.

Selecting Default Char Set means that your message is sent in the default encoding for
your machine.

The display of the message in your Compose window does not change; however,
Mailer delivers it in the selected character set when you click Send.
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Note – Mailer converts only the text of the outgoing message, not its header or
attachments.

Using a Template to Compose a Mail Message
You can save a message as a template for use repeatedly, such as a template for a
status report that you send out monthly. The status report template might contain, for
example, the addresses, subject, and headings for the message body. You could use
that template and fill in the contents before emailing it as a status report every month.

� To Create a Template
1. Choose Templates from the Options menu of the Mail Options dialog box.

The Templates Options dialog box is displayed.

2. Click the New Template button.

A Compose window is displayed.

3. Type the headers and template body.

4. Choose Template from the Save As button menu at the bottom of the window, or
from the Save As submenu of the File menu.

The Mailer Save As Template dialog box is displayed.

5. Type the template name in the text field, and click Save.

The template is saved in the default directory HomeDirectory/MailTemplates. Its
name and path are displayed in the Templates scrolling list.

You can save an attachment as part of a template. Doing so is equivalent to copying
the attachment there. Editing or moving the source of the attachment after it has been
included in the template does not affect the attachment in the template.

� To Use a Template
1. From the main window, choose New, Use Template from the Compose menu, then

choose the template you would like to use from the submenu.

The Compose window opens with the template loaded.
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Note – If the Compose window is already open, you can load the template by
choosing its name from the Use Template submenu of the Format menu in the
Compose window.

2. Edit the headers and body, as necessary, and send the message as usual.

For more details, See “Editing and Formatting Outgoing Messages” on page 278.

Using a Draft to Compose a Mail Message
Occasionally, while composing a message, you may want to save it as a draft, then
continue to work on it later before sending it as a message. A draft is intended for
one-time use only. Once you click Send after working on a draft in the Compose
window, Mailer deletes it from your file system.

� To Create a Draft
1. Choose New Message from the Compose menu.

A Compose window is displayed.

2. Compose the message as you normally would.

3. Choose Draft Message from the Save As button at the bottom of the window, or
from the Save As submenu of the File menu.

The Mailer Save As Draft dialog box is displayed.

4. Type a file name under Draft Name.

5. Click Save.

Mailer saves the draft in the default mailbox HomeDirectory/MailDrafts.

Note – You can also save the message body only as text by choosing Text from the
Save As button.

� To Use a Draft
1. Choose Continue Composing Draft from the Compose menu, then choose the draft

you would like to work on from the submenu.

The Compose window opens with the draft loaded.
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Note – If the Compose window is already open, you can load the draft by choosing its
name from the Use Draft submenu of the Format menu.

2. Continue with your edits and send the message as usual.

After you have clicked Send, Mailer posts a message that asks if you want to delete
that draft from the file system once the message is sent.

� To Delete a Draft
Use this procedure if you have saved a message as a draft, but no longer intend to
send it.

1. Choose the draft from the Continue Composing Draft on the Compose menu.

The New Message dialog box is displayed containing the draft message.

2. Re-address the message to yourself and click Send.

The New Message dialog box disappears.

3. When the message arrives in your Inbox, delete it.

Note – If your workstation has experienced system crashes while Mailer was running,
you may also notice drafts named DeadLetter1, DeadLetter2, and the like. You
can delete these drafts by deleting the corresponding files in the
$HOME/MailDrafts folder.

� To Include Multiple Messages in a New Message
1. From the Message Header List, select the email messages to be included in your

new message.

Shift+Click selects several messages in a row by moving the highlight up or down the
Message Header List. Control+Click selects discontiguous messages from the list, one
at a time.

2. Choose Forward from the Compose menu.

3. Compose and send your message as usual.
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� To Include a Text File in a Mail Message
You can drag and drop a text file from File Manager to a Compose window or follow
these steps:

1. Choose New Message from the Compose menu.

A Compose window is displayed.

2. Choose Include from the File menu in the Compose window.

3. Select the text file to be included in your email message.

4. Click Include.

The file is included in the text area of your message.

5. Compose and send your message as usual.

Using a Signature
A signature is text you can include with each mail message that you send. For
example, a typical signature might include your name, job title, company name, and
so on:

John Person
Marketing Manager
ABC Products, Inc.
Email: john.person@mymachine

Phone: (100) 555-1234

You can either include this signature with each email message, or choose to include it
on an individual message basis.

� To Create a Signature
1. Choose Signature from the Options menu in the main window or the Format menu

in a Compose window.

The Signature Options dialog box is displayed.

2. Type the text for the signature in the Signature text pane.

3. Click OK or Apply.

Your signature is saved in the default file HomeDirectory/.signature. You can
change this default location by typing a new path in the Save signature to Path/File
field.
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� To Include a Signature in All Messages
1. Choose Signature from the Options menu in the main window or the Format menu

in a Compose window.

The Signature Options dialog box is displayed.

2. Select the “Include signature in every message” option.

3. Click OK or Apply.

� To Include a Signature Only in Specific Messages
1. Choose Signature from the Options menu in the main window or the Format menu

in a Compose window.

The Signature Options dialog box is displayed.

2. Deselect the “Include signature in every message” option.

3. Click OK or Apply.

4. In the Compose window for the message in which you want to include your
signature, choose Include Signature from the Format menu.

� To Create an Automatic Reply (Vacation Message)
If you plan to be away from your mail for a period of time, such as during a vacation,
you can set up an automatic reply to alert the senders of your incoming mail about
your absence.

1. Choose Vacation Message from the Options menu.

The Vacation Message Options dialog box is displayed.

2. Select On next to Vacation.

3. Type the date you want the vacation reply to start under Start Date.

The default is today’s date.

4. Type the End Date.

Your vacation message takes effect at 12:01 a.m. or later of the Start Date, and ends at
12:01 a.m. of the End Date. If the start and end dates are the same, then the vacation
notifier ends at midnight of the End Date.
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5. (Optional) Under “Interval between replies to repeat senders,” set a number for the
interval during which the sender will receive one automatic reply from you.

The default is seven days. which means the senders of your incoming mail will receive
only one automatic reply from you within seven days of your absence, regardless of
how many messages they send you during that period.

6. Type a subject and the text for your vacation message.

The default for this field is “Out of the office.” If you use the variable $SUBJECT in
your message, the subject of the incoming mail will be quoted in your vacation
message. For example:

I am on vacation, and will read your message regarding “$SUBJECT” when I return.

7. Click OK or Apply.

Once your vacation message is on, Mailer adds [Vacation] to the mailbox name on
the title bars of your Inbox and other mailboxes until your vacation message is off.

Note – To stop sending your vacation message before the End Date, select Off next to
Vacation, then click OK or Apply.

Sending Mail Messages in MIME or Sun Mail Tool
Format
Mailer sends messages in MIME format (a published standard officially known as RFC
1521 or RFC-MIME). If your email recipients see confusing codes like =20 or =09 in
the messages that you send, their mail applications are not MIME-compliant.

You can solve this problem by having your email recipients use a MIME-compliant
mail application. If that is not possible, then send your email in Sun Mail Tool format.
However, most MIME-compliant mail readers do not understand this proprietary
format.

� To Send Mail Messages in MIME or Sun Mail Tool Format
1. Choose Send As from the Compose File menu.

2. Choose either Internet MIME or Sun Mail Tool from the submenu.

Your message is sent in the selected format.

If you do not specify a format, the default is Internet MIME. To change this default:

1. Choose Advanced from the Options menu.

The Advanced Options dialog box is displayed.

Using Mailer 277



2. Deselect the option, “Send mail in MIME format.”

3. Click OK.

Editing and Formatting Outgoing
Messages
While composing an outgoing message, you can use Mailer to edit and format your
text, as well as check the spelling.

Editing Text
You can use the Edit menu options in a Compose window to change the message text
you are composing.

TABLE 10–5 Mailer Compose Window Editing Options

Undo Reverses the last editing action in the text area.

Cut Removes the selected text and stores it on the clipboard. Only one
selection can be stored at a time. If text is already there, the most current
selection overwrites it.

Copy Stores a copy of the selected text on the clipboard. Only one selection
can be stored at a time. If text is already there, the most current selection
overwrites it.

Paste Inserts the contents of the clipboard at the insertion point.

Paste Special
(Bracketed or
Indented)

Inserts the contents of the clipboard at the insertion point surrounded
above and below by Begin and End Included Message text, or by
indented markers.

Clear Removes the selection and leaves the resulting white space.

Delete Removes the selection and the resulting white space.

Select All Selects all the text in the text area.

Find/Change Opens a dialog box for you to search for words or phrases in your
message and make changes to occurrences that are found.
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TABLE 10–5 Mailer Compose Window Editing Options (Continued)
Check Spelling Runs the spelling checker on your mail message and displays a dialog

box that lists words that might be spelled incorrectly. You can Find,
Change, or Change All instances of a word.

For more information on editing functions, see Chapter 12.

Formatting Text
You can use two of the Format menu options in the Compose window to make
formatting changes to the message you are composing.

Word Wrap Toggles the text entry mode that causes lines to automatically wrap at
the edge of the message. Note that if you have Word Wrap on and the
recipient’s window is of a different size, you may cause display
problems.

Settings Displays a dialog box for setting margins and paragraph alignment, and
applying format settings to your message.

For more information on editing functions, see Chapter 12.
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� To Find or Change Text
1. Choose Find/Change from the Compose Edit menu.

The Find/Change dialog box is displayed.

FIGURE 10–7 Mailer Find/Change dialog box

2. Type (or copy and paste) the text you want to locate in the Find field.

3. (Optional) To automatically change the located text to replacement text, type the
replacement text in the Change To field.

4. Select the appropriate option:

� Click Find to find and select the text.
� Click Change to change the first instance.
� Click Change All to change all instances.

5. Click Close to dismiss the dialog box.

� To Check Spelling
You can use the spelling checker in Mailer to verify and correct the spelling in the
message you are composing.

1. Choose Check Spelling from the Edit menu in the Compose window.

The Spell dialog box is displayed, showing the first instance of a potentially
misspelled word under Word. Suggestions for the correct spelling are displayed in a
scrolling list. For details, see “Correcting Misspelled Words” on page 328in Chapter 12.
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Note – The spelling checker is case sensitive.

2. Click Close to exit the Spell dialog box.

Creating and Using Mailboxes
You may want to file certain mail messages for safekeeping. All your messages are
received by default in the mailbox (Inbox). Since keeping all your mail messages in
your Inbox probably is not practical, you may want to set up other mailboxes to store
groups of messages together.

Mailboxes help you organize your mail. You can create mailboxes by project, by user,
by email list, or any other system that works for you. You should place these
mailboxes in the default mailbox directory HomeDirectory/Mail.

To find out how to change the default mailbox directory, see “To Change the Default
Mailbox Directory” on page 284.

� To Create a Mailbox
1. Choose New Mailbox from the Mailbox menu.

The File Selection dialog box is displayed.

2. Specify the mailbox name and location.

See “Using the File Selection Dialog Box” on page 292 for details.

3. Click New.

The new mailbox is created in HomeDirectory/Mail, the default mailbox directory, and
opened.

To find out how to change this directory, see “To Change the Default Mailbox
Directory” on page 284.

� To Rename a Mailbox
1. Choose Rename Mailbox from the Mailbox menu.

The File Selection dialog box is displayed.
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2. Select or type the name and location of the mailbox you want to rename, then click
Rename.

The Rename Mailbox dialog box is displayed.

3. Type the mailbox name in the New mailbox name field.

4. Click Rename.

� To Open a Mailbox
1. Choose Open Mailbox from the Mailbox menu.

2. Choose one of the following items in the submenu:

� Inbox – The mailbox where you receive email by default

� Sent Mail – The file that contains your outgoing messages
(HomeDirectory/Mail/sent.mail by default). This item is active only if you have
saved outgoing messages in this file.

� Select Mailbox – A mailbox that you specify from the File Selection dialog box

� Other Mailboxes – One of the mailboxes in the default mailbox directory

� The mailboxes that you opened, or moved or copied messages to previously in this
Mailer session

� To Close a Mailbox
To close a mailbox:

� Choose Close from the Mailbox menu or Window menu, or press Alt+F4.

When the last open mailbox is closed, Mailer exits.

Filing Messages in Other Mailboxes
You can file some incoming messages by manually moving or copying them into
specific mailboxes.

� To Manually File Messages in Other Mailboxes
� Select the messages that you want to file and do one of the following:
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� Choose Select Mailbox from the Move menu (or the Copy To submenu of the
Message menu) and select the desired mailbox in the File Selection dialog box.

� Choose Other Mailboxes from the Move menu (or the Copy To submenu of the
Message menu) and indicate the desired mailbox.

� Drag and drop messages to other mailboxes.

See “To Drag and Drop Messages to Other Mailboxes” on page 283for more
information.

For convenience, you can:

� Add mailboxes where you frequently file messages to your Move menu (and the
Copy To submenu of the Message menu).

For information on adding mailboxes to your Move menu, refer to “Customizing
the Open, Move, and Copy To Menus” on page 284.

� Set your Move menu to display the most recently visited mailboxes.

For details, refer to “To Change the Number of Mailboxes Displayed in the Move
Menu and Copy To Mailbox Submenu” on page 285.

� To Drag and Drop Messages to Other Mailboxes
1. Make sure Mailer is open on the desktop and its Message Header List is visible.

2. Open the mailbox to which you want to move the message and make sure you can
see the Message Header List.

3. Select the message to be moved.

4. Drag the message and drop it onto the appropriate mailbox Message Header List.

The message is moved to the end of the target mailbox.

You can also drag and drop a message to the file icon of the target mailbox in File
Manager. With this method, Mailer places a copy of the message in the target mailbox
instead of moving it.

� To Delete a Mailbox
1. Choose Delete Mailbox from the Mailbox menu.

The File Selection dialog box is displayed.

2. Select or type the mailbox name and location of the mailbox you want to delete,
then click Delete.

The mailbox is deleted.
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� To Change the Default Mailbox Directory
1. Choose Move Menu Setup from the Options menu.

The Move Menu Setup Options dialog box is displayed.

2. Type the directory name in the Default Mailbox Folder field.

3. (Optional) Type the IMAP server name in the IMAP Filing Server field.

You can also specify the default mailbox folder for your IMAP server by editing the
Default IMAP Folder field; the default is HomeDirectory/Mail.

4. Click OK or Apply.

Customizing the Open, Move, and Copy To Menus
Once you have set up a number of mailboxes, you may discover that there are several
mailboxes you use frequently. You can customize your Move menu, the Open Mailbox
submenu of the Mailbox menu, and the Copy To Mailbox submenu of the Message
menu to show these key mailboxes. Opening and filing to mailboxes is much more
efficient this way.

Adding the names of the mailboxes that you recently opened to the Move Menu and
Copy To Mailbox submenu of the Message menu can save you time when you next
move or copy messages to these mailboxes.

� To Add Mailboxes to the Open, Move, and Copy To
Menus

1. Choose Move Menu Setup from the Options menu.

The Move Menu Setup Options dialog box is displayed.

2. Select Local or IMAP Server to specify the server where the mailboxes are located.

If you select IMAP Server, type the server name in the text field.

3. Type the path to the mailbox under Path/Mailbox Name, then click Add.

The mailbox is added to the Move menu, as well as the Open Mailbox submenu of the
Mailbox menu and the Copy To Mailbox submenu of the Message menu.

4. (Optional) Make further customizations:

� To alter what is in the Path/Mailbox Name field once a mailbox name is selected,
edit that field and click Change.

� To delete a mailbox name from the scrolling list, select it and click Delete.

284 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



� To display the mailboxes in alphabetical order, click Alphabetize.

� To change the position of a selected mailbox in the scrolling list, click Move Up or
Move Down.

5. Click OK or Apply.

� To Change the Number of Mailboxes Displayed in the
Move Menu and Copy To Mailbox Submenu
To change the number of mailboxes that are displayed on these menus:

1. Choose Move Menu Setup from the Options menu.

The Move Menu Setup Options dialog box is displayed.

2. Increase or decrease the number of mailboxes you have recently opened in the
“Display up to: Recently visited mailboxes” field.

3. Click OK or Apply to make the change take effect.

Up to the desired number of mailboxes now appear on the Move menu and the Copy
To Mailbox submenu of the Message menu.

Printing Mail Messages
You can print messages with the default options, or set different print options before
starting the print job.

� To Print a Copy of a Message with Default Options
1. Select the message to be printed in the Message Header List.

Shift+Click selects several messages in a row by moving the highlight up or down the
Message Header List. Control+Click selects discontiguous messages from the list, one
at a time.

2. Choose Print One from the Message menu.
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� To Print a Message with Specific Options
1. Select the message to be printed.

Shift+Click selects several messages in a row by moving the highlight up or down the
Message Header List. Control+Click selects discontiguous messages from the list, one
at a time.

2. Choose Print from the Message menu.

3. Set the options you want to change:

� Type a new printer name in the Printer field.
� Indicate the number of copies in the Copies field.
� Type a banner page title in the Banner Page Title field.
� Select Print Page Numbers to print page numbers in your document.
� Type print command options in the Print Command Options field.

4. Click Print.

� To Print a Message Using Drag and Drop
1. Select the message to be printed.

2. Drag the message onto the Printer control in the Front Panel.

The Print dialog box is displayed.

3. Set the print options as desired and click Print.

For more information, see “To Print a Message with Specific Options” on page 286.

Note – For information on how to change the print action, see the section
“Configuring and Administering Printing from the Desktop” in Common Desktop
Environment: Help System Author’s and Programmer’s Guide

Working with Attachments
An attachment is an image, document, or executable file that you send or receive with
your email.
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� To View an Attachment
1. Select the attachment icon in the attachment list.

FIGURE 10–8 Example of an attachment icon

2. Choose Open from the Attachments submenu in the Message menu, or double-click
the attachment icon.

Note – If Open does not appear on the Attachments submenu, you cannot open the
attachment.

� To Print an Attachment
1. Select the attachment.

2. Choose Print from the Attachments submenu in the Message menu.

Note – If your system does not provide the ability to print attachments, or if the
attachment cannot be printed, the Print item will not be available.

� To Add an Attachment
1. Compose your email message.

2. Choose Add File from the Attachments menu in the Compose window.

The Mailer - Attachments - Add dialog box is displayed. See “Using the File Selection
Dialog Box” on page 292for more information.

3. (Optional) Click the Keep dialog box open on desktop check box.

This indicates that you do not want the dialog box to close after the Add button is
clicked. This eliminates the need to choose Add File from the Attachments menu to
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add more than one attachment.

4. Select a file to attach and click Add.

The attachment is added to the attachment list in the lower portion of the Compose
window.

To remove an attachment you just added, select its icon and choose Delete from the
Attachments menu.

To restore a deleted attachment, choose Undelete from the Attachments menu.

5. (Optional) Choose Rename from the Attachments menu to change the name of a
selected attachment.

If you drag and drop messages from the Message Header List in the main window to
the attachment list, Mailer creates one mailbox that contains all of the messages.

� To Save an Attachment to Your File System
1. Select the attachment you want to save.

2. Choose Save As from the Attachments menu.

3. In the File Selection dialog box, indicate where you want to save the attachment.

4. Type a new name, if desired, for the file.

5. Click Save.

The file is saved to the selected location.

Note – You can also drag and drop an attachment to File Manager. See Chapter 5for
more information.

� To Attach a File from File Manager
1. Select the file within File Manager.

2. (Optional) If the attachment list is not displayed, choose Show List from the
Attachments menu in a Compose window.

3. Drag the file from File Manager and drop it onto the attachment list in a Compose
window.
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4. Send the message as usual.

Note – You can also drag an attachment from the attachment list to File Manager. See
Chapter 5.

� To Attach a Calendar Appointment
1. Create the calendar appointment in Calendar.

2. Drag the appointment from the Calendar Appointment Editor dialog box and drop
it onto the attachment list in the Compose window.

3. Send the message as usual.

Note – You can also drag a calendar appointment attachment from the attachment list
to Calendar. See “To Drag an Appointment From Mailer to Calendar” on page 364in
Chapter 13.

Customizing Mailer
Once you have used Mailer for some time, you may want to change some of its
defaults. The Options menu provides you with these choices:

� Basic
� Aliases
� Compose Window
� Message View
� Move Menu Setup
� Notification
� Signature
� Templates
� Toolbar
� Vacation Message
� Advanced

The following sections describe some of the customizations you can do using the
options in these dialog boxes.
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� To Display Message Numbers in Your Mailbox
1. Choose Basic from the Options menu.

The Basic Options dialog box is displayed.

2. Select the Display message numbers option.

3. Click OK or Apply to make your changes take effect.

The numbering appears on the left side of your Message Header List.

� To Change the Character Marker for Included Text
in a Reply
Having a marker for text you include when you reply to a message sets it off from the
text you want to add. Mailer provides a right-angle bracket (>) as the default. You can
customize this marker to a character of your choice.

1. Choose Compose Window from the Options menu.

The Compose Window Options dialog box is displayed.

2. Type the character you want to use under Indent Characters For Included Message.

3. Click OK or Apply to make your changes take effect.

� To Set How Often Mailer Checks for Messages
1. Choose Basic from the Options menu.

The Basic Options dialog box is displayed.

2. Increase or decrease the setting in the “Check for new mail every” field.

3. Click OK or Apply to make your changes take effect.

� To Add Custom Fields to the Format Menu
Besides the To, Subject, Cc, and Bcc fields in the Format menu of a Compose window,
you may want to add your own fields, such as Reply-To, Return-Receipt-To, and so on.

1. Choose Compose Window from the Options menu.

The Compose Window Options dialog box is displayed.
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2. Type a name in the Header Name field as it will appear in the Compose window
header (for example, Return-Receipt-To).

3. (Optional) Type a default entry for the defined header field in the Default Value
field (for example, your email address).

4. Click Add to add the values to the scrolling list.

To change a custom field, select it and edit the Header Name or Default Value field, as
appropriate, then click Change.

To remove a custom field, select it and click Delete.

5. Click OK or Apply to make your changes take effect.

� To Customize Mail Notification
To determine how Mailer signals the arrival of new mail:

1. Choose Notification from the Options menu.

2. Under “Signal new mail with,” specify whether you want Mailer to beep, the
Header window to flash, or Mailer to play an audio file when new mail arrives. You
can choose to have all three signals if you desire.

Set the number of beeps and flashes by clicking on the up or down arrow under Beeps
and Flashes.

To play an audio file, either type the full path name of the file in the Sound File text
field, or click Select to specify that file in a File Selection dialog box.

Configuring the Appearance of the Toolbar
From the settings in the Toolbar Options dialog box, you can change the appearance of
the Toolbar buttons (as icons or with text), determine which buttons display, and set
the order in which they are displayed.
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By default, the following commands appear as icons: Delete; Next; Previous; Reply,
Include Message; Forward; New Message; Print One; Open Mailbox; and Reply.

� To Customize the Toolbar
1. Choose Toolbar from the Options menu.

The Toolbar Options dialog box is displayed. Under Commands is a list of the
commands you can choose to be displayed in the Toolbar, either as icons or with text.
Those commands you have chosen to be displayed in the Toolbar are shown in the
Toolbar scrolling list.

2. Select Icons or Text as your preference for the display.

3. (Optional) Click Add or Remove to add or remove a selected command from the
Toolbar.

4. (Optional) Click Move Up or Move down to change the order in which the buttons
are displayed.

5. Click OK or Apply to make your changes take effect.

Using the File Selection Dialog Box
When you perform certain functions (like opening a mailbox or saving a message),
there is a standard method to access your file system. From a File Selection dialog box,
you are presented with a place to enter a path or folder name or a place to select from
the folders and files in your file system.
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FIGURE 10–9 File Selection dialog box

The title bar and the buttons of the dialog box vary, depending on the operation you
wish to perform.

The fields are:

� Local or IMAP Server – Specifies the mail server type. If you select IMAP Server,
type its name in the text field.

� Keep dialog box open on desktop – Indicates that you do not want the New
Mailbox dialog box to disappear after you click New Mailbox (same affect as Apply
button on most dialog boxes).

� Enter path or folder name – Indicates the path to the item. It can be a location
anywhere in your file system. If folders or file names are selected, the path appears
here.

� Filter – Shows the filter criteria; an asterisk (*) shows all files. You can enter
wildcard characters to display only those files that match a suffix. For example,
*.doc lists only those files with a .doc suffix.

� Folders – Lists the folders in the current directory.

� Files – Lists the files within the current folder.

� Enter file name – Shows the name of the mailbox. You can either type in the name
or select it from the list.

You can:
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� Click Open Mailbox (or whatever action is specified in the leftmost button) to
perform the operation and dismiss the dialog box.

� Click Update to display a new list of files after changing the filter key or changing
to a new folder.

� Click Cancel to halt the operation without applying the changes and dismiss the
dialog box.

� Click Help to display information about this dialog box.

294 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



CHAPTER 11

Printing

You can easily print files, find or cancel print jobs, and get information about printers
and print jobs through the desktop.

� “Your Default Printer” on page 295
� “Printing Files” on page 296
� “Printer Applications” on page 300

Your Default Printer
Your system may have more than one printer that you can use for printing. One of the
printers will be designated as the default printer. The default printer is the printer that
your desktop automatically uses if you submit a document for printing and you don’t
specify a printer name. When you first open your desktop, the default printer is
shown in the Front Panel.

To find out how to display a printer other than your default printer in the Front Panel,
see “To Change the Front Panel Printer” on page 306.

� To Determine the Default Printer
� To find out the name of your default printer, double-click the Default printer

control in the Personal Printers subpanel in the Front Panel.

This starts the Printer Jobs application. The name under the printer icon is the name of
your default printer.
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� To Change the Default Printer
To designate a different printer as the default printer:

1. Go to your home folder and open the file .dtprofile.

2. Add or edit a line that sets a value for the LPDEST environment variable:

LPDEST=printer_device; export LPDEST

If you are using csh the syntax is:

setenv LPDEST printer_device

Note – This change will take effect the next time you log out and back in again.

For example, the following line would change the default printer to the printer whose
device name is laser3d.

LPDEST=laser3d; export LPDEST

If you are using csh the syntax is:

setenv LPDEST laser3d

Printing Files
The desktop can print different types of files, as listed in Table 11–1.

TABLE 11–1 Types of Data That Can Be Printed (Initial Configuration)

Type of Data Data Type Requirement Description

Text file File name ends with.txt Text files containing ordinary (ASCII)
text data

PostScript File name ends with .ps, or
content is recognized as
PostScript data

PostScript files

(requires a PostScript printer)

PCL File name ends with.pcl,or
content is recognized as
PCL data

Printer Control Language files

(requires a PCL printer)

Data Contains text data The default data type assigned to all files
containing ASCII data that do not match
other data types
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If applications are installed on your system that create other types of files, your system
administrator can add printing capabilities for them.

Note – Ensure that your destination printer is capable of printing PostScript™ or PCL
files before you try to print them.

Submitting a File to a Printer
There are many ways to submit a file to a printer:

� Using the Front Panel
� Using File Manager
� Using Print Manager
� Using applications

� To Print Using the Front Panel
1. Drag a single file or multiple files from File Manager to the Printer control in the

Front Panel or to a Printer icon in the Personal Printers subpanel.

The system then displays a Print dialog box for specifying print options. A Print
dialog box appears for each file you drag to the Printer control.

Prints to default printer

Prints to pscolor printer

Prints to the default
printer or the printer
that you copied to
the Main Panel
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Note – pscolor will not show on your system. It is only included as an example of a
printer that has been added to a system.

2. Optional. Use the text fields in the Print dialog box to set additional print options.
(See “Setting Print Options Using the Print Dialog Box” on page 299.)

3. Click OK in the Print dialog box to send the job to the printer.

� To Print Using File Manager
1. Select the file in File Manager.

2. Choose Print from the Selected menu or the file’s pop-up menu.

The system displays a Print dialog box for specifying various print options.

3. Optional. Use the text fields in the Print dialog box to set additional print options.
(See “Setting Print Options Using the Print Dialog Box” on page 299.)

4. Click OK in the Print dialog box to send the job to the printer.

� To Print Using Print Manager
1. Start Print Manager from the Personal Printers subpanel.

2. Drag a file from File Manager to a printer icon in Print Manager.

In Print Manager, you can submit a document by dropping it on a printer icon or into
the jobs list area to the right of a printer.

Note – If you submit a job to a printer that is down (flag is showing), it may never be
printed even though it appears in the jobs list.

The system displays a Print dialog box for specifying various print options.

3. Optional. Use the text fields in the Print dialog box to set additional print options.
(See “Setting Print Options Using the Print Dialog Box” on page 299.)

4. Click OK in the Print dialog box to send the job to the printer.
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Setting Print Options Using the Print Dialog Box
The desktop displays the Print dialog box when you print text, PCL, PostScript, and
data files (see Table 11–1).

When application data files, such as word processor documents, are submitted for
printing, they may display their own unique Print dialog boxes.

Use the Print dialog box to set these print options:

TABLE 11–2 Setting Print Options

Printer The destination for the print job. The text field initially displays
the printer on which you dropped the data file. In this example,
the document was dropped on a printer named lj4_n5.

Copies The number of copies to print. The default is 1.

Banner Page Title A title to appear on the banner page. The banner page is a sheet
of paper that the printer prints before it prints the first page of
your document.

Print Page Numbers Prints page numbers on each page. If page numbering is
selected, Print Manager will not display the true name of your
document. Instead, the name in the jobs list will be
STDIN:XXXXX, where XXXXX is a five-digit number.

Print Command Options Other options that change the way printing is done. See the next
section for more details on using this field.
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Print Command Options
You can use the Print Command Options text field in the Print dialog box to set other
print options. Type the proper lp command flag in the text field for the print option
you want to use. To see a list of the lp command flags, type man lp in a Terminal
window.

For example, one of the lp flags is -m. This flag tells the print server to send you a
mail message that tells you when it is done printing your document. To use this flag
you would type -m in the Print Command Options field of the Print dialog box. Then
when your document is done printing, a message appears in your mailbox from the
printer.

Printer Applications
After you submit a document (print job) for printing, you can use the Print Manager
or Printer Jobs applications to find out about the progress of the printing. Printer Jobs
gives you information about jobs on a single printer. Print Manager shows all the
printers that are on your system.

Print Manager
The Print Manager window is shown below. To find out how to modify it, see
“Changing the Print Manager Display” on page 306.
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Printer
open/close
button

Message line

Print jobs
waiting to
be printed

� To Start Print Manager
� Click the Print Manager control in the Personal Printers subpanel in the Front

Panel.

Starts Print Manager
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Printer Jobs Application
The Printer Jobs application is the application you see when you open a single printer
from the Front Panel. The Printer Jobs application is a simplified version of Print
Manager that shows only a single printer instead of all the printers on your system.
The functions that are available inside Printer Jobs work the same way as they do in
Print Manager.

Default printer

Print jobs waiting
to be printed

� To Start the Printer Jobs Application
� Click the Printer control in the Front Panel.

Starts printer jobs
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Note – The pscolor printer is only shown in the figure as an example of a printer that
has been added to a system. It will not be on your subpanel.

Displaying Print Job Information
Information about the jobs waiting to be printed on a printer is displayed when you
open a printer icon. A display area to the right of the printer icon displays an icon for
each of the jobs waiting to be printed on it, and each job’s position in line, job name,
and owner.

� To Open a Printer Icon
There are three ways to open a printer:

� Click the Open [+] button to the left of the printer icon.

� Select a printer, then choose Open from the Selected menu or from the printer’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

� Double-click the printer icon.

Note – Your job will not appear in the Print Manager or Printer Jobs window if
there are no jobs waiting to be printed when you send your job to the printer.

� To Close a Printer Icon
Close a printer if you don’t want to see the jobs waiting to be printed on it.

� Click the Close [-] button to the left of the printer icon.

� Select a printer, then choose Close from the Selected menu or from the printer’s
pop-up menu (displayed by pressing Shift+F10 or mouse button 3).

� To Find a Print Job
1. Choose Find from the Printers menu.

Find is available in Print Manager but not in the Printer Jobs application.
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2. Type the name of the print job you want to find in the Job Name field.

For example, typing cat will find all jobs that include the fragment “cat” in their
name, such as “Catchall” and “catalog,” regardless of case.

To find jobs with the name “cat” only, you would select Exact match.

To find only jobs that match your capitalization, deselect Ignore case.

Note – Find only finds print jobs that list you as the owner and it searches all printers,
even those that are not currently displayed.

3. Click Start Find.

4. Once you have found a job, you can go directly to it in Print Manager or cancel it.
To go to a found job, select the job and click Goto. To cancel a found job, select it
and click Cancel Print Jobs.

� To Cancel a Print Job
1. Select a print job in the Print Manager or Printer Jobs window.

2. Choose Cancel from the Selected menu or from the print job’s pop-up menu
(displayed by pressing Shift+F10 or mouse button 3).

3. Click Yes in the confirmation dialog box.

Print Job Properties
The following properties can be displayed for print jobs:

� Job name

� Job owner

� Job number

� Job size

� Time job submitted

� Date job submitted

Note – The term “not available” may appear in some fields to indicate that the
print system is not supplying that information.
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� To Display Print Job Properties
1. Select a print job.

2. Choose Properties from the Selected menu or the print job’s pop-up menu
(displayed by pressing Shift+F10 or mouse button 3).

The properties are displayed.

Printers and the Front Panel
The printer shown in the Front Panel is usually your default printer. You can change it
to another printer, or add a printer to the Personal Printers subpanel.
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� To Change the Front Panel Printer

Note – This does not change your default printer assignment. To find out how to
change the default printer, see “To Change the Default Printer” on page 296.

1. Open the Personal Printers subpanel (by clicking the arrow above the Printer
control in the Front Panel) and verify that the icon for the printer you want to move
to the Front Panel appears.

If the printer is not in the Personal Printers subpanel, add it by following the steps in
“To Add a Printer to the Personal Printers Subpanel” on page 306.

2. In the subpanel, point to the printer icon you want to add to the Front Panel and
select Put In Main Panel from the icon’s pop-up menu (displayed by pressing
Shift+F10 or mouse button 3).

To verify that the printer has been changed, click the Printer control in the Front Panel
and check the name of the icon in the Printer Jobs window that appears.

� To Add a Printer to the Personal Printers Subpanel
1. Open the Personal Printers subpanel (by clicking the arrow above the Printer

control in the Front Panel).

2. Start Print Manager.

3. Drag a printer icon from the Print Manager window to the Install Icon control in
the open subpanel.

Changing the Print Manager Display
This section describes how to change display parameters in Print Manager.
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� To Change How Printers and Print Jobs Are
Displayed

1. Start Print Manager.

2. Choose Set Options from the View menu.

3. Select how you want the print jobs represented:

� Large Icon – Displays printers and print jobs as large icons

� Small Icon – Displays printers and print jobs as small icons

� Name Only – Displays printer and print jobs as only text

� Details – Displays job owner, size, job number, and the date and time each job was
submitted

� Show Labels – Displays a description of each details row to the left of the job list
area

Note – The term “not available” may appear in some fields to indicate that the
print server is not supplying that information

4. Click OK.

� To Change the Update Frequency
1. Start Print Manager.

2. Choose Set Options from the View menu.

3. Adjust the interval gauge to specify how frequently printers are queried for
information about their print jobs. The default is every 30 seconds.

4. Click OK.

� To Determine Which Jobs Are Displayed
1. Start Print Manager.

2. Choose Set Options from the View menu.

3. Select which jobs you want shown:

� Only Mine – Displays just your print jobs
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� Everyone’s – Displays all print jobs

4. Click OK.

� To Display the Print Manager Message Line
1. Start Print Manager.

2. Choose Set Options from the View menu.

3. Select Message Line to display a message line at the bottom of the Print Manager
window.

The message line shows the number of printers on your system and the number that
are currently hidden. It also presents messages telling you when printer updates are
being done.

4. Click OK.

� To Display the Print Manager Problem Flag
1. Start Print Manager.

2. Choose Set Options from the View menu.

3. Select Problem Flag to have a flag icon displayed next to printers when a problem is
found with one of them.

For more information on the problem, you can double-click the Flag icon.

4. Click OK.

� To Determine Which Printers Are Shown
1. Start Print Manager.

2. Choose Modify the Show List from the View menu.

Printers that are visible in the Print Manager window have highlighted names.

3. Click a non-highlighted printer to make it visible in the Print Manager window.

Click a highlighted printer to remove it from the main window. You can also use Select
All to show all the printers or Deselect All to hide all the printers.

4. Click OK.
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Printer Properties
The following properties can be displayed:

� Icon label
� Icons
� Description
� Printer queue
� Printer queue status
� Device name
� Device status

� To Show a Printer’s Properties
1. Select a printer in the Print Manager window or the printer in the Printer Jobs

window.

2. Choose Properties from the Selected menu or from the printer’s pop-up menu
(displayed by pressing Shift+F10 or mouse button 3).

� To Change a Printer’s Icon
1. Select a printer in the Print Manager window or the printer in the Printer Jobs

window.

2. Choose Properties from the Selected menu or from the printer’s pop-up menu
(displayed by pressing Shift+F10 or mouse button 3).

3. Click Find Set.

4. Select the new icon you wish to use.

If the icon you want is not visible, choose another folder from the Icon Folders menu.
This dialog box will only display icons that have a complete set of all three sizes.

5. After you have selected an icon, click OK.

6. Click OK in the Properties dialog box.
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� To Change a Printer’s Icon Label
1. Select a printer in the Print Manger window or the printer in the Printer Jobs

window.

2. Choose Properties from the Selected menu or from the printer’s pop-up menu
(displayed by pressing Shift+F10 or mouse button 3).

3. Type the new icon label in the Icon Label field.

4. Click OK.
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CHAPTER 12

Using Text Editor

This chapter describes how to create and edit short documents such as memos, mail
messages, or resource files using Text Editor.

� “Opening and Closing Text Editor” on page 311
� “Text Editor Window” on page 313
� “Opening and Saving Documents ” on page 314
� “Entering Text” on page 319
� “Moving the Cursor in a Document” on page 320
� “Selecting Text” on page 322
� “Editing Text” on page 324
� “Correcting Misspelled Words” on page 328
� “Using Drag and Drop” on page 335
� “Searching a Document” on page 336
� “Formatting and Printing Documents” on page 337
� “Recovering a File” on page 340
� “Text Editor and Other Applications” on page 340
� “Using Text Note” on page 341

Opening and Closing Text Editor
There are several ways to start Text Editor from your desktop.
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� To Open Text Editor
� Open the Applications subpanel in the Front Panel and click the Text Editor control.

Text Editor can also be started from the command line by typing this command in a
Terminal window:

dtpad filename &

The file name is optional.

Note – If the path /usr/dt/bin has not been set in your .cshrc file, then type
/usr/dt/bin/dtpad to run Text Editor from the command line.

� To Close Text Editor
� Choose Close from the File menu or press Alt+F4.

Note – If your keyboard does not have an Alt key, ask your system administrator to
identify the corresponding key.
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Text Editor Window
You create and edit a document in the Text Editor window. The title bar displays the
name of the current document. A new document is named (UNTITLED).

FIGURE 12–1 Text Editor window

You can optionally display a status line that reports the number of lines in your
document and enables you to go to a specific line number.
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� To Display the Status Line
The status line displays the line number where the insertion cursor is located and the
total number of lines in the document. It also reports Text Editor messages and
indicates whether Overstrike mode is active.

� Choose Status Line from the Options menu. To remove the status line, choose
Status Line again from the menu.

Opening and Saving Documents
You can create a new document or open an existing document. Opening a document
displays the contents of a selected file in the Text Editor window.

Saving a document stores the edited contents into a file. You can save a document to
its original file or to a new file.

You can choose that Text Editor maintains a file containing the previously saved
version of a file each time it performs a save during the current session.

� To Create a New Document
A new document named (UNTITLED) is created when you start Text Editor. To enter
text in your document, see “Entering Text” on page 319. You provide a new file name
when you save the document.

After finishing a document, you can create another document using the New
command.

� Choose New from the File menu.
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The Text Editor window is cleared and a new document is created. If you have not
saved your current document, a dialog box is displayed that enables you to save your
document.

� To Save a Document to a New File
1. Choose Save As from the File menu.

The Save As dialog box lists files and folders located in your current folder. You can
store your document in the current folder, a subfolder, or a folder that you specify.

If you used Wrap To Fit, the dialog box includes an additional choice about handling
line endings. If Wrap To Fit is set off, the dialog box omits this choice (see “Using
Wrap To Fit” on page 319).

FIGURE 12–2 Save As dialog box

2. Optional. If you do not want to save the file to the current folder, choose a subfolder
or indicate a different folder.

� For a subfolder, select the subfolder in the Folders list and press Return.

� For a different folder, use the .. (go up) icon to change to a folder or type its path
name in the Enter path or folder name field.

3. Type a new file name in the Enter file name field.
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4. Press Return or click OK.

Note – To save your document to a diskette that has been mounted, choose
/floppy/floppy_name through the menu button at the end of the text field, Enter path
or folder name. Type a name in the Enter file name text field and click OK.

� To Save a Document to the Original File
� Choose Save from the File menu to save your work and continue editing your

document.

If you used Wrap To Fit, the Save dialog box includes an additional choice about
handling line endings (see “Using Wrap To Fit” on page 319).

Opening an Existing Document
You can open an existing document in these ways:

� Open the document in Text Editor.

� Select the file icon in File Manager and choose Open from the File Manager
Selected menu.

� Double-click the file icon in File Manager.

� Drag the document’s file icon to the Text Editor control in the Front Panel.

� To Open an Existing Document from Text Editor
1. Choose Open from the File menu.

The Open a File dialog box lists files and folders in your current folder. You can
browse the documents listed, or change to a new folder to locate other files on your
system.
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FIGURE 12–3 Open a File dialog box

2. Select the name of the document you want to open, or type the document name in
the Enter file name field.

3. Press Return or click OK.

Note – You can also use this shortcut: double-click the document name in the dialog
box.

Note – To save a file from a CD-ROM or diskette that has been mounted, choose
/cdrom/cd_name or /floppy/floppy_name through the menu button at the end of the
text field, Enter path or folder name. Select the file name and click OK.

� To Open an Existing Document from File Manager
1. Display the document’s file icon in a File Manager window.
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FIGURE 12–4 Document file icon

2. Open the document in one of the following ways:

� Double-click the document.

� Select the document, then choose Open from the File Manager Selected menu.

� Drag the document file icon to the Front Panel and drop the icon on the Text Editor
control.

Working with Backup Versions
You can choose that Text Editor maintains a file containing the previously saved
version of a file each time it performs a save. You do this using the Backup on Save
menu item on the Options menu. The default setting is un-selected, so each time you
run Text Editor, the setting reverts to the default.

When performing a save with Backup on Save selected, Text Editor first copies the
original file to a new file name (the old file name with a percent character “%”
appended), and then saves the edited file to the original file name.

� To Recover the Backup Version of a File
You can revert to the previously saved version of a file in which you are interested as
follows:
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1. Choose Open from the File menu.

Text Editor displays the Open a File dialog.

2. Browse to the folder containing the file in which you are interested, and select the
corresponding file name with a percent character “%” appended.

Text Editor opens the file.

3. Use the Save As command in the file menu to overwrite the original file.

The original file now contains the contents of the previous version.

Entering Text
As you create a document, you type and edit text. A cursor (I) shows your current
position. Characters are inserted unless you set Overstrike mode (see “To Set
Overstrike Mode” on page 325).

� To Enter New Text
� Click in the document and start typing.

To start a new line, press Return. Or, you can use the Wrap To Fit option to
automatically wrap text at the edge of the window.

To start a paragraph, press Return twice.

Using Wrap To Fit
Wrap To Fit controls whether lines are automatically wrapped to fit the width of the
window. When Wrap To Fit is set on, lines are broken automatically at the edge of the
window. Because these line breaks are dynamic, you can resize the Text Editor
window and the text automatically adjusts to fit the new window width.

When you save your document, you decide whether to add a line break to each of the
wrapped lines, or to discard the dynamic line endings. When you save your
document, you choose one of these options:

� Add a newline character (hard return) to the end of each wrapped line to preserve
each line ending as it currently appears.
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� Or, preserve only line breaks that were created by pressing Return.

� To Set Wrap To Fit On or Off
� To set Wrap To Fit on, choose Wrap To Fit in the Options menu. To set Wrap To Fit

off, choose it from the menu again.

Entering Special Characters
Different systems often use certain key combinations to insert special characters (see
“Composing Special Characters” on page 70).

In some instances, a key combination may be reserved by Text Editor. For example, a
Text Editor mnemonic for displaying a menu might conflict with a key sequence you
want to use on your keyboard. To insert the correct character you may need to
override the reserved behavior by preceding the key combination with Control+Q.

Moving the Cursor in a Document
As you enter and edit text, you move the insertion cursor using the mouse and
keyboard cursor keys. Using the mouse, move the pointer to the new location in the
document and click mouse button 1.

You can also use the keyboard cursor movement keys:

Key Cursor Movement

Up Arrow Up one line

Down Arrow Down one line
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Key Cursor Movement

Left Arrow Left one character

Right Arrow Right one character

Control+Left Arrow Move left to previous word

Control+Right Arrow Move right to next word

Home Beginning of the current line

End End of the current line

Control+Up Arrow Beginning of the previous paragraph

Control+Down Arrow Beginning of the next paragraph

Control+Home Beginning of the document

Control+End End of the document

Control+G To the Line field in the status line

Note – If your keyboard uses different key labels, ask your system administrator to
identify the corresponding keys.

� To Go to a Specific Line
1. Display the status line (see “To Display the Status Line” on page 314).

2. Press Control+G or click in the Line field of the status line.

3. Type the line number you want to go to and press Return.

� To Scroll a Document
� Select and drag the vertical scroll bar to view more text. Use the horizontal scroll

bar to view long lines.

You can also use the scrolling keys:

Key Scroll Movement

Page Up Up one page
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Key Scroll Movement

Page Down Down one page

Control+Page Up Left one page

Control+Page Down Right one page

Selecting Text
Before using edit commands such as cut and paste, you must select the text. You can
select text using the mouse or the keyboard.

� To Select Text with the Mouse
1. Click at the beginning of the text you want to select.

2. Press and hold mouse button 1 and drag to the end of the text.

To deselect text, click any area in the window.

Note – To modify a selection you have made, press and hold the Shift key and mouse
button 1. Then drag forward or backward to adjust the amount of selected text. Or,
hold down the Shift key and one of the arrow keys to change the selection.

You can also use these shortcuts for selecting text:

Word Double-click the word

Line Triple-click the line

All text Quadruple-click in the text

Secondary Selection
This method enables you select text and replace it with another selection, which is
used as the replacement text.
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� To Replace Text Using Secondary Selection
1. Select the text that you want to replace.

2. Move the pointer to the beginning of the text you want to replace the first selection
with. Hold down the Alt key and mouse button 2 and drag to the end of the text
you want to use.

The text is underlined.

Note – If your keyboard does not have an Alt key, ask your system administrator to
identify the corresponding key.

3. Release the Alt key and mouse button.

The underlined text overwrites your first selection.

� To Select Text with the Keyboard

Text to Select Action

Text block Move the cursor to the beginning of the text
block. Hold down the Shift key and an arrow
key to move the cursor to the end of the text
block.

Cursor to beginning of line Shift+Home

Cursor to end of line Shift+End

Cursor to beginning of paragraph Shift+Control+Up Arrow

Cursor to end of paragraph Shift+Control+Down Arrow

Cursor to beginning of document Shift+Control+Home

Cursor to end of document Shift+Control+End

All text Control+/

Deselect all text Control+\
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Editing Text
Minor edits can be made using the editing keys. You may also want to copy, move, or
delete portions of text, find and change a word or phrase, or check the spelling of your
document.

Editing Keys

Key Action

Backspace Deletes the character before the cursor

Delete Deletes the character following the insertion cursor

Control+Backspace Deletes the previous word

Shift+Backspace Deletes characters from the cursor to the beginning of
the line

Control+Delete Deletes all the characters from the cursor to the end of
the current line

Insert Toggles Overstrike and Insert mode

Menu Shortcut Keys
You can also use these shortcut keys when making edits.

TABLE 12–1 Shortcut Keys

Control+C Copy selected text

Control+X Cut selected text

Control+V Paste selected text

Control+F Find/Change text

Control+Z Undo a cut, delete, clear, include, copy, or paste command

324 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



UNIX Key Bindings
UNIX® key bindings enable you to use a set of extended Emacs keys, such as Alt+B
(back word) or Control+N (next line), in Text Editor. To enable UNIX key bindings
(which are set off by default) you edit a file in your home directory.

� To Enable UNIX Key Bindings
1. Add the following line to the .Xdefaults file in your home directory:

#include "/usr/dt/app-defaults/language/UNIXbindings"

Replace language with the name of your language environment.

If the .Xdefaults file does not exist, create the file in your home directory.

2. Log out of your current session.

3. Log in and restart Text Editor.

Some Text Editor menu accelerators conflict with UNIX key bindings. When UNIX key
bindings are enabled, Text Editor provides alternate menu accelerators for these
commands:

Command Alternate Menu Accelerator

Find/Change (Control+F) Control+S

Paste (Control+V) Shift+Insert

Print (Control+P) No alternate accelerator

Undo (Control+Z) Control+_

If you want to modify these menu accelerators, copy the contents of the
/usr/dt/app-defaults/language/UNIXbindings file into your .Xdefaults file
and then make your changes.

Note – When using UNIX key bindings, the Delete key deletes the previous character
rather than the character that follows the cursor.

� To Set Overstrike Mode
As you type, new characters are inserted. If you want to type over existing characters,
change to Overstrike mode.
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� Choose Overstrike from the Options menu. To return to Insert mode, choose
Overstrike again from the menu.

� Or, use the Insert key to switch between Insert and Overstrike mode.

When Overstrike mode is on, the cursor changes to a solid block. If you use
Overstrike mode often, you may want to display the status line (see “To Display
the Status Line” on page 314) because it indicates whether Overstrike mode is on
or off.

� To Type Over Text
1. Select the text.

2. Type the replacement text.

You can also choose Overstrike from the Options menu to turn off Insert mode and
type over the text directly.

� To Delete Text
1. Select the text.

2. Choose Delete from the Edit menu or press the Delete key.

Deleted text cannot be pasted, but it can be recovered with the Undo command (see
“To Undo an Edit” on page 326).

If you intend to paste the text that you delete, use the Cut command (see “To Undo an
Edit” on page 326).

� To Clear Text
The Clear command replaces the selected text with spaces or blank lines.

1. Select the text to be cleared.

2. Choose Clear from the Edit menu.

� To Undo an Edit
� Choose Undo from the Edit menu or press Control+Z.

Undo reverses the last cut, paste, clear, delete, change, include, or format operation.
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� To Copy Text
1. Select the text to be copied.

2. Choose Copy from the Edit menu or press Control+C.

A copy of the text is stored on a clipboard where it can be accessed or replaced by
other applications.

3. Click where you want to insert the text.

4. Choose Paste from the Edit menu or press Control+V.

You can also use drag and drop to copy text (see “To Copy Text Using Drag and Drop”
on page 335).

Note – Use this shortcut to copy a word or phrase: Select the text, move the pointer to
where you want to insert the text, and click mouse button 2. This is a quick way to
copy text into a dialog box.

� To Move Text (Cut and Paste)
1. Select the text.

2. Choose Cut from the Edit menu or press Control+X.

The text is erased from the document and stored on a clipboard where it can be
accessed or replaced by other applications.

3. Move the cursor to where you want to insert the text.

4. Choose Paste from the Edit menu or press Control+V.

You can also use drag and drop to move text (see “To Move Text Using Drag and
Drop” on page 335).

� To Include a File
You can insert a text file into your document using a menu command or by dragging a
file icon into the Text Editor window (see “To Include a File Using Drag and Drop”
on page 335).

1. Position the cursor where you want to insert the text file.
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2. Choose Include from the File menu.

The Include a File dialog box lists files and folders on your system. You can browse the
documents listed, or change to a new folder to locate other files on your system.

FIGURE 12–5 Include a File dialog box

3. Select the document you want to insert in the Files list.

4. Press Return or click OK.

Note – To include a file from a CD-ROM or diskette that has been mounted, choose
/cdrom/cd_name or /floppy/floppy_name through the menu button at the end of the
text field, Enter path or folder name. Select the file name and click OK.

Correcting Misspelled Words
You can correct misspelled words with the Spelling Checker. You can also customize
your Personal Dictionary and Main Dictionary; see “To Correct Misspelled Words”
on page 329 for more information.
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� To Correct Misspelled Words
1. Choose Check Spelling from the Edit menu.

Note – Your Spelling Checker dialog box may look different than the one pictured in
Figure 12–6. If so, go to Figure 12–7 and follow the instructions after that figure.

The Spell dialog box lists misspelled or unrecognized words.

The Check Spelling (Version 1) feature is only available for the English language.

FIGURE 12–6 Spell dialog box - Version 1

2. Select the misspelled word in the Misspelled Word list that you want to find and
press Return. Or, just double-click the word.

The next occurrence of the word is highlighted in your document.

3. Type the correct word into the Change To field.

4. Click Change to correct a single occurrence.

Or, click Change All to replace all occurrences.

5. To find and change additional single occurrences, click Find and then Change.
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6. Click Close when you are done.

Note – If your Spelling Checker dialog box resembles Figure 12–7, follow the
instructions after the figure.

The Spelling Checker dialog box displays a misspelled or unrecognized word and lists
suggestions. To start a new spelling check while the Spelling Checker dialog box is
open, click Start Check.

FIGURE 12–7 Spelling Checker dialog box - Version 2

1. Take action on the first word found by the spelling checker:

� If the suggested replacement is correct, click Change to correct this occurrence, or
Change All to change all occurrences. (You cannot Undo a Change All.)

� If you see the correct replacement in the list, select it and click Change or Change
All.

� If the correct replacement is not in the list, type it in the suggestion field and click
Change or Change All.

� If the word is correct and you want to add it to your Personal Dictionary, click
Learn Word.

� If the word is correct but you do not want to add it to your Personal Dictionary,
click Skip to skip this occurrence, or Skip All to skip all occurrences.

2. Continue through the misspelled words found by the Spelling Checker.

3. To stop the Spelling Checker and leave the dialog box displayed, click Stop Check.

To stop Spelling Checker and close the dialog box, click Close.
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Customizing Spelling Checker Dictionaries
When you run Spelling Checker, it uses both your Personal Dictionary and Main
Dictionary. You can edit your Personal Dictionary and set your Main Dictionary.

You can run Spelling Checker with or without your Personal Dictionary. You can also
remove words from your Personal Dictionary, import another user’s Personal
Dictionary, and export your Personal Dictionary to make it accessible to other users.
When you import another user’s Personal Dictionary, you can choose whether you
want to append the imported Personal Dictionary to your own Personal Dictionary, or
overwrite your own Personal Dictionary with the imported one.

Spelling Checker automatically sets your Main Dictionary to the default locale
installed on your system. You can change the Main Dictionary to a different locale
whenever Spelling Checker starts or change the locale just for the current session.

� To Run Spelling Checker Without Your Personal
Dictionary

1. Click Options in the Spelling Checker dialog box.

2. Choose Personal Dictionary as the Category.

FIGURE 12–8 Personal Dictionary dialog box

3. Deselect the Use Personal Dictionary checkbox.

4. Click OK to save your changes and close the dialog box.

Spelling Checker will now run only with your Main Dictionary.
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� To Remove a Word From Your Personal Dictionary
1. Click Options in the Spelling Checker dialog box.

2. Choose Personal Dictionary as the Category.

3. Select the word in the scrolling list.

To select more than one word, select the first word and then Shift-Click (or
Control-Click) to choose the other words. You can drag choose contiguous words.

4. To delete the word from the list, click Remove.

5. To save your changes and close the dialog box, click OK.

� To Import Another User’s Personal Dictionary
1. Click Options in the Spelling Checker dialog box.

2. Click Import in the Spelling Checker Options dialog box.

The Spelling Checker Import dialog box is displayed.

FIGURE 12–9 Personal Dictionary Import dialog box

3. Select the dictionary you want to import in the Files list, or type the dictionary
name in the Selection field.
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4. Press Return or click OK.

Note – You can also double-click the dictionary name in the dialog box.

5. In the dialog box that appears, choose whether you want to append the imported
personal dictionary to your own personal dictionary, or overwrite your own
personal dictionary with the imported one.

� To Export Your Personal Dictionary
1. Click Options in the Spelling Checker dialog box.

2. Click Export in the Spelling Checker Options dialog box.

The Spelling Checker Export dialog box is displayed.

FIGURE 12–10 Personal Dictionary Export dialog box

3. Select the dictionary you want to export in the Files list, or type the dictionary name
in the Selection field.

4. Press Return or click OK.

Note – You can also double-click the dictionary name in the dialog box.

Now other users can import your dictionary. You can send your personal dictionary to
another user or tell them where it is in your file system.
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� To Set Your Current Dictionary Locale
1. Click Options in the Spelling Checker dialog box.

2. Choose Main Dictionary as the Category.

The Main Dictionary dialog box is displayed.

FIGURE 12–11 Main Dictionary dialog box

3. Choose the desired locale as the Current Dictionary.

Note – This locale setting is for the current Spelling Checker session only. The next
time you restart Spelling Checker it will run with your default locale.

4. To save your changes and close the dialog box, click OK.

� To Set Your Default Dictionary Locale
1. Click Options in the Spelling Checker dialog box.

2. Choose Main Dictionary as the Category.

3. Determine your main dictionary locale:

� To have your Main Dictionary match the default locale installed on your system,
select Set Dictionary to Match Locale Language.

� To override the system default locale, Set Dictionary To and choose the desired
locale.

4. To save your changes and close the dialog box, click OK.
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Using Drag and Drop
You can use drag and drop to move or copy text between Text Editor documents or
other applications. You can also include a file into your document using drag and
drop.

� To Move Text Using Drag and Drop
1. Select the text that you want to move.

2. With the pointer on the selection, press and hold mouse button 1, and drag to where
you want to insert the text.

3. Release the mouse button.

The text is inserted into your document relative to the position of the drag icon.

� To Copy Text Using Drag and Drop
1. Select the text you want to copy.

2. With the pointer on the selection, press and hold the Control key and mouse button
1, and drag to where you want to copy the text.

3. Release the Control key and mouse button.

The text is copied relative to the position of the drag icon.

� To Include a File Using Drag and Drop
When using drag and drop, the contents of the file are copied into the Text Editor
window at the position of the insertion cursor. The original file remains intact.

1. Click in your document where you want to include the file.

2. Drag the file icon that you want to include into the Text Editor window.
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Searching a Document
You can search for a word or phrase in your document. The Find command begins
from the position of the insertion cursor and proceeds through the entire document.
You can automatically replace or delete occurrences found in your document.

Searches are case sensitive. To find all occurrences, search for both lowercase and
uppercase instances.

� To Find Text
1. Choose Find/Change from the Edit menu or press Control+F.

FIGURE 12–12 Find/Change dialog box

2. Type the text you want to find in the Find field.

3. Press Return or click the Find button to locate the next occurrence of the text.

4. To find additional occurrences, press Return or click Find again.
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� To Find and Change Text
1. Choose Find/Change from the Edit menu or press Control+F.

2. Type the text you want to find in the Find field.

3. Type the replacement text in the Change To field.

4. Press Return or click the Find button to locate the next occurrence of the text.

5. Click Change to replace a single occurrence.

6. To find and change additional occurrences, click Find and then Change.

Or, click Change All to replace all occurrences.

Caution – There is no Undo for Change All.

7. Click Close when you are done.

� To Find and Delete Text
1. Choose Find/Change from the Edit menu or press Control+F.

2. Type the text you want to delete in the Find field.

3. Leave the Change To field blank.

4. Press Return or click Find to locate the next occurrence.

5. Click Change to delete a single occurrence.

6. To find and change additional occurrences, click Find and then Change.

Or, click Change All to replace all occurrences.

7. Click Close when you are done.

Formatting and Printing Documents
Once your editing is complete, format your document by choosing margins and text
alignment.
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� To Format a Document
1. Choose Settings from the Format menu.

FIGURE 12–13 Format Settings dialog box

2. Enter margins.

The default left margin is 0 and the right margin is dynamically set to the width of the
Text Editor window. Margins are specified as a number of character columns.

3. Select left, right, justify (block style), or center alignment.

4. Determine the scope of the formatting:

� To format a single paragraph, place the cursor in the paragraph, then click
Paragraph.

� To format the entire document, click All.

5. After closing the dialog box, choose Paragraph or All from the Format menu to
apply the settings.

� To Print an Open Document
1. Open the document in Text Editor.

2. Choose Print from the File menu or press Control+P.

The Print dialog box displays the name of your system’s printer and enables you to set
printing options. By default, your document is printed on your system printer. If
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desired, you can direct your job to a different printer.

FIGURE 12–14 Print dialog box

3. Optional. Set any of these printing options:

� Type the number of copies to print.
� Type text to appear on the printer banner page.
� Click Print Page Numbers if you want to number the pages.
� Type command-line printer options.

4. Click Print.

The Print dialog box closes when you print your document. To close the dialog box
without printing your file, click Cancel.

� To Print a Closed Document
1. Display the document’s file icon in File Manager.

2. Drag the file icon to the Printer control in the Front Panel.

The Print dialog box is opened.

3. Optional. Set printing options.

4. Click Print.
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Recovering a File
If Text Editor is interrupted due to a system error, it attempts to save your changes in a
recovery file in your current folder. The recovery file is named #filename#, where
filename is the name of the document. If you had never named your document, the
recovery file name is #UNTITLED#.

� To Recover a File
1. Start Text Editor.

2. Open the recovery file.

3. Save the document using your original file name or provide a new name for a
previously unsaved document.

Text Editor and Other Applications
Other applications can use Text Editor as a tool to edit documents or other types of
information. Under certain conditions, an application may choose to restrict your
editing choices. In the example below, the File menu has been modified. The Save As
command has been replaced with a Copy To File command and the New and Open
commands are not available.
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FIGURE 12–15 Text Editor with modified File menu

Using Text Note
When you click the Text Note control on the Front Panel, Text Editor opens in note
mode; this enables you to type some text and post it on the Workspace for fast
retrieval. If you exit Text Editor while it is in note mode, the text note is saved in your
home folder and displayed as an icon on the Workspace backdrop. You can reopen a
text note by double-clicking its icon on the Workspace.

� To Type a Text Note
1. Click the Text Note control on the Front Panel.

Text Editor is opens in note mode.

2. Type your note.
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3. Choose Close from the File menu.

The Save dialog box is displayed.

4. Choose Yes to save changes.

The text note is put on the Workspace.

� To Put a Note on the Workspace
� Exit Text Editor while you are editing the text note, making sure you choose to save

current changes if prompted by the Save dialog box.

The note icon is displayed in the upper right corner of the workspace.

� To Remove a Note from the Workspace
� Double-click the text note icon on the Workspace.

File Naming
Text notes are saved as files in your home directory using file names derived from the
first twenty characters of the note. For example, if our fictional user Fred Jones had a
note containing the text Reminder: Call John Smith about meeting, it would
be saved in the file /home/fredj/Reminder: Call John .
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CHAPTER 13

Using Calendar

Calendar is a desktop application that enables you to schedule appointments and To
Do items, set reminders, make and print appointment and To Do lists, browse other
calendars, and schedule group appointments.

� “Calendar Startup” on page 343
� “Calendar Main Window” on page 345
� “Calendar Views” on page 347
� “Appointments” on page 351
� “To Do Items” on page 355
� “Printing Calendars, Appointment, or To Do Lists” on page 358
� “Browsing Calendars on a Network” on page 360
� “Scheduling Appointments on Other Calendars” on page 361
� “Customizing Calendar” on page 366
� “Other Calendar Tools” on page 373
� “Using Federated Naming with Calendar” on page 380

Calendar Startup
You can start Calendar in one of two ways:

� Click the Calendar control in the Front Panel.
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Calendar control           

� Type dtcm to start Calendar from the command line.
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Calendar Main Window
The menus and tool bar controls are at the top of the main window. The selected
Calendar view is displayed in the lower part of the main window.

Menus

Tool bar

Calendar view

Calendar Tool Bar
Calendar’s tool bar provides controls for quick navigation through calendars. The tool
bar controls and their functions are described in Table 13–1.
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TABLE 13–1 Calendar Tool Bar Icons

Control Function

Appointment Editor icon opens the Appointment Editor so you can insert,
delete, or edit Calendar appointments.

To Do Editor icon opens the To Do Editor so you can create, modify,
update, or set reminders for things you have to do.

Previous View arrow changes the Calendar view to display the view
before the current view. For example, if you are viewing August in
Month view, clicking the Previous View arrow changes the Calendar
display to July.

Today changes the Calendar view to display the current day in the
format you are viewing. For example, if you are viewing by month,
clicking Today displays the current month.

Next View arrow changes the Calendar view to display the view after the
current view. For example, if you are viewing August in Month view,
clicking the Next View arrow changes the Calendar display to
September.

Day View icon displays the calendar you are viewing with one day’s
appointments in the window plus a three-month mini-calendar.

Week View icon displays the calendar you are viewing with a week’s
appointments in the window plus a week grid showing scheduled times.
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TABLE 13–1 Calendar Tool Bar Icons (Continued)
Control Function

Month View icon displays the calendar you are viewing with a month’s
appointments in the window.

Year View icon displays the calendar you are viewing with a year in the
window. Appointments are not displayed.

Calendar Views
The Calendar view is the day, week, month, or year displayed in the main Calendar
window.

Day View
Day view displays the calendar you are viewing with one day’s appointments in the
window. Day view also provides a three-month mini-calendar that displays the month
you are viewing and the previous and next months.

Clicking on a day in the three-month mini-calendar changes the Day view to display
the selected day. Clicking on a month name in the mini-calendar changes the Calendar
display from Day view to Month view.
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Week View
Week view displays the calendar you are viewing with one week’s appointments in
the window. The selected day is highlighted.

Week view also provides a week grid showing at a glance the times that are scheduled
(shaded) and the times that are available (unshaded).

Clicking on a day name in the Week view changes the Calendar display from Week
view to Day view.
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Month View
Month view displays the calendar you are viewing with one month’s appointments in
the window. The selected day is highlighted.

Clicking on a day in Month view changes the Calendar display to Day view.
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Year View
Year view displays a year calendar. Appointments are not displayed. Clicking on a
month name in Year view changes the Calendar display to Month view.
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Appointments
Use the Appointment Editor to insert, change, or delete appointments on your
calendar.

� To Schedule a Basic Appointment
1. In Day, Week, or Month view, display the day for which you want to schedule an

appointment.
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2. Double-click that day to open the Appointment Editor.

3. Choose the Start and End times.

The default appointment duration is one hour. If your appointment is longer or
shorter, edit the time in the End field.

4. Type a description of the appointment in the What field.

For example, you may want to enter the appointment’s location and purpose.

If you want to add optional settings to an appointment, see “To Set Appointment
Options” on page 352.

5. Click Insert.

The appointment is added to your calendar.

6. Click Cancel to close the Appointment Editor.

� To Set Appointment Options
1. Set up a basic appointment, as described above.

2. Click the More button in the Appointment Editor to display additional
appointment options.

3. Select the desired appointment in the Appointment Editor list.

4. Select Beep, Flash, Popup, or Mail (or more than one, in combination) for the types
of reminders you want.

5. Edit the reminder intervals and the Mail To entry if necessary.

6. Optional. To repeat the appointment more than once, choose an option from the
Occurs menu, and then choose an option from the For menu.

If you don’t see the interval you want, choose Repeat Every from the Occurs menu,
and type the desired interval in days, weeks, or months.

7. Choose an option from the Privacy menu.

Others See Time and Text Displays full appointment to others

Others See Time Only Displays only time commitment, not description

Others See Nothing Displays nothing to others
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8. Click Change.

If you set the appointment options at the same time as setting up a basic appointment,
click Insert at this step.

Note – If you are inserting multiple appointments one after another, be sure to click
Clear between insertions. This will reset options that you may not want to carry over
from one appointment to the next.

9. Click Cancel to close the Appointment Editor.

� To Change an Appointment
1. Click the Appointment Editor icon.

2. Select the appointment in the appointment list that you want to change.

3. Edit the appointment date, start or end time, description, reminders, frequency, or
privacy.

4. Click Change.

5. Click Cancel to close the Appointment Editor.

� To Delete an Appointment
1. Click on the Appointment Editor icon to open it.

2. Select the appointment in the appointment list.

3. Click Delete.

4. Click Cancel to close the editor.

� To Find an Appointment
1. Choose Find from the View menu.

The Find dialog box is displayed

2. Type some text in the in the Find field that can become a keyword for the search; for
example, conference.

The Find field is not case-sensitive.
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By default, Calendar searches the past and future six months in your calendar. If you
want to change the search range, click Search all to search your entire calendar (can
take a long time) or edit the dates in the Search from fields.

3. Click Find.

Appointments with matching text are displayed in the Find window.

4. Select the desired appointment in the list.

5. Click Show Appointment to display the entire appointment.

6. Click Close to close the Find dialog box.

� To View an Appointment List
This section describes how to create an appointment list and display it on your
system. If you want to print your Appointment list, see “Printing Calendars,
Appointment, or To Do Lists” on page 358.

1. Display the view of the calendar that you want the appointment list to show.
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2. Choose Appointment List from the View menu.

Appointments are listed chronologically and show date, time, and description. For
example, if you are viewing by week, the Appointment List displays the week’s
appointments.

To Do Items
Use the To Do Editor to insert, update, or delete To Do items in your Calendar.
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� To Insert a To Do Item
1. Click the To Do Editor icon.

2. Type or edit the due date for the item in the Due Date field.

3. Type a description of the To Do item in the What field.

4. Click Insert.

5. Click Cancel to close the To Do Editor.

� To Change a To Do Item
1. In Day, Week, or Month view, display the day for which you want to change a To

Do item.

2. Select that day.

3. Click the To Do Editor icon.

4. Select the To Do item in the To Do list.

5. Edit the due date or the description of the To Do item.

6. Click Completed to change the status of the To Do item, if applicable.

7. Click Change.

8. Click Cancel to close the To Do Editor.

� To Delete a To Do Item
1. Click the To Do Editor icon to open it.

2. Select the To Do item in the To Do list.

3. Click Delete.

4. Click Cancel to close the editor.
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� To View a To Do List
This section describes how to create a list of To Do items and display it on your
system. If you want to print your To Do list, see “Printing Calendars, Appointment, or
To Do Lists” on page 358.

1. Display the view of the calendar that you want the To Do list to show.

2. Choose To Do List from the View menu.

To Do items are listed chronologically and show a check box beside each item, due
date, and description. For example, if you are viewing by day, the To Do List displays
the day’s To Do items.
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Marking To Do Items Completed
Calendar keeps track of the state of To Do items: whether they’re completed or pending.
In the To Do List dialog box, you can choose to display all To Do items, only
completed items, or only pending items.

If you make a To Do list and then want to check off an item on the list, use one of the
two methods described below.

� To Mark an Item Directly in the To Do List
1. Choose To Do List from the View menu.

2. Click the check box beside the To Do item you’ve completed.

3. Click Apply or OK.

This changes the item’s state to completed.

To return the item’s state to pending, click the check box again and apply your
changes.

� To Use the To Do Editor To Mark an Item
1. Click the To Do Editor icon.

2. Select the To Do item in the To Do list.

3. Click Completed to mark the item completed.

To return the item’s state to pending, click Completed again.

4. Click Change.

This changes the item’s state to completed.

5. Click Cancel to close the To Do Editor.

Printing Calendars, Appointment, or To
Do Lists
You can print any of the four Calendar views, plus appointment and To Do lists.
Calendar uses the default printer settings when you choose Print Current View from
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the File menu. To customize printer settings, see “To Change the Printer Settings for
Future Print Jobs” on page 372.

� To Print Current Day, Week, Month, or Year Views
1. Display the Calendar view you want to print.

2. Choose Print Current View from the File menu.

� To Print Your Appointment or To Do List
1. Display the Calendar view containing the day for which you want to print an

appointment or To Do list.

2. Select that day.

3. Choose Print from the File menu.

The Print dialog box is displayed.

4. Choose Appointment List or To Do List from the Report Type menu.

5. Specify a printer in the Printer Name field.

6. Click Print.

� To Change the Print Options for a Single Print Job
1. Choose Print from the File menu.

The Print dialog box is displayed.

2. Double-click in the Printer Name field to select the contents and type a printer
name.

3. Choose the view or list you want to print from the Report Type menu.

4. Click the arrows next to the Copies field to adjust the number of copies to be
printed or type the number.

5. Optional. Change the range of time to print in the From or To fields.

6. Optional. Add printer options in the Print Command Options field.

For example, to save paper, you may want to specify -o nobanner to suppress
header pages.
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7. To print Calendar data to a file instead of to a printer, select Print to file.

Click again on this setting to deselect it.

8. Edit the file name, if desired.

9. Click Print.

10. Click Close to close the Print dialog box.

Browsing Calendars on a Network
If you know the names of other calendars on a network, you can use Calendar to
browse those calendars. A practical example is to set up a meeting or appointment for
several people. You can use Calendar to check for free times.

To browse other calendars and possibly to insert an appointment, you need:

� The calendar names in the form calendar-name@hostname, such as
kent@dailyplanet

� To add calendars to the Browse list

� To determine if you have access to other calendars

Note – Calendar doesn’t yet provide a way for you to look up other calendar names.
Call or talk to people and get them to tell you their calendar-name@hostname
information.

By default, Calendar allows the “world” (all users) to have browse permission. Only
the calendar owner has insert and delete permission. To change access and
permissions, see “Changing Access and Permissions” on page 368.

� To Add or Delete Calendars in the Browse List
To add:

1. Choose Menu Editor from the Browse menu.

2. Type calendar-name@hostname in the User Name field.

3. Click Add Name.
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4. Click OK to add the calendar to the Browse list and close the dialog box.

To delete:

1. Select a calendar name in the Browse list.

2. Click Remove Name.

3. To delete the calendar from the Browse list and close the dialog box, click OK.

To delete the calendar and leave the dialog box displayed, click Apply.

4. To erase your changes and leave the dialog box displayed, click Reset.

To erase your changes and close the dialog box, click Cancel.

� To Determine Whether You Have Access to Other
Calendars

1. Choose Compare Calendars from the Browse menu.

2. Select one or more entries in the Browse list that you want to check for access.

3. Click Schedule to open the Group Appointment Editor.

4. Look at the Calendar Access list.

The Calendar Access list displays the calendar names that you selected in the
Compare Calendars dialog box.

A “Y” in the Access column means you have insert access. An “N” means you don’t.

Note – To add appointments or To Do items to other calendars, ask the owners to
grant you insert access. To find out how to grant or deny access to your calendar by
others, see “Changing Access and Permissions” on page 368.

Scheduling Appointments on Other
Calendars
Once you’ve browsed calendars for free times and have permission to insert
appointments on other calendars, you can schedule a group appointment.
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Use the Group Appointment Editor to insert, change, or delete a group appointment
on your and other calendars. If you don’t have insert access to other calendars, you
can use the Group Appointment Editor to mail notices of group appointments to other
users.

� To Schedule a Group Appointment
1. Choose Compare Calendars from the Browse menu.

2. Click one or more entries in the Browse list.

Notice that the grid overlays calendars one on top of another and displays busy times
shaded darker and available times unshaded.

3. Click in an unshaded time block in the grid.

4. Click Schedule.

The Group Appointment Editor is displayed with the fields for date, time, and mail
automatically filled out.

5. Type (or edit) the group appointment start time in the Start field.

6. Type (or edit) the group appointment end time in the End field.

7. In the What field, type the appointment description, such as its location or purpose.

8. Click More.

9. Choose the repeat interval and duration for the group appointment.

10. Click Insert to add the group appointment to the selected calendars.

If you don’t have insert access on all the calendars, you can send mail to notify others
about the group appointment. See “To Mail Reminders to a Group Using Calendar”
on page 362.

11. Click Cancel to close the Group Appointment Editor.

� To Mail Reminders to a Group Using Calendar
Once you’ve set up a group appointment (date, start and end times, description,
repeat interval), you may want to mail the group a reminder. With the group
appointment displayed in the Group Appointment Editor:

1. Click More to display additional options.
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2. Click Mail.

Calendar displays a Compose window containing an appointment attachment. The
appointment attachment is pre-addressed to the selected users and automatically filled
out with the date and appointment start and end times.

3. Click Deliver in the Compose window.

Calendar mails the reminder to the selected users.

Recipients of a mail message with a calendar-formatted reminder can drag the
message from the mailer header window and drop it on their calendars to
automatically schedule the pre-formatted appointment.

� To Create an Appointment Message Using a Mail
Program

1. Start Mailer (or your regular mail program).

2. Open a compose window or create a blank message.

3. Add a section to the message that includes exactly the following format. Replace
<tab> with a tab character, <blank line> with a blank line, and replace the italicized
format information with actual data.

<tab>** Calendar Appointment **

<blank line>

<tab>Date:<tab>mm/dd/yyyy

<tab>Start:<tab>hh:mm am

<tab>End:<tab>hh:mm pm

<tab>What:<tab>description line 1

<tab><tab>description line 2

An example might be:

** Calendar Appointment **

Date: 11/22/94

Start: 10:00 am

End: 11:00 am

What: Staff meeting

Monet conference room

4. Insert any additional text into the mail message.
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5. Address the message to the recipient and include the subject of the message.

6. Send the message.

For information about using Mailer, see Chapter 10.

� To Drag an Appointment From Mailer to Calendar
From Mailer, and possibly other applications, you can drag an appointment icon to
Calendar to schedule it.

1. In Mailer’s Message Header List, click the header containing the formatted
appointment.

2. Drag the header to Calendar and drop it.

The pointer changes to an icon representing the moving file.

Calendar schedules your appointment and prints a message in the message area
stating that the appointment was scheduled.

3. Display the Calendar view containing the day on which you scheduled the
appointment.

4. Double-click that day to open the Appointment Editor.

Verify that the appointment is scheduled for the correct day and time.

For more information on using Mailer, see Chapter 10.

� To Drag an Appointment From File Manager to
Calendar
From File Manager, and possibly other applications, you can drag an appointment
icon to Calendar to schedule it.

If you have a file containing a formatted appointment:

1. In an open File Manager window, navigate to a folder containing a file with a
formatted appointment.

2. With both the formatted appointment and Calendar visible on your screen, drag the
formatted appointment file to Calendar and drop it.

Calendar schedules your appointment.

3. Double-click that day to open the Appointment Editor.

Verify that the appointment is scheduled for the correct day and time.
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For more information about File Manager, see Chapter 5.

� To Drag an Appointment From Calendar to Mailer
From Calendar, you can drag an appointment icon to Mailer to mail it to someone.

1. Use the Appointment Editor to create an appointment but don’t click Insert.

2. Start Mailer and choose New Message from the Compose menu.

Make sure both the Appointment Editor and Mailer’s Compose window are visible on
your screen.

3. Drag the Drag Appt icon from the Appointment Editor and drop it on Mailer’s
attachment list.

The pointer changes to an appointment icon representing the moving file.

Mailer displays your appointment as a text file in the attachment list.

4. Compose and address your mail message and send it.

For more information on using Mailer, see Chapter 10.

� To Drag an Appointment from Calendar to File
Manager
From Calendar, you can drag an appointment icon to File Manager to save it in your
file system.

1. Use the Appointment Editor to create an appointment but don’t click Insert.

2. In an open File Manager window, navigate to a folder where you want to save the
appointment in a file.

3. With both the File Manager window and Calendar Appointment Editor visible on
your screen, drag the Drag Appt icon from the Appointment Editor and drop it on
the File Manager window.

The appointment is saved in a text file in the folder where you dropped it.

For more information about File Manager, see Chapter 5.
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Customizing Calendar
Calendar provides Options dialog boxes to change the settings for all future
appointments. To change the settings for individual appointments, see “To Set
Appointment Options” on page 352.

� To Change Appointment Editor Defaults
1. Choose Options from the File menu.

The Calendar Options dialog box is displayed.

2. Choose Editor Defaults from the Category menu.

3. Optional. Change the default appointment duration in the Duration field.

4. Optional. Change the default appointment start time by choosing from the Start
menu.

5. Select Beep, Flash, Popup, or Mail reminders.

Beep Causes your system to emit an electronic beep

Flash Causes your calendar to flash

Popup Displays a reminder dialog box

Mail Sends electronic mail

6. Edit the default time intervals if necessary.

The time interval fields are active for each reminder you select. They specify the time
before an appointment that the reminder is activated.

7. Choose a privacy option from the Privacy menu.

Others See Time Only The default – displays only the time of an appointment so
others can see you’re busy

Others See Time and Text Displays the time and text of an appointment in your calendar

Show Nothing Displays nothing about an appointment in your calendar for
maximum privacy

8. Click Apply to apply the new defaults to all future appointments.
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9. Click Cancel to close the Calendar Options dialog box.

Changing the Display Settings
You can customize many parts of the Calendar display:

� Determine the initial calendar that displays
� Set time boundaries
� Set the default view

� To Set the Initial Calendar Displayed
You can set Calendar to display a calendar other than your own when you first start it.

1. Choose Options from the File menu

The Calendar Options dialog box is displayed.

2. Choose Display Settings from the Category menu.

3. Double-click in the Initial Calendar View field and type calendar-name@hostname for
the calendar you want to view each time you start Calendar.

4. Click Apply.

5. Click Cancel to close the Options dialog box.

� To Set the Time Boundaries on Day and Week Views
Time boundaries are the earliest and latest hours you want displayed in your calendar.

1. Choose Options from the File menu.

2. Choose Display Settings from the Category menu.

3. Move the Begin and End sliders to adjust the earliest and latest hours you want
displayed on your calendar.

4. Select 12 Hour or 24 Hour time display.

5. Click Apply.

6. Click Cancel to close the Options dialog box.
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� To Set the Default Calendar View
Calendar displays the default Calendar view each time you start it. The initial default
view is by month. You may want to set the default to the view you use most often,
such as Week view.

1. Choose Options from the File menu.

2. Choose Display Settings from the Category menu.

3. Select Day, Week, Month, or Year from the Default View options.

4. Click Apply.

5. Click Cancel to close the Options dialog box.

Changing Access and Permissions
You can set access to your calendar, controlling what others can do in your calendar.
To determine whether you have access to other calendars, see “To Determine Whether
You Have Access to Other Calendars” on page 361.

� To Grant Access to Your Calendar
1. Choose Options from the File menu.

2. Choose Access List and Permissions from the Category menu.

The Access List and Permissions dialog box is displayed.

Note – Depending on the version of your calendar, your Access List and Permissions
dialog box may look different than the one pictured in Figure 13–1. If so, go to Figure
13–2 and follow the instructions after that figure.
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FIGURE 13–1 Access List and Permissions dialog box – Version 1

3. In the User Name field, type username@hostname for the user to whom you want to
grant access. To grant access to everyone, type world in the User Name field.

The default permission is for browse access only.

4. Select Browse, Insert, and/or Delete permissions.

Browse The default – enables others to see information in your calendar

Insert Others can add appointments or To Do items to your calendar

Delete Others can delete appointments or To Do items from your calendar
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5. Click Add Name to add username or world to the Access list with the permissions
you’ve chosen.

Note – Individual user access overrides world access; if everyone (world) has browse
access only and user X has browse and insert access, user X can browse and insert
entries in the current calendar.

6. To grant the selected access and close the dialog box, click OK.

To grant the selected access and leave the dialog box displayed, click Apply.

To erase your changes and leave the dialog box displayed, click Reset.

To erase your changes and close the dialog box, click Cancel.

Note – If your Access List and Permissions dialog box resembles Figure 13–2 below,
follow the instructions after the figure.

FIGURE 13–2 Access List and Permissions dialog box – Version 2

7. In the User Name field, type username@hostname for the user to whom you want to
grant access. To grant access to everyone, type world in the User Name field.

The default permission is for view access to public appointments only.
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8. Select View, Insert, or Change permissions and Public, Semiprivate, or Private
access rights.

Permissions control whether others can perform specific operations on your calendar.
You can choose more than one permission.

Access rights control the specific types of appointments others can perform operations
on.‘

Public Enables another user to display the time and text of your appointments
marked Others See Time and Text

Semiprivate Enables another user to display the time and text of your appointments
marked Others See Time Only

Private Enables another user to display the time and text of your appointments
marked Others See Nothing

9. Click Add to add username or world to the Access list with the permissions and
access rights you’ve chosen.

Note – Individual user access overrides world access; if everyone (world) has browse
access only, and user X has browse and insert access, user X can browse and insert
entries in the current calendar.

10. To grant the selected access and permissions and close the dialog box, click OK.

To grant the selected access and permissions and leave the dialog box displayed, click
Apply..

To erase your changes and leave the dialog box displayed, click Reset.

To erase your changes and close the dialog box, click Cancel.

� To Deny Access to Your Calendar
1. Choose Options from the File menu.

2. Choose Access List and Permissions from the Category menu.

3. Select the user to whom you want to deny access in the Access list.

4. Click Remove Name (Calendar data version 3, Figure 13–1) or Delete (Calendar data
version 4, Figure 13–2) to remove the user from the Access list.

5. To remove access for the specified user and close the dialog box, click OK.

To remove access for the specified users and leave the dialog box displayed, click
Apply.
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To erase your changes and leave the dialog box displayed, click Reset.

To erase your changes and close the dialog box, click Cancel.

� To Change the Printer Settings for Future Print Jobs
To print a Calendar view or appointment or To Do list using the default printer
settings, see “To Print Current Day, Week, Month, or Year Views” on page 359. To
change the printer settings for future print jobs:

1. Choose Options from the File menu.

The Options dialog box is displayed.

2. Choose Printer Settings from the Category menu.

The Printer Settings dialog box is displayed.

3. Select Printer or File.

4. Type the name of your default printer.

5. Edit the Options field to specify print command-line options, if any.

For example, to save paper, you may want to specify -o nobanner to suppress
header pages.

6. Edit the page dimensions or position, if necessary.

7. Edit the number of units, if desired.

For example, if you are printing Week view and you set Units to 2, you will print the
current week and the next week.

8. Edit the number of copies if you want more than one.

9. Choose the desired privacy option for the information you want printed.

See Step 7 of “To Change Appointment Editor Defaults” on page 366 for privacy
options.

10. To save your changes and close the dialog box, click OK.

To save your changes and leave the dialog box displayed, click Apply.

To erase your changes and leave the dialog box displayed, click Reset.

To erase your changes and close the dialog box, click Cancel.
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� To Change the Date Format
1. Choose Options from the File menu.

2. Choose Date Format from the Category menu.

3. Choose the desired date order option.

4. Choose the desired date separator.

5. To save your changes and close the dialog box, click OK.

To save your changes and leave the dialog box displayed, click Apply.

To erase your changes and leave the dialog box displayed, click Reset.

To erase your changes and close the dialog box, click Cancel.

� To Change the Default Time Zone
You can set Calendar to view your or another calendar’s appointments in a time zone
other than your local one.

1. Choose Time Zone from the View menu.

2. Choose the Custom Time setting.

3. In the Hours field, edit the number of hours before or after Greenwich Mean Time
that you want your calendar set to.

For example, to synchronize your calendar for Pacific Standard Time, choose GMT+8
hours. For Finland, choose GMT-2 hours. For Japan, choose GMT-9 hours. You may
have to adjust by one hour for daylight, or summer, time.

4. To revert to your own time zone, click the My Time setting in the Time Zone dialog
box.

5. Click OK to apply changes and close the dialog box.

Other Calendar Tools
Calendar includes several command-line interface tools:

� sdtcm_admin - Use to create and administer calendars
� sdtcm_convert - Use to convert data format or prune a calendar
� dtcm_editor - Use to edit appointments
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� dtcm_lookup - Use to view calendar appointments
� dtcm_insert - Use to insert calendar appointments
� dtcm_delete - Use to delete calendar appointments

sdtcm_admin
Use sdtcm_admin from the command line to create and administer calendars. This
tool can be used to add or remove a calendar on a local system or remotely on a host
on the network. Use sdtcm_admin to list calendars that exist on a host, or to grant
and revoke access to users to a specific calendar. Options to sdtcm_admin include:

-l Lists calendars on your system in a single column

-h Lists calendars on other hosts

-a Adds a new calendar to a system (by default, login@localhost)

-c Add a named calendar to a system

-d Delete a calendar from a system (by default, removes)

See the sdtcm_admin(1) man page for more details and examples of the other
options.

Examples
To list calendars on your system:

% sdtcm_admin -l

kasso

vacation

test

foobar

sleepy

To list calendars on another host:

% sdtcm_admin -l -h totoro

ytso

root

test
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To add a calendar with your login name to the host you are logged in to:

% sdtcm_admin -a

By default the -a option will create the calendar <login>@<localhost>. Other calendars
can be created on the host by using the -c option.

To create the calendar buildschedule on the local host, aha:

% sdtcm_admin -a -c buildschedule@aha

To create the calendar sleepy on the remote host totoro:

% sdtcm_admin -a -c sleepy@totoro

To remove the calendar with your login name from the host you are logged in to:

% sdtcm_admin -d

By default the -d option will remove the calendar <login>@<localhost>. For example, if
kasso is logged into aha and runs sdtcm_admin -d with no other options, the
following response will be displayed:

Delete the calendar kasso@aha [y/n]?

Respond y or n.

To remove the calendar old on the host aha:

% sdtcm_admin -d -c old@aha

You can only remove calendars for which you have Owner privileges. If you attempt
to remove a calendar that you do not own, you will see an error message:

Delete the calendar old@aha [y/n]? y

sdtcm_admin: Could not delete calendar because: Permission denied.

sdtcm_convert
Usesdtcm_convert to convert Calendar data format, prune a calendar, or check data
integrity. Use it to convert version 3 (OpenWindows) calendar data format to version 4
(the extensible calendar data format), and vice versa.
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Note – sdtcm_convert is automatically invoked when performing an OS upgrade to
2.6.

sdtcm_convert must be run by superuser or the owner of the calendar. Superuser
can run sdtcm_convert on any calendar; a regular user can only run
sdtcm_convert on his or her own calendar. Note that sdtcm_convert can be used
only on calendars located on the local host.

The version 3 data format is fixed and limited. In order to take advantage of the new
features supported by the calendar API, version 3 calendars should be converted to
the version 4 data format.

Note – OpenWindows Calendar Manager does not support the version 4 data format.
If you need to switch back to OpenWindows Calendar Manager and you have a
version 4 calendar, you should convert your calendar to the version 3 data format
before switching the server. Be aware, however, that data not supported in the version
3 data format (for example, all calendar attributes except the access list, entry
attributes such as date of creation or date of last update, and so on) will be lost.

Options for sdtcm_convert are listed and described below.

� Use the -v option to specify the data version of output.

Valid values are 3 (OpenWindows calendar data format) and 4 (the extensible data
format). If this option is not specified, the output data version is the same as that of
the specified calendar and no data conversion is done.

Note – The data version of a calendar is displayed in the About Calendar dialog box
of Calendar, accessible from the Help menu.

� Use the -s option to specify the date to prune the calendar.

Appointments starting before the specified date are pruned. One-time
appointments with a start date on or after the specified date are included.
Repeating appointments are truncated such that the first appointment in the
sequence will happen on or after the specified date and those sequences that end
before the specified date are removed. If this option is not specified, no
appointments are pruned.

� Use the -c option to specify the value for the character set attribute.

The value should be a valid Sun-specific locale name (C or de, for example). The
CDE platform-independent equivalent of the locale name is stored in the calendar.
If this option is not specified, the CDE platform-independent name of the current
locale associated with the process is used. This option is used when converting
version 3 data to version 4 data and is ignored otherwise.
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� Use the -d option to specify the directory in which to save the original calendar file
which is saved in a filed called calorig.calendar.

If this option is not specified, the backup file is placed in the
/var/spool/calendar directory.

See the sdtcm_convert(1) man page for more details and examples of usage.

Examples
To convert the calendar user1 to version 4 data format and also prune the calendar:

% sdtcm_convert -v 4 -s 1/1/94 user1

To check data integrity of the calendar user1:

% sdtcm_convert user1

If no option is specified, sdtcm_convert will check the calendar file for data
integrity.

dtcm_editor
Use the standalone Appointment Editor to create a Calendar-formatted appointment
and save it in a file.

1. Type dtcm_editor filename at the command line.

The standalone Appointment Editor is displayed.
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2. Type a date in the Date field.

Remember to use the date format set in the Date Format dialog box.

3. Choose the Start and End times for the appointment.

4. Type a description of the appointment in the What field.

5. Choose a frequency for the appointment from the Occurs menu.

6. Click Save to write the appointment contents to the file you specified on the
command line.

dtcm_lookup
Use dtcm_lookup to view appointments on your calendar.

1. Type dtcm_lookup at the command line to view appointments for the default view.

For example, if Day view is the default, to view appointments for the current day:

system% dtcm_lookup
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Appointments for Monday October 31, 1994:

1) Halloween

2) 2:30pm-3:30pm Staff meeting

3) 6:00pm Trick-or-treating

4) 7:15pm-10:00pm Choir practice

2. To choose the calendar, date, or range of time for which to look up appointments,
use the following syntax:

dtcm_lookup [-c calendar] [-d date] [-v view]

For example:

system% dtcm_lookup -c hamilton@artist -d 10/28/1994 -v day

Appointments for Friday October 28, 1994:

1) 9:00am-10:00am Project meeting

2) 1:30pm-2:00pm Testing

dtcm_insert
Use dtcm_insert from the command line to insert appointments on your calendar.
For example:

system% dtcm_insert -d 11/1/1994 -s 11:30am -e 12:30pm -w workout

Appointments for Tuesday November 1, 1994:

1) 10:00am-11:00am one-on-one

2) 11:30am-12:30pm workout

3) 12:30pm-1:00pm eat lunch

Calendar automatically prints the appointments scheduled so you can see that the
new appointment was inserted.

dtcm_delete
Use dtcm_delete from the command line to delete appointments from your
calendar. For example:

system% dtcm_delete -d 11/1/1994

Appointments for Tuesday November 1, 1994:
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1) 10:00am-11:00am one-on-one

2) 11:30am-12:30pm workout

3) 12:30:pm-1:00pm eat lunch

Item to delete (number)? 3

Appointments for Tuesday November 1, 1994:

1) 10:00am-11:00am one-on-one

2) 11:30am-12:30pm workout

When you don’t want to delete any more items, press Return.

Using Federated Naming with Calendar
If your site uses Federated Naming Service (FNS), calendar naming can be location
independent: you can name a calendar without including its host machine. For
example, to name the calendar of user jsmith without FNS, you need to enter
jsmith@hostmachine; with FNS you can enter jsmith alone.

The default behavior of Calendar is unchanged; you can name calendars using the
form username@hostname. To use the new way of naming calendars, you need to set the
resource useFNS. You can turn this resource on either manually by editing your
.desksetdefaults file or through the Display Settings dialog box. (Choose Options
from the File menu and Display Settings from the Category options menu in the
Options dialog box. Click the Calendar Names: Use Federated Naming checkbox and
then click OK.)

Calendar Naming
When the useFNS feature is on, you can use both the old and new ways of naming
calendars. When you choose Show Other Calendar from the Browse menu, you can
enter simply rosanna to browse user rosanna’s calendar. Or you could enter
rosanna@alto to name the calendar directly. The new names can be entered
wherever a calendar name is expected (Show Other Calendar, Initial Calendar View in
Display Settings Options, Browse list editor, Browse short list, and so on).

For location-independent naming to work, there must be a name space that holds
registered information about where the calendars are.
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Calendar Registration
When you run Calendar with useFNS set on, Calendar will automatically attempt to
register your calendar into the name space. Once it has been registered, someone can
use just your username to browse your calendar. If you subsequently move your
calendar, change the User Calendar Location in the Display Settings dialog box and
the registered calendar address in the name space will automatically be updated the
next time you restart Calendar. You can also update the information in the name space
outside Calendar using the FNS command, fnbind.

In an NIS environment, auto-registration is not supported because NIS does not
support dynamic updates of arbitrary data. In addition, fnbind only succeeds when
run by root on the NIS master.

Naming Service Dependencies
In Solaris 2.5 Operating Environment or compatible versions, FNS works with NIS+
only.

Build Dependencies
For CDE developers that build dtcm, you need to have the appropriate FNS package
installed on the build machine. For a Solaris 2.5 or earlier target, you need to have the
Solaris 2.5 SUNWfns package. These packages can be picked up from the OSNet gates
(/ws/on297-gate/packages, for example) or from the packages directory of a
specific Solaris release.

Runtime Dependencies
If dtcm cannot locate the appropriate SUNWfns package at runtime, it will simply not
use FNS. Calendar can always run on a system without the SUNWfns package.
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CHAPTER 14

Using Terminal

A terminal emulator displays a window that enables you to enter operating system
commands, use UNIX commands, and copy and paste text.

� “Default Desktop Terminal Emulator” on page 383
� “Using a Terminal Window” on page 388
� “Running dtterm on Another System” on page 389
� “Customizing dtterm” on page 391
� “dtterm Global Options” on page 393
� “dtterm Terminal Options” on page 398
� “Terminal Control Characters” on page 402
� “Changing the Default Terminal Emulator” on page 403

Note – Illustrations shown in this chapter were taken from the default CDE screens.
Your screens may be different from the illustrations if you or your system
administrator have customized them.

Default Desktop Terminal Emulator
The default terminal emulator on the desktop is dtterm. The dtterm terminal
emulator emulates that portion of the VT220 terminal that is consistent with ANSI and
ISO standards.

The dtterm command-line prompt is a special character that is displayed in the left
margin of your terminal emulator. It can be a ‘‘%’’, ‘‘<‘’, ‘‘$’’, or another special
character. A small box or bar, called a cursor, shows where characters will appear in the
window when you type something on the keyboard.
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Starting a Terminal Window
There are several ways you can start a Terminal window:

� From the Front Panel
� From Application Manager
� From File Manager
� From the Window Menu of Another Terminal
� From Address Manager with a host selected

� To Start a Terminal Window from the Front Panel
� Select the This Host control on the Hosts subpanel.
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Activity indicator

Hosts
subpanel

1. Or, click the activity indicator (globe) control on the workspace switch.

The Go dialog box is displayed.

2. Type an IP address such as 129.156.120.179 or the @ symbol followed by a
hostname (for example, @jupiter) for the host on which you want to run the
terminal session.

3. Click OK.

� To Start a Terminal Window from Application Manager
1. Click the Desktop_Apps control on the Front Panel.

2. Double-click the Terminal icon (you may have to scroll down to see it).
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� To Start a Terminal Window from File Manager
1. Click the File Manager control on the Front Panel.

The File Manager window appears.

2. Choose Open Terminal from the File Manager File menu.

386 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



� To Start a Terminal Window from the Window Menu of
Another Terminal

� Choose New from the Window menu of an existing Terminal window.

An exact replica of the Terminal window appears.

� To Start a Terminal Window from Address Manager with a
host selected
� With the IP address of the required host displayed in the scrolling pane of Address

Manager, choose Terminal from the Actions menu.

� To Close a Terminal Window
1. Type exit at the command line and press Return.

2. Or, choose Exit from the Terminal Window menu.

3. Or, choose Close from the Window menu (displayed through the button at the
upper left of the window frame).
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Note – Typing exit at the command line is the preferred method of closing a
Terminal window. The other two methods don’t terminate any background processes
you may have started, which can sometimes cause problems.

If you started the Terminal window from a command line, you can stop it by pressing
Control+C in the window from which you started it.

Using a Terminal Window
The Terminal window provides a means to start other applications, enter UNIX
commands, and copy and paste text between and within windows.

� To Start Applications in a Terminal Window
� Type the command to start the application at the command-line prompt.

The general syntax for starting an application is:

application [options] &

application—the application name

options—a list of optional information to be passed to the application

&—indicates that the application runs in the background; that is, you can continue to
use the Terminal window while the application is also running

Refer to the man page or other documentation for each application to find the
command and options to use for that application.

For example, to start a digital clock from the command line, type:

xclock -digital &

� To Enter a Command
� Type the command and press Return.

For example, to obtain a list of the files in the current directory, type:
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ls

To obtain a list of the files in the current directory and print it on the default printer,
type:

ls | lp

� To Copy and Paste Text
1. Use mouse button 1 and drag over the text you want to move.

The text appears highlighted.

2. Release mouse button 1 after all the text you want is highlighted.

The highlighted text is copied to an internal clipboard. The text is not removed from
your original source.

3. Click mouse button 2 where you want to insert the text.

A copy of the contents of the clipboard is pasted at the location you indicated. You can
make additional copies by repeating the above steps.

� To Resize the Window Contents
When you change the size of a Terminal window, applications running in the window
may not know about the resizing. Use this procedure to resize the application’s
output.

� To resize the window contents, type the following at the command-line prompt:

eval ‘resize‘

Note that resize is enclosed within a set of single close quotation marks rather than
double quotation marks.

Running dtterm on Another System
You can run dtterm on another system through various commands:

� The -display option

� The rlogin command

� The remsh command

Using Terminal 389



� The Terminal menu item in Address Manager (when the remote host is displayed)

Using the -display Option
-display host:display[.screen]

where

host—the name of a valid system on the network.

display—the number of the display on the host.

screen—Optional. The screen within the display. The default is 0.

You can find these values by typing env, and examining the DISPLAY line. The
terminal emulator is running on your system, but the window shows on another
system.

For example, the following command starts a dtterm window on the host computer
named hpcvxdm:

dtterm -display hpcvxdm:0 &

Using rlogin
You can use rlogin in an existing Terminal window to log in to a remote host. Once
the window is acting as a terminal to the remote host, you can run applications there,
redirecting the display back to your system if you desire.

For example, the following command logs onto a system named there, runs the
client xload, and redirects the display back to your original system. Assume your
system is named here.

rlogin there

xload -display here:0

Using remsh
The remsh command starts a shell on a remote host, performs some client activity
(often starting a terminal emulator on that host), and redirects the display back to your
original system if desired.

It has the syntax:

remsh remote -n client -display system:display[.screen]
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where:

remote—the remote host name

client—the program you want to run on the remote host

system:display[.screen]—the host and display on which the results are to be displayed

The remsh command is often used when customizing a menu to access other hosts.

For example, the following command runs xload on the remote host named there,
and directs output back to your system, here.

remsh there -n /usr/bin/X11/xload -display here:0.0 &

Using the Terminal menu item in Address Manager
Address Manager (see Chapter 18) displays details of selected hosts when the Hosts is
selected on the Search menu.

When the details of a remote host are displayed in the scrolling pane, the Terminal
menu item is displayed on the Actions menu. Choosing this menu item runs a
terminal session on the remote host from your local display (see “Performing Actions
on Host Cards” on page 489).

Customizing dtterm
There are several ways in which you can customize dtterm:

� Run it with special options, such as the menu bar and scroll bar

� Run the terminal emulator on another system

� Change global options such as cursor style and background color

� Change terminal options such as keyboard and screen control

Displaying the Menu Bar
By default, dtterm appears with a menu bar. You can remove it if you wish.
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� To Remove the Menu Bar
� Choose Menu Bar from the Options menu.

The menu bar disappears from the dtterm window.

� To Restore the Menu Bar
1. Click mouse button 3 anywhere within the dtterm window.

A pop-up menu appears containing items identical to those of the menu bar.

2. Choose Menu Bar from the Options menu.

The menu bar appears at the top of the dtterm window.

Displaying the Scroll Bar
By default, dtterm appears without a scroll bar.
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� To Display the Scroll Bar
� Choose Scroll Bar from the Options menu.

The scroll bar appears in the dtterm window.

To remove the scroll bar from the window, choose Scroll Bar from the Options menu
again.

dtterm Global Options
There are four areas that you can control from the Global Options dialog box:

� Cursor control
� Color control
� Scroll behavior
� Bell control
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� To display the Global Options dialog box, choose Global from the Options menu.

Cursor Control
You can control three aspects of the dtterm cursor: the cursor style, whether the
cursor blinks, and the blink rate.

� To Determine Cursor Style
1. If the Global Options dialog box is not displayed, choose Global from the Options

menu.

2. Click the Cursor Style button and choose the cursor style option you want:

� Box (the default)
� Underline
� None (the cursor is invisible)
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3. Click OK at the bottom of the Global Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

The changes you make will be visible on existing dtterm windows; you don’t have to
start a new one.

� To Determine Cursor Blinking
The dtterm cursor blinks by default. You can turn off the blinking or change the blink
rate (see “To Set the Cursor Blink Rate” on page 395).

1. If the Global Options dialog box is not displayed, choose Global from the Options
menu.

2. Click the Blinking Cursor button in the Cursor Control section and choose to either
have the cursor blink (Enabled) or not blink (Disabled).

3. Click OK at the bottom of the Global Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

Note that when this option is set to Disabled, the Blink Rate option and text field are
both inactive.

� To Set the Cursor Blink Rate
The blink rate determines how often the dtterm window’s cursor blinks. The default
blink rate is 250 milliseconds. To change the cursor blink rate:

1. If the Global Options dialog box is not displayed, choose Global from the Options
menu.

2. In the Blink Rate text field, type the value in milliseconds that you want.

3. Click OK at the bottom of the Global Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

The changes you make will be visible on existing dtterm windows; you don’t have to
start a new one.
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� To Switch Foreground and Background Colors (Color
Control)

1. If the Global Options dialog box is not displayed, choose Global from the Options
menu.

2. Click the Window Background button in the Color Control section and choose the
color display you want:

� Normal displays the foreground and background colors normally.
� Inverse switches the foreground and background colors.

3. Click OK at the bottom of the Global Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

� To Determine Scroll Behavior
Smooth scrolling displays each line sent to the Terminal window immediately, rather
than storing it in a buffer. This results in scrolling that is more pleasing to the eye, but
is slower. The default is smooth scrolling disabled. To enable smooth scrolling:

1. If the Global Options dialog box is not displayed, choose Global from the Options
menu.

2. Click the Smooth Scrolling button and choose the type of scrolling you want:

� Disabled (the default) disables smooth scrolling.
� Enabled starts smooth scrolling.

3. Click OK at the bottom of the Global Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

Bell Control
There are three types of Bell Control options in dtterm:

� Bell type
� Margin warning
� Margin distance
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� To Set the Bell Type
1. If the Global Options dialog box is not displayed, choose Global from the Options

menu.

2. Click the Bell Type button in the Bell Control section and choose the type of bell
you want:

� Audible (the default) causes the bell to make a sound.
� Visible causes the bell to blink the background color.

3. Click OK at the bottom of the Global Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

� To Set the Margin Warning
The Margin Warning option is used in conjunction with the Margin Distance option to
warn the user either visually or aurally that the cursor is within a specified distance
from the right margin. To set the margin warning:

1. If the Global Options dialog box is not displayed, choose Global from the Options
menu.

2. Click the Margin Warning button in the Bell Control section.

3. Choose Enabled or Disabled.

4. Click OK at the bottom of the Global Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

Note that the Margin Distance option (see “To Set the Margin Distance” on page 397)
is inactive when Margin Warning is disabled.

� To Set the Margin Distance
The Margin Distance option is only active when the Margin Warning option is set to
Enabled. You set the distance from the right margin of the dtterm window at which
you want the bell to ring (or appear, if Bell Type is set to Visible). The default value is
10 characters.

To change the distance:

1. If the Global Options dialog box is not displayed, choose Global from the Options
menu.
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2. Click inside the Margin Distance text field in the Bell Control area and type the
number of characters from the right margin of the window at which you want the
margin warning to be issued.

3. Click OK at the bottom of the Global Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

The changes you make will be visible on existing dtterm windows; you don’t have to
start a new one.

dtterm Terminal Options
There are two areas that you can control from the Terminal Options dialog box:

� Keyboard control
� Screen control

� To display the Terminal Options dialog box, choose Terminal from the Options
menu.

Changes you make through the Terminal Options dialog box are effective on existing
dtterm windows; you don’t have to start a new one.
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Keyboard Control
You can control four aspects of your keyboard through the Terminal Options dialog
box:

� Cursor key mode
� Keypad mode
� Newline sequence
� User function keys

� To Set the Cursor Key Mode
1. If the Terminal Options dialog box is not displayed, choose Terminal from the

Options menu.

2. Click the Cursor Key Mode button in the Keyboard Control section and choose the
mode you want:

� In Normal mode (the default), the cursor keys move the cursor in the specified
direction.

� In Application mode, the cursor keys generate escape sequences that the
application uses for its own purpose.

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

� To Set the Keypad Mode
The keypad mode determines the behavior of keys on the numeric keypad.

1. If the Terminal Options dialog box is not displayed, choose Terminal from the
Options menu.

2. Click the Keypad Mode button in the Keyboard Control section and choose the
mode you want:

� In Numeric mode, when keys on the numeric keypad are pressed, the
corresponding numeral is displayed in the dtterm window.

� In Application mode, keys pressed on the numeric keypad generate escape
sequences that the application uses for its own purpose.

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.
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� To Determine the Newline Sequence
The Newline Sequence option determines how carriage returns at the ends of lines are
treated.

1. If the Terminal Options dialog box is not displayed, choose Terminal from the
Options menu.

2. Click the Newline Sequence button in the Keyboard Control section and choose the
mode you want:

� Return Only (the default) generates only a carriage return.

� Return/Line Feed generates both a carriage return and a line feed.

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

� To Set the User Function Keys
The User Function Keys option either locks or unlocks (the default) the user function
keys.

1. If the Terminal Options dialog box is not displayed, choose Terminal from the
Options menu.

2. Click the User Function Keys button in the Keyboard Control section and choose
Locked or Unlocked (the default).

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

Screen Control
There are three aspects of screen control in a dtterm window:

� 132 column switching
� End-of-line wrapping
� Reverse end-of-line-wrapping
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� To Set 132-Column Switching
This option corresponds to the following dtterm command-line options and
resources:

� -132
� +132
� c132

1. If the Terminal Options dialog box is not displayed, choose Terminal from the
Options menu.

2. Click the 132 Column Switching button in the Keyboard Control section and choose
the mode you want:

� Disabled (the default) does not change the display when an application switches to
132 columns.

� Enabled automatically enlarges the dtterm window to display 132 columns when
the application switches to 132 columns.

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

� To Set End-of-Line Wrapping
This option determines whether text wraps at the end of a line. It corresponds to the
following dtterm command-line options and resources:

� -aw
� -+aw
� autoWrap

1. If the Terminal Options dialog box is not displayed, choose Terminal from the
Options menu.

2. Click the End-of-Line Wrapping button in the Keyboard Control section and choose
the mode you want:

� Enabled means characters automatically wrap to the next line when the end-of-line
is reached.

� Disabled means text does not wrap.

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.
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� To Set Reverse End-of-Line Wrapping
This option determines the behavior of backspacing at the end of a line. It corresponds
to the following dtterm command-line options and resources:

� -rw
� -+rw
� reverseWrap

1. If the Terminal Options dialog box is not displayed, choose Terminal from the
Options menu.

2. Click the Reverse End-of-Line Wrapping button in the Keyboard Control section
and choose the mode you want:

� Enabled means backspace characters automatically wrap to the next higher line
when the end-of-line is reached.

� Disabled (the default) means no wrapping occurs.

3. Click OK at the bottom of the Terminal Options dialog box or press Return to save
your selection and exit the window.

To save your selection and retain the window, click Apply.

Terminal Control Characters
Because dtterm only emulates a terminal, your control characters might not be what
you are used to on a physical terminal. The ttyModes resource enables you to set
control characters for your terminal emulator.

By default, Login Manager sets the control characters listed in Table 14–1.

TABLE 14–1 Terminal Control Characters

Control Name Character Definition

erase Control+H Backspace erases characters

intr Control+C Interrupt: Cancel the current operation and
redisplay the command-line prompt.

kill Control+U Stop an operation or application.

start Control+Q Accept keyboard input: Used to continue an
application that has been paused.
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TABLE 14–1 Terminal Control Characters (Continued)
Control Name Character Definition

stop Control+S Do not accept keyboard input: Used to pause an
application.

swtch Control+@ Switch between layers in a shell.

For example, to interrupt an operation in progress, you press Control+C.

The syntax for the ttyModes resource is:

ttyModes: Control+C name

where name is the control, and C is the character. (^ is another way of expressing
Control.) For example, the default value of ttyModes describing the preceding list is:

ttyModes: erase ^H intr ^C kill ^U start ^Q stop ^S swtch ^@

� To Set Terminal Control Characters
1. Use the EditResources action to update the ttyModes resource.

2. Choose Restart Workspace Manager from the Workspace menu.

Changing the Default Terminal Emulator
There are several other terminal emulators you can use in addition to dtterm. You
can start most of them from an existing terminal emulator command line; however, if
you want to consistently use a terminal emulator other than dtterm, you should
change the default assignment. See Solaris Common Desktop Environment: Advanced
User’s and System Administrator’s Guide for more information.
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CHAPTER 15

Using Icon Editor

Icon Editor is a tool for creating both bitmap and pixmap image files for use as icons
or backdrops.

� “Basic Drawing Tasks” on page 407
� “Saving Icon Files” on page 411
� “Color Usage” on page 412
� “Advanced Drawing Tasks” on page 413

Introducing Icon Editor
Icon Editor enables you to create and edit images in two formats, described in Table
15–1.

TABLE 15–1 Icon Formats

Format Description File Name

X pixmap (XPM) Multicolor images that include static and dynamic
colors

*.pm

X bitmap (XBM) Two-color images limited to a foreground and
background color (used for black and white icons)

*.bm
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Actual size 
icons

Work area

Drawing tools

FIGURE 15–1 Icon Editor main window

You create images by selecting drawing tools and colors, and using them in the work
area. As you draw, Icon Editor displays an actual-size copy of your icon in both
formats. You need to consider the two-color version of the icon even if you are
drawing an image for use on color systems, because icons may revert to two colors if
there are not enough free colors available on the workspace.

For information on designing icons, read the Visual Design chapter in Common Desktop
Environment: Style Guide and Certification Checklist.

Startup
To start Icon Editor:
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1. Open Application Manager and display the Desktop_Apps folder therein.

2. Double-click Icon Editor.

Icon Editor starts with an empty drawing work area.

You can also start Icon Editor and have it load an icon into the work area in one of the
following ways:

� In a File Manager view, locate the icon file and double-click it to open it. (The
default action for pixmap and bitmap files runs Icon Editor and loads the file.)

� Type the following command in a Terminal window:

dticon -f filename &

Note – If the path /usr/dt/bin has not been set in your .cshrc file, then type
/usr/dt/bin/dticon to run Icon Editor from the command line.

Basic Drawing Tasks
This section describes how to create and edit an icon and how to use the Icon Editor
drawing tools.

� To Open an Existing Icon
1. Choose Open from the File menu.

If you have unsaved changes, Icon Editor warns you that your changes will be lost by
loading another icon. Click Cancel to cancel the Open command. Click OK if you
don’t want to save your changes.
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2. Type the name of the file you want to load in the Enter file name field, or select the
icon file you want to load from the Files section of the Open File dialog box.

3. Click Save.

Note – When you load a file, the Output Format (in the Options menu) is
automatically set to the format of the file you load.

You can also open an existing icon by double-clicking the icon file in File Manager.

� To Start a New Icon
� Choose New from the File menu.

If you have unsaved changes, Icon Editor warns you that your changes will be lost by
starting a new icon. Click Cancel to cancel the New command or click OK if you don’t
want to save your changes.

Icon Editor clears the work area and resizes it to the default size (32x32).

If you have an icon already loaded, you can choose Clear Icon from the Edit menu to
start a new icon with the same size and name as the previously loaded icon.

� To Clear an Icon
1. Save your current icon, if necessary.

2. Choose Clear Icon from the Edit menu.

The entire icon drawing work area is cleared.

� To Draw an Image
1. Select one of the drawing tools (listed in Table 15–2).

2. Select a color (static color, static gray, or a dynamic color).

3. Begin drawing with the tool you’ve selected.

More details on drawing with each tool are provided below.
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Drawing Tools
The drawing tools area of Icon Editor is shown in Figure 15–2.

Currently selected tool

Pencil

Line

Rectangle

Circle

Eraser

Fill Solids check box

Flood

Open Polygon

Closed Polygon

Ellipse

Selection

FIGURE 15–2 Icon Editor drawing tools

TABLE 15–2 Using the Drawing Tools

Tool Purpose Action

Pencil For drawing freehand lines
and individual pixels.

Press and hold to draw freehand lines.

Line For drawing straight lines. Press and hold to stretch the line.
Release to draw the line.

Rectangle For drawing solid or outlined
rectangles.

Press and hold to stretch the outline of
the rectangle. Release to draw the
rectangle.

Circle For drawing solid or outlined
circles.

Point to where you want the center of
the circle, press and hold, drag to the
desired size, and release.

Eraser For erasing large areas of the
image.

Press and hold; then drag over the area
to erase.

To erase individual pixels, select the
Pencil tool and the Transparent color.
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TABLE 15–2 Using the Drawing Tools (Continued)
Tool Purpose Action

Flood For flooding a region of one
color with the selected color.

Click any pixel within the region to be
flooded. The selected pixel and all
adjacent pixels of the same color are
recolored with the selected color. The
filled region extends in all directions,
bounded only by pixels of a different
color.

Open Polygon For drawing connected
straight lines.

Click the starting point; then click for
each segment.

Double-click to end the last segment.

Closed Polygon For drawing connected
straight lines, where the first
line and last line are
connected to form a closed
polygon.

Click the starting point; then click for
each segment.

Double-click to end the last segment.

Ellipse For drawing solid or outlined
ovals.

Press and hold, drag to the desired size
and shape, and release.

Selection For selecting an area to work
on. Several commands in the
Edit menu require an area to
be selected.

Point to the corner pixel of the region to
be selected, press and hold, drag to the
desired region, and release.

Fill Solids For changing the rectangle,
circle, ellipse, and closed
polygon tools to draw filled-in
shapes instead of outlines.

Select the check box to automatically
draw filled-in shapes. Deselect the check
box to return the tools to drawing
outlines.

� To Undo a Drawing Operation
� Choose Undo from the Edit menu.

Only the single, most recent change can be undone.
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Saving Icon Files
When saving icon files, you must use the appropriate file-name suffix. There are two
suffixes appended to the base name of the icon, one for size and one for format. Many
icon names are in these general forms:

basename.size.format
basename.format

The basename is the image name used to reference the image.

size is a single letter indicating the standard size of the icon: l for large (48x48 pixels),
m for medium (32x32), s for small (24x24), or t for tiny (16x16). (“Icon Size
Conventions” on page 411) If your icon is not a standard size, you can omit this letter.

format is pm for X pixmaps (the color icon format) or bm for X bitmaps (the
monochrome icon format).

If you save an icon in XBM format that has transparent color in it, an icon mask file is
also saved. The icon mask file is named basename.size_m.format. If you move the icon
you saved to another folder, you must also move the mask file.

For example, suppose you specify an icon named mail for a file type you’ve written.
If you have a color display and have set the File Manager preferences to use tiny icons,
the assumed icon name is mail.t.pm. If it had transparent color and you saved it in
XBM format, two files would be created: mail.t.bm and mail.t_m.bm.

Icon Size Conventions
Table 15–3 lists the recommended sizes—in pixels, width x height—for creating new
icons for use in CDE. Icons can be up to 256x256.

TABLE 15–3 Icon Size Recommendations

Usage High Medium Low

File Manager (Large) 32x32 32x32 32x32

File Manager (Small) 16x16 16x16 16x16

Application Manager (Large) 32x32 32x32 32x32

Application Manager (Small) 16x16 16x16 16x16

Front Panel 48x48 48x48 32x32
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TABLE 15–3 Icon Size Recommendations (Continued)
Usage High Medium Low

Front Panel subpanels 32x32 32x32 16x16

Minimized windows 48x48 48x48 32x32

Workspace 32x32 32x32 32x32

� To Save the Icon
1. Choose an output format from the Options menu:

� XBM for two-color X bitmap format
� XPM for multicolor X pixmap format (the default)

2. Choose Save from the File menu.

If the icon is unnamed or you choose Save As, Icon Editor prompts you for a file
name. Type the name and then click Save.

Note – If you save an icon in XBM format that has transparent color in it, an icon
mask file is also saved. The icon mask file is named basename.size_m.format. If you
move the icon you saved to another folder, you must also move the mask file.

� To Save the Icon with a New Name
1. Choose Save As from the File menu.

2. Type (or select) the file name under which you want to save the icon file.

3. Click Save.

If the file already exists, you will need to click OK in the warning dialog box to
overwrite the existing file.

Color Usage
Icons in the desktop use a palette of 22 colors:

� Eight static grays

� Eight static colors: red, blue, green, cyan, magenta, yellow, black, and white
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� Five dynamic colors: Foreground, Background, TopShadow, BottomShadow, and
Select

� A transparent “color” that allows the background to show through

These colors are the default colors in Icon Editor. This set of colors provides a
reasonable palette with which to create icons. This limited palette was chosen to
maximize the attractiveness and readability of icons without using an unnecessary
number of colors.

The dynamic colors represent the colors used to display the application on which your
icon will appear. If your icon appears in File Manager, File Manager determines what
the background color is. Dynamic colors are useful for icons that you want to change
color as different color palettes are selected in Style Manager. Dynamic colors are also
useful if the icon will be used in more than one place and you want it to use the colors
of the application where it appears.

TopShadow and BottomShadow can be used for drawing a shadow under your icon.
You can use these colors to make the icon appear to be etched into the surface. This is
only recommended for Front Panel style icons.

The transparent color is useful for creating icons that have the illusion of being
nonrectangular, since it allows the color behind the icon to show through. If your icon
does not fill the entire bounding box, you should fill the unused area with the
transparent color.

Advanced Drawing Tasks
After you become familiar with the basic drawing facilities in Icon Editor, you may
want to try some more advanced operations. Many of these operations require you to
first select an area of the icon. This is done using the Selection tool (next to the eraser).

When an area of the icon is selected, you can:

� Cut, copy or move it
� Resize (scale) it
� Flip it (horizontally or vertically)
� Rotate it (right or left)

� To Select an Area of the Icon
1. Click the Selection tool (next to the eraser).

Using Icon Editor 413



2. Drag a box around the area you want to select.

When an area is selected, a box flashes around the selected area.

� To Cut a Region of the Icon
1. Select the area of the icon you want to cut using the Selection tool.

2. Choose Cut from the Edit menu.

When you cut a portion of an icon, the exposed area becomes transparent (that is, filled
in with the Transparent color).

Note that after cutting a region, you can paste it back into the icon by choosing Paste
from the Edit menu.

� To Copy a Region of the Icon
1. Select the area of the icon you want to copy using the Selection tool.

2. Choose Copy from the Edit menu.

3. Choose Paste from the Edit menu.

4. Position the outline where you want to paste the copy, and then click.

You may repeat steps 3 and 4 as many times as you like to paste multiple copies of the
region you copied.

� To Move a Region of the Icon
1. Select the area of the icon you want to move using the Selection tool.

2. Choose Cut from the Edit menu.

3. Choose Paste from the Edit menu.

4. Position the outline where you want to paste the area, and then click.

You may repeat steps 3 and 4 as many times as you like to paste multiple copies of the
region you cut.
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� To Rotate Part of the Icon
1. Select the area of the icon you want to rotate using the Selection tool.

2. Choose Rotate then Left or Rotate then Right from the Edit menu.

3. Position the outline where you want to paste the rotated area, and then click.

� To Flip (Mirror) Part of the Icon
Flipping an area creates a pixel-for-pixel mirror image of the selected area.

1. Select the area of the icon you want to flip using the Selection tool.

2. Choose Flip then Vertical or Flip then Horizontal from the Edit menu.

Resizing Icons
You can resize the entire icon or a region of the icon.

� To Resize the Current Icon
1. Choose Resize Icon from the Edit menu.

Icon Editor displays a dialog box that prompts for the new size.

2. Edit the current width and height to specify the new size.

3. Click OK.

Note – If you make the icon smaller, the right and bottom edges are clipped off. If you
make the icon larger, the existing image remains in the upper left of the icon.

� To Resize (Scale) a Region of the Icon
1. Select the area of the icon you want to resize using the Selection tool.

2. Choose Scale from the Edit menu.

3. Drag a box that defines the size and shape that you want the scaled image to be.

The size of the box is shown in the upper right area. This determines how the selected
portion of the image will be scaled; it does not determine where to place the results.
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4. Position the outline where you want to paste the scaled copy, and then click.

Hotspots
Bitmap images (XBM format) can be used as special mouse pointer shapes. A hotspot
marks a single pixel within the image that is the true point of the mouse pointer.

� To Add a Hotspot
You can only have one hotspot in an icon.

1. Choose Add Hotspot from the Edit menu.

2. Click the pixel where you want the hotspot.

� To Delete a Hotspot
� Choose Delete Hotspot from the Edit menu.

Screen Captures
You can copy any area from any part of the screen into the Icon Editor. You can copy
(“grab”) a text or graphic that is displayed and load it into the Icon Editor work area.

� To Capture (Grab) a Region of the Display
1. Save your current icon, if necessary.

2. Choose Grab Screen Image from the Edit menu.

3. Drag a box around the portion of the workspace you want to capture (press mouse
button 1, drag, and release).
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Note – Capturing a region of the display could cause the icon to use up some of the
available colors on the desktop.

Modifying the View of an Icon
You can change the view of an icon in the Icon Editor work area by changing the
magnification or using a grid.

� To Hide the Grid
� Choose Visible Grid from the Options menu.

This will hide the grid. Choose Visible Grid from the Options menu again to display
the grid. The grid is displayed by default.

� To Change the Magnification of an Icon
1. Choose Magnification from the Options menu.

2. Choose the Magnification level you want from the submenu.

Using Icon Editor 417



418 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



CHAPTER 16

Using Image Viewer

Use Image Viewer to view, edit, print, and translate the file formats of monochrome
and color images and multiple page documents such as PostScript files. Use the
Snapshot function of Image Viewer to capture snapshots of windows, user-defined
regions, or the entire desktop screen.

� “Starting and Quitting Image Viewer” on page 419
� “Viewing Images” on page 421
� “Editing Images” on page 423
� “Saving Images” on page 427
� “Viewing PostScript Files” on page 428
� “Printing” on page 432
� “Image Viewer File Formats” on page 435
� “Using Snapshot” on page 437

Starting and Quitting Image Viewer
There are several ways to start Image Viewer:

� From the Workspace Programs menu
� From Application Manager
� From the command line
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� To Start Image Viewer from the Workspace
Programs Menu

1. Place the mouse pointer anywhere on the background of the desktop (the
workspace) and click mouse button 3.

The Workspace menu appears.

2. Choose Programs, and then choose Image Viewer from the Programs submenu.

The Image Viewer main window appears.

� To Start Image Viewer from Application Manager
1. Open Application Manager by clicking the Applications icon on the Applications

subpanel of the Front Panel.

2. Double-click Desktop_Apps in the Application Manager window.

The Desktop_Apps group is displayed in Application Manager.

3. Double-click Image Viewer in the Desktop_Apps group.

Image Viewer opens.

FIGURE 16–1 Image Viewer icon

Install Image Viewer in the Front Panel.

� To Start Image Viewer from the Command Line
Image Viewer has new features which can be accessed by running the tool from the
command line. To start Image Viewer and open files directly from the command line:

� Type sdtimage to start Image Viewer.

Or, type sdtimage filename to start Image Viewer and open a specific file.
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� To Exit Image Viewer
� Choose Exit from the File menu.

Viewing Images
With Image Viewer, you can view, edit, print, and translate the file formats of
monochrome and color images and PostScript files. See “Image Viewer File Formats”
on page 435 for a list of the file formats that Image Viewer can open. See “Viewing
PostScript Files” on page 428 to learn how to view PostScript files.

� To Open an Image File
1. Choose Open from the File menu.

The Open dialog box appears.

2. To navigate among and display the contents of folders, double-click a folder in the
Folders list.

3. Select an image file from the Files list or type its name in the Enter file name field.

4. Click OK to open the image file.

The image file is displayed in the View window.

� To Open an Image File Using Drag and Drop
� If Image Viewer is already running, drop an image file icon on an open Image

Viewer window.

If Image Viewer is not running:

1. Drag an image file icon from File Manager and drop it on the workspace.

2. Click mouse button 3 over the image file icon on the workspace and choose Open
from the Workspace Object menu.

Image Viewer starts and the image file is displayed in Image Viewer’s View window.

3. To remove the icon from the Workspace when you are finished with it, click mouse
button 3 on the icon and select Remove From Workspace from the pop-up menu.
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� To View an Image in Gray Scale or Color
To determine whether images appear in gray scale or color:

1. Choose Options from the File menu.

2. Select either Gray Scale or Color for the View Image In setting.

3. If you chose to display images in color, set the Color option to the number of colors
you want used.

The Color setting depends on the type of display monitor you have. For example, if
only one option, such as 256, appears, that is the only option available on your
monitor.

4. Click OK to activate the settings and close the dialog box. Click Apply to activate
the setting and leave the dialog box displayed.

� To Move the Image within the View Window
1. Select Palette from the Edit menu if the palette is not displayed.

2. Click the Pan tool in the palette.

See “Using the Palette Tools” on page 424 for information on the palette.

3. Move the pointer into the View window, over the image or page.

The pointer changes to a hand shape.

4. Drag the pointer in the direction you want to move the image or page.

5. Click the Pan tool to deselect it.

� To Change an Image Orientation in the View
Window
To rotate the displayed image in 90-degree increments (mimics landscape or portrait
orientation):

1. Choose Page Viewing Controls from the View menu.

2. Select a percentage by which you want the image rotated (90 degrees, 180 degrees,
or 270 degrees).

3. Select whether you want the image rotated Right or Left.
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4. Click OK to rotate the image and close the dialog box, or Apply to rotate the image
and leave the dialog box displayed.

� To Display Information about an Image
� Choose Image Info from the View menu.

The Image Information dialog box appears.

FIGURE 16–2 Image Information dialog box

The dialog box displays the following information about the image:

� Height of the page in inches, centimeters, and pixels
� Width of the page in inches, centimeters, and pixels
� Number of colors used in the file
� Size of the file in Kbytes
� Format of the file

Editing Images
You can use Image Viewer to manipulate images in many ways:

� Select a region to save
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� Rotate, flip, or scale the image

Using the Palette Tools
The Palette dialog box provides tools that enable you to manipulate images.

Pan tool

Selector tool

Rotate tools

Flip tools

Scale tool

FIGURE 16–3 Palette dialog box

� Pan tool – Use to move the contents of the View window

� Selector tool – Use to select a region to be saved as a new image

� Rotate tools – Use to rotate the contents of the View window to the right or left

� Flip tool – Use to flip the image horizontally or vertically

� Scale tool – Use to size the image

� To Display the Palette Automatically
You normally display the Image Viewer Palette by choosing Palette from the Edit
menu. However, you can also automatically display the palette whenever you open a
document:

1. Choose Options from the File menu.

2. Select Display Palette On Opening Document.
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3. Click OK or Apply.

� To Select a Region to Save as a New File
You can cut out a region of an image or page and save that region as a new file.

1. Select Palette from the Edit menu if the palette is not displayed.

2. Click the Selector tool in the palette.

3. Move the pointer into the View window.

4. Place the target pointer over a corner of the region you want to save as a new image
and drag mouse button 1 to the opposite corner.

Image Viewer draws a border around the region you define.

5. Choose Save Selection As from the File menu.

The Save Selection As dialog box appears.

6. Select the file format in which you want your file written.

For a list of the formats, see “Image Viewer File Formats” on page 435.

7. (Optional) Choose a compression method from the Compression menu button.

The default is None (no compression); compressed files require less disk space.

8. (Optional) Choose the number of colors to save for your file from the Colors menu
button.

The choices depend on the type of monitor you have.

9. Click OK.
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� To Rotate an Image
1. Select Palette from the Edit menu if the palette is not displayed.

Rotate
clockwise

Rotate
counter-
clockwise

Use to set
degree of rotation

2. Specify the number of degrees you want the image or page rotated.

The default value is 90 degrees; change the value in one of the following ways:

� Double-click in the Rotate Degrees field and type the number
� Click the arrow buttons
� Drag the slider

3. Click one of the rotate tools to rotate the image or page left or right.

Image Viewer rotates the image or page according to the value in the Rotate Degrees
field.

4. To restore the image to its last-saved orientation, click Revert.

� To Flip an Image
1. Select Palette from the Edit menu if the palette is not displayed.

2. Click one of the flip tools to invert or create a mirror image of the currently
displayed image or page.

Mirror

Invert

3. To restore the image to its last-saved orientation, click Revert.
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� To Scale an Image
To enlarge or reduce an image proportionally:

1. Select Palette from the Edit menu if the palette is not displayed.

Click to scale
the image to the

percentage value Use to set the scale
percentage value

2. Specify the scale percentage.

The default value is 100%; change the value in one of the following ways:

� Double-click in the Scale Percentage field and type the number
� Click the arrow buttons
� Drag the slider

3. Click the Scale tool.

Image Viewer scales the image according to the value in the Scale Percentage field.

4. To restore the image to its last-saved size, click Revert.

� To Undo an Edit Operation
Image Viewer provides two methods for cancelling an unsaved edit operation:

� Choose Undo from the Edit menu to cancel the last unsaved edit made to an image
or page.

� Or, click the Revert button on the palette to cancel all unsaved changes and display
the last saved version of the image or page.

Saving Images
You can save changes you make to an image or page in the same file you opened, or to
a new file. Saving to a new file enables you to save to a different format or name.
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� To Save an Edited Image in the Same File
1. Choose Save from the File menu.

The Save dialog box appears.

2. Click OK.

A dialog box is displayed, asking you if you want to overwrite the existing file.

3. Click Overwrite Existing File to save the changes in the existing file.

Click Cancel if you do not want to overwrite the existing file. Change the file name or
change folders in the Save dialog box to save the changes to a new file.

� To Save an Image as a New File
To save a file and specify its format, folder, and name:

1. Choose Save As from the File menu.

2. Double-click a folder name in the Folder list to open it.

3. Type the name of the file in the Enter file name field.

4. Select the file format in which you want your file written.

For a list of the formats, see “Image Viewer File Formats” on page 435.

5. Choose a compression method from the Compression menu button.

The default is None (no compression); compressed files require less disk space.

6. Choose the number of colors to save for your file from the Colors menu button.

The choices depend on the type of monitor you have.

7. Click OK.

Image Viewer saves your file in the specified format.

Viewing PostScript Files
With Image Viewer you can view and manipulate PostScript files as well as image
files. (See “Viewing Images” on page 421 to learn how to view image files.)
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� To Open a PostScript File from the File Menu
1. Choose Open from the File menu.

2. To navigate among and display the contents of folders, choose a folder from the
Folders list.

3. Choose a PostScript file from the Files list or type the PostScript file name in the
Enter file name field.

4. Click OK to open the PostScript file.

The PostScript file is displayed in Image Viewer’s View window.

� To Open a PostScript File Using Drag and Drop
� If Image Viewer is already running, drop a PostScript file icon on an open Image

Viewer window.

If Image Viewer is not running:

1. Drag a PostScript file icon from File Manager and drop it on the Workspace.

2. Press or click mouse button 3 over the PostScript file icon on the workspace and
choose Open from the Workspace Object menu.

Image Viewer is started up and the PostScript file is displayed in Image Viewer’s View
window.

3. To remove the icon from the Workspace when you are finished with it, click mouse
button 3 on the icon and select Remove From Workspace from the popup menu.

� To View a PostScript File in Black and White or
Color

1. Choose Options from the File menu.

2. Select either Black & White or Color for the Display PostScript setting.

3. Click OK or Apply.
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� To Page through a PostScript File
� Use the Page slider or the arrow buttons.

Using your keyboard, you can view:

� The first page by pressing Home
� The next page by pressing PgDn or Return
� The previous page by pressing PgUp, Back Space, or Del[ete]
� The last page by pressing End

� To View a Specific Page of a PostScript File
1. Choose Page Overview from the View menu.

The Page Overview window uses thumbnail page buttons to show simple renderings
of the pages in a document. Up to 16 thumbnail page buttons are displayed in a set.
Clicking the scroll bar displays up to 12 new thumbnail page buttons.
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Note – If the Page Overview menu item is unavailable, Image Viewer is loading the
information for the Page Overview dialog box. For a long document, this may take a
while.

2. Determine the page you want to view.

� Double-click the thumbnail page button.

� Or, type the page number in the text field and click Display Page.

� To Reverse Page Order
The page order of a document is often reversed when the file is prepared for printing;
this is a convenient way to collate a document on printers that produce pages printed
side up. To reverse the page order of a document you are viewing:

1. Choose Page Viewing Controls from the View menu.

The Page Viewing Controls dialog box appears.

2. Select the order in which you want the pages of the current document displayed
(First Page First or Last Page First).

3. Click OK to apply your choices and close the dialog box.

� To Change the Size of the Displayed Page
The page description language used to create some documents may not include page
size information. This can cause page boundaries to display incorrectly. To change the
displayed page size:

1. Choose Page Viewing Controls from the View menu.

The Page Viewing Controls dialog box appears.

2. Select the size of the page you want for displaying the current document.

3. Click OK to apply your choices and close the dialog box.

See “Print Dialog Box” on page 432 for information on changing the size of the printed
page.
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� To Save a PostScript Page as a Bitmap Image
1. Choose Save Page As Image from the File menu.

The Save Page As Image dialog box appears.

2. Select the file you want to save.

If you do not specify a file, Image Viewer saves the page currently displayed in the
View window.

You can filter the Files list by typing a file-name condition in the Filter field and
clicking Update. For example, typing *.ps will list only the files ending in .ps in the
Files list.

3. Select the format in which you want to save the page from the File Format list.

See Table 16–2 for a list of file formats in which Image Viewer can save an image.

4. (Optional) Set a compression type through the Compression button menu.

5. (Optional) Choose the number of colors for the image from the Colors button menu.

The default is 256.

6. Type the name under which you want to save the file in the Enter file name field.

7. Click OK.

Printing
You can print an image or PostScript file in Image Viewer and set parameters for
image position, orientation, and size, plus the more standard print settings such as
page size and number of copies.

Print Dialog Box
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FIGURE 16–4 Print dialog box

TABLE 16–1 Print Dialog Box Options

Option Usage

Copies Increase or decrease the number of copies to print.

Header Page Choose whether to print a header page.

Printer Select the printer on which to print your image from a list of
printers.

Page Size Select from a list of standard page sizes. This value should
correspond with the size of the paper in your printer.

Page Range Choose whether to print the entire document or one page.

Image Size If Page Range is This Page (As Image), you can choose
whether to scale the image.
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TABLE 16–1 Print Dialog Box Options (Continued)
Option Usage

Image Orientation Choose between Portrait, which prints an image vertically on
the page, and Landscape, which prints it horizontally.

Image Position Choose between Centered (default), which prints the image in
the center of the page, and Margins, which uses the entered
values for the top and left margins. The button labeled “in” or
“cm” controls whether margin values are in inches or
centimeters.

� To Print (With Options)
1. Choose Print from the File menu.

The Print dialog box appears.

2. Specify the details of the print job your print parameters.

See Table 16–1.

3. Click Print.

� To Preview a File to Be Printed
To see how the contents of the View window will appear when printed with the
current Print dialog box settings:

1. Choose Print Preview from the File menu.

The Print Preview dialog box appears.

If the image is too big to fit on a single page, lines in the Print Preview window show
you the boundaries of the printed page.

2. To control which area of the image or page is printed, move the pointer into the
window (it changes to a hand shape) and use mouse button 1 to drag the image into
position.

3. To print the image, click Print, and then click Print in the Print dialog box that is
displayed.

See “Print Dialog Box” on page 432 for information about print settings.

4. Click Close to close the Print Preview dialog box.
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� To Print a Document
To print a single copy of the image or multiple-page document you are viewing:

� Choose Print One from the File menu.

Image Viewer prints one copy of the file, using the current Print dialog box settings.

See “Print Dialog Box” on page 432 for information about Print settings.

� To Print a Page from a Document
1. Display the required page in Image Viewer.

2. Choose Print Page from the File menu.

Image Viewer prints one copy of the current page on the current printer.

� To Print an Image File
1. Display the required image in Image Viewer.

2. Choose Print Image from the File menu.

Image Viewer prints one copy of the current image file on the current printer.

Image Viewer File Formats
You may want to identify the specific format, or file type, of the file you want to open.
Image Viewer can open files in the formats listed in Table 16–2, which you can specify
by choosing Open As from the File menu.

TABLE 16–2 Image Viewer Open File Formats

Andrew Toolkit Kodak Photo CD (Base/4)

Atari Compressed Spectrum* Lisp Machine Bit-Array

Atari Degas 1* MGR

Atari Degas 3* MTV/PRT Ray-Tracer

Atari Uncompressed Spectrum* MacPaint
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TABLE 16–2 Image Viewer Open File Formats (Continued)
AutoCAD Slide PBM

Benet Yee Face File PC PaintBrush

CMU Window Manager PGM

Encapsulated PostScript (EPSF) PICT

FITS PPM

GEM PostScript

GIF QRT Ray-Tracer

Gould Scanner Sun Icon

Group 3 FAX Sun Raster

HIPS TIFF

HP PaintJet TrueVision Targa

IFF ILBM Usenix FaceSaver

Img-Whatnot X Bitmap

JFIF (JPEG) X11 Window Dump (XWD)

Kodak Photo CD (4Base) XPM

Kodak Photo CD (Base) Xerox Doodle Brush

Kodak Photo CD (Base/16) Xim

*SPARC only.

Image Viewer can save files in the formats listed below:

Encapsulated PostScript (EPSF) GIF

JFIF (JPEG) PostScript

Sun Raster TIFF

XPM
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Using Snapshot
Snapshot takes a “snapshot” of a window, of a region of the desktop, or of the entire
desktop screen. You can then view, save, or edit the snapshot in Image Viewer.

� To Start Image Viewer Snapshot
� Choose Snapshot from the Image Viewer File menu

Or, start Image Viewer with the -snapshot option:

sdtimage -snapshot

FIGURE 16–5 Snapshot window

� To Take a Snapshot of a Window
1. If Snapshot is not running, choose Snapshot from the Image Viewer File menu.

2. Select Window as the Snap Type.

3. Click the Snap button.

The mouse pointer becomes a plus sign.

4. Move the mouse pointer to the window to be snapped and click mouse button 1.

The message at the bottom of the Snapshot dialog box reads “Snap succeeded” once
the window is snapped.
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� To Take a Snapshot of a Region
1. If Snapshot is not running, choose Snapshot from the Image Viewer File menu.

2. Select Region as the Snap Type.

3. Click the Snap button.

The mouse pointer becomes a plus sign.

4. Move the mouse pointer to a corner of the region to be snapped, press and hold
mouse button 1, drag the mouse diagonally to encompass the region to be snapped,
and release mouse button 1.

The message at the bottom of the window reads “Snap succeeded” once the region is
snapped.

� To Take a Snapshot of the Screen
1. If Snapshot is not running, choose Snapshot from the Image Viewer File menu.

2. Select Screen as the Snap Type.

3. Click the Snap button.

The message at the bottom of the window reads “Snap succeeded” once the screen is
snapped.

� To Take a Delayed Snapshot
When taking a snapshot of a menu or some other pop-up or pull-down element, you
can delay the time between clicking Snap and the snapshot being taken.

1. If Snapshot is not running, choose Snapshot from the Image Viewer File menu.

2. Determine the number of seconds to delay by using the down arrow button and
selecting a value or by typing in the text field.

The next time you click Snap, the snapshot will be delayed by the specified number of
seconds.

3. (Optional) If you want to hear the seconds counted off before the snapshot is taken,
select Beep During Countdown.

4. Select a Snap Type and click Snap.

If Snap Type is Region, drag mouse button 1 to select the region to be snapped.
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5. Make any necessary adjustments to the image during the snap delay time.

You can display a menu, for instance, by clicking on an item in a menu bar.

After the specified number of seconds, the window, region, or screen is snapped and
“Snap succeeded” is displayed in the message area at the bottom of the window.

� To Hide the Snapshot Dialog Box While Taking a
Snapshot
If you want a snapshot of the entire screen and do not want the Snapshot dialog box to
be included in the image, you can hide the Snapshot dialog box while you take a
snapshot.

1. If Snapshot is not running, choose Snapshot from the Image Viewer File menu.

2. Select the Hide Window During Capture check box.

The Snap Delay changes to 8 seconds and the message area at the bottom of the
Snapshot dialog box displays “Timer adjusted to guarantee correct operation.”

3. Click Snap to take the snapshot.

All Image Viewer windows disappear and do not reappear until after the snapshot has
been taken.

� To Save a Snapshot
See “To Save an Image as a New File” on page 428 for instructions for saving a
captured snapshot image.
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CHAPTER 17

Using Video and Audio

Video is the Java Media Player application used for viewing or saving video data in
several formats. The Java Media Player is automatically launched once you select the
Audio/Video menu option from the Applications menu. This is the default unless you
select the Audio option to customize your environment.

Audio is a CDE Motif application for playing, recording, or saving audio data in AU
(Sun), WAV (PC), or AIFF (Macintosh) format.

� Video Overview
� Starting and Quitting Audio
� Audio Main Window
� Voice Notes
� Displaying the Waveform Window
� Opening and Playing Audio Files
� Recording with Audio
� Audio Control
� Menus
� Using the Tabs
� Controlling Master Recordings
� Controlling Master and Application Output
� Recording Using the Master Application Input
� Using the Status Dialog
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Video

Overview
Use the Java Media Player for viewing multimedia files. The Java Media Framework
(JMF) is an application programming interface (API) for incorporating media data
types into Java applications and applets. It is specifically designed to take advantage
of Java platform features.

Java Media Player Main Window
All video functions start with the main window.

You can open a video file by choosing Open file from the File menu. Once you open a
file, the main window alters to display the file and a control panel at the bottom of the
screen.
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The control panel consists of the following icons and their respective functions:

Click this button to begin playing a file.

Click this button to pause a file.

This button indicates how far a file has played.

Click this button to alternatively turn on or turn off the sound.
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Click this button to increase or decrease the volume.

Click this button to view information on a file.

Supported Media Formats
The Java Media Player supports the following formats:

Aiff (.aiff)
� 8 bits mono/stereo linear
� 16 bits mono/stereo linear
� G.711 mono
� IMA4 ADPCM

AVI (.avi)
Audio:

� 8 bits mono/stereo linear
� 16 bits mono/stereo linear
� G.711 mono
� GSM mono

Video

� Cinepak
� Indeo (iv31 and iv32)
� JPEG (411, 422, 111)

GSM (.gsm)
� GSM mono audio
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MIDI (.midi)
� Type 1 & 2 MIDI audio files

MPEG-1 (.mpg)
This format is not available on Solaris x86.

� Video: MPEG-1
� Audio: MPEG-1, Layer 1 and 2

MPEG audio (.mp2)
This format is not available on Solaris x86.

� MPEG layer 1 or 2 audio

Quicktime (.mov)
Audio:

� 8 bits mono/stereo linear
� 16 bits mono/stereo linear
� G.711 mono
� GSM mono
� IMA4 ADPCM
� u-law

Video:

� Cinepak
� H.261
� H.263
� Indeo (iv31 and iv32)
� JPEG (411, 422, 111)
� Raw
� RLE
� SMC

RMF (.rmf)
Headspaces Rich Media Format audio files.
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RTP
Audio:

� 4 bits mono DVI 8 kHz
� 4 bits mono DVI 11.05 kHz
� 4 bits mono DVI 22.05 kHz
� 4 bits mono DVI 44.1 kHz
� G.711 mono
� GSM mono
� G.723 mono

Video:

� JPEG (411, 422, 111)
� H.261
� H.263

Sun Audio (.au)
� 8 bits mono/stereo linear
� 16 bits mono/stereo linear
� G.711 mono

Vivo (.viv)
Video: H.263

Wave (.wav)
� 8 bits mono/stereo linear
� 16 bits mono/stereo linear
� G.711 mono
� GSM mono
� DVI ADPCM (not MSADPCM)

Using the Java Media Player
The following tasks can be performed on multimedia files using JMF.
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To Open a New Java Media Player
� From the File menu, select New player.

To Exit the Java Media Player
� From the File menu, select Exit.

The Java Media Player server shuts down 15 seconds after the last player exits.

To Open a File
� From the File menu, select Open file.

To Close a File
� From the File menu, select Close player.

This will close the file but will not exit the Java Media Player.

To Open a URL
� From the File menu, select Open URL.

� To Play a File
1. From the File menu, select Open file.

2. Enter the path or folder name in the text field.

3. From the Files window, double click the file that you want to open.

To Stop or Pause a File
� Click on the triangle at the bottom left of the screen.

To Rewind a File
� Click and drag the slider to your left.

The file will begin playing from the point you placed the slider.
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To Forward a File
� Click and drag the slider to your right.

The file will begin playing from the point you placed the slider.

To Adjust the Volume
You can either adjust or mute the volume for a file. To adjust the volume of a file:

� Click on the triangles at the bottom right of the screen.

A progress bar will indicate the change in volume.

To select mute for a file:

� Click on the speaker icon at the bottom right of the screen.

The icon will change to indicate that the file is in mute mode.

� To Set the Play Rate for a File
1. Place the cursor over the triangle on the lower left of the screen.

2. Right-click the mouse button.

3. From the pull-down menu select one of the options.

� 1/10 speed - 1/10th the original rate
� Half speed - 1/2 the original rate
� Normal speed - the original rate
� Double speed - twice the original rate
� Triple speed - three times the original rate
� Quadruple speed - four times the original rate

� To Alter the Screen Size
1. Place the cursor over the screen.

2. Right-click the mouse button.

3. From the pull-down menu select a zoom option:

� Half Size - Shrinks the screen to half its original size
� Normal - Alters the screen to accommodate the picture
� Double Size - Expands the screen to twice its original size
� Quadruple Size - Adjusts the screen to 4 times its original size
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To Display Information on a Video File
� Click on the “i” icon on the bottom right of the screen.

A pop-up window displays details on the file you are viewing.

Starting and Quitting Audio
There are several ways to start Audio:

� From the Front Panel
� From the command line
� From the Workspace Programs menu

� To Start Audio From the Front Panel
1. Click the Voice Note control on the Applications subpanel to start the application.

Audio runs in note mode, and automatically starts recording.

2. Click the Stop button to stop recording.

� To Start Audio From the Command Line
You can start Audio and open files directly from the command line.

� Type sdtaudio to start Audio.

Or:

� Type sdtaudio filename to start Audio and open a specific file.
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� To Start Audio From the Workspace Programs
Menu

1. Place the mouse pointer anywhere on the background of the desktop (the
workspace) and click mouse button 3.

The Workspace menu appears.

2. Choose Programs, and then choose Audio from the Programs submenu.

The Audio main window is displayed.

� To Exit Audio
� Choose Exit from the File menu or Close from the Window menu, or hold down the

Alt key and press the F4 key with the mouse cursor over the Audio main window to
exit Audio.

Audio Main Window
All Audio functions start with the main window. Open an audio file by choosing Open
from the File menu; record by choosing New from the File menu and clicking the
Record Audio button; set startup, recording, or playing options by choosing the
appropriate item from the Options menu.
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Voice Notes
In the same way as Text Note allows you to rapidly create small text files and display
them on the desktop, Voice Note allows you to record an audio message and save it on
the desktop for playing later. For example, you might want to record the
pronunciation of a foreign name, or a useful quotation which you don’t want to type.

The Voice Note control is located on the Applications subpanel of the Front Panel.
When you click the Voice Note control it runs the Audio application, which
immediately starts recording from your host’s microphone. To stop recording, you
click the Stop button or exit the Audio application.

The sound file that is created is displayed on your desktop when you exit the Audio
application. You can remove it by choosing Remove From Workspace from the
right-mouse button popup menu. You can remove it from your file system by deleting
it from your home directory.

Caution – If you click the Voice Note control and neglect to stop Audio, it can record
and save a huge file that may eventually use up all your disk space.
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Displaying the Waveform Window
An audio file can be displayed with or without a waveform displayed. The waveform
is a graphic depiction of the sound levels of an audio file.

� To Display the Waveform Window
1. To show the waveform window, click the Show Wave Window button.

2. To hide the waveform window, click the button again.

The button is a toggle, changing from Show Wave Window to Hide Wave Window
and back again to Show Wave Window as it is clicked.

If stereo viewing is enabled, the window depicts levels and volume individually for
left and right channels.

� To Start Audio With the Waveform Displayed
1. Choose Startup from the Options menu.

The Options dialog box is displayed, with Startup selected as the Category. If the
Options dialog box is already displayed, choose Startup from the Category menu.
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2. Click Waveform View Enabled or Stereo View Enabled.

3. Click OK.

The Options dialog box closes. The next time you start Audio the monaural or stereo
waveform will be displayed. The Stereo View Enabled button is inactive if the current
audio file is in monaural format.

Opening and Playing Audio Files
You can open an audio file from the Audio File menu or by dragging and dropping it
from File Manager onto Audio. Once you have opened an audio file or recorded
something, you can play it from the beginning or from any point in the file. You can
specify whether an audio file will be played automatically when it is opened.

� To Open an Audio File
1. Choose Open from the File menu or hold down the Control key and press ‘‘o’’ with

the mouse cursor over the Audio main window.

The Audio-Open File dialog box is displayed.

2. Navigate to the folder where the audio file is located.

Navigate by selecting a folder in the Folders list or by entering a folder name in the
Enter path or folder name text field.

3. Optional. Type an audio-file suffix (au, wav, aiff) after the asterisk (*) in the Filter
field.

Only files with the specified suffix will be listed in the Files field.

4. Press Return or click Update to update the change in the folder location or filter
field.

5. Select a file from the Files list.

6. Double-click the file in the Files list or select it and click OK.

The selected file is opened. If Automatically play audio file on Open is selected in the
Options-Play dialog box, the audio file starts playing.

Audio automatically detects the type of device accessed. If Audio is started with a
play-only device, only playback options and output sources are available. If audio is
started with a record-only device, such as a microphone, only record options and
input sources are available.
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� To Open an Audio File With Drag and Drop
1. Open File Manager and navigate to the folder where the audio file is located.

2. Drag the audio file icon from File Manager and drop it on the Audio main window.

The Selected file is opened. If Automatically play audio file on Open is selected in the
Options-Play dialog box, the audio file starts playing.

� To Specify Play Options
1. Choose Play from the Options menu.

The Options dialog box is displayed, with Play selected as the Category. If the Options
dialog box is already displayed, choose Play from the Category menu.
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2. Determine whether files should automatically play when they are opened.
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� Click Automatically play audio file on Open to automatically play files when they
are opened.

� Deselect Automatically play audio file on Open if you do not want files to
automatically start playing when opened.

3. Move the Set Default Play Volume and Balance Audio Output sliders to desired
positions.

Position the mouse pointer over the slider and press mouse button 1 as you move the
mouse to change slider positions.

4. Click OK to apply the specified values and close the Options dialog box.

� To Play an Audio File
Once you have recorded something or opened an audio file, you can play it, as
follows. You can play AU, WAV, or AIFF files.

1. Click the Play Audio button.

When you click Play Audio, play begins at the play pointer position. The file is played
from the beginning if it has just been opened or if you have just created the recording.
If you click the Stop Playing button during play and then click Play Audio, play
begins at the previous stop point.

Note that the Play Audio button is a toggle: before play, it is Play Audio; during play,
it is Stop Playing.

2. Optional. Move the play pointer to a new start play position.

To move the play pointer to the beginning of the file, click the Go to Start button.

To move the play pointer to the end of the file, click the Go to End button.

To move the play pointer to a position within the file:

� If the waveform is not displayed, drag the slider with mouse button 1.

� If the waveform is displayed, click anywhere in the waveform window.

3. Optional. Adjust the output volume by clicking on the Increase Volume or Decrease
Volume buttons.

To mute the output, click the Turn Sound Off button.

4. To stop playing the file, click the Stop Playing button.

Note – The Play buttons are inactive when no file has been loaded or recorded.
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Recording With Audio
You can record and save audio files in three formats.

� To Specify Record Options
You can specify audio format, sample rate, encoding method, channels, record
volume, and input balance in the Options dialog box. You can also specify whether
you will specify the values when you start recording, or if the set values will be used
automatically when recording or if you will specify the values when you start
recording.

1. Choose Record from the Options menu.

The Options dialog box is displayed, with Record selected as the Category. If the
Options dialog box is already displayed, choose Record from the Category menu.
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2. Choose AU, WAV, or AIFF from the Audio Format menu.
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AU, which is the default, is Sun audio format. WAV is Microsoft PC format. AIFF is
Macintosh audio format.

3. Choose samples per second from the Sample Rate menu.

8.000kHz is the default. Other rates fall in a range between 5.510kHz and 48.000kHz.

4. Choose an encoding method from the Encoding menu.

Encoding method options include u-law, A-law, and linear PCM.

5. Choose Mono or Stereo from the Channels menu.

Choose Mono, the default, for single-track recording, or Stereo for multiple channels.

6. Determine whether to use the selected recording options as the default for new
files.

� To use the selected recording options as the default, click Use selected recording
options as default for new files.

� To specify recording options when you click Record Audio, click Ask me when I
start recording.

7. Set default record volume and balance the audio input.

Position the mouse pointer over the slider and press mouse button 1 as you move the
mouse to set the Default Record Volume and Balance Audio Input sliders to desired
positions.

8. Click OK to apply the specified values and close the Options dialog box.

� To Create a Recording
You can record Audio files from a microphone, line-in, or CD source.

1. Specify recording options.

2. Choose New from the File menu or hold down the Control key and press ‘‘n’’ with
the mouse cursor over the Audio main window.

If a previous recording has not been saved, you are asked if you want to save it.

3. Prepare to record.

Be sure that the selected input device is connected to your computer and ready for
transmission, and that the microphone or other input device is on.

4. Click Record Audio button and start recording.

Speak, sing, or play into the microphone or start transmission of audio from a line-in
or CD source. Recording starts as soon as you click Record Audio unless you have
specified Ask me when I start recording in the Options-Record dialog box.
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5. When recording is complete, click the Stop Recording button.

6. Click Play Audio button to play what you have just recorded.

Note – The Record Audio button, which becomes the Stop Recording button during
recording, is inactive if a file is open; the button’s function is not displayed in the
current function area when it is inactive. Similarly, the Play and Go to buttons are
inactive when no audio file has been opened or recorded.

� To Save an Audio File or a Recording
You can save an existing audio file or a new recording in AU, AIFF, or WAV format.

1. Choose Save As from the File menu or hold down the Control key and press ‘‘a’’
with the mouse cursor over the Audio main window.

The Audio - Save As dialog box will be displayed.

2. Specify the folder in which you want to save the file.

Change to a different folder, if you wish. Press Return or click Update to update the
folder location.

3. Choose a format (AU, WAV, or AIFF) from the Audio Format menu.

AU, which is the default, is Sun audio format. WAV is Microsoft PC format. AIFF is
Macintosh audio format.

4. Type a name in the Enter file name field.

Audio files are usually named with .au, .wav, or .aiff suffixes for easy
identification. To overwrite an existing file, select the file in the Files list.

5. Click OK to save the audio file or recording.

� To Specify Input and Output Device Options
You can specify output (play) and input (record) devices for playing and recording.
Audio automatically detects the type of device accessed. If Audio is started with a
play-only device, only playback options and output sources are available. If Audio is
started with a record-only device, such as a microphone, only record options and
input sources are available.
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1. Choose Devices from the Options menu.

The Options dialog box is displayed, with Devices selected as the Category. If the
Options dialog box is already displayed, choose Devices from the Category menu.
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2. Select Speaker, Headphone, or Line Out as Output Sources.

Note that you can select more than one output source. Only devices that are installed
on your computer are active.

3. Select Microphone, Line In, CD, or Codec Loopback as the Input Source.

Only devices that are installed on your computer are active.

4. Click OK to apply the specified values and close the Options dialog box.

� To Display Information About an Audio File
� To view file information, choose Get Info from the File menu.

The File Information dialog box is displayed.

Audio provides the following information about the current file:

� File name
� File size in kilobytes
� File length in seconds
� Number of channels
� Sample rate (in kilohertz)
� Encoding (how many bits, what standard, etc.)
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Audio Control
Audio Control enables you to control the volume and balance levels for playback and
recording. Please refer to the following illustration for an example of the Audio
Control window.

Menus
There are three menu items available:

� File — controls whether or not you want Mixer Mode enabled (the default is
enabled). Mixer mode enables you to listen to two audio sessions at once. For
example, while listening to a Sun Microsystems broadcast you will also be able to
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hear the tone alerting you that you have new mail. Refer to the following
illustration for an example of the Mixer mode enabled.

File is also where you will find the Exit command when you are ready to quit
Audio Control.

� View — controls your audio input and output. Toggling the Applications Control
shows/hides (toggles) all Master and all Application processes.

� Help — provides you with assistance in all areas of Audio Control. Refer to the
following illustration for an example showing the Help pull-down menu.
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Using the Tabs
There are two tabs, Playback and Record. Audio Control detects the type of device
being used and displays the appropriate tab. The Playback window appears if used
with a play-only device, such as speakers. The Record tab appears when used with a
record-only device, such as a microphone.

If your device supports both play and record, you can switch between adjusting
Playback (Output) and Record (Input) by selecting the corresponding tab (toggles). If
you have the Playback tab selected when you check the Application Controls box, the
Application control box also displays. Refer to the following illustration for an
example of this.
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Master Output
The following controls are provided on the Master Output window:

� Output Source — contains a list of available output sources. You check and
uncheck sources to turn them on and off. Your choices are Built-in Speaker,
Headphone, and Line Out. This list can grow to accommodate additional output
devices. Volume and balance levels apply to all sources simultaneously, not to
individual sources to turn them on and off.

� Volume slider —for setting the master volume for all sources. The absolute level is
displayed in a text label next to the control (the value is 50 in the figure above.) The
displayed value changes as the slider is moved up and down.

� Balance slider — for setting the balance for all sources.

� Mute — for simultaneously muting all output sources.
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Controlling Master Recordings
You can control master recording parameters on the Master Recording window. Access
it by selecting the Record tab at the top of the window. Please refer to the following
illustration for an example of this.

The controls provided are:

� Master Input — contains a list of the available input sources. You can choose only
one input source at a time. The default choices are Microphone, CD ROM, and Line
In. This list can grow to accommodate additional input device.

� Gain (db) slider — for setting the master gain (recording volume). The level is
displayed next to the control (the value is 50 in the previous figure.) The displayed
value changes as the slider is moved up and down.

� Monitor slider — for adjusting the volume of the incoming audio that is sent to the
output device(s). It allows you to monitor the audio as it is being recorded.

Using Video and Audio 469



� Balance slider — for setting the recording balance for the selected source.

Controlling the Master and Application
Output
The Playback tab lets you control individual process audio output parameters. You
can access it by selecting the Application Controls option from the View menu when
the Playback tab is active. The new controls provided are exactly the same as those
provided for the Master Output, with the exception that they are provided for one
process at a time, rather than for an entire output device. Processes that are currently
using audio are displayed in the list box at the top of the panel. By selecting a process,
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you can individually control the volume, balance, and muting of that process. If you
have multiple audio channels, you can customize the individual volume and balance
of each channel.

Recording Using the Master and
Application Input
You can control individual process’ audio input parameters using the Master and
Application Input screen. You access it by selecting the Application Controls option
from the View menu when the Record tab is active. Refer to the following illustration
for an example of this.

Using Video and Audio 471



The controls provided behave exactly the same as those provided for the Master
Output, with the exception that they are provided for one process at a time, rather
than for an entire output device. Processes that are currently using audio are displayed
in the list box at the top of the panel. By selecting a process, you can individually
control the gain, and balance of that process. The Monitor volume is controllable only
at the master level, so there is no Monitor Volume Slider on the Application Input
panel.

Using the Status Dialog
This dialog allows you to view playback and recording status at the master level for
each process. You can access it by selecting Status from the View menu. Audio Control
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detects the type of device in use. If the device supports playback, the Playback Status
appears, if the device supports recording, the Record Status appears. Please refer to
the following illustration.

The controls provided are:

� Process List Box — this is a list of the items available for status monitoring. You can
choose to view Master status or to see status for each of the running processes that
are using dev/audio. You can choose only one process (or Master) to monitor at a
time. As you select items in the list, the Playback and Record panes in the lower
portion of the dialog update to reflect the status for the selected item being
monitored.

� Continuous Update Checkbox — status is displayed at the time the dialog was
invoked, unless you check Continuous Update. If Continuous Update is checked,
the status for the selected process is continuously monitored and updated.
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� Update Now Button — if Continuous Update is not turned on, you can update the
display by clicking Update Now. If Continuous Update is turned on, the Update
Now button is disabled (grayed out.)

The status of each of the following parameters being monitored and is represented by
either an LED icon in the on or off state, or a text string with the details of the status
item being displayed.

Playback and Record

� Open — The device is open by a process. The device may be opened read only,
write only, or read and write. Which is why there is an open for play and one for
record. These will be used only when mixing is disabled.

� Paused — The applications has commanded the device to pause playing or
recording. Just like Open, you can have one direction paused while the other is
active. Also, this will be used only when mixing is disabled.

� Active — Sound is being played or recorded. In mixer mode this means at least one
stream is playing or recording. It is possible that other streams will be paused.
When the mixer is off then there can be only a single play and record stream, so
this means that single stream is active.

� Underflow — When playing there wasn’t enough audio available so the device
underflowed and there is silence. With the mixer this means that the stream didn’t
have enough sound to mix into the audio stream that is being played, so that one
stream will have silence.

� Open-Waiting — When the mixer is turned of this means a process is trying to
open the audio device and can’t because another process already has the device
open. When the mixer is enabled it means a process is either trying to open the
audio device a second time for the same direction, or the mixer is out of resources
and is waiting for another process to close the audio device and free up a resource
for use.

� EOF Count — When playing it is possible to mark the audio stream so that you
know when a segment has been played. This is done by doing a zero sized write
and accepting signal. Each time this marker is encountered while playing the EOF
Count will be incremented by one and a signal will be sent to the application.

� Samples — The number of sample frames that has been played or recorded. A
sample frame is all samples to play one sample time. For example, playing a mono
audio stream means that one sample frame has one sample, but playing a stereo
stream means that one sample frame has two samples. One for the left channel and
one for the right channel.

� Encoding — This combines two audio format properties, precision and encoding.
Precision is the number of bits each sample uses. We support 16 bits and 8 bits. The
encoding method determines any processing of the audio sample. This is usually
done to compress the size of the audio stream so not as much data needs to be sent
over the network or stored on disk. We support "linear" which is linear pulse code
modulation, AKA linear PCM. We also support u-Law (u is for the Greek letter mu,
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which can’t be reproduces in simple text like this, but it can in postscript), and
A-Law. When combined together with precision we support 16-bit Linear PCM,
8-bit Linear PCM, 8-bit u-Law, and 8-bit A-Law. Also, linear PCM may be signed or
unsigned, we support only signed.

� Sample Rate — The number of times a second the audio stream is sampled and
thus converted from an analog signal to a digital number for recording. Or
converted from a digital number to an analog signal when playing. The higher the
number the greater the accuracy of the digital signal. But a higher number also
means more disk space is needed for storage or network bandwidth is needed to
transfer the data.

� Channels — The number of samples in a sample frame. Currently we support 1
(mono) or 2 (stereo).

� Close Button — Dismisses the Status dialog.
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CHAPTER 18

Using Address Manager

Unless you already know the addresses and command-line options for remote
operations, you’ll find that Address Manager is the fastest way to carry out remote
operations and find information about the systems and users on your network.

Address Manager can help you increase your productivity by providing information
about users, email aliases and systems on your network. It can also speed up common
tasks such as sending an email, remote login, setting an appointment on another user’s
calendar, and so on.

� “Cards” on page 477
� “To Open Address Manager” on page 483
� “Searching” on page 484
� “Performing Actions on Cards” on page 487
� “Working With Cards” on page 491

Cards
To make best use of Address Manager, you should understand the difference between
address cards, host cards, and alias cards, and recognize the icons that represent them
in Address Manager. You can add and edit some cards but others are created and
owned by the system. Depending on its type, each card has a number of fields of
information such as phone number, IP address, email alias, and so on.

Items on the Search Menu
The Search menu in Address Manager enables you to specify the types of card to
search for, as listed in the following table.
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TABLE 18–1 Card Types in Address Manager

Item on Search Menu Created By Card Type Icon in Address
Manager

System Cards System Address card

(Conforms to vCard™
standard)

Personal Cards User Editable address card

(Conforms to vCard™
standard)

System Aliases System Alias card

(an email alias)

Personal Aliases User Editable alias card

(an email alias)

Users System (one card
per username)

Address card

(Conforms to vCard™
standard)
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TABLE 18–1 Card Types in Address Manager (Continued)
Item on Search Menu Created By Card Type Icon in Address

Manager

Hosts System (one card
per host)

Host card

(an IP address)

Address Cards

Address cards are similar to Rolodex™ cards in that they contain pre defined lines
containing names, addresses, contact information, and so on. The name of an address
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card is usually derived from a person’s name, such as “FredJones” or “Fred-Jones”.
When searching, Address Manager searches all entries on the card to match the search
text.

Address
card icon

Address cards are based on the virtual card (vCard™) standard. This standard is
supported on other operating environments and enables easier interchange of
information by email. For further information, contact the Internet Mail Consortium
(http://www.imc.org).

Address Manager maintains a directory on your system called the personal cards folder
($HOME/.dt/Addresses) where it stores any personal address cards you create.
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Note – You may have useful information on Rolo or XRolo cards: These do not follow
any particular format and therefore are not automatically converted to vCards. To use
the information in your XRolo cards in Address Manager, convert them to the vCard
format and copy them to the Personal Cards folder.

Host Cards

Each workstation and server on your network has a host name and an associated IP
address (Internet Protocol address) that uniquely identifies the workstation. A host
card contains only the IP address. For example, the host card for our fictional user
Fred Jones’ workstation (jupiter) might contain the IP address 129.155.220.93.

Host
card icon

Host cards are created and maintained by the system and cannot be edited. They
contain only host information.
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Alias Cards

An alias is a pseudonym for one or more user names or user addresses used by CDE’s
email application, Mailer. Alias cards contain either:

� An email alias (such as fredj@jupiter) created by your system

� A personal email alias available from the Aliases menu in Mailer:

Personal
Aliases menu

FIGURE 18–1 Alias Menu in the New Message Window in Mailer

Sending email to an alias will send the message to all the addresses listed on the alias
card. For example, the alias research might contain the following addresses of
people in the Research Department at the fictional company Widget Makers Inc.:

fredj@jupiter, johns@pluto, susanw@saturn
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Alias
card icon

Alias cards contain only email addresses.

To Open Address Manager
� Click the Find Card control in the Cards subpanel of the Front Panel.

Address Manager opens. (Personal Cards, Personal Aliases, and System Cards are
automatically selected in the Search menu.)

� Or, click the Find Host control in the Tools subpanel of the Front Panel.

Address Manager opens. (Hosts is automatically selected in the Search menu.)
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Type Indicator
icon 

Found
drop-down box

Search button

Scrolling pane

FIGURE 18–2 Address Manager Application Window.

Searching
To make the best use of Address Manager, you will need to know how to enter your
search text, and how to select the types of cards to search for.

The Search menu allows you to select up to six types of card to search. When you type
your search text and click the search button, Address Manager searches each card of
the selected types for the search text. If it finds that text anywhere in the card, it lists
the card in the Found drop-down box.

When the search is completed, indicated by the activity (spinning globe) icon reverting
to a search (magnifying glass) icon:

� The first card found is listed in the scrolling pane

� The number of cards found is listed to the left of the Found drop-down box

� Any cards found are listed in the Found drop-down box

� The icon to the right of the drop-down box indicates a card’s type
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Tip – If your search returns no cards, check that the relevant card types are selected in
the Search menu.

� To Find an Address Card
1. Open Address Manager.

2. Open the Search menu and ensure that the following menu items are selected:

� Personal Cards
� System Cards

3. Type your search text in the box provided.

Your search text should be a string of characters such as John Smith or John that
you expect to find somewhere in the cards you are searching for.

4. When you are satisfied with the search text you have entered and the types of card
you are searching for, click the search (magnifying glass) icon.

Address Manager searches in the relevant card folders for all occurrences of the
specified text. Each time it finds a card matching the search criteria, it lists it in the
Found drop-down box.

Tip – If no matching cards are found, refine the search text or the card types you are
searching for.

5. Use the Found drop-down box to browse the cards found and identify the required
card.
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The Actions menu will list the available actions for each card type selected.

� To Find a Host Card
1. Open Address Manager.

2. Open the Search menu and ensure that only the Hosts menu item is selected.

3. Type your search text in the box provided.

Your search text should be a full or partial system name such as jupiter, or a full or
partial IP address such as 129.150.220.93.

4. When you are satisfied with the search text you have entered, click the search
(magnifying glass) icon.

Address Manager searches in the relevant card folders for all occurrences of the
specified text. Each time it finds a card matching the search criteria, it lists it in the
Found drop-down box.

Tip – If no matching cards are found, refine the search text.

5. Use the Found drop-down box to browse through the cards found to identify the
required hosts.

The Actions menu will list the available actions. See also “Performing Actions on
Cards” on page 487.
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� To Find an Alias Card
1. Open Address Manager.

2. Open the Search menu and ensure that the following menu items are selected:

� Personal Aliases
� System Aliases

3. Type your search text in the box provided.

Your search text should be a full or partial email alias such as fredj@jupiter or
fredj.

4. When you are satisfied with the search text you have entered and the types of cards
you are searching for, click the search (magnifying glass) icon

Address Manager searches in the specified card folders for all occurrences of the
specified text. Each time it finds a card matching the search criteria, it lists it in the
Found drop-down box.

Tip – If no matching cards are found, refine the search text or the card types you are
searching for and try again.

5. Use the Found drop-down box to browse through any cards found to identify the
required email aliases.

The Actions menu will list the available actions for each card type selected.

Performing Actions on Cards
When a card of a particular type is displayed in the scrolling pane, the Actions menu
is updated to reflect the available actions (remote login, sending an email, and so on)
for that card type.

Performing Actions on Address Cards
An address card provides contact information and location information for a
particular user. When you display an address card in Address Manager’s scrolling
pane, the Actions menu is updated to contain the following menu items:
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FIGURE 18–3 Actions Menu for an Address Card

TABLE 18–2 Actions for an Address Card

Action Description

Mail To Enables you to send mail to the listed email addresses

Dial Enables you to dial the listed phone numbers

Open Calendar Attempts to open the person’s calendar

Open Home Folder Attempts to open the person’s home folder

Open URL Attempts to open a URL listed on the card

Print Prints the information from the card

Performing Actions on Alias Cards
An alias card contains one or more email addresses. When you display an alias card in
Address Manager’s scrolling pane, the Actions menu is updated to contain the
following menu items:
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FIGURE 18–4 Actions Menu for an Alias Card

TABLE 18–3 Actions for an Alias Card

Action Description

Mail To Enables you to send mail to the listed email addresses

Who Are Attempts to resolve the alias into a global address

Print Prints the information from the card

Performing Actions on Host Cards
A host card contains a host name and an IP address. When you display a host card in
Address Manager’s scrolling pane, the Actions menu is updated to contain the
following menu items:
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FIGURE 18–5 Actions Menu for a Host Card

TABLE 18–4 Actions For a Host Card

Action Description

Terminal Displays a remote terminal (dtspcd) for the host

Terminal Rlogin Performs a remote login (rlogin) on the host

Process Manager Opens Process Manager for the host

Performance Meter Opens Performance Meter for the host

Workstation Info Opens Workstation Information for the Host

Disk Usage Displays disk usage statistics for the host

Print Manager Opens Print Manager for the host

Suspend System Issues a Suspend action on the host

Reboot Issues a Reboot action on the host

Halt Issues a Halt action on the host

Admintool Opens the Admintool application for the host
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TABLE 18–4 Actions For a Host Card (Continued)
Action Description

Admintool Super-user Requests that you enter the host’s root password, and
opens Admintool (super-user mode) on the host

Working With Cards
Each address card, alias card, and host card is actually a file known to your
workstation. When searching for them, Address Manager searches the locations
indicated in the following table.

TABLE 18–5 Locations of Card Types

Cards Stored

System Cards A site-specific database searched by sdtnamer (1)

Personal Cards The file $HOME/.dt/Addresses (Editable in Address
Manager)

System Aliases The file /etc/aliases and the Mail.Aliases NIS map

Personal Aliases The file $HOME/.mailrc

Users The file /etc/passwd and the Passwd.Byname NIS map

Hosts The file /etc/hosts and the Hosts.Byname NIS map

� To Create a Personal Address Card
1. Choose New from the Card menu.

Address Manager displays a template for a new card in the scrolling pane. Each line in
the template card represents a field specified in the vCard specification. All fields are
optional, although you should fill in at least the Name field.

2. Type the relevant information for the new address card in the scrolling pane.

If you are unsure as to the appropriate format of information such as phone numbers,
and the like, print out an existing card and use it as a guide.

3. When you are satisfied with the details you have entered, choose Save As from the
Card menu.

Address Manager displays the Save As dialog box.
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4. Type a name for the new card file and click Save.

The file name should contain the name of the person to which the card relates.
Address Manager saves the file under the file name that you specified in the
Addresses folder.

Tip – For address cards (which conform to the vCard standard), some operating
environments such as Windows recognize the .vcf file extension. If you intend
mailing your address cards to users of such systems, you may want to use this
file-naming convention.

5. (Optional) Verify your new personal address card by searching for it with Personal
Cards selected in the Search menu.

Address Manager finds and displays the personal address card you created.

� To Create a Personal Alias Card
Creating a personal alias card has the same effect as adding an alias to Mailer’s list of
Aliases.

1. Choose New from the Card menu.

Address Manager displays a template for a new card in the scrolling pane.

2. Delete all text in the template.

3. Type one or more email addresses such as fredj@jupiter in the blank scrolling
pane.

Separate the addresses using commas.

4. Choose Save as Mailer Alias from the Card menu.

Address Manager displays the Save As dialog box.

5. Type a name for the new card file and click Save.

Any UNIX file name will suffice but it should contain the name of the person to whom
the card relates. Address Manager saves the file under the file name specified in the
Addresses folder.

6. (Optional) To verify your new personal alias, restart Mailer and choose Aliases from
the Options menu.

Mailer displays the Mail Options dialog box, which contains your personal alias.

You can also search for the alias in Address Manager with Personal Cards selected in
the Search menu.
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Caution – After saving a personal mail alias, restart Mailer. If you make any changes
to options in Mailer before restarting Mailer, your mail alias will be lost.

� To Edit a Personal Address Card
1. Display the card you want to edit by searching for it and then selecting it in the

Found drop-down box.

2. Edit the text in the scrolling pane.

3. When you are satisfied with the changes you have made, choose Save from the Card
menu.

Address Manager saves the changes to the card, which resides in the personal cards
folder.

� To Put a Card on the Workspace
If you find yourself using Address Manager to find the same card a few times a day,
you can put this card in the current workspace for quick access. For example, if you
phone John Smith a few times a day and want to be able to look up his phone number
with one click of the mouse, put his address card in the workspace.

1. Display the card in Address Manager.

2. Choose Put In Workspace from the Card menu.

Address Manager displays an icon for the card in the current workspace.

3. (Optional) Click the card icon to invoke its default action.

Default actions are listed in the following table.

Displays the card in Address Manager

Opens a Mail To dialog box for the alias
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Opens a terminal session on the host

Printing Cards
Each card contains one or more lines of text. You can print this information as
displayed in the scrolling pane by choosing Print from the Card menu.

Browsing Your Card Folders
The personal cards folder $HOME/.dt/Addresses contains your personal address
cards. You can edit any of the cards in this folder by choosing Open from the Card
menu and specifying the card file to be edited.

You can save the changes you make by choosing Save from the Card menu.
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CHAPTER 19

Using Process Manager

Use Process Manager to display the processes that are running on your workstation,
and to perform actions on them. You can do this without knowing the syntax for
ps(1), truss(1), kill(1), and other character-based commands. Where relevant, the
equivalent UNIX commands are given for each Process Manager action.

� “About Processes” on page 495
� “Sampling, Displaying, and Saving Process Information” on page 496
� “Performing Actions on a Selected Process” on page 501

About Processes
UNIX works with processes. Your login shell, application programs, the edit session
you run, and even the ls program that lists your files are all processes under control
of the operating environment.

In UNIX you can perform operations on these processes. For example, you can look at
all the programs you’re running at any time, stop and restart programs as you choose,
and investigate and debug errant processes.

Tips for Finding Errant Processes
An errant process is a process that is not doing the job you expect it to do. For
example, a process might be consuming a large percentage of your available resources
due to a bug, or it might be interfering with another process. Use Process Manager to
detect errant processes when you experience the following:

� Workstation performance or response seems to have slowed.
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� A program will not respond to user input.

� A standard service such as printing, file transfer or remote login does not respond.

When displaying all processes, Process Manager typically displays thirty to fifty
processes, so finding the errant processes can be daunting to the untrained eye. The
following tips may help (otherwise contact your System Administrator):

� Use Performance Meter to see if performance parameters such as CPU usage or
disk usage are exceptionally high. If so, you can use Process Manager to identify
the errant process.

� Use Process Manager to identify:

� Processes using a large percentage of the available CPU or RAM when they
shouldn’t

� Orphaned processes whose parent process has reverted to 1, that is init (but
not processes such as sched, dtlogin, or cron whose parent process ID
should be 1)

� Processes that were started a long time ago and weren’t terminated when they
should have been

� Large processes owned by another user that are degrading performance

Sampling, Displaying, and Saving
Process Information
Process Manager displays and provides access to processes that are running on your
workstation.

FIGURE 19–1 Process Manager showing process entries containing the string “audio”.

Each process entry in the list gives you useful information, as explained in the
following table:
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Column Heading Meaning

ID Process ID

Name Process Name

Owner Name of Owner

CPU% Ratio of CPU time used recently to time available in the same period,
expressed as a percentage

RAM Amount of RAM currently occupied by this process

Swap Total size in virtual memory

Started Actual start time (or date if other than current)

Parent Process ID of parent process, or PPID

Command Actual UNIX command (truncated) being executed

You can perform the following actions without affecting any processes on the selected
workstation:

� Display all processes, or only those containing a specified character string

� Find processes containing a specified character string

� Display processes sorted by any of the columns in the scrolling pane

� Change the sampling interval, and copy and save the sample information

� To Open Process Manager
� Click the Find Process control on the Tools subpanel of the Front Panel.

The Process Manager main window is displayed. It immediately samples the
workstation and displays a sample of all current processes.

� To Display Subsets of the Processes
1. Type your filter text into the Filter field of the Process Manager window.

You filter text should be a string of characters that is common to the process entries of
the subset or group of processes you want to display. For example, in Figure 19–1 the
user is displaying all processes relating to Audio Tool.

2. Press Return.

Process Manager updates the processes in the scrolling pane to include only those
process entries that contain an exact match of the filter text.
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3. To revert to displaying all processes, clear the Filter field and press Return.

� To Find a Process
1. Type your search text into the Find drop-down box, or select a previously used

search text from the Find drop-down list.

Your search text should be a string of characters that is common to the process entries
of all of the processes you want to display.

2. Press Return to highlight the first occurrence of the search text below the current
cursor position.

The text can be in any of the fields in the process entry.

3. Press Return to highlight the next occurrence, and so on.

4. When you have found the required process entry, clear the Find field.

Note – When you reach the end of the scrolling pane, search does not revert to the top
of the list. Therefore, to ensure you search all processes, select the first process entry in
the list before typing your search text in the Find box.

� To Change the Sort Order of the Display
By default, Process Manager lists the process entries in order of decreasing CPU usage.
You can tell this because the column heading over the CPU usage column (CPU%) is
depressed, while the other column headings are not.

1. To select the column on which the list of process entries is to be sorted, click the
relevant column heading or choose the column name from the View menu.

Process Manager sorts the list of process entries and displays them in the new order.
The default ordering for each column is indicated in the following table.

TABLE 19–1 Default Display Order for Process Entries

Selected Column Heading Method

ID Sorts numerically by process ID in increasing order

Name Sorts alphabetically by process name

Owner Sorts alphabetically by owner name

CPU% Sorts numerically by CPU usage in decreasing order
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TABLE 19–1 Default Display Order for Process Entries (Continued)
Selected Column Heading Method

RAM Sorts numerically by RAM usage in decreasing order

Swap Sorts numerically by swap space usage in decreasing order

Started Sorts chronologically by actual start time in decreasing order

Parent Sorts numerically by process ID number of parent process in
decreasing order

Command Sorts alphanumerically by full path name in decreasing order (
characters such as / have a lower sort value than letters)

2. (Optional) To reverse the sort order for any one of these columns (for example, to
sort by RAM usage in increasing order), click the depressed column heading button.

The column heading area will turn black and sort the display in the reverse order.

Now sorted in order of increasing CPU usage.

� To Change the Sampling Interval
By default, Process Manager samples the workstation and updates the display every
30 seconds.

� To disable/enable the continuous sampling mode, choose Stop/Start from the
Sample menu.

If continuous sampling is on, you will see a Stop menu item on the Sample menu;
otherwise the menu item will read Start.

� To change the interval between samples, type a number of seconds (up to 604800,
that is, 14 days) in the Sample Every box.

Press Return to make the new sampling frequency come into effect.

Using Process Manager 499



� To sample immediately, choose Now from the Sample menu.

Process Manager samples and then updates the display.

Copying and Saving
You can select and copy one or more of the process entries in the display, and paste the
text into other applications.

You also have the following options for saving the sample data to files:

� Creating a new file containing only the current sample
� Setting up a log file to which each new sample is appended

� To Create a File Containing the Current Sample
1. Choose Save As from the Sample Menu.

Process Manager displays the Save As dialog box.

2. Specify the name and location of a new file and click OK.

Process Manager creates the text file containing the process entries from the current
display.

� To Set Up a Log File
1. Choose Log File from the Sample menu.

Process Manager displays the Log File dialog box.

2. Specify the name and location of a new file and click OK.

Process Manager creates the text file and appends each new sample (with header
information) to the file.
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Caution – Process Manager will continue to append to this file until you terminate the
Process Manager application, or until you choose Stop Logging from the Sample
menu.

Performing Actions on a Selected
Process
When you have identified and selected a process entry in the list, you can perform
these actions on the process:

� Send a kill signal to terminate the process or invoke a response
� Search for more information about the owner in Address Manager
� Trace system calls, display child processes, or run a debugger
� Show its stack or its ancestors

Caution – Consult your system administrator if you do not understand the
implications of carrying out any of these procedures.

Sending Kill Signals to a Process
The kill command in UNIX enables the user to send a signal to a process. A signal is a
message sent to a process to interrupt it and cause a response. If the process has been
designed to respond to signals of the type sent it does so; otherwise, it terminates. The
following table lists some commonly used signal numbers/names and their meanings.

Signal No. Signal Name Meaning

1 HUP Hangup (often used before logging out)

2 INT Interrupt (same as pressing Control+C in a terminal
session)
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Signal No. Signal Name Meaning

9 KILL Kill (terminates without cleanup)

Only works if issued by process owner or super user
(root)

The program cannot respond to this signal; it must
terminate

15 TERM Kill (terminates gracefully after cleanup)

Only works if issued by process owner or super user
(root)

The Kill menu item enables you to kill a process quickly by sending it a kill (9) signal.
The Signal menu item gives you more control of the signal sent by the kill(1)
command. For example you could send an INT signal or a HUP signal, and so on.

Caution – You should only send a signal to a process if you understand the
implications of doing so. For example, if you select the login shell and send a kill
signal, you will suddenly log out. For further information on processes and job
control, contact your system administrator or see the Solaris Advanced User’s Guide
(Sun Microsystems).

� To Kill A Process (Quick Kill)
1. Select a process entry in the Process Manager scrolling pane.

2. Choose Kill from the Process menu.

Process Manager kills the process (and its child processes) provided that you have
permission to do so; otherwise an error is displayed. Sometimes it takes several
seconds for the process to terminate. You can tell that a process has been killed if it is
not listed the next time Process Manager updates its display.
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Tip – The equivalent UNIX command is:

kill -9 PID where PID is the process ID of the selected process.

You can redefine the command performed by the Kill menu item to a different
command by redefining the action labelled ’Kill’ in the file:

/usr/dt/appconfig/types/C/sdtprocess.dt

� To Send a Signal to a Process
1. Select a process entry in the Process Manager scrolling pane.

2. Choose Signal from the Process menu.

Process Manager displays a dialog box requesting you to specify the signals. You must
supply at least one of the 42 signals defined in the signal(5) man page.

3. Type the relevant signal number or name and click OK.

Process Manager issues the signal command and closes the dialog box. No success
message is issued. Killing a process typically kills its children.

Tip – The equivalent UNIX command is: kill -signum_name PID

where -signum_name is the signal number or name, and PID is the process ID of the
selected process.

� To Look Up the Owner of a Process
1. Select a process entry in the Process Manager scrolling pane.

2. Choose Look Up Owner from the Process menu.

Process Manager opens Address Manager and requests it to search the System Cards
for the system user name of the selected process. For further details on Address
Manager see Chapter 18.

� To Show the Ancestry for a Process
1. Select a process entry in the Process Manager scrolling pane.
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2. Choose Show Ancestry from the Process menu.

Process Manager displays a window containing the process trees for the specified
process. Child processes are indented from the respective parent processes.

Tip – The equivalent UNIX command is:

/usr/proc/bin/ptree PID

where PID is the process ID of the selected process.

� To Trace Child Processes
When a UNIX process initiates one or more dependent processes, we call these child
processes, or children. Child and parent processes have the same user ID.

1. Select a process entry in the Process Manager scrolling pane.

2. Choose Trace Children from the Process menu.

Process Manager displays a record of the creation of any new children (and their
children, recursively) for the selected process.

Error returns are reported using the error code names described in the Intro(2) man
page.
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Tip – The equivalent UNIX command is:

truss -fa -texec,fork -s¦CLD,ALRM -p PID

where PID is the process ID of the selected process.

� To Trace System Calls
During its execution, a process makes calls to the UNIX kernel, or system calls. You
might want to trace these system calls to see the affect they are having on other
processes.

1. Select a process entry in the Process Manager scrolling pane.

2. Choose Trace System Calls from the Process menu.

Process Manager displays a dialog box requesting you to enter optional arguments.

3. Click OK.

Each line of the trace output reports either the fault or signal name or the system call
name with its arguments and return values. For further information, see the truss(1)
man page.

Tip – The equivalent UNIX command is:

truss -p PID

where PID is the process ID of the selected process.

� To Show the Stack for a Process
1. Select a process entry in the Process Manager scrolling pane.

2. Choose Show Stack from the Process menu.

Process Manager displays a window containing hexadecimal and symbolic stack trace
for the selected process.
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Tip – The equivalent UNIX command is:

/usr/proc/bin/pstack PID

where PID is the process ID of the selected process.

� To Debug a Process
Application developers and system administrators sometimes use a debugging
application such as Sun Workshop to investigate an errant process. The Debug item on
the Process menu invokes your preferred debugger on the selected process.

� Debug the process using your preferred debugger.

Tip – The equivalent UNIX command is:

workshop -d command

where workshop is the name of the debugger program and command is the command
needed to pass the process ID to the debugger.
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CHAPTER 20

Using Performance Meter

Use the Performance Meter to monitor activity and performance on a workstation.
Several performance parameters such as CPU utilization, disk activity, network
packets, and the like, can be displayed graphically in this customizable window.

You can monitor performance of local or remote hosts, set up color-coded activity
thresholds to warn you of exceptional performance, and log the samples to a file.

Tip – Performance Meter enables you to identify errant behavior on your system.
After identifying the errant behavior, you can use Process Manager (see Chapter 19) to
identify and kill the errant processes.

� To Open Performance Meter
� Choosing the Host and Parameters Display
� Choosing How the Parameters are Displayed
� Working With Colors and Thresholds
� Logging Samples and Choosing the Sample Interface

To Open Performance Meter
� Click the Performance Meter control on the Font Panel.

Performance Meter opens and displays the default charts (CPU and disk activity).
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Tip – To make Performance Meter’s Front Panel icon inactive, use Process Manager to
kill the sdtperfmeter process.

Choosing the Host and Parameters to
Display
You can monitor performance on your workstation (local) or on another workstation
(remote). The View menu lists several performance parameters that you can display
for the host you are monitoring.

The parameters you choose to monitor may depend on:

� The type of applications you run
� Your network
� Your level of understanding of UNIX processes and system loading

Users unfamiliar with system parameters will typically choose to display CPU and
disk usage. The typical setup for a more aware user is to display the CPU usage, disk
usage, system load, and packets. Here are some hints and tips for choosing what to
monitor:

� If you are worried about network traffic congestion, display the number of network
packets per second and monitor this performance while you are running
network-intensive activities such as Internet browsing or remote operations.
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� If Performance Meter indicates high CPU usage, use Process Manager to identify
and kill errant or CPU-intensive processes.

� If you log out while running a CPU intensive application, and log back in,
Performance Meter’s CPU display may show you that there is a lot of CPU activity.
On recognizing this, you can use Process Manager to kill any errant processes.

For further information, see Managing System Performance in System Administration
Guide: Advanced Administration.

� To Specify the Host to Be Monitored
1. Choose Setup from the Options menu.

Performance Meter displays the Setup dialog box.

2. Select the Remote radio button to indicate that you are about to type the name of a
remote host.

3. Type the system name (for example, jupiter) or the IP address (for example,
129.156.220.133) of the remote host.

Tip – To find a host, use Address Manager with Hosts selected on the Find menu.

4. Click Apply to make your changes take effect.

Performance Meter accesses the remote host and displays its performance. The system
name on the title bar of the Performance Meter main window changes to the name of
the remote host.

� To Change the Parameters Displayed
1. Open the View menu to display the list of available parameters.

Each parameter has a checkbox to indicate whether it is currently selected for display.

2. Select or deselect the relevant menu item to display or remove any of the
parameters.

You can display any combination of parameters.
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Choosing How the Parameters Are
Displayed
You can arrange the Performance Meter window in different ways, depending on the
number of parameters you have chosen to display, the space available on your
desktop, and whether you want to display historical values.

FIGURE 20–1 Performance Meter Displaying All Parameters

� To Show/Hide the Menu Bar
� Choose Hide/Show Menubar from the Options menu.

Performance Meter hides the menu bar.

You can re-display the menu bar at any time by clicking once on the display area of
the Performance Meter main window.

� To Show/Hide the Line Chart or Area Chart
� Choose Hide/Show Strip Chart from the Options menu.

Performance Meter hides the line/area charts for all displayed parameters if they were
displayed, or displays the line/area charts if they were hidden.

For each parameter you choose to display, Performance Meter displays:

� An activity bar to show the instantaneous level for each parameter

� (Optional) A line chart or an area chart to show the performance for each
parameter over time
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� To Change the Orientation of the Charts
By default, Performance Meter displays the performance charts horizontally
(side-by-side). Depending on the number of parameters you monitor and the available
space on your desktop, you may want to display them vertically.

1. Choose Setup from the Options menu.

Performance Meter displays the Setup dialog box.

2. Select Vertical or Horizontal to specify the type of chart required.

3. (Optional) Select the Show Limit Line checkbox if you want your charts to indicate
the threshold value using a line.

4. Click Apply when you are satisfied with the changes you have made.

Performance Meter displays the performance information in the specified orientation.

� To Choose Line Charts or Area Charts
The optional chart displayed for each parameter can be one of the following types:

� A line chart (the default), which represents activity using a continuous line

� An area chart, which is the same as a line chart but with the area between the line
and the horizontal axis filled

Line charts Area charts

1. Choose Setup from the Options menu.

Performance Meter displays the Setup dialog box.

2. Select the Solid choice button for area charts or the Line choice button for line
charts.
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3. (Optional) Select the Show Limit Line checkbox if you want your charts to indicate
the threshold value using a line.

4. Click Apply when you are satisfied with the changes you have made.

Performance Meter displays the information using the specified charts.

Working With Colors and Thresholds
Performance Meter uses colors and thresholds to help you differentiate between
activity that you consider normal and activity that you consider exceptional. If a
parameter exceeds a threshold value, the exceptional value is displayed using a
different color. By default, values less than the default thresholds are displayed in blue
and values exceeding the default thresholds are displayed in red.

The Setup dialog box enables you to change the colors and threshold values.

Tip – Be consistent in your use of colors: if red means “warning” for one parameter,
then it should mean the same for the other.

If you do not know an appropriate threshold value for a parameter, consider using the
same color for both “above” and “below” so that you are only monitoring activity.

� To Change Chart Colors
1. Choose Setup from the Options menu.

Performance Meter displays the Setup dialog box. For each parameter, color selectors
enable you to choose the colors for values above and values below the current
threshold.

2. Press mouse button 1 on any of the color selectors and choose a new color.

3. Click Apply when you are satisfied with the changes you have made.

Performance Meter applies the new colors to the display.
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� To Change the Threshold Value for a Parameter
1. Choose Setup from the Options menu.

Performance Meter displays the Setup dialog box which contains a Threshold box for
each parameter.

2. Type a new threshold value for the relevant parameter and click Apply.

Values below the new threshold value are now displayed using the color selected for
below, and values above this threshold value are now displayed in the color selected
for above.

TABLE 20–1 Default Threshold Settings

Parameter Default Threshold Value

CPU 50%

Load 2 per second

Disk 20 per second

Page 8 per second

Context 32 per second

Swap 2 per second

Interrupts 50 per second

Packets 16 per second

Collisions 2 per second

Errors 2 per second

Logging Samples and Choosing the
Sample Interval
By default, Performance Meter samples the activity on the workstation every 2
seconds, and creates a log file containing details of the initial sample only. You can
change this sample interval and choose to continually add the sample information to a
log file.
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� To Save Sample Information to a Log File
1. Choose Setup from the Options menu.

Performance Meter displays the Setup dialog box.

2. Select the Log Samples In checkbox.

3. Type the name of your log file in the Log Samples In text box.

Use a descriptive name such as the default samples, or if you are monitoring
multiple hosts from your workstation: samples_hostname.

The default location is your home folder, such as /home/fredj/samples.

4. Click Apply to make your changes take effect.

Performance Meter creates the specified log file (a text file) if it doesn’t exist.
Performance Meter continues to append sample details for each sample until you exit
Performance Meter. The next time you run Performance Meter, the Log Samples In
checkbox will be unselected.

� To Change the Sample Interval
1. Choose Setup from the Options menu.

Performance Meter displays the Setup dialog box.

2. Specify a new sample interval in the Sample Every selector.

The number you specify must be a whole number between 1 and 9 (inclusive). If you
are viewing performance on-screen, a low interval such as 3 seconds may be
appropriate; if you are logging samples to a log file, a higher interval is useful for
restricting the size of your log file.

3. Click Apply to make your changes take effect.

Performance Meter samples at the specified rate for this and all future sessions, until
you change the value in the Sample Every selector again.
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CHAPTER 21

Using Hotkey Editor

Use the Hotkey Editor to create, modify, or delete CDE hotkeys. Hotkey is a general
term used to show the association between a specific key and a specified event (target
event). For example, choosing Alt+Left will move the workspace to the left. The target
event could be a CDE action, an application, a document, a workspace management
function, or a multiple monitor management function.

� To Start Hotkey Editor
� Creating a Hotkey
� Editing a Hotkey
� Deleting and Recovering Hotkeys

To Start Hotkey Editor
The first time the Hotkey Editor is started, the display area is populated with the
currently defined hotkeys. These keys are the default keys which are presented as
pre-defined keys. The Hotkey Editor application has two screens, the main Hotkey
Editor window and the Edit Key dialog box. You can start Hotkey Editor from:

� Application Manager
� The front panel
� The command line

To start Hotkey Editor from Application Manager:

1. In Application Manager select Desktop_Apps.

2. Double-click the Hotkey Editor icon.
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The Hotkey Editor window is displayed.

You can only bring up one instance of the Hotkey Editor. The buttons on the toolbar
can be used for creating, editing, and deleting hotkeys. Alternatively, right-click the
mouse button over the display area for a drop-down list of the same menu options. At
the bottom of the window is an explanation of what the starred items mean, as well as
an update of the most recently executed action on a hotkey.

Click on a hotkey to select it. Double-clicking a hotkey opens the Edit Key dialog box
and populates it with that hotkey’s current data. Use the Edit Key dialog box to create
and edit hotkeys.

To start Hotkey Editor from the front panel:

1. Open the Tools subpanel by clicking on the tab.
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2. Click the Hotkey Editor icon.

To start Hotkey Editor from the command line, type sdthotkey.

Creating a Hotkey
Hotkey Editor does not permit you to create duplicate hotkeys. You can create single
letter hotkeys (for example “a”) . However, this is not recommended due to the
probability of accidentally triggering a target event. Hotkey Editor is not
case-sensitive, for example, “A” is the same as “a”.

You can create or edit hotkeys to affect the following targets:

� An application, action, or document
� A workspace management function
� A multi-monitor management function

To Create a Hotkey for an Application, Action, or
Document

1. From the Hotkey Editor window, click New.
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2. For Step 1, from the pull-down menu, select An application, action, document.

3. In Step 2, establish the target that the hotkey will affect.

a. Click on either Application Manager or File Manager to display their respective
icons.

b. Select an icon and drag and drop it into the Drop the target here field.
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4. Under Step 3, in the text field, type the keystrokes of your choice that will act as the
hotkey.

To determine where the hotkey will be effective, click Show Details.

5. (Optional) Modify where the target event will be active and the path to the target
event.

Unless specified the hotkey will be effective everywhere. You can also modify the
hotkey’s target name or path if no drag and drop option exists for the target.

a. Specify where the hotkey will be active.

� Everywhere - The created hotkey takes precedence over an application assigned
hotkey

� Only in application windows - The hotkey is effective only in an application
window

� Only on the desktop - Hotkey is effective only on the backdrop of the monitor

b. Type the path to the target event that the hotkey will affect.

You may also click Browse to navigate to the target event directory.

c. Enter the command-line argument.

This permits you to have extra command line arguments associated with the target.

6. Click Save As New.

7. Click Cancel to close the dialog box.

8. In the main Hotkey Editor window, choose Save from the File menu.

This will activate the hotkey.

Once you have completed creating a hotkey, you can begin creating another new
hotkey without exiting the current Edit Key dialog box.
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To Create a Hotkey for a Workspace Management
Function

1. From the Hotkey Editor window, click New.

2. For Step 1, from the pull-down menu, select A workspace management function.

3. In Step 2, select an option under Workspace Function:

� Previous Workspace - Moves you to the previous workspace

� Next Workspace - Moves you to the next workspace

� Goto Workspace - Moves you to a specified workspace

� Create Workspace - Creates a new workspace

� Delete Workspace - Deletes a workspace

� Pack Icons - Packs the icons in the workspace

� Refresh All Windows - Updates all windows with any changes you made

� Toggle Front Panel - Switches the front panel between the open and close state
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� Pass Keys - The defined pass key will override all existing hotkeys. Toggle the pass
key hotkey to switch between the on/off modes.

The Workspace Name listbox contains the workspace names as shown on the front
panel. It also contains a system identifier in case duplicate names are created. The
Workspace Name listbox is enabled only if the workspace function list on the left
requires a workspace argument. If you are creating a new hotkey, the first option in
the Workspace Function listbox is already selected.

4. Under Step 3, in the text field, type the keystrokes of your choice that will act as the
hotkey.

To determine where the hotkey will be effective, click Show Details.

5. (Optional) Specify where the hotkey will be active.

� Everywhere - The created hotkey takes precedence over an application assigned
hotkey

� Only in application windows - The hotkey is effective only in an application
window

� Only on the desktop - Hotkey is effective only on the backdrop of the monitor

6. Click Save As New.

7. Click Cancel to close the dialog box.

8. In the main Hotkey Editor window, choose Save from the File menu.

This will activate the hotkey.

Once you have completed creating a hotkey, you can begin creating another new
hotkey without exiting the current Edit Key dialog box.

To Create a Hotkey for a Multi-Monitor
Management Function

1. From the Hotkey Editor window, click New.
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2. For Step 1, from the pull-down menu, select A multi-monitor management function.

3. In Step 2, select an option under Multi-Monitor Function:

� Next Monitor - Moves to the next monitor
� Previous Monitor - Moves to the previous monitor
� Last Monitor - Moves to the last monitor
� Goto Monitor - Moves to a specified monitor

The Multi-Monitor Function listbox contains the monitor function. The Monitor
Number listbox contains a list of monitors available on your desktop.

If you are creating a new hotkey, the first option in the Multi-Monitor Function listbox
is already selected.

4. Under Step 3, in the text field, type the keystrokes of your choice that will act as the
hotkey.

To determine where the hotkey will be active, click Show Details.
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5. (Optional) Specify where the hotkey will be active.

� Everywhere - The created hotkey takes precedence over an application assigned
hotkey

� Only in application windows - The hotkey is effective only in an application
window

� Only on the desktop - Hotkey is effective only on the backdrop of the monitor

6. Click Save As New.

7. Click Cancel to close the dialog box.

8. In the main Hotkey Editor window, choose Save from the File menu.

This will activate the hotkey.

Once you have completed creating a hotkey, you can begin creating another new
hotkey without exiting the current Edit Key dialog box.

Editing a Hotkey
You can edit a hotkey to change or modify its target event. An edited hotkey will
replace the currently defined hotkey. Hotkey Editor will not warn you prior to
overriding existing hotkeys.

To Edit a Hotkey for an Application, Action, or
Document

1. In the Hotkey Editor window, double-click a hotkey.

Alternatively, select a hotkey and click Open.

The Edit Key dialog box opens with the specifics for that hotkey.

2. For Step 1, from the pull-down menu, select An application, action, document.

To change the type of target that the hotkey will trigger, select the appropriate option
from the pull-down menu.

3. In Step 2, establish the target that the hotkey will affect.

a. Click either the Application Manager or File Manager to display their respective
icons.
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b. Select an icon and drag and drop it into the Drop the target here field.

4. Under Step 3, in the text field, type the keystrokes of your choice that will replace
the currently defined hotkey

To determine where the hotkey will be effective, click Show Details.

5. (Optional) Modify where the target event will be active and the path to the target
event.

Unless specified the hotkey will be effective everywhere. You can also modify the
hotkey’s target name or path if no drag and drop option exists for the target.

a. Specify where the hotkey will be active.

� Everywhere - The created hotkey takes precedence over an application assigned
hotkey

� Only in application windows - The hotkey is effective only in an application
window

� Only on the desktop - Hotkey is effective only on the backdrop of the monitor

b. Type the path to the target event that the hotkey will affect.

You can also click Browse to navigate to the target event directory.

c. Enter the command-line argument.

This permits you to have extra command line arguments associated with the target.

6. Click Update.

7. Click Cancel to close the dialog box.

8. In the main Hotkey Editor window, choose Save from the File menu.

This will activate the hotkey.

You cannot edit multiple hotkeys in the same Edit Key dialog box. You will have to
complete the edits on the current hotkey, close the Edit Key dialog box, and then select
and open the next hotkey to be edited.

To Edit a Hotkey for a Workspace Management
Function

1. In the Hotkey Editor window, double-click a hotkey.

Alternatively, select a hotkey and click Open.

The Edit Key dialog box displays with the specifics for that hotkey.
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2. For Step 1, from the pull-down menu, select A workspace management function.

To change the type of target that the hotkey will trigger, select the appropriate option
from the pull-down menu.

3. In Step 2, select an option under Workspace Function:

� Previous Workspace - Moves you to the previous workspace

� Next Workspace - Moves you to the next workspace

� Goto Workspace - Moves you to a specified workspace

� Create Workspace - Creates a new workspace

� Delete Workspace - Deletes a workspace

� Pack Icons - Packs the icons in the workspace

� Refresh All Windows - Updates all windows with any changes you made

� Toggle Front Panel - Toggles the front panel between the open and close state

� Pass Keys - The defined pass key will override all existing hotkeys. Toggle the pass
key hotkey to switch between the on/off modes.

The Workspace Name listbox contains the workspace names as shown on the front
panel. The Workspace Name listbox contains a system identifier in case duplicate
names are created. The Workspace Name listbox is enabled only if the workspace
function list on the left requires a workspace argument.

4. Under Step 3, in the text field, type the keystrokes of your choice that will replace
the currently defined hotkey.

5. (Optional) Specify where the hotkey will be active.

� Everywhere - The created hotkey takes precedence over an application assigned
hotkey

� Only in application windows - The hotkey is effective only in an application
window

� Only on the desktop - Hotkey is effective only on the backdrop of the monitor

6. Click Update.

7. Click Cancel to close the dialog box.

8. In the main Hotkey Editor window, choose Save from the File menu.

This will activate the hotkey.

You cannot edit multiple hotkeys in the same Edit Key dialog box. You will have to
complete the edits on the current hotkey, close the Edit Key dialog box, and then select
and open the next hotkey to be edited.
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To Edit a Hotkey for a Multi-Monitor Management
Function

1. In the Hotkey Editor window, double-click a hotkey.

Alternatively, select a hotkey and click Open.

The Edit Key dialog box displays with the specifics for that hotkey.

2. For Step 1, from the pull-down menu, select A multi-monitor management function.

To change the type of target that the hotkey will trigger, select the appropriate option
from the pull-down menu.

3. In Step 2, select the target that the hotkey will affect:

� Next Monitor - Moves you to the next monitor
� Previous Monitor - Moves you to the previous monitor
� Last Monitor - Moves you to the last monitor
� Goto Monitor - Moves to a specified monitor

The Multi-Monitor Function listbox contains the monitor function. The Monitor
Number listbox contains a list of monitors available from your desktop.

4. Under Step 3, in the text field, type the keystrokes of your choice that will replace
the currently defined hotkey.

5. (Optional) Specify where the hotkey will be active.

� Everywhere - The created hotkey takes precedence over an application assigned
hotkey

� Only in application windows - The hotkey is effective only in an application
window

� Only on the desktop - Hotkey is effective only on the backdrop of the monitor

6. Click Update.

7. Click Cancel to close the dialog box.

8. In the main Hotkey Editor window, choose Save from the File menu.

This will activate the hotkey.

You cannot edit multiple hotkeys in the same Edit Key dialog box. You will have to
complete the edits on the current hotkey, close the Edit Key dialog box, and then select
and open the next hotkey to be edited.
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Deleting and Recovering Hotkeys
You can delete and recover hotkeys. You can also choose to revert to the original
settings of an edited hotkey.

To Delete a Hotkey
1. Click on a hotkey in the main Hotkey Editor window.

2. From the Edit menu select Delete.

Alternatively, click on the delete button from the tool bar. The status bar at the bottom
of the window will indicate which hotkey was deleted.

To Undo the Previous Action
� From the Edit menu select Undo.

To Redo the Previous Action
1. Click on a hotkey in the main Hotkey Editor window.

2. From the Edit menu select Redo.

The status bar at the bottom of the window will indicate which hotkey was redone.

To Revert to a Previous Hotkey
1. Click on a hotkey in the main Hotkey Editor window.

2. Click on the Revert button from the tool bar.

This option does not activate a modified and saved hotkey, instead, it reverts to the
previously defined fields for that hotkey. The status bar at the bottom of the window
will indicate the hotkey to which it was reverted.
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CHAPTER 22

Using Personal Digital Assistant (PDA)
Synchronization

The Personal Digital Assistant Synchronization (PDA Sync) application enables you to
synchronize data from Sun applications, such as Calendar Manager, with data in a
similar application on your PDA. It also enables you to install applications and
databases from your workstation or server to your PDA.

For example, applications that have been downloaded from the web can be copied to
your PDA using PDA Sync. All illustrations in this document depict the software
interacting with a PDA.

The applications correlate as Calendar manager/Date Book, Address
manager/Address Book, Desktop Mail/Mail, and Text Note/Memo Pad. PDA Sync
supports most Palm Pilot Computing platform handheld devices, including the Palm
V, Palm III and PalmPilot Professional Edition.

� Accessing PDA Sync Software
� Configuring Synchronization
� Configuring Conduits
� Configuring the Log
� Starting Synchronization
� Checking Status

Note – Please refer to "About PDA Sync" in the online help pulldown menu for
important information on the differences between Sun’s PDA Sync and 3COM’s
HotSync product.

Accessing PDA Sync Software
Access the PDA Sync software using the following procedure.
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1. Using the desktop icon, open the Applications pull-down menu from the Front
Panel (typically at the bottom of your screen), click on Applications to open
Application Manager.

2. Double-click on Desktop_Apps to locate the PDA Sync icon.

3. Click on the PDA Sync icon.

You can also access the PDA software by entering /usr/dt/bin/sdtpdasync an the
command line.

In order to make the PDA Sync icon more accessible in the future, drag and drop
the PDA Sync icon from the Desktop_Apps screen into the Install area of the
Application pull-down menu or into your user space.

For more information on the PDA Sync application, see the Help information on
the PDA Sync software.

Configuring Synchronization
The application opens by default to the Synchronization tab.

FIGURE 22–1 Configuring Synchronization

The application begins a synchronization operation using current or default
configurations on the currently active or default conduits, as defined on the Conduits
tab. The first thing you must do when the Synchronization window appears is
establish the port setting in the Synchronization Properties window.
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Setting Synchronization Properties
Clicking the properties button (the one with a checkmark on it) on the
Synchronization tab brings up the Synchronization Properties dialog box (refer to the
following figure). This dialog contains all of the PDA Sync options that are not directly
related to specific conduits and therefore do not belong in the conduit configuration
dialog boxes. The options in this dialog box are not likely to require changing very
often.

FIGURE 22–2 Setting Synchronization Properties

In this dialog you can:

� Set the serial port. Select the port from the options list to which you connected the
PDA.

� Set the port speed. The default is “As fast as possible”. The choices in this
pull-down menu are the speeds that are supported by the API.

� Set the “Iconify application window after synchronization” to ON (default) or OFF.
The window will minimize itself to an icon automatically upon completion of the
sync. If it is turned OFF, the window will remain open on the screen after the sync
is completed.

Configuring Conduits
The Conduits tab contains a list of all the conduits that are available to the PDA Sync
application. This is not a fixed list, as conduits can be added and removed. Active
conduits are indicated with a check mark. A Synchronize operation runs all of the
active (checkmarked) conduits ONLY, as shown in the following figure.
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FIGURE 22–3 Configuring Conduits

The buttons below the scrolling list represent actions you can take on the selected
conduit in the list (except the Add Conduit button). When the pointer is over one of
the buttons, the button name is displayed in a small Button Tag that appears near the
button. The button names in the toolbar are:

� “Change Conduit Settings” (a checked box) - brings up the configuration dialog for
that particular conduit and is disabled if more than one item is selected.

� “Toggle the Conduit’s Activate State” (a check mark) - Either activates or
deactivates the conduit. When a conduit is active, it is executed in the next
synchronization.

� “Add New Conduit to List” (a plus (+) symbol) - Brings up a file selection dialog
enabling you to add new conduits. (See the Adding a Conduit section.)

� “Delete Conduit from List”(a minus (-) symbol) - Removes the conduit from the
list, after a confirmation dialog.

Calendar
The Configure Calendar Conduit window enables you to determine how
appointments are synchronized between calendar applications. Refer to the following
figure.
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FIGURE 22–4 Configuring the Calendar Conduit

In this window you can:

� Change the host name. The default is user@host.

� Specify the base calendar on the workstation or server.

� Determine a rolling date range to synchronize. The default range is six months.

� Determine what information is displayed for others to see on private appointments
marked on your PDA.

� Change the data synchronization direction to:

� Synchronize the files (this is the default) — merges the calendar information on
your desktop and your PDA.

� Desktop overwrites PDA — replaces your PDA calendar information with the
calendar information you have on your workstation.

� PDA overwrites desktop — replaces your desktop calendar information with
the calendar information you have on your PDA.

Memo
The Configure Memo Conduit window enables you to synchronize text files between
the desktop and the PDA as shown in the following figure.
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FIGURE 22–5 Configuring the Memo Conduit

You change the data synchronization direction to:

� Synchronize the files (this is the default) — merges together information on your
desktop and your PDA.

� Desktop overwrites PDA — replaces your PDA memo information with the memo
information you have on your workstation.

� PDA overwrites desktop — replaces your desktop memo information with the
memo information you have on your PDA.

In the memos directory, separate directories can be created for different categories of
memos, such as Business and Personal. These become categories on your PDA when
synchronized. Conversely, new categories on your PDA become directories in the
memo folder on your file system when synchronized. If the category directory is
deleted from the desktop, the category and all of its records are deleted from the
handheld device when synchronized.

534 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



Address
The Configure Address Conduit dialog box (refer to the following figure) enables you
to determine how entries are synchronized between address applications.

FIGURE 22–6 Configuring the Address Conduit

In this window you can select the data synchronization direction. The default is to
merge the data. In the address directory, subdirectories can be created for different
categories of addresses, such as Business and Personal. These become categories on
your PDA when synchronized. If the category directory is deleted from the desktop,
the category and all of its records are deleted from the handheld device when
synchronized. Additional layers of subordinate directories are not supported.

System
The Configure System Conduit backs up all system information, graffiti shortcuts, and
any .pdbs and .prcs that are NOT already associated with other applications. The
default is that your PDA overwrites the desktop. Refer to the following figure.
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Note – You should choose "Desktop overwrites PDA" only if everything on your PDA
has been corrupted or lost. Refer to the following figure.

FIGURE 22–7 Configuring the System Conduit

Mail
The Configure Mail Conduit window tells your PDA your INBOX location. Refer to
the following figure.

In this dialog you can define the IMAP location of the INBOX (server.domain) or the
local location of the INBOX (path and filename).
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In addition, the IMAP choice requires that you submit a login ID and password. You
can save the login and password to avoid retyping. If the ID and password are NOT
saved, synchronization is interrupted every time with the following dialog box (refer
to the following figure).

FIGURE 22–8 Configuring the Mail Conduit

You can choose to have the desktop mailbox overwrite your PDA mailbox. This is set
to “OFF” by default.

Note – This option should only be used if your PDA INBOX folder is not in sync with
your desktop.

All other setup for mail synchronization is done on your PDA. When you synchronize,
your PDA automatically:

� Sends mail from the Outbox.
� Destroys the deleted mail in the Deleted folder.
� Does the things you have defined in the options.

In the Mail synchronization options on the PDA, you can tell your PDA to:

� Synchronize mailbox (for example, make the two Inboxes identical, given the
constraints, which include no attachments and truncation of messages). This is the
same as setting the PDA parm option to All.

� Send mail from the Outbox only and retrieve nothing. This is the same as setting
the PDA parm option to Send Only.
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� Synchronize mail according to a filter. This is the same as setting the PDA parm
option to Filter. The messages are truncated to a specified length; the range is: 250,
500, 1000, 2000, 4000, 6000, 8000. The filter can operate two ways:

� Ignore messages with a certain criteria and retrieve all others.
� Retrieve messages with a certain criteria and ignore all others.

Installer
The Configure Installer Conduit window allows you to determine which files
(applications or databases) to install on your PDA. Refer to the following figure

FIGURE 22–9 Configuring the Installer Conduit

In this dialog you can display all the files that are available for installation to your
PDA. These are all the files currently in the default install directory. Use the Add
PalmPilot Applications window refer to the following figure), by clicking the plus (+)
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symbol, to add files. To delete files from the list, select the file and click the minus (-)
symbol. All files in the list are installed on the next sync operation.

FIGURE 22–10 Adding an Application

Adding a Conduit
Click the Add button on the Add PalmPilot Applications window to get to the Add
Conduit window. This enables you to add conduits to PDA Sync. Refer to the
following figure.

FIGURE 22–11 Adding a Conduit

The available conduits come from one of three categories, represented in the
pull-down menu:

� Personal Conduits (default) — Conduits that you may have obtained from the Web
or elsewhere.
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� System Default — The default set that the PDA Sync application comes with (for
example, Calendar, Memo, Address). You should use conduits from this category to
replace any defaults that have been deleted.

� System Additions — Any third-party conduits added automatically through
packages.

If you want to add a new conduit not currently in any of the folders, press the “Import
Conduit” button to bring up the Import Conduit dialog. Refer to the following figure.

FIGURE 22–12 Importing a Conduit

Select a file and press the Import button. The file will be copied into the selected
folder. If it is a conduit previously deleted from the Conduit tab, it will automatically
be added back to the list. If the Conduit is a new one, then the Associate Conduit
dialog will display. Refer to the following figure.

A list of the available databases will display in this list only if they are already
installed on the PalmPilot. If you want to install a new database you must first install
the database (refer to the Installer section under Configuring Conduits).

Then select a database in the list and click OK. The conduit will be added to the
conduit list.
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FIGURE 22–13 Associating Conduits

Configuring the Log
To configure the log you must first go to the Log tab. Refer to the following figure.

FIGURE 22–14 Configuring the Log

To configure the Log you must access the Log Properties dialog by clicking on the
checked box Refer to the following figure.
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FIGURE 22–15 Configuring the Log Properties

In this dialog you can:

� Set log file properties (a log file will be saved by default).
� Append to the last log file.
� Overwrite the last log file.
� Show diagnostic information in log (default is OFF).
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Viewing the Log
The third tab in the PDA Sync application lets you view the activity log for each
synchronization. This area consists of a vertical and horizontal scrolling read-only text
field, which displays a real-time log of a sync or install operation. Refer to the
following figure.

FIGURE 22–16 Viewing the Log

By default, the top of the log is displayed at the top of the data window. Because the
log file can be appended (see Log Properties dialog in the next section), the top of the
current log may be at the bottom of the file. This means that the scroll bar may be at
the bottom of the window when the log is displayed; scrolling up reveals previous
logs.

By default, the date on which the sync operation is performed is displayed at the top
and bottom of the current log. Time stamp information is added as appropriate. You
can also choose to show full debugging information in the log through an option on
the Log Properties dialog.

If a failure occurs during a synchronization operation, the log is displayed
automatically. At the time the failure occurs, the system beeps, the log shows where
the failure occurred, and the sync operation is aborted. These entries usually give as
much information as is reasonable to provide. You may also turn on debugging
information in the Log Properties dialog in order to troubleshoot. After a failure
occurs, the application does not minimize itself, regardless of the "Iconify application
window after synchronization" setting in the Application Properties dialog.
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Printing the Log
The log is saved to disk as a text file. The log file can also be printed. Refer to the
following figure.

FIGURE 22–17 Printing the Log

Starting Synchronization
The PDA Sync application is available as an icon on the Common Desktop
Environment (CDE) desktop. It is activated when you first log in. When you exit the
application, restart it manually in order to perform synchronization again.

The following figure shows that the application is ready to synchronize, as indicated
by the status line. At this point, you may press the sync button on your organizer’s
cradle.

If you are synchronizing for the first time after installing PDA Sync, a dialog box
appears asking you to name your organizer. If your organizer already has a name, this
dialog box does not appear. Refer to the following figure.
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FIGURE 22–18 Naming Your PDA

If your organizer has a password, a dialog box asks you for it every time you run the
application. If your organizer does not have a password, this dialog does not appear.
Refer to the following figure.

FIGURE 22–19 Assigning Your PDA a Password

Checking Status
The status area contains information about the current operation. This information
includes status or prompt text, an animated graphic that indicates that an operation is
in progress, and a progress bar that shows estimated progress during a sync operation.
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FIGURE 22–20 Checking Synchronization Status

The progress bar is not displayed unless a sync or install operation is in progress.
Choosing Cancel Synchronization pauses the sync operation and brings up a
confirmation dialog box. If you choose the Cancel button, the sync is aborted. If you
choose Continue, the sync operation continues.

Completion of a sync operation is indicated by an audio signal. If the "Iconify
application window after synchronization" option is checked in Application
Properties, the window minimizes itself to an icon automatically upon completion of
sync.

Note – To cancel synchronization click on the Cancel button.
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CHAPTER 23

Power Management

This chapter gives an overview of Power Management™ and explains the features
that apply to your system by default when you use this Solaris™ release. It also
explains how to customize the Power Management features.

Value of Power Management
Reducing the amount of power consumed by a computer not only reduces the cost of
the electricity itself, it also reduces the efforts required to control the heat surrounding
the computer. Reducing power consumption also can extend the effective life of the
hardware you use.

The United States Environmental Protection Agency (EPA) has established Energy
Star® guidelines for computer products. Other nations have issued similar energy
efficiency guidelines. To meet these guidelines, hardware products are designed to use
power efficiently.

The Power Management software provided in the Solaris operating environment
works in conjunction with the hardware to reduce overall consumption of electricity.
In some cases, you may need to use this software for your workstation to meet the
Energy Star guidelines that apply to that hardware.

Note – As an Energy Star Partner, Sun Microsystems, Inc. has determined that its
hardware products that have the Energy Star symbol on the shipping box or on the
product itself meet the Energy Star guidelines for energy efficiency.
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Types of Power Management
Power Management software enables two ways of reducing power consumption:
Device power management and Suspend-Resume.

Device Power Management
Device power management automatically reduces the amount of power used by
individual devices when they are not in demand to perform some function. Disk
drives, monitors, adapters, and even CPUs can provide this power-saving feature. The
effect of device power management is transparent to the computer user. The overall
system is still in operation, and is able to respond to requests for service from devices.
Those devices are able to power up for full service within seconds when needed.

Suspend-Resume
Suspend-Resume is a time-saving feature that allows you to turn off the power to your
system without losing the state of your current activities. When you use this feature,
your workspace and files are preserved when the system is powered off and restored
to the same state when the system is powered on. For example, if you are in the
middle of revising a document when you decide to leave, you can power off your
system using the Suspend feature and your work session is automatically saved. The
next time you power on the system, the Resume feature causes your work to appear in
the same state as you left it. Whether a shutdown is initiated automatically (through
Power Management software) or manually through keystrokes, the Suspend-Resume
feature saves checkpoint information about the state of the system at that time.

Suspend-Resume can be active on your system in the following ways:

� Suspend-Resume is used automatically in some Energy Star 2.0-compliant systems.

� You can use the keyboard to suspend or resume your system whenever you
choose. The steps for doing this are explained in Chapter 4 “Using the
Suspend-Resume Feature”.

� Dtpower software can be used to activate Suspend-Resume automatically at
designated times.

548 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



Caution – Do not use System Power Management on systems that do work that
should not be interrupted. Conditions where you should choose to not use the
Suspend-Resume features are described in “Using the Suspend-Resume Feature”
on page 560.

Hardware Support for Power
Management Features
All SPARC workstations can use some features of the Power Management software.
However, some features only work on certain types of hardware. Some default power
states vary from one type of system to another.

The following section describes the Power Management features that are supported by
your hardware, as well as the defaults that will be in effect when you first use this
Solaris release with your hardware.

Note – Intel hardware running the Solaris operating environment does not support
Power Management.

Power Management Features on Different
Hardware Systems
The Power Management features are enabled by both the hardware’s power-saving
capability and the software provided with the Solaris operating environment. The
exact nature of the power-saving mode your system goes into depends on your
hardware and its compliance with Energy Star. To determine the version of Energy
Star to which your system complies, use the prtconf -vp | grep energystar
command.

Power Management-capable hardware provides the features discussed in the
following sections.

Energy Star 3.0-Compliant Systems
The Energy Star 3.0-compliant SPARC™ hardware reduces power consumption by
entering a low-power mode from which devices can resume full operation
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automatically. This hardware can turn off monitors and frame buffers, spin down
disks, and drop the devices’ power consumption significantly when they are idle — all
while leaving the system up and running, ready for use, and visible on the network.
When a job appears on the system, either through a cron process, or an external
demand through a network, the devices and other hardware snap back into full-power
mode within seconds.

Energy Star 2.0-Compliant Systems
The earlier, Energy Star 2.0-compliant SPARC hardware does not have the capability
of going into a reduced-power mode; after the designated minutes of idleness, the
system completely shuts down. The exception to this are the monitors, which do have
the capability of going into low-power mode and continuing to operate. Upon restart,
the system takes a minute to reboot.

Systems Noncompliant with Energy Star
Systems that are noncompliant with Energy Star regulations perform power
management for only the monitor; no other devices are power managed.

System Architecture Distinctions and Default
Settings
The SPARC architecture of a workstation determines which Power Management
features are available. The default behavior in Power Management functions varies on
systems, as described in Table 23–1.

To determine your system’s architecture, use the uname -m command.

If you have Sun Microsystems™ hardware that is not described by this manual, refer
to the Sun Hardware Platform Guide for this Solaris release. It may contain additional
information about how Power Management software functions on your system.

TABLE 23–1 Power Management Features in Different SPARC Architectures

Power Management Features sun4m sun4u (Energy
Star 2.0)

sun4u (Energy
Star 3.0)

Servers

Display PM Available Yes Yes Yes Yes

Display PM by Default Yes Yes Yes Yes

Device PM Available No No Yes No
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TABLE 23–1 Power Management Features in Different SPARC Architectures (Continued)
Power Management Features sun4m sun4u (Energy

Star 2.0)
sun4u (Energy
Star 3.0)

Servers

Device PM by Default N/A N/A Yes N/A

Suspend-Resume Available Yes Yes Yes No

Suspend-Resume by Default No Yes No N/A

AutoShutDown Available No Yes Yes No

AutoWakeup by Default N/A Yes No N/A

Note – The SPARCstation™ Voyager is a sun4m-architecture system, but it is not
supported in this Solaris release.

Power Management Software
In most cases, the default Power Management settings should suffice. If you would
like to change them, however, you can do so through Dtpower, the Power
Management software.

Dtpower Software
Dtpower launches a graphical user interface (GUI) that allows you change your power
saving scheme, or to designate periods of inactivity after which the devices (including
the monitor and disk drives) and the system will go into a power saving mode.

You can also use the Dtpower GUI to set the time of day to activate the
Suspend-Resume feature (called AutoShutdown when configured through Dtpower).
For example, if you want the AutoShutdown feature to activate only after your regular
work hours. On sun4u-architecture workstations, you can also activate the
AutoWakeup feature of the Dtpower software, which will power on the system at a
specific time following an AutoShutdown.

Power Saving Schemes
The simplest way to manage your system power is by selecting one of three
power-saving schemes offered by the Dtpower program:
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� Standard — Power management for all capable devices
� Minimal — Power management for monitors only
� Disabled — No power management

In addition to these three schemes, you can also create a customized power scheme,
which is discussed in “Customizing Power Schemes” on page 555.

Basic Dtpower Settings and
Configurations
This chapter describes the Dtpower GUI and its conventions. It also explains the
preset power-saving schemes for Dtpower.

Accessing Dtpower
In previous releases, it was necessary to start the Dtpower software as superuser to
edit the configurations. In this release, the program can be started in a number of
ways, all of which allow you to change the configurations.

Note – If you are unable to access Dtpower for editing purposes, it may be because
you do not have the correct permissions. See the dtpower(1M) man page for details.

If Dtpower is already running, it may appear on your desktop as this icon:

FIGURE 23–1 The Dtpower Icon

� To Start Dtpower Through the CDE Workspace
1. On the CDE desktop, hold down the menu button on your mouse.

2. From the pull-down list, select Tools.

3. From the pull-down list, select Power Manager.
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� To Start Dtpower From the Applications Manager
1. From the front panel on the CDE desktop, select Applications Manager.

2. From Applications Manager, select Desktop_App.

3. From Desktop_App, select Power Manager.

� To Start Dtpower From the Command Line
� Start Dtpower:

# /usr/dt/bin/dtpower &

Note – Due to system initialization, Dtpower can take some time to launch.

Overview of the Dtpower GUI

Basic Dtpower Window Controls
Every Dtpower window has one or more of the following buttons:

� A triangle indicates a pull-down menu. In the Figure 23–2, the Current Power
Saving Scheme box can be pulled down to reveal two additional levels of power
management: Minimal and Disabled.

� OK puts into effect the settings currently displayed in the window.

� Cancel reverses settings to the state they were in when OK was previously selected
(or to default values if this is the first time you have run Dtpower). Cancel,
however, will not return to earlier values if you have already selected OK.

� Help displays the Dtpower Help window.

� More expands the window to reveal the full options for editing the idle time for
the system, monitors, and disk drives.

� Less reduces the window to conceal the options revealed through the More button.

� Edit is located in the Quick Edit tab (see Figure 23–5). It opens a window in which
you can configure the AutoShutdown and AutoWakeup options.
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FIGURE 23–2 The Dtpower Basic Window

Power Saving Schemes
The simplest way to select a level of power management for your system is to choose
one of the preset power saving schemes. The schemes appear in the Current Power
Saving Scheme box in the Dtpower basic window. The default scheme is Standard, as
shown in Figure 23–2.

The implementation of the power saving schemes depends on the architecture and the
Energy Star capability of the hardware running Dtpower.

The implementation of the power schemes depends on the power saving capabilities
of your hardware. In addition to the schemes described below, you can also modify
any one of these schemes and save it as a Customized scheme. For more information
on creating a customized power saving scheme, see “Customizing Power Schemes”
on page 555.

The available power schemes are:

� Standard scheme – The default Power Management settings of your hardware
determine the implementation of the Standard scheme. (To determine your
system’s default settings, see “Value of Power Management” on page 547.) SPARC
platforms that are Energy Star 3.0 compatible, for example, reduce power
consumption by entering a power-saving mode for all devices.

� Minimal scheme – Manages power for monitors only. The monitor goes into
power-saving mode after 30 minutes of idleness; no other devices are power
managed.

� Disabled scheme – No power management. None of the components of the system
are power managed.
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� To Select a Power-Saving Scheme
1. Start Dtpower.

This launches the Dtpower basic window.

2. From the pull-down list in the Current Power Saving Scheme box, choose a scheme.

FIGURE 23–3 Pulldown List of Power Saving Schemes

3. Click OK.

Note – Some schemes in the pull-down list may be grayed out; you may be unable to
select them because you do not have the correct permissions.

Customizing Power Schemes
This chapter explains how you can create a customized power scheme, overriding the
schemes that come preset in the Dtpower software.

You cannot overwrite the schemes provided by the system, but you can create a
customized scheme. When you change a system-shipped scheme, a new scheme called
“Customized” is created. When you edit another scheme, that first Customized
scheme is overwritten by the new one. Thus, only one customized scheme can be
saved at any time.

The Customized scheme remains the default scheme even if you reboot your system.
But it is temporary in that it only remains in the system until you select one of the
three preset schemes. Once you do that, the customized scheme is deleted and
removed from the pull-down list of available schemes.
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Power Management of Overall System
The system idle time defines the length of time for which the CPU and the devices
connected to your system must be idle before they power down. Although the GUI
can be used to assign only one idle time for all devices and the CPU, the idle time of
each device is measured separately. If a system has two external hard drives, for
example, and you are only using one of them, the second will go to power-saving
mode after 30 minutes of idleness. The first will go to the power-saving mode
separately, after it has been idle for 30 minutes.

For information on configuring a different idle time for each device, refer to the
power.conf(4) man page.

� To Change System Power Management
1. Start Dtpower.

This launches the Dtpower basic window:

FIGURE 23–4 The Dtpower Basic Window

2. In the Dtpower basic window, select More.

The Quick Edit tab is displayed.
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FIGURE 23–5 Quick Edit Tab

3. From the pull-down list for Default System Idle Time, choose the amount of time
you want all the devices to be idle before powering down.

Or you can type in the system idle time.

Power Management of Monitors
You can override the monitor power management from the overall system power
management through the Dtpower GUI. When you change the idle time for monitor
power, the idle time for all other devices and the system remains as it appears in the
Default System Idle Time box; only the idle time for the monitor power changes.

When the screen goes blank, some monitors can power down, and then power up
when you use the computer again. Other monitors will only blank the screen but not
power down.

Power management of workstations that have two monitors (sometimes called a
“double-headed system”) is also handled through Dtpower. In such a case, both
monitors receive the same idle time setting.
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Note – In some past versions of Solaris operating environment, power management
for monitors was handled through your windowing system’s screen-saver options,
rather than through the Dtpower program. That is no longer the case. Power
management for the monitor, disk drive, and system power are now all handled
uniformly through the Dtpower program.

� To Change Monitor Power Management
1. Start Dtpower.

This launches the Dtpower basic window.

2. In the Dtpower basic window, select More.

The Quick Edit tab is displayed.

3. Check the Monitors - Sleep After Idling For button.

The pull-down list for the monitors’ idle time becomes active.

FIGURE 23–6 Pull-Down List for Disks Idle Time

4. Either choose a time from the pull-down list of idle times or enter a unique value.

You must leave a blank space between the number you enter and the units. Abbreviate
the units to Sec, Min, or Hr, as appropriate. Decimal values are accepted. For
example, if you enter 1.5 Hr, the display idle time will be set to 90 minutes.

If you enter a new value, it is added to the list and will be available the next time you
use the pull-down list. The value will be displayed in the format that you entered it in
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the edit box.

5. Click OK.

� To Reactivate the Monitor
� Move the mouse or press any key.

This restores the power to the monitor, but you may find that your screen is locked.
The screen lock option is set through the Style Manager in CDE. Unlike in previous
versions of the Power Management software, the screen lock is now completely
independent of the Power Management software. If your screen is locked, enter your
password to return to the desktop.

Power Management of Disk Drives
You can override the power management of disk drives just as you can for monitors.
When you change the idle time for disk drives, the idle time for all other devices and
the system remains as it appears in the Default System Idle Time box (see Figure 23–3);
only the setting for the disks’ power changes. All disk drives connected to the system
receive the same idle time.

For information on setting a different idle time for each disk drive, refer to the
power.conf(4) man page.

� To Change Disk Drive Power Management
1. Start Dtpower.

This launches the Dtpower basic window.

2. In the Dtpower basic window, select More.

The Quick Edit tab is displayed.

3. Check the Disk Drives - Sleep After Idling For button.

The corresponding pull-down list for idle time becomes active.

4. Either choose a time from the pull-down list of idle times or enter a unique value.

Leave a blank space between the number you enter and units. Abbreviate the units to
Sec, Min, or Hr, as appropriate. Decimal values are accepted. For example, if you
enter 1.5 Hr, the disk drive idle time is set to 90 minutes.

If you enter a new value, it is added to the list, and will be available the next time you
use the pull-down list. The value will be displayed the way you entered it in the edit
box.
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5. Click OK.

Using the Suspend-Resume Feature
This chapter discusses the issues to consider when choosing to use the
Suspend-Resume feature. It describes how to use the Suspend-Resume features to
manually shut down your system and start it up again in the same working state. It
also explains how to use the Dtpower program to manage system power, such as to
specify when you want the desktop system to shut down automatically. It describes
how to activate or turn off the Suspend-Resume feature.

This chapter points out the few differences in how the Dtpower program operates on
sun4m-architecture desktop machines (such as the SPARCstation™ 20) and on
sun4u-architecture desktop machines (such as the Sun Ultra™ 1).

Note – A command line interface is also provided for a system administrator to
change a desktop machine’s system default settings and to change the idleness
definition. For more information, see the power.conf(4) man page.

Choosing to Use Suspend-Resume
Powering off a desktop system may interfere with some operations that involve that
machine. This section presents some guidelines to take into account before deciding
when to use system Power Management features on a desktop machine.

Electronic Mail Issues
Mail is not sent to any mail spool file on a machine while the machine is suspended.
Typically, if mail cannot be delivered for more than three days, it is returned to the
sender as undeliverable.

If you suspend your system for three days or longer, and your machine has a local
mail spool, you may fail to receive items of mail that have been bounced back to the
sender.
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Mail Alias Issues
Mail aliases on a machine are not available to other users while that machine is
suspended. If the machine is suspended long enough (typically three days), messages
sent to an alias on that machine are bounced back to the sender.

Remote Login Issues
While your machine is suspended, you cannot access it by remote dial-in. That is, you
cannot use rlogin(1) to connect to a machine while that machine is suspended.

Networked Software Issues
The Suspend-Resume feature may have an impact on a networked application. A
networked program may fail if it is not resilient when a peer system is suspended and
does not respond to network traffic.

One example of this is when you run an Xhosted application from one system and
display it on another system. If the Power Management software suspends the latter
system, the application software may fail.

Solstice AutoClient Issues
Do not use Suspend-Resume features on a machine that uses Solstice™ AutoClient™
software.

ATM Issues
The Power Management software is not supported on SunATM™ devices. The ATM
protocol is connection oriented, which means calls must be established between two
endpoints (such as workstations) before data can be transferred. Each end of the call
must maintain the connection actively, so neither end of an ATM connection can use
the Power Management software to suspend and, later, resume the connection.

Cron Job Issues
Operations specified in a cron file do not run during the time a machine is
suspended.

When a system resumes, cron jobs scheduled to run during the time the system was
suspended with the Power Management software are handled in the following way:
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� The first cron job (the one scheduled to run earliest during the time the system was
suspended) is started as soon as the system resumes.

� The second and subsequent cron jobs that might have run during the time the
system was suspended are not run at all.

Normally, the cron command identifies the next job to run and calculates the interval
to wait until it is time to run that job. When a system resumes, the cron command
calculates the interval until the first job has expired; then this already-queued cron job
is run. The cron process then rechecks its queue of jobs. It only considers jobs whose
execution time has not yet passed, so any additional jobs whose run time fell during
the time the system was suspended are not run.

Calendar Manager Issues
The Calendar Manager software does not display pop-up windows for scheduled
events that occur while the desktop machine is suspended.

Thermal Stress Issues
The goal of the Power Management software is to conserve electricity. However, you
should also take into account how an increase in power cycling will affect the overall
reliability of the hardware.

The Power Management software is active by default on sun4u systems (such as the
Sun Ultra 1). Accordingly, the Power Management system for those machines
evaluates each automatic power-cycle request that occurs due to the system being idle.
If an evaluation determines that the thermal shock of power cycling on a particular
occasion would decrease hardware reliability, then that power-cycle request is
deferred.

Despite this feature, you can choose to turn off a sun4u system manually at any time.
This checking feature is intended as a brake on the hardware being subjected to an
excessive number of automatic power-cycle requests.

Suspending and Resuming Your System Manually
The Power Management software includes a timesaving feature called
Suspend-Resume. This feature is used by default through the AutoShutdown and
AutoWakeup features of the Dtpower program. You also can Suspend and Resume
your system whenever you choose by following the procedures in this section.

The traditional process of powering off your system can be time consuming. Similarly,
the process of rebooting and setting up your workspace also can take some time. With
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the Suspend-Resume feature, you can power off your system and quickly save all your
current work-in-process automatically. When you power on the system, the saved
workspace is restored.

You can leave your system suspended and powered off for an indefinite length of time
without losing data. However, there are some outside operations (such as receiving
mail) that may be affected while your system is suspended. Before you use the
Suspend-Resume feature, be sure to read “Choosing to Use Suspend-Resume”
on page 560.

Note – The Suspend-Resume feature is not supported on systems configured as
diskless clients.

You can suspend your system automatically using the AutoShutdown feature in the
Power Management software. To suspend your system manually, follow the
instructions in this section.

Suspend allows you to do the following without losing the current state of your
system:

� Move your system from one location to another.
� Power off your system to conserve energy.

Note – Do not use the Suspend feature if you need to reconfigure your system. You
must halt the operating system whenever you want to reconfigure your system.

Before you suspend a system, you must wait for operations such as the following to
finish:

� Audio activity
� Floppy disk activity
� Tape activity
� ISDN activity
� Synchronous TTY activity

Initiating a Suspend and a subsequent Resume usually requires less than a minute.
You can initiate Suspend in several ways:

� Use the power key, then respond to a prompt.

� Use the Shift and Power keys to Suspend without a further prompt.

� Use the standby switch available on the front of systems such as the Sun Ultra 5
and Sun Ultra 10.

� Use the CDE desktop Workspace menu.

� Use the sys-suspend command.
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� To Suspend Your System Using the Keyboard
1. Press the Power key.

For examples of the location of the Power key, see Figure 23–7 and Figure 23–8.

FIGURE 23–7 Example of Power Key Location on Sun Type 5 and Type 6 Keyboards

FIGURE 23–8 Power Key Location on Sun Compact 1Keyboard

After you press the Power key, the confirmation window shown in Figure 23–9 is
displayed.
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FIGURE 23–9 Default Confirmation Window for Power Key Suspend

2. Select Suspend in the confirmation window.

Suspend saves the state of the system to disk, enabling you to return later to the current
system environment.

Shutdown syncs the disks to a neutral state and effectively shuts down the operating
system. This is equivalent to running the shutdown(1M) command.

3. Wait for the system to power off.

4. Power off all external devices.

External devices include disk drives, printers, or other serial or parallel peripherals.
See the manual supplied with the external device for instructions.

� To Immediately Suspend Your System Using the Keyboard
1. Press the Shift and the Power key at the same time.

See Figure 23–7 or Figure 23–8 for the location of the Power key.

2. Wait for the system to power off.

3. Power off all external devices.

External devices include external disk drives, printers, or other serial or parallel
peripherals. See the manual supplied with the external device for instructions.

� To Disable the Power Key
1. As root, edit the /usr/openwin/lib/speckeysd.map file

# vi /usr/openwin/lib/speckeysd.map
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2. comment out the two lines starting "SunPower" by putting a "#" as the first character
in the line.

#SunPowerSwitch - $OPENWINHOME/bin/sys-suspen

#SunPowerSwitchShift - $OPENWINHOME/bin/sys-suspend -n

3. Save the edited file.

4. Shut down and restart the system.

� To Suspend Your System Using the Standby Switch
Some systems, such as the Sun Ultra 5 and Sun Ultra 10, have a standby switch on the
front of the system.

1. Press the standby switch while you are in a windowing environment.

Caution – If you are not in a windowing environment, pressing the standby switch
will immediately shut down the system.

In a windowing environment, the confirmation window shown in Figure 23–10 is
displayed.

FIGURE 23–10 Default Confirmation Window for Standby Switch

2. Select Suspend in the confirmation window.

Suspend saves the state of the system to disk, enabling you to return to the current
system environment.

Shutdown syncs the disks to a neutral state and effectively shuts down the operating
system. This is equivalent to running the shutdown(1M) command.

In the window for the standby switch, Shutdown is the default. In the similar window
that appears when you press the power key, Suspend is the default.

3. Wait for the system to power off.
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4. Power off all external devices.

External devices include disk drives, printers, or other serial or parallel peripherals.
See the manual supplied with the external device for instructions.

� To Suspend Your System Using CDE
1. Place your cursor in the workspace and hold down the menu button.

The Workspace menu is displayed.

2. Select Suspend System from the Workspace menu.

The Suspend confirmation window is displayed, as shown in Figure 23–9.

3. Select Suspend in the confirmation window.

4. Wait for the system to power off.

5. Power off all external devices.

External devices include disk drives, printers, or other serial or parallel peripherals.
See the manual supplied with the external device for instructions.

� To Initiate Suspend Using the sys-suspend Command

Note – You do not need to be running a windowing system, such as OpenWindows or
CDE, for the sys-suspend shell command to work, nor do you need to be superuser.

1. At the prompt, initiate the system suspend process:

example% /usr/openwin/bin/sys-suspend

The Suspend confirmation pop-up window is displayed, as shown in Figure 23–10. If a
window system is not running, the command executes without displaying the
confirmation pop-up window.

2. Click Suspend.

3. Wait for the system to power off.

4. Power off all external devices.

External devices include disk drives, printers, or other serial or parallel peripherals.
See the manual supplied with the external device for instructions.
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� To Resume a Suspended System
1. Power on all external devices connected to your system.

2. Press the Power key.

See Figure 23–7 or Figure 23–8 for power key locations.

3. Enter your password to unlock the system.

Whenever the system is suspended, it is automatically locked.

System AutoShutdown and AutoWakeup Controls
Using the Dtpower program, you can specify times for your system to shut down
automatically. This feature is called AutoShutdown. If you have a sun4u desktop
machine, you can also set your system to power on automatically at a specified time.
This feature is called AutoWakeup.

Note – Be sure to read “Choosing to Use Suspend-Resume” on page 560 before
changing the AutoShutdown settings.

AutoShutdown uses the Suspend feature to automatically power off your system.
When the system powers up again, it resumes in the state in which it was suspended.

Through the Dtpower window, you can activate or deactivate the AutoShutdown and
AutoWakeup features. You can also specify the following values:

� The number of minutes of idle time before AutoShutdown attempts to suspend the
system

� The start and finish times when AutoShutdown can occur during each day. (If you
specify the same time for both start and finish, AutoShutdown can occur at any
time of day. See Figure 23–11.)

� The time of day when the system will automatically power on and resume
(AutoWakeup) after being suspended by AutoShutdown (available on sun4u
desktop systems only).
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FIGURE 23–11 Autoshutdown Configuration for All Day

Note – AutoWakeup does not occur after you suspend a system manually; it can occur
only after an AutoShutdown.

� To Set an Idle Time for AutoShutdown
1. Start Dtpower.

Note – Consecutive executions of AutoShutdown do not occur less than five minutes
apart, even if the idle time setting is under five minutes.

2. In the Dtpower basic window, click More.

The window expands to show the Quick Edit tab.

3. In the Quick Edit tab, check Enable Autoshutdown.

4. Click Edit.

The AutoShutdown window is displayed.
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FIGURE 23–12 Autoshutdown Window

5. Enter the time you want the AutoShutdown feature to start to be active.

6. Enter the time you want the AutoShutdown feature to cease being active.

7. In the numerical box for Shutdown During This Interval If Idle for, enter the
duration for which the computer must be idle before shutting down.

In Figure 23–12, the AutoShutdown will occur after 1 hour of idle time between the
hours of 6:00 p.m. and 8:00 a.m.

8. Click OK when all the settings you want are displayed.

If you want to reject the displayed settings, select Cancel; the currently active settings
will be displayed in the window.

� To Disable Autoshutdown
1. Start Dtpower.

2. In the Dtpower basic window, click More.

The window expands to show the Quick Edit tab.

3. In the Quick Edit tab, uncheck Enable Autoshutdown.

4. Click OK.
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� To Enable AutoWakeup

Note – The AutoWakeup feature is available only on sun4u desktop systems.

1. Start Dtpower.

2. In the Dtpower basic window, click More.

This expands the window to reveal the Quick Edit tab.

3. In the Quick Edit tab, check Enable Autoshutdown.

4. Click Edit.

The AutoShutdown window is displayed.

5. Set the idle time for AutoShutdown.

See “To Set an Idle Time for AutoShutdown” on page 569.

6. Check the Restart at <time> button.

The time the computer will restart is the second time you have specified for
Autoshutdown.

� To Disable AutoWakeup
1. Start Dtpower.

2. In the Dtpower basic window, click More.

This expands the window to reveal the Quick Edit tab

3. In the Quick Edit tab, uncheck Enable Autoshutdown.

4. Click Edit.

The AutoShutdown window is displayed.

5. Uncheck the Restart at <time> button.

� To Exit Dtpower
� Click OK to activate the new settings you made in the Dtpower window.

The Dtpower window closes.
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Troubleshooting Power Key Problems
If pressing the Power key does not suspend your system, refer to the following
procedure.

� To Respond When the Power Key Does Not Suspend the
System

1. Verify that the key processing daemon is present:

% ps -eaf | grep speckeysd

If the resulting message does not list /usr/openwin/bin/speckeysd, you will
need to start the key processing daemon.

2. Become superuser and start the key processing daemon (if necessary):

% /usr/openwin/bin/speckeysd

Troubleshooting Suspend Failures
When the system fails to suspend, an alert appears. The exact message within the
pop-up window may vary, depending on the cause of the problem, but the Suspend
Failed window will appear similar to the following figure.

FIGURE 23–13 Suspend Failed Pop-up Window

When any Suspend Failed window appears, click either of the buttons at the bottom of
the window:
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� Power Off turns off power without preserving the current operating state, as a
suspend operation usually does.

� Cancel cancels the suspend request, and the hardware continues to be powered
on.

� To Respond to a Device Suspend Failure
1. When the Suspend Failed pop-up window appears saying Device error during

suspend, select Cancel.

If you have not already saved your work, do so now. Take the corrective action
described below before retrying suspend again.

2. Check for more information in the console window in the workspace.

An unsupported device or a device performing nonresumable activity may be the
cause of this problem.

If the device specified by the console message is performing a nonresumable activity,
stop the activity and try suspend again, as described in Step 1.

If your system contains devices in addition to the default configuration, then these
devices may not support the Suspend feature. In that case, continue with the next step.

3. Unload the device driver.

Before you try to suspend again, attempt to unload the device driver by doing these
steps:

a. Get the module ID by running modinfo.

b. Unload that module:

modunload -i module_idYou might not be able to unload a driver for one of these
reasons:

� There is no detach support in the code.

� Another driver must be unloaded first, such as audio(7I) and dbri(7D).

� The device is actually in use and busy.

In such a case, contact your system administrator.

4. Try Suspend again.

� If Suspend succeeds, the system saves your activities and the system powers off
successfully.

� If Suspend does not succeed, the alert pop-up window is displayed again. In this
case, continue with the next step.
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Caution – Save your work if you have not already done so.

5. Select Power Off.

Since the error persists, suspend is not possible. Selecting Power Off shuts down the
system properly without causing file system damage. (Remember, your data will not
be saved unless you have saved it manually.) When you power on again, your system
automatically reboots.

However, if you select Power Off and it fails, your system does not support software
power off. An alert pop-up window is then displayed with information about the
power-off failure, as shown in the following figure:

FIGURE 23–14 Power Off Failed Pop-up Window

6. Select Continue.

Your system might not support software power off due to a non-Type 5 keyboard or
an outdated system PROM. If you do have a Type 5 keyboard installed, then contact
your system provider for a system PROM upgrade.

Also, some sun4m-architecture systems drop to an OpenBoot™ PROM prompt after a
suspend operation, because those systems do not support software power off.

7. Save your work if you have not already done so.

8. Halt the operating system.
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9. Power off by pressing the power switch on the back panel of the system to the off
(0) position.

Note – When possible, solve the problem for that device in the future by obtaining
and installing a device driver that supports Suspend features, if one is available from
your manufacturer.

� To Respond to a Process Suspend Failure
1. When the Suspend Failed pop-window appears saying Process cannot be

stopped, select Cancel.

If you have not already saved your work, do so now. Retry Suspend again.

2. Check for more information in the Console window in the Workspace.

If a process is a real-time process or if it is performing certain special network
operations, that process may refuse to suspend gracefully. In most cases, this is only a
temporary condition and you can correct it by trying Suspend again.

However, if the problem persists, stop the offending process (as specified in the
console message) and retry Suspend again.

3. Try Suspend again.

� If Suspend succeeds, the system saves your activities and the system powers off.

� If Suspend does not succeed, the alert pop-up window is displayed again.

Caution – Save your work if you have not already done so.

4. Select Power Off.

Remember, your data will not be saved unless you have done so manually.

When you power on again, your system automatically reboots.

� To Respond to an Abnormal Condition
1. When the Suspend Failed pop-window appears saying Abnormal condition

during suspend,, select Cancel.

You’ll need to take corrective action before you can try to suspend again.

If you have not already saved your work, do so now.
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2. Check for more information in the Console window in the Workspace.

You may be able to take further corrective action by checking the console error
messages.

3. Try Suspend again.

� If Suspend succeeds, the system saves your activities and the system powers off.

� If Suspend does not succeed, the alert pop-up window is displayed again. In this
case, continue with the next step.

Caution – Save your work if you have not already done so.

4. Select Power Off.

Remember, your data won’t be saved unless you have done so manually.

When you power on again, your system automatically reboots.

Troubleshooting a Shortage of Disk Space
When your system suspends, it creates a statefile to preserve the current state of your
system. If the file system containing the statefile is full, a Suspend Failed pop-up
window is displayed that includes the following message:

Suspend requires more disk space for statefile.

Perform the following procedure in response to this message.

� To Respond to a Disk Space Limitation
1. Select Cancel.

You’ll need to take corrective action before you can try Suspend again.

If you have not already saved your work, do so now.

2. Check for more information in the Console window in the Workspace.

You must have a minimum of 10 Mbytes of space available. Clean up a partition
before you try suspend again. Another solution is to change the location of the statefile
to a file system with sufficient space, as described in the power.conf(4) man page.

Contact your system administrator for assistance, if necessary.

3. Try Suspend again.

� If Suspend succeeds, the system saves your activities and the system powers off.
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� If Suspend does not succeed, the alert pop-up window is displayed again. In that
case, continue with the next step.

Caution – Save your work if you have not already done so.

4. Select Power Off.

Remember, your data will not be saved unless you have done so manually.

When you power on again, your system automatically reboots.

Disabling the Screen Lock
After a Resume, the system’s screen lock is invoked by default. To disable the screen
lock before you use the power key to Suspend, use the following procedure.

Note – You cannot disable screen locking that is put into effect by AutoShutdown.
This is a security feature. It ensures that only someone who knows your password can
get access to your work session when the system resumes.

� To Disable the Screen Lock After Using the Power Key to
Suspend

1. Modify the speckeysd.map file to add the -x flag to the sys-suspend entry.

For more information, see the man page for speckeysd.map(4).

Caution – Save your work if you have not already done so.

2. Exit the current windowing session and restart.

In place of this step, you may also kill the speckeysd daemon and then restart the
daemon.
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APPENDIX A

Keyboard Shortcuts for the Desktop

This appendix describes keyboard alternatives to using your mouse.

� “Menu Shortcuts” on page 579
� “Moving the Keyboard Focus” on page 580
� “Opening and Closing Windows” on page 581
� “Online Help Keyboard Navigation” on page 588

Keyboard shortcuts offer a way to accomplish desktop tasks such as moving and
selecting windows and controls, choosing menus, and navigating in workspaces
without the use of your mouse.

When you use the keyboard to navigate on the desktop, note that:

� The Alt key is the same as the Extend char key on some keyboards.

� Return is the same as Enter on some keyboards.

� In Style Manager, the Window Behavior setting must be Click In Window To Make
Active (this is the default).

For more information on the Window Behavior setting, refer to Chapter 9.

Menu Shortcuts
Menu items that appear dimmed are unavailable. They are available only under
certain conditions.

An underlined character in a menu name or item is called a mnemonic. The sequence of
keys listed to the right of some menu items is called a shortcut key.

Mnemonics and shortcut keys provide quick keyboard access to menu items.
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To choose an item from a pull-down menu using the menu’s mnemonics:

1. Hold down Alt and press the underlined letter in the menu’s name.

2. Press the underlined letter in the menu item’s name.

Keyboard Focus and the Highlight
Keyboard focus uses the highlight to show you which element of a window, menu, or
control will respond to your input. To activate a selected menu item or control (such as
a button), press the Spacebar.

In windows and dialog boxes, you can move the keyboard focus among tab groups. A
tab group is a collection of related controls, such as a set of buttons.

The OK, Cancel, and
Help buttons are a tab
group

This portion of a dialog box shows the keyboard focus on the OK button.

Moving the Keyboard Focus
To move the keyboard focus, as shown by the highlight:

� Within a window, dialog box, or the front panel

Press To Move To

Tab The next tab group

Shift+Tab The previous tab group

Down Arrow The next control in the tab group

Up Arrow The previous control in a tab group
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Press To Move To

F10 The window’s menu bar—use the arrow keys to display menus and
move among their items

Shift+F10 The selected object’s pop-up menu—use the arrow keys to move among
the menu’s items

Alt+Spacebar The Window menu

� Within a workspace

Press To Move To

Alt+Tab or Alt+Esc The next window or icon

Shift+Alt+Tab The previous window or icon

Alt+Up Arrow The bottom window in a stack of windows (bringing it forward)

Alt+Down Arrow The bottom of the window stack

Alt+F6 The next window belonging to an application, or between the Front
Panel and a subpanel

Shift+Alt+F6 The previous window belonging to an application, or between the Front
Panel and a subpanel

� Within a menu

Press To Move To

Down Arrow The next menu item

Up Arrow The previous menu item

Press the Spacebar to choose a selected item from within a menu.

Press Esc to dismiss a menu.

Opening and Closing Windows
This section describes how to do window-related activities through your keyboard.

Keyboard Shortcuts for the Desktop 581



� To Open an Application Window
From the Front Panel:

1. Press Alt+Tab to move the keyboard focus to the Front Panel.

2. Press the arrow keys to move the highlight within the Front Panel and select a
control.

3. Press Return or the Spacebar to choose the control and open the application’s
window.

From Application Manager:

1. Open the Application Manager window by choosing its Front Panel control as
described above.

2. Press the arrow keys to move the highlight to an application group icon within the
Application Manager window.

3. Press Return twice to open the application group.

4. Press the arrow keys to move the highlight to an application or action icon, then
press Return twice to start the application.

From a terminal emulator window:

1. Open a terminal emulator window by choosing its Front Panel control as described
above.

2. When the window opens, type the command that starts the application.

� To Close an Application Window
Closing a window removes it from all workspaces.

Caution – Before closing an application window, save your work.

1. Press Alt+Tab to move the highlight to the window you want to close.

2. Press Alt+F4.
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� To Select a Window or Icon
� Press Alt+Tab to move the highlight to the window or icon you want to select.

When a window or icon is selected, its border changes color to show that it is active
and will receive input from the mouse or keyboard.

� To Turn a Window into an Icon (Minimize)
1. Press Alt+Tab to move the highlight to the window you want to minimize.

2. Press Alt+Spacebar to display the Window menu.

3. Choose the Minimize item:

� Press Down Arrow until you select Minimize, then press Return.
� Or, press N, the menu’s mnemonic for Minimize.

� To Restore a Window from an Icon
1. Press Alt+Tab to move the highlight to the icon you want to restore.

2. Press Alt+Spacebar to display the Window menu.

3. Press Down Arrow to choose Restore, then press Return.

� To Move a Window or Window Icon
1. Press Alt+Tab to move the highlight to the window or icon you want to move.

2. Press Alt+Spacebar to display the Window menu.

3. Press M, the menu’s mnemonic for Move.

4. Press the arrow keys to relocate the window or icon.

Hold down Control while you press an arrow key to speed up the movement of the
window or icon.

5. When you’ve moved the window or icon where you want it, press Return.

To cancel the move operation, press Esc.
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� To Resize a Window
1. Press Alt+Tab to move the highlight to the window you want to resize.

2. Press Alt+Spacebar to display the Window menu.

3. Press S, the menu’s mnemonic for Size.

4. Press the arrow keys to stretch or shrink the window. An outline appears to show
you the window’s size.

Hold down Control while you press an arrow key to size the window faster.

5. When the outline shows the size you want, press Return.

To cancel the resize operation, press Esc.

� To Scroll a Window’s Contents
1. Press Alt+Tab to move the keyboard focus, as shown by the highlight, to the

window whose contents you want to scroll.

2. Press Tab to move to the window area you want to scroll.

3. Press the arrow keys, Prev and Next, or Page Up and Page Down.

Hold down Control while you press an arrow key to scroll faster.

� To Select a List Item
Some windows and dialog boxes display lists from which you select options or
settings.

1. Press Tab to move the highlight to the list.

2. Press the arrow keys to move through the list.

To select more then one contiguous item in lists that allow you to do so, press
Shift+Down Arrow or Shift+Up Arrow.

3. Press Tab to move the highlight to the appropriate button (such as OK), then press
Return.
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� To Display a Pull-down Menu
To display a pull-down menu from a window’s menu bar:

1. Press Alt+Tab to move the highlight to the application window.

2. Press F10 to move the highlight to the name of the first menu in the menu bar, then
use the arrow keys to display menus and move among their items.

3. Press Return to choose a highlighted item.

To dismiss a menu without choosing an item, press Esc.

� To Use a Pop-up Menu
With the keyboard focus on the component whose pop-up menu you want to display:

1. Press Shift+F10 to display the pop-up menu.

2. Choose a menu item:

� Press the Down Arrow key to move through the menu, highlight the item you
want, then press Return.

� Or, type the underlined letter in the menu item’s name (its mnemonic).

� Or, type the shortcut key, as listed to the right of the item’s name.

� To Use the Window Menu
1. Press Alt+Tab or Alt+Esc to move the keyboard focus, as shown by the highlight, to

the window or icon.

2. Press Alt+Spacebar to display the Window menu.

3. Press the key for the menu item’s mnemonic (the underlined character in the item’s
name).

To close the menu without choosing an item, press Esc.

� To Switch to Another Workspace
1. Press Alt+Tab until you’ve placed the keyboard focus, as shown by the highlight,

on the Front Panel.
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2. Press the arrow keys to move the highlight to the button for the workspace you
want to display.

3. Press Return or the Spacebar.

� To Rename a Workspace
1. Press Alt+Tab until you’ve placed the keyboard focus, as shown by the highlight,

on the Front Panel.

2. Press the arrow keys to move the highlight to the button for the workspace you
want to rename.

3. Press Shift+F10 to display the workspace button’s pop-up menu.

4. Press the Down Arrow key to select Rename, then press Return.

The button becomes a text field.

5. Edit the workspace’s name in the text field.

6. Once you’ve renamed the workspace, press Return.

� To Move among Windows
To move to the next window or icon, press Alt+Tab or Alt+Esc.

To move to the previous window or icon, press Shift+Alt+Tab or Shift+Alt+Esc.

To shuffle through a stack of windows, press Alt+Up Arrow or Alt+Down Arrow.

To move between the windows belonging to an application, or the Front Panel and a
subpanel, press Alt+F6 or Shift+Alt+F6.

� To Display a Window in Other Workspaces
1. Press Alt+Tab to move the keyboard focus, as shown by the highlight, to the

window you want to display in other workspaces.

2. Display the Window menu by pressing Alt+Spacebar.

3. Press the Down Arrow key to select Occupy Workspace, then press Return.

The Occupy Workspace dialog box appears.
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4. Press Tab until the keyboard focus is in the Workspaces list.

5. Select the workspaces in which you want the window to appear:

� Press Down Arrow or Up Arrow to move through the list.

� To select more than one workspace, press Shift+Down Arrow or Shift+Up Arrow.

6. Press Tab to move the keyboard focus to OK, then press Return or the Spacebar.

� To Choose a Front Panel Control
1. Press Alt+Tab to move the keyboard focus to the Front Panel.

2. Press the arrow keys to move the highlight within the Front Panel and select a
control.

3. Press Return or the Spacebar to choose the control and open the application’s
window.

� To Choose a Subpanel Control
1. Press Alt+Tab to move the keyboard focus to the Front Panel.

2. Press the arrow keys to move the highlight within the Front Panel to one of the
subpanel arrow controls, then press Return.

3. Press the arrow keys to move the highlight among the controls within the subpanel,
then press Return or the Spacebar to choose a selected control.

To close the subpanel without choosing a control, press Esc.

� To Move the Front Panel
1. Press Alt+Tab to move the keyboard focus to the Front Panel.

2. Press Alt+Spacebar to display the Front Panel menu.

3. Press M, the menu’s mnemonic for Move.

4. Press the arrow keys to relocate the Front Panel.

Hold down Control while you press an arrow key to speed up the movement of the
Front Panel.
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5. When you’ve moved the Front Panel to where you want it, press Return.

To cancel the move operation, press Esc.

Online Help Keyboard Navigation
Choose hyperlinks to display related information. Help topic hyperlinks appear as:

� Underlined text
� An open-cornered box surrounding a graphic

� To Get Help in Any Window
� Press F1 (or the Help key if your keyboard has one).

� To Choose a Help Topic Hyperlink
1. If the help window does not already have the keyboard focus, press Alt+Tab to

move the highlight to the help window.

2. Press Tab and the arrow keys to move the highlight to the hyperlink you want to
choose, then press Return.

To return from a hyperlink to the previous topic:

� Press Control+B, the keyboard accelerator for Backtrack.

For more information about using Help, refer to Chapter 3.
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APPENDIX B

Running Localized Sessions

You can customize the desktop user interface in many different languages. Various
elements such as screens, default languages, fonts, input (keyboard) methods, and
icons can be changed. In addition, the menus, online help, and error messages can be
localized and are available in multiple languages.

� “Default Language at Login” on page 589
� “Logging In to a Language-Specific Session” on page 590
� “Creating or Editing a Language-Specific File” on page 590
� “Using a Language-Specific Terminal Emulator” on page 591
� “Specifying Fonts” on page 591
� “Changing Fonts” on page 592
� “Choosing Your Input Method and Keyboard” on page 594

Default Language at Login
The messages and menus in the initial login window are displayed in the default
language. If the default language has not been set up, the messages and menus are
displayed using a generic “C” locale environment. You can change the language from
the Options menu in the login screen.
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Logging In to a Language-Specific
Session
Logging in to a specific language through the desktop is easy. However, specific
hardware requirements such as keyboards and printers may be required to make the
localized session more usable. These requirements vary by language, character set,
and country. Software and fonts can further increase the effective localization of your
system. To log in to a language-specific session:

1. Use the Options menu in the login screen to select a language.

The list of languages includes all the supported languages.

2. Log in normally with your name and password.

Creating or Editing a Language-Specific
File
You can create, edit, and print language-specific files. You can also give files
language-specific names. However, for system administration files that are shared
across a network, the file names should just contain ASCII characters. Different
systems on the network might be using different locales.

If you have logged in to the desktop in a specific language, all applications will be
invoked using that language. However, you can still invoke an application with
another language.

If you want to create a file with a different language, invoke a new instance of Text
Editor specifying your desired language.

� To Create or Edit a Language-Specific File
1. In a Terminal window, set the LANG environment variable to the desired language.

For example, to set the locale to Japanese, you can type:

LANG=Japanese_locale

where Japanese_locale sets the value of the LANG environment variable for the
Japanese character set. Refer to your specific platform to determine the value for
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Japanese_locale.

2. In the same window, call Text Editor (dtpad) under the desired language by typing:

/usr/dt/bin/dtpad &

To start Text Editor with the Japanese language directly, type:

/usr/dt/bin/dtpad -xnllanguage Japanese_locale

You can now enter Japanese characters if the locale-specific files have been installed.
You can also use the Text Editor session to edit a previously created Japanese file.

See “To Specify Fonts from the Command Line” on page 593 for an example of
specifying a font set.

Using a Language-Specific Terminal
Emulator
The following example uses dtterm and will start a Japanese terminal emulator. It
assumes that the default language is not Japanese, that you are using the Korn shell,
and that the locale-specific files have been installed.

� From a command line in a Korn shell Terminal window type:

LANG=Japanese_locale dtterm

where Japanese_locale sets the value of the LANG environment variable for the
Japanese character set. Refer to your specific platform to determine the value for
Japanese_locale.

Specifying Fonts
The user usually changes fonts using Style Manager, which in turn restarts Workspace
Manager, resetting the desktop fonts. You can also customize fonts at the command
line or in resource files. In an internationalized environment, the user must specify
fonts that are independent of the code set. This is necessary because the specification
can be used under various locales with different code sets than the character set
(charset) of the font. Therefore, all font lists should be specified with a font set.
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Font Specification
A font specification within a fontlist can be either an X Logical Function Description
(XLFD) name or an alias for the XLFD name. For example, the following are valid font
specifications for a 14-point font:

-dt-interface system-medium-r-normal-serif-*-*-*-*-p-*-iso8859-1

Or, -*-r-*-14-*iso8859-1

Font Set Specification
The font set specification within a fontlist is a list of XLFD names or their aliases
(sometimes called a base name list). The names are separated by semi-colons, and any
blank space before or after the semicolon is ignored. Pattern-matching (wildcard)
characters can be specified to help shorten XLFD names.

A font set specification is determined by the locale that is running. For example, the
Japanese locale defines three fonts (character sets) necessary to display all of its
characters. The following example identifies the set of Mincho fonts needed.

� Sample name list with character set:

-dt-interface system-medium-r-normal-serif-*-*-*-*-p-*-14;

-dt-mincho-medium-r-normal--14-*-*-m-*-jisx0201.1976-0;

-dt-mincho-medium-r-normal--28-*-*-*-m-*-jisx0208.1983-0:

� Sample single pattern name without character set:

-dt-*-medium-*-24-*-m-*:

The preceding two cases can be used with a Japanese locale as long as there are fonts
that match the base name list.

Changing Fonts
You can change the fonts of dtterm by using either of the following methods:

� Specifying fonts from the command line
� Specifying fonts within a resource file
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� To Specify Fonts from the Command Line
To change the fonts for the menu from the command line, type:

dtterm -xrm ’*fontList: fontset’

where fontset is a font set specification. A font set specification can be specified by a
full X Logical Font Description (XLFD) name list, a simple XLFD pattern, or an alias
name. Note that a font set specification is determined by the locale that is running.

For example, to use a larger font except for the menu font, type:

dtterm -xrm ’*fontList:-dt-interface user-medium-r-normal-l*-*-*-*:’

To use a smaller font except for the menu font, type:

dtterm -xrm ’*fontList:-dt-interface user-medium-r-normal-s*-*-*-*:’

These specifications will work for any locale.

� To Specify Fonts within a Resource File
For example, to change the fonts for the dtterm command in a resource file:

1. Edit the Dtterm resource file in the /usr/dt/app-defaults/language directory.

You can use either the class name (Dtterm) or the application name (dtterm) for a
resource file of Dtterm.

Also, setting the LANG environment variable alters the search path of resource files to
include the /usr/dt/app-defaults/language directory, where language is the locale
name.

After setting the LANG environment variable, the search path for resource files would
include the following two folders:

/usr/dt/app-defaults/language/Dtterm

/usr/dt/app-defaults/C/Dtterm

2. Insert the font set you want to use at the bottom of the file.

For example, to use a monospace font, put this line at the bottom of the file:

dtterm -fn -dt-interface user-medium-r-normal-*-*-*-*

3. Save the file.
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Choosing Your Input Method and
Keyboard
Each locale has a single default input method associated with it. If the user does
nothing, this default is selected. Because there may be many input methods installed
at any one time, the following sections explain how various input methods are
selected on behalf of the user.

Using Input Method Modifiers
When there is more than one input method for a locale, use the XmNinputMethod
resource to identify the one you would like used. This is done by specifying a
modifier. The modifier must be of the following form, where modifier is the name
used to uniquely identify the input method:

inputMethod :@im=modifier

The modifier string specified in the XmNinputMethod resource is used to choose
which input method is used.

Alternatively, set the XMODIFIERS environment variable. The syntax is the same as
for the XmNinputMethod resource, but values are not. Values for XMODIFIERS are
vendor specific.

Specifying the Input Method Style
The input method style determines how pre-editing will occur. It is controlled by the
XmNpreeditType resource. The syntax, possible values, and default value type of the
XmNpreeditType resource are:

Syntax value[,value,...]

Possible values OverTheSpot, OffTheSpot, Root, None

Default value OverTheSpot, OffTheSpot, Root

The string list, separated by a comma, specifies the priority order for this resource. The
first value supported by the input method is used.
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For more information, see the Solaris Common Desktop Environment: Advanced User’s and
System Administrator’s Guide.

Changing the X Keyboard Map at the Server
If the keymaps currently used by the X server do not match the physical keyboard on
the system, you can change them manually by using the xmodmap command or a
vendor keyboard mapping utility. For information on the xmodmap command, type
man xmodmap.
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APPENDIX C

Compose Key Sequences

If you are using the standard ISO 8859-1 (Latin-1) code set you can produce all
characters by pressing the Compose key followed by other keys. These compose key
sequences are listed in Table C–1.

Note – ISO Latin-1 does not support the character for the Euro currency symbol (see
“Euro Currency Symbol” on page 71).

On a SPARC keyboard, pressing the Compose key should illuminate the light on the
key. On an IA keyboard, the Compose key is Control-Shift-F1 (hold the Control and
Shift keys down and press the F1 key).

TABLE C–1 Compose Key Sequences for ISO Latin-1 Code Set

Compose Result Description

space space Space

! ! ¡ Inverted exclamation

c / ¢ Cents

l - £ Pounds sterling

o x ¤ Currency symbol

y - ¥ Yen

| | ¦ Broken bar

s o § Section

" " ¨ Umlaut/diaeresis

c o © Copyright

- a ª Feminine ordinal
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TABLE C–1 Compose Key Sequences for ISO Latin-1 Code Set (Continued)
Compose Result Description

< < « Left guillemet

- | ¬ Not sign

- - - Soft hyphen

r o ® Registered

^ -
¯

Macron

^ 0 ° Degree

+ - ± Plus-minus

^ 2 Superscript 2

^ 3 Superscript 3

\ \ ´ Prime/acute accent

/ u Mu/micro

P ! ¶ Pilcro/paragraph

^ .
·

Middle dot

, , ¸ Cedilla

^ 1 Superscript 1

_ o º Masculine ordinal

> > » Right guillemet

1 4 ¼ Quarter

1 2 ½ Half

3 4 ¾ Three quarters

? ? ¿ Inverted question

A ‘ À A grave

A ’ Á A acute

A ^ Â A circumflex

A ~ Ã A tilde

A " Ä A umlaut

A * Å A angstrom

A E Æ AE ligature
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TABLE C–1 Compose Key Sequences for ISO Latin-1 Code Set (Continued)
Compose Result Description

C , Ç C cedilla

E ‘ È E grave

E ’ É E acute

E ^ Ê E circumflex

E " Ë E umlaut

I ‘ Ì I grave

I ’ Í I acute

I ^ Î I circumflex

I " ˙ I umlaut

D - Ð Eth

N ~ Ñ N tilde

O ‘ Ò O grave

O ’ Ó O acute

O ^ Ô O circumflex

O ~ Õ O tilde

O " Ö O umlaut

x x x Multiply

O / Ø O slash

U ‘ Ù U grave

U ’ Ú U acute

U ^ Û U circumflex

U " Ü U umlaut

Y ’ Ý Y acute

T H þ Thorn

s s ß Eszett/digraph s

a ‘ à a grave

a ’ á a acute

a ^ Â a circumflex
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TABLE C–1 Compose Key Sequences for ISO Latin-1 Code Set (Continued)
Compose Result Description

a ~ ã a tilde

a " ä a umlaut

a * å a angstrom

a e æ ae ligature

c , ç c cedilla

e ‘ è e grave

e ’ é e acute

e ^ ê e circumflex

e " ë e umlaut

i ‘ ì i grave

i ’ í i acute

i ^ î i circumflex

i " ï i umlaut

d - eth

n ~ ñ n tilde

o ‘ ò o grave

o ’ ó o acute

o ^ ô o circumflex

o ~ õ o tilde

o " ö o umlaut

- : ÷ Divide

o / ø o slash

u ‘ ù u grave

u ’ ú u acute

u ^ û u circumflex

u " ü u umlaut

y ’ ý y acute

t h Þ thorn
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TABLE C–1 Compose Key Sequences for ISO Latin-1 Code Set (Continued)
Compose Result Description

y " ÿ y umlaut

Note – Localized keyboards do not all generate the same key codes for ISO Latin-1
characters. However, system translation tables take care of producing the right
character code. The SunOS system finds its tables in /usr/share/lib/keytables.
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APPENDIX D

Locale Notes

This appendix describes the display, manipulation, and printing of text using CDE and
the Thai and Hebrew locales.

Thai Locale
The Solaris 7 operating environment includes the Thai Language Environment (TLE).
TLE provides a localized Thai language environment that enables you to type, display,
and print the Thai language. In addition, TLE provides a platform for building Thai
language applications, commands, and other features for the operation and
maintenance of Solaris 7 and CDE 1.3.

The following list describes the features of TLE:

� Code Set Standard

This release supports the Thai Industrial Standard (TIS 620-2533) for representing
Thai characters. Directory and file names can consist of Thai characters.

� Thai Text Input

This release includes an input mode indicator for each window to indicate the
current input mode. You can also convert ASCII input to Thai characters using the
dynamically loadable module for the internationalized X11R6 library. You can type
text using a regular Sun Type 4 or Type 5 keyboard.

� Thai Text Output

All Common Desktop Environment (CDE 1.3) text rendering routines have been
enhanced for displaying Thai text. The output method algorithm is based on the
WTT 2.0 Thai text display specification, which is maintained by the Thai
government. This release also includes Thai bitmap and TrueType fonts.
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� Thai Text Printing

Printer support is provided for 15 dot matrix printers. For a list of printers
supported, see Appendix C in Thai Language Supplement for Solaris 2.6: Release
Overview.

� Common Desktop Environment Productivity Tools

All CDE 1.3 application windows display and accept Thai text. You can also cut
and paste text between window applications. This release supports Thai input at
the Xlib level and Thai output at the toolkit level, including CDE 1.3. This release
also provides localized CDE desktop tools that display Thai labels and messages,
and supports the use of Thai text, file names, and so on.

� Complex Text Layout (CTL)

CTL additions enable Motif APIs to support writing systems that require complex
transformations between logical and physical text representations. It also provides
character shaping and the transformation of static and dynamic text widgets. In
addition, CTL supports right-to-left and left-to-right text orientation and tabbing
for dynamic text widgets.

CDE 1.3 Library Features
TLE contains the CDE 1.3 library, which includes Thai text manipulation (insertion,
deletion, selection, cut, copy, paste, drag, and drop) according to WTT 2.0 standards.
For information about using the library to develop programs, see Solaris Common
Desktop Environment: Programmer’s Guide.

Thai Text Manipulation
This section explains the mechanics of manipulating Thai characters.

Typing Thai Text
You may need to intersperse Thai and English text in the same file. To toggle a
window between English and Thai or Thai and English, press Ctrl+spacebar. The
message window at the base of each tool displays the current input language.

Editing Thai Text
This section describes how to work with Thai text, specifically, how to:

� Insert and delete text
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� Wrap text
� Move the cursor
� Select text
� Copy/paste and drag-and-drop text

Character Insertion and Deletion

Inserting and deleting Thai characters changes the display of the text, depending on
whether the character classes can be composed.

The following graphics show the sequence of inserting MAIHUNAKAT (AV2 vowel)
between SARA_II (AV3 vowel) and YOYAK (consonant) .

FIGURE D–1 Logical Buffer and Display Before Text Insertion

FIGURE D–2 Logical Buffer and Display After Text Insertion

MAIHUNAKAT cannot be composed with SARA_II, so it must be displayed in its
own cell.

The following example shows the deletion of SARA_II (AV3 vowel).
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FIGURE D–3 Logical Buffer and Display Before Text Deletion

FIGURE D–4 Logical Buffer and Display After Text Deletion

MAIHUNAKAT can be composed with NONU (consonant class CONS). Therefore, it
is displayed in the previous cell.

Character Wrapping

There are no delimiters (spaces) between words in Thai. This makes correct character
wrapping difficult because of the combinations of spacing and non-spacing characters.

In Solaris 7 TLE character wrapping is done at the display cell, and the TLE software
compensates for non-spacing characters when wrapping a line. For example, when a
forward spacing character is typed in the last column of a line, the cursor advances to
the next line. If a non-spacing character is typed at the same point, the cursor does not
advance to the next line. The non-spacing character is displayed in the last display cell
of the previous line, and the cursor location remains unchanged.

Text Selection, Copy/Paste, and Drag-and-Drop

When a display cell is selected, all characters within the display cell (spacing and
non-spacing) are selected.
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Cursor Movement in an Editor Window (dtpad)

The multiple display levels of the Thai language may seem to cause unusual cursor
movement in dtpad (text editor) windows. The cursor physically moves only
between display cells. However, because there is frequently more than one Thai
character in a display cell, the cursor does not physically move between them.

Cursor Movement in a Terminal Window (dtterm)

Cursor movement in a Terminal window is slightly different from editing text in one
of the Thai CDE tools using text widgets (such as dtpad). When you move the cursor
in a Terminal window, if there is only one character in a display cell, the cursor will be
highlighted in the cell. If the character shares a display cell, the entire display cell will
be highlighted.

You can display a combination of Thai and English characters using the four Thai
fonts included in this release. The fonts are listed in Table D–1 and Table D–2.

Thai Fonts
You can display a combination of Thai and English characters using the four Thai
fonts included in this release. The fonts are listed in Table D–1.

TABLE D–1 Solaris 7 TLE Fonts (Scalable)

Type Face Style Font Name

Angsana Normal -monotype-angsa-medium-r-normal--*-*-*-*-m-*
-tis620.2533-0

Bold -monotype-angsab-bold-r-normal--*-*-*-*-m-*
-tis620.2533-0

Italic -monotype-angsai-medium-i-normal--*-*-*-*-m-*
-tis620.2533-0

BoldItalic -monotype-angsaz-bold-i-normal--*-*-*-*-m-*
-tis620.2533-0

Browalia Normal -monotype-browa-medium-r-normal--*-*-*-*-m-*
-tis620.2533-0

Bold -monotype-browab-bold-r-normal--*-*-*-*-m-*
-tis620.2533-0

Italic -monotype-browai-medium-i-normal--*-*-*-*-m-*
-tis620.2533-0
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TABLE D–1 Solaris 7 TLE Fonts (Scalable) (Continued)
Type Face Style Font Name

BoldItalic -monotype-browaz-bold-i-normal--*-*-*-*-m-*
-tis620.2533-0

Cordia Normal -monotype-cordia-medium-r-normal--*-*-*-*-m-*
-tis620.2533-0

Bold -monotype-cordiab-bold-r-normal--*-*-*-*-m-*
-tis620.2533-0

Italic -monotype-cordiai-medium-i-normal--*-*-*-*-m-*
-tis620.2533-0

BoldItalic -monotype-cordiaz-bold-i-normal--*-*-*-*-m-*
-tis620.2533-0

TABLE D–2 Solaris 7 TLE Fonts (Fixed Width)

Type Face Style Font Name

Gothic Normal 12pt -logic-gothic-medium-r-normal--12-120-75-75-c-80
-tis620.2533-0

14pt -logic-gothic-medium-r-normal--14-140-75-75-c-90
-tis620.2533-0

16pt -logic-gothic-medium-r-normal--16-160-75-75-c-80-tis620.
2533-0

20pt -logic-gothic-medium-r-normal--20-200-75-75-c-100
-tis620.2533-0

24pt -logic-gothic-medium-r-normal--24-240-75-75-c-100
-tis620.2533-0

Gothic Bold 12pt -logic-gothic-bold-r-normal--12-120-75-75-c-100
-tis620.2533-0

14pt -logic-gothic-bold-r-normal--14-140-75-75-c-110
-tis620.2533-0

16pt -logic-gothic-bold-r-normal--16-160-75-75-c-80
-tis620.2533-0

20pt -logic-gothic-bold-r-normal--20-200-75-75-c-120
-tis620.2533-0

24pt -logic-gothic-bold-r-normal--24-240-75-75-c-120
-tis620.2533-0
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TABLE D–2 Solaris 7 TLE Fonts (Fixed Width) (Continued)
Type Face Style Font Name

Gothic Italic 16pt -logic-gothic-medium-i-normal--16-160-75-75-c-80
-tis620.2533-0

Printing
This section describes how to print Thai text from CDE 1.3 and a dot matrix printer.
For a list of dot matrix printers supported, see Appendix C of Thai Language
Supplement for Solaris 2.6: Release Overview.

Printing From CDE Tools
If the Angsana UPC font is installed on your printer, you can print from any CDE 1.3
tool (fonts are not provided in Solaris 7 TLE).

Setting Up Thai Printing on a Dot Matrix Printer
This section assumes that your printer is registered in the WTT 2.0 standard listed in
Appendix C, "Printer Brand, Model, and Code IDs" of Thai Language Supplement for
Solaris 2.6: Release Overview.

If the system you are setting up uses printers that are registered in the WTT 2.0
standard, set them up using the instructions in the Setting Up User Accounts, Printers,
and Mail manual of the SunOS 5.6 documentation.

Once your printer is set up, follow these steps to enable printing of Thai characters:

1. Type cd /usr/lp/interfaces

2. Edit the file named for the printer you just set up.

Change lp.cat to lp.filter in the following line:

if [! -x "${LPCAT:=${LOCALPATH}/lp.cat}"]

3. Create a shell script in /usr/lib/lp/bin called lp.filter that pipes printer
jobs through lp.cat.

The lp.filter program should have the syntax given below. See the thaifilter(1)
man page in Appendix D, "Manual Pages", of the Thai Language Supplement for
Solaris 2.6: Release Overview for the syntax of the thai_filter_command.

thai_filter_command | lp.cat
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Printing Thai Text
This section describes how to use the thaifilter(1) print utility and printer
conversion tables, which you may need to print Thai text.

Using the thaifilter(1) Utility

The thaifilter(1) program is a filter that converts Thai text into three levels:

� Base level characters (including any ASCII characters)
� Above-level characters
� Below-level characters

This system is called 3-Level Classification. The two main uses for files converted to
3-Level Classification are:

� To direct printers to print Thai characters at the correct display level.

� To view Thai text files on terminals that normally do not allow the multi-level
(normal) display of Thai text.

Note – Some newer printers come with 3-Level Classification software already
installed. For that reason the thaifilter(1) program has the -x option that turns
3-Level Classification off.

The thaifilter(1) man page is supplied in the TLE 2.6 software, and is also
available in printed form in Appendix D, "Manual Pages", of the Thai Language
Supplement for Solaris 2.6: Release Overview.

Setting Up Printer Software

The WTT 2.0 standard identifies the following terms and conventions for printing Thai
text:

� Printer IDs

Printer IDs are 6-character codes defined by TAPIC to specify a printer’s model,
brand name, and character code. Printer vendors should have their printer codes
clearly marked on their printers. The syntax for a printer ID is BBMMCC, where BB
is a two-letter brand abbreviation, MM is a two-letter model abbreviation, and CC
is a two-digit number representing the conversion code the printer uses. The
printer brand and model abbreviations are listed in Appendix C, "Printer Brand,
Model, and Code IDs," of the Thai Language Supplement for Solaris 2.6: Release
Overview. See the next section for a discussion of printer conversion codes.

For example, the first line of Table D–3 shows that the brand and model
abbreviations for a Data Products IZR650 printer are DA and ZI. If this printer
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used the code conversion table number 10, the full printer ID would be: DAZI10.

� Conversion codes and printer code conversion tables

Use the codes listed in the right side of Table A-3 when specifying a printer ID.
Solaris 7 TLE adheres to TIS 988-2533, which specifies a table of codes for printing
to the TAC11x11.COD standard. Because not every printer uses this table, the TIS
standard specifies a total of 17 code conversion lookup tables to convert other
known printer codes to TAC11x11.COD. (TAC is an abbreviation for the Thai API
Consortium. APIs defined by the Thai Internationalization Committee are prefixed
with “TAC.”)

These 17 code conversion tables are supplied with Solaris 7 TLE for converting the
codes supplied with various printers to the TAC11x11.COD standard. The tables,
listed in Table D–3, are stored in the /usr/lib/lp/files directory.

TABLE D–3 Code Conversion Tables

Code Conversion Table Code for Use With Printer ID

TAC11x10.COD 10

TAC11x12.COD 12

TAC11x13.COD 13

TAC11x14.COD 14

TAC11x15.COD 15

TAC11x16.COD 16

TAC11x17.COD 17

TAC11x18.COD 18

TAC11x19.COD 19

TAC11x20.COD 20

TAC11x21.COD 21

TAC11x22.COD 22

TAC11x40.COD 40

TAC11x41.COD 41

TAC11x42.COD 42

TAC11x43.COD 43

TAC11xAA.COD AA

If your printer does not use one of the printer code conversion tables, see the
following section for help with creating your own.
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Creating a New Printer Code Conversion Table

Printer conversion tables are used to convert printing instructions to the TIS 988-2553
format, which is the WTT 2.0 default printing format. The code conversion tables
listed in the WTT 2.0 standard are included with Solaris 7 TLE.

If the printer you are using does not use the TIS 988-2553 format, and cannot use any
of the code conversion tables, then you need to create a custom conversion table. This
section explains how to create a new printer code conversion table.

Conversion Table Syntax

The following is an example of a code conversion file:

-- -- -- -- TN -- ! TAC11x10.COD 16 AUG 1991
00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
10 11 12 13 14 15 16 17 18 19 1A 1B 1C 1D 1E 1F
20 21 22 23 24 25 26 27 28 29 2A 2B 2C 2D 2E 2F
30 31 32 33 34 35 36 37 38 39 3A 3B 3C 3D 3E 3F
40 41 42 43 44 45 46 47 48 49 4A 4B 4C 4D 4E 4F
50 51 52 53 54 55 56 57 58 59 5A 5B 5C 5D 5E 5F
60 61 62 63 64 65 66 67 68 69 6A 6B 6C 6D 6E 6F
70 71 72 73 74 75 76 77 78 79 7A 7B 7C 7D 7E 7F
3F 3F 3F 3F 3F 3F 3F 3F 3F 3F 3F 3F 3F 3F 3F 3F
3F 3F 3F 3F 3F 3F 3F 3F 3F 3F 3F 3F 3F 3F 3F 3F
3F A1 A2 A3 A4 A5 A6 A7 A8 A9 AA AB AC AD AE AF
B0 B1 B2 B3 B4 B5 B6 B7 B8 B9 BA BB BC BD BE BF
C0 C1 C2 C3 C4 C5 C6 C7 C8 C9 CA CB CC CD CE CF
D0 D1 D2 D3 D4 D5 D6 D7 D8 D9 DA 3F 3F 3F 3F DF
E0 E1 E2 E3 E4 E5 E6 E7 E8 E9 EA EB EC ED EE EF
F0 F1 F2 F3 F4 F5 F6 F7 F8 F9 FA FB 3F 3F 3F FF

! End of TAC11x10.COD

The first line of a code conversion table uses the following syntax:

CC LG UM EX TN SP ! comment

If one of the two-character fields is not used, it must be replaced with two dashes (--).
The fields in the first line are explained in Table D–4.

TABLE D–4 Code Conversion Tables

Field Description

CC Combined Code at TIS 988-2553, for example SaraI and MaiEk

LG Line Graphic

UM The combination code of SaraAm and Nikhahit

EX Ascender Extension

TN Thai Numerics
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TABLE D–4 Code Conversion Tables (Continued)
Field Description

SP Special code not defined in TIS 988-2553

! comments Any comments you have. In the WTT 2.0 standard this field contains the
name of the file and the date. The comment must be proceeded by the "!"
symbol.

The middle of the conversion file contains 16 lines of 16 codes, a total of 256 codes.
These codes are the replacement for the TIS 988-2553. The TIS988-2553 code is shown
below:

-- -- -- -- TN -- ! TAC11x11.COD 16 AUG 1991
00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F
10 11 12 13 14 15 16 17 18 19 1A 1B 1C 1D 1E 1F
20 21 22 23 24 25 26 27 28 29 2A 2B 2C 2D 2E 2F
30 31 32 33 34 35 36 37 38 39 3A 3B 3C 3D 3E 3F
40 41 42 43 44 45 46 47 48 49 4A 4B 4C 4D 4E 4F
50 51 52 53 54 55 56 57 58 59 5A 5B 5C 5D 5E 5F
60 61 62 63 64 65 66 67 68 69 6A 6B 6C 6D 6E 6F
70 71 72 73 74 75 76 77 78 79 7A 7B 7C 7D 7E 7F
80 81 82 83 84 85 86 87 88 89 8A 8B 8C 8D 8E 8F
90 91 92 93 94 95 96 97 98 99 9A 9B 9C 9D 9E 9F
A0 A1 A2 A3 A4 A5 A6 A7 A8 A9 AA AB AC AD AE AF
B0 B1 B2 B3 B4 B5 B6 B7 B8 B9 BA BB BC BD BE BF
C0 C1 C2 C3 C4 C5 C6 C7 C8 C9 CA CB CC CD CE CF
D0 D1 D2 D3 D4 D5 D6 D7 D8 D9 DA DB DC DD DE DF
E0 E1 E2 E3 E4 E5 E6 E7 E8 E9 EA EB EC ED EE EF
F0 F1 F2 F3 F4 F5 F6 F7 F8 F9 FA FB FC FD FE FF

! End of TAC11x10.COD Note: There is no conversion in this table

The last line of the conversion table is another comment, proceeded by the "!" symbol.
The WTT 2.0 conversion tables end with the line:

! END OF filename

Hebrew Locale
The Solaris 7 operating environment includes the Hebrew Language Environment.
This section describes the main features of the Hebrew Language Environment.
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Typing Hebrew Text
You may need to intersperse Hebrew and English text in the same file. To toggle
between Hebrew and English input modes, use Ctrl+t. The message at the base of each
tool displays the current input language.

Editing Hebrew Text
This section describes how to work with Hebrew text, specifically, how to manipulate
the cursor within the logical edit mode.

Note – You may find a residual cursor image at the beginning of a line of text, after
text has been entered. Functionality is not affected by this residual image. Continue
entering data.

Character Insertion
There is ambiguity when the text insertion point is in the boundary between Hebrew
and English text. To solve this ambiguity, a split cursor has been implemented to
reflect the two positions. The display will be ab|DC| where “|” represents each
cursor.

Note – The split cursor may not display properly when pressing the Home or End
keys.

Printing Hebrew Text
Hebrew printing is implemented by using a set of filters. The Hebrew locale package
SUNWheu should be installed on both the server machine to which the printer is
attached and the client machine.

Installed Hebrew Filters
The following list of filters are included in the Hebrew locale package.
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heb2ps

This heb2ps filter converts any text to postscript and sends the Hebrew font together
with font to printer.

� Input types: heb2ps

� Output types: postscript

� Printer types: any

� Printers: any

� Filter type: slow

� Command: /usr/openwin/bin/mp

� Options: INPUT * = -A4

Options: INPUT * = -L he

hebl2r

When printing with the hebl2r filter, no reordering is done on input text. Text is
formatted to fit an 80 column paper size. This would be useful for printing an English
document with a few Hebrew words.

� Input types: hebl2r
� Output types: heb2ps
� Printer types: any
� Printers: any
� Filter type: slow
� Command: /usr/lib/lp/postscript/convert_text
� Options: INPUT * = -linewidth 80

hebr21

When printing with the hebr21 filter, all text is indiscriminately reversed and the
resulting printer output is aligned to the right.

� Input types: hebr21

� Output types: heb2ps

� Printer types: any

� Printers: any

� Filter type: slow

� Command: /usr/lib/lp/postscript/convert_text

� Options:

INPUT * = -linewidth 80
-inputLayoutDirection right_down -outputLayoutDirection left_down
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hebtxt

When printing with the hebtxt filter, text is sorted in both Hebrew and English
directions and the resulting printer output is aligned to the right

� Input types: hebtxt

� Output types: heb2ps

� Printer types: any

� Printers: any

� Filter type: slow

� Command: /usr/lib/lp/postscript/convert_text

� Options:

INPUT * = -inputTextMode text_mode_implicit
-outputTextMode text_mode_visual -lineWidth 80 -inputLayoutDirection
left_down -outputLayoutDirection right_down

Using the Hebrew Filter From the Command Line
To print from the command line, use the hebtxt filter. The lp printing command is
lp -T hebtxt -d printer_name.

Printing from dt Applications
The print action field in the dt configuration files should be modified to add the
Hebrew text filter. For example, in the dtmail application, the print action in the file
/usr/dt/appconfig/types/he/dtmail.dt should be:

ACTION Print
{
LABEL Print
ARG_TYPE DTMAIL_FILE
TYPE COMMAND
WINDOW_TYPE NO_STDIO
EXEC_STRING sh -c ’ \

dtmailpr -p -f %(File)Arg_1% |
/usr/lib/lp/postscript/convert_text -inputTextMode
-text_mode_implicit -outputTextMode text_mode_visual
-lineWidth 80 -inputLayoutDirection left_down
-outputLayoutDirection right_down| mp -A4 -L he| dtlp

-u %(File)Arg_1%;’}

The listed convert_text parameters will print right-aligned text right-to-left. To
print text aligned to left, left-to-right replace the previous parameters with
-lineWidth 80.
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APPENDIX E

Access for Users With Disabilities

Many users with disabilities have trouble using the standard keyboard and mouse on
computers. They may find it difficult or impossible to hold down two keys at once (to
type capital letters or control characters), or to use a mouse, or type accurately.

AccessX is an extension to OpenWindows that makes it easier for people with
disabilities to use a keyboard and to move a pointer around their screen. With AccessX
running, you can:

� Keep the Control, Shift, Alt, and Meta keys pressed and active while you press
another key, enabling you to type capital letters, Control-C, Alt-M, and so forth.
(See “StickyKeys” on page 622.)

Note – Not all keyboards have all these keys. On some keyboards, for example, the
Meta key is replaced by Control-Alt.

� Use the numeric keypad to emulate the mouse. You can move a pointer around the
screen and perform mouse button actions (for instance, double-clicking), all from
the keyboard. (See “MouseKeys” on page 624.)

� Make the computer beep when certain keys are activated or deactivated; people
with limited vision can then tell whether, for example, the Caps Lock key is on.
(See “ToggleKeys” on page 626.)

� Prevent a key from repeating if you have trouble releasing it quickly. (See
“RepeatKeys” on page 626.)

� Prevent a key that you hit accidentally from inputting to the system. (See
“SlowKeys” on page 627.)

� Make a key accept input as intended, even if you are unable to hold the key down
steadily. (See “BounceKeys” on page 628.)

617



Starting AccessX
AccessX is an extension to OpenWindows.

To start OpenWindows with the AccessX extension, type

openwin -accessx

This enables you to activate and deactivate AccessX features both with buttons in
AccessX windows and with certain keystroke combinations. For example, you can
turn StickyKeys on and off by pressing the Shift key five times.

Alternately, you can start OpenWindows without the -accessx option. You still have
the full AccessX functionality; however, you can’t use the special keystroke sequences
to turn features on or off. You must use buttons in AccessX windows instead.

The -accessx option does not affect the use of other OpenWindows options.

(If OpenWindows comes up automatically, from your . or .login file, you may want
to add the -accessx option to the line that calls OpenWindows.)

AccessX Windows
If you’ve brought up OpenWindows, and no AccessX windows are already up on your
screen, type accessx & in a command window.

If you’re running AccessX and want to have AccessX windows come up automatically
when you start OpenWindows, choose Save Workspace from the Utilities submenu of
the main (background) OpenWindows menu.

The AccessX Main Window
After you type accessx &, this window appears:
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accessx

Status

Sound tone when features turned on or off

Enable AccessX

Turn on Features

Off after time out (min)

MouseKeys

StickeyKeys

5

RepeatKeys

ToggleKeys

BounceKeys

SlowKeys

Settings...

HelpTurn
AccessX

on/off

For pressing
2 keys at once

Beep when NumLock,
Caps Lock, and so on,

are down

For using the keypad
as a mouse

Automatic
shutoff

Get a beep

Ignore accidental
keystrokes

Prevent unwanted 
keystroke repetition

For users who 
"bounce" on keys

Bring up the 
Settings window

FIGURE E–1 The AccessX Main Window

Displaying the Status of Buttons and Keys
From the Status menu, you can display two windows that show the status of mouse
buttons and certain keys. The StickyKey status window indicates if a key such as
Control or Shift is pressed; the MouseKeys status window does the same for mouse
buttons.
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To open the Status menu, either use the MENU mouse button, or press the F10 key
and the letter s. Use the arrow keys to move through the menu.

FIGURE E–2 The Status Menu

Note – If you’re using StickyKeys or MouseKeys, it’s a good idea to display the status
window for that feature. Otherwise, you may encounter unexpected behavior that can
be very confusing. In StickyKeys, for example, if the Control key is “locked” down,
pressing the letter c sends a Control-C to the computer. The StickyKeys status window
reminds you that Control is active.

Getting a Beep When a Feature is Turned On or Off
The main window has a check box labeled “Sound when features turned On/Off.”
(See Figure E–1.) If you check this box, any time a feature such as StickyKeys or
SlowKeys is activated or deactivated, the computer beeps.

Setting the Automatic Shutoff Timer
If you share your computer with someone who doesn’t use AccessX, you may want to
have AccessX turn itself off automatically if the machine isn’t used for a certain period
of time. That way, neither you nor the person who uses your machine after you has to
remember to shut off AccessX.

To activate this timeout, check the “Off after time out (min)” check box. (See Figure
E–1.) Move the associated slider to set the amount of time AccessX should wait
without input before disabling itself. You can set this time to be anywhere from zero to
six minutes.
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Getting On-Line Help
AccessX has several help windows; choose the subject that interests you from the main
window’s Help menu. To open this menu, either use the MENU mouse button, or
press F10 and the letter h. Use the arrow keys to move through the menu.

FIGURE E–3 The Help Menu

The Settings Window
Click the Settings button in the AccessX main window to display the Settings window.
This window displays adjustable parameters for various AccessX features. These
parameters are discussed in the section covering each individual feature.
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FIGURE E–4 The AccessX Settings Window

Individual Features

StickyKeys
Many people with disabilities have trouble holding down two keys at once, making
combinations like Control-D or Shift-Mouse-Click difficult. When StickyKeys is turned
on, modifier keys (generally, Shift, Alt, Control, and Meta) stay active while you type
another key or click a mouse button.
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Turning StickyKeys On and Off
There are four ways to turn StickyKeys off:

� Check the StickyKeys check box in the AccessX main window.

� Press the Shift key five times in succession (valid only if you’ve started
OpenWindows with the -accessx option).

� Press a modifier and any other key — for example, Shift-x or Control-Shift (valid
only if you’ve started OpenWindows with the -accessx option).

� Press two modifier keys at once (see under “StickyKeys Settings” on page 623).

Latching and Locking
Sticky keys may be either latched or locked:

� You latch a modifier key by pressing it once.

A latched key stays active until a non-modifier key is pressed. Suppose that, with
StickyKeys on, you press the Control key. It will stay “pressed” while you press the
l key, giving you Control-L. Once you press l, Control is “released.”

� You lock a modifier key by pressing it twice in succession.

The key stays locked until you press it again. For example, suppose you want to
enter

:WR

In this case, you would press Shift twice to lock it. Then you’d press the colon key and
the letters w and r. To unlock Shift, press it again.

You can bring up a Status window to see which keys are latched or locked. (See
“Displaying the Status of Buttons and Keys” on page 619.)

StickyKeys Settings

Getting a Beep Whenever a Modifier is Pressed

You can have your computer beep every time you press a modifier key (with
StickyKeys on). Since pressing these keys latches, locks, or releases them, a beep can
be a useful reminder that you’ve enabled or disabled a modifier. (It’s easy to forget
this in the course of normal typing.)

To enable this setting, check the “Sound when modifier pressed” check box in the
Settings window. (See Figure E–4.)
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Turning StickyKeys Off by Pressing Two Modifiers at Once

When you check this box (in the Settings window), you allow yourself to turn off
StickyKeys by pressing two modifiers at once (such as Control and Shift). Some people
find this easier than clicking with a mouse or pressing Shift five times.

MouseKeys
If you have trouble using a mouse, use MouseKeys to make the numeric keypad on
your keyboard emulate mouse actions. You can move the pointer around your screen,
as you would with a mouse, and click or press mouse buttons.

Turning MouseKeys On and Off
There are two ways to turn MouseKeys on and off:

� Check the MouseKeys check box on the AccessX main window

� Press the Alt, Shift, and Num Lock keys at once. (Valid only if you’ve started
OpenWindows with the -accessx option.)

Keyboard Emulations of Mouse Actions
When MouseKeys is turned on, the keys on the numeric pad have three different kinds
of functions:

� Keys 1-4 and 6-9 move the pointer around the screen.

� The 5, + (plus), 0 (zero) and . (decimal point) keys simulate mouse button clicks
and presses.

� The /(slash), * (multiply), and - (minus) keys switch the keyboard mapping
between various mouse buttons.

You can bring up a Status window to see which mouse keys are currently pressed.
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Note: Your keyboard (and mouse) may differ.

FIGURE E–5 Mouse Button Equivalents for a Numeric Keypad

MouseKeys Settings

Changing the Maximum Speed of the Pointer

If you have trouble moving the pointer with the accuracy you want, you can slow it
down. To change how fast the pointer moves, check the box marked “Max. pointer
speed (pix/sec).” (SeeFigure E–4 .) Adjust its slider bar to the speed that you want.
The speed is in pixels/per second, and can range from 10 up to 1000.1

Setting the “Ramp-Up” Speed for the Pointer

You can set how fast the pointer reaches its maximum speed (when MouseKeys is set).
To do this, adjust the slider marked “Time to max speed” (see Figure E–4.) This way,

1 Limits on pointer speed apply only when MouseKeys is turned on.
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you can be more deliberate in moving the pointer. You can set the mouse to take up to
four seconds to reach full speed.

ToggleKeys
Many keyboards have indicator lights (LEDs) that light up when certain keys are
active. An example of this is the Caps Lock key. When Caps Lock is pressed, its
indicator light goes on.

For people with no or little eyesight, these indicator lights are of limited use. The
ToggleKeys feature serves as the aural equivalent of such a light. When you make
Num Lock, Caps Lock, or Scroll Lock active, the computer beeps once. When you
deactivate the key, the computer beeps twice.

Turning ToggleKeys On and Off
Check the ToggleKeys check box in the AccessX main window to turn this feature on
and off.

RepeatKeys
Some users with limited motor abilities have a hard time taking their finger (or mouth
stick) off keys quickly. As a result, for example, they sometimes type kkkkkkkkk when
they mean to type k,. With RepeatKeys on, a key must be held down for a certain
length of time before it starts to repeat.

Turning RepeatKeys On and Off
There are two ways to turn RepeatKeys on and off:

� Check the RepeatKeys check box in the AccessX main window.

� Hold down the Shift key (either one) for eight seconds.

The computer beeps at four seconds to let you know that you’re turning this
feature on or off. (Valid only if you’ve started OpenWindows with the -accessx
option.)

626 Solaris Common Desktop Environment: User’s Guide • December 2001 (Beta)



Note – Holding down the Shift key for eight seconds also turns on SlowKeys.

RepeatKeys Settings

Delaying the Onset of Repetition

You can set the amount of time you want a key to be pressed before it begins
repeating. This interval can be anywhere from a tenth of a second up to ten seconds.
To set this parameter, move the “Delay until repeat” slider (see Figure E–4) to the
number of seconds you want keys to wait before repeating.

Setting the Rate of Repeating

You can also set the repeat rate. The repeat rate represents how many times a pressed
key will repeat per second. The rate ranges from 0.1 (that is, ten seconds per key) to 10
(that is, ten keys per second). The higher you set this value, the faster the key repeats. Set
this to a low value to keep a pressed key from repeating, or from repeating too
quickly.

Move the “Repeat rate” slider to the value you want. (See Figure E–4.)

SlowKeys
Users who have trouble typing often hit the wrong key, or keys, while trying to type.
They may, for example, hit r while reaching to type t. When SlowKeys is turned on,
only keys that are held down for a minimum, specified time will be accepted as input.
Keys that are hit inadvertently will not register.

Note – Both SlowKeys and BounceKeys cannot be active at once.

Turning SlowKeys On and Off
Turn SlowKeys on and off in either of these ways:

� Check the SlowKeys check box on the AccessX main window

� Hold either Shift key down for at least eight seconds. The machine will beep at
four seconds to let you know you’re turning this feature on or off. (Valid only if
you’ve started OpenWindows with the -accessx option.)
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Note – Holding down the Shift key for eight seconds also turns on RepeatKeys.

SlowKeys Settings

Setting the Notification Style

You may want to be notified of a key’s status while SlowKeys is active. That way you
don’t have to guess whether you’ve held the key down long enough for it to be
accepted.

There are two check boxes (“pressed” and “accepted”) in the Settings window for
setting how you want to be notified of a key’s status when SlowKeys is in effect. By
checking these boxes, you can have your machine beep:

� When a key is initially pressed
� When the key-press is accepted
� Both when the key is first pressed and when the key-press is accepted
� Not at all

Setting the Acceptance Delay

The acceptance delay is the interval between when you first press a key and when it
transmits input. You can set this with the “Acceptance delay (sec” slider located in the
Settings window. (See Figure E–4.) This delay can range from zero to five seconds.

BounceKeys
BounceKeys aids people who have trouble holding down a key, or who tend to hit a
key repeatedly when they mean to press it only once. BounceKeys sets the window
system to ignore rapid, repeated pressings of a single key.

Note – Both SlowKeys and BounceKeys cannot be active at once.

Turning BounceKeys On and Off
To turn BounceKeys on and off, check the BounceKeys check box on the AccessX main
window.
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BounceKey Settings

Setting the Debounce Time

The Debounce Time is the interval that must pass before a second pressing of a key is
accepted.

You can set this interval with the “Debounce time (sec)” slider. (See Figure E–4.) This
delay can range from zero to five seconds.

Keystrokes for AccessX Features
Table E–1 shows the various AccessX features and their associated keystrokes. You
must start OpenWindows with the -accessx option to use these keystrokes.

TABLE E–1 Features and Their Keystrokes

Feature Keystroke

Turn StickyKeys on or off. Press Shift five times.

Turn StickyKeys off. Press any two modifiers (e.g., Shift and
Alt) at once. Note: You must turn this
ability on from the Settings menu.

Turn MouseKeys on or off. Alt - Shift - Num Lock

Move the pointer (when MouseKeys is turned on). 1-4, 6-9 keys on the numeric keypad

Click

Double-click

Press

Release

5

0

.

+

SELECT (mb1)

ADJUST (mb2)

MENU (mb3)

/

*

-

Turn RepeatKeys on or off. Hold down Shift for eight seconds (beeps
at four seconds)

Turn SlowKeys on or off. Hold down Shift for eight seconds (beeps
at four seconds)
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Glossary

access privileges Permissions granted to a user or group of users to perform various
operations on a file or folder (directory). See permission.

action A desktop construct that provides a method for running applications,
executing commands, and other activities such as printing, removing
files, and changing directories. Actions are defined in a database of
configuration files.

action icon An icon that represents an action in a File Manager or Application
Manager window, or in the workspace. An action icon is created by
creating an empty executable file with the same name as the action it
represents.

action label The name displayed under the icon of an action. See action name.

action name The name associated with an action, which by default is displayed
under the icon for the action. See action label.

active A window, window element, or icon that is currently affected by
keyboard and mouse input. Active windows are differentiated from
other windows on the workspace by a distinctive title-bar color or
shade. An active window element is indicated by a highlight or
selection cursor.

active window A window that receives keyboard input.

address An electronic mail location of a user.

address card A file (conforming to the vCard standard) containing contact
information about a user. Address cards are displayed by the Address
Manager application.

alias An alternative name or names assigned to a program or to an
electronic mail address.
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In electronic mail, an address for mailing to a group of users. An alias
can be created to send electronic mail to a small group of people or to
many people.

alias card An alias (see above), as displayed in Address Manager application.

application See software application.

application group An Application Manager folder that holds a specific software
application or set of software applications.

application icon See action icon.

Application Manager A window containing objects representing the system actions available
to you.

application server A host computer that provides access to a software application.

Apply A choice that causes a selection (or group of selections) in a dialog box
to take effect.

Appointment Editor In Calendar, a window you use to schedule, change, or delete an
appointment.

Appointment List A chronological list of appointments displayed by Calendar.

arrow button An element of a scroll bar used to scroll a window by small
increments. Also, a control in the Front Panel used to slide up or slide
down a subpanel.

arrow keys The four directional keys on a keyboard. Also see navigation keys.

attachment In Mailer, a data object within an electronic mail message that is
displayed as an icon in the Attachments list. An attachment can be
text, sound, or a graphic. Multiple messages can be added (attached) to
a single electronic mail message.

backdrop The pattern that covers the workspace background.

background The underlying area of a window on which elements, such as buttons
and lists, are displayed.

Backtrack In Help Manager, a button and Navigate menu item you use to follow
links backward, in the reverse order they were traversed.

base name The file name of an icon file minus the file-name suffixes for size (.l,
.m, .s, .t) and type (.bm, .pm). For example, the base name of an
icon file named myicon.m.pm is myicon.

bitmap An image stored in a raster format. Usually refers to an image limited
to two colors (a foreground and a background color). Contrast with
pixmap.

busy light A control that blinks when a Front Panel action has been invoked prior
to the appearance of a window or when reloading actions.
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button A generic term for a window control. See push button.

Calculator A software application that mimics the function of a hand-held
calculator.

Calendar A software application that enables you to schedule appointments and
create To Do lists.

Calendar view The day, week, month, or year displayed in the main Calendar
window.

Cancel A push button that removes a window without applying any changes
made in that window.

cards The Address Manager application uses the concept of cards (similar to
Rolodex cards) when searching and displaying information about
users (address cards), hosts (host cards), and aliases (alias cards).

CDE An acronym for Common Desktop Environment, a graphical user
interface running on UNIX.

check box A nonexclusive control whose setting is indicated by the presence or
absence of a check mark. A check box has two states, on and off.

choose To use the mouse or keyboard to pick a menu item, button, or icon that
begins a command or action. Contrast with select.

click To press and release a mouse button without moving the mouse
pointer. Unless otherwise specified, mouse button 1 is assumed.

client A system or software application that requests services from another
application, usually across a network.

clipboard A buffer that temporarily stores the last cut, copy, or pasted data.

Clock A Front Panel control that displays the local time.

Close A menu item used to remove a window and all related secondary
windows from all workspaces.

command-line prompt A prompt (usually %, >, or $) that shows the computer is ready to
accept commands. In a terminal emulation window, you display the
command-line prompt by pressing Return.

Compose window In Mailer, the window you use to create new electronic mail messages.
Several message-composing options are available from the Compose
window menu bar.

configuration file A file that is used to customize the properties of an application.

container A control intended to hold objects or data. A folder and a notebook are
examples of containers.
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In Mailer, your electronic mailbox and filing system that contains all
mail messages. Once a message is put in a container, you can display,
modify, delete, print, include, forward, and reply to it.

control A generic term for a variety of elements (such as buttons, check boxes,
and scroll bars) that perform an action or indicate an option setting.
See Front Panel control.

Create Action A software application that enables you to associate an icon with a
command so that the command can be issued by clicking on the icon.
Create Action is also used to define specific data types for an
application’s data files and to associate icons with those data types.

current folder The currently opened folder in an active File Manager view.

current item, current
selection

The currently highlighted item in a list.

current session The session saved by Session Manager when you log off. At the next
login, unless you specify otherwise, this session automatically opens,
enabling work to continue where you left off. Contrast with home
session.

cursor A graphical device that shows the area that will receive keyboard or
pointing device input.

customization The process of changing settings to alter the appearance and behavior
of the desktop and applications running on the desktop.

data type A mechanism that associates particular data files with the appropriate
applications and actions. Data types can determine the type of a file
based on file-naming conventions, such as a particular extension name,
or on the contents of the file.

default A value set automatically by an application.

desktop See workspace.

dialog box A window displayed by an application that requires user input.

dimmed Reduced contrast to show unavailable emphasis.

directory A collection of files and other subdirectories. In graphical user
interface applications, may be called a folder.

double-click To quickly press a mouse button twice without moving the mouse
pointer. Unless otherwise specified, mouse button 1 is assumed.
Double-clicking can often be used as an alternative to selecting menu
items.

drag To press and hold down any mouse button while moving the
pointer—and the object under the pointer—on the screen.

drag and drop To directly manipulate an icon by using a pointing device to move and
place the icon somewhere else. Also referred to as drag transfer.
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drag transfer See drag and drop.

drop After starting the drag of an object, the act of releasing the mouse
button. If the object is dropped in an appropriate area, an action is
initiated.

drop target A rectangular graphic that represents the drop zone in an application.

drop zone An area of the workspace, including the Trash Can, Print Manager, and
Mailer Front Panel controls, that accepts a dropped icon. Icons can be
dropped on the workspace for quick access.

duplicate button Mouse button 2 is referred to as the duplicate button because, when
clicked in an editable area, it copies the currently selected text to the
position at which it was clicked.

element A generic term for any entity that can be considered a standalone item
in a broader context, such as an item in a list or a control in a window.

email Short name for “electronic mail.” Email usually describes text
messages addressed and sent to you electronically and are received in
your electronic mailbox. Sometimes just known as “mail.”

environment variables Standard UNIX variables that are used by the shell and by
applications.

error message A message that requires the user’s immediate attention. Error
messages are used to convey a message about a user error.

execute A file or folder (directory) access permission. For files, execute
permission enables the user to run a program or shell script file. For
folders (directories), execute permission enables the user to access the
folder (directory) contents.

Exit button A Front Panel control used to log out of the desktop.

extended selection To add multiple items to a selected set by augmenting the selection
technique. For example, you can add to a selection by moving the
pointer to a new item and pressing Control and mouse button 2
simultaneously.

file A unit of data, such as text, program, image, and so on, that is stored
in a folder (directory).

File Manager The software application that manages the files and directories on your
system.

file name The name of the file as it is stored in a folder (directory) or on a storage
device. A file name consists of a base name and any suffixes. A fully
qualified file name also includes the path.

file server A host computer that stores data files used by applications.

file suffix A suffix added to the end of a file name, often used in file typing or to
categorize files for the user.
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file type Characteristics of a file that determine how it is used. The type of a file
may be determined by a portion of its name (for example, the file
extension) or by its content.

filter Used to display only objects that meet certain criteria, such as a name
pattern match, and to hide all other objects from view.

focus The place to which keyboard input is directed, indicated by the
highlight.

folder An icon that represents a directory.

font A complete set of characters (letters, digits, and special characters) of
one size and one typeface. Ten-point Helvetica bold is an example of a
font.

foreground The content of a window and the color or shading used to distinguish
it from the window’s background.

Front Panel A centrally located window containing controls for accessing
applications and utilities, including the workspace switch. The Front
Panel occupies all workspaces.

Front Panel control An object in the Front Panel used as an interface to basic system
services and frequently performed tasks and operations. Controls in
the default Front Panel are: Clock, Calendar, Mailer, Text Editor, Help
Viewer, File Manager, Printer, Style Manager, Application Manager,
and Trash Can.

Front Panel move
handles

An area on each end of the Front Panel used for moving the Front
Panel and for bringing it to the front of the workspace.

grab handles (or
handles)

The small squares displayed at the corners and midpoints of a selected
graphic element.

group A collection of users who are referred to by a common name.

Also, a permission setting that determines a group’s access to files.

Group Appointment In Calendar, an appointment for a group of people, scheduled using
the Group Appointment Editor.

header In Mailer, the basic information about an electronic mail message as it
appears in the mailer container. A message header displays the name
of the sender, subject, the date and time it was received, and message
size.

Help A button or menu item used to access information about objects,
choices, tasks, and error messages.

help family A set of help volumes that provide online information about related
applications.

Help Index An alphabetic listing of help topics.
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help key A designated key, usually the F1 key, used to request online help
information about what the cursor is currently on.

Some keyboards have a dedicated Help key that may take the place of
F1.

Help Manager A special help volume that lists all the online help registered on your
system.

Help Viewer The software application that displays online help.

help volume A complete body of help information about a subject.

help window A secondary window that displays help information.

hierarchical file system A way to organize data on computer systems using a hierarchy of
containers, often called folders (directories) and files. In this scheme,
folders may contain other folders and files. The successive
containment of folders within folders creates the levels of organization,
which is the hierarchy.

highlight (v) To make something stand out on the screen by selecting or
choosing it. Also (n) the visual indicator that something is selected.

history A list of the most recently accessed commands, files, folders, or help
topics.

home directory A directory where you keep personal files and additional directories.
In graphical user interface applications, may be called the home folder.

HomeDirectory Symbolizes your home directory. For example: If your home directory
is /users/anna, then HomeDirectory/bitmaps/smile.bm
represents /users/anna/bitmaps/smile.bm.

home folder A folder where you keep personal files and additional directories. By
default, File Manager and Terminal Emulator windows are set to the
home folder when you first open them. When discussing
command-line activities, may be called the home directory.

home session A choice at logout to designate a particular session, other than the one
you are currently in, as the one you will automatically return to at the
next login.

host A computer system.

host card The details of a host, as displayed in the Address Manager application.

hyperlink In Help text, text or a graphic you click to display another Help topic.

icon A graphical representation of an object consisting of an image, an
image background, and a label. An icon can be directly manipulated.

Icon Editor The software application used to create new icons and to modify
existing icons.
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Inbox The main or default Mailer container. The Inbox receives all incoming
mail. Messages can be moved out of the Inbox and put in various
containers.

index In a help volume, an alphabetical list of words or phrases that can be
searched to find help on a subject. The Help System displays the index
when you choose the Index button in a help dialog box.

insertion point The point at which data typed on the keyboard, or pasted from the
clipboard or a file, appears on the screen. In text, a synonym for cursor.

Install Icon An item on a subpanel used to install icons into the Front Panel using
drag and drop.

ITE Internal Terminal Emulator. ITE allows use of a bitmapped display as a
terminal (through command-line mode from the login screen).

items Elements in a list or menu.

label The text appearing next to an icon or control that names the element.

link Synonym for symbolic link.

list A control that contains elements from which you select. Also called
selection list.

Lock button A Front Panel control used to lock the screen.

log in To supply a user name and password to gain access to a system or
desktop session.

login The process of gaining access to a system.

log out To terminate or end access to a system or desktop session.

logout The termination of a desktop session.

Mailer An application that enables you to send, receive, and compose
electronic mail messages.

mailer container The electronic mail box and filing system that contains all mail
messages. Once a message is put in a container, you can display,
modify, delete, print, include, forward, and reply to it.

Mailer control The Front Panel control used to start the Mailer software application.
Dropping a file on the control loads the file into the Mailer Compose
window.

Main Panel The portion of the Front Panel excluding the subpanels.

mapping A method of using one action to run another action. Also, a pairing of
entities in one set with those in another set.

Maximize A choice that enlarges a window to its largest possible size.
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maximize button A button on a window’s title bar that you choose to display the
window in its largest size.

menu A list of items from which you select to perform a particular
application task. Also see submenu.

menu bar The part of the application window between the title bar and the work
area where menu names are listed.

menu item An element in a menu that represents a choice (for example, Copy on
the Edit menu).

Minimize To turn a window into an icon. The push button that minimizes a
window is located near the upper right corner of the window frame.

minimize button A button on a window’s title bar that you choose to display the
window as an icon.

mnemonic A single, underlined character in a command. The mnemonic indicates
that you can choose the command by typing that letter. Mnemonics are
used most commonly in menu commands; however, other buttons
may also have mnemonics.

modifier key A key that when pressed and held along with another key or mouse
button changes the meaning of the second key or mouse click. Control,
Alt, and Shift are examples.

mouse A device for moving the pointer and making selections.

mouse button A mechanism on a mouse that you press to make selections.

mouse button 1 On a mouse, the leftmost button when configured for right-handed
use; the rightmost button when configured for left-handed use. Mouse
button 1 is primarily used for selection, and is the default button for
the “click” instruction.

mouse button 2 On a three-button mouse, the middle button. Mouse button 2 has two
modes: Transfer and Adjust.

mouse button 3 On a mouse, the rightmost button when configured for right-handed
use; the leftmost button when configured for left-handed use. Mouse
button 3 activates pop-up menus.

Move A Window menu choice used to put a window in a different location
on the screen.

navigation keys The keyboard keys used to move the current location of the cursor.
These include the arrow keys (with or without the Control key); the
Tab key (with or without the Control or Shift keys); the Begin and End
keys (with or without the Control key); and the Page Up and Page
Down keys.

newline character An unseen character that marks the end of a line of text in a document.
It tells a printer or screen to break a line and start a new one.
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object Any logical piece of data that has associated behavior. For example, in
File Manager, files, folders, actions, and applications are all considered
objects. Each type of object has specific associated actions. Typically,
each object is represented as an icon.

object type A desktop mechanism used to associate particular data files with the
appropriate applications and actions. Object typing defines the criteria
for typing the file (such as name or contents), the appearance (the icon
used in File Manager), and the behavior of the object (for example,
what happens when you double-click it).

OK A choice that accepts the information in a window and closes it. If the
window contains changed information, those changes are applied
before the window is closed.

On Item help When you choose On Item from the Help menu, the cursor changes to
a question mark and you can obtain information about a particular
command, operation, dialog box, or control by clicking that object.

On Item Help control A Front Panel control used to access item help information on the
Front Panel.

overwrite To replace.

page To advance text displayed in a window by one full screen at a time,
usually using a scroll bar.

palette A range of graphically displayed choices, such as colors or collections
of tools, that you can select in an application.

parent directory A directory that contains subdirectories and files. In graphical user
interface applications, this may be called the parent folder.

parent folder A folder that contains subfolders and files. When discussing
command-line activities, this may be called the parent directory.

password A sequence of characters that users type to prove their identity to the
system.

path A text string that specifies the hierarchical location of a folder
(directory).

pause To temporarily suspend a process without ending it.

permission A setting that determines how users or groups of users may access a
file or folder (directory).

pixmap An image stored in a raster format. Usually refers to an image that
may have more than two colors. Contrast with bitmap.

point To move the mouse until the pointer rests on a particular screen
element or area.
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pointer A cursor that shows the area that receives input from a pointing
device. The pointer can take the form of an arrow, an I-beam, a cross,
or other graphic. Also see cursor.

pop-up menu A menu that, when requested, is displayed next to the object with
which it is associated. Pop-up menus are usually displayed by clicking
mouse button 3 or pressing Shift+F10.

Print Manager A software application that shows all the printers on your system.

print server A host computer to which one or more printers are connected, or the
UNIX process that manages those printers.

Printer control The Front Panel control used to start the Printer software application.
Dropping a file on the control displays a dialog box you can use to
print the file to the default printer.

Printer Jobs A software application that provides information about jobs on a
single printer.

program A sequence of instructions that a computer can interpret and execute.

Properties A menu item used to set characteristics of an item, such as its date or
name, or display identifying characteristics of an item, such as
typefaces.

pull-down menu A menu of related choices that extends from a cascading choice when
you click mouse button 1 on a menu bar item or the Window menu
button.

push button A control that immediately starts an action by an application, usually
executing a command (such as Apply), displaying a window, or
displaying a menu.

queue An ordered list of jobs waiting to be performed.

radio button An exclusive control whose setting is indicated by the presence or
absence of a graphical indicator, usually part of a radio group. A radio
button has two states, on and off.

Read Permission to look at the data in a file or permission to list the files and
folders (directories) in a folder (directory).

Reset A button or menu item used to return an item to the condition it was
in when it was last opened or to the condition it was in before the most
recent changes were applied to it, whichever is more recent.

resize border A control used to change the size of a window or a pane in a window.

resource A mechanism of the X Window System™ for specifying an attribute
(appearance or behavior) of a window or application. Resources are
usually named after the elements they control.

restart To stop a process and start it again.
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Restore A menu item used to return a window to the size and position it
occupied before you minimized or maximized it.

root, root user See superuser.

root directory In a hierarchical file system, the directory that contains all other
directories and files. Represented by a / (slash) in UNIX systems.

run To start an application or action.

sash A box on a separator or split bar that enables you to increase or
decrease the size of a window pane using the mouse. You can navigate
to the sash using the keyboard.

screen lock A function that locks the workstation screen, barring further input
until the valid user password is entered.

screen saver A choice that, after a specified time period, switches off the
workstation display or varies the images that are displayed, thereby
prolonging the life of the screen.

scroll To move the cursor through data one increment at a time. While
scrolling, data shifts within the window to indicate the current
position of the cursor.

scroll bar A control located at the right or bottom of a window that enables you
to display window content not currently visible.

scroll box The part of a scroll bar that shows the position of the visible
information relative to the total amount of information available in a
window. You click a scroll box to see information that is not currently
visible.

select To add highlighting or some other visual cue to an item or element so
that it can be operated or enabled. Selection does not imply the
initiation of an action but rather a change of state, such as highlighting
an item in a list, or toggling a check box on.

server A system that supplies services to a client.

session The elapsed time between user login and logout. Also, a particular
configuration of workspaces that includes Style Manager settings,
open applications, and the size and position of objects.

Session Manager A software application that controls saving sessions, restoring sessions,
screen locking and unlocking, and the use of screen savers. When a
session is saved, the state of the desktop environment (location of
icons, size and location of open windows, open/closed status of
applications, current color palette, and so on) is preserved so that it
can be restored at the next login.

session server A system that provides networked sessions. Session files reside on the
session server and are used whenever you log in to a system on the
network.
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shortcut General term for a mouse gesture that simplifies filling out a dialog
box. For example: As a shortcut, double-click an item in the Filename
list box to select it and choose OK in one action.

shortcut keys A keyboard key sequence used to activate a menu item, usually
through a special accelerator key. For example: Press Alt+F to choose
Print from the File menu.

slider A control that uses a track and arm to set a value from among the
available values. The position of the arm (or a separate indicator) gives
the currently set value.

software application A computer program that provides you with tools to do work. Style
Manager, Text Editor, and File Manager are examples of software
applications.

status area A part of a window where information is displayed that shows the
state of an object or the state of a particular view of an object.

Style Manager The software application used to customize some of the visual
elements and system device behaviors of the workspace environment,
including colors and fonts, and keyboard, mouse, window, and session
start-up behaviors.

subdirectory A directory contained within another directory (sometimes called the
parent directory). In graphical user interface applications, this may be
called a subfolder.

subfolder A folder contained within another folder (sometimes called the parent
folder). When discussing command-line activities, this may be called a
subdirectory.

submenu A menu displayed by choosing an item from a menu.

subpanel An extension of the Front Panel that slides up, providing access to
additional elements. Subpanels usually contain groups of related
elements.

suffix A part of a file name, added at the end, separated from other suffixes
or the base file name by some punctuation, such as a period (.).

superuser A login identity that enables special permissions for modifying system
files that most users do not have permission to modify. Superuser is
also called “the root user” or “root” because the user ID for superuser
is root. On most computer systems, only a few users have permission
to become superuser.

symbolic link A type of link that is capable of pointing to a file or directory that
resides on another physical storage device or partition.

template In Mailer, an ASCII file you can create for conveniently including
frequently typed information, such as your name and electronic mail
address, in your mail messages.
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Terminal In the CDE desktop, an icon used to open a terminal window.

terminal emulator A window that emulates a particular type of terminal for running
nonwindow programs. Terminal emulator windows are most
commonly used for typing commands to interact with the computer’s
operating environment.

text cursor A cursor that shows the insertion point for textual input. This cursor
usually takes the form of an I-beam. Contrast with location cursor and
pointer.

Text Editor The software application used to create and edit documents.

text field A rectangular area in a window where information is typed. Text fields
with keyboard focus have a blinking text insertion cursor.

title bar The topmost area of a window containing the window title, window
menu button, and the maximize and minimize buttons. See also
window title.

toggle To change the state of a two-state control, such as a radio button or
check box, using either the mouse or keyboard.

topic tree In a general help dialog box, a list of topics that can be selected to
display help information.

Trash Can A container for deleted files or folders.

tree view A view of a folder or files that includes all lower-level folders in the
search path.

user name An identifier for making a user known to the system. Sometimes called
a login name. For example, a user whose name is John Doe might have
the user name jdoe. The login screen prompts for the user name.

window A rectangular area on the display. Software applications typically have
one main window from which secondary windows, called dialog boxes,
can be opened.

window frame The visible part of a window that surrounds a software application. A
window frame can contain up to five controls: title bar, resize borders,
minimize button, maximize button, and the Window menu button.

window icon A minimized window.

Window Manager The software application that provides users with the capability to
manipulate windows on the workspace; for example, opening,
resizing, moving, and closing windows.

Window menu The menu displayed by choosing the Window menu button. The menu
provides choices that manipulate the location or size of the window,
such as Move, Size, Minimize, and Maximize.

Window menu button The control at the upper left corner of a window, next to the title bar.
Choosing it displays the Window menu.
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work area The part of a window where controls and text appear.

workspace The current screen display, the icons and windows it contains, and the
unoccupied screen area where icons can be placed.

workspace backdrop See backdrop.

workspace background The portion of the display not covered by windows or icons.

workspace icon An icon that has been copied from File Manager to the workspace.

Workspace Manager The software application that controls the size, placement, and
operation of windows within multiple workspaces.

Workspace menu The menu displayed by pointing at an unoccupied area of the
workspace and clicking button 3 on the mouse.

workspace object An object that resides in a workspace, rather than inside a viewer in a
window. Workspace objects include windows, icons (minimized
windows), and objects that have been dragged from File Manager and
Application Manager and dropped on a workspace.

workspace switch A control that enables you to select one workspace from among several
workspaces.

workspace switch area The rectangular area in the center of the Front Panel that contains the
workspace switches, the Lock control, the Exit button, and the busy
light.

Wrap To Fit In Text Editor, this setting controls whether lines are automatically
wrapped to fit the window width as you enter text. If set, lines wrap at
the edge of the window. If not set, you must press Return to end the
line.

Write Permission to modify the contents of a file or folder.
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Numbers and Symbols
.. (parent directory), 189

A
absolute path, 148
access

denying to your calendar, 371
granting to your calendar, 368, 371
to calendar, changing, 368
to other calendars, 361

Access Control Lists, 163, 167
adding entries, 169
changing entries, 170
default permissions, 172
deleting entries, 171
viewing, 168

accessing Dtpower, 552
AccessX, 617, 629

automatic shut-off, 620
beeping on locked keys, 626
BounceKeys, 628
controlling repeat behavior of keys, 626
holding a key down, 622
ignore multiple key presses, 628
initial delay of repeating keys, 627
keyboard equivalent of mouse buttons, 624
keystrokes for features, 629
latching and locking keys, 623
main window, 618
MouseKeys, 624

AccessX (continued)
pressing two keys at once, 622
preventing accidental input, 627
RepeatKeys, 626
setting rate of repeating keys, 627
Settings window, 621
SlowKeys, 627
sound when feature enabled/disabled, 620
starting, 618
StickyKeys, 622
ToggleKeys, 626

accidental input, preventing, 627
ACL-enabled, 167
action icon, 223

and file names, 228
actions

creating, 229
double-clicking, 156
executing, 160
executing the default, 161
on Process Manager entries, 501

Actions menu, 156
Activity Indicator

control on main panel, 116
add calendar, 375
adding

applications, 229
applications to personal application

group, 227
attachments to mail messages, 287
calendars to Browse list, 360
controls with Install Icon, 139
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adding (continued)
group appointment, 362
mail signatures to all messages, 276
palette, 240
subpanels, 140
To Do item, 356
workspaces, 141

Address Manager
Front Panel control, 483

addresses, 268
aliases, 268
ancestry

showing for a process, 503
AnswerBook, displaying, 98
appending

a message to a file, 260
application

adding to Front Panel, 139
application groups, 222

built-in, 223
definition of, 223
personal, 227

application help, 81
application icon, 223

on workspace backdrop, 226
Application Manager, 43, 221

application groups, 222
built at login, 223
control on subpanel, 222
customizing, 227
folders in, 222
Front Panel control, 222
labels and file names, 228
location in file system, 228
opening, 221
running applications from, 46, 47, 224
updating, 227
window, 222

applications
adding, 229
registering, 231
reloading, 227
running from Application Manager, 46, 47,

224
running from drop zones, 47
running from File Manager, 231
running from Front Panel, 46

applications (continued)
running from terminal emulator, 48
running from Workspace menu, 46
starting in Terminal window, 388

Applications
subpanel, 222

applications
using Text Editor with, 340

applications, opening, 65
Appointment Editor

changing defaults, 366
Group, 361
options, 352
standalone, 377
using, 351

appointment list
displaying, 354
printing, 359

appointments
adding to mail message, 289
basic, 351
changing, 353
creating, 351
creating using standalone Appointment

Editor, 377
deleting, 353
deleting using dtcm_delete, 379
dragging from File Manager, 364
dragging from Mailer, 364
dragging to File Manager, 365
dragging to Mailer, 365
finding, 353
finding using dtcm_lookup, 378
format for mail message, 363
frequency of, 352
inserting, 351
inserting using dtcm_insert, 379
inserting using standalone Appointment

Editor, 377
looking up, 378
mailing, 363, 368
options, 352
reminders, 352
scheduling, 351
scheduling using standalone Appointment

Editor, 377
ATM issues, 561
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attachments
adding to mail message, 287
adding with drag and drop, 288
as part of a template, saving, 272
printing, 287
reading, 287
saving, 288
viewing, 287

Audio
command-line start, 450
description, 441
opening a file, 454
playing audio file, 457
playing audio files, 454, 457
starting, 450
starting from command line, 450
starting from Front Panel, 450
starting from Voice Note control, 452
starting from Workspace Programs

menu, 451
startup, 450
workspace menu startup, 451

audio activity, 563
Audio main window, 451
automatic mail messages, 276
automatic shut-off for AccessX, 620
AutoShutdown, 563, 568

availability, 551
disabling, 570
setting idle time, 569
window, 570

AutoShutdown and AutoWakeup, 562
AutoWakeup, 568

availability, 551
disabling, 571
enabling, 571

B
backdrop, See workspace backdrop
Backdrop dialog box, 244
base name font list, 592
basic appointment, 351
basic file management skills, 149
basic permissions, 165

default, 172

basic user types, 164
Beep Calendar reminder, 352
beep, changing settings for, 246
Beep dialog box, 246
beep when modifier key is pressed

(AccessX), 623
beeping on locked keys, 626
bell options in Terminal, 396, 398
blanking the screen, 552, 557
BottomShadow, 413
BounceKeys, 628

set the debounce time, 629
bringing up AccessX, 618
Browse list, 361
browsing calendars, 360
Browsing Help on Your System, 98
buttons

check box, 58
OK, 57
radio, 58
types of, 57

C
Calendar

add, 375
control on Main Panel, 115
convert version 3 to version 4, 375
creating, 374
delete, 375
Front Panel control, 343
list calendars, 374
menus, 345
saving data in a file, 360
starting, 343
starting from command line, 344
Tool bar, 345
tool bar, 345

Calendar access
world (anyone), 369, 370

Calendar Manager on suspended
machines, 562

Calendar tools, 373
Calendar views

changing, 347, 348, 349, 350
changing default, 368
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Calendar views (continued)
Day, 347
default, 345
displaying, 347
Month, 349
printing, 359
Week, 348
Year, 350

calendars
access to other, 361
browsing, 360
comparing, 361
deleting from the Browse list, 360

Cancel button, 553
canceling

dragging, 151
print jobs, 304

capturing region of display, 416, 417
CDE, 552, 558
CDE workspace, 552
CD-ROM, 192

ejecting, 195
changing

Appointment Editor defaults, 366
appointments, 353
beep settings, 246
calendar access and permissions, 368
Calendar printer settings, 372
Calendar time zone, 373
Calendar views, 347, 348, 349, 350
colors, 238
date format in Calendar, 373
default Calendar view, 368
disk drive Power Management, 559
File Manager default preferences, 189
Front Panel lock settings, 247
how your next session starts, 251, 252
initial calendar displayed, 367
monitor Power Management, 558
number of colors, 241
permissions for your calendar, 371
printer icon, 309
printer label, 310
privacy defaults in Calendar, 366
reminders in Calendar, 366
system Power Management, 556

changing (continued)
time boundaries on Day and Week
views, 367
To Do item, 356

changing ramp-up speed of pointer, 625
changing the character set of an incoming

message, 257
changing the character set of an outgoing

message, 271
character marker for included mail messages,

changing, 290
character set

incoming message, changing, 257
outgoing message, changing, 271

characters
composing special, 70

check boxes, 57, 58
child processes

a definition of, 504
tracing in Process Manager, 504

choosing
Front Panel controls with the keyboard, 587
help, 72
help topic hyperlinks with the

keyboard, 588
menu items, 67
push buttons, 57
subpanel controls with the keyboard, 587
Window menu items, 66
Workspace menu items, 65

choosing to use Power Management, 560
Clean Up (command in View menu), 188, 189
clicking, 39

to make window active, 249
Clock

control on Main Panel, 115
closing

application windows, 50, 582
subpanels, 108

code sets
composing special characters, 70

color
changing, 238
in Terminal window, 396
displaying use of in image, 423
for icons, 412, 413
grabbing from workspace, 240
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color (continued)
in help windows, 103
limiting usage of, 241
viewing image in, 422

Color dialog box, 238, 240
color flashing, 235
Color setting in Image Viewer, 422
colormap flashing, 235
command line

to start Calendar, 344
Command Line Login mode

definition of, 77
exiting, 77
logging in to, 77

command-line startup
Audio, 450

commands
entering in Terminal window, 388
issuing for printing, 300

Compare Calendars grid, using, 362
comparing calendars, 361
composing

special characters, 70
contents, finding file using, 182
control

adding to subpanel, 139
control characters in Terminal, 402, 403
Control key, 68
controls

adding with Install Icon, 139
customizing in the workspace switch, 142
deleting, 112
moving to Main Panel, 139
renaming, 112
replacing in Main Panel, 140

controls, Front Panel, 43
convert version 3 Calendar to version 4, 375
copying

a region of an icon, 414
files, 157
folders, 157
objects, 157
palette, 240
text, 327
text in Terminal window, 389

Create Action, 229
creating, 229

copying (continued)
actions, 229
appointment using standalone Appointment

Editor, 377
appointments, 351
custom palette, 240
data types, 229
document, 314
file with language-specific characters, 590
files, 156
folders, 156
mail aliases, 269
mail search scripts, 265
mail signatures, 275
mailboxes, 260, 281
objects, 156
personal application group, 227
To Do items, 356

creating a calendar, 374
cron jobs on suspended machines, 561
cron process, 550
current folder, 148
current session, 69

definition of, 78, 251
resuming at, 251

cursor movement keys, 320
cursor options in Terminal, 394, 395
custom fields in Format menu, adding, 290
Custom Time, in Calendar, 373
customized power saving scheme, 555
customizing

Calendar printer settings, 359, 372
colors, 239
File Manager views, 184, 185
keyboard behavior, 244
mouse behavior, 245
palette, 239
screen saver, 247, 248

cutting a region of an icon, 414

D
data types, 229
date format, 373
Day view

Calendar, 347
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Day view (continued)
changing time boundaries, 367
three-month mini-calendar, 347

debounce time, 629
debugging a process

in Process Manager, 506
default actions, 161
default permissions, 172

optional Default entry types, 172, 174
required Default entry types, 172, 173

default Power Management settings, 550
default printer

changing, 296
definition of, 295
determining, 295

default terminal emulator, 383
changing, 403

defaults, 562
Calendar view, 345
changing access and permissions, 368
changing Appointment Editor, 366
changing Calendar reminder, 366
changing Calendar view, 368
changing privacy, 366
date format in Calendar, 373
initial calendar displayed, 367
time boundaries on Day and Week

views, 367
delaying a snapshot, 438
delete calendar, 375
deleting

appointments, 353
appointments using dtcm_delete, 379
calendars from Browse list, 360
controls from subpanels, 112
files, 163
folders, 163
mail messages, 260
mailboxes, 283
palette, 241
subpanels, 140
text, 326
To Do items, 356
workspaces, 142

denying access to your calendar, 371
deselecting text, 54

desktop
current session, 69
exiting, 69
help, 72
logging out, 69
workspaces, 54

desktop session, 76
detach support, 573
device drivers, 573, 575
device idle time, 556
device Power Management availability, 550
device suspend failure, 573
dial in to suspended machines, 561
directories, See folders
disabled users, interface for, 617
disabled users, see also handicapped users and

AccessX, 617
disabling

AutoShutdown, 570
AutoWakeup, 571
the power key, 565
the screen lock, 577

disk space shortage, 576
diskette, 192

copying files and folders to, 195
creating files and folders on, 196
deleting files and folders from, 196
ejecting, 195
formatting, 194
moving files and folders to, 195
renaming, 195

diskless clients, 563
display

capturing region of, 416, 417
locking, 70
refreshing, 65
unlocking, 70

display Power Management availability, 550
displaying

appointment list, 354
Calendar views, 347
concealed windows, 53
Front Panel pop-up menus, 109
help, 72
image in color, 422
man pages, 99
message line in Print Manager, 308
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displaying (continued)
pop-up menus, 63, 66, 585
PostScript file in black and white, 429
PostScript file in color, 429
PostScript files, 429
print job properties, 305
print jobs, 303
Print Manager problem flag, 308
printer properties, 309
pull-down menus, 62, 66, 585
subpanels, 107
To Do list, 357
Window menu, 63
Workspace menu, 64
workspaces, 55, 585

document
creating, 314
editing, 311
formatting, 337
going to specific line in, 321
including file in, 327
including file through drag and drop, 335
justifying text in, 338
margins, 338
new lines in, 319
opening existing, 316, 318
opening existing from File Manager, 317
printing, 338
restoring, 311
saving, 315
searching, 336
word wrap, 320

dot files, 189
double-clicking, 40

action performed, 156
double-headed systems, 557
drafts

creating for mail messages, 273
deleting draft mail messages, 274
using for mail messages, 273

drag and drop, in Text Editor, 335
dragging, 40

appointment from Calendar to File
Manager, 365

appointment from Calendar to Mailer, 365
appointment from File Manager to

Calendar, 364

dragging (continued)
appointment from Mailer to Calendar, 364
canceling, 151
file to Text Editor, 335
files, 151
folders, 151
objects, 151
text, 335

drawing icon image, 408
undo, 410

drawing tools for Icon Editor, 409, 410
drop zones

running applications from, 47
dropping

file in Text Editor, 335
files, 151
folders, 151
objects, 151
text, 335

dtcm
to start Calendar from command line, 344

dtcm_convert, 375
dtcm_delete, 379
dtcm_editor, 377
dtcm_insert, 379
dtcm_lookup, 378
Dtpower

accessing, 552
AutoShutdown, 562
AutoWakeup, 562
basic window, 554, 556
conventions, 552
exiting, 571
GUI, 551, 552, 553
program, 551
starting from command line, 553
starting through CDE workspace, 552
window controls, 553

dtterm command, 383
dtterm, Terminal, 383
due date, setting for To Do item, 356
duplicating

using mouse, 41
dynamic colors for icons, 413
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E
Edit button, 553
editing

existing mail message text, 259
file with language-specific characters, 590
text fields, 61
text or document, 311

effective permissions, 165
electronic mail on suspended machines, 560
enabling AutoWakeup, 571
encoding

incoming messages, 257
outgoing messages, 271

Energy Star, 547
Energy Star, v.3, 550
Enter key, 68
entering

commands in Terminal window, 388
text in a text field, 60

errant processes
a definition, 495
tips for finding, 496

Esc key, 68
Euro

currency symbol, 71
executing actions, 160
Exit control, 69, 76, 117
exiting Dtpower, 571
Extend char key, 68
external devices, 565, 567

F
F1 key, 72
failsafe session, 77
File Finder

find by properties, 182
to open, 178
using, 178

file management, basic skills, 149
File Manager

changing icon display area size in, 191
control on Main Panel, 115
determining headers for, 185
disabling icon browsing in, 191
Front Panel control, 45, 146

File Manager (continued)
icon browsing in, 190
Information dialog box, 154
main window, 146
opening existing text document from, 317
printing using, 298
removable media, 192
running applications from, 231
saving current preferences as default, 189
starting, 146
starting Icon Editor from, 407

File Manager views
aligning icons in, 189
arranging icons in, 185
changing, 184
changing sort order of, 187, 188
customizing, 184, 185
folder, 187
saving, 189
tree, 185, 186

file names
and action icons, 228
in Application Manager, 228

file path, 148
file system

concepts, 147
hierarchical, 147
moving through, 159

files
ACL-enabled, 167
changing ownership, 166
copying, 157
copying to diskette, 195
creating, 156
creating on diskette, 196
default permissions, 172
deleting from diskette, 196
dragging, 151
dropping, 151
dropping in Text Editor document, 335
with language-specific characters, 590
finding by contents, 182
finding by name, 179
getting help on, 154
hidden, 189
hiding, 190
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files (continued)
including in document through drag and
drop, 335
including in mail messages, 275
including in Text Editor document, 327
locating, 178
moving, 157
moving to diskette, 195
opening, 156
ownership, 163
putting on workspace backdrop, 177
removing from workspace, 178
renaming, 153
restoring from Trash Can, 162
security, 163
selecting multiple, 150
selecting single, 150
sorting, 189
types for printing, 296, 297
viewing on CD-ROM, 194
viewing on diskette, 194

files, in CDE, 43
Files subpanel, 43
filing mail messages

manually, 282
filter

applying to Process Manager display, 497
find

a process, 498
Find

menu item in File Manager, 178
Find File

control on Files subpanel, 178
Find Process

Front Panel control, 497
finding

a file by properties, 182
appointment using dtcm_lookup, 378
appointments, 353
files and folders, 178
mail messages, 261
objects, 178
objects using wildcards, 181
print jobs, 303

finding files, 43
Flash Calendar reminder, 352

flashing
colors on screen, 235

Flip tool, in Image Viewer, 424
flipping an image, 426
flipping part of an icon, 415
floppy disk activity, 563
folder view in File Manager, 187
folders

ACL-enabled, 167
changing, 159
changing ownership, 166
changing to, 159
copying, 157
copying to diskette, 195
creating, 156
creating on diskette, 196
default permissions, 172
definition of, 147
deleting, 163
deleting from diskette, 196
dragging, 151
dropping, 151
finding by name, 179
getting help on, 154
hidden, 189
hiding, 190
moving, 157
moving to diskette, 195
opening, 156
ownership, 163
putting on workspace backdrop, 177
removing from workspace, 178
renaming, 153
restoring from Trash Can, 162
security, 163
selecting multiple, 150
selecting single, 150
sorting, 189
viewing on CD-ROM, 194
viewing on diskette, 194

Font dialog box, 242, 243
font group

adding, 242
deleting, 243
selecting, 242

font set specification, 592
font specification, 592

Index 655



fonts
internationalizing, 591, 593
selecting font group, 242
selecting new size for, 242, 243
specifying from the command line, 593
specifying within a resource file, 593
viewing attributes, 243

format of image, displaying, 423
formatting

document in Text Editor, 337
mail message text, 279

forwarding messages, 259
frame buffer activity, 549
frame controls, 48
frequency of appointments, 352
Front Panel, 43, 105

Address Manager control, 483
Application Manager control, 222
Calendar control, 343
changing the printer in, 306
contents, 115
Exit control, 69, 76
File Manager control, 146
Find Card control, 483
help, 113
Help control, 131
Icon Editor control, 407
Lock control, 70
lock settings, 247
minimizing, 114
moving, 113
On Item help, 113
pop-up menus, 109
printing through, 297, 298
removing customizations made through the

GUI, 141
restoring default, 141
running applications from, 46
Text Editor control, 312

G
globe

control on main panel, 116
grabbing

region of display, 416, 417

grabbing color from workspace, 240
granting access to your calendar, 368
Graphical Workspace Manager, 212
gray scale, displaying image in, 422
grid

Calendar Week view, 348
Compare Calendars, 362
in Icon Editor, 417

Group Appointment Editor, starting, 361
group appointments

inserting, 362
mailing reminders, 362
scheduling, 362

guidelines for using Power Management, 560

H
handicapped users, see also AccessX, 617
handicapped users

avoiding unintentional input, 627, 628
controlling key repeat behavior, 626
getting a beep for locked keys, 626
ignoring inadvertent key presses, 627, 628
pressing two keys at once, 622
using keys to mimic the mouse, 624

handicapped users, interface for, 617
hardware support for Power

Management, 549
hardware’s power-saving capability, 549
height of image, displaying, 423
help

browsing, 95
context-sensitive, 82
displaying, 72
displaying for file, 154
displaying for folder, 154
displaying topics, 87
Front Panel, 113
on objects, 154
hyperlinks, 588
index, 92
keyboard navigation, 588
moving between topics, 89
On Item help, 83
pop-up menu, 90
printing help topics, 101
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help (continued)
using Help key, 82
window colors, 103
windows, 85

Help button, 553
help commands

Backtrack, 89
History, 89
Home Topic, 89
Index, 94
New Window, 97
Print, 101
Top Level, 96

Help key, 72
Help Manager

control on the Main Panel, 117
Front Panel control, 83
opening, 95

Help Manager control, 130
Help menu, 73
help windows

color in, 103
duplicating, 97
topic display area, 86
topic tree, 86
types of, 85

hidden files, 189
hiding

files, 190
folders, 190
waiting print jobs, 303
Icon Editor grid, 417
objects, 190
Snapshot dialog box during snap, 439

hierarchical file system, 147
highlight, keyboard, 580
$HOME

definition of, 178
home folder, navigating to, 160
home session

definition of, 78, 251
returning to, 251
setting, 78, 251
starting automatically at login, 78

hotspot in an icon, 416
hyperlink, used in help, 87

I
icon browsing, 191
Icon Editor

control, 407
drawing tools, 409, 410
hiding grid in, 417
opening icon for editing, 407
saving icon, 412
saving icon with new name, 412
starting, 407
starting a new icon, 408
starting from File Manager, 407
starting from Terminal, 407

icons
aligning in File Manager view, 189
arranging in File Manager view, 185
behavior of in Front Panel, 139
browsing in File Manager, 190
changing display area size in File

Manager, 191
changing for printer, 309
changing magnification of, 417
clearing loaded, 408
color usage for, 412, 413
copying a region of, 414
cutting a region of, 414
displaying in icon box, 250
displaying on workspace, 250
drawing image, 408
flipping part of, 415
hotspot, 416
moving a region of, 414
naming, 411
opening existing, 407
output format, 412
resizing, 415
resizing a region of, 415
rotating part of, 415
saving, 412
saving with new name, 412
selecting an area of, 413
selecting multiple, 150
selecting single, 150
size conventions for, 411

idle time
device, 556

ignore multiple key presses, 628
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image
changing orientation in the View

window, 422
displaying color usage of, 423
displaying format of, 423
displaying height of, 423
displaying in color, 422
displaying in gray scale, 422
displaying size of, 423
displaying width of, 423
flipping, 426
moving within View window, 422
opening in Image Viewer, 421
printing, 435
rotating, 426
saving, 428
saving a PostScript file page as, 432
saving region of to new file, 425
saving to a new file, 428
scaling, 427

Image Viewer
opening image in, 421
palette tools, 424
starting from Application Manager, 420
starting from command line, 420
starting from Workspace Programs

menu, 420
IMAP

default mailbox folder in IMAP server, 284
filing server, 284
mailbox, 254

included text, marker for, 278
including multiple messages in a mail

message, 274
initial calendar displayed, changing, 367
input method for locales, 594, 595
inserting

appointment, 351
appointment using dtcm_insert, 379
appointment using standalone Appointment

Editor, 377
group appointment, 362
To Do item, 356

Install Icon
behavior of icons installed with, 139
control, 106

Install Icon control, 139

internationalization and fonts, 591
Internet Messaging Access Protocol (IMAP)

Inbox, logging in to, 255
ISDN activity, 563

J
justification, setting in Text Editor, 338

K
key, power, 564, 565, 568
key processing daemon, 572
keyboard, 564, 574

basic skills, 68
choosing menu items with, 67
Compact 1, 564
cursor movement keys in Text Editor, 320
customizing behavior, 244
displaying menus with, 585
focus, 580
highlight, 580
navigation, 68, 579
navigation and Window Behavior

setting, 68
options in Terminal, 399, 400
shortcuts, 68, 579
tab groups, 580
type 5, 564
type 6, 564

keyboard access for handicapped users, 617
Keyboard dialog box, 244
keyboard equivalents of mouse buttons, 624
keyboard shortcuts, 565
keyboard used to Suspend or Resume, 548
keymaps, changing, 595
keys

controlling repeat behavior, 626
ignore multiple presses, 628
latching and locking, 623
modifier, 622
rate of repeat, 627

keystrokes for AccessX features, 629
keywords, for mail search scripts, 261, 264
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kill
a process, 501

L
labels

changing for printer, 310
in Application Manager, 228

LANG environment variable, 590
language, setting for desktop session, 76
language-specific

characters in file, 590
data, 590
login, 590
sessions, 589
terminal emulator, 591
Text Editor, 591

latching keys (AccessX), 623
Less button, 553
link, creating symbolic, 158
list

of appointments, 354
of To Do items, 357

list calendars, 374
lists

scrollable, 57
selecting items in, 59

local time, setting in Calendar, 373
Lock control, 70, 116
locked screen, 577
locking keys (AccessX), 623
locking the display, 70
log file

in Process Manager, 500
logging in, 76

to language-specific session, 590
logging in to

IMAP Inbox, 255
Mailer, 254

logging out, 69, 76
login, language-specific, 590
login screen, 75
logout confirmation, 252
logout, determining session resumption at, 251
looking up appointments, 378

M
magnification of icons, 417
mail aliases, 268
mail aliases on suspended machines, 561
Mail Calendar reminder, 352
mail messages, See messages
mail notification, customizing, 291
mail on suspended machines, 560
mail search scripts

creating, 265
keywords for, 261, 264

mail signatures
adding to specific messages, 276
automatically adding to all messages, 276
creating, 275

mailboxes
adding to menus, 284
changing default directory for, 284
closing, 282
creating, 281
deleting, 283
filing messages in, 282
filing using drag and drop, 283
opening, 282
renaming, 281
views of, 266, 268

Mailer
control on Main Panel, 116
logging in to, 254
main window, 256
starting, 253

Mailer Inbox
IMAP (remote), 254
local, 254

mailing
Calendar appointment, 363, 368
reminders of group appointment, 362

Main Panel, 106
changing controls in, 139
contents, 115
moving subpanel control to, 112
replacing a control, 140

man pages, displaying, 99
managing files, 43, 149
margins, document, 338
marking To Do item completed

using To Do Editor, 358
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marking To Do item completed (continued)
using To Do list, 358

mask, 175
modifying, 175

maximize button, 49
menu bar

removing from Terminal window, 391
restoring to Terminal window, 392

menus
Calendar, 345
mnemonics, 62, 579
shortcut keys, 63, 579
using, 62
Window, 63
Workspace, 64

message filing
manual, 282

messages
adding attachments to, 287
adding Calendar appointments to, 289
adding signature to specific, 276
automatically generated, 276
Calendar appointment format for, 363
changing character set of incoming, 257
changing character set of outgoing, 271
changing text, 280
checking spelling, 280
deleting, 260
displaying numbers of, 290
editing existing, 259
filing, 282
finding text in, 280
forwarding, 259
frequency of checking for new, 290
including signature in all, 276
including text files, 275
printing, 285
reading, 257
replying to, 258
restoring deleted, 260
saving as template, 272
searching for, 261
setting marker for included text in, 278
sorting, 258
viewing, 257

MIME format, email in, 277
minimize button, 49

minimizing
Front Panel, 114
windows, 50

mnemonics, menu, 62, 579
modifier keys, 622
Modify dialog box, 240
modinfo command, 573
modunload command, 573
monitors, double, 557
Month view, 349
More button, 553
More Criteria

option in File Finder, 182
mouse

choosing a menu item, 66
click, 39
customizing behavior, 245
double-click, 40
dragging, 40
duplicating, 41
using, 39

mouse access for handicapped users, 617
mouse button 1, 39
mouse button 2, 54
mouse button 3, 63
Mouse dialog box, 245
MouseKeys, 624

change maximum speed of pointer, 625
changing ramp-up speed, 625
keyboard equivalents, 624

moving
controls to Main Panel, 139
files, 157
folders, 157
Front Panel, 113
icons, 51
keyboard focus, 580
a region of an icon, 414
objects, 157
subpanels, 113
windows, 51, 583

My Time, setting Calendar time zone, 373

N
name, finding file by, 179
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names
for icon files, 411

navigating
moving text insertion cursor, 320
to home folder, 160
to specific line in document, 321
with keyboard, 579

networked applications, 561
Next key, 59
notification of new mail, customizing, 291

O
objects

aligning in File Manager view, 189
copying, 157
creating, 156
dragging, 151
dropping, 151
executing action of, 160
finding by name, 179
folder, 147
getting help on, 154
hiding, 190
manipulating, 156
moving, 157
opening, 155, 156
pop-up menu for, 177
putting on workspace backdrop, 177
removing from workspace, 178
renaming, 153
restoring from Trash Can, 162
selecting multiple, 150
selecting single, 150
sort order in File Manager, 187, 188
sorting, 189

Occupy Workspace dialog box, 55
OK button, 57, 553
On Item help, 83, 154
On Item Help control, 131
online help, 81

displaying, 72
keyboard navigation, 588

opening
application windows, 49, 581
Audio file, 454

opening (continued)
existing document, 316, 318
File Finder application, 178
files, 156
folders, 156
icon, 407
mailboxes, 282
objects, 155, 156
Style Manager, 234
subpanels, 107
Terminal window in current directory, 160

opening applications, 65
overstrike mode, in Text Editor, 325
overview of Dtpower GUI, 553
overview of power management, 549

P
page

printing, 435
Page Down key, 59
Page Up key, 59
palette

adding, 240
creating, 240
deleting, 241
modifying, 239
restoring, 241
selecting, 238

palette (Image Viewer)
description of tools in, 424
displaying automatically, 424

Pan tool, in Image Viewer, 424
parent folder, navigating to, 160
pasting

text, 54
text in Terminal window, 389

path, 148
pending To Do item, 358
Performance Meter

control on the Main Panel, 117
permissions

Access Control Lists, 167
basic, 163
basic user types, 164
changing for your calendar, 368, 371
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permissions (continued)
default, 172
effective, 165
mask, 175
modifying basic, 165
setting for your calendar, 369

Permissions dialog box, 165, 173, 174
personal application group

adding applications to, 227
creating, 227

pointer
change speed of, 625

pointer speed
changing, 625
changing ramp up, 625

pointing to make window active, 249
Popup Calendar reminder, 352
pop-up menus

displaying, 63, 66, 152
for objects, 176, 177
Front Panel, 109
for subpanels, 112

PostScript file
changing the size of display of, 431
displaying, 429
displaying in black and white, 429
displaying in color, 429
paging through, 430
printing, 434, 435
reversing page order, 431
saving a page as bitmap image, 432
viewing a specific page, 430

power cycling, 562
power key, 564, 568, 572
power key, disabling, 565
power key with Shift, 565
Power Management

disk drives, 559
monitors, 557
Suspend-Resume feature, 560
system, 556

power on, 568
power saving schemes, 551

customized, 555
default scheme, 554
grayed out, 555
selecting, 555

power-off failed message, 574
preferences, saving File Manager current, 189
Prev key, 59
print commands, issuing, 300
Print dialog box, 299, 300
print jobs

canceling, 304
definition of, 303
determining type in Print Manager

display, 307
display of in Print Manager, 307
displaying, 303
displaying properties of, 305
finding, 303
hiding, 303
properties, 304

Print Manager
determining type of print jobs

displayed, 307
display of print jobs in, 307
displaying message line in, 308
printer display in, 307
printing using, 298
problem flag, 308
starting, 301, 302
window, 300

print options, setting, 299
printer

changing the default, 296
changing the Front Panel, 306
definition of default, 295
determining the default, 295

Printer control, 117
Printer Jobs, 302

starting, 302
printers

changing icon of, 309
changing label of, 310
display of in Print Manager, 307
displaying properties of, 309

printing, 434, 435
a page from a document, 435
allowable file types, 296, 297
an image file, 435
appointment list, 359
Calendar views, 359
changing Calendar printer settings, 372
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printing (continued)
document, 338
help topics, 101
image, 434, 435
issuing print commands, 300
mail attachments, 287
mail messages, 285
PostScript file, 434, 435
using File Manager, 298
through the Front Panel, 297, 298
using Print Manager, 298
setting options for, 299
To Do list, 359

privacy, changing Calendar defaults, 366
problems

device suspend fails, 573
disk space filled, 576
power key, 572
process suspend fails, 575
suspend failures, 572

process
errant, 495

Process
finding, 498

process
search for a, 498
sending a signal to, 501
to kill a, 501

Process Manager
continuous sampling mode, 499
copying process entries, 500
debugging a process, 506
equivalent UNIX commands for

actions, 495
killing a process, 501
log file, 500
main window, 497
performing actions, 501
sampling interval, 499
saving process entries, 500
sending a signal to a process, 501
setting up a log file, 500
showing the ancestry for a process, 503
Showing the stack for a process, 505
to open, 497
tracing child processes, 504
tracing system calls for a process, 505

process suspend failure, 575
processes

definition of, 495
displaying only certain processes, 497

Programs submenu
(now Applications), 65

properties
of print jobs, 304, 305

Properties dialog box, 155, 166, 167, 168, 169
opening from command-line, 166

pull-down list for monitor idle time, 558
pull-down menus, displaying, 62, 66
push buttons, 57

Q
question mark pointer, 73
Quick Edit tab, 557
Quit button, 571

R
radio buttons, 58
reactivating the monitor, 559
reading mail messages, 257
real-time process, 575
reconfiguring systems, 563
region of screen, taking a snapshot of, 438
registering applications, 231
relative path, 149
reloading applications, 227
reminders

appointment, 352
changing defaults, 366
of group appointment, mailing, 362

remote login on suspended machines, 561
removable media, 192

drag-and-drop behavior, 192
viewing files and folders, 194

removing
files or folders from workspace, 178
Front Panel customizations made through

the pop-up menus, 141
Front Panel customizations made with the

Install Icon control, 141
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removing (continued)
mailboxes, 283
menu bar from Terminal window, 391
scroll bar from Terminal window, 393
workspaces, 142

renaming
controls from subpanels, 112
files, 153
folders, 153
mailboxes, 281
objects, 153
workspaces, 56, 111, 586

renaming workspaces, 141
RepeatKeys, 626

rate of repeating, 627
setting initial delay, 627

replacing controls in Main Panel, 140
replying to mail messages, 258
resizing

icons, 415
a region of an icon, 415
windows, 52, 584

restoring
deleted mail messages, 260
items in Trash Can, 162
menu bar to Terminal window, 392
palette, 241
scroll bar to Terminal window, 393
Text Editor file, 340
window icon, 51
windows from an icon, 51, 583

resuming a suspended system, 568
Return key, 68
reversing page order display, 431
Rotate tool, in Image Viewer, 424
rotating an image, 426
rotating part of an icon, 415

S
sample interval

of Process Manager display, 499
saving

appending to a text file, 260
Calendar data in a file, 360
document to new file, 315

saving (continued)
document to original file, 316
icons, 412
icons with new name, 412
images, 428
incoming or outgoing mail message as

text, 259
mail attachments, 288
mail message as template, 272

saving current work, 562
Scale tool, in Image Viewer, 424
scaling an image, 427
scheduling

appointments, 351
appointments using standalone Appointment

Editor, 377
group appointments, 362
To Do items, 356

screen blanker, settings for, 247
screen blanking, 552, 557
screen control options in Terminal, 401, 402
Screen dialog box, 247, 249
screen lock, 559, 577

duration before starting, 249
enabling, 249

screen saver, customizing, 247, 248
screen, taking snapshot of, 438
scroll bar

removing from Terminal window, 393
restoring to Terminal window, 393

scrolling
setting in Terminal window, 396
window contents, 59

scrolling window contents, 584
sdtcm_admin

creating a calendar, 374
search and replace, in Text Editor, 336
search scripts, See mail search scripts
searching for mail messages, 261, 266
secondary selection, in Text Editor, 322
selecting

an area of an icon, 413
backdrop, 244
check boxes, 58
files, 150
folders, 150
font size, 242, 243
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selecting (continued)
icons, 150
list items, 59, 584
multiple files, 150
multiple folders, 150
multiple icons, 150
multiple objects, 150
objects, 150
palette, 238
radio buttons, 58
a window, 49
text, 53, 322

selecting a power saving scheme, 555
Selector tool, in Image Viewer, 424
sending mail messages in MIME or Sun Mail

Tool format, 277
session

changing startup, 251
current, 78, 251
determining for each login, 79
home, 78, 251
language-specific, 589

setting idle time for AutoShutdown, 569
settings for AccessX, 621
Shift-power key (suspend), 565
shortcut keys, 63, 579

in Text Editor, 324
shortcuts, keyboard, 565
Showing a stack

for a process, 505
showing ancestry

for a process in Process Manager, 503
shutdown, automatic, 569
shut-off (AccessX), 620
signal

sending to a process, 501
signals to send, 501
signatures for mail messages

adding to specific messages, 276
automatically adding to all messages, 276
creating, 275

size of image, displaying, 423
sizes of icons, 411
sliders, 57, 59
SlowKeys, 627

setting notification parameters, 628
setting the acceptance delay, 628

snapshot
delaying, 438

Snapshot
hiding dialog box during snap, 439

snapshot
of region, 438
of screen, 438
of window, 437

Snapshot
starting, 437

Solstice AutoClient issues, 561
sort order

changing File Manager, 187, 188
of objects, 187, 188
of Process Manager display, 498

sorting
files and folders, 189
mail messages, 258

SPARC architectures, 550
special characters

in Terminal, 402, 403
in Text Editor, 320

speckeysd daemon, 577
speckeysd key processing daemon, 572
speckeysd.map file, 577
speed of pointer

changing, 625
changing ramp up, 625

spelling, correcting in Text Editor, 329
stack

for a process, 505
standalone Appointment Editor, 377
standby switch, 566
starting

Application Manager, 221
applications in Terminal window, 388

Starting
Audio, 451

starting
Audio, 450
Audio from command line, 450
Audio from Front Panel, 450
Audio from Voice Note control, 452
Audio from Workspace Programs

menu, 451
Calendar, 343
Calendar from command line, 344
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starting (continued)
Command Line Login Mode, 77
File Manager, 146
home session automatically at login, 78
Icon Editor, 407
Image Viewer from Application

Manager, 420
Image Viewer from command line, 420
Image Viewer from Workspace Programs

menu, 420
Mailer, 253
new icon, 408
Print Manager, 301, 302
Printer Jobs, 302
Snapshot, 437
Style Manager, 234
Terminal, 384, 388
terminal emulator with specific

language, 591
Text Editor with specific language, 591

starting AccessX, 618
starting Dtpower from command line, 553
starting Dtpower through CDE

workspace, 552
startup

changing session, 251
Startup dialog box, 251, 252
statefile, 576
status line

in Text Editor window, 314
StickyKeys, 622

disable by pressing two modifier keys, 624
sound when modifier key is pressed, 623

Style Manager, 558
opening, 234
starting, 234
Window Behavior setting, 68

subdirectories
changing to, 159

subfolders
changing to, 159

submenu
Applications, 65

subpanel
adding, 140
deleting, 140

subpanels, 43, 106

subpanel (continued)
adding, 140
deleting, 140
displaying, 107
moving, 113
opening and closing, 107

Sun Mail Tool format, email in, 277
Sun Microsystems Computer Corporation

(SMCC), 550
Sun Ultra 10, 566
Sun Ultra 5, 566
sun4m systems, 560
sun4u systems, 560
sun4u UltraSPARC III (Energy Star, v3), 551
superuser, 552
suspend confirmation message, 565
suspend failed message, 572
suspend failures, 572
suspending and resuming system

manually, 562
suspending your system

immediately, 565
Sun Ultra 10, 566
Sun Ultra 5, 566
using CDE, 567
using sys-suspend, 567
using the standby switch, 566
ways to, 563

Suspend-Resume, 548
Suspend-Resume feature

issues to consider, 560
symbolic link, creating, 158
symbols

special characters, 70
synchronous TTY activity, 563
sys-suspend command, 563, 567, 577
system architecture distinctions, 550

sun4m, 551
sun4u (pre Energy Star 3.0), 551
sun4u (pre Energy Star, v3), 551

system calls
tracing in Process Manager, 505

system idle time, 556
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T
tab groups, 580
Tab key, 580
tape activity, 563
templates

creating for mail messages, 272
using for mail messages, 272

Terminal
bell options, 396, 398
color control in, 396
control characters in, 402, 403
cursor options, 394, 395
entering commands in window, 388
Global Options dialog box, 394
keyboard options, 399, 400
removing menu bar from window, 391
removing scroll bar from window, 393
resizing window, 389
restoring menu bar to window, 392
restoring scroll bar to window, 393
running on another system, 389, 391
screen control options, 401, 402
scroll behavior in, 396
setting language through, 590
starting, 384, 388
starting applications in window, 388
starting Icon Editor from, 407
stopping, 388
Terminal Options dialog box, 398

terminal emulator, 383
changing the default, 403
default, 383
definition of, 383
language-specific, 591
running applications from, 48

Terminal window
opening in current directory from File

Manager, 160
text

alignment, 338
automatic wrapping, 320
copying, 327
copying and pasting among windows, 53
copying in Terminal window, 389
cutting and pasting, 327
deleting, 326
deselecting, 54

text (continued)
dragging, 335
dropping, 335
editing, 311
editing in a field, 61
entering, 319
entering in a field, 60
finding in Text Editor, 336
justifying, 338
pasting, 54
pasting in Terminal window, 389
selecting, 53, 61, 322
selecting characters, 61

Text Editor
closing, 312
cursor keys, 320
drag and drop in, 335
entering text, 319
formatting document in, 337, 338
Front Panel control, 312
menu shortcut keys, 324
opening document, 314
printing document, 338
saving document, 314
saving document to new file, 315
saving document to original file, 316
special characters and, 320
Spelling Checker, 328, 334
Spelling Checker, customizing

dictionaries, 331, 334
starting, 311
starting with specific language, 591
status line, 314
UNIX (Emacs) key bindings, 325
used in other applications, 340
using Undo in, 326
window, 313
word wrap, 320
Wrap To Fit option, 320

text fields, 57
Text Note

control on Main Panel, 115
thermal stress issues, 562
three-month mini-calendar

Calendar Day view, 347
time zone, in Calendar, 373
title bar, 49

Index 667



To Do items
changing, 356
deleting, 356
inserting, 356
marking completed, 356, 358
pending, 358
scheduling, 356
setting due date, 356

To Do list
displaying, 357
printing, 359

ToggleKeys, 626
Tool bar, Calendar, 345
tool bar, Calendar, 345
Toolbar in Mailer, configuring, 291
tools

Calendar, 373
topic display area, 86
topic tree, 86
TopShadow, 413
tracing

system calls in Process Manager, 505
tracing child processes

in Process Manager, 504
Trash

control on the main panel, 118
Trash Can

emptying, 163
opening, 162
restoring objects from, 162
using, 162

tree view, in File Manager, 185, 186
troubleshooting, 572
TTY activity, 563

U
unblanking the screen, 559
Undo, in Text Editor, 326
UNIX key bindings, 325
unlocking the display, 70

V
version 3 Calendar

convert to version 4, 375
viewing, 354

mail attachments, 287
mail messages, 257

views
Calendar, 347
controlling File Manager, 184
of mailboxes, 266, 268

Voice Note, 452
Voice Note command, 452

W
Week grid, Calendar Week view, 348
Week view

Calendar, 348
changing time boundaries, 367
Week grid, 348

width of image, displaying, 423
wildcards

for finding files, 181
to search help index, 92

window controls in Dtpower, 553
Window menu

displaying, 63
items, 63
keyboard usage, 585

Window menu button, 49, 63
windows

bringing forward, 53
closing, 50
copying and pasting text, 53
determining how to display active, 250
dragging, 52
focus policy for, 249
frame controls, 48
icon display policy for, 250
icons, moving, 51
icons, restoring, 51
moving, 51
opening, 49
placing in other workspaces, 55, 586
policy for activating, 249
removing, 50
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windows (continued)
resize border, 49
resizing, 52, 584
restoring from an icon, 51, 583
scroll bar, 59
scrolling, 59, 584
selecting with keyboard, 583
taking a snapshot of, 437
title bar, 49
turning into an icon, 50, 583

word wrap, 320
workspace

adding, 141
deleting, 142
renaming, 141

workspace backdrop
putting file or folder on, 177
selecting, 244

workspace, definition of, 43
Workspace menu, 64

definition, 43
running applications from, 46

Workspace Programs submenu, accessing, 43
workspace switch, 43, 106, 107
Workspace Switch

control on Main Panel, 116
workspace switch

customizing, 142
customizing controls in, 142
help for, 111
switch area of, 111

workspace utilities and Suspend, 567
workspaces

adding, 141
bringing windows forward in, 53
changing colors of, 238
customizing, 141
deleting, 142
displaying, 55
keyboard navigation, 586
placing windows in, 55
removing files or folders from, 178
removing objects from, 178
renaming, 56, 111, 586

world access
to grant access to anyone, 369, 370

Wrap to Fit, turning on and off, 320

X
Xhosted applications, 561
XLFD, 592
XmNinputMethod resource, 594
XmNpreeditType resource, 594
XMODIFIERS environment variable, 594
xmodmap command, 595

Y
Year view, 350
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