[SunRay-Users] Strange accumulation of "DI" sessions

Craig Bender Craig.Bender at Oracle.com
Sat Sep 18 02:41:18 EEST 2010


Can you tell us a little bit about the environment.  Smart cards, no 
smart cards?  Do non-card sessions Sun Rays are sit at the windows login 
screen and timeout after 120 seconds of no-login?  Or do they sit at 
something else, then users insert smart card to get windows.

Depending on your scenario, those sessions in a DI state could be 
sessions that got loadbalanced to the other server.  Do they go away in 
15 minutes?

On 9/17/10 4:04 PM, Michael Jinks wrote:
> We have a two-server FOG, currently serving 151 sessions, all uttsc in
> kiosk mode.
>
> Sometime last week(?), we started to see sessions slipping into "DI"
> state and sticking, and I haven't been able to figure out why.
>
> We thought we were running out of licenses for our TS servers, and we do
> have more traffic there than just our Sun Ray stuff, but after adding a
> hundred CALs earlier today, the problem didn't appear to diminish.
>
> If I kill the sessions marked "DI", they gradually come back, but others
> go into disconnected state.  It seems like we top out between 60 and 64
> sessions per server, for a total of just over 120, with the remaining
> sessions going DI.  As far as I can tell, there's no pattern to which
> DTU's get sick and which ones work.
>
> I don't think it's a user account exhaustion issue; we have 200 utku*
> users configured on each FOG member.
>
> On the Windows side, our servers are busy, but not *that* busy.  The
> Windows crew has so far been unable to find any cause for the trouble in
> their area.
>
> I don't find anything in /var/opt/SUNWut/messages that looks related.
> The only errors look like this:
>
>    Sep 17 18:04:02 blackstone Sun Ray Connector proxy:[27847]: [ID 855542 user.error] Child closed socket prematurely, session shutdow
>
> ...and we get quite a few of those, but they don't seem to coincide with
> sessions going into DI state.  Maybe they're related, maybe not, I can't
> tell.
>
> If I fire up a Sun Ray soft client, I can't duplicate the problem.  I've
> tried connecting to a test Sun Ray server for a JDS session and running
> uttsc from a terminal there; I've also tried connecting the soft client
> directly to the FOG where we're having trouble.  In both cases, after a
> few dozen tries, I've gotten a successful uttsc connection every time.
>
> Any clues on where to look next?
>
> Thanks,
> --Michael
> _______________________________________________
> SunRay-Users mailing list
> SunRay-Users at filibeto.org
> http://www.filibeto.org/mailman/listinfo/sunray-users


More information about the SunRay-Users mailing list