[SunRay-Users] No sound on SRSS 4.2/Fedora 12

Hana Skoumalova Hana.Skoumalova at ff.cuni.cz
Fri Mar 19 12:47:16 EET 2010


Alexander Koponen wrote:
> On Thu, 18 Mar 2010, Aaron Wilson wrote:
> 
>> Fresh install of RHEL5 and SRSS
>>
>> I attempt the compile and get
>>
>> [root at slosunray01 debugger]# gcc -shared -O2 -Wall -Werror -licuuc
>> -lssl flashsupport-for-linux-sunray.c -o libflashsupport.so
>> /usr/bin/ld: /tmp/cckq5egN.o: relocation R_X86_64_32 against `a local
>> symbol' can not be used when making a shared object; recompile with
>> -fPIC
>> /tmp/cckq5egN.o: could not read symbols: Bad value
>> collect2: ld returned 1 exit status
>>
>> So then I tried it with -fPIC
>>
>> gcc -shared -O2 -Wall -Werror -licuuc -lssl -fPIC
>> flashsupport-for-linux-sunray.c -o libflashsupport.so
>>
>> That didn't throw any errors, but I still get no sound in firefox :(
> 
> * Is libflashsupport.so in /usr/lib/ ?
> * Have you done : export AUDIODEV=`utaudio`
> * Have you closed firefox and all other applications that might steal the
>    sound, like mp3-players and rdesktop, etc
> * And most important: do you get sound at all?
>    you can try this with the "sound of god test" which is:
>    cat /boot/vmlinuz > $AUDIODEV

I have a similar problem. First, I compiled libflashsupport.so with the
option -m32, as I run a 64-bit OS. When I copy it to /usr/lib, SeaMonkey
or Firefox (both are 32-bit versions) crashes. After removing that
library from /usr/lib, the web browsers work, but flash has no sound.

AUDIODEV is set to /tmp/SUNWut/dev/utaudio/utdsp-0 and the sound works.

Hana



More information about the SunRay-Users mailing list