[SunRay-Users] No sound on SRSS 4.2/Fedora 12

Aaron Wilson aaron at ernieball.com
Thu Mar 18 23:18:15 EET 2010


Fresh install of RHEL5 and SRSS

I attempt the compile and get

[root at slosunray01 debugger]# gcc -shared -O2 -Wall -Werror -licuuc
-lssl flashsupport-for-linux-sunray.c -o libflashsupport.so
/usr/bin/ld: /tmp/cckq5egN.o: relocation R_X86_64_32 against `a local
symbol' can not be used when making a shared object; recompile with
-fPIC
/tmp/cckq5egN.o: could not read symbols: Bad value
collect2: ld returned 1 exit status

So then I tried it with -fPIC

gcc -shared -O2 -Wall -Werror -licuuc -lssl -fPIC
flashsupport-for-linux-sunray.c -o libflashsupport.so

That didn't throw any errors, but I still get no sound in firefox :(





On Mon, Mar 8, 2010 at 5:31 AM, Alexander Koponen
<koponen at mittag-leffler.se> wrote:
> On Mon, 8 Mar 2010, SIMOND Gilles wrote:
>
>> Hello
>>
>> I've also installed SRSS 4.2 on fedora 12, everything works, sound also
>> the only remainning problem (if you know how to solve it, you're welcome!)
>> flash videos are displayed with the wrong colors in web browsers
>
> I use SRSS on RHEL 5 and my experiences are:
>
> Some versions of flash gives wrong colors in web browsers.
>
> Sound in flash can be solved with the patches from:
>  http://tobi.oetiker.ch/patches/
>
> For some reason Gnome with SRSS defaults to volume = 0 and turning up the
> volume gets sound.
>
> The applications compete for the sound support, so if you run an audioapp
> you might need to close it and restart firefox for firefox to get the sound.
>
> Everytime you update the kernel you need to recompile the utaudio, utadem,
> utdisk modules...
>
> Not everything works. It often boils down to whether the app respect the
> AUDIODEV setting.
>
> Also, SRSS sound emulates OSS not alsa. So set your app to OSS-sound or some
> kind of OSS-emulation.
>
>
>> I had to configure pulse audio to get it work with the utaudio device
>> so I add the small script listed below
>> the script is in /etc/opt/SUNWut/xinitrc.d/0101.SUNWutaudio with a
>> symbolic link to it in /etc/X11/xinit/xinitrc.d/
>>
>>
>> Gilles Simond
>>
>> ======8<===============8<===============8<===============8<=========
>> #!/bin/bash
>>
>> if [ ! "x${UTAUDIODEV}" == "x" ] ; then
>>
>> if [ ! -d ${HOME}/.pulse ] ; then
>>  mkdir ${HOME}/.pulse
>> fi
>>
>> # create pulseaudio configuration for utaudio
>> PULSECONF=${HOME}/.pulse/default.pa
>> sed "s|UTAUDIODEV|$UTAUDIODEV|g" /opt/SUNWut/lib/utpulse.pa > ${PULSECONF}
>>
>> # create asoundrc for pulseaudio redirection
>> ASOUNDRC=${HOME}/.asoundrc
>> echo -n > ${ASOUNDRC}
>> echo "pcm.!default { " >> ${ASOUNDRC}
>> echo "  type pulse" >> ${ASOUNDRC}
>> echo "}" >> ${ASOUNDRC}
>> echo "ctl.!default { " >> ${ASOUNDRC}
>> echo "  type pulse" >> ${ASOUNDRC}
>> echo "}" >> ${ASOUNDRC}
>>
>> fi
>> ======8<===============8<===============8<===============8<=========
>>
>> On 08/03/2010 12:16, Hana Skoumalova wrote:
>>>
>>> Hello,
>>>
>>> I managed to install and configure SRSS 4.2 on Fedora 12, but I have
>>> problems with sound.
>>>
>>> On the system console, the sound works (so the problem is not in
>>> Fedora-not-supporting-multimedia).
>>>
>>> The env variables AUDIODEV and UTAUDIODEV are set to
>>> /tmp/SUNWut/dev/utaudio/utdsp-0, the devices in /tmp/SUNWut/dev/utaudio
>>> are created:
>>>
>>> total 8
>>> drwxr-xr-x 2 root root 4096 2010-03-08 11:53 ./
>>> drwxr-xr-x 3 root staff 4096 2010-03-08 11:07 ../
>>> crw------- 1 skoumal staff 14, 3 2010-03-08 11:53 utdsp-0
>>> prw------- 1 skoumal staff 0 2010-03-08 11:53 utdsp-0stat|
>>> crw------- 1 skoumal staff 14, 0 2010-03-08 11:53 utmix-0
>>>
>>> When I try to play something, the system pretends to play, but no sound
>>> can be heard.
>>>
>>> I even tried to replace the DTU, but the new one behaves exactly the
>>> same way.
>>>
>>> Can anyone help me to solve this problem?
>>>
>>> Best regards,
>>>
>>> Hana
>>> _______________________________________________
>>> SunRay-Users mailing list
>>> SunRay-Users at filibeto.org
>>> http://www.filibeto.org/mailman/listinfo/sunray-users
>>
>>
>>
>
>
>  -- Alexander
>
> ------------------------------------------------------------------------
> Alexander Koponen                                   System Administrator
> Institut Mittag-Leffler                           phone: +46 8 622 05 75
> Auravagen 17                                        fax: +46 8 622 05 89
> SE-182 60 DJURSHOLM                            koponen at mittag-leffler.se
> SWEDEN                                     http://www.mittag-leffler.se/
> _______________________________________________
> SunRay-Users mailing list
> SunRay-Users at filibeto.org
> http://www.filibeto.org/mailman/listinfo/sunray-users
>



-- 
Aaron Wilson
Ernie Ball, Inc.
I.T. Department
aaron at ernieball.com
(805) 544-7726
Skype: aaron.kane.wilson

NOTICE: This e-mail is for the sole use of the intended recipient(s).
Any unauthorized review, use, disclosure or distribution of this
e-mail or its contents is strictly prohibited. If you are not the
intended recipient, please contact the sender by reply mail and
destroy the original and all copies of the original message.


More information about the SunRay-Users mailing list