[SunRay-Users] EXTERNAL: Sun Desktop Access Client (SDAC / soft client) poor performance

Bob Doolittle Robert.Doolittle at Sun.COM
Mon Mar 1 21:37:55 EET 2010


What version of SDAC? You can find out in the initial startup screen.
What version of SRSS? What platform?

-Bob

Devin Nate wrote:
> Hi Bob;
>
> The machines are idle, but good call ... we're to the point now of doing fresh installs just for the purpose of testing SDAC. No swapping, memory is good, and all cores (some are dual core, some quad core) are idle.
>
> Ethernet stats are good... no dropped packets reported by the Ethernet cards or the utcapture.
>
> The PCs are lab PCs, fully in our control, and performing well, except for SDAC.
>
> Definitely no spyware/virus activity on these (as they're fresh built).
>
> We've tried different AV software and settings running, including none for testing.
>
> We've used different PCs also, to ensure it's not just one bad PC. Mostly IBM/Lenovo PCs, although I think we used one Dell.
>
> ...??? still no luck
>
> I'm really appreciating the ideas, please keep them coming?
>
> Thanks,
> Devin
>
>
>
> -----Original Message-----
> From: sunray-users-bounces at filibeto.org [mailto:sunray-users-bounces at filibeto.org] On Behalf Of Bob Doolittle
> Sent: Monday, March 01, 2010 12:22 PM
> To: SunRay-Users mailing list
> Subject: Re: [SunRay-Users] EXTERNAL: Sun Desktop Access Client (SDAC / soft client) poor performance
>
> I'd look closely at what is running on the PCs besides SDAC. If SDAC 
> can't get cycles that would show up as latency for servicing packets. 
> Scan for spyware/viruses, use the Task Manager, etc.
>
> -Bob
>
> Devin Nate wrote:
>   
>> As a follow up, there are no lost packets for either system. Simply a huge difference in latencies. The network (ICMP) is reporting 10-20 ms. The Sun DTU's are reporting 10-20 ms. There's no reason for SDAC to report 500+ ms.
>>
>> Maybe a bug in the SDAC causing really high latencies? Maybe a bug in utcapture as to what it's reporting.
>>
>> We're going through our network, including with Wireshark/pcap ... so far, we cannot see any differences between the packages generated by a DTU and that of SDAC.
>>
>> We're going to put a SDAC machine on the same LAN in the data center and see what happens... but.
>>
>> Any more thoughts??
>>
>> Thanks,
>> Devin
>>
>>
>>
>>
>> -----Original Message-----
>> From: sunray-users-bounces at filibeto.org [mailto:sunray-users-bounces at filibeto.org] On Behalf Of Devin Nate
>> Sent: Monday, March 01, 2010 11:10 AM
>> To: SunRay-Users mailing list
>> Subject: Re: [SunRay-Users] EXTERNAL: Sun Desktop Access Client (SDAC / soft client) poor performance
>>
>> Hi Scott;
>>
>> Thanks for the initial tip... so, yes, there's a huge amount of additional latency for the SDAC clients. I don't know why.
>>
>> Our Sun Ray DTUs are running a latency of between 10-20, and they perform great.
>>
>> Our SDAC clients are running a latency of 500.000 to 516.000, and they perform bad (understandable with latencies like that).
>>
>> Now I've literally just unplugged the cable from one of our DTUs and plugged it into one of our test PCs, and it still shows this large change in latency. All power mgmt has been disable on the PC, etc. Any thoughts as to what could cause latency to be so wildly different between these 2 systems?
>>
>> Thanks,
>> Devin
>>
>>
>>
>>
>> -----Original Message-----
>> From: sunray-users-bounces at filibeto.org [mailto:sunray-users-bounces at filibeto.org] On Behalf Of Nishimura, Scott L (IT Solutions)
>> Sent: Monday, March 01, 2010 10:24 AM
>> To: SunRay-Users mailing list
>> Subject: Re: [SunRay-Users] EXTERNAL: Sun Desktop Access Client (SDAC / soft client) poor performance
>>
>> Devin,
>>
>>    What does utcapture show for those slow SDAC clients?  Any
>> appreciable packet loss or latency?
>>
>>
>> Scott
>>
>> -----Original Message-----
>> From: sunray-users-bounces at filibeto.org
>> [mailto:sunray-users-bounces at filibeto.org] On Behalf Of Devin Nate
>> Sent: Monday, March 01, 2010 9:15 AM
>> To: sunray-users at filibeto.org
>> Subject: EXTERNAL:[SunRay-Users] Sun Desktop Access Client (SDAC / soft
>> client) poor performance
>>
>> Dear SunRay Users;
>>
>> We have begun testing the Sun Desktop Access Client (SDAC), and have
>> experienced poor performance. I am looking for a solution.
>>
>> When I say 'poor performance', we are seeing laggy screen redraws and
>> 'blocking' where certain blocks of the screen will be visibly not
>> updated. We run nearly exclusively in kiosk mode, using uttsc, and the
>> operations/things we're doing are very basic (we are not watching
>> movies, flash, etc). All we are doing is logging in, opening word/excel,
>> pushing the start button, etc., all which show lag and blocking. The
>> performance is such that while technically working, the end user
>> experience isn't solid enough that we can deploy the SDAC.
>>
>> By comparison, on the exact same network and using the same Sun Ray
>> Servers v5, we have a number of Sun Ray ultra thin clients (DTUs). The
>> Sun Rays work as desired, and if the SDAC was working the same I'd be
>> more than happy. I'm rather shocked that a full fledged PC cannot
>> achieve the same performance.
>>
>> Also by comparison, raw RDP from the PCs achieves the same excellent
>> performance as the Sun Ray thin clients.
>>
>>
>>
>> Environment:
>>
>> Servers:
>> Our srs servers are 2x Red Hat Enterprise Linux 64-bit servers running
>> the most current SRSS software. They live in VMware ESXi v4.0u1
>> Enterprise, and exist in a FOG configuration. The Sun Ray Servers are
>> connected via internet to our clients ... so the actual DTUs are not on
>> the same LAN as the Sun Ray Servers. There is an approx 15-25ms rtt for
>> ping/icmp packets. Again, I don't suspect a server problem, in so much
>> as the Sun Ray DTUs work excellent.
>>
>> DTUs:
>> Our DTUs are Sun Ray ultra thin clients, model 2's and model 270's. They
>> work great. They are connected to the exact same network/ports/etc as
>> the PCs below. These DTU's have a MTU of 1200.
>>
>> PCs using SDAC:
>> Our PCs are a combo of Windows 7 professional 64 bit and WinXP
>> professional 32 bit. All running SDAC 1.0.51. These are the machines
>> that see the performance/blocking problems. We've adjusted MTU in the
>> software ranging from 500 (the minimum) to 1500 (the maximum), including
>> at 1200. We've also turned on/off compression and lossless compression.
>> None of these options have helped.
>>
>>
>> Thanks, and look forward to any information people can share that might
>> help.
>> Devin Nate
>>
>>
>>
>>
>>
>> _______________________________________________
>> SunRay-Users mailing list
>> SunRay-Users at filibeto.org
>> http://www.filibeto.org/mailman/listinfo/sunray-users
>> _______________________________________________
>> SunRay-Users mailing list
>> SunRay-Users at filibeto.org
>> http://www.filibeto.org/mailman/listinfo/sunray-users
>> _______________________________________________
>> SunRay-Users mailing list
>> SunRay-Users at filibeto.org
>> http://www.filibeto.org/mailman/listinfo/sunray-users
>> _______________________________________________
>> SunRay-Users mailing list
>> SunRay-Users at filibeto.org
>> http://www.filibeto.org/mailman/listinfo/sunray-users
>>   
>>     
>
> _______________________________________________
> SunRay-Users mailing list
> SunRay-Users at filibeto.org
> http://www.filibeto.org/mailman/listinfo/sunray-users
> _______________________________________________
> SunRay-Users mailing list
> SunRay-Users at filibeto.org
> http://www.filibeto.org/mailman/listinfo/sunray-users
>   



More information about the SunRay-Users mailing list