[SunRay-Users] Problems with sound since Nevada build 118

Bob Doolittle Robert.Doolittle at Sun.COM
Thu Oct 15 15:14:07 EEST 2009


Ivar,

I've subsequently discovered that you've been using 
http://defect.opensolaris.org/bz/show_bug.cgi?id=10036 to track this 
issue, so we seem to have split the conversation into two threads.

Since I'm not the person working on this bug I suggest we keep 
discussion within the bug for the benefit of whomever is pursuing it. 
Please update the bug with this information.

Thanks,
   Bob

Ivar Janmaat wrote:
> Hello Bob,
>
> If I start a session:
> - AUDIODEV and UTAUDIODEV are not set.
> - The audio deamon is not running
> The result is that I can not play audio on my Sun Ray.
>
> When I set AUDIODEV with a shell command:
> $ AUDIODEV= `/opt/SUNWut/bin/utaudio`
> The following line is printed:
> SO_KEEPALIVE: option not supported by protocol
> And a blank line is printed.
> I have to press Enter or ^C to get back to the command prompt.
> In both cases the AUDIODEV is set correctly.
>
> If I also set UTAUDIODEV and export them I can play audio on the Sun 
> Ray with:
> gst-launch filesrc location x.wav ! wavparse ! sunaudiosink
> All the gstreamer apps and realplayer still complain that the can not 
> access the audio device.
>
> Hope this helps,
>
> Ivar
>
>
> Bob Doolittle wrote:
>
>>
>> /etc/X11/xinit/xinitrc.d/0100.SUNWut.sh should launch utaudio which 
>> should return the value stored in UTAUDIODEV. Files in that directory 
>> are executed by gdm when it executes /etc/X11/gdm/Xsession. We 
>> haven't done a lot of experimenting with SRSS on 124 yet (although 
>> hopefully I will tomorrow if I can get my IPS repository to install 
>> since those testbeds are 124 based) and would appreciate any data you 
>> may gather.
>>
>> -Bob
>>
>
> _______________________________________________
> SunRay-Users mailing list
> SunRay-Users at filibeto.org
> http://www.filibeto.org/mailman/listinfo/sunray-users



More information about the SunRay-Users mailing list