[SunRay-Users] Firefox and Flash on Sunrays

Aaron Wilson aaron at ernieball.com
Thu Oct 8 17:49:58 EEST 2009


I actually just saw some improvement for the first time in years.

Like I said in the past it used to be just videos. It seemed like if I 
went to youtube and played a video, the initial video would hang the 
browser and once it came back subsequent videos would work on youtube.com
If I went to vimeo.com the initially played video would hang the browser 
and subsequent videos on that site would play fine.

Today I just downloaded the latest Firefox 3.53 build for Solaris 10 x86 
and I downloaded the latest flash.
http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.5.3/contrib/

I just extracted the tarball to my desktop and put the flash plugin in 
the plugins folder.
Now it still hangs when I first load a page with flash but now it seems 
subsequent flash pages regardless of domain seem to work fine. Even video!
I went to my company home page that has a small flash animation, which 
did hang the browser for 10 seconds, but then I immediately went to 
youtube and hit play on a video and it immediately started playing. 
Amazing!! I haven't seen that in 3 years :)

Might be to early to call and I should do more testing but initial tests 
show marked improvement.

 That initial flash hang will undoubtedly still confuse my users, but at 
least it doesn't appear to do that on every single page with flash now.

I think maybe I might be motivated to rebuild my servers now to the 
latest Solaris release and SRSS build. Or maybe I'll be patient and wait 
for SRSS 4.2.


I guess next I'll try the actual pkg version of Firefox 3.53 and see how 
that works system wide for my users.


Regards,

Aaron

Lars Tunkrans wrote:
> Hi,
>
>    Which  version of Firefox  is used  ?    the Mozilla guys   fixed a 
> number of  "interesting"  bugs that caused firefox
>      to hang    with  Firefox 2.0.0.18    latest is 2.0.0.20
>
>     I do belive you should upgrade to SRS 4.1 
>    //Lars
>
>
>
> Aaron Wilson skrev:
>> Apparently I'm the only one on the planet that can consistently 
>> recreate this problem and have been able to do so for some years now. 
>> I probably emailed this group 2 years ago with the same problem and I 
>> think I just gave up hoping the problem would get fixed. It has only 
>> gotten worse.
>>
>> We have two offices.
>>
>> In the one office Firefox with recent versions of Flash works fine on 
>> SunRay servers
>> In the other office Firefox with recent versions of Flash works but 
>> with problems on SunRay servers.
>>
>> I used to have the problem where normal flash animations worked. If I 
>> went to Youtube or any other site with flash videos, Firefox would 
>> become unresponsive for anywhere between 30 seconds to 5 minutes. 
>> Generally it lasts for a minute or so. If I didn't have 30 users 
>> telling me about it everytime it happens I could live with it.
>>
>> That was with flash_player_9_solaris_r47_x86 and prior.
>>
>> Now with versions later than flash_player_9_solaris_r47_x86 all flash 
>> animations regardless of how complex they are or whether or not they 
>> have video, make the browser hang.
>>
>> Only difference between the two server setups is the one office has 
>> local access over the LAN to the ldap server, and the other office 
>> with flash problems accesses the ldap server over an MPLS VPN.
>>
>> I think when I last tried to report this I was told ldap couldn't 
>> have any thing to do with this, which leaves SunRay software?
>>
>> I'm in the office with flash sunray problems. In this same office I 
>> have 7 Ultra 20 machines that don't use LDAP for authentication and 
>> obviously don't have any SunRay software installed and they can run 
>> the latest flash_player_10_solaris_r32_18_x86 with no  problems.
>>
>> The affected systems are running Sun Ray Server Software Version 4.0 
>> and Solaris 10 8/07 s10x_u4wos_12b X86.
>>
>> I would rebuild the servers with SRSS 4.1 and Solaris 10 5/09 
>> s10x_u7wos_08 X86 but I've rebuilt my servers twice with previous 
>> latest versions of Solaris and SRSS now. Neither of those rebuilds 
>> made the problem go away.
>>
>> When I last rebuilt my servers I tested Flash before installing SRSS 
>> and LDAP auth and Flash worked fine. So in my mind it's gotta be SRSS 
>> or LDAP or both in tandem. I'm no software engineer though  :)
>>
>>
>>
>> ---
>> Aaron
>>
>>
>>
>> _______________________________________________
>> SunRay-Users mailing list
>> SunRay-Users at filibeto.org
>> http://www.filibeto.org/mailman/listinfo/sunray-users
>>
>
> _______________________________________________
> SunRay-Users mailing list
> SunRay-Users at filibeto.org
> http://www.filibeto.org/mailman/listinfo/sunray-users


More information about the SunRay-Users mailing list