[SunRay-Users] Utconfig -w apache error

Talley, Paul Paul.Talley at tadpole.com
Thu Oct 8 15:49:48 EEST 2009


Also, not sure if it makes a difference but the server was installed with Solaris 10 with the developer install, not full distribution plus oem. 

Sent from Blackberry
------------------------------------------------------------------------------
This email message is for the sole use of the intended recipient(s) and may contain GDC4S confidential or privileged information. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not an intended recipient, please contact the sender by reply email and destroy all copies of the original message.

----- Original Message -----
From: sunray-users-bounces at filibeto.org <sunray-users-bounces at filibeto.org>
To: sunray-users at filibeto.org <sunray-users at filibeto.org>
Sent: Thu Oct 08 05:21:10 2009
Subject: Re: [SunRay-Users] Utconfig -w apache error

.. Ls - la gives rwx to root and r x to all others. Getent passwd utwww get :
Utwww:x:251614:25160:ut admin web server user:/tmp: /bin/sh

Getent group ut admin returns 
Utadmin::25160.

Nsswitch.conf is set up correct for passed and group with files nis.

Sent from Blackberry
------------------------------------------------------------------------------
This email message is for the sole use of the intended recipient(s) and may contain GDC4S confidential or privileged information. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not an intended recipient, please contact the sender by reply email and destroy all copies of the original message.

----- Original Message -----
From: sunray-users-bounces at filibeto.org <sunray-users-bounces at filibeto.org>
To: SunRay-Users mailing list <sunray-users at filibeto.org>
Sent: Thu Oct 08 04:40:51 2009
Subject: Re: [SunRay-Users] Utconfig -w apache error

Talley, Paul schrieb:
> I have installed srss 4.1 on Solaris 10 spare with no problems. When I run utconfig I get the following errors and the web admin gui will not start.
> 
> In /var/opt/SUNWut/log/utwebadmin.log I get this :
> Can not access tomcat runtime environment (bootstrap.jar) at /opt/apach-tomcat/bin.
> 
> This may be due to no permissions to read /opt/apache-tomcat/bin directory as user ut www
> 
> I installed apache from srss/Supplemental exactly as in the instructions with no problems.
> 

So what does ls -la /opt/apache-tomcat/ say?

> The server is running NIS and I could not login as a user created with user add and in /etc/passwd it gave user utwww a userid of 25614 and gid of 25640 not thw usual 100 and 106. 
> 

Can you show us your nsswitch.conf? It should support NIS and local 
files (preferably files before NIS) for passwd and group. If it doesn't, 
you need to add all usually local accounts to your NIS database.

What does 'getent passwd utwww' and 'getent group utadmin' say?

FWIW: That the utwww user and the utadmin group use the next free 
uid/gid that useradd/groupadd provide is a design flaw. You can work 
around this by manually creating the user and group with a chosen 
uid/gid (for utwww you can also use a user name of your choice) before 
running utconfig. This may by unrelated to your current problem, but it 
will prevent problems from collision between the utwww/utadmin users and 
your next NIS additions.

- Jörg
_______________________________________________
SunRay-Users mailing list
SunRay-Users at filibeto.org
http://www.filibeto.org/mailman/listinfo/sunray-users
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/ms-tnef
Size: 3938 bytes
Desc: not available
URL: <http://www.filibeto.org/pipermail/sunray-users/attachments/20091008/f4447771/attachment.bin>


More information about the SunRay-Users mailing list