[SunRay-Users] USB redirection on SRS 5 ea2 not working -- what am I doing wrong?

Isaac Bush isaac at okeeffemuseum.org
Wed Oct 7 18:07:43 EEST 2009


I meant to follow up on this sooner but I've had my hands full with some
other crises (fun fact: do you now how much a Solaris system can do if
SMF pukes itself? Not much... ). So the issue was indeed old firmware.
Initially when people responded to check firmware I thought "old
firmware? _whatever_ ... of course I have the ea2 firmware! ... in fact
let me just hit stop+v here to prove I'm running ea2 before I hit reply
... oh crap!"

I actually had run utfwsync after installation but the sun ray still had
older firmware on it so I guess I did something wrong during
installation. After I enabled the newer firmware with utfwadm USB
redirection started working correctly. So nothing to see here folks,
move along, just a guy not paying attention.

Thanks again for the help everyone,

Isaac


From: sunray-users-bounces at filibeto.org
[mailto:sunray-users-bounces at filibeto.org] On Behalf Of Ashley W
Sent: Thursday, October 01, 2009 8:24 PM
To: sunray-users at filibeto.org
Subject: Re: [SunRay-Users] USB redirection on SRS 5 ea2 not working --
what am I doing wrong?

If you have utUsbPort showing in device manager, USB redirection has
been setup properly. In order for devices to get redirected you need to
be running EA2 firmware.

-a-


> Date: Thu, 1 Oct 2009 12:26:57 -0600
> From: isaac at okeeffemuseum.org
> To: sunray-users at filibeto.org
> Subject: [SunRay-Users] USB redirection on SRS 5 ea2 not working --
what am I doing wrong?
> 
> Hello all,
> 
> I'm trying to get USB redirection going on the ea2 software but it
isn't
> working for some reason. Here's what I've done so far:
> 
> installed a fresh copy of s10u7 in a ESX vm.
> Installed/configured srss4.2 and srwc 2.2
> installed a fresh WinXP VM (standalone; not part of a VDI setup)
> added usb drives to WinXP install and then installed the USB redir
> components.
> I also installed the MMR stuff which is working.
> 
> 
> The XP install shows the utSrSession device under System Devices and
> shows the utUsbPort device under USB controllers and the USB redirect
> icon does show up in the system tray. However when I plug a flash disk
> into the Sun Ray port (a sunray 2 if that matters) then nothing
happens
> even after waiting a long time. I've checked the server logs and I
have
> entries for utstoraged servicing the disk so I believe that the Sun
Ray
> server is seeing the device but that does not seem to be getting
passed
> to the windows vm.
> 
> I'm sure I've missed a step here but I'm not sure what it is... is
there
> a argument that needs to passed to uttsc for instance? I've looked
> around the web gui and read the man page for uttsc but I don't see
> anything to enable USB redirection.
> 
> I'd appreciate any help on this.
> 
> Thanks, Isaac
> 
> Isaac Bush
> Systems Administrator 
> Georgia O'Keeffe Museum
> 217 Johnson Street
> Santa Fe, NM 87501
> 505.946.1067 tel
> 505.946.1092 fax
> 
> _______________________________________________
> SunRay-Users mailing list
> SunRay-Users at filibeto.org
> http://www.filibeto.org/mailman/listinfo/sunray-users
________________________________________
Invite your mail contacts to join your friends list with Windows Live
Spaces. It's easy! Try it!


More information about the SunRay-Users mailing list