[Solaris-Users] pkgadd zone locks in S10

Stoyan Angelov s_angelov at filibeto.org
Thu Apr 6 20:59:24 EET DST 2006


Dan Klinedinst wrote:
> Hello,
> I have a Solaris 10 machine with one non-global zone.  When I try to do
> pkgadd or pkgrm of any package it complains about not being able to do
> it on the non-global zone, and therefore fails for the global zone as well:
> 
> ## Waiting for up to <300> seconds for package administration commands
> to become available (another user is administering packages on zone <xxxx>)
> pkgadd: ERROR: Unable to acquire package administration lock for zone
> <xxxx>; please try again later
> pkgadd: ERROR: Unable to acquire lock on non-global zone <xxxx>:
> releasing all locks
> pkgadd: ERROR: unable to lock zones to perform operations
> 
> I checked to make sure there are no lock files in either /tmp or
> /var/sadm/pkg on both zones.
> 
> I can do a pkgadd with the -G option (global zone only), but I'm trying
> to install a large application from a vendor so it's impractical to
> trace every one of their install scripts and find where it does a
> pkgadd.  Plus there's no -G option to pkgrm so I can never uninstall
> (not even packages that were installed with -G to begin with.)
> 
> We have plenty of S10 machines running non-global zones and this is only
> a problem on this one machine.  Can't find any mention of it on Sun's
> web site or Google.
> 
> Any help would be greatly appreciated.
> 
> Thanks,
> Dan
> _______________________________________________

hello Dan,

i recently had a similar problem with the staroffice update 2 patch. i
was trying to install the patch from a directory deep within my home dir
- i tried then and moved the patch in / (also tried /tmp) and the
installation proceeded successfully. i am not sure what exactly causes
the problem and if this "fix" will work for you too but you can give it
a try. the particular machine was solaris 10 3/05 x86.

greetings,

Stoyan







More information about the Solaris-Users mailing list